INTERMEDIATE
Excel

TeachUcomp, Inc.
...it’s all about you
Welcome to Teachucomp, Inc.’s Intermediate Excel course. This class expands the student’s knowledge of Microsoft Excel, one of the most popular worksheet programs available today. This class is designed to give the student a firm working knowledge of this program.

Excel is an excellent program to learn, as the skills that you learn in Excel apply to many other programs as well, especially Access. It is the recommended starting point for learning database programs.

Excel is a multi-featured worksheet program in which you can create powerful worksheets that can manipulate numbers for you. It is a very powerful program, and has many advanced features that can automate and simplify your work.

This class will focus on giving the student enhanced skills in the Excel program. You will learn how to create and format charts, create 3D Formulas, use Paste Special, link cells for instant updating of data, create tables, and perform many other advanced tasks in Excel.
## Table Of Contents

### Chapters/Lessons: Creating Charts in Excel 2010 & 2007

- **27.1 - Creating Charts** 114
- **27.2 - Selecting Charts and Chart Elements** 114
- **27.3 - Moving and Resizing Charts** 115
- **27.4 - Changing the Chart Type** 115
- **27.5 - Changing the Data Range** 116-117
- **27.6 - Switching Column and Row Data** 117
- **27.7 - Choosing a Chart Layout** 117
- **27.8 - Choosing a Chart Style** 117
- **27.9 - Printing Charts** 118
- **27.10 - Deleting Charts** 118

*Creating Charts in Excel 2010 & 2007- Actions* 119-122

*Creating Charts in Excel 2010 & 2007- Exercises* 123

### Chapters/Lessons: Formatting Charts in Excel 2013

- **28.1 - Formatting Chart Objects** 125
- **28.2 - Inserting Objects into a Chart** 125
- **28.3 - Formatting Axes** 126
- **28.4 - Formatting Axis Titles** 126
- **28.5 - Formatting a Chart Title** 127
- **28.6 - Formatting Data Labels** 127
- **28.7 - Formatting a Data Table** 128
- **28.8 - Formatting Error Bars** 128
- **28.9 - Formatting Gridlines** 129
- **28.10 - Formatting a Legend** 129
- **28.11 - Formatting Drop and High-Low Lines** 129-130
- **28.12 - Formatting Trendlines** 130
- **28.13 - Formatting Up/Down Bars** 130
- **28.14 - Formatting the Chart and Plot Areas** 131
- **28.15 - Naming Charts** 131
- **28.16 - Applying Shape Styles** 131
- **28.17 - Applying WordArt Styles** 132
- **28.18 - Saving Custom Chart Templates** 132

*Formatting Charts in Excel 2013- Actions* 133-141

*Formatting Charts in Excel 2013- Exercises* 142

### Chapters/Lessons: Formatting Charts in Excel 2010 & 2007

- **29.1 - Formatting Chart Objects** 144
- **29.2 - Inserting Objects into a Chart** 144
- **29.3 - Changing Chart Labels** 144-145
- **29.4 - Changing Axes Display** 145
- **29.5 - Changing the Chart Background** 145
- **29.6 - Applying Chart Analysis Lines** 146
- **29.7 - Naming Charts** 146
- **29.8 - Applying Shape Styles to Chart Elements** 146-147
- **29.9 - Applying WordArt Styles to Chart Elements** 147
- **29.10 - Saving Custom Chart Templates** 147

*Formatting Charts in Excel 2010 & 2007- Actions* 148-152

*Formatting Charts in Excel 2010 & 2007- Exercises* 153

### Excel Keyboard Shortcuts

154-157

©TeachUcomp, Inc. Intermediate Excel
CHAPTER 12
3D FORMULAS

12.1- Creating 3D Formulas

12.2- 3D Formula Syntax

12.3- Creating 3D Range References
12.1- Creating 3D Formulas:

It is helpful to be able to create a single formula that calculates data gathered from multiple worksheets. These types of formulas are called 3D formulas. They calculate information from multiple worksheets and show the result in a selected formula cell.

When you use 3D formulas, you must also expand your knowledge of formula syntax. You will be using additional punctuation marks when you write these formulas to tell Excel specifically which cells from which worksheet you will be using. The additional punctuation marks you will need to know are:

1. `!` - used to separate the sheet name from the cell reference.
2. `$` - used to denote an absolute value.
3. `:` - used to separate sheet names in ranged 3D formulas.
4. `,` - used to separate individual sheet/cell references from each other.

12.2- 3D Formula Syntax:

The best way to learn how a 3D formula works is to look at some examples. Here are three examples of 3D formulas. The first is a simple 3D formula, the latter two are ranged 3D formulas:

2. `=SUM(Sheet1:Sheet3!B2)`
   Or
3. `=SUM(Sheet1!B2,Sheet2!B2,Sheet3!B2)`

All three of these formulas will display the same answer. You can use any syntax that you like. The change in the syntax from what you previously learned is that now you are inserting the name of the particular worksheet in the workbook, followed by an exclamation point, and then the cell reference.

12.3- Creating 3D Range References:

In example #2 above, you can see a 3D cell range reference used to create a formula. A 3D cell range is one cell range that spans several sheets deep. In example #2, the range is cell B2, but it is cell B2 in all of the worksheets from "Sheet1" through "Sheet3."

When referencing 3D ranges in formulas, you use the colon (:) to separate the names of the first and last sheets in the range, followed by a single cell range reference. The cell reference given is then used as the selected cell range through all of the worksheets listed. So in the above example, you are adding cell B2 from Sheet1, Sheet2 and Sheet3.

In 3D ranges, the given cell range cannot change from one sheet to another. Otherwise it is just another 3D formula, and you should use one of the other two alternate syntaxes available.
ACTIONS
3D Formulas

ADDITIONAL PUNCTUATION USED IN 3D FORMULAS:

! used to separate the sheet name from the cell references.
$ used to denote an absolute value.
: used to separate sheet names in ranged 3D formulas.
, used to separate individual sheet/cell references from each other.

CREATING A SIMPLE 3D FORMULA:

1. Select the cell into which you want to enter the 3D formula, and type an equal sign to begin. (=)
2. Type the name of the worksheet (found on the worksheet tab) of the first page from which you want to select a cell range, followed by an exclamation point (!).
3. Enter the cell range address from the sheet that you want to enter into the formula, followed by the mathematical operator you need.
4. Select the next sheet from which you want to select a cell range, followed by an exclamation point (!).
5. Enter the cell range address from this sheet that you want to enter into the formula, followed by the mathematical operator you need.
6. Repeat steps 5 and 6 until you have entered all of the cell ranges from all of the worksheets that you want to use in the 3D formula.
7. Press “Enter” on your keyboard to finish the formula.

CREATING A RANGED 3D FORMULA:

1. Select the cell where you want to enter your ranged 3D formula. Then type an equal sign (=), followed by the function name that you want to use, then followed by an open parenthesis [()].
2. Type the name of the sheet (found on the worksheet tab) that contains the cell range that you want to include in the function, followed by an exclamation point (!).
3. Enter the cell range to select from the sheet (separated by a colon [:], if it is a cell range), and then followed by a comma (,) to separate this sheet/cell reference from the next sheet/cell reference.
4. Repeat steps 3 and 4 for the other sheet/cell references needed for your ranged 3D formula. Do not enter a comma (,) after the last sheet/cell reference, but instead close the ranged 3D formula with the closed parenthesis [)].
5. Press “Enter” on your keyboard to finish the formula.

CREATING A 3D-RANGE FORMULA:

1. Select the cell into which you want to enter the 3D formula.
2. Type an equal sign to begin the formula, followed by the function name that you want to calculate a 3D cell range for, and an open parenthesis [()].
3. Type in the name of the worksheet (found on the worksheet tab) of the first page, a colon (:), and then the last work sheet name followed by an exclamation point (!).
4. Enter a cell range reference for the selected sheets into the formula.
5. Type a closed parenthesis [)].
6. Press “Enter” on your keyboard.
EXERCISES - 3D Formulas

**Purpose:**

1. To be able to create 3D formulas in a worksheet.

**Exercises:**

1. Open your Excel application.
2. Create a new blank workbook in Excel
3. Select “Sheet1.”
4. Type “Region:” into cell A2.
5. Type “Q1 Sales:” into cell B2.
6. Type “North” into cell A3.
7. Type the number 100000 into cell B3.
8. Type “East” into cell A4.
9. Type the number 125000 into cell B4.
10. Type “South” into cell A5.
11. Type the number 200000 into cell B5.
12. Type “West” into cell A6.
13. Type the number 175000 into cell B6.
14. Select the range of cells from A2 through B6.
15. Click the drop-down arrow on the “Borders” button within the “Font” button group on the “Home” tab in the Ribbon and then select the “all Borders” choice from the drop-down menu.
16. Select the range of cells from B3 through B6.
17. Click the “Number Format” drop-down menu within the “Number” button group on the “Home” tab in the Ribbon and then select “Currency” from the drop-down menu.
18. If using Excel 2013, click the “New Sheet” button to the right of the “Sheet1” worksheet tab to insert a new worksheet named “Sheet2.”
19. If using Excel 2013, ensure that “Sheet2” is selected and then click the “New Sheet” button to the right of the “Sheet2” worksheet tab to insert a new worksheet named “Sheet3.”
20. If using Excel 2013, select “Sheet1” worksheet tab within the workbook.
21. Copy the range of A2:B6, and paste it to the same range of cells in “Sheet2.”
22. On “Sheet2,” edit the contents of cell B2 to read “Q2 Sales:.”
23. Click the “Sheet3” worksheet tab.
24. Click into cell A1, and type “Total Sales:.”
25. In cell A2, type “=SUM(Sheet1:Sheet2!B3:B6).”
26. Exit the cell to finish the formula.
27. For your version of Excel, use the “Save As” dialog box to save the file to the “Documents” folder on your computer and name the file “Inter-Sample.”
28. When you are finished saving the file, you may close it.
<table>
<thead>
<tr>
<th>Section</th>
<th>Title</th>
</tr>
</thead>
<tbody>
<tr>
<td>13.1</td>
<td>Naming Ranges</td>
</tr>
<tr>
<td>13.2</td>
<td>Creating Names from Headings</td>
</tr>
<tr>
<td>13.3</td>
<td>Moving to a Named Range</td>
</tr>
<tr>
<td>13.4</td>
<td>Using Named Ranges in Formulas</td>
</tr>
<tr>
<td>13.5</td>
<td>Naming 3D Ranges</td>
</tr>
<tr>
<td>13.6</td>
<td>Deleting Named Ranges</td>
</tr>
</tbody>
</table>
13.1- Naming Ranges:

Instead of always having to type a cell range into formulas you can use range names, but only if you first name a particular range of cells. This can be helpful if you have a worksheet that contains data of the same type in the same place. For instance, if the cell range F2:F10 always contained totals of the regional sales for your company, you could select that range and name it “regional_sales”. Then you can move quickly to that named range, or use it as a substitute for cell range references in ranged formulas.

To name a range, first select the cell range that you want to name. Then click into the “Name Box” in the formula bar. Type the name for the range, and then press the “Enter” key on your keyboard to set the range name. Remember that there are no spaces allowed in range names, so use the underscore character instead (_), if needed. Also, range names must be unique within their defined scope- which is typically the whole workbook, by default. Once you have created the named range, then any time in the future when you select that specific cell range, the range name will appear in the name box within the formula bar.

Alternatively, you can create a named range by first selecting the cell range that you want to name, and then clicking the “Define Name” button in the “Defined Names” group on the “Formulas” tab in the Ribbon. Doing this will open the “New Name” dialog box, where you can define the named range that you selected. You enter the range name into the “Name:” text box. A neat feature of this method is that you can then use the “Scope:” drop-down to select where you want the definition of the named range to function. When you use the name box to create a named range, it defines it with a default “workbook” scope. You can limit this scope by selecting a single worksheet from this drop-down, if desired. You can then enter a comment, if desired, into the “Comment:” text box. Next, assuming that you selected your cell range first, you should see the cell reference shown in the “Refers to:” text box. You can, however, change this reference if necessary. Once you have the correct information entered, click the “OK” button to create the named range.

It is also extremely important to note that when you create named ranges, you are making a specific reference to particular cells on a particular sheet. The reference that is created when you make a named range is an absolute reference, meaning that you cannot copy and paste a formula that contains a range name and expect it to adjust to its new location. Instead, the formula will always refer back to its original cells (the ones defined by the range name) no matter where you copy or paste the formula in the workbook.

13.2- Creating Names from Headings:

You can use the column and row headings in a table or list within a worksheet to name a range of cells. If you use this method of creating named ranges, then start by selecting the cell range- including any titles that you want to use as the names for the ranges that will be created. Next, click the “Create from Selection” button in the “Defined Names” group on the “Formulas” tab in the Ribbon. In the “Create Names from Selection” dialog box that appears, check the checkboxes that indicate where in your selection the range names are located. Usually, this dialog box will not need to be changed, as it looks for text values at the perimeter of your selection from which it can create range names. When the correct location of the cells that you want to use for the named ranges is checked in the “Create Names from Selection” dialog box, finish the process by clicking the “OK” button to create them.
13.3- Moving to a Named Range:

A quick way to select the cells in any named ranges that you have in your workbook is to move to the named range. Once you have named ranges in your workbook, they are contained in the drop-down list that appears when you click the “Name Box” drop-down within the Formula Bar.

Click the drop-down arrow next to the “Name Box” to view the available ranges and select the name of the range that you want to select from the list. The range will appear selected in the worksheet and the name will appear in the “Name Box” in the formula bar.

13.4- Using Named Ranges in Formulas:

You can use named ranges instead of cell range addresses in formulas. One way to do this is to simply type the named range instead of the specific cell range when creating the formulas by hand. Another way to use named ranges in formulas is to begin creating the formula using whichever method that you prefer. When you need to insert the reference to the named range, just click the “Use in Formula” drop-down button in the “Defined Names” group on the “Formulas” tab in the Ribbon. Just select the name of the range that you want to use in the formula to insert it. Then finish your formula as you normally would.

You can also change your existing formulas by inserting the named ranges into the formulas that already exist in your worksheet. To do this, first create the named range that is an exact substitute for a pre-existing cell range reference in one of your formulas. Then select the formula cell that contains the cell range reference that you want to replace with a named range. Next, click the “Define Name” drop-down button in the “Defined Names” group on the “Formulas” tab in the Ribbon. Select the “Apply Names…” command from that button’s drop-down menu of choices to open the “Apply Names” dialog box. In this dialog box, click on the name or names of the named ranges shown to substitute the named ranges. Often, this is already done when you open the “Apply Names” dialog box. Once you have selected the correct named range to use for the substitution, click the “OK” button to apply them.

13.5- Naming 3D Ranges:

You can also give names to 3D ranges. As we learned in the previous chapter, a 3D range is one cell range that spans through multiple worksheets. As long as the cell range reference is the same for all of the different worksheets in the group that you select, you can give it a name. Then it, too, can be used in your formulas in place of the typical 3D cell range references.

To do this, click the “Define Name” button in the “Defined Names” group on the “Formulas” tab in the Ribbon. That will open the “New Name” dialog box. In the “Name:” text box, enter the name that you want to give to your 3D range. Remember that there are no spaces allowed in range names. Ensure that the “Scope:” drop-down is set to “workbook.”

Next, in the “Refers to:” text box, click the “Collapse Dialog” button at the right end of the text box. Click the sheet name tab of the first sheet in the 3D cell range. Hold down the “Shift” key on your keyboard and then click the sheet name tab of the last worksheet that you want to include in the 3D range.

Once the worksheet group has been selected, click and drag over the cells in the worksheet that you want to use as the cell reference for the 3D range. Next, click the “Expand Dialog” button at the right end of the “Refers To:” text box again to expand the dialog box. In the “New Name” dialog box, click the “OK” button when you are finished to create the 3D named range.

Note that you will not be able to select this range name from the “Name Box.” Remember that when you select a range name from the “Name Box,” it highlights the cells in the selected range. It would be...
13.5- Naming 3D Ranges (cont'd.):

impossible to show all of the cells from the multiple sheets in a single window so you cannot access it through the “Name Box.” You may, however, use it as a substitute for 3D range references in your 3D formulas.

13.6- Deleting Named Ranges:

If you no longer require a named range that you have created, you can delete it from the list of named ranges in the workbook. To see the list of named ranges that are available, click the “Name Manager” button in the “Defined Names” group on the “Formulas” tab in the Ribbon. Select the named range that you want to delete from the list of named ranges shown in the dialog box. Next, click the “Delete” button to delete the named range. Click “OK” in the confirmation message box that appears to finish deleting the selected range name. You can then click the “Close” button in the “Name Manager” dialog box.
NAMING RANGES:

1. Select the cell range that you want to name.
2. Click into the “Name Box” in the formula bar and type the name for the range.
3. Press the “Enter” key on your keyboard to set the range name.

OR

1. Select the cell range that you want to name, and then click the “Define Name” button in the “Defined Names” group on the “Formulas” tab in the Ribbon.
2. In the “New Name” dialog box, enter a range name into the “Name:” text box.
3. Then use the “Scope:” drop-down to select where you want the definition of the named range to function. When you use the name box to create a named range, it defines it with a default “workbook” scope. You can limit this scope by selecting a single worksheet from this drop-down, if desired.
4. You can then enter a comment, if desired, into the “Comment:” text box.
5. Next, assuming that you selected you cell range first, you should see the cell reference shown in the “Refers to:” text box. You can, however, change this reference if necessary.
6. Once you have the correct information entered, click the “OK” button to create the named range.

CREATING RANGE NAMES FROM HEADINGS:

1. Select the cell range- including any titles that you want to use as the names for the ranges that will be created.
2. Next, click the “Create from Selection” button in the “Defined Names” group on the “Formulas” tab in the Ribbon.
3. In the “Create Names from Selection” dialog box that appears, check the checkboxes that indicate where in your selection the range names are located. Usually, this dialog box will not need to be changed, as it looks for text values at the perimeter of your selection from which it can create range names.
4. When the correct location of the cells that you want to use for the named ranges is checked in the “Create Names from Selection” dialog box, finish the process by clicking the “OK” button to create the named range.

MOVING TO A NAMED RANGE:

1. Click the drop-down arrow next to the “Name Box” in the Formula Bar to view the available ranges.
2. Select the name of the range to which you want to move from the list shown.
3. The range will appear selected in the worksheet, and the name will appear in the “Name Box” in the formula bar.
USING NAMED RANGES IN FORMULAS:

1. Type the named range, instead of the specific cell range, when creating the formulas by hand.

2. Start by creating the formula using whichever method that you prefer.

3. When you need to insert the reference to the named range into your formula, just click the “Use in Formula” drop-down button in the “Defined Names” group on the “Formulas” tab in the Ribbon.

4. Select the name of the range that you want to use in the formula to insert it.

5. Then finish your formula as you normally would.

OR

1. You can also change your existing formulas, inserting the named ranges into the formulas that already exist in your worksheet. To do this, first create the named range that is an exact substitute for a pre-existing cell range reference in one of your formulas.

2. Select the formula cell that contains the cell range reference that you want to replace with a named range.

3. Click the “Define Name” drop-down button in the “Defined Names” group on the “Formulas” tab in the Ribbon. Select the “Apply Names…” command from that button’s drop-down menu of choices to open the “Apply Names” dialog box.

4. In this dialog box, click on the name or names of the named ranges shown to substitute the named ranges. Often, this is already done when you open the “Apply Names” dialog box.

5. Once you have selected the correct named range to use for the substitution, click the “OK” button to apply them.

NAMING 3D RANGES:

1. Click the “Define Name” button in the “Defined Names” group on the “Formulas” tab in the Ribbon.

2. In the “New Name” dialog box, click into the “Name:” text box and enter the name that you want to give to your 3D range.

3. Ensure that the “Scope:” drop-down is set to “workbook.”

4. Next, in the “Refers to:” text box, click the “Collapse Dialog” button at the right end of the text box.

5. Click the sheet name tab of the first sheet in the 3D cell range. Hold down the “Shift” key on your keyboard, and then click the sheet name tab of the last worksheet that you want to include in the 3D range. Once the worksheet group has been selected, you next click and drag over the cells in the worksheet that you want to use as the cell reference for the 3D range.

6. Next, click the “Expand Dialog” button at the right end of the “Refers To:” text box again to expand the dialog box. In the “New Name” dialog box, click the “OK” button when you are finished to create the 3D named range.
DELETING NAMED RANGES:

1. If you no longer require a named range that you have created, you can delete it from the list of named ranges in the workbook.
2. To see the list of named ranges that are available, click the “Name Manager” button in the “Defined Names” group on the “Formulas” tab in the Ribbon.
3. Select the named range that you want to delete from the list of named ranges shown in the dialog box.
4. Next, click the “Delete” button to delete the named range.
5. Click “OK” in the confirmation message box that appears to finish deleting the selected range name.
6. You can then click the “Close” button in the “Name Manager” dialog box.
EXERCISES-
Named Ranges

Purpose:
1. To be able to create named ranges and use them in formulas.

Exercises:
1. Open up the “Inter- Sample” workbook in your “Documents” folder that has been completed through the Exercise at the end of the previous chapter.
2. Select “Sheet1” within the “Inter- Sample” workbook.
3. Click the “Define Name” button in the “Defined Names” group on the “Formulas” tab in the Ribbon. This will open the “New Name” dialog box.
4. Enter “SalesRange” into the “Name:” text box.
5. Select “Workbook” from the “Scope:” drop-down.
6. Click the “Expand/Collapse Dialog Box” button at the right end of the “Refers to:” box to collapse the dialog box.
7. Hold down the “Shift” key on your keyboard, and then click the worksheet tab for “Sheet2.”
8. Select the range of cells from B3:B6.
9. Click the “Expand/Collapse Dialog Box” button at the right end of the “Refers to:” box to expand the dialog box. The range reference shown in the “Refers to:” text box should read: 
   “=Sheet1:Sheet2!$B$3:$B$6.”
10. Click the “OK” button in the “New Name” dialog box.
11. Select “Sheet3.”
12. Select cell A2 in “Sheet3.”
13. Click and drag over the cell range reference of “Sheet1:Sheet2!B3:B6” shown in the Formula Bar to select the text.
14. Click the “Use in Formula” button in the “Defined Name” group on the “Formulas” tab in the Ribbon. Select “SalesRange” from the drop-down menu. That should paste the name into the formula shown in the Formula Bar.
15. Press the “Enter” key on your keyboard to set the formula.
16. Click the “Save” button in the Quick Access Toolbar to save your changes.
17. You can then close the workbook.
CHAPTER 14 -
CONDITIONAL FORMATTING AND CELL STYLES

14.1 - CONDITIONAL FORMATTING
14.2 - FINDING CELLS WITH CONDITIONAL FORMATTING
14.3 - CLEARING CONDITIONAL FORMATTING
14.4 - USING TABLE AND CELL STYLES
14.1- Conditional Formatting:

With conditional formatting, you set criteria for cells that change the appearance of the cell depending on whether or not the cell’s value meets the criteria specified. For example, if you wanted to have a worksheet cell appear with a red fill color only if it contained a negative number, you could do that with conditional formatting. Conditional formatting can be applied to all cells, but can be especially helpful in formula cells as a way to visually indicate the cell’s value- which may change when data entry occurs.

You can make use of several of the preset conditional formats that are provided in Excel, or you can create your own rules and formatting to apply. To apply conditional formatting, first select the cells in the worksheet to which you wish to apply conditional formatting. Then click the “Conditional Formatting” button in the “Styles” group on the “Home” tab in the Ribbon.

If you want to apply one of the default formats using the values from your cell selections as the upper and lower bounds, then simply roll down to the conditional formatting style that you wish to use in the second section of the drop-down menu that appears. From the side menu that appears, you can then choose which of the specific variations of the style you wish to apply. Just click the style that you want to apply it to the selection.

You can also create your own custom rules, and then decide what type of formatting to apply when a selected cell meets the criteria that you have specified. To do this, you can select one of the rule choices shown in the first section of the drop-down menu: “Highlight Cell Rules” or “Top/Bottom Rules.” From the side menu, you then select the type of values that you want to highlight. This will open a dialog box where you enter the criteria, which when met, will apply the formatting that you then choose.

Note that you can create multiple rules for selected cells. However, if you wish to do this, then you may want to begin by selecting the cells to which you want to apply multiple rules, first. Then you can click the “Conditional Formatting” button in the “Styles” group on the “Home” tab in the Ribbon. From the drop-down menu that appears, you can then choose the “Manage Rules…” command to open the “Conditional Formatting Rules Manager” dialog box. Assuming that you want to only view rules for the selected cells, then choose the “Current Selection” choice from the “Show formatting rules for:” drop-down at the top of this dialog box. Otherwise, you can choose a whole worksheet, or even the entire workbook, from this drop-down. Any rules for the selection made from this drop-down are then listed in the rules area below that. If there are no rules created yet, then this area will not show anything.

To create a new rule for the selected area, click the “New Rule…” button at the top of the “Conditional Formatting Rules Manager” dialog box. In the “New Formatting Rule” dialog box, select what type of rule to create by choosing a rule type from the types shown in the “Select a Rule Type:” list. Then enter the evaluation criteria into the area at the bottom of this window. Once you have finished setting the formatting that you want to use, click the “OK” button to return to the “Conditional Formatting Rules Manager” dialog box.

If you want to add other rules to the selection, just repeat the process. New rules will be added to the list shown. Note that if you have multiple rules applied, they will be enforced in the order shown, from top to bottom, within this dialog box. Note that for any rule, you can check the “Stop If True” checkbox at the right end of the rule to end the sequence of rule processing if the cell value meets the criteria specified by the selected rule.

You can edit a rule that has been applied by selecting the rule to modify from the list, and then clicking the “Edit Rule…” button at the top of the “Conditional Formatting Rules Manager” dialog box. This will re-open the rule in the “Edit Formatting Rule” window, where you can change the criteria or formatting.

If you want to delete a rule from the list shown in the “Conditional Formatting Rules Manager” dialog box, start by clicking on the rule that you wish to remove. Then click the “Delete Rule” button at the top of the “Conditional Formatting Rules Manager” dialog box.
14.1- Conditional Formatting (cont’d.):

Note that you can also alter the order in which the rules are enforced in this dialog box. To change the order of the rules, click on the rule whose order you wish to change, and then click either the “Move Up” or “Move Down” buttons to change the order in which the rule will be enforced. Remember that the rules are enforced from top to bottom in this list.

Once you have finished creating your rules, you can click the “OK” button to apply the conditional formatting rules to your selection and close the “Conditional Formatting Rules Manager” dialog box.

14.2- Finding Cells with Conditional Formatting:

Often, if a cell that has a conditional formatting rule applied doesn’t meet the criteria specified, the cell will not appear to be any different from any other cell. This can be a problem when trying to edit or modify conditional formatting for selected cells. If you want to find the cells that contain conditional formatting within your worksheet or workbook, Excel makes it easy to do so. First, click into a cell that doesn’t contain conditional formatting within your worksheet. Then click the “Find & Select” button in the “Editing” group on the “Home” tab in the Ribbon. From the drop-down that appears, select “Conditional Formatting” to move the active cell to the first cell that it encounters that contains conditional formatting.

14.3- Clearing Conditional Formatting:

You can easily clear all conditional formatting from selected cells, or from the entire worksheet. If you want to only remove conditional formatting from selected cells, then you will first need to select those cells in your worksheet. Then click the “Conditional Formatting” button in the “Styles” group on the “Home” tab in the Ribbon. Roll your mouse pointer down to the “Clear Rules” command in the drop-down menu that appears. From the side menu that appears, you can select from which object you wish to remove the conditional formatting. If you want to remove the conditional formatting from only the selected cells, then choose the “Clear Rule from Selected Cells” command. To clear all conditional formatting from the entire sheet, select the “Clear Rule from Entire Sheet” command.

14.4- Using Table and Cell Styles:

You can apply predefined formatting to tables, or selected cells, within your worksheets. This can quickly and easily improve the appearance and functionality of your worksheet data. You can use the “Format as Table” function to quickly format selected cells and also convert them into a table. You can also apply this to any existing tables that you have created in your worksheet. If you simply want to apply formatting without converting the selected cells into a table, then use the “Cell styles” command, instead.

To do either task, first select the cells to which you want to apply a predesigned format. Then click either the “Format as Table” or “Cell styles” drop-down buttons in the “Styles” group on the “Home” tab in the Ribbon, depending upon which type of formatting you want to apply. From the drop-down menus that appear, select the appearance to apply to the selected cells or cell in your worksheet.

If you select the “Format as Table” button, then after you have selected your desired style, you will see the “Format As Table” dialog box appear. This will convert the selected cells into a table. If your selected table has headers (meaning selected cells that contains labels at the top of columns) then check the “My table has headers” checkbox. Then just click the “OK” button to apply the selected formatting to the cells and simultaneously convert them into a table.
APPLYING CONDITIONAL FORMATTING:

1. Select the cells in the worksheet to which you wish to apply conditional formatting.
2. Click the “Conditional Formatting” button in the “Styles” group on the “Home” tab in the Ribbon.
3. To apply one of the default conditional formats using the values from your cell selections as the upper and lower bounds, roll down to the conditional formatting style you wish to apply, located in the second section of the drop-down menu.
4. From the side menu that appears, click a choice shown to choose the specific variation to apply.
5. To create your own custom rules and decide the formatting to apply when a selected cell meets the criteria you specify, select one of the rule choices shown in the first section of the drop-down menu: “Highlight Cell Rules” or “Top/Bottom Rules.”
6. From the side menu, select the type of values to highlight.
7. This will open a dialog box where you enter the criteria, which when met, will apply the formatting that you then choose.
8. To create multiple rules for selected cells, begin by selecting the cells to which you want to apply multiple rules, first.
9. Then click the “Conditional Formatting” button in the “Styles” group on the “Home” tab in the Ribbon.
10. From the drop-down menu that appears, choose the “Manage Rules…” command to open the “Conditional Formatting Rules Manager” dialog box.
11. To only view rules for the selected cells, choose the “Current Selection” choice from the “Show formatting rules for:” drop-down at the top of this dialog box. Otherwise, you can choose a whole worksheet, or even the entire workbook, from this drop-down. Any rules for the selection made are listed in the rules area below. If there are no rules created, this area will not show anything.
12. To create a new rule for the selected area, click the “New Rule…” button at the top of the “Conditional Formatting Rules Manager” dialog box.
13. In the “New Formatting Rule” dialog box, select what type of rule to create by choosing a rule type from the types shown in the “Select a Rule Type” list.
14. Enter the evaluation criteria into the area at the bottom of this window.
15. Once you have finished setting the formatting to use, click the “OK” button to return to “Conditional Formatting Rules Manager” dialog box.
16. To add other rules to the selection, repeat steps 12-15 above. New rules will be added to the list shown. If you have multiple rules applied, they will be enforced in the order shown, from top to bottom, within this dialog box.
17. Note that for any rule, you can check the “Stop If True” checkbox at the right end of the rule to end the sequence of rule processing if the cell value meets the criteria specified by the selected rule.
18. You can edit a rule by selecting the rule to modify from the list, and then clicking the “Edit Rule…” button at the top of the “Conditional Formatting Rules Manager” dialog box. This will re-open the rule in the “Edit Formatting Rule” window, where you can change the criteria or formatting.
19. To delete a rule from the list shown in the “Conditional Formatting Rules Manager” dialog box, start by clicking on the rule to remove. Then click the “Delete Rule” button at the top of the “Conditional Formatting Rules Manager” dialog box.
20. You can alter the order in which the rules are enforced in this dialog box. To change the order of the rules, click on the rule whose order you wish to change, and then click either the “Move Up” or “Move Down” buttons to change the order in which the rule will be enforced. Remember that the rules are enforced from top to bottom in this list.
21. Once you have finished creating your rules, click the “OK” button to apply the conditional formatting rules to your selection and close the “Conditional Formatting Rules Manager” dialog box.
ACTIONS-
Conditional Formatting and Cell Styles

FINDING CONDITIONAL FORMATTING:

1. First, click into a cell that doesn’t contain conditional formatting within your worksheet.
2. Then click the “Find & Select” button in the “Editing” group on the “Home” tab in the Ribbon.
3. From the drop-down that appears, select “Conditional Formatting” to move the active cell to the first cell that it encounters that contains conditional formatting.

CLEARING CONDITIONAL FORMATTING:

1. You can easily clear all conditional formatting from selected cells, or from the entire worksheet. If you want to only remove conditional formatting from selected cells, then you will first need to select those cells in your worksheet.
2. Click the “Conditional Formatting” button in the “Styles” group on the “Home” tab in the Ribbon. Roll your mouse pointer down to the “Clear Rules” command in the drop-down menu that appears. From the side menu that appears, you can select from which object you wish to remove the conditional formatting.
3. If you want to remove the conditional formatting from only the selected cells, then choose the “Clear Rule from Selected Cells” command.
4. To clear all conditional formatting from the entire sheet, select the “Clear Rule from Entire Sheet” command.

AUTOMATICALLY FORMATTING A TABLE OR SELECTED CELLS:

1. First select the cells to which you want to apply a predesigned format. Then click either the “Format as Table” or “Cell styles” drop-down buttons in the “Styles” group on the “Home” tab in the Ribbon, depending upon which type of formatting you want to apply. From the drop-down menus that appear, select the appearance to apply to the selected cells or cell in your worksheet.
2. If you select the “Format as Table” button, then after you have selected your desired style, you will see the “Format As Table” dialog box appear. If your selected table has headers then check the “My table has headers” checkbox. Then just click the “OK” button to apply the selected formatting to the cells and convert them into a table.
Purpose:

1. To be able to apply and remove conditional formatting.

Exercises:

1. Open up the “Inter- Sample” workbook in your “Documents” folder that has been completed through the Exercise at the end of the previous chapter.
2. Select “Sheet1.”
3. Select the cell range of B3:B6.
4. Click the “Conditional Formatting” button in the “Styles” group on the “Home” tab in the Ribbon.
5. Roll your mouse pointer down to the “Color Scales” command.
6. Choose the “Green-Yellow-Red Color Scale” choice (should be the choice in the upper-left corner) from the side menu to shade the results by the default upper and lower values.
7. If necessary, select cell range B3:B6 again.
8. Click the “Conditional Formatting” button in the “Styles” group on the “Home” tab in the Ribbon.
9. Roll your mouse pointer down to the “Clear Rules” command.
10. Choose the “Clear Rules from Selected Cells” command from the side menu to remove the conditional formatting from the selected cells.
11. Click the “Save” button in the Quick Access Toolbar to save your changes.
12. You can then close the workbook.
CHAPTER 15 - Paste Special

15.1 - Using Paste Special

15.2 - Pasting Linked Formulas
15.1- Using Paste Special:

Paste Special is a tool that Excel provides to you that allows you to cut or copy information, and then paste only certain elements of the original selection to a new location. For example, you could copy a cell and then select to paste its value, or format only. You can also copy and paste values from cells and perform mathematical operations as you paste the values to new cell locations: adding, subtracting, or multiplying them with the value(s) that already existed in the destination cell(s).

By default in Excel, information is exclusive to individual worksheets. This means that if you copy data from one worksheet and paste it to another worksheet, any changes that you make to the original data will not be automatically reflected in the worksheet to which you had pasted a copy of the data. Paste Special fixes this by allowing you to paste a link between the two cells so that when the original data is changed in the original worksheet, the new value will be passed to the linked cell in the second worksheet the next time it is opened. Using this feature also allows you to paste linked data cells between two completely separate workbooks.

To use the Paste Special function, you begin by copying a cell as usual. Then select the destination cell. Now, however, instead of directly clicking the “Paste” button, you will click the “Paste” button’s drop-down arrow. At the top of the drop-down menu that appears, you can see different options that you have for selecting what elements of the copied element you want to paste to the new location. You could also just click the “Paste Special…” command at the bottom of the drop-down menu to launch the “Paste Special” dialog box.

In the “Paste Special” dialog box you select the option button that represents what aspect of the copied element you wish to paste in the “Paste” section at the top of this dialog box. Note that if you select the “Values” option, you can then also choose a mathematical operation from the “Operation” section to perform between the value that you are pasting, and the value that currently exists in the cell to which you are pasting. Once you have made your selections, click the “OK” button to paste your special content.

When you invoke the “Paste Special” dialog box, you have several options as to what elements of the copied cells you wish to paste. Let’s take a moment to examine what options are available when using the “Paste Special” dialog box.

In the “Paste” section at the top of the dialog box you can select “All” to paste everything that you copied. This is the same thing as simply choosing “Paste” from the “Paste” button’s drop-down menu. You can select “Formulas” to paste the formula only. This is also the default behavior of a formula when you normally copy and paste, so it is also rare to choose this option. Selecting “Values” copies the current values displayed in the cell or cells that you copied. This is useful for copying and pasting the displayed values from formula cells. Also, you sometimes want to paste the value of one cell that you have copied onto the value displayed in another cell, performing a selected mathematical operation between the two values. If you select the “Values” option and select a destination cell into which to paste the copied value that has a pre-existing value in it, you can then select a mathematical operation to perform with the two values in the “Operation” section. You can choose “None” to overwrite the destination cell’s value with the copied value. You can also select “Add,”
15.1- Using Paste Special (cont’d.):

“Subtract,” “Multiply,” or “Divide” to perform those calculations on the two values, as well.

Back in the “Paste” section at the top, you can also select to paste the “Formats” of the copied cells. This pastes only the formatting of the copied cells and will perform the same function that the “Format Painter” button performs. You can select “Comments” to copy cell comments from one cell to a new cell. You can select “Validation” to copy the cell validation rules from one cell to another cell.

You can select “All using Source theme” to paste all of the cell contents in the document theme formatting that is applied to the copied cells. If you select “All except borders,” you will paste all of the copied cell contents and formatting, except for the borders. If you select “Column Widths,” you will paste the copied cell’s column width onto the selected cell’s column. You can also select “Formulas and number formats” to paste only the cell formulas and the number formatting. You can also select “Values and number formats” to paste only the cell values and the number formatting to the destination cells. Starting in Excel 2010, you can select “All merging conditional formats” to copy conditional formatting and merge it with existing conditional formatting in the destination cell or cells.

You can check the “Skip Blanks” checkbox to not replace cell data in the destination cells where there were blank values in the copied cells. Checking the “Transpose” checkbox will switch the data in the columns to data that will now display across the rows, and vice versa. Once again, after selecting your options, you would click “OK” to paste the copied data elements.

15.2- Pasting Linked Formulas:

You can select to paste a link between two cells so that when the value in the copied cell is changed, the value displayed in the linked cell reflects the change. This is very handy when using the result of a formula as the basis for other formulas in linked workbooks or worksheets. For example, if you had a workbook that totaled sales per month on one worksheet, and another worksheet in the same workbook that totaled the monthly sales per quarter, you could copy and link the totals from the first worksheet into the second worksheet. That way, any changes made to the data in the first worksheet would be automatically reflected in the second sheet!

To copy a link between cells, first copy the cell that you want to link into another worksheet or workbook, and then select the destination cell to link. Then click the “Paste” button’s drop-down menu in the “Clipboard” group on the “Home” tab of the Ribbon to display the drop-down menu of choices. Select the “Paste Link” command to paste the link back to the original cell that you copied. If you are using the “Paste Special” dialog box, you can also click the “Paste Link” button that appears in the lower left corner of the dialog box to paste a link to the original cell that you copied. If you examine the contents of the linked cell, you will see that it is actually a formula. The formula simply states that the cell’s value is to be equal to the value displayed in the cell address shown. The cell address is the address of the cell that was copied.

If you use this feature to paste links between data in separate workbooks you should exercise care not to rename or move those workbooks. Doing so will break any links in the formula references created by the “Paste Link” button, forcing you to delete the links and recreate them again or edit the formula references within each linked cell. As long as you do not move or rename the workbooks, you should be able to change the value in the cell which you copied in one workbook and save your changes. The next time that you open the workbook that contains the linked cells, you may see a message appear onscreen telling you that the workbook contains links to data in other workbooks which has changed. To update the values in the linked cells to reflect the changes, click the “Update” or “Enable content” buttons in Excel to update the data in the linked worksheet, and be sure to save the changes made in this workbook as well.
USING PASTE SPECIAL:

1. Begin by copying a cell, as usual.
2. Select the destination cell to which you want to paste the copied content.
3. Click the “Paste” button’s drop-down arrow in the “Clipboard” group on the “Home” tab in the Ribbon. At the top of the drop-down menu that appears, you can see options that you have for selecting what elements of the copied element you want to paste. You could also just click the “Paste Special…” command at the bottom of the drop-down menu to open the “Paste Special” dialog box.
4. In the “Paste Special” dialog box you select the option button that represents what aspect of the copied element you wish to paste in the “Paste” section at the top of this dialog box. Note that if you select the “Values” option, you can then also choose a mathematical operation from the “Operation” section to perform between the value that you are pasting, and the value that currently exists in the cell to which you are pasting.
5. Once you have made your selections, click the “OK” button to paste your special content.

PASTING LINKED CELL DATA:

1. Begin by copying a cell, as usual.
2. Select the destination cell to which you want to link the copied content.
3. Click the “Paste” button’s drop-down menu in the “Clipboard” group on the “Home” tab in the Ribbon.
4. Select the “Paste Link” command to paste the link back to the original cell that you copied. If you are using the “Paste Special” dialog box, you can also click the “Paste Link” button that appears in the lower left corner of the dialog box to paste a link to the original cell that you copied.
EXERCISES-
Paste Special

Purpose:
1. To be able to use features of the paste special tool.

Exercises:
1. Open up the “Inter-Sample” workbook in your “Documents” folder that has been completed through the Exercise at the end of the previous chapter.
2. Select the “Sheet1” worksheet.
4. Click the “Copy” button in the “Clipboard” group on the “Home” tab in the Ribbon.
5. Select the “Sheet3” worksheet.
7. Click the “Paste” button in the “Clipboard” group on the “Home” tab in the Ribbon.
8. Expand the width of column B on “Sheet3” so that you can read the number values.
9. Edit the contents of cell B4 to read: “Q1-Q2 Sales:.”
10. Select the “Sheet2” worksheet.
11. Select the cells from B3:B6.
12. Click the “Copy” button in the “Clipboard” group on the “Home” tab in the Ribbon.
13. Select the “Sheet3” worksheet.
14. Select cell B5.
15. Click the drop-down button below the “Paste” button in the “Clipboard” group on the “Home” tab in the Ribbon.
16. Select the “Paste Special…” command from the button’s drop-down menu.
17. In the “Paste Special” dialog box, select the “Values” option in the “Paste” section at the top of the dialog box.
18. Select the “Add” option button in the “Operation” section at the bottom of the dialog box.
19. Click the “OK” button when you are finished.
20. Click the “Save” button in the Quick Access Toolbar to save your changes.
21. You can then close the workbook.
CHAPTER 16-
SHARING WORKBOOKS

16.1- SHARING WORKBOOKS
16.2- HIGHLIGHTING CHANGES
16.3- REVIEWING CHANGES
16.4- USING COMMENTS
16.5- COMPARE AND MERGE WORKBOOKS
16.1- Sharing Workbooks:

You can share a workbook to allow multiple users on a network to access the workbook and make changes simultaneously. All you need to do is create the workbook, set it to be a shared workbook, and then place it on a shared network folder that the editing users can access. There are, however, a few pointers that you should be aware of before you share a workbook.

After sharing a workbook, you will not be able to insert or change any of the following objects or settings until you have stopped sharing the workbook: merged cells, conditional formatting, data validation, charts, pictures, objects, drawing objects, hyperlinks, scenarios, outlines, subtotals, data tables, PivotTable reports, workbook and worksheet protection, and macros. Therefore, insert or apply these things prior to sharing the workbook, if needed. Also, all users who will be editing the workbook must have Excel 97 or later to be able to make changes.

To share a workbook, first open the workbook that you wish to share. Then click the “Share Workbook” button in the “Changes” group on the “Review” tab to launch the “Share Workbook” dialog box. In this dialog box, click the “Editing” tab, and check the “Allow changes by more than one user at the same time.” This also allows workbook merging.” checkbox. Next, click the “Advanced” tab to set additional sharing options. In the “Track Changes” section, you can select the option button for “Keep change history for:**” and type a number (in days) to track any changes to the workbook. If you don’t want to track changes, then select the “Don’t keep change history” option. In the “Include in personal view” section, you can include what to include in your custom view of the shared workbook. By default, the view includes any filter or print settings you make, or you can use the original printer and filter settings. In the future, when you open the shared workbook, it will display using the settings of your custom view, so that each user can have their own view of the data. You can check the “Print settings” and “Filter settings” checkboxes to include those in the default view.

Sometimes, when two users edit the same cell at the same time a conflict will arise when Excel goes to save the workbook. In the “Conflicting changes between users” section, you can set how to resolve those conflicts. You can select either the option button for “Ask me which changes win” or “The changes being saved win.” In the “Include in personal view” section, you can include what to include in your custom view of the shared workbook. By default, the view includes any filter or print settings you make, or you can use the original printer and filter settings. In the future, when you open the shared workbook, it will display using the settings of your custom view, so that each user can have their own view of the data. You can check the “Print settings” and “Filter settings” checkboxes to include those in the default view.

When you finish specifying share options, click “OK” in the “Share Workbook” dialog box. If you have already saved the workbook, a message box will appear telling you that you must resave the workbook. Click “OK” to continue. Then select the shared network location to which you want to save the shared workbook. Once you have done this, the other users may go edit and review the shared workbook. When two users try to save changes that affect the same cell, Excel will display the “Resolve Conflicts” dialog box for one of the two users. In this dialog box, read about each change and the conflicting change made by others. To keep your changes and move to the next conflicting change, click “Accept Mine.” To accept the other user’s changes, click “Accept Others.” You can also click “Accept All Mine” or “Accept All Others” to accept all of your changes over the other users, or to accept all of the other users changes over yours. Note that this will only occur if you selected to “Ask me which changes win” in the “Conflicting changes between users” section of the “Share Workbooks” dialog box.

When you want to stop sharing a shared workbook, make sure that all the other users have saved and closed their copies of the shared workbook, first. Then click the “Share Workbook” button in the “Changes” group on the “Review” tab to launch the “Share Workbook” dialog box. On the “Editing” tab, uncheck the “Allow changes by more than one user at the same time” checkbox. Then click “OK.” In the message box that appears, click the “Yes” button to stop sharing the workbook.
16.2- Highlighting Changes:

You have a few options for reviewing the changes that have been made to a workbook. You can elect to show and track changes in a workbook and even list the changes made in a separate worksheet named “History.” You can then use the “History” tab to review the changes that were made and then choose to accept or reject the changes individually. In the “History” sheet you will see the name of the person who made the change, what type of change was made, when it was made, what cells were affected, and what data was added or deleted. If you don’t want to see this information in a separate sheet, you can also elect to have it display in the changed worksheet directly. You can use this when several people have made editing changes to a shared workbook, or after you have sent out a workbook for review and then want to merge the input and commentary into one copy.

To review the changes made in a shared workbook, click the “Track Changes” button in the “Changes” group on the “Review” tab. Then click the “Highlight Changes…” command in the button’s drop-down menu to open the “Highlight Changes” dialog box.

In the “Highlight Changes” dialog box you can set the display of editing changes. You can check the “Track changes while editing.” checkbox to enable changes to be tracked as you edit the workbook. In the “Highlight which changes” section, you decide what types of changes to highlight. By default, some types of changes aren’t tracked. However, in this section you can choose when, for whom, and for what cells to highlight changes. Use the “When:” checkbox and drop-down to select for what duration of time to highlight the changes. You only can highlight changes from as far back as you have set to track changes when you created the shared workbook. So, for example, if you set the shared workbook to track change history for 30 days, you won’t be able to see or highlight any changes made from before 30 days ago. Use the “Who:” checkbox and drop-down to select from whom to highlight changes. You can even use the “Where:” checkbox and drop-down to select a cell range to highlight changes within.

You can check the “Highlight changes on screen” checkbox to show the changes made in the cells that were changed. Changed cells display a small triangle in their upper left corners. When you hold your mouse pointer over them in the worksheet, the information about the change appears in a small pop-up text box. You can also check the “List changes on a new sheet” checkbox to list the changes in a new worksheet named “History.” You can then review the changes in either place. Just click the “OK” button to highlight changes in the selected location.

16.3- Reviewing Changes:

After viewing the changes that have been made, you can then elect to either accept or reject the changes to the shared worksheets. To do this, click the “Track Changes” button in the “Changes” group on the “Review” tab. Then click the “Accept/Reject Changes” command in the button’s drop-down menu to open the “Select Changes to Accept or Reject” dialog box. In this dialog box, use the “When:,” “Who:,” and “Where:” checkboxes and drop-down menus to filter for the changes that you want to review. Once you have made your desired selections, click “OK” to begin reviewing the selected changes.

Next, each selected change will appear. It will show who made the change, when they made the change, and what they changed in the “Accept or Reject Changes” dialog box. At the bottom of the dialog box click “Accept,” to accept the change shown; “Reject,” to reject the change shown; “Accept All,” to accept all changes made; or “Reject All” to reject all changes made. Note that if there were multiple changes made to a cell, you may have to select which change to keep in the dialog box before pressing one of the buttons available. When you are finished, the dialog box will close automatically. You can leave anytime before then, if needed, by simply clicking the “Close” button to exit.

©TeachUcomp, Inc. Intermediate Excel
16.4- Using Comments:

You can use the buttons in the “Comments” group on the “Review” tab in the Ribbon to manage comments in worksheet cells and also review changes to a shared workbook. You can also manipulate “ink” annotations from users of tablet PCs using the buttons in this group during the review process.

You can add a comment to a cell for other people who use that workbook to read. For example, you could include a cell comment to a formula cell that explains its function, or you could add a cell comment that gives tips on what data should be entered into the cell. Often you use comments when making changes to a shared workbook so that others can be informed as to what you changed and why you changed it.

Cell comments are little text boxes associated with particular cells. When someone moves their mouse pointer over a cell that contains a comment, the comment text box will pop up: revealing the comments for that cell. Cells with commentary attached to them display as normal within the workbook, but contain a small red triangle in the upper right corner of the cell to indicate that they have a comment associated with them. When you make a change to a shared workbook and then highlight the changes, you will see the changes also listed as cell comments, but using a different color.

You can easily insert a new comment into a cell by clicking on the cell into which you want to place the comment, and then clicking the “New Comment” button in the “Comments” group on the “Review” tab in the Ribbon. You may also right-click on a cell and then choose the “Insert Comment” command from the pop-up menu that appears to insert a new comment, as well.

The comment will appear as a text box attached to the cell. It will display the default user name associated with the Office installation associated with the comment. You simply type your comment into the text box. When you are finished typing your cell comment, click back into the worksheet cells to “set” the comment. After that, you will see the comment appear in your worksheet when you simply hold your mouse pointer over the cell that contains the comment.

If you want to edit cell comments at a later point, you start by selecting the cell with the comment that you want to edit. Next, either click the “Edit Comment” button in the “Comments” group on the “Review” tab in the Ribbon, or right-click the comment cell and select the “Edit Comment” command from the pop-up menu. This will make the comment appear in its editing mode, where you can change the comment as you wish. Once again, when you are finished editing the content, just click back into the worksheet cells to “set” the comment.

To delete a comment from a cell, you start by selecting the cell with the comment that you want to delete. Next, click the “Delete” button in the “Comments” group on the “Review” tab in the Ribbon, or right-click the cell with the comment that you want to delete and select the “Delete Comment” command from the pop-up menu that appears.

Comments can be easily viewed by moving the mouse pointer over the cell with the comment that you wish to display. The comment will pop-up so you can read it. However, if you have many comments in a workbook, you may want to start at a certain comment and read through all of the comments available. You can do this by clicking either the “Previous” or “Next” buttons in the “Comments” group on the “Review” tab in the Ribbon to move from comment to comment in the workbook until you reach the end of the workbook. Once you have reached the end of the comments in a workbook, it will ask you if you want to start reviewing from the beginning of the workbook. Just click the “OK” button to continue reviewing the comments from the beginning of the workbook, or click the “Cancel” button to stop reviewing the comments. Then just click into a non-commented cell in the worksheet to hide the display of the comment again.

You can also change the display of a comment so that when you roll your mouse pointer off the cell that contains the comment, the comment will still be visible. To do this, click on the cell that has the comment that you want to constantly display, and then click the “Show/Hide Comment” button in the “Comments” group on the “Review” tab in the Ribbon. You also click this button to hide the comment.
16.4- Using Comments (cont'd.): 

when you want to hide the display again it by clicking on the cell with the displayed comment, and then clicking the “Show/Hide Comment” button again.

Likewise, you can also toggle the display of all of the comments in your workbook between constantly showing and only showing when selected. To do this, just click anywhere into the worksheet and then click the “Show All Comments” button in the “Comments” group on the “Review” tab in the Ribbon to constantly display all the workbook’s comments. If the comments overlap each other, you can move the hidden comment by clicking and dragging the comment by its border to reposition the display of the comment. To hide all the comments again once you’ve shown them, just click the “Show All Comments” button again to hide the constant display of comments in the workbook.

You can print the comments in a worksheet in one of two ways. You can either print them off on a separate sheet that lists all of the comments in a workbook, or you can print them as they are displayed on screen. If you choose the latter option, then you must set the comments that you want to print in the worksheet to constantly “show.” Then click the “Page Setup” dialog box button in the lower right corner of the “Page Setup” group on the “Page Layout” tab of the Ribbon to open the “Page Setup” dialog box. In the “Page Setup” dialog box, click the “Sheet” tab. Use the “Comments” drop-down to select how to print cell comments: “(None),” which won’t print comments; “At end of sheet,” which prints them at the end of the sheet on a separate piece of paper; or “As displayed on sheet,” which prints them as they are displayed on the sheet. Click “OK” to set your printing preference for the comments and then print the sheet to view the comments in the printout using the method that you specified.

16.5- Compare and Merge Workbooks:

If you have created or received copies of a shared workbook into which different users have made different changes, you can take those workbook files and merge the changes together into a single workbook. There are a few requirements that the files must meet before you can merge them together. First, all merged workbooks must be copies of the original shared workbook. They must all have different files names, but must all be located in the same folder. They cannot have passwords applied to them. They must also have change tracking in effect since the copies were created and they must have been tracking the change history. Also note that if you merge multiple copies, changes in the last workbook copy that you merge will replace any conflicting changes in the workbook into which you are merging.

To merge shared workbooks, make sure that you have all of the copies to be merged located in the same folder with different file names. Next, you will need to add a button to the Quick Access toolbar for this function, which does not appear in the Ribbon. To do this, click the “Customize Quick Access Toolbar” button at the right end of the Quick Access toolbar. Then select the “More commands…” choice from the button’s drop-down menu. In the “Excel Options” window that appears, select the “All commands” choice from the “Choose commands from:" drop-down menu. Then scroll through the list of commands until you find the “Compare and Merge Workbooks…” command. Click it to select it, and then click the “Add >>” button to move it to the list at the right. Then click the “OK” button to finish.

Next, click the “Compare and Merge Workbooks” button in the Quick Access toolbar. You can save the workbook, if prompted. That will then launch the “Select Files to Merge into Current Workbook” dialog box. Here you can select the copies of the workbook to merge into the open copy, or original shared workbook. Note that if you do select more than one copy in this dialog box, the order in which they appear will be the order in which they are merged into the open workbook. When you have finished selecting the file or files to merge into the open workbook, click “OK.”
**SHARING WORKBOOKS:**

1. Open the workbook that you wish to share.
2. Click the “Share Workbook” button in the “Changes” group on the “Review” tab to launch the “Share Workbook” dialog box.
3. In this dialog box, click the “Editing” tab, and check the “Allow changes by more than one user at the same time. This also allows workbook merging.” checkbox.
4. Click the “Advanced” tab to set additional sharing options. In the “Track Changes” section, you can select the option button for “Keep change history for:” and type a number (in days) to track any changes to the workbook. If you don’t want to track changes, then select the “Don’t keep change history” option.
5. In the “Update changes” section, you can select the “When file is saved” option button to update the workbook’s changes every time that it is saved. You could also select the “Automatically every:” option button, and then enter a number (in minutes) that it should save the changes automatically. If you select this option, you can also specify to “Save my changes and see others’ changes” or “Just see other users’ changes” by clicking either option button.
6. In the “Conflicting changes between users” section, you can set how to resolve conflicts. You can select either the option button for “Ask me which changes win” or “The changes being saved win.”
7. In the “Include in personal view” section, you can include what to include in your custom view of the shared workbook. By default, the view includes any filter or print settings you make, or you can use the original printer and filter settings. In the future, when you open the shared workbook, it will display using the settings of your custom view, so that each user can have their own view of the data. You can check the “Print settings” and “Filter settings” checkboxes to include those in the default view.
8. When you finish specifying share options, click “OK” in the “Share Workbook” dialog box. If you have already saved the workbook, a message box will appear telling you that you must resave the workbook. Click “OK” to continue. Then select the shared network location to which you want to save the shared workbook.

**RESOLVING CONFLICTS TO A SHARED WORKBOOK:**

1. When two users try to save changes that affect the same cell, Excel will display the “Resolve Conflicts” dialog box for one of the two users.
2. In this dialog box you will be able to read information about each change and the conflicting change made by others.
3. To keep your changes and move to the next conflicting change, click “Accept Mine.”
4. To accept the other user’s changes, click “Accept Others.”
5. You can also click “Accept All Mine” or “Accept All Others” to accept all of your changes over the other users, or to accept all of the other users changes over yours.

**TO STOP SHARING A SHARED WORKBOOK:**

1. Make sure that all the other users have saved and closed their copies of the shared workbook, first.
2. Then click the “Share Workbook” button in the “Changes” group on the “Review” tab to launch the “Share Workbook” dialog box.
3. On the “Editing” tab, uncheck the “Allow changes by more than one user at the same time” checkbox, and then click “OK.”
4. In the message box that appears, click the “Yes” button to stop sharing the workbook.
HIGHLIGHTING CHANGES IN A SHARED WORKBOOK:

1. Click the “Track Changes” button in the “Changes” group on the “Review” tab. Then click the “Accept/Reject Changes…” command in the button’s drop-down menu to open the “Highlight Changes” dialog box.

2. In the “Highlight Changes” dialog box you can set the display of editing changes. You can check the “Track changes while editing. This also shares your workbook.” checkbox to enable changes to be tracked as you edit the workbook.

3. In the “Highlight which changes” section, you decide what types of changes to highlight. In this section, use the “When:” checkbox and drop-down to select for what duration of time to highlight the changes. Then use the “Who:” checkbox and drop-down to select from whom to highlight changes. You can also use the “Where:” checkbox and drop-down to select a cell range to highlight changes within.

4. You can check the “Highlight changes on screen” checkbox to show the changes made in the cells that were changed. Changed cells display a small triangle in their upper left corners. When you hold your mouse pointer over them, the information about the change appears in a small pop-up text box.

5. You can also check the “List changes on a new sheet” checkbox to list the changes in a new worksheet named “History.” You can then review the changes in either place.

6. When you are finished, click the “OK” button to highlight changes in the selected location.

ACCEPTING OR REJECTING SHARED WORKBOOK CHANGES:

1. Click the “Track Changes” button in the “Changes” group on the “Review” tab. Then click the “Accept/Reject Changes” command in the button’s drop-down menu to open the “Select Changes to Accept or Reject” dialog box.

2. In this dialog box, use the “When:,” “Who:,” and “Where:” checkboxes and drop-down menus to filter for the changes that you want to review.

3. Once you have made your desired selections, click “OK” to begin reviewing the selected changes.

4. Next, each selected change will appear. It will show who made the change, when they made the change, and what they changed in the “Accept or Reject Changes” dialog box.

5. At the bottom of the dialog box click “Accept,” to accept the change shown; “Reject,” to reject the change shown; “Accept All,” to accept all changes made; or “Reject All” to reject all changes made.

6. Note that if there were multiple changes made to a cell, you may have to select which change to keep in the dialog box before pressing one of the buttons available. When you are finished, the dialog box will close automatically.

7. You can leave anytime before finishing, if needed, by simply clicking the “Close” button to exit.

USING COMMENTS:

1. You can insert a new comment into a cell by clicking on the cell into which you want to place the comment, and then clicking the “New Comment” button in the “Comments” group on the “Review” tab in the Ribbon. You may also right-click on a cell and then choose the “Insert Comment” command from the pop-up menu that appears to insert a new comment, as well.

2. The comment will appear as a text box attached to the cell. It will display the default user name associated with the Office installation associated with the comment.

(cont'd.)
USING COMMENTS (CONT’D.):

3. You simply type your comment into the text box. When you are finished typing your cell comment, click back into the worksheet cells to “set” the comment.

4. After that, you will see the comment appear in your worksheet when you simply hold your mouse pointer over the cell that contains the comment.

5. If you want to edit cell comments at a later point, you start by selecting the cell with the comment that you want to edit.

6. Next, either click the “Edit Comment” button in the “Comments” group on the “Review” tab in the Ribbon, or right-click the comment cell and select the “Edit Comment” command from the pop-up menu.

7. This will make the comment appear in its editing mode, where you can change the comment as you wish. Once again, when you are finished editing the content, just click back into the worksheet cells to “set” the comment.

8. To delete a comment from a cell, you start by selecting the cell with the comment that you want to delete.

9. Next, click the “Delete” button in the “Comments” group on the “Review” tab in the Ribbon, or right-click the cell with the comment that you want to delete and select the “Delete Comment” command from the pop-up menu that appears.

10. You can read through all of the comments available by clicking either the “Previous” or “Next” buttons in the “Comments” group on the “Review” tab in the Ribbon to move from comment to comment in the workbook until you reach the end of the workbook. Once you have reached the end of the comments in a workbook, it will ask you if you want to start reviewing from the beginning of the workbook. Just click the “OK” button to continue reviewing the comments from the beginning of the workbook, or click the “Cancel” button to stop reviewing the comments. Then just click into a non-commented cell in the worksheet to hide the display of the currently selected comment again.

11. You can also change the display of a comment so that when you roll your mouse pointer off the cell that contains the comment, the comment will still be visible. To do this, click on the cell that has the comment that you want to constantly display, and then click the “Show/Hide Comment” button in the “Comments” group on the “Review” tab in the Ribbon. You also click this button to hide the comment when you want to hide the display again by clicking on the cell with the displayed comment, and then clicking the “Show/Hide Comment” button again.

12. Likewise, you can also toggle the display of all of the comments in your workbook between constantly showing and only showing when selected. To do this, just click anywhere into the worksheet and then click the “Show All Comments” button in the “Comments” group on the “Review” tab in the Ribbon to constantly display all the workbook’s comments.

13. If the comments overlap each other, you can move the hidden comment by clicking and dragging the comment by its border to reposition the display of the comment.

14. To hide all the comments again once you’ve shown them, just click the “Show All Comments” button again to hide the constant display of comments in the workbook.

15. You can print the comments in a worksheet in one of two ways. You can either print them off on a separate sheet that lists all of the comments in a workbook, or you can print them as they are displayed on screen. If you choose the latter option, then you must set the comments that you want to print in the worksheet to constantly “show.”

16. Then click the “Page Setup” dialog box button in the lower right corner of the “Page Setup” group on the “Page Layout” tab of the Ribbon to open the “Page Setup” dialog box.

(cont’d.)
USING COMMENTS (CONT’D.):

17. In the “Page Setup” dialog box, click the “Sheet” tab.
18. Use the “Comments:” drop-down to select how to print cell comments: “(None),” which won’t print comments; “At end of sheet,” which prints them at the end of the sheet on a separate piece of paper; or “As displayed on sheet,” which prints them as they are displayed on the sheet.
19. Click “OK” to set your printing preference for the comments and then print the sheet to view the comments in the printout using the method that you specified.

COMPARE AND MERGE WORKBOOKS:

1. If you have created or received copies of a shared workbook into which different users have made different changes, you can take those workbook files and merge the changes together into a single workbook. There are a few requirements that the files must meet before you can merge them together. First, all merged workbooks must be copies of the original shared workbook. They must all have different files names, but must all be located in the same folder. They cannot have passwords applied to them. They must also have change tracking in effect since the copies were created and they must have been tracking the change history. Also note that if you merge multiple copies, changes in the last workbook copy that you merge will replace any conflicting changes in the workbook into which you are merging.
2. Next, you will need to add a button to the Quick Access toolbar for this function, which does not appear in the Ribbon.
3. To do this, click the “Customize Quick Access Toolbar” button at the right end of the Quick Access toolbar. Then select the “More commands…” choice from the button’s drop-down menu.
4. In the “Excel Options” window that appears, select the “All commands” choice from the “Choose commands from:” drop-down menu.
5. Then scroll through the list of commands until you find the “Compare and Merge Workbooks…” command. Click it to select it, and then click the “Add >>” button to move it to the list at the right.
6. Then click the “OK” button to finish.
7. Next, click the “Compare and Merge Workbooks” button in the Quick Access toolbar. You can save the workbook, if prompted.
8. That will then launch the “Select Files to Merge into Current Workbook” dialog box. Here you can select the copies of the workbook to merge into the open copy, or original shared workbook. Note that if you do select more than one copy in this dialog box, the order in which they appear will be the order in which they are merged into the open workbook.
9. When you have finished selecting the file or files to merge into the open workbook, click “OK.”
**Purpose:**

1. To be able to insert and manage cell comments.

**Exercises:**

1. Open up the "Inter-Sample" workbook in your "Documents" folder that has been completed through the Exercise at the end of the previous chapter.
2. Select “Sheet3.”
4. Click the “New Comment” button in the “Comments” group on the “Review” tab in the Ribbon.
5. Type a comment that reads, “Table values below are static values created from a paste special function. They are not formulas.”
6. Click into cell A1 to set the comment in B4.
7. Roll your mouse pointer over cell B4 to watch the comment appear. Roll your mouse pointer away from cell B4 to hide the comment again.
8. Select cell B4.
9. Click the “Show/Hide Comment” button in the “Comments” group on the “Review” tab in the Ribbon.
10. Click once on the border of the displayed comment to select it.
11. Move your mouse pointer over one of the small white resizing handles that surround the border until your mouse pointer changes into a two-pointed arrow.
12. Click and drag at that point to change the size of the comment. Release the mouse button when it is the size that you prefer.
13. Click the “Show/Hide Comment” button in the “Comments” group on the “Review” tab in the Ribbon. The display of the comment should return to its normal function.
14. Click the “Save” button in the Quick Access Toolbar to save your changes.
15. You can then close the workbook.
CHAPTER 17 - AUDITING WORKSHEETS

17.1 - Auditing Worksheets
17.2 - Tracing Precedent and Dependent Cells
17.3 - Tracing Errors
17.4 - Error Checking
17.5 - Using the Watch Window
17.6 - Cell Validation
17.1- Auditing Worksheets:

Auditing Worksheets refers to the process of discovering which cells involved in cell formulas are dependent upon which other cells to function. For example, you might have a formula at the bottom of a column that adds up the numbers above it. That formula is “dependent” on those cells to function, so you call it a “dependent cell” in regards to the cells above it. The cells above the formula cell would be called the “precedent” cells. These are the cells which contain the values used to perform the calculation. Auditing worksheets it is simply a way of analyzing the relationships that exist between cells, and the related cell dependencies, within a workbook.

In Excel, you can use the buttons available in the “Formula Auditing” group on the “Formulas” tab in the Ribbon to trace the precedent and dependent cells of a selected formula cell. This allows you to easily see what cells the selected formula cell uses in its calculations. This also enables you to see what other formula cells then use the value derived by the selected formula cell in their calculations.

17.2- Tracing Precedent and Dependent Cells:

You can select any formula cell, or any cell referenced by a formula cell, and then trace arrows that point to either the precedent or dependent cells from the selected cell. When you do this, Excel draws blue arrows either from the selected cell to its dependent cells, or from the precedent cells to the selected cell-depending on which button you choose from the buttons available in the “Formula Auditing” group on the “Formulas” tab in the Ribbon.

If the precedent or dependent cells are on another worksheet, then a black arrow that points to a worksheet icon will be displayed versus displaying a blue arrow. You can double-click on the black arrow to view the “Go to” dialog box, which should point to the worksheet reference. You can then click on the reference and click “OK” to jump to the referenced cell in the other worksheet.

To view the precedent cells from a selected formula cell, first select the formula cell. Next, click the “Trace Precedents” button in the “Formula Auditing” group on the “Formulas” tab in the Ribbon. This will cause Excel to trace arrows back to the precedent cells that are referenced by the formula in the selected cell. In some cases, these cells may also be formulas. In that case, you can continue to click the “Trace Precedents” button to view multiple levels of precedent cells. In this way, you can work backward to discover which cells are referenced by the formula to perform its calculations. This is handy for determining which cells may be causing errors or inaccuracies in your worksheet formula calculations.

Tracing dependent cells is the same procedure in reverse. You simply click on a cell from which you want to trace the dependent cells, and then click the “Trace Dependents” button in the “Formula Auditing” group on the “Formulas” tab in the Ribbon. Excel will draw arrows to any cells that need the value calculated by the selected cell to function. You can click the “Trace Dependents” button as many times as needed to trace multiple levels of dependency from the selected cell, if necessary.

To remove all of the auditing arrows that Excel draws in a worksheet, first select the worksheet from which you want to remove the auditing arrows. Next, click the “Remove Arrows” button in the “Formula Auditing” group on the “Formulas” tab in the Ribbon. This will remove all arrows from the selected worksheet. It is important to note that you must clear the traced arrows in each individual worksheet separately.

If you only wish to remove the last level of precedent or dependent arrows that were drawn in a worksheet, you can click the drop-down button to the right of the “Remove Arrows” button, and then select either the “Remove Precedent Arrows” or “Remove Dependent Arrows” commands from the button’s drop-down menu to remove the last level of precedent and dependent arrows that were traced.
17.3- Tracing Errors:

Another feature of auditing worksheets is that it allows you to trace arrows back to the cells that are being referenced by a selected formula if the formula that you create displays an error. To do this, first select the formula cell with the error displayed in it. Next, click the “Error Checking” drop-down button in the “Formula Auditing” group on the “Formulas” tab in the Ribbon, and then select the “Trace Error” command to draw arrows to the cells that cause the error. Invalid or inaccurate cell referencing is often a common cause of formula errors. Using this tool will show you the cells that are being referenced. You can then fix the cell references, if that turns out to be the reason why the formula won’t function.

17.4- Error Checking:

You can use the “Error Checking” button in the “Formula Auditing” group on the “Formulas” tab in the Ribbon to trace and correct formula errors in your worksheets. To do this, just click the “Error Checking” button in the “Formula Auditing” group on the “Formulas” tab in the Ribbon while selecting a worksheet that contains formula errors. You’ll then show the first formula error encountered in the worksheet in the “Error Checking” dialog box.

You can click the “Help on this error” button to launch the associated help page for this error topic in a separate window. You can read the information, and close the window when you are finished. You can then click the “Resume” button in the “Error Checking” dialog box to resume error checking the sheet. If you click the “Show Calculation Steps…” button in the “Error Checking” dialog box, it then launches the “Evaluate Formula” dialog box. Note that you can also launch this dialog box independently of the “Error Checking” dialog box. You can separately launch this dialog box by clicking the “Evaluate Formula” button in the “Formula Auditing” group on the “Formulas” tab in the Ribbon.

In the “Evaluate Formula” dialog box, you can click the “Evaluate” button to evaluate the underlined reference displayed in the formula. If you have nested functions in the formula, you can step through each calculation to view when the error occurs. You can click the “Restart” button to restart the calculations again, if needed. If the underlined reference that is being evaluated is a reference to another formula, you can click the “Step In” button to view that function in this window and evaluate its value. You can then click the “Step Out” button to step back out of that formula and into the original formula to continue evaluating the first formula. When you are finished, click “Close” to return to the “Error Checking” dialog box.

You can click the “Ignore Error” button to skip the error displayed in the formula and continue to the next formula error. However, once you choose to ignore an error, you will no longer be able to recheck it using the “Error Checking” feature! This acts much like telling the “Spell Checker” feature to ignore a misspelled word: it will no longer regard the error cell as being an error, even though the formula still won’t function. You can click the “Options…” button in the lower left corner of this dialog box to fix this. Click the “Reset Ignored Errors” button in the “Options” dialog box and then click “OK” to reset ignored errors.

You can click the “Edit in Formula Bar” button in the “Error Checking” dialog box to display the formula in the Formula Bar, where you can edit it to fix the mistake. Once you feel that you have corrected the problem, click the “Enter” button within the formula bar to “set” the formula. Then click “Resume” in the “Error Checking” dialog box to resume error checking.

You can also just click the “Previous” and “Next” buttons at the bottom of the “Error Checking” dialog box to move through the malfunctioning formulas in your worksheet without “ignoring” them. When you finish viewing all of the errors in your formula cells, you will see a small dialog box that appears and tells you that the error check is complete. Click “OK” to finish your error checking.
17.5- Using the Watch Window:

You can watch the value of a cell to note when it changes, even if the cell isn’t viewable on screen at the time it changes. To watch the value of a cell, click the “Watch Window” button in the “Formula Auditing” group on the “Formulas” tab in the Ribbon. That will open the “Watch Window” dialog box.

In this dialog box, click the “Add Watch…” button at the top of the dialog box to set a cell to watch in this window. Then, with the “Add Watch” dialog box open, click and drag over the adjacent cells in the sheet that you want to watch. If the cells are non-adjacent, you can hold down “Ctrl” on your keyboard and click on non-adjacent cells to select them. Once you have made your cell selections, click “Add” to return to the “Watch Window.” The cell references that you added will be listed individually in this window pane. Then as you change cells in your worksheet, you can see the values change in the watch window. This can be useful for checking how data entry will affect cell values in a formula that you can’t see when you are performing the data entry. To delete an entry from the “Watch Window,” click on the reference in the “Watch Window” that you want to delete. Then click the “Delete Watch” button at the top of the “Watch Window” to delete the selected reference. When you are finished with the “Watch Window,” close it by clicking the “X” in the upper right corner of the “Watch Window.”

17.6- Cell Validation:

You can use cell validation to restrict data entry in selected cells to a limited range of values. To use cell validation, first select the cell or cell range upon which you wish to place data entry restrictions. Then click the “Data Validation” button shown in the “Data Tools” group on the “Data” tab in the Ribbon. In the “Data Validation” dialog box that opens there are three tabs: “Settings,” “Input Message,” and “Error Alert.”

You click the “Settings” tab to set the range of allowable values for the selected cell or cells. You use the “Allow:” drop-down to select a restriction criteria. You can select “Whole Number” or “Decimal” to restrict the cell entry to values within a specified limit. Next, you would use the “Data:” drop-down to select a comparison criteria. You then specify the value or values within which data entry will be allowed.

You can select the “List” choice from the “Allow:” drop-down on the “Settings” tab to restrict data entry in the selected cells to a list of cell values shown in the worksheet. Next, you would click the “Collapse Dialog” button at the right end of the “Source:” text box to collapse the “Data Validation” dialog box to a single line. Then click and drag over the cells that you want to use as the list of values from which the user can select. The list you select must be on the same worksheet as the cell to which you are applying the cell validation. Click the “Expand Dialog” button at the right end of the text box to expand the dialog box again. To the right of the “Data Validation” dialog box, you can check the “In-cell dropdown” to set the cell’s data entry method to be a drop-down list from which the user can select a displayed choice.

You can select “Date” or “Time” from the “Allow:” drop-down to restrict data entry in the selected cell or cells to a range of dates or times. Then use the “Data:” drop-down to select a comparison operator for your criteria. Use the “Start Date:” or “Start Time:” and (if needed) the “End Date:” or “End Time:” text boxes to set the date or time range by which you wish to restrict data entry.

You can select “Text Length” from the “Allow:” drop-down to restrict the length of text entries in cells. Once again, you would use the “Data:” drop-down to select a comparison operator and then use the “Minimum:” and/or the “Maximum:” text boxes to set the upper and lower limits of the text for data entry.

You can select “Custom” from the “Allow:” drop-down to enter a logical formula or select a logical formula cell in the “Formula:” text box. A logical formula has to evaluate to either “True” or “False.” This indicates whether or not to allow data entry in the cell.
17.6- Cell Validation (cont'd.):

After selecting what data to allow on the “Settings” tab, note that you can check or uncheck the “Ignore blank” checkbox for most selections. To allow null (empty) cells as being a valid entry, then check this box. To disallow blank cells as valid entries, clear the check box. Note that if you have a reference to a range with a blank cell in it for the allowed values of the cell, then checking the “Ignore blank” checkbox will allow any cell value to be entered into the cell as valid data.

Next, click the “Input Message” tab in the “Data Validation” dialog box. Here you can set an option message to display when the cell is selected for data entry. You have to check the “Show input message when cell is selected” checkbox. Then you can type a title for the message box that will appear when the user selects this cell into the “Title:” text box. Type the message that you want the user to see into the “Input message:” text box. When the user click onto this cell in the worksheet they will see a cell comment appear next to the cell. They can click and drag the message box to a different location in the worksheet if they find it to be in the way when they select the cell for data entry.

You can click the “Error Alert” tab to set how Excel will respond to invalid data entry in the cell. Make sure that the “Show error alert after invalid data is entered” checkbox is checked to enable this feature. Then use the “Style:” drop-down to set the icon that will appear in the error dialog box. You will see the icon shown below the “Style:” drop-down. Type the title for the error message box into the “Title:” text box. Then type the text of your error message into the “Error Message:” text box.

Once you have set the data validation that you want to the currently selected cells in the worksheet, click “OK” to apply the data validation. When you apply data validation on cells that have pre-existing values, the existing values will not be checked against the new cell validation rules. So, you can have data that breaks the validation rules that you have applied. If you want to check to see if there are any cells with invalid data entries, click the “Data Validation” drop-down button on the “Data Tools” group on the “Data” tab in the Ribbon. Then select the “Circle Invalid Data” command from the drop-down button’s menu of choices. Doing this will circle the invalid entries with a red circle in the worksheet. You can then edit the values of the circled cells. To remove the red circles around the invalid data, you can click the “Data Validation” drop-down button on the “Data Tools” group on the “Data” tab in the Ribbon. Then select the “Clear Validation Circles” command from the drop-down button’s menu of choices to remove them.

If you want to edit the restrictions placed on a cell through cell validation, select the cell that you want to edit and click the “Data Validation” button shown in the “Data Tools” group on the “Data” tab in the Ribbon. This will launch the “Data Validation” dialog box again, where you can change the settings as desired. If you change one cell of several cells that have the same cell validation rule applied, you can check the “Apply these changes to all other cells with the same settings” checkbox at the bottom of the “Settings” tab in the “Data Validation” dialog box and then click “OK” to apply the change not only to the selected cell, but also to all other cells in the worksheet that had the same data validation settings applied.

To clear cell validation after applying it to a cell or cells in a worksheet, select the cell or cells from which you want to remove the cell validation. Then click the “Data Validation” button shown in the “Data Tools” group on the “Data” tab in the Ribbon. Click the “Clear All” button in the lower left corner of the “Data Validation” dialog box to remove all cell validation settings from the selected cells.
TRACING PRECEDENT AND DEPENDENT CELLS:

1. To view the precedent cells from a selected formula cell, first select the formula cell.
2. Next, click the “Trace Precedents” button in the “Formula Auditing” group on the “Formulas” tab in the Ribbon. This will cause Excel to trace arrows back to the precedent cells that are referenced by the formula in the selected cell. In some cases, these cells may also be formulas. In that case, you can continue to click the “Trace Precedents” button to view multiple levels of precedent cells.
3. Tracing dependent cells is the same procedure in reverse. You simply click on a cell from which you want to trace the dependent cells, and then click the “Trace Dependents” button in the “Formula Auditing” group on the “Formulas” tab in the Ribbon. Excel will draw arrows to any cells that need the value calculated by the selected cell to function. You can click the “Trace Dependents” button as many times as needed to trace multiple levels of dependency from the selected cell.
4. If the precedent or dependent cells are on another worksheet, then a black arrow that points to a worksheet icon will be displayed versus displaying a normal blue arrow. You can double-click on the black arrow to view the “Go to” dialog box, which should point to the worksheet reference. You can then click on the reference and click “OK” to jump to the referenced cell in the other worksheet.
5. To remove all of the auditing arrows that Excel draws in a worksheet, first select the worksheet from which you want to remove the auditing arrows. Next, click the “Remove Arrows” button in the “Formula Auditing” group on the “Formulas” tab in the Ribbon. This will remove all arrows from the selected worksheet. It is important to note that you must clear the traced arrows in each individual worksheet separately.
6. If you only wish to remove the last level of precedent or dependent arrows that were drawn in a worksheet, you can click the drop-down button to the right of the “Remove Arrows” button, and then select either the “Remove Precedent Arrows” or “Remove Dependent Arrows” commands from the button’s drop-down menu to remove the last level of precedent and dependent arrows that were traced.

TRACING FORMULA ERRORS:

1. Select the formula cell with the error displayed in it.
2. Click the “Error Checking” drop-down button in the “Formula Auditing” group on the “Formulas” tab in the Ribbon, and then select the “Trace Error” command to draw arrows to the cells that cause the error.

ERROR CHECKING A WORKSHEET:

1. Click the “Error Checking” button in the “Formula Auditing” group on the “Formulas” tab in the Ribbon.
2. In the “Error Checking” dialog box you’ll see the first formula error displayed.
3. You can click the “Help on this error” button to view the associated help file for the error topic. You can click the “Resume” button in the “Error Checking” dialog box to resume error checking, when finished.
4. If you click the “Show Calculation Steps…” button, it launches the “Evaluate Formula” dialog box. You can also launch this dialog box by clicking the “Evaluate Formula” button in the “Formula Auditing” group on the “Formulas” tab in the Ribbon.
5. In the “Evaluate Formula” dialog box, you can click the “Evaluate” to evaluate the underlined reference in the formula displayed. You can click the “Restart” button to restart the calculations again, if needed.

(cont’d.)
ACTIONS -
Auditing Worksheets

ERROR CHECKING A WORKSHEET:

6. If the underlined reference being evaluated is a reference to another formula, you can click the “Step In” button to view that function evaluate its value. You can then click the “Step Out” button to step back out of that formula and into the original formula to continue evaluating the first formula.

7. When you are finished evaluating the formula, click “Close” to return to the “Error Checking” dialog box.

8. You can click the “Ignore Error” button to ignore the error displayed in the formula and continue to the next formula error.

9. You can click the “Edit in Formula Bar” button in the “Error Checking” dialog box to display the formula in the Formula Bar, where you can edit it to fix the mistake. Once you feel that you have corrected the problem, click the “Enter” button within the formula bar to “set” the formula. Then click “Resume” in the “Error Checking” dialog box to resume error checking.

10. You can also just click the “Previous” and “Next” buttons at the bottom of the “Error Checking” dialog box to move through the malfunctioning formulas in your worksheet without “ignoring” them.

11. When you finish viewing all of the errors in your formula cells, you will see a small dialog box that appears, telling you that the error check is complete. Click “OK” to finish your error checking.

USING THE WATCH WINDOW:

1. Click the “Watch Window” button in the “Formula Auditing” group on the “Formulas” tab in the Ribbon. That will open the “Watch Window” dialog box.

2. In this dialog box, click the “Add Watch…” button at the top of the dialog box to set a cell to watch in this window. Then, with the “Add Watch” dialog box open, click and drag over the adjacent cells in the sheet that you want to watch. If the cells are non-adjacent, you can hold down “Ctrl” on your keyboard and click on non-adjacent cells to select them.

3. Once you have made your cell selections, click “Add” to return to the “Watch Window.” The cell references that you added will be listed individually in this window pane.

4. To delete an entry from the “Watch Window,” click on the reference in the “Watch Window” that you want to delete.

5. Then click the “Delete Watch” button at the top of the “Watch Window” to delete the selected reference.

6. When you are finished with the “Watch Window,” close it by clicking the “X” in the upper right corner of the “Watch Window.”

APPLYING CELL VALIDATION:

1. Select the cell or cell range upon which you wish to place data entry restrictions.

2. Click the “Data Validation” button shown in the “Data Tools” group on the “Data” tab in the Ribbon. In the “Data Validation” dialog box that opens there are three tabs: “Settings,” “Input Message,” and “Error Alert.”

3. Click the “Settings” tab to set the range of allowable values for the selected cell or cells. You use the “Allow” drop-down to select a restriction criteria. You can select “Whole Number” or “Decimal” to restrict the cell entry to values within a specified limit. Next, you would use the “Data:” drop-down to select a comparison criteria. You then specify the value or values within which data entry will be allowed.

(cont’d.)
APPLYING CELL VALIDATION (CONT’D.):

4. You can select the “List” choice from the “Allow:” drop-down on the “Settings” tab to restrict data entry in the selected cells to a list of cell values shown in the worksheet. Next, you would click the “Collapse Dialog” button at the right end of the “Source:” text box to collapse the “Data Validation” dialog box to a single line. Then click and drag over the cells that you want to use as the list of values from which the user can select. The list you select must be on the same worksheet as the cell to which you are applying the cell validation. Click the “Expand Dialog” button at the right end of the text box to expand the dialog box again. To the right of the “Data Validation” dialog box, you can check the “In cell dropdown” to set the cell’s data entry method to be a drop-down list from which the user can select a displayed choice.

5. You can select “Date” or “Time” from the “Allow:” drop-down to restrict data entry in the selected cell or cells to a range of dates or times. Then use the “Data:” drop-down to select a comparison operator for your criteria. Use the “Start Date:” or “Start Time:” and (if needed) the “End Date:” or “End Time:” text boxes to set the date or time range by which you wish to restrict data entry.

6. You can select “Text Length” from the “Allow:” drop-down to restrict the length of text entries in cells. Once again, you would use the “Data:” drop-down to select a comparison operator and then use the “Minimum:” and/or the “Maximum:” text boxes to set the upper and lower limits of the text for data entry.

7. You can select “Custom” from the “Allow:” drop-down to enter a logical formula or select a logical formula cell in the “Formula:” text box. A logical formula has to evaluate to either “True” or “False.” This indicates whether or not to allow data entry in the cell.

8. After selecting what data to allow on the “Settings” tab, note that you can check or uncheck the “Ignore blank” checkbox for most selections. To allow null (empty) cells as being a valid entry, then check this box. To disallow blank cells as valid entries, clear the check box. Note that if you have a reference to a range with a blank cell in it for the allowed values of the cell, then checking the “Ignore blank” checkbox will allow any cell value to be entered into the cell as valid data.

9. Next, click the “Input Message” tab in the “Data Validation” dialog box. Here you can set an option message to display when the cell is selected for data entry. You have to check the “Show input message when cell is selected” checkbox. Then you can type a title for the message box that will appear when the user selects this cell into the “Title:” text box. Type the message that you want the user to see into the “Input message:” text box. When the user click onto this cell in the worksheet they will see a cell comment appear next to the cell. They can click and drag the message box to a different location in the worksheet if they find it to be in the way when they select the cell for data entry.

10. You can click the “Error Alert” tab to set how Excel will respond to invalid data entry in the cell. Make sure that the “Show error alert after invalid data is entered” checkbox is checked to enable this feature. Then use the “Style:” drop-down to set the icon that will appear in the error dialog box. You will see the icon shown below the “Style:” drop-down. Type the title for the error message box into the “Title:” text box. Then type the text of your error message into the “Error Message:” text box.

11. Once you have set the data validation that you want to the currently selected cells in the worksheet, click “OK” to apply the data validation.

12. When you apply data validation on cells that have pre-existing values, the existing values will not be checked against the new cell validation rules. So, you can have data that breaks the validation rules that you have applied. If you want to check to see if there are any cells with invalid data entries, click the “Data Validation” drop-down button on the “Data Tools” group on the “Data” tab in the Ribbon. Then select the “Circle Invalid Data” command from the drop-down button’s menu of choices. This will circle the invalid entries with a red circle in the worksheet. You can then edit the values of the circled cells.

(cont’d.)
APPLYING CELL VALIDATION (CONT’D.):

13. To remove the red circles around the invalid data, you can click the “Data Validation” drop-down button on the “Data Tools” group on the “Data” tab in the Ribbon. Then select the “Clear Validation Circles” command from the drop-down button’s menu of choices to remove them.

14. If you want to edit the restrictions placed on a cell through cell validation, select the cell that you want to edit and click the “Data Validation” button shown in the “Data Tools” group on the “Data” tab in the Ribbon. This will launch the “Data Validation” dialog box again, where you can change the settings as desired. If you change one cell of several cells that have the same cell validation rule applied, you can check the “Apply these changes to all other cells with the same settings” checkbox at the bottom of the “Settings” tab in the “Data Validation” dialog box and then click “OK” to apply the change not only to the selected cell, but also to all other cells in the worksheet that had the same data validation settings applied.

15. To clear cell validation after applying it to a cell or cells in a worksheet, select the cell or cells from which you want to remove the cell validation. Then click the “Data Validation” button shown in the “Data Tools” group on the “Data” tab in the Ribbon. Click the “Clear All” button in the lower left corner of the “Data Validation” dialog box to remove all cell validation settings from the selected cells.
EXERCISES- Auditing Worksheets

**Purpose:**
1. Displaying precedent and dependent cell arrows.
2. Removing auditing arrows.

**Exercises:**

1. Open up the “Inter- Sample” workbook in your “Documents” folder that has been completed through the Exercise at the end of the previous chapter.
2. Select “Sheet1.”
3. Select cell B3.
4. Click the “Trace Dependents” button in the “Formula Auditing” group on the “Formulas” tab in the Ribbon.
5. Double-click on the black arrow that appears to open the “Go To” dialog box.
6. Select the cell reference shown in the dialog box and then click the “OK” button.
7. Select the “Sheet1” worksheet again.
8. Click the “Remove Arrows” button in the “Formula Auditing” group on the “Formulas” tab in the Ribbon.
9. Click the “Save” button in the Quick Access Toolbar to save your changes.
10. You can then close the workbook.
CHAPTER 18 - Outlining Worksheets

18.1 - Using Outlines

18.2 - Applying and Removing Outlines
18.1- Using Outlines:

Outlining a worksheet adds an additional organizational quality to a long or wide worksheet. Outlines group worksheet data into different levels based on column and row headings. Lower level data is associated with the headings in the rows or columns. To apply an outline, though, you must have a structured worksheet that would benefit from outlining. Usually, large worksheets that have column and row headings, detail data, and totals or subtotals can benefit from outlining.

Once applied, the outline can be expanded to view any pertinent detail data. They can also be collapsed to hide the detail data, but still show totals. This makes outlining larger, organized worksheets an excellent idea as it will minimize the scrolling that you have to do to access the data that you want to see. You can also see labels and totals that normally would be difficult to see simultaneously because of their distance of separation within the columns and rows of the worksheet.

When an outlined section is expanded, you can see all of the data in that section. Also, a minus (-) sign will appear above the section. If you click the minus sign, the section will collapse, hiding the detail data. The minus sign will also turn into a plus sign (+) indicating that there is detail data being hidden. Clicking the plus sign will expand the section again. You may also click the small “1” and “2” numbers at the left end or top of the outline section to view the first level or second level of details data. It is also possible to have multiple levels of outlining in the same section.

18.2- Applying and Removing Outlines:

You can apply an outline to a selected range of cells by first selecting the cell range to which you want to apply an outline and then clicking the “Group” button in the “Outline” group on the “Data” tab in the Ribbon. This will launch the “Group” dialog box where you select whether to group the rows or columns of your cell selection. Then click the “OK” button to apply an outline to the columns or rows.

To remove an outline, just select the cell range to which you applied the outline and then click the “Ungroup” button in the “Outline” group on the “Data” tab in the Ribbon. This will launch the “Ungroup” dialog box from which you will select whether to ungroup the rows or columns of your selection. Then click the “OK” button to remove the outlining from the selection’s columns or rows.

You can also apply an auto outline to an entire worksheet. Just select any cell in the worksheet area and then click the drop-down “Group” button in the “Outline” group on the “Data” tab in the Ribbon. Select the “Auto Outline” command from the drop-down menu of choices. The worksheet will be automatically outlined depending on the logical structure that you have applied to the worksheet’s creation. It is quick and easy to outline an entire worksheet this way.

To remove an auto outline that you have applied, just click the drop-down “Ungroup” button in the “Outline” group on the “Data” tab in the Ribbon. Then select the “Clear Outline” command from the button’s drop-down menu. This will remove any outlining from your worksheet.
COLLAPSING AND EXPANDING AN OUTLINE:

1. To collapse an outline, click the minus sign (-) in the gray outline border over the columns or next to the rows that you want to collapse.
2. To expand an outline, click the plus sign (+) in the gray outline border over the columns or next to the rows that you want to expand.
3. You may also click the small "1" and "2" numbers at the left end or top of the outlined section to view the first level or second level of detail data.

APPLYING AND REMOVING OUTLINES:

1. You can apply an outline to a selected range of cells by first selecting the cell range to which you want to apply an outline and then clicking the “Group” button in the “Outline” group on the “Data” tab in the Ribbon. This will launch the “Group” dialog box where you select whether to group the rows or columns of your cell selection. Then click the “OK” button to group the selected columns or rows.
2. To remove an outline, just select the cell range to which you applied the outline and then click the “Ungroup” button in the “Outline” group on the “Data” tab in the Ribbon. This will launch the “Ungroup” dialog box from which you will select whether to ungroup the rows or columns of your selection. Then click the “OK” button to remove the outlining from the selection’s columns or rows.
3. You can also apply an auto outline to an entire worksheet. Just select any cell in the worksheet area and then click the drop-down “Group” button in the “Outline” group on the “Data” tab in the Ribbon. Select the “Auto Outline” command from the drop-down menu of choices. The worksheet will be automatically outlined depending on the logical structure that you have applied to the worksheet’s creation. It is quick and easy to outline an entire worksheet this way.
4. To remove an auto outline that you have applied, just click the drop-down “Ungroup” button in the “Outline” group on the “Data” tab in the Ribbon. Then select the “Clear Outline” command from the button’s drop-down menu. This will remove any outlining from your worksheet.
EXERCISES - Outlining Worksheets

Purpose:
1. To apply and remove an outline.

Exercises:
1. Open up the “Inter-Sample” workbook in your “Documents” folder that has been completed through the Exercise at the end of the previous chapter.
2. Click the “Sheet3” worksheet tab.
3. Click into cell B9 in the worksheet.
4. Double-click the “AutoSum” button in the “Function Library” group on the “Formulas” tab in the Ribbon.
5. Click the drop-down arrow below the “Group” button in the “Outline” group on the “Data” tab in the Ribbon.
6. Select the “Auto Outline” command from the button’s drop-down menu.
7. Click the small minus sign (-) that appears at the left edge of the screen to collapse the detail data.
8. Click the small plus sign (+) that appears at the left edge of the screen to expand the detail data.
9. Click the drop-down arrow below the “Ungroup” button in the “Outline” group on the “Data” tab in the Ribbon.
10. Select the “Clear Outline” command from the button’s drop-down menu.
11. Click the “Save” button in the Quick Access Toolbar to save your changes.
12. You can then close the workbook.
CHAPTER 19 - CONSOLIDATING WORKSHEETS

19.1- CONSOLIDATING DATA
19.1- Consolidating Data:

Consolidating data refers to making a worksheet that adds, subtracts, or performs some other mathematical operation on information gathered from multiple other worksheets. For example, if you had a workbook that had quarterly accounting balances on four separate worksheets, you could create a single consolidated worksheet that adds the data from the four separate worksheets into a single annual worksheet. You can consolidate data from up to 255 different sources. You can even create links to the original source data from the consolidated sheet that will allow it to be updated when information in one of the original worksheets changes. When used in this way, consolidating worksheets become akin to performing a very large paste special.

Before you perform a consolidation, be sure that you have opened all of the workbooks that contain data that you want to consolidate. You will need to make references to the cells that contain the data needed for the consolidation, and the references are much easier to create when the workbooks are opened.

Next, you must select the destination cell for the results first. This is the cell that will be used as the upper left corner of the final, consolidated data. Once you have this cell selected, you can click the “Consolidate” button in the “Data Tools” group on the “Data” tab in the Ribbon. This will open the “Consolidate” dialog box.

In the “Consolidate” dialog box, you use the “Function” drop-down to select the mathematical operation you want to perform on the consolidated data.

Next, you need to enter references to the cells in the worksheets that you want to consolidate into the “All references:” list. You use the “Reference:” text box to add the individual worksheet references to the “All references:” list. To do this, click the “Expand/Collapse Dialog Box” button at the right end of the “Reference:” text box to collapse the entire “Consolidate” dialog box down to only the “Reference:” line. Then simply click on the worksheet that contains the first cell range that you want to consolidate. In this worksheet, you then click and drag over the cells that you want to use as the first reference in your consolidation. Then click the “Expand/Collapse Dialog Box” button at the right end of the “Reference:” text box to expand the “Consolidate” dialog box back into view. To add the reference that you just made into the “All references:” list, click the “Add” button to the right of the “All references:” list to add the reference currently shown in the “Reference:” text box into the list. Then repeat the whole process of selecting cell references until you have added all of the cell references needed by the consolidation into the “All references:” list.

Next, you need to determine how to consolidate the information in the cell references. The references can either be consolidated by category or by position. When you create a worksheet that is consolidated by category, the row and/or column headings used in each reference become the categories by which Excel will consolidate the data in the final consolidated worksheet. For example, if you are consolidating multiple worksheets that have the exact same heading (“Quarter 1,” “Quarter 2,” etc...), then you will probably want to consolidate by category. This allows Excel to use the headings to consolidate the data, even if they aren’t in the same place within each worksheet from which you are consolidating!

Also note that when you consolidate by category it is imperative that you select the row and column headings in addition to the data that you want to consolidate from each worksheet reference, so that Excel can consolidate the data based on matching the category names. Note that you must check either or both checkboxes for the “Top row” and/or “Left column” in the “Use label in” section in the lower left corner of the “Consolidate” dialog box, based upon where the labels are in the cell references that you selected. Excel will consolidate the data using the labels that are in the position that you indicate. This is a must when you consolidate by category.

You can also choose to consolidate worksheet data by its position in the reference. In this case,
19.1- Consolidating Data (cont'd.):

Excel doesn't care what the titles of the rows or columns are. They shouldn't even be selected in your references when consolidating by position. All that Excel needs to know when consolidating by position is where the data is in the worksheet reference. If consolidating by position, you must use worksheets that have the data that you want to consolidate in the exact same position in each referenced worksheet for this to work properly and have the resultant consolidated data have any worthwhile meaning. When using this method Excel simply performs consolidation of the data based on its physical location (cell addresses) within the worksheet references that you select. Note that to consolidate by position, you simply do not check anything in the “Use labels in” section of the “Consolidate” dialog box.

Finally, you must decide whether or not to check the checkbox for “Create links to source data.” This checkbox, if checked, will create a link back to the original data sources in the final consolidated data, updating the consolidation when the original data changes. If you choose this method, your resultant consolidated data will contain actual references back to the source data cells. These inserted columns or rows contain a reference to the original data. Excel then outlines and hides these references, so that the consolidated data appears like a normal outlined worksheet. You can click the plus and minus signs on the consolidated worksheet to view the detail data it received from the original worksheet references.

Note that if you do not check the “Create links to source data” checkbox, then Excel will simply insert the consolidated data values into the destination area. However, if values in one of the original data source changes, it will not update the consolidated data.

Once you are ready to perform the consolidation, just click the “OK” button in the “Consolidate” dialog box.
CONSOLIDATING DATA:

1. Before you perform a consolidation, be sure that you have opened all of the workbooks that contain data that you want to consolidate.
2. Next, you must select the destination cell for the results first. This is the cell that will be used as the upper left corner of the final, consolidated data.
3. Once you have this cell selected, you can click the “Consolidate” button in the “Data Tools” group on the “Data” tab in the Ribbon. This will open the “Consolidate” dialog box.
4. In the “Consolidate” dialog box, you use the “Function:” drop-down to select the mathematical operation you want to perform on the consolidated data.
5. Next, you need to enter references to the cells in the worksheets that you want to consolidate into the “All references:” list. You use the “Reference:” text box to add the individual worksheet references to the “All references:” list.
6. To do this, click the “Expand/Collapse Dialog Box” button at the right end of the “Reference:” text box to collapse the entire “Consolidate” dialog box down to only the “Reference:” line.
7. Then simply click on the worksheet that contains the first cell range that you want to consolidate. In this worksheet, you then click and drag over the cells that you want to use as the first reference in your consolidation. Then click the “Expand/Collapse Dialog Box” button at the right end of the “Reference:” text box to expand the “Consolidate” dialog box back into view.
8. To add the reference that you just made into the “All references:” list, click the “Add” button to the right of the “All references:” list to add the reference currently shown in the “Reference:” text box into the list.
9. Then repeat steps 6 through 8 until you have added all of the cell references needed by the consolidation into the “All references:” list.
10. If consolidating by category, be sure to select the row and column headings in addition to the data that you want to consolidate from each worksheet reference, so that Excel can consolidate the data based on matching the category names. Note that you must check either or both checkboxes for the “Top row” and/or “Left column” in the “Use label in” section in the lower left corner of the “Consolidate” dialog box, based upon where the labels are in the cell references that you selected. Excel will consolidate the data using the labels that are in the position that you indicate. This is a must when you consolidate by category.
11. If consolidating by position, you must use worksheets that have the data that you want to consolidate in the exact same position in each referenced worksheet for this to work properly. Also, you do not need to select the column or row labels in the individual references. When using this method Excel simply performs consolidation of the data based on its physical location (cell addresses) within the worksheet references that you select. Note that to consolidate by position, you simply do not check anything in the “Use labels in” section of the “Consolidate” dialog box.
12. Finally, you must decide whether or not to check the checkbox for “Create links to source data.” This checkbox, if checked, will create a link back to the original data sources in the final consolidated data, updating the consolidation when the original data changes.
13. Note that if you do not check the “Create links to source data” checkbox, then Excel will simply insert the consolidated data values into the destination area. However, if values in one of the original data source changes, it will not update the consolidated data.
14. Once you are ready to perform the consolidation, just click the “OK” button in the “Consolidate” dialog box.
EXERCISES-
Consolidating Worksheets

Purpose:

1. Consolidate worksheets by category.

Exercises:

1. Open up the “Inter- Sample” workbook in your “Documents” folder that has been completed through the Exercise at the end of the previous chapter.
2. Select the “Sheet3” worksheet tab.
3. Click cell A12.
4. Click the “Consolidate” button in the “Data Tools” group on the “Data” tab in the Ribbon. This will open the “Consolidate” dialog box.
5. From the “Function:” drop-down, select “Sum.”
6. Click into the “Reference” text box, and then click the red, white and blue “Collapse/Expand Dialog Box” button at the right end of the “Reference” text box.
7. Click the “Sheet1” sheet, and select cells A3:B6.
8. Click the red, white and blue “Collapse/Expand Dialog Box” button at the right end of the “Reference” text box to expand the “Consolidate” dialog box.
9. Click the “Add” button to add the selected reference to the “All references:” list.
10. Click the red, white and blue “Collapse/Expand Dialog Box” button at the right end of the “Reference” text box to collapse the “Consolidate” dialog box again.
11. Click the “Sheet2” sheet, and select cells A3:B6.
12. Click the red, white and blue “Collapse/Expand Dialog Box” button at the right end of the “Reference” text box to expand the “Consolidate” dialog box.
13. Click the “Add” button to add the selected reference to the “All references:” list.
14. Click the check box for “Left Column” in the “Use labels in” section.
15. Remove the checkbox from “Create links to data source,” if one is present.
16. Click the “OK” button.
17. Click the “Save” button in the Quick Access Toolbar to save your changes.
18. You can then close the workbook.
CHAPTER 20 - Tables

20.1 - Creating a Table

20.2 - Adding and Editing Records

20.3 - Inserting Records and Fields

20.4 - Deleting Records and Fields
20.1- Creating a Table:

Excel can store information in tables. An Excel table is information stored in a table format and defined as being a table within Excel. When you store information in a table format, you place the different types of information that you want to collect in columns, which are called “fields” in database terminology. Each “field” contains a separate type of information. Examples could be: “First Name,” “Last Name,” “Title,” “Address,” “City,” “State,” and so forth. Each row in the table is called a “record.” A record is a single entry in which you record each type of field information about the subject of your table. For example, within a “Customers” table that contains the fields in the previous example, a record in that table might contain the information: “John,” “Doe,” “Mr.,” “111 Nowhere Ln.,” “Holt,” “MI.”

When entering data into a table, avoid creating entirely blank columns or rows! Having blank columns and rows within a table can often lead to problems with sorting and filtering table data.

Before you create a table in Excel, you need to consider what information you want to collect. Sometimes, it is easier to think of what fields to create after thinking of the subject of the table, first. For example, if you wanted to create a table to record customer data, you would need to think about what information you want to collect about your customers. The types of information that you decide to track will become the “fields” (columns) in your table.

For the purpose of the example, assume that you decided to record your customer’s name, address, city, state, and zip code. When thinking of the field structure of the table, you need to consider just how detailed you want to be with the customer’s information. Poor decisions in the planning phase can be problematic later. For example, do you want to record the customer’s name in one field or in more than one field? If you ever want to sort the database by the last name of the customer, you will probably want to store the customer’s name in at least two fields: “firstname” and “lastname.” Noting little things like this during the creation process can save time in editing the table structure later on, after it becomes a problem. Once you have decided what information you would like to record in which field, you enter the titles of these fields as the top row of your table. The top row in your table is a special row and is often called the “header row.” It is always the top row in a table, and it displays the names of the fields for which you are collecting data.

Once you have the header row created, you can then define it as a being a “table” to enable the table management features of Excel. To do this, select the cells within the header row and then click the “Table” button in the “Tables” group on the “Insert” tab in the Ribbon. In the “Create Table” dialog box that appears, you will see the reference to the selected cells appear in the “Where is the data for your table?” text box. Check the “My table has headers” checkbox and then click the “OK” button. This will then create the table area within the worksheet and add a new row into which you can enter your first table record.

Another way to create a table in Excel is to create the header row of your table and then enter as many records as you would like to initially record. Then click and drag over the entire table, including the header row and all records entered, to select it. Once it has been selected, click the “Format as Table” button in the “Styles” group on the “Home” tab within the Ribbon. You can then select the desired table style to apply from the drop-down menu shown. At this point, the “Format As Table” dialog box will appear. The range of selected cells should appear within the “Where is the data for your table?” field. If your table has a header row at the top of the table, be sure to check the “My table has headers” checkbox. Then click the “OK” button to apply the selected style, as well as define the range of cells as being a table.

Note that each field within the header row of a table has a drop-down button within it. These are “AutoFilters,” which are used to filter data in the table. We will look at using those in a later lesson. Also notice that the table has a different formatting than the rest of the worksheet area. This table style encloses any records that you want to identify as being part of your table. Note that you can place your mouse pointer over the lower right corner of the table, until you see a double-pointed black arrow appear, and then click and drag right or down with your mouse to resize the table border to include new rows or columns, if needed.
20.2- Adding and Editing Records:

Once you have created the field structure of the table and labeled the fields within the header row, you are then ready to enter your first table record. A record is simply all of the information, determined by the fields within the header row, that pertains to a single entry. Using the example of a “Customers” table, a record would be all of the information that pertains to a single customer. You enter the first record into a table immediately underneath the header row. Use the “Tab” key on your keyboard to move between cells within a row, as well as to the next new row after you have finished entering one record to automatically add a new row to the table where you can then enter your next record.

Each piece of information recorded should match the corresponding field into which it is entered. For example, if you have a customer table with the fields: “Title,” “FirstName,” and “LastName,” and a customer named “Mrs. Jane Smith;” then her record would look like this in the table: [Mrs.] [Jane] Smith]. Additional records are always appended to the next row in the table, never entirely skipping a row.

After you have created your table and entered your records, you can edit the information in the cells just as you would in a normal worksheet. Just select the cell that contains the information that you want to edit and then change it. Use the “Tab” key to exit and move to the next cell in the table when finished with data entry. Just as when entering records, you can also format any records or information as desired.

20.3- Inserting Records and Fields:

You can also insert records or fields into a database in the middle of the table rather than appending them onto the bottom row of the table or onto the right column of the table. This is the same process used to insert new columns or new rows. So the number of columns or rows that you select will be the number that you insert. Also, new columns will insert to the left of the selection and new rows will insert above the selection. You start by clicking and dragging over the headings of the columns or rows, selecting the number to insert. You can then right-click on the selected headings. From the pop-up menu that appears, select the “Insert” command. Remember to fill the new columns or rows with data so that you do not have any entirely blank rows or columns in your table.

20.4- Deleting Records and Fields:

You can also delete records or fields from a database by right-clicking on the column or row heading and then selecting “Delete” from the pop-up menu that appears. Note that this will remove the entire column or row, allowing the database to remain intact with no skipped columns or rows. Make sure that you do not simply select some cells and then clear their contents as this tends to leave entirely blank columns and rows, which you should not have in a table.
CREATING A TABLE:

1. Select the cell into which you want to type your first field name.
2. Type the field name, and then press the “Tab” key on your keyboard to move to the cell to the right.
3. Repeat step 2 until you have made your entire header row.
4. Select the header row by clicking and dragging over the cells that contain the header row labels.
5. Click the “Table” button in the “Tables” group on the “Insert” tab in the Ribbon.
6. In the “Create Table” dialog box, check the “My table has headers” checkbox.
7. Click “OK.”

ADDING NEW RECORDS TO A TABLE:

1. Select the first field cell in the next available empty row within the table.
2. Type the information into the field.
3. Press “Tab” on your keyboard to move to the cell to the right.
4. Enter the appropriate data for that field.
5. Repeat steps 3 and 4 until the new record is fully entered. Then press the “Tab” key on your keyboard to create a new blank row for the next record.

EDITING TABLE RECORDS:

1. Select the cell that contains data that you want to edit.
2. Make any changes to the data as necessary.
3. Press “Tab” on your keyboard to exit the cell and save your changes.

CREATING A TABLE USING THE “FORMAT AS TABLE” COMMAND:

1. Create the header row of the table and then enter as many records as you would like to initially record.
2. Click and drag over the entire table, including the header row and all records entered, to select it.
3. Once it has been selected, click the “Format as Table” button in the “Styles” group on the “Home” tab within the Ribbon.
4. You can then select the desired table style to apply from the drop-down menu shown.
5. At this point, the “Format As Table” dialog box will appear.
6. The range of selected cells should appear within the “Where is the data for your table?” field.
7. If your table has a header row at the top of the table, be sure to check the “My table has headers” checkbox.
8. Then click the “OK” button to apply the selected style, as well as define the range of cells as being a table.

ADDING NEW RECORDS TO A TABLE:

1. Select the first field cell in the next available empty row within the table.
2. Type the information into the field.
3. Press “Tab” on your keyboard to move to the cell to the right.
4. Enter the appropriate data for that field.
5. Repeat steps 3 and 4 until the new record is fully entered. Then press the “Tab” key on your keyboard to create a new blank row for the next record.

INSERTING NEW ROWS INTO A TABLE:

1. Right-click on the row heading of the row that is above the row where you want to insert the new row.
2. Select “Insert” from the pop-up menu that appears.
3. Move into the new row that you inserted and enter all of the information for that record.
**INSERTING NEW FIELDS INTO A TABLE:**

1. Right-click on the column heading to the right of where you would like to insert the new column.
2. Select the “Insert” command from the pop-up menu that appears.
3. Select the cell that is in the header row and type the label for the new field.
4. Press “Enter” on your keyboard to exit the cell and move down into the column.
5. Enter the new field’s information for all of your existing records, if needed.

**DELETING COLUMNS AND ROWS FROM A TABLE:**

1. Select the column headings or row headings for the fields or records you want to delete.
2. Right-click the selected headings.
3. Select “Delete” from the pop-up menu that appears.
### Purpose:

1. To be able to create a table in Excel.

### Exercises:

1. Open up the Excel application.
2. Create a new blank workbook.
3. Enter the data into the workbook region shown in the picture below in “Sheet1” of the new workbook.
4. Select the data that you have entered, including the header row.
5. Click the “Table” button in the “Tables” group on the “Insert” tab in the Ribbon.
6. In the “Create Table” dialog box, ensure that there is a check in the “My table has headers” checkbox, and then click the “OK” button. Your table should appear as shown in the picture below when you select a cell within the table area.

<table>
<thead>
<tr>
<th></th>
<th>Region</th>
<th>Salesperson</th>
<th>City</th>
<th>Quarter</th>
<th>Month</th>
<th>Date</th>
<th>Daily Sales</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>North</td>
<td>Joy Jameson</td>
<td>Lansing</td>
<td>First</td>
<td>Jan</td>
<td>1/2/2007</td>
<td>3,426.00</td>
</tr>
<tr>
<td>2</td>
<td>North</td>
<td>Ken Sterling</td>
<td>Lansing</td>
<td>First</td>
<td>Jan</td>
<td>1/2/2007</td>
<td>2,203.00</td>
</tr>
<tr>
<td>3</td>
<td>North</td>
<td>Joshua Smith</td>
<td>Lansing</td>
<td>First</td>
<td>Jan</td>
<td>1/2/2007</td>
<td>417.00</td>
</tr>
<tr>
<td>4</td>
<td>North</td>
<td>Donna Smith</td>
<td>Detroit</td>
<td>First</td>
<td>Jan</td>
<td>1/2/2007</td>
<td>7,012.00</td>
</tr>
<tr>
<td>5</td>
<td>North</td>
<td>Jeffrey Richards</td>
<td>Detroit</td>
<td>First</td>
<td>Jan</td>
<td>1/2/2007</td>
<td>6,407.00</td>
</tr>
<tr>
<td>6</td>
<td>North</td>
<td>Mekhi Jones</td>
<td>Detroit</td>
<td>First</td>
<td>Jan</td>
<td>1/2/2007</td>
<td>4,703.00</td>
</tr>
<tr>
<td>7</td>
<td>North</td>
<td>Laverne Lawless</td>
<td>Chicago</td>
<td>First</td>
<td>Jan</td>
<td>1/2/2007</td>
<td>8,179.00</td>
</tr>
<tr>
<td>8</td>
<td>North</td>
<td>Sara Swanson</td>
<td>Chicago</td>
<td>First</td>
<td>Jan</td>
<td>1/2/2007</td>
<td>5,391.00</td>
</tr>
<tr>
<td>9</td>
<td>North</td>
<td>Hector Veracruz</td>
<td>Chicago</td>
<td>First</td>
<td>Jan</td>
<td>1/2/2007</td>
<td>1,115.00</td>
</tr>
<tr>
<td>10</td>
<td>North</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

7. Click the “Save” button within the Quick Access toolbar.
8. The “Save As” dialog box will appear in Excel 2010:2007. If using Excel 2013, click the “Computer” choice within the “Save As” backstage view and then click the “Browse” button to the right to open the “Save As” dialog box.
9. Use the “Save As” dialog box to save the file to the “Documents” folder on your computer, and name the file “Table Sample.”
10. Click the “X” button in the upper right corner of the application window to exit.
CHAPTER 21 - Sorting Data

21.1 - Sorting Data

21.2 - Custom Sort Orders
21.1- Sorting Data:

Any table can be sorted using any of the fields available. Sorting is one of the main reasons that you create tables. It allows you to easily organize information in the table records. By default, Excel can sort alphabetically or numerically in either “ascending” (A-Z, 1-9) or “descending” (Z-A, 9-1) order. It will sort from top to bottom by default but it can also be set to sort from left to right, if necessary. You can sort a table by the values within a single column in a table or by the values within multiple columns.

When you sort data, you need to choose the fields used to sort the data and the order used to sort the data. For example, if you primarily sorted a table by the “LastName” field, there might be multiple entries with the same last name. That is when applying a secondary sort, by the “FirstName” field for example, can ensure that records are sorted in alphabetical order by last name, then by first name.

To sort a table by a single column, click into a cell within the column by which to sort the data. Then click either the “Sort A to Z” or “Sort Z to A” buttons in the “Sort & Filter” group on the “Data” tab in the Ribbon to sort the table in either ascending or descending order by the column’s values. You can perform a multi-column sort on a table by first clicking into the table and then clicking the “Sort” button in the “Sort & Filter” group on the “Data” tab in the Ribbon. In the “Sort” dialog box that appears, just use the first “Sort by” drop-down to select the name of the first column by which you want to sort the data. This is called the “primary sort.” To the right of that, ensure that the “Sort On” drop-down is set to “Values.” Then select the desired option for the primary sort order: “A to Z,” “Z to A,” or “Custom List…”

You can then add more sorting levels by clicking the “Add Level” button. You can then repeat the process using the next sorting row to create additional sorting levels, if desired. When you have finished adding all of the desired sorting levels into this dialog box, click the “OK” button to apply the sorting that you set. If you make a mistake after sorting data, you can undo it by clicking the “Undo” button in the Quick Access toolbar immediately after performing the sort.

You can delete sorting that has been applied to a table by simply clicking the “Sort” button in the “Sort & Filter” group on the “Data” tab in the Ribbon, and then selecting the sorting level to delete from the “Sort” dialog box. Then click the “Delete Level” button in the “Sort” dialog box to delete the selected sorting level. Then click the “OK” button when you are finished.

21.2- Custom Sort Orders:

Sometimes you may want to sort data using a sort order that is not alphabetically or numerically ascending or descending. These type of sort orders are called “custom sort orders.” An example of a custom sort order would be the chronological sorting of the days of the week: Sunday, Monday, Tuesday, Wednesday, Thursday, Friday, and Saturday. You can create your own custom sort orders in Excel. Once they are created, custom sort orders are available to all worksheets in Excel.

To create a custom sort order, type the items that you would like to have in the custom sort order down a column in a worksheet. Then click and drag over the items to select them. Next, click the “File” tab in the Ribbon and then click the “Options” command at the left side of the backstage view to open the “Options” dialog box. Then click the “Advanced” category at the left side of the “Options” dialog box.

Scroll down through the options shown in the dialog box, and then click the “Edit Custom Lists…” button when you see it to open the “Custom Lists” dialog box. In this dialog box, you will see a reference to the currently selected cell range shown in the text box in the lower right corner. Click the “Import” button that appears next to the cell reference to import the contents of the selected cells into the “List entries:” box. The custom sort order will then appear in the “Custom lists:” box at the left side of this tab.

Note that you can also delete custom lists that you have created in this tab, as well. To delete a
21.2- Custom Sort Orders (cont.):

custom list that you have created, select it from the “Custom lists:” list box at the left side of this tab. Then click the “Delete” button at the right side of this tab. You will have to click “OK” in the confirmation dialog box that appears to delete the selected list.

Another way that you can create a custom list is to simply type the entries that you want in the list into the “List entries” text box within the “Custom Lists” dialog box. Press the “Enter” key on your keyboard after creating each entry to move to a new line and continue entering the list entries. Once you have entered all of the list entries, click the “Add” button to the right to add your list to the “Custom lists” text box. When you are finished creating and deleting lists in this dialog box, click the “OK” button to save your changes. You can then click the “OK” button within the “Options” dialog box to save the changes and close the dialog box.

To apply a custom sort order to a table in Excel, click anywhere into the data table which you want to sort and then click the “Sort” button in the “Sort & Filter” group on the “Data” tab in the Ribbon. In the “Sort” dialog box that appears, use the “Sort by” drop-down to select the name of the field that contains the data to which you want to apply a custom sort order. Next, use the “Sort On” drop-down to select what you want to sort. This will typically be “Values.” Then click the “Order” drop-down and select “Custom List...” from the drop-down menu. In the “Custom Lists” dialog box, select the custom sort order to use, and then click “OK” to return to the “Sort” dialog box. Here you can then click “OK” to apply the custom sort to the specified field.
SORTING DATA:

1. To sort a table by a single column, just click into a cell within the column by which you’d like to sort the data. Then click either the “Sort A to Z” or “Sort Z to A” buttons in the “Sort & Filter” group on the “Data” tab in the Ribbon to sort the table in either ascending or descending order by the column’s data values.
2. You can perform a multi-column sort on a table by first clicking into the table and then clicking the “Sort” button in the “Sort & Filter” group on the “Data” tab in the Ribbon.
3. In the “Sort” dialog box that appears, just use the first “Sort by” drop-down to select the name of the first field by which you want to sort the data. To the right of that, ensure that the “Sort On” drop-down is set to “Values.” Then select the desired option for the primary sort order: “A to Z,” “Z to A,” or “Custom List…”
4. You can then add more sorting levels by clicking the “Add Level” button. You can then repeat step 3 above, using the next sorting row to create a additional sorting levels, if desired.
5. When you have finished adding all of the desired sorting levels into this dialog box, click the “OK” button to apply the sorting that you set.
6. If you make a mistake after sorting data, you can undo it by clicking the “Undo” button in the Quick Access toolbar immediately after performing the sort.
7. You can delete sorting that has been applied to a table by simply clicking the “Sort” button in the “Sort & Filter” group on the “Data” tab in the Ribbon, and then selecting the sorting level to delete from the “Sort” dialog box. Then click the “Delete Level” button in the “Sort” dialog box to delete the selected sorting level. Then click the “OK” button when you are finished.

USING CUSTOM SORT CRITERIA:

1. To create a custom sort order, type the items that you would like to have in the custom sort order down a column in a worksheet.
2. Then click and drag over the items to select them.
3. Click the “File” tab in the Ribbon and then click the “Options” command at the left side of the backstage view to open the “Options” dialog box.
4. Then click the “Advanced” category at the left side of the “Options” dialog box.
5. Scroll down through the options shown in the dialog box, and then click the “Edit Custom Lists…” button when you see it to open the “Custom Lists” dialog box.
6. In this dialog box, you will see a reference to the currently selected cell range shown in the text box in the lower right corner.
7. Click the “Import” button that appears next to the cell reference to import the contents of the selected cells into the “List entries:" box.
8. The custom sort order will then appear in the “Custom lists:" box at the left side of this tab.
9. Another way to create a custom list is to simply type the entries that you want in the list into the “List entries” text box within the “Custom Lists” dialog box.
10. Press the “Enter” key on your keyboard after creating each entry to move to a new line and continue entering the list entries.
11. Once you have entered all of the list entries, click the “Add” button to the right to add your list to the “Custom lists” text box.
12. To delete a custom list that you have created, select it from the “Custom lists:" list box at the left side of this tab.
(cont'd.)
USING CUSTOM SORT CRITERIA (CONT’D.):

13. Then click the “Delete” button at the right side of this tab.
14. You will have to click “OK” in the confirmation dialog box that appears to delete the selected list.
15. When you are finished creating and deleting lists in this dialog box, click the “OK” button to save your changes.
16. You can then click the “OK” button within the “Options” dialog box to save the changes and close the dialog box.
17. To apply a custom sort order to a table in Excel, click anywhere into the data table which you want to sort and then click the “Sort” button in the “Sort & Filter” group on the “Data” tab in the Ribbon.
18. In the “Sort” dialog box that appears, use the “Sort by” drop-down to select the name of the field that contains the data to which you want to apply a custom sort order.
19. Next, use the “Sort On” drop-down to select what you want to sort. This will typically be “Values.”
20. Then click the “Order” drop-down and select “Custom List…” from the drop-down menu.
21. In the “Custom Lists” dialog box, select the custom sort order to use, and then click “OK” to return to the “Sort” dialog box.
22. Here you can then click “OK” to apply the custom sort to the specified field.
EXERCISES - Sorting Data

Purpose:
1. To be able to sort data in a table.

Exercises:
1. Open up the “Table Sample” workbook.
2. Click cell B3 to select it.
3. Click the “Sort A to Z” button in the “Sort & Filter” group on the “Data” tab in the Ribbon to sort the table by the “Salesperson” field in ascending order.
4. Click the “Sort” button in the “Sort & Filter” group on the “Data” tab in the Ribbon.
5. Use the “Sort by” drop-down to select “City.”
6. Use the “Sort On” drop-down to select “Values.”
7. Use the “Order” drop-down to select “A to Z.”
8. Click the “Add Level” button to create a new sorting level.
9. Use the “Then by” drop-down to select “Daily Sales.”
10. Use the “Sort On” drop-down to select “Values.”
11. Use the “Order” drop-down to select “Largest to Smallest.”
12. Click the “OK” button.
13. Click the “Clear” button in the “Sort & Filter” group on the “Data” tab in the Ribbon.
14. Click the “Save” button in the Quick Access Toolbar to save your changes.
15. Click the “X” button in the upper right corner of the application window to exit.
CHAPTER 22 - FILTERING DATA

22.1 - Using AutoFilters

22.2 - Using the Top 10 AutoFilter

22.3 - Applying a Custom AutoFilter

22.4 - Creating Advanced Filters

22.5 - Applying Multiple Criteria

22.6 - Using Complex Criteria

22.7 - Copying Filtered Results to a New Location

22.8 - Using Database Functions
22.1- Using AutoFilters:

AutoFilter is a useful tool that allows you to quickly filter your data tables. However, you must have a header row in your table for AutoFilter to function. When you create a table in Excel, you automatically have AutoFilter drop-downs placed into the header row for each column. You can toggle the AutoFilters on and off in your table by selecting any cell in your table and then clicking the “Filter” button in the “Sort & Filter” group on the “Data” tab in the Ribbon.

When AutoFilter is enabled, if you click on any of the drop-down arrows on the field headers, you will see a drop-down list of available sorting and filtering options followed by a listing of all of the unique values found within the selected field. You can manually filter a list to ensure that only the values that you want to see are checked within the list of values shown. If you click the “(Select All)” choice when all of the values are checked, it will uncheck all of them. This will allow you to quickly check only the values which you wish to see. When you click the “OK” button, Excel will filter the table to show only records in the table that have a matching value for that field. All of the other records will be hidden, not deleted.

You can tell when a filter is being applied, and to which field it is being applied, because when a filter is being used on a field the drop-down arrow next to that field appears with a small “funnel” icon to let you know that a filter is being applied. You can apply multiple kinds of filters using this tool, and you may also apply more than one filter on a table at a time using the various columns.

Once you have applied an AutoFilter, you can remove it to show all of the records again. One way is to select the AutoFilter drop-down arrow that is currently being applied, and then check the “(Select All)” checkbox from the list of values shown in the drop-down menu and then click the “OK” button to show all of the records that were being hidden by the filter. Alternately, you could also click the “Clear” button in the “Sort & Filter” group on the “Data” tab in the Ribbon.

22.2- Using the Top 10 AutoFilter:

You can apply a special type of filter to number fields called a “Top 10 AutoFilter” that can show you a specified number of the top or bottom percent or items in a field within the table. For example, it defaults to showing the top 10 percent of a column, but you could also change it to show you the bottom 5 items (by value) with a column, as well. Note that this filter cannot be applied to text fields, as they have no numeric ranking by which to base a value.

To apply a “Top 10 AutoFilter,” click the AutoFilter drop-down arrow button next to the column heading for the field by which you want to filter the table. Next, roll down to the “Number Filters” choice. Then select the “Top 10…” option from the side menu that appears to open the “Top 10 AutoFilter” dialog box. In this dialog box, select the first drop-down and pick either “Top” or “Bottom.” Next, enter a number into the spinner box in the center of the dialog box. Finally, use the drop-down on the right to pick either “Items” or “Percent.” What is displayed across the dialog box is the filter setting that you will apply to the selected column. So you could view only the “Top 10 Items,” or “Bottom 40 Percent”, or any other variation using this dialog box. When you have created the desired filter, just click “OK” to apply it.

22.3- Applying a Custom AutoFilter:

You can also display a special type of filter called a “Custom AutoFilter” that you can customize by using any available comparison operator in conjunction with wildcard characters. Using a custom AutoFilter allows you to display records using a custom set of comparison criteria that you create. To apply a custom AutoFilter, just click the AutoFilter drop-down arrow button next to the column header.
22.3- Applying a Custom AutoFilter (cont.):

by which you want to filter the data. Roll down to either the “Text Filters,” “Number Filters” or “Date Filters” command in the drop-down menu. The command name changes depending upon the type of data stored within the column. In the side menu that appears, you will see many of the available comparison operators. You can select one of these, if desired, or you can simply choose the “Custom Filter” command. When you do this, Excel will open the “Custom AutoFilter” dialog box.

In the “Custom AutoFilter” dialog box, you select the desired comparison criteria from the upper left drop-down box. Next to it, in the upper right drop-down box, you can either enter a value or select a value from the drop-down list. If you enter a value, note that you can choose to use wildcard characters to represent unknown data values within the field, if desired. The characters that you can use, and what they represent, are shown in a small listing at the bottom of this dialog box. So, for example, if you entered “J???” as a criteria value, you would filter for 3-character words that start with a “J,” like “Joe,” “Jim,” “Jam,” and others. If you specified “J*” as your filter criteria, you would filter for any word that starts with the character “J,” like “Jennifer,” “Joe,” “Jacob,” and so on, regardless of the length of the word. Wildcard characters can appear before or after the known values to find unknown characters that either proceed, appear between, or follow the known characters.

You can also specify a second filter criteria as you create the first, if you wish. To do this, create the first criteria and then select either the “And” or “Or” option buttons in the middle of the “Custom AutoFilter” dialog box to connect the two conditions that you create. If you select the “And” option, then the value in the field must meet both conditions to be displayed. If you select the “Or” condition, the field values will be displayed if they meet either criteria specified. Next, create the second criteria in the same way that you created the first criteria.

When you have created your own custom filter criteria, just click “OK” to apply the selected criteria to the selected field.

22.4- Creating Advanced Filters:

You can create advanced filters that will allow you to filter data using multiple “And” and “Or” criteria, if necessary. To create an advanced filter, however, you must first create a criteria range within the workbook into which you will enter the criteria to filter your table. A criteria range is a duplicate of the header row of your table that is physically separated from the rest of the table. It must contain a header row of fields that is identical to the header row of the table that you are going to filter. Below this header row, you then enter the criteria against which you want to filter the table.

When creating a criteria range, it may be useful to note that it does not have to be on the same worksheet. You could have one worksheet with the table data, and then a separate worksheet that contains your criteria range or criteria ranges. You can create multiple criteria ranges if you like, but you can only apply one range at a time to the table. No matter where you decide to place the criteria range within your workbook, however, you must leave room between the criteria range and your table if they are contained within the same worksheet! This is very important for the filter to work correctly. Also, the criteria range must be at least one column by two rows in length. This leaves at least one row available for entry of filtering criteria. Also, the field names listed in criteria rows must be spelled exactly as they appear in the table, but are not case-sensitive.

As long as you have created a criteria range that consists of one top row of criteria labels, and at least one row beneath it where you can enter criteria conditions, then you can use the criteria range to create an advanced filter. Before applying the filter, you must enter the necessary criteria conditions under the corresponding fields within the criteria rows in the criteria range. When you have created a criteria range
22.4- Creating Advanced Filters (cont.):
and entered at least one criteria that you want to use as a filter, you are then ready to apply the filter.

To apply the filter, select a cell in the table to which you want to apply the filter, and then click the “Advanced” button in the “Sort & Filter” group on the “Data” tab in the Ribbon. Doing this will open the “Advanced Filter” dialog box.

At the top of the “Advanced Filter” dialog box in the “Action” section, choose the “Filter the table, in-place” option button. The “List range:” text box should show a reference to the table that will be filtered. All you have to do is click into “Criteria range:” text box, and then click and drag over the entire criteria range, including the header row and any criteria rows that you have added, to select it. Make sure your selection encompasses both the labels and the criteria in the criteria range. Then click “OK” to filter your table based on the criteria you supplied.

To remove the filter after applying it, click into the filtered data within your table and then click the “Clear” button in the “Sort & Filter” group on the “Data” tab in the Ribbon. This will then display all of the records in your table again.

22.5- Applying Multiple Criteria:

You can apply multiple criteria to the criteria rows in your criteria range. However, the conditions must be logically joined together using “And” and “Or” statements. You use the “And” condition to specify that a record must meet multiple criteria at the same time to be included in the filtered data. When creating the criteria in the criteria range to apply an advanced filter, you can create multiple criteria and join them together with the “And” condition by simply inserting both the criteria in the same criteria row, under their respective field headings in the criteria range prior to applying the filter.

For example if you had two fields named “Amount” and “Region,” you could place =”>5000” in one row under the “Amount” column and you could place “=North” under “Region” in the same criteria row. As long as you place both of these criteria in the same row, they will be interpreted by Excel as being one criteria with an “And” condition joining them. If you applied this criteria, you would see all the records in your table where the region was listed as “North” and there was more than 5000 dollars in the “Amount” field.

You use the “Or” condition to specify that a record can meet one or more of the criteria to be included in the filtered record set. To specify an “Or” condition, you write your first criteria in one of the criteria rows available, using multiple criteria in the same row for “And” conditions, if needed. Then you place the next set of criteria that you want to look for using an “Or” condition into a separate criteria row directly beneath the first criteria row. You can then apply the advanced filter. However, be sure to select all of the criteria rows that are needed when selecting the criteria range in the “Advanced Filter” dialog box.

Using the aforementioned example, assume that you wanted to see any record in your table where the city was equal to “North” or the record contained an “Amount” greater than 5000. To do this you would have to place =”>5000” under the “Amount” field header in one criteria row and then enter “=North” under the “Region” field header in a separate criteria row. If you then filter the table with this criteria, you would see all of the records in your table where the “Region” field contained “North” or where the “Amount” field was greater than 5000.

It can sometimes be confusing to think of the “And” and “Or” conditions, and be able to pick which one you need at first. Just remember that if you use the “And” condition, a record must meet all of the criteria joined together by the “And” condition to be included in the result set. If you use the “Or” condition, a record can meet any one of the criteria joined by the “Or” condition to be included in the result set.
22.6- Using Complex Criteria:

You have many advanced criteria that you can create in the criteria range to filter your selected table. In this lesson, we will review some of the advanced criteria techniques that you can apply to the criteria entered into the criteria range when creating an advanced filter.

First, it should be mentioned that when you use a comparison operator, the values must be proceeded by the equal sign. However, this causes Excel to evaluate the entry that follows the equal sign as if it were a formula. This can cause unexpected results when using comparison operators with text and number fields. Therefore, you should enter the comparison criteria in the following general format: ="entry" where =entry is the comparison operator and associated text or value by which you wish to filter the field.

Many times when filtering data, you wish to see records where a field’s value is equal to a value entered into the criteria range. In these cases, you would enter ="entry" as the criteria. However, there are many other comparison criteria that you can use for text and number fields. You can use the following comparison operators when creating complex criteria: > (greater than), < (less than), >= (greater than or equal to), <= (less than or equal to), and <> (does not equal). So for example, entering the criteria expression of ="<=>North" under a “Region” field in the criteria range would filter the table to show all records where the “Region” field did not equal “North.”

Also note that you can use wildcard characters to search for unknown values. You can use the asterisk (*) to represent multiple unknown characters and you can use the question mark (?) to represent a single unknown character. To use a wildcard character, just decide under which text field you want to place the criteria and in which criteria row. Then simply use the wildcard characters in conjunction with the known values to search for matching records. For example, if you had a “Last Name” column within which you wanted to display anyone whose last name started with a “J,” you could enter ="=J*” under the “Last Name” column as a wildcard criteria.

It is also possible to create a criteria that matches the first few characters in the field’s values and returns any matching values. This is akin to setting a criteria that looks for fields that “begin with.” In this case, you do not enter any comparison operator into the criteria, but rather enter only the first characters for which you want to find matches. For example, entering “Car” as a criteria underneath a “Last Name” field would return last names that begin with “Car,” like “Carson” and “Carlisle.”

22.7- Copying Filtered Results to a New Location:

You can copy the results of an applied filter to a new location instead of having to always filter the table in its original place. To do this, create your criteria filters as you normally would, then click into the data that you wish to filter, and then click the “Advanced” button in the “Sort & Filter” group on the “Data” tab in the Ribbon.

In the “Advanced Filter” dialog box, choose the option for “Copy to another location” in the “Action” section at the top. Then select the cells that contain your “Table range:” and “Criteria range:” as normal. Next, click into the “Copy to:” text box and then click the cell that will become the upper left corner of the cell range to which you wish to paste the filtered data. Finally, click “OK” to filter the table and copy the results to the location you selected.

One point to note is that when you do copy the results to a new location, the location specified must be in the active worksheet-meaning the worksheet that contains the table that is being filtered.
22.8- Using Database Functions:

You can use the criteria range that you have created to also perform database functions on the data stored in your table. Database functions are much like your typical functions, like “AVERAGE,” “SUM,” or “PRODUCT,” but will only be performed on values in rows that match a certain criteria that you specify.

For example, if you wanted to “SUM” an “Amount” field, but only if the “Region” field was equal to “North,” you could use the database function of “DSUM” to do that. Most of the database functions simply perform your usual mathematical operations, but only for records that match the criteria that you specify. You can view the various database functions by looking at the “Database” category of functions shown in the function drop-down list inside the “Insert Function” dialog box. Note that this function group is NOT displayed by default within the buttons of function categories shown within the “Function Library” button group on the “Formulas” tab within the Ribbon in Excel. You can, however, click the “Insert Function” button within the “Function Library” button group on the “Formulas” tab within the Ribbon to open the “Insert Function” dialog box. Then you can select the “Database” category from the “Or select a category” drop-down to view the database functions available in Excel.

Notice that these database functions are all strikingly similar in the structure of their syntax. Most are simply equivalent to the same mathematical function, but with the letter “D” added to the front. For example, you use the “AVERAGE” function to find the average of selected cells. To use the database average, the function simply becomes “DAVERAGE.” Second, each database function only requires three arguments: “Database,” which is the table cell range reference; “Field,” which is the name of the field (enclosed in double quotes), or the column number of the field that contains the values upon which you want to perform the selected function; and “Criteria,” which is a cell reference to the criteria range which contains the criteria used to decide which rows will be included in the function. The criteria range is exactly the same as the criteria range that you make when creating advanced filters for your table, as we saw in the previous lessons within this chapter.
USING AUTOFILTERS:

1. You can toggle the AutoFilters on and off in your table by selecting any cell in your table and then clicking the “Filter” button in the “Sort & Filter” group on the “Data” tab in the Ribbon. When AutoFilter is enabled, if you click on any of the drop-down arrows on the field headers, you will see a drop-down list of available filtering options followed by a listing of all of the different and unique values found within the selected field.

2. You can manually filter a list to ensure that only the values that you want to see are checked within the list of values shown. If you click the “(Select All)” choice when all of the values are checked, it will uncheck all of them. This will allow you to quickly check only the values which you wish to see.

3. When you click the “OK” button, Excel will filter the database table to show only records in the table that have a matching value for that field. All of the other records will be hidden, not deleted.

4. Once you have applied an AutoFilter, you can remove it to show all of the records again. One way is to select the AutoFilter drop-down arrow that is currently being applied, and then check the “(Select All)” checkbox from the list of values shown in the drop-down menu and then click the “OK” button to show all of the records that were being hidden by the filter.

5. Alternately, you could also click the “Clear” button in the “Sort & Filter” group on the “Data” tab in the Ribbon.

USING THE TOP 10 AUTOFILTER:

1. Click the AutoFilter drop-down arrow button next to the column heading for the field by which you want to filter the table.

2. Roll your mouse down to the “Number Filters” choice.

3. Select the “Top 10…” option from the side menu that appears.

4. In the “Top 10 AutoFilter” dialog box, select the first drop-down and pick either “Top” or “Bottom.”

5. Next, enter a number into the spinner box in the center of the dialog box.

6. Finally, use the drop-down on the right to pick either “Items” or “Percent.” What is displayed across the dialog box is the filter setting that you will apply to the selected column.

7. When you have created the desired filter, just click “OK” to apply it.

APPLYING A CUSTOM AUTOFILTER:

1. Click the AutoFilter drop-down arrow button next to the column header by which you want to filter the data.

2. Roll down to either the “Text Filters,” “Number Filters” or “Date Filters” command in the drop-down menu. The command name changes depending upon the type of data stored within the column.

3. In the side menu that appears, you will see many of the available comparison operators. You can select one of these, if desired, or you can simply choose the “Custom Filter…” command. When you do this, Excel will open the “Custom AutoFilter” dialog box.

4. In the “Custom AutoFilter” dialog box, you select the desired comparison criteria from the upper left drop-down box.

5. Next to it, in the upper right drop-down box, you can either enter a value or select a value from the drop-down list.

(cont.)
APPLYING A CUSTOM AUTOFILTER (CONT.):

6. You can also specify a second filter criteria as you create the first, if you wish. To do this, create the first criteria and then select either the “And” or “Or” option buttons in the middle of the “Custom AutoFilter” dialog box to connect the two conditions that you create. If you select the “And” option, then the value in the field must meet both conditions to be displayed. If you select the “Or” condition, the field values will be displayed if they meet either criteria specified. Next, create the second criteria in the same way that you created the first criteria.

7. When you have created your own custom filter criteria, just click “OK” to apply the selected criteria to the selected field.

CREATING ADVANCED FILTERS:

1. To create an advanced filter, you must first create a criteria range within the workbook into which you will enter the criteria to filter your table. A criteria range is a duplicate of the header row of your table that is physically separated from the rest of the table. It must contain a header row of fields that is identical to the header row of the table that you are going to filter. Below this header row, you then enter the criteria against which you want to filter the table. The criteria range must be at least one column by two rows in length. This leaves at least one row available for entry of filtering criteria.

2. When you have created a criteria range and entered at least one criteria that you want to use as a filter, you are then ready to apply the filter.

3. To apply the filter, select a cell in the table to which you want to apply the filter, and then click the “Advanced” button in the “Sort & Filter” group on the “Data” tab in the Ribbon. Doing this will open the “Advanced Filter” dialog box.

4. At the top of the “Advanced Filter” dialog box in the “Action” section, choose the “Filter the table, in-place” option button. The “List range:” text box should show a reference to the table that will be filtered.

5. Click into “Criteria range:” text box, and then click and drag over the entire criteria range, including the header row and any criteria rows that you have added, to select it. Make sure your selection encompasses both the labels and the criteria in the criteria range.

6. Click “OK” to filter your table based on the criteria you supplied.

7. To remove the filter after applying it, click into the filtered data within your table and then click the “Clear” button in the “Sort & Filter” group on the “Data” tab in the Ribbon.

APPLYING MULTIPLE CRITERIA:

1. You use the “And” condition to create multiple criteria that must all be met to display a records from the table. You join them together with the “And” condition by simply inserting the criteria in the same criteria row, under their respective field headings, in the criteria range prior to applying the filter.

2. You use the “Or” condition to specify that a record can meet one or more of the criteria to be included in the filtered record set. To specify an “Or” condition, you write your first criteria in one of the criteria rows available, using multiple criteria in the same row for “And” conditions, if needed. Then you place the next set of criteria that you want to look for into a separate criteria row directly beneath the first criteria row. You can then apply the advanced filter.

3. Be sure to select all of the criteria rows that are needed when selecting the criteria range in the “Advanced Filter” dialog box.

©TeachUcomp, Inc. Intermediate Excel 77
USING COMPLEX CRITERIA:

1. You should enter the comparison criteria in the following general format: "="entry" where "entry" is the comparison operator and associated text or value by which you wish to filter the field.
2. You can use the following comparison operators when creating complex criteria: > (greater than), < (less than), >= (greater than or equal to), <= (less than or equal to), and <> (does not equal).
3. Also note that you can use wildcard characters to search for unknown values. You can use the asterisk (*) to represent multiple unknown characters and you can use the question mark (?) to represent a single unknown character.
4. It is also possible to create a criteria that matches the first few characters in the field’s values and returns any matching values. In this case, you do not enter any comparison operator into the criteria, but rather enter only the first characters for which you want to find matches.

COPYING FILTERED RESULTS TO A NEW LOCATION:

1. Create your criteria filters as you normally would, and then click into the data that you wish to filter.
2. Click the “Advanced” button in the “Sort & Filter” group on the “Data” tab in the Ribbon.
3. In the “Advanced Filter” dialog box, choose the option for “Copy to another location” in the “Action” section at the top.
4. Select the cells that contain your “Table range:” and “Criteria range:” as normal.
5. Next, click into the “Copy to:” text box and then click the cell that will become the upper left corner of the cell range to which you wish to paste the filtered data.
6. Finally, click “OK” to filter the table and copy the results to the location you selected.
7. One point to note is that when you do copy the results to a new location, the location specified must be in the active worksheet- meaning the worksheet that contains the table that is being filtered.

USING DATABASE FUNCTIONS:

1. You can use the criteria range that you have created to also perform database functions on the data stored in your table. You can view the various database functions by looking at the “Database” category of functions shown in the function drop-down list inside the “Insert Function” dialog box.
2. To view these functions, click the “Insert Function” button within the “Function Library” button group on the “Formulas” tab within the Ribbon to open the “Insert Function” dialog box.
3. Then select the “Database” choice from the “Or select a category” drop-down within the dialog box.
4. The database functions will then be displayed within the dialog box.
5. Each database function only requires three arguments: “Database,” which is the table cell range reference; “Field,” which is the name of the field (enclosed in double quotes), or the column number of the field that contains the values upon which you want to perform the selected function; and “Criteria,” which is a cell reference to the criteria range which contains the criteria used to decide which rows will be included in the function.
**EXERCISES - Filtering Data**

**Purpose:**

1. To be able to filter table data.

**Exercises:**

1. Open up the “Table Sample” workbook.
2. Select a cell within the table.
3. Click the “City” AutoFilter drop-down and click the “(Select All)” choice to de-select all selections in the drop-down menu.
4. Click the “Lansing” filter choice.
5. Click the “OK” button in the AutoFilter drop-down menu.
6. Click the “City” AutoFilter drop-down and click the “(Select All)” choice to select all selections in the drop-down menu.
7. Click the “OK” button in the AutoFilter drop-down menu.
8. Select the “DailySales” AutoFilter drop-down, roll your mouse pointer down to the “Number Filters” menu choice, and select “Top 10…” from the side menu that appears.
9. Use the drop-downs and spinner boxes in the “Top 10 AutoFilter” dialog box to change the filter to read “Top 5 Percent.”
10. Click “OK.”
11. Use the “DailySales” AutoFilter drop-down to select “(Select All).”
12. Click “OK.”
13. Copy the cell range A1:G1 to the cell range A14:G14.
15. In cell G15, type =“> 5000”.
16. In cell C16, type =“=Chicago”.
17. In cell G16, type =“> 5000”.
19. Click the “Advanced” button in the “Sort & Filter” group on the “Data” tab in the Ribbon.
20. Click into “Criteria Range:” text box.
22. Click “OK” in the “Advanced Filter” dialog box.
24. Click the “Clear” button in the “Sort & Filter” group on the “Data” tab in the Ribbon.
25. Click into cell A19, and type “Average amount of sale from Detroit or Chicago that is over $5000 dollars:”
26. Click into cell A20.
27. Type this formula: “=DAVERAGE(A1:G10,7,Criteria)” and exit the cell.
28. Select cell A20 and format it as “Currency.”
29. Select the cell range of A14:G20.
30. Click the “Clear” drop-down button in the “Editing” group on the “Home” tab in the Ribbon, and then choose the “Clear All” command.
32. Click the “Save” button in the Quick Access Toolbar to save your changes.
33. Click the “X” button in the upper right corner of the application window to exit.
CHAPTER 23 - USING WHAT-IF ANALYSIS

23.1 - Using Data Tables

23.2 - Using Scenario Manager

23.3 - Using Goal Seek
23.1- Using Data Tables:

Data tables are a handy way of being able to change one or two variables in a formula to view and compare the different possible results in a comparison table. You can create either single-variable data tables or double-variable data tables. For example, you can create a single-variable data table that computes and compares the possible different loan payment amounts for a loan based on different interest rates. Using the same example, you could also create a double-variable data table that displays the different loan payments that could be made for various interest rates and different loan repayment lengths.

When you create a data table, you must organize it in a specific way based on whether it is a single-variable data table, or a double-variable data table. All data tables consist of three basic parts: an “input” column or “input” row (or both, if creating a double-variable data table); an “output” column or “output” row (or both, if creating a double-variable data table); and the formula that is being evaluated within the data table.

The variables that you wish to modify within the formula must be entered as separate cell references within the formula being evaluated. If needed, you can create a small table that contains the cells to which you make references in the data table’s formula, unless you already have cells being referenced for that purpose already existing in the worksheet.

In a single-variable data table, you have the option of arranging the data table in either a columnar layout or in a row layout. In the “column” style, you place the formula being evaluated at the top of the “output” column, which is the right of the two columns. The left column is the “input” column that contains all of the possible values that you wish to evaluate for the variable reference used by the formula.

In the “row” style, you place the formula that is being evaluated in the cell to the left of the “output” row, which is the bottom of the two rows. The top row is the “input” row and contains all of the possible values that you wish to evaluate for the variable reference used by the formula.

In double-variable data tables, there is only one way to layout the data table. You must create both an “input” column and an “input” row. In a double-variable data table, the formula that is being evaluated is placed at the top of the “input” column and to the left of the “input” row. The square that extends to the right and down from there is the “output” grid, where we will see the various outcomes of the formula being evaluated for the different variable intersections that are placed into the “input” column and the “input” row.

To create the data table, select the cell range that includes the formula being evaluated, the “input” column(s) and/or row(s), and the “output” column(s) and/or row(s). Then click the “What-If Analysis” button in the “Data Tools” group on the “Data” tab in the Ribbon. Choose the “Data Table...” command from the drop-down menu to open the “Data Table” dialog box.

Next, click into “Row input cell:” text box and then select the cell in the worksheet that represents the changing variable shown in the “input” row, if you have one. Then click into the “Column input cell:” text box and select the cell in your worksheet that represents the variable that is changing in the “input” column, if you have one. In a single-variable table, you will only fill in one of these two boxes. The one which you choose depends upon whether you created the data table using a column layout or a row layout. In a double-variable data table you must fill-in both boxes, indicating which cell reference to use for your “input” column and which cell reference to use for your “input” row. When you are done, click the “OK” button in the “Data Table” dialog box to fill the data table with output information, based on the values you placed in your “input” column(s) and/or row(s).

Now you can adjust the values in the “input” column(s) and/or row(s) in your data table to view various possible outcomes of the formula that is being evaluated.
23.2- Using Scenario Manager:

Sometimes you want to create a worksheet that contains several sets of saved values that you can easily switch between to compare possible variations in projected data in a worksheet. In Excel, you can save different sets of worksheet cell values as a scenario. Then you can switch between the saved scenarios to compare the potential outcomes. For example, if you wanted to create a worksheet that could be used to display different financial projections, you could create different scenarios to project different factors that might occur to change the worksheet results. You could create a worksheet that contains the current year’s revenues, and then create additional scenarios based on that data that show a 5% increase, a 10% increase, or a 4% downturn. You can then switch between these different sets of data, as needed.

To create a scenario based on your current data, click the “What-If Analysis” button in the “Data Tools” group on the “Data” tab in the Ribbon. Then select the “Scenario Manager...” command from the button’s drop-down menu to open the “Scenario Manager” dialog box. Click the “Add...” button at the right side of this dialog box to open the “Add Scenario” dialog box. In the “Add Scenario” dialog box, type a name for the new scenario into the “Scenario name:” text box. Give it a name that describes which scenario you are modeling.

Next, click into the “Changing cells:” text box. You can then select the cells within the worksheet that you want to change for the given scenario. You can select up to 32 different cells in the worksheet to change, which will allow you to create complex scenarios. You can type a comment about the scenario into the “Comment:” text box, if desired. When you are ready to proceed, click “OK.”

In the “Scenario Values” dialog box that appears, you enter the values for the selected variable cells in your worksheet. When you have the values that you want to shown in the scenario entered, click “OK.” The new scenario will appear in the list of scenarios displayed within the “Scenario Manager” dialog box.

To show a scenario that you have created, you must select the name of the scenario to view in the “Scenario Manager,” and then click the “Show” button. The selected cell values in the worksheet will change to the values saved by the scenario. To close the “Scenario Manager” dialog box and view the changes, you can click the “Close” button in the “Scenario Manager” dialog box.

It is important to note that if you want to show the data as it was in the worksheet before displaying the scenario, you may want to create a “Current Values” scenario, in which you display the values as shown before applying scenarios. That way, you can easily revert the data back its original state. Otherwise, you will have to click “Undo” button to revert the data back to its original values.

You can edit any scenarios that you have created to modify the variable values associated with each scenario. To do this, open the “Scenario Manager” dialog box again and then select the name of the scenario to modify from the list shown. Then click the “Edit...” button to open the “Edit Scenario” dialog box. Here you can edit any of the “Changing cells:” listed. Then click “OK” and proceed to enter any new values needed. Click “OK” when you are done to save the changed scenario.

You can delete scenarios that you no longer need within the “Scenario Manager” dialog box, as well. To do this, open the “Scenario Manager” dialog box and then select the name of the scenario that you want to delete. Then click the “Delete” button in the “Scenario Manager” dialog box to remove it instantly.

You can also import other scenarios from other worksheets in other workbooks into your current worksheet. However, this is only effective if the changing cells are the same in both worksheets. To merge scenarios, open the workbook from which you want to import the scenarios. Next, open the worksheet into which you wish to merge the scenarios. Open the “Scenario Manager” dialog box, and click the “Merge...” button. This will display the “Merge Scenarios” dialog box. In the “Merge Scenarios” dialog box, you use the “Book:” drop-down to select the workbook which contains the scenarios to import. You will then view all of the worksheets within the selected workbook. Click any worksheet name in the “Sheet:” list and a message will display at the bottom of the dialog box that tells you how many scenarios are attached to that...
23.2- Using Scenario Manager (cont.):

worksheet. Select the worksheet that contains the scenarios that you want to import, and click “OK” to import them into the current worksheet.

You can easily compare the different results of scenarios within a scenario report. This report will show the different scenarios in the current worksheet, the changing values in each, and the different results that they generate. This makes it easy to compare different projections.

To create a scenario report, click the “Summary…” button in the “Scenario Manager” dialog box. This will launch the “Scenario Summary” dialog box. Click the option button that represents the type of report that you want to generate: “Scenario summary” or “Scenario PivotTable report.”

Next, click into the “Result Cells:” text box, and then select the cells within the workbook whose values are changed by the different scenarios. When you are ready to create the selected report, click “OK.”

The report will appear as a new worksheet in the workbook, which you can then click to view. In the “Scenario Summary” report, you will show the data in an outlined format, which you can collapse and expand to compare data. In the “Scenario PivotTable” report, you will also view the same data, but it is laid out as a PivotTable report which you can modify to compare data as needed.

23.3- Using Goal Seek:

Excel provides another great tool for assisting you when know the result that you want a formula to return, but you do not know the value needed to create the desired result. This tool is called “Goal Seek.” Anytime you have a situation where you know the result that you need to obtain, but are unsure of one of the values that would be needed to attain that goal, you can use “Goal Seek” to help you find the missing value required.

For example, if you knew that you could pay up to $600 dollars per month on a loan, Goal Seek could help you determine what the amount that you could borrow would be for known loan terms.

To use “Goal Seek,” just click the “What-If Analysis” button in the “Data Tools” group on the “Data” tab in the Ribbon. Then select the “Goal Seek…” command from the drop-down menu to open the “Goal Seek” dialog box. In this dialog box, you will need to enter three pieces of information: the cell that contains the result that you want to set to a given “goal” value, the “goal” value itself, and which cell contains the value that you need to change to achieve the goal value.

Click into the “Set cell:” text box and then click the cell within the worksheet that contains the result that you want to set to a given goal value. Then click into the “To value:” text box and enter the goal value that you want to find. Then click into the “By changing cell:” text box, and then click the cell in the worksheet that contains the variable that you want to change to achieve the desired result. Once that is entered, just click the “OK” button to instantly see the result. To accept the result and place it into your worksheet, click the “OK” button again or just click the “Cancel” button to discard the information.
actions

using what-if analysis

using data tables:
1. Select the cell range that includes the formula being evaluated, the “input” column(s) and/or row(s), and the “output” column(s) and/or row(s).
2. Then click the “What-If Analysis” button in the “Data Tools” group on the “Data” tab in the Ribbon. Choose the “Data Table…” command from the drop-down menu to open the “Data Table” dialog box.
3. Next, click into “Row input cell:” text box and then select the cell in the worksheet that represents the changing variable shown in the “input” row, if you have one.
4. Then click into the “Column input cell:” text box and select the cell in your worksheet that represents the variable that is changing in the “input” column, if you have one.
5. When you are done, click the “OK” button in the “Data Table” dialog box to fill the data table with output information, based on the values you placed in your “input” column(s) and/or row(s).
6. Now you can adjust the values in the “input” column(s) and/or row(s) in your data table to view various possible outcomes of the formula that is being evaluated.

using scenario manager:
1. To create a scenario based on your current data, click the “What-If Analysis” button in the “Data Tools” group on the “Data” tab in the Ribbon. Then select the “Scenario Manager…” command from the button’s drop-down menu to open the “Scenario Manager” dialog box.
2. Click the “Add…” button at the right side of this dialog box to open the “Add Scenario” dialog box.
3. In the “Add Scenario” dialog box, type a name for the new scenario into the “Scenario name:” text box.
4. Next, click into the “Changing cells:” text box. You can then select the cells within the worksheet that you want to change for the given scenario. You can select up to 32 different cells.
5. You can type a comment about the scenario into the “Comment:” text box, if desired.
6. When you are ready to proceed, click “OK”.
7. In the “Scenario Values” dialog box that appears, enter the values for the selected variable cells in your worksheet. When you have the values that you want to shown in the scenario entered, click “OK.”
8. The new scenario will appear in the list of scenarios shown within the “Scenario Manager” dialog box.
9. To show a scenario that you have created, you must select the name of the scenario to view in the “Scenario Manager,” and then click the “Show” button.
10. To close the “Scenario Manager” dialog box, you can click the “Close” button.
11. After showing a scenario, you can click the “Undo” button to revert the data back to its original values.
12. To edit a scenario that you have created, open the “Scenario Manager” dialog box again and then select the name of the scenario to modify from the list shown. Then click the “Edit…” button.
13. In the “Edit Scenario” dialog box, you can edit any of the “Changing cells:” listed.
14. Then click “OK” and proceed to enter any new values needed.
15. Click “OK” when you are done to save the changed scenario.
16. You can delete scenarios that you no longer need. To do this, open the “Scenario Manager” dialog box and then select the name of the scenario that you want to delete. Then click the “Delete” button in the “Scenario Manager” dialog box to remove it instantly.
17. You can import other scenarios from different worksheets into your current worksheet. However, this is only effective if the changing cells are the same in both worksheets. To merge scenarios from one worksheet into another worksheet, open the worksheet from which you want to import the scenarios.
18. Next, open the worksheet into which you wish to merge the scenarios from the first sheet.

(cont.)
USING SCENARIO MANAGER (CONT.):

18. Open the “Scenario Manager” dialog box, and click the “Merge…” button.
19. In the “Merge Scenarios” dialog box, you use the “Book:” drop-down to select the workbook which contains the scenarios you want to import.
20. Click any worksheet name in the “Sheet:” list, and a message will display at the bottom of this dialog box that tells you how many scenarios are attached to that worksheet. Select the worksheet that contains the scenarios that you want to import, and click “OK” to import them into the current worksheet.
21. To create a scenario report, click the “Summary…” button in the “Scenario Manager” dialog box.
22. In the “Scenario Summary” dialog box, click the option button that represents the type of report that you want to generate: “Scenario summary” or “Scenario PivotTable report.”
23. Next, click into the “Result Cells:” text box, and then select the cells within the workbook whose values are changed by the different scenarios.
24. When you are ready to create the selected report, click “OK.”

USING GOAL SEEK:

1. To use “Goal Seek,” just click the “What-If Analysis” button in the “Data Tools” group on the “Data” tab in the Ribbon. Then select the “Goal Seek…” command from the drop-down menu to open the “Goal Seek” dialog box.
2. Click into the “Set cell:” text box and then click the cell within the worksheet that contains the result that you want to set to a given goal value.
3. Then click into the “To value:” text box and enter the goal value that you want to find.
4. Then click into the “By changing cell:” text box, and then click the cell in the worksheet that contains the variable that you want to change to achieve the desired result.
5. Once that is entered, just click the “OK” button to instantly see the result.
6. To accept the result and place it into your worksheet, click the “OK” button again or just click the “Cancel” button to discard the information.
EXERCISES-
USING WHAT-IF ANALYSIS

Purpose:
1. To be able to use data tables and scenarios.

Exercises:
1. Open up the “Table Sample” workbook.
2. If needed, click the “New sheet” button to add a new worksheet, titled “Sheet2,” to the workbook.
3. After creating this new worksheet, select “Sheet2.”
4. Select cell F2, and type “Commission.”
5. Select cell H1, and type “Minimum Sales Amount.”
6. Select cell H2, and type “1000.” Format cell H2 as “Accounting Number Format.”
7. Select cell H3, and type “Percent Commission.”
8. Select cell H4, and type “.05.” Format this as a “Percent.”
9. Select cell H6, and type “Sold.”
10. Select cell I6, and type “Earned.”
11. Select cell H7, and type “1000.” Format this as “Accounting Number Format.”
12. Select cell I7, and type “=H2*H4.”
13. Select cell H8, and type “2000.” Format this as “Accounting Number Format.”
14. Select cell H9, and type “3000.” Format this as “Accounting Number Format.”
15. Select cell H10, and type “4000.” Format this as “Accounting Number Format.”
16. Select cell H11, and type “5000.” Format this as “Accounting Number Format.”
17. Select cells H7:I11.
18. Click the “What-If Analysis” button in the “Data Tools” group on the “Data” tab in the Ribbon.
19. Select the “Data Table…” command from the drop-down menu.
20. Click into the “Column input cell:” text box.
22. Click “OK.”
23. Format the selection as “Accounting Number Format.”
25. Click the “What-If Analysis” button in the “Data Tools” group on the “Data” tab in the Ribbon.
26. Select the “Scenario Manager…” command from the drop-down menu.
27. In the “Scenario Manager” dialog box, click the “Add…” button.
28. Type “Current Commission Rates” in the “Scenario name” text box.
29. Ensure that cell “H4” appears in the “Changing cells:” text box, and then click “OK.”
30. Click “OK” in the “Scenario Values” dialog box.
31. Click the “Add…” button again in the “Scenario Manager” dialog box.
32. Type “7% Commission” as the “Scenario Name” and then click “OK.”
33. Type “.07” into text box 1, and then click the “OK” button.
34. Select the “7% Commission” scenario, and then click the “Show” button.
35. View the change in the worksheet.
36. Select the “Current Commission Rates” scenario, and click the “Show” button.
37. Click the “Close” button to close the “Scenario Manager” dialog box.
38. Select “Sheet1.”
39. Click the “Save” button in the Quick Access Toolbar to save your changes.
40. Click the “X” button in the upper right corner of the application window to exit.
CHAPTER 24-
Table-Related Functions

24.1- The Hlookup and Vlookup Functions

24.2- Using the IF, AND, and OR Functions
24.1- The Hlookup and Vlookup Functions:

Now you will examine some formulas that are commonly used when dealing with tables. The first functions that we will discuss are in the “Lookup & Reference” function category. There are two primary functions within this function set that are used to lookup table data. You can use these functions to lookup a columnar array in a table and then return a corresponding column value from the same row. The first, “HLOOKUP,” will look up a data value in a table that is structured in rows (with a “header column” on the left). The second and more commonly used function, “VLOOKUP,” will look up data values in a traditional columnar table. Based on the layout of the table in which you are looking up data, you will need to use either one or the other to lookup a data value in a table.

There are three required arguments and one optional fourth argument that you must know before you can create a lookup function. “Arguments” are the additional pieces of information that a function requires to be performed. First, you must know the “lookup value.” This is the value which you want to lookup within the table. This is most commonly a cell reference. Second, you need to know the cell range reference of the table in which you want to lookup the first value. This is called the “table array.” Third, you need to know the “column or row index number.” This is the number of columns to the right of the leftmost column, or the number of rows down from the top row of the table, within which Excel must look for the data that you want it to return. The optional fourth argument is “range lookup.” This is a logical value (“TRUE” or “FALSE”) which you can enter, if needed. If omitted, this argument is assumed to be “TRUE.” What it does is specify whether or not you wish to perform a “ranged” lookup on the data within the database. If you need to find an exact match on your data, often when you are looking up text values, you can insert “FALSE” for the “range lookup” argument to find an exact match in the table.

For example, let’s say that you have a columnar customer table in a worksheet. In that sheet, you want to create a cell that will automatically lookup the customer’s address when you type the customer’s company name in an adjacent cell. Assume that the first column of the table contains the customer’s company names and the third column of the table contains the customer’s addresses. You can then write a function that will take the value of the cell adjacent to it (the lookup value), compare it to the customer table (the table array), lookup the customer’s company name in the first column until it finds a match, and then count over three (3) columns (the column index number) to find the customer’s address! Since we want the function to find an exact match on the customer name, we will then add the “FALSE” value to the “range lookup” argument in this case.

After you created the formula, you could type a customer name into the cell that is being looked up and the cell into which you had placed the formula would display the customer’s address after looking it up in the table. In this case, we would use the “VLOOKUP” function because the example stated that we had a traditional columnar table in which we were looking up the data. The syntax of a lookup function is either:

=VLOOKUP(lookup_value,table_array,column_index_number,range_lookup)

OR

=HLOOKUP(lookup_value,table_array,row_index_number,range_lookup)

When you are entering the “table array” value for the lookup function, it may be useful to assign it a range name or make it an absolute reference. Named ranges are always assigned as absolute references and this will ensure that the “table array” argument will not change if you copy and paste this formula. If you don’t use named ranges, you can assign the “table array” as an absolute reference by typing the dollar symbol ($) before both the column reference letter and the row reference number for both cell references in the range. Remember, if you don’t do this, the lookup function may not work if you copy it to a new location.

©TeachUcomp, Inc. Intermediate Excel 88
24.2- Using the IF, AND, and OR Functions:

We will now discuss “Logical” functions, which you can use to perform logical tests on the values in cells and then return a result based on whether or not the value in the cell passed or failed the test. Logical formulas take the form of an “If…then…else” statement. You must know at least three different arguments before you can write a logical function: the “logical test” that you want to apply to the cell, the cell value or formula to return if the test returns a “TRUE” value (or “passes” the logical test), and the cell value or formula to return if the test returns a “FALSE” value (or “fails” the logical test). When you write logical functions, they must have a certain syntax. That is:

=IF(logical_test,true_response,false_response)

Note that if you want the formula to display a text response for the true response or the false response, then you must place the response inside of double quotation marks (“ ”). If you want the cell to display dates, these must be enclosed within pound signs (# #). The only time you wouldn’t mark the type of value to return is if you want the cell to display a numerical result or calculate a formula.

A “nested” logical function is one that places the cell through a second logical test if it “fails” the first. These functions are useful for determining the value of a cell by placing it through several different tests, displaying different results based on which test it passes. You can nest up to 64 additional IF statements behind your original. The syntax for these are:

=IF(logical_test_1,true_response,IF(logical_test_2,true_response,false_response))

You must remember to close all of the open parenthesis for every IF statement that you nest within the logical function at the end of the formula. In this case since there are two IF statements, there are two closing parentheses at the end of the formula.

Often it is the case that you will want to know if a cell meets multiple criteria. You can use the AND and OR functions to find this out. The AND function will return a “TRUE” value if the cell being evaluated passes all of the tests listed after the AND function. The OR function will return a true value if the cell being evaluated passes any of the logical tests that follow the OR function. Note that you can evaluate up to 255 different logical test after the AND and OR statements.

When you look at how you can combine these tests with the IF function, or many nested IF functions, you can begin to see how you can start to become a very powerful formula creator. Now you can run cells through a battery of tests, and then decide what function to perform or value to display based on the results shown from the tests. The general syntax when combining the IF function with the AND and OR functions is as follows:

=IF(AND(logical_test_1,logical_test_2,logical_test_3,etc.),true_response,false_response)

=IF(OR(logical_test_1,logical_test_2,logical_test_3,etc.),true_response,false_response)
GENERAL SYNTAX FOR THE HLOOKUP AND VLOOKUP FUNCTIONS:
1. =VLOOKUP(lookup_value,table_array,column_index_number,range_lookup)
2. =HLOOKUP(lookup_value,table_array,row_index_number,range_lookup)

GENERAL SYNTAX FOR THE IF FUNCTION:
1. =IF(logical_test,true_response,false_response)

GENERAL SYNTAX FOR NESTING IF FUNCTIONS:
1. =IF(logical_test_1,true_response,IF(logical_test_2,true_response,false_response))

GENERAL SYNTAX FOR USING THE IF FUNCTION WITH THE AND/OR FUNCTIONS:
1. =IF(AND(logical_test_1,logical_test_2,logical_test_3,etc.),true_response,false_response)
2. =IF(OR(logical_test_1,logical_test_2,logical_test_3,etc.),true_response,false_response)
EXERCISES-
Table-Related Functions

Purpose:
1. To be able to table-related functions.

Exercises:
1. Open up the “Table Sample” workbook and open it to “Sheet1.”
2. Select cell J1, and type “City.”
3. Select cell K1, and type “Percent Commission.”
4. Select cell J2, and type “Lansing.”
5. Select cell K2, and type “5%.”
6. Select cell J3, and type “Detroit.”
7. Select cell K3, and type “6%.”
8. Select cell J4, and type “Chicago.”
9. Select cell K4, and type “7%.”
10. Select cell H1 and type “Commission.” Allow the table to expand to include this new column.
11. Select cell H2.
12. Type
   =IF(C2="Lansing",PRODUCT(G2,VLOOKUP(C2,$J$1:$K$4,2,FALSE)),IF(C2="Detroit",PRODUCT(G2,VLOOKUP(C2,$J$1:$K$4,2,FALSE)),IF(C2="Chicago",PRODUCT(G2,VLOOKUP(C2,$J$1:$K$4,2,FALSE)),"No reference available")))
13. If Excel does not fill in the column for you, then copy this formula to cells H3:H10.
15. Click the “Save” button in the Quick Access Toolbar to save your changes.
16. Click the “X” button in the upper right corner of the application window to exit.
CHAPTER 25-
SPARKLINES

25.1- INSERTING AND DELETING SPARKLINES

25.2- MODIFYING SPARKLINES
25.1- Inserting and Deleting Sparklines:

You can insert sparklines into your worksheets to illustrate changes to data values within a column or row of contiguous worksheet cells. A sparkline is basically a mini-chart that appears within a single selected worksheet cell and displays selected cell values as a trendline, columns, or a win-loss series.

To create a sparkline within a cell, first select the cell within which you want the sparkline to appear. Often this will be the cell at the end of a column or row of data values which you want to illustrate visually. Then click the desired type of sparkline to insert into the cell by clicking either the “Line,” “Column,” or “Win/Loss” button within the “Sparklines” button group on the “Insert” tab within the Ribbon. In the “Create Sparklines” dialog box that then appears, click into the “Data Range” field. Then click and drag over the cells within the worksheet whose values you wish to illustrate within the sparkline. Note that the cells you select that contain the values to show within the sparkline need to be adjacent to each other and in the order that you want them to be displayed within the sparkline. After selecting the cells, you should note that the “Location Range” field will display a reference to the initially selected cell within the worksheet. This is the cell that will contain the sparkline. You can change this value, if needed. Once you have made your selections, click the “OK” button within the dialog box to insert a sparkline of the selected type into your worksheet.

Another way to create sparklines within a worksheet is to first select the cells that contain the values that you want to illustrate within the sparkline. Then click either the “Line,” “Column,” or “Win/Loss” button within the “Sparklines” button group on the “Insert” tab within the Ribbon. Within the “Create Sparklines” dialog box, you can then click into the “Location Range” field and then select the cell range within the worksheet where you want the sparklines of the initially selected data to appear. You can then click the “OK” button to insert multiple sparklines, called a sparkline group, for the selected data into the chosen location.

To delete sparklines, select a sparkline to delete. Then click the “Design” tab within the “Sparkline Tools” contextual tab within the Ribbon. Then click the drop-down button at the right of the “Clear” button within the “Group” button group. From the drop-down menu that appears, you can select either the “Clear Selected Sparklines” to delete the selected sparkline or choose the “Delete Selected Sparkline Group” command to delete the selected sparkline group. Note that simply clicking the “Clear” button directly will only delete the selected sparkline, not the entire group.

25.2- Modifying Sparklines:

You can modify the appearance of a selected sparkline or sparkline group within a worksheet by first selecting the sparkline cell or sparkline group that you want to modify within the worksheet. Note that if you created the sparklines as a sparkline group, then you cannot format them independently of one another without first ungrouping them. Then click the “Design” tab within the “Sparkline Tools” contextual tab within the Ribbon to use the buttons available within this tab to modify the sparklines within the selected cells.

You can click the “Edit Data” drop-down button within the “Sparkline” group to display a listing of commands. You can select the “Edit Group Location & Data…” command to open the “Edit Sparklines” dialog box where you can change the “Data Range” or “Location Range” that you initially selected, and then click the “OK” button to change the sparkline data. Note that this same dialog box will appear if you simply click the “Edit Data” button directly. You can choose the “Edit Single Sparkline’s Data…” command to open the “Edit Sparkline Data” dialog box where you can select a new data source for a selected sparkline and then click the “OK” button to apply it. You can select the “Hidden & Empty Cells…” command to open the “Hidden and Empty Cell Settings” dialog box where you can choose the behavior and display of hidden and
Sparklines

25.2- Modifying Sparklines- (cont’d.):

empty cells within the sparklines and then click the “OK” button to apply them.

In the “Type” button group you can click either the “Line,” “Column,” or “Win/Loss” button to select the sparkline style of the selected sparkline or sparkline group. In the “Show” button group you can check or uncheck the checkboxes shown to show or hide the selected elements within the sparkline or sparkline group.

You can select a sparkline style from the choices shown within the “Styles” button group. The selected style will then be applied to the sparkline or sparkline group that is selected. You can click the “Sparkline Color” drop-down button to choose a color for the selected sparkline or sparkline group. If you selected the “Line” sparkline style and then checked the “Markers” checkbox in the “Show” button group you can then click the “Marker Color” drop-down button to choose the colors of the markers used within the sparkline or sparkline group.

You can click the “Axis” button in the “Group” button group to select axis options for the sparkline data from the drop-down menu that appears. You can use the “Group” and “Ungroup” buttons to group andungroup selected sparklines from a sparkline group, if needed. You can use the “Clear” button to delete sparklines and sparkline groups.
INSERTING AND DELETING SPARKLINES:

1. **To create a sparkline within a cell**, first select the cell within which you want the sparkline to appear.
2. Click the desired type of sparkline to insert into the cell by clicking either the “Line,” “Column,” or “Win/Loss” button within the “Sparklines” button group on the “Insert” tab within the Ribbon.
3. In the “Create Sparklines” dialog box that then appears, click into the “Data Range” field.
4. Click and drag over the cells within the worksheet whose values you wish to illustrate within the sparkline. Note that the cells you select that contain the values to show within the sparkline need to be adjacent to each other and in the order that you want them to be displayed within the sparkline.
5. After selecting the cells, you should note that the “Location Range” field will display a reference to the initially selected cell within the worksheet. This is the cell that will contain the sparkline. You can change this value, if needed.
6. Once you have made your selections, click the “OK” button within the dialog box to insert a sparkline of the selected type into your worksheet.
7. **To create a sparkline group**, select the cells that contain the values that you want to illustrate within the sparkline.
8. Click either the “Line,” “Column,” or “Win/Loss” button within the “Sparklines” button group on the “Insert” tab within the Ribbon.
9. Within the “Create Sparklines” dialog box, you can then click into the “Location Range” field and then select the cell range within the worksheet where you want the sparklines of the initially selected data to appear.
10. You can then click the “OK” button to insert multiple sparklines, called a sparkline group, for the selected data into the chosen location.
11. **To delete sparklines**, select a sparkline to delete.
12. Then click the “Design” tab within the “Sparkline Tools” contextual tab within the Ribbon.
13. Then click the drop-down button at the right of the “Clear” button within the “Group” button group. From the drop-down menu that appears, you can select either the “Clear Selected Sparklines” to delete the selected sparkline or choose the “Delete Selected Sparkline Group” command to delete the selected sparkline group. Note that simply clicking the “Clear” button directly will only delete the selected sparkline, not the entire group.
MODIFYING SPARKLINES:

1. You can modify the appearance of a selected sparkline or sparkline group within a worksheet by first selecting the sparkline cell or sparkline group that you want to modify within the worksheet. Note that if you created the sparklines as a sparkline group, then you cannot format them independently of one another without first ungrouping them.

2. Click the “Design” tab within the “Sparkline Tools” contextual tab within the Ribbon. You can use the buttons available within this tab to modify the sparklines within the selected cells.

3. You can click the “Edit Data” drop-down button within the “Sparkline” group to display a listing of commands.

4. You can select the “Edit Group Location & Data…” command to open the “Edit Sparklines” dialog box where you can change the “Data Range” or “Location Range” that you initially selected, and then click the “OK” button to change the sparkline data. Note that this same dialog box will appear if you simply click the “Edit Data” button directly.

5. You can choose the “Edit Single Sparkline’s Data…” command to open the “Edit Sparkline Data” dialog box where you can select a new data source for a selected sparkline and then click the “OK” button to apply it.

6. You can select the “Hidden & Empty Cells…” command to open the “Hidden and Empty Cell Settings” dialog box where you can choose the behavior and display of hidden and empty cells within the sparklines and then click the “OK” button to apply them.

7. In the “Type” button group you can click either the “Line,” “Column,” or “Win/Loss” button to select the sparkline style of the selected sparkline or sparkline group.

8. In the “Show” button group you can check or uncheck the checkboxes shown to show or hide the selected elements within the sparkline or sparkline group.

9. You can select a sparkline style from the choices shown within the “Styles” button group. The selected style will then be applied to the sparkline or sparkline group that is selected.

10. You can click the “Sparkline Color” drop-down button to choose a color for the selected sparkline or sparkline group.

11. If you selected the “Line” sparkline style and then checked the “Markers” checkbox in the “Show” button group you can then click the “Marker Color” drop-down button to choose the colors of the markers used within the sparkline or sparkline group.

12. You can click the “Axis” button in the “Group” button group to select axis options for the sparkline data from the drop-down menu that appears.

13. You can use the “Group” and “Ungroup” buttons to group and ungroup selected sparklines from a sparkline group, if needed.

14. You can use the “Clear” button to delete sparklines and sparkline groups.
EXERCISES-
SPARKLINES

Purpose:
1. To be able to insert a sparkline.

Exercises:
1. Open up the “Table Sample” workbook and select “Sheet1.”
2. Select cell G11.
3. Click the “Column” button within the “Sparklines” button group on the “Insert” tab within the Ribbon to launch the “Create Sparklines” dialog box.
4. Click into the “Data Range” field within the dialog box.
5. Click and drag over the cell range of G2 through G10 to select those values for the sparkline.
6. Click the “OK” button within the “Create Sparklines” dialog box.
7. Check the “High Point” checkbox within the “Show” button group on the “Options” tab within the “Sparkline Tools” contextual tab within the Ribbon.
8. Click the “Save” button within the Quick Access Toolbar to save your changes.
9. You can close the workbook when you are finished.
CHAPTER 26-
CREATING CHARTS IN EXCEL 2013

26.1- CREATING CHARTS

26.2- SELECTING CHARTS AND CHART ELEMENTS

26.3- ADDING CHART ELEMENTS

26.4- MOVING AND RESIZING CHARTS

26.5- CHANGING THE CHART TYPE

26.6- CHANGING THE DATA RANGE

26.7- SWITCHING COLUMN AND ROW DATA

26.8- CHOOSING A CHART LAYOUT

26.9- CHOOSING A CHART STYLE

26.10- CHANGING COLOR SCHEMES

26.11- PRINTING CHARTS

26.12- DELETING CHARTS
26.1- Creating Charts:

Excel 2013 allows you to create charts from the data stored in a worksheet more easily than in previous versions. Charts are useful for times when you wish to create visual representations of the worksheet data for meetings, presentations, or reports.

To insert a chart, first select the cell range that contains the data that will be used in the chart-including the row and column labels. This allows the selected data to automatically be used in the chart, saving you the step of having to select it later. You can also adjust your data selection later on, if needed, but selecting the data first allows you to see the previews of how the chart will appear once inserted much more clearly.

Next click the “Insert” tab in the Ribbon. In the “Charts” button group, you can see various types of charts that you can insert. Starting in Excel 2013, you can insert a chart by clicking the “Recommended Charts” button to open the “Insert Chart” dialog box and display the “Recommended Charts” tab. On this tab you will see the types of charts that Excel thinks would best illustrate your selected data. You can click on the choices shown at the left side of the tab to see a preview of the chart appear to the right. If you wish to insert one of the choices shown, click on it to select it from the listing at the left side of the tab and then click the “OK” button at the bottom of the “Insert Chart” dialog box.

Another way to insert a chart based on selected data is to click on the button that represents the general chart type that you want to use within the “Charts” button group, and then click on the specific subtype to insert within the button’s drop-down menu.

To view all of your charting choices and then insert a selected chart type, you can click the “See All Charts” button in the lower right corner of the “Charts” group to open the “Insert Chart” dialog box. To display all available chart choices, click the “All Charts” tab. On this tab you can select a major chart type from the listing shown at the left side of the dialog box. You can then select the specific subtype to insert by clicking on the desired subtype in the list at the right side of the dialog box. To then insert a chart of the selected subtype, you can click the “OK” button at the bottom of the dialog box.

Using any of these chart insertion methods will insert a chart of the selected subtype as an embedded chart object within the current worksheet. The next thing that you should immediately notice is that when you have a chart object selected, you will see a new contextual tab appear in the Ribbon. This is the “Chart Tools” tab, and it consists of two tabs: “Design” and “Format.” You will use the buttons within the various button groups on these two tabs that appear in the “Chart Tools” contextual tab to make changes to the selected chart objects.

When a chart object is selected in Excel 2013, you will also now see a three-button grouping of chart options appear at the right side of the selected chart object. The buttons are, from top to bottom, “Chart Elements,” “Chart Styles,” and “Chart Filters.” You can also use these buttons to make changes to your selected chart object.
26.2- Selecting Charts and Chart Elements:

When you insert a new chart into a worksheet, the entire chart area will initially appear selected. You will also see the “Chart Tools” contextual tabs appear in the Ribbon as well as three drop-down buttons attached at the right side of the chart. When editing charts, the first thing that you should become familiar with performing is selecting chart elements. Note that a chart is not simply a single object, but rather is a complex object that is comprised of many other smaller, selectable objects. You should be aware of exactly what element in the chart is selected before you begin any procedure, such as formatting the chart itself or the objects within the chart.

One way to select objects is by using your mouse. You can click on the individual elements within the chart to select them. Note that to select the entire chart, you should click into the “Chart Area.” That is the blank area that surrounds most of the actual elements of the chart. When the “Chart Area” is selected you can then perform functions that affect the entire chart, such as moving the chart or formatting the background of the chart.

Inside of the chart area is the “Plot Area.” This is the area inside of the “Chart Area,” where the actual graphic representation of your data is located. Inside of the “Plot Area,” you can click on the graphic to select a series from your chart. You can then click on an individual point in a series to select an individual point. Note that other chart elements, such as chart titles, data labels, and the legend are all independently selectable.

So, in summary, you should be aware of exactly what element within the chart is selected before you perform an operation or function. Otherwise, you could inadvertently make mistakes such as moving elements within the chart when you meant to move the entire chart, or formatting the entire chart background when you meant to format only a single data series.

Another way to select a chart or many of the elements of a chart is by using the “Chart Elements” drop-down in the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab in the Ribbon. Use this drop-down to select the major elements within your chart. However, you should also note that not all chart elements are shown in the drop-down list.

It should be noted that you can also click on chart elements with your mouse and then inspect the value shown within the “Chart Elements” drop-down to see exactly what object you have selected within your chart. This is a great way to double-check and ensure that you have the correct chart element selected before you begin an editing or formatting procedure.
26.3- Adding Chart Elements:

You can add chart elements to a selected chart to clarify the data illustrated within it. Chart elements can include axes, axis titles, chart titles, data labels, data tables, error bars, gridlines, legends, lines, trendlines, and up/down bars. Note that some of the chart elements, however, may not be able to be added to the type of chart that you have selected.

To add a chart element, first select the chart to which you would like to add a chart element. Then click the “Add Chart Element” button within the “Chart Layouts” button group on the “Design” tab within the “Chart Tools” contextual tab within the Ribbon. From the drop-down menu that appears, roll your mouse pointer over the type of elements that you want to add to view a side menu of available style choices for the selected elements onscreen display. Then click the type of onscreen display that you would like the selected element to possess to add the element to your selected chart.

Note that for all of the available chart elements, you can click the “More Options…” command at the bottom of the side menu to open a task pane at the right side of the screen that allows you to position and format the selected chart element. You can click the various category icons shown within this pane to display their associated properties below. You can then set any desired properties for the selected element to apply a customized appearance to your inserted chart element. Note that the available properties will change, depending on the type of chart element you chose to insert. When you are finished using the task pane at the right side of the screen, simply click the “X” in the upper right corner of the task pane to close it.
Creating Charts in Excel 2013

26.4- Moving and Resizing Charts:

When you insert a new chart into a worksheet, it will appear as an embedded chart object within the worksheet. When a chart is embedded within a worksheet, you can move it around within the worksheet and also resize it to the desired size. Before you do this, however, you will need to ensure that you have the “Chart Area” selected. To select the “Chart Area,” you can either click into the blank area of the chart object to select the entire chart or you can select the “Chart Area” choice from the “Chart Elements” drop-down in the “Current Selection” group on the “Format” tab of the “Chart Tools” contextual tab in the Ribbon.

To move the chart, just click and drag inside the “Chart Area” within the chart. The mouse pointer will appear as a four-pointed arrow while the chart is being moved. When the chart is in the desired location, release the mouse button to drop the chart into its new location within the worksheet.

To resize the chart, place your mouse pointer over one of the white resizing squares that appear at the four corners and the four sides of the chart within the chart object’s border. When you are in the correct position, you will see your mouse pointer become a double-pointed arrow. At that point, click and drag to resize the chart area to your desired width and height.

Also, you may want the selected chart to appear as the only object within its own worksheet. You may also want to move the chart to a different worksheet, but still have it remain as an embedded object within a different worksheet. You can accomplish either task by selecting the chart area, and then clicking the “Move Chart” button in the “Location” group on the “Design” tab of the “Chart Tools” contextual tab in the Ribbon. Doing this will open the “Move Chart” dialog box. Here you can decide where to place your chart.

First, select either the option button for “New sheet:” or “Object in:,” as desired. If you choose “New sheet:,” then type the name for the new worksheet into the text box to the right of the option button. This option places the chart as the only object in its own worksheet. This maximizes the amount of space available for plotting charted data. If you select the “Object in:” option, then use the drop-down to the right of that option button to select the name of the worksheet into which you want to embed the selected chart object. Once you have made your choice in this dialog box, click the “OK” button to move the chart.

26.5- Changing the Chart Type:

After creating your chart, you can change the fundamental chart type, or choose a different sub-type of the same general chart type that you initially selected. Either way, be aware that when you change the chart type, you may lose some custom formatting that you have applied to the chart or you may need to reposition custom elements that you have added to the chart area.

To change your chart type, simply select the chart or one of the chart elements. Next, click the “Change Chart Type” button in the “Type” group on the “Design” tab of the “Chart Tools” contextual tab in the Ribbon.

In the “Change Chart Type” dialog box that appears, you can select the type of chart that you want to use from the various chart types shown in the pane at the left side of the dialog box. When you do that, the different sub-types of the selected chart type will appear in the scrolling list at the right side of the dialog box. Click on the specific chart sub-type that you want to apply. Then click the “OK” button at the bottom of this dialog box to change the selected chart type.
26.6- Changing the Data Range:

You can switch the range of data cells that are being used by a chart. If you accidentally selected the wrong range of cells when you created the chart, or if you later want to switch the data that is being shown in a chart that you have already created, it can be helpful to note that you can switch the data shown in a chart without having to create a new chart object.

To change the data that is being plotted by a chart, select the chart or a chart element. Then click the “Select Data” button in the “Data” group on the “Design” tab in the “Chart Tools” contextual tab within the Ribbon. Doing that will open the “Select Data Source” dialog box. You use this dialog box to select which cells in your worksheet contain the data and labels that you want to plot in your chart.

In the “Chart data range:” text box, you will see a range reference to the cells that have been selected for the data. To change the data range, click the “Collapse/Expand Dialog Box” button at the right end of the “Chart data range:” text box to collapse the “Select Data Source” dialog box. Now you should be able to view the selected cells within the worksheet, which appear in the worksheet with a blinking marquee encircling them. To select a new data range, just click and drag over the cells in the worksheet that contain the new data that you want to show within the chart. Then click the “Collapse/Expand Dialog Box” button again to show the “Select Data Source” dialog box. You can then just click the “OK” button to chart the newly selected data using the same chart.

You can also use the “Select Data Source” dialog box to edit and modify the legend entries and axis labels used by the chart. To do this, open the “Select Data Source” dialog box again by clicking the “Select Data” button in the “Data” group on the “Design” tab in the “Chart Tools” contextual tab within the Ribbon.

In the “Select Data Source” dialog box, you will see the “Legend Entries (Series)” section and the “Horizontal (Category) Axis Labels” section at the bottom of the dialog box. Also note that you can switch the column and row data from your selection by clicking the “Switch Column/Row” button to switch what data is being shown where within the chart.

In the “Legend Entries (Series)” section, you can click the “Add” button to add another series to your chart. In the “Edit Series” dialog box that appears, you can click into the “Series name:” text box and then click the worksheet cell that contains the value that you want to use as the label for the series. Alternately, you can just type a name for the series directly into the text box provided. You then click into the “Series values:” text box, and then click and drag over the cells in the worksheet that contain the values that you want to display in the series. If needed, you can use the “Collapse/Expand Dialog Box” buttons to assist you in selecting the cells. Once you have added the necessary cell references, just click the “OK” button to add the series to the list shown in the “Legend Entries (Series)” list.

Also, you can edit a selected series in this list to change its title or the cells referenced by the series. To do this, just select the series in the “Legend Entries (Series)” list that you want to change, and then click the “Edit” button in the “Legend Entries (Series)” list. As when adding a new series, the “Edit Series” dialog box appears. You can change the cell references shown in either the “Series name:” or “Series values:” text boxes, just as you would if creating a new series. Once again, when finished, click the “OK” button to change the series and return to the “Legend Entries (Series)” list in the “Select Data Source” dialog box.

To delete a series shown in the “Legend Entries (Series)” list in the “Select Data Source” dialog box, just click on the name of the series within the list that you want to remove. Then click the “Remove” button in this section to remove the series from being plotted within the chart. Note that this will not delete or otherwise affect the cells used by the series, it simply removes them from the data that is being charted.

If you wish to change the order in which the series are plotted within the chart, start by selecting the series whose position you wish to change from the “Legend Entries (Series)” list in the “Select Data Source” dialog box. Then you can click the small “Move Up” and “Move Down” arrows in the “Legend Entries (Series)” to change the order of the selected series within the series list.
26.6- Changing the Data Range (cont’d.):

In the “Horizontal (Category) Axis Labels” section of the “Select Data Source” dialog box, you can change which cells are used for the axis labels within your chart. To do this, just click the “Edit” button in the “Horizontal (Category) Axis Labels” section to open the “Axis Labels” dialog box. Here you can select the cell range that is shown in the “Axis label range:” text box, if needed and then click and drag over the cells in your worksheet that contain the axis labels. Use the “Collapse/Expand Dialog Box” button, if needed. Once you have selected these cells, just click the “OK” button to return to the “Select Data Source” dialog box.

If you wish to set how the chart interprets hidden and empty cells that appear in your data range selection, you can click the “Hidden and Empty Cells” button in the lower left corner of the “Select Data Source” dialog box. In the “Hidden and Empty Cell Settings” dialog box that appears, you can choose the display of empty cells by selecting the desired option from the “Show empty cells as:” section. You can show them as “Gaps” in a line, “Zero” value points in a line, or you can “Connect data points with line.” Once you have set your choice, you can check or uncheck the “Show data in hidden columns or rows” checkbox, as desired. This defaults to being unchecked, which hides the display of data in hidden rows and columns from your chart. You can check it if you wish to display that information within the chart. Once you have set your choices for the display of hidden and empty cells, just click the “OK” button to return to the “Select Data Source” dialog box. Once you have finished using the “Select Data Source” dialog box, just click the “OK” button to apply your changes to your chart data.

26.7- Switching Column and Row Data:

While it is possible to switch the charted display of the series and the categories by using the “Select Data Source” dialog box, note that you can also just click the “Switch Row/Column” button in the “Data” group on the “Design” tab on the “Chart Tools” contextual tab within the Ribbon to switch the charting of the selected values between the column values and the row values. Each time you click this button, Excel will toggle the data series being charted to the data contained either in the rows or the columns in the cell range that you selected as the source data for your chart.

26.8- Choosing a Chart Layout:

You can use one of the preset chart layouts to quickly and easily create a chart that contains the chart elements that you want to show, including standard chart objects such as the legend, data labels, and a chart title.

To apply or change a chart layout, simply select a chart or an element within the chart, first. Then click the “Quick Layout” drop-down button within the “Chart Layouts” group on the “Design” tab of the “Chart Tools” contextual tab in the Ribbon. You can then roll your mouse pointer over the choices shown in the drop-down menu to preview them within the selected chart. You can then click on the layout that you wish to use to apply it to the selected chart.
26.9- Choosing a Chart Style:

You can use the chart styles that are available to quickly and easily apply a themed style to your chart and its elements. To apply or change a chart style, simply select a chart or an element within the chart, first. You can then roll your mouse pointer over the chart styles shown within the “Chart Styles” button group on the “Design” tab of the “Chart Tools” contextual tab in the Ribbon to preview how each style would appear within the selected chart. You can then click on the style choice that you prefer to apply it to the selected chart.

Another way to change your chart style is to click or tap the “Chart Styles” button that appears at the right side of the selected chart. In the side menu that appears, you can click or tap the “Style” command, if needed, to view the scrollable listing of chart styles. You can then tap or click on the chart style within the scrollable list that you want to apply to the selected chart.

26.10- Changing Color Schemes:

You can also change the color scheme used by the data within your chart. One way to do this is to select the chart or an element within the chart, and then click the “Change Colors” button in the “Chart Styles” button group on the “Design” tab of the “Chart Tools” contextual tab within the Ribbon. You can then select a color scheme from the drop-down menu of choices. Alternately, you can select the chart and then click or tap the “Chart Styles” button that appears at the right side of the selected chart. In the side menu that appears, you can click or tap the “Color” command, if needed, to view the color scheme choices. You can then tap or click on the choice within the scrollable list that you want to apply to the chart.

26.11- Printing Charts:

To print a chart that is embedded in a worksheet without printing the rest of the worksheet, select the chart or one of the elements of the chart, first. To print an embedded chart in a worksheet along with the accompanying worksheet information, just click into one of the worksheet cells first. To print a chart that is on its own page, just select the worksheet containing the chart.

Once you have made your selection, click the “File” tab within the Ribbon and then click the “Print” command at the left side of the backstage view. You will then see a preview of the selected chart appear to the right. You can then click the “Print” button to print the selected chart.

26.12- Deleting Charts:

To delete an embedded chart from a worksheet you must first select the chart area. You can do this by selecting “Chart Area” from the “Chart Elements” drop-down menu in the “Current Selection” group on the “Format” tab in the “Chart Tools” contextual tab in the Ribbon. Next, press the “Delete” key on your keyboard to delete the chart object from the worksheet.

If you have placed the chart on its own worksheet in the workbook, then you should delete the worksheet that contains the chart to remove it from the workbook entirely. You can right-click on the worksheet tab that contains the chart, and then choose the “Delete” command from the pop-up menu that appears. In the confirmation message box that then opens, click the “Delete” button to permanently remove the worksheet chart.
CREATING A CHART:

1. Select the cell range that contains the data to show in the chart, including the row and column labels.
2. Click the “Insert” tab in the Ribbon.
3. In the “Charts” button group, you can see various type of charts that you can insert.
4. Starting in Excel 2013, you can insert a chart by clicking the “Recommended Charts” button to open the “Insert Chart” dialog box and display the “Recommended Charts” tab.
5. On this tab you will see the types of charts that Excel thinks would best illustrate your selected data. Click on the choices shown at the left side of the tab to see a preview of the chart appear to the right.
6. If you wish to insert one of the choices shown, click on it to select it from the listing at the left side of the tab and then click the “OK” button at the bottom of the “Insert Chart” dialog box.
7. Another way to insert a chart based on the selected data is to click on the button that represents the general chart type that you want to use within the “Charts” button group, and then click on the specific subtype to insert within the button’s drop-down menu.
8. To view all of your charting choices and then insert a selected chart type, you can click the “See All Charts” button in the lower right corner of the “Charts” group to open the “Insert Chart” dialog box.
9. To display all available chart choices, click the “All Charts” tab.
10. On this tab you can select a major chart type from the listing shown at the left side of the dialog box. You can then select the specific subtype to insert by clicking on the desired subtype in the list at the right side of the dialog box.
11. To insert a chart of the selected subtype, click the “OK” button at the bottom of the dialog box.
12. Notice that when you have a chart object selected, you will see a new contextual tab appear in the Ribbon. This is the “Chart Tools” contextual tab, and it consists of two tabs: “Design” and “Format.” You will use the buttons within the various button groups on these two tabs that appear within the “Chart Tools” contextual tab to make changes to the selected chart objects.
13. When a chart object is selected in Excel 2013, you will also now see a three-button grouping of chart options appear at the right side of the selected chart object. The buttons are, from top to bottom, “Chart Elements,” “Chart Styles,” and “Chart Filters.” You can also use these buttons to make changes to your selected chart object.

SELECTING CHARTS AND CHART ELEMENTS:

1. One way to select chart objects is by using your mouse. You can click on the individual elements within the chart to select them.
2. Note that to select the entire chart, you should click into the “Chart Area.” That is the blank area that surrounds most of the actual elements of the chart.
3. Another way to select a chart or many of the elements of a chart is by using the “Chart Elements” drop-down in the “Current Selection” group on the “Format” tab of the “Chart Tools” contextual tab in the Ribbon.
4. You can also click on chart elements with your mouse and then inspect the value shown in the “Chart Elements” drop-down to see exactly what you have selected within your chart. This make a great double-check to ensure that you have the correct chart elements selected before you begin an editing or formatting procedure.
ADDITION CHART ELEMENTS:

1. To add a chart element, first select the chart to which you would like to add a chart element.
2. Click the “Add Chart Element” button within the “Chart Layouts” button group on the “Design” tab within the “Chart Tools” contextual tab within the Ribbon.
3. From the drop-down menu that appears, roll your mouse pointer over the type of elements that you want to add to view a side menu of available style choices for the selected elements onscreen display.
4. Click the type of onscreen display that you would like the selected element to possess to add the element to your selected chart.
5. Note that for all of the available chart elements, you can click the “More Options…” command at the bottom of the side menu to open a task pane at the right side of the screen that allows you to position and format the selected chart element.
6. You can click the various category icons shown within this pane to display their associated properties below.
7. You can then set any desired properties for the selected element to apply a customized appearance to your inserted chart element. Note that the available properties will change, depending on the type of chart element you chose to insert.
8. When you are finished using the task pane at the right side of the screen, simply click the “X” in the upper right corner of the task pane to close it.

MOVING AND RESIZING CHARTS:

1. Select the “Chart Area,” you can either click into the blank area of the chart object to select the entire chart or you can select the “Chart Area” choice from the “Chart Elements” drop-down in the “Current Selection” group on the “Format” tab of the “Chart Tools” contextual tab in the Ribbon.
2. To move the chart, just click and drag inside the “Chart Area” within the chart. The mouse pointer will appear as a four-pointed arrow while the chart is being moved.
3. When the chart is in the desired location, release the mouse button to drop the chart into its new location within the worksheet.
4. To resize the chart, place your mouse pointer over one of the dotted resizing areas that appear at the four corners and the four sides of the chart inside of the light blue border. When you are in the correct position, you will see your mouse pointer become a double-pointed arrow.
5. At that point, click and drag to resize the chart area to your desired width and height.
6. If you want the selected chart to appear as the only object in its own worksheet, or if you want to move the chart to a different worksheet but still have it remain as an embedded chart, you can perform either task by selecting the chart area, and then clicking the “Move Chart” button in the “Location” group on the “Design” tab of the “Chart Tools” contextual tab in the Ribbon.
7. In the “Move Chart” dialog box that appears, select either the option button for “New sheet:” or “Object in:.”
8. If you choose “New sheet:,” then type the name for the new worksheet into the text box to the right of the option button.
9. If you select the “Object in:” option, then use the drop-down to the right of that option to select the name of the worksheet into which you want to embed the selected chart object.
10. Once you have made your choice in this dialog box, click the “OK” button to move the chart.
CHANGING THE CHART TYPE:

1. Select the chart or one of the chart elements.
2. Next, click the “Change Chart Type” button in the “Type” group on the “Design” tab of the “Chart Tools” contextual tab in the Ribbon.
3. In the “Change Chart Type” dialog box that appears, you can select the type of chart that you want to use from the various chart types shown in the pane at the left side of the dialog box.
4. When you do that, the different sub-types of the selected chart type will appear in the scrolling list at the right side of the dialog box.
5. Click on the specific chart sub-type that you want to apply.
6. Then click the “OK” button at the bottom of this dialog box to change the selected chart type.

CHANGING THE DATA RANGE:

1. To change the data that is being plotted by a chart, select the chart or a chart element.
2. Click the “Select Data” button in the “Data” group on the “Design” tab in the “Chart Tools” contextual tab within the Ribbon.
3. In the “Select Data Source” dialog box, you will see a range reference to the cells that have been selected for the data in the “Chart data range:” text box.
4. To change the data range, click the “Collapse/Expand Dialog Box” button at the right end of the “Chart data range:” text box to collapse the “Select Data Source” dialog box. You should be able to view the selected cells within the worksheet, which appear with a blinking marquee encircling them.
5. To select a new data range, just click and drag over the cells in the worksheet that contain the new data that you want to show within the chart.
6. Then click the “Collapse/Expand Dialog Box” button again to show the “Select Data Source” dialog box.
7. You can then just click the “OK” button to chart the newly selected data using the same chart.
8. To use the “Select Data Source” dialog box to edit and modify the legend entries and axis labels used by the chart, open the “Select Data Source” dialog box again by clicking the “Select Data” button in the “Data” group on the “Design” tab in the “Chart Tools” contextual tab within the Ribbon.
9. In the “Select Data Source” dialog box, you will see the “Legend Entries (Series)” section and the “Horizontal (Category) Axis Labels” section at the bottom of the dialog box.
10. You can switch the column and row data from your selection by clicking the “Switch Column/Row” button to switch what data is being shown where within the chart.
11. In the “Legend Entries (Series)” section, click the “Add” button to add another series to your chart.
12. In the “Edit Series” dialog box that appears, you can click into the “Series name:” text box and then click the worksheet cell that contains the value that you want to use as the label for the series.
13. Alternately, you can just type a name for the series directly into the text box provided. You then click into the “Series values:” text box, and then click and drag over the cells in the worksheet that contain the values that you want to display in the series. If needed, you can use the “Collapse/Expand Dialog Box” buttons to assist you in selecting the cells.
14. Once you have added the necessary cell references, just click the “OK” button to add the series to the list shown in the “Legend Entries (Series)” list.
15. You can edit a selected series in this list to change its title or the cells referenced by the series. To do this, select the series in the “Legend Entries (Series)” list to change, and then click the “Edit” button in the “Legend Entries (Series)” list to display the “Edit Series” dialog box again.

(cont'd.)
CHANGING THE DATA RANGE (CONT’D.):

16. You can change the cell references shown in either the “Series name:” or “Series values:” text boxes, just as you would if creating a new series.

17. When finished, click the “OK” button to change the series and return to the “Legend Entries (Series)” list in the “Select Data Source” dialog box.

18. To delete a series shown in the “Legend Entries (Series)” list in the “Select Data Source” dialog box, just click on the name of the series within the list that you want to remove.

19. Then click the “Remove” button in this section to remove the series from being plotted within the chart. Note that this will not delete or otherwise affect the cells used by the series, it simply removes them from the data that is being charted.

20. If you wish to change the order in which the series are plotted within the chart, start by selecting the series whose position you wish to change from the “Legend Entries (Series)” list in the “Select Data Source” dialog box.

21. Then you can click the small “Move Up” and “Move Down” arrows in the “Legend Entries (Series)” to change the order of the selected series within the series list.

22. In the “Horizontal (Category) Axis Labels” section of the “Select Data Source” dialog box, you can change which cells are used for the axis labels within your chart. To do this, just click the “Edit” button in the “Horizontal (Category) Axis Labels” section to open the “Axis Labels” dialog box.

23. Here you can select the cell range that is shown in the “Axis label range:” text box, if needed and then click and drag over the cells in your worksheet that contain the axis labels. Use the “Collapse/Expand Dialog Box” button, if needed.

24. Once you have selected these cells, just click the “OK” button to return to the “Select Data Source” dialog box.

25. If you wish to set how the chart interprets hidden and empty cells that appear in your data range selection, you can click the “Hidden and Empty Cells” button in the lower left corner of the “Select Data Source” dialog box.

26. In the “Hidden and Empty Cell Settings” dialog box that appears, you can choose the display of empty cells by selecting the desired option from the “Show empty cells as:” section. You can show them as “Gaps” in a line, “Zero” value points in a line, or you can “Connect data points with line.”

27. Once you have set your choice, you can check or uncheck the “Show data in hidden columns or rows” checkbox, as desired. This defaults to being unchecked, which hides the display of data in hidden rows and columns from your chart. You can check it if you wish to show that information within the chart.

28. Once you have set your choices for the display of hidden and empty cells, just click the “OK” button to return to the “Select Data Source” dialog box.

29. Once you have finished using the “Select Data Source” dialog box, just click the “OK” button to apply your changes to your chart data.
SWITCHING COLUMN AND ROW DATA:

1. To switch the charted display of the series and the categories in your selected chart, note that you can click the “Switch Row/Column” button in the “Data” group on the “Design” tab on the “Chart Tools” contextual tab within the Ribbon to switch the charting of the selected values between the column values and the row values.
2. Each time you click this button, Excel will toggle the data series being charted to the data contained either in the rows or the columns in the cell range that you selected as the source data for your chart.

CHOOSING A CHART LAYOUT:

1. To apply or change a chart layout, simply select a chart or an element within the chart, first.
2. Then click on the chart layout that you wish to apply to the selected chart from the list shown in the “Chart Layouts” group on the “Design” tab of the “Chart Tools” contextual tab in the Ribbon.

CHOOSING A CHART STYLE:

1. Select a chart or an element within the chart.
2. You can then roll your mouse pointer over the chart styles shown within the “Chart Styles” button group on the “Design” tab of the “Chart Tools” contextual tab in the Ribbon to preview how each style would appear within the selected chart.
3. You can then click on the style choice that you prefer to apply to the selected chart.
4. Another way to change your chart style is to click or tap the “Chart Styles” button that appears at the right side of the selected chart.
5. In the side menu that appears, you can click or tap the “Style” command, if needed, to view the scrollable listing of chart styles.
6. You can then tap or click on the chart style within the scrollable list that you want to apply to the selected chart.

CHANGING COLOR SCHEMES:

1. Select the chart or an element within the chart.
2. Click the “Change Colors” button in the “Chart Styles” button group on the “Design” tab of the “Chart Tools” contextual tab within the Ribbon.
3. You can then select a color scheme from the drop-down menu of choices.
4. Alternately, you can select the chart and then click or tap the “Chart Styles” button that appears at the right side of the selected chart.
5. In the side menu that appears, you can click or tap the “Color” command, if needed, to view the color scheme choices.
6. You can then tap or click on the color scheme choice within the scrollable list that you want to apply to the chart.
PRINTING CHARTS:
1. To print a chart that is embedded in a worksheet without printing the rest of the worksheet, select the chart or one of the elements of the chart, first.
2. To print an embedded chart in a worksheet along with the accompanying worksheet information, just click into one of the worksheet cells first.
3. To print a chart that is on its own page, just select the worksheet containing the chart.
4. Once you have made your selection, click the “File” tab within the Ribbon and then click the “Print” command at the left side of the backstage view.
5. You will then see a preview of the selected chart appear to the right.
6. You can then click the “Print” button to print the selected chart.

DELETING CHARTS:
1. To delete an embedded chart from a worksheet you must first select the chart area. You can do this by selecting “Chart Area” from the “Chart Elements” drop-down menu in the “Current Selection” group on the “Format” tab in the “Chart Tools” contextual tab in the Ribbon.
2. Next, press the “Delete” key on your keyboard to delete the chart object from the worksheet.
3. If you have placed the chart on its own worksheet in the workbook, then you should delete the worksheet that contains the chart to remove it from the workbook entirely. You can right-click on the worksheet tab that contains the chart, and then choose the “Delete” command from the pop-up menu that appears. In the confirmation message box that then opens, click the “Delete” button to permanently remove the worksheet chart.
EXERCISES -
Creating Charts in Excel 2013

**Purpose:**

1. To be able to chart data shown in a worksheet in Excel 2013.

**Exercises:**

1. Open up the “Table Sample” workbook in your “Documents” folder that has been completed through the Exercise at the end of the previous chapter.
2. Select the “Sheet1” worksheet tab.
4. Click the “Insert” tab within the Ribbon.
5. Within this tab, click the “Recommended Charts” button within the “Charts” button group to open the “Insert Chart” dialog box and display the “Recommended Charts” tab.
6. Select the “Clustered Column” choice titled “Sum of Daily Sales by City” from the listing of recommended chart choices shown at the left side of this tab. This chart should be the third one down from the top of the charts listed at the left side of the dialog box. You can see the preview of how the chart will appear at the right side of the tab.
7. Click the “OK” button at the bottom of the “Insert Chart” dialog box to insert the chart into a new worksheet titled “Sheet3.”
8. Click and drag the chart to move the chart so that its upper left corner covers cell D2 in “Sheet3.”
9. Click the “Save” button in the Quick Access Toolbar to save your changes.
10. You can then close the workbook.
CHAPTER 27-
CREATING CHARTS IN EXCEL 2010 & 2007

27.1- CREATING CHARTS

27.2- SELECTING CHARTS AND CHART ELEMENTS

27.3- MOVING AND RESIZING CHARTS

27.4- CHANGING THE CHART TYPE

27.5- CHANGING THE DATA RANGE

27.6- SWITCHING COLUMN AND ROW DATA

27.7- CHOOSING A CHART LAYOUT

27.8- CHOOSING A CHART STYLE

27.9- PRINTING CHARTS

27.10- DELETING CHARTS
27.1- Creating Charts:

Excel allows you to create charts from the data stored in a worksheet. This is useful for times when you wish to create visual representations of the worksheet data for meetings, presentations, or reports. To insert a chart, first select the cell range that contains the data that will be used in the chart— including the row and column labels. This allows the selected data to automatically be used in the chart, saving you the step of having to select it later. Then click the “Insert” tab in the Ribbon. In the “Charts” button group, you can see various types of charts that you can insert. To insert a chart based on the selected data, click on the button that represents the general chart type that you want to use, and then click on the specific subtype to use in the button’s drop-down menu. Alternately, you can click the “Create Chart” button in the lower right corner of the “Charts” group to open the “Insert Chart” dialog box. Here you can select a major chart type from the listing shown at the left side of the dialog box, and then select the specific subtype to use by clicking on the desired subtype in the list at the right side of the dialog box. To then insert a chart of the selected type, you can click the “OK” button. Using either method will insert a basic chart of the selected subtype as an embedded chart object in the current worksheet.

The next thing that you should immediately notice is that when you have a chart object selected, you will see a new contextual tab appear in the Ribbon. This is the “Chart Tools” tab, and it consists of three separate tabs: “Design,” “Layout,” and “Format.” You will use the buttons that are in the various groups on all three tabs within the “Chart Tools” contextual tab to make changes to the selected chart objects.

27.2- Selecting Charts and Chart Elements:

When you insert a new chart into a worksheet, the entire chart area will appear selected. You will also see the “Chart Tools” contextual tabs appear in the Ribbon. First, you should become familiar with selecting chart elements. Note that a chart is not simply a single object, but rather is a complex object that is comprised of many other smaller, selectable objects. You should be aware of exactly what element in the chart is selected before you begin any procedure, such as formatting or moving the chart itself or the objects within the chart.

One way to select objects is by using your mouse. You can click on the individual elements within the chart to select them. Note that to select the entire chart, you should click into the “Chart Area.” That is the blank area that surrounds most of the actual elements of the chart. When the “Chart Area” is selected you can then perform functions that affect the entire chart, such as moving the chart or formatting the background of the chart. Inside of the chart area is the “Plot Area.” This is the area inside of the “Chart Area,” where the actual graphic representation of your data is located. Inside of the “Plot Area,” you can click on the graphic to select a series from your chart. You can then click on an individual point in a series to select an individual point. Note that other chart elements, such as chart titles, data labels, and the legend are all independently selectable. So, in summary, you should be aware of exactly what element within the chart is selected before you perform an operation or function. Otherwise, you could inadvertently make mistakes such as moving elements within the chart when you meant to move the entire chart, or formatting the entire chart background when you meant to format only a single data series.

Another way to select a chart or many of the elements of a chart is by using the “Chart Elements” drop-down in the “Current Selection” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon. Use this drop-down to select the major elements within your chart. However, not all chart elements are shown in the drop-down list. However, you can also click on chart elements with your mouse and then inspect the value shown in the “Chart Elements” drop-down to see exactly what you have selected within your chart. This make a great double-check to ensure that you have the correct chart elements selected before you begin a procedure.
27.3- Moving and Resizing Charts:

When you insert a new chart into a worksheet, it will appear as an embedded chart object within the worksheet. When a chart is embedded within a worksheet, you can move it around within the worksheet and also resize it to the desired size. Before you do this, however, you will need to ensure that you have the “Chart Area” selected. To select the “Chart Area,” you can either click into the blank area of the chart object to select the entire chart or you can select the “Chart Area” choice from the “Chart Elements” drop-down in the “Current Selection” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon.

To move the chart, just click and drag inside the “Chart Area” within the chart. The mouse pointer will appear as a four-pointed arrow while the chart is being moved. You will also see an outline of where the chart will be placed when you release your mouse pointer. When the outline appears in the desired location, release the mouse button to drop the chart into its new location within the worksheet.

To resize the chart, place your mouse pointer over one of the dotted resizing areas that appear at the four corners and the four sides of the chart inside of the light blue border. When you are in the correct position, you will see your mouse pointer become a double-pointed arrow. At that point, click and drag to resize the chart area to your desired width and height.

Also, you may want the selected chart to appear as the only object in its own worksheet. You may also want to move the chart to a different worksheet, but still have it remain as an embedded object within a different worksheet. You can accomplish either task by selecting the chart area, and then clicking the “Move Chart” button in the “Location” group on the “Design” tab of the “Chart Tools” contextual tab in the Ribbon. Doing this will open the “Move Chart” dialog box. Here you can decide where to place your chart.

First, select either the option button for “New sheet:” or “Object in:,” as desired. If you choose “New sheet:,” then type the name for the new worksheet into the text box to the right of the option button. This option places the chart as the only object in its own worksheet. This maximizes the amount of space available for plotting charted data. If you select the “Object in:” option, then use the drop-down to the right of that option button to select the name of the worksheet into which you want to embed the selected chart object. Once you have made your choice in this dialog box, click the “OK” button to move the chart.

27.4- Changing the Chart Type:

After creating your chart, you can change the fundamental chart type, or choose a different sub-type of the same general chart type that you initially selected. Either way, be aware that when you change the chart type, you may lose some custom formatting that you have applied to the chart or you may need to reposition custom elements that you have added to the chart area.

To change your chart type, simply select the chart or one of the chart elements. Next, click the “Change Chart Type” button in the “Type” group on the “Design” tab of the “Chart Tools” contextual tab in the Ribbon. In the “Change Chart Type” dialog box that appears, you can select the type of chart that you want to use from the various chart types shown in the pane at the left side of the dialog box. When you do that, the different sub-types of the selected chart type will appear in the scrolling list at the right side of the dialog box. Click on the specific chart sub-type that you want to apply. Then click the “OK” button at the bottom of this dialog box to change the selected chart type.
27.5- Changing the Data Range:

You can switch the range of data cells that are being used by a chart. If you accidentally selected the wrong range of cells when you created the chart, or if you later want to switch the data that is being shown in a chart that you have already created, it can be helpful to note that you can switch the data shown in a chart without having to create a new chart object.

To change the data that is being plotted by a chart, select the chart or a chart element. Then click the “Select Data” button in the “Data” group on the “Design” tab in the “Chart Tools” contextual tab within the Ribbon. Doing that will open the “Select Data Source” dialog box. You use this dialog box to select which cells in your worksheet contain the data and labels that you want to plot in your chart.

In the “Chart data range:” text box, you will see a range reference to the cells that have been selected for the data. To change the data range, click the “Collapse/Expand Dialog Box” button at the right end of the “Chart data range:” text box to collapse the “Select Data Source” dialog box. Now you should be able to view the selected cells within the worksheet, which appear in the worksheet with a blinking marquee encircling them. To select a new data range, just click and drag over the cells in the worksheet that contain the new data that you want to show within the chart. Then click the “Collapse/Expand Dialog Box” button again to show the “Select Data Source” dialog box. You can then just click the “OK” button to chart the newly selected data using the same chart.

You can also use the “Select Data Source” dialog box to edit and modify the legend entries and axis labels used by the chart. To do this, open the “Select Data Source” dialog box again by clicking the “Select Data” button in the “Data” group on the “Design” tab in the “Chart Tools” contextual tab within the Ribbon.

In the “Select Data Source” dialog box, you will see the “Legend Entries (Series)” section and the “Horizontal (Category) Axis Labels” section at the bottom of the dialog box. Also note that you can switch the column and row data from your selection by clicking the “Switch Column/Row” button to switch what data is being shown where within the chart.

In the “Legend Entries (Series)” section, you can click the “Add” button to add another series to your chart. In the “Edit Series” dialog box that appears, you can click into the “Series name:” text box and then click the worksheet cell that contains the value that you want to use as the label for the series. Alternately, you can just type a name for the series directly into the text box provided. You then click into the “Series values:” text box, and then click and drag over the cells in the worksheet that contain the values that you want to display in the series. If needed, you can use the “Collapse/Expand Dialog Box” buttons to assist you in selecting the cells. Once you have added the necessary cell references, just click the “OK” button to add the series to the list shown in the “Legend Entries (Series)” list.

Also, you can edit a selected series in this list to change its title or the cells referenced by the series. To do this, just select the series in the “Legend Entries (Series)” list that you want to change, and then click the “Edit” button in the “Legend Entries (Series)” list. As when adding a new series, the “Edit Series” dialog box appears. You can change the cell references shown in either the “Series name:” or “Series values:” text boxes, just as you would if creating a new series. Once again, when finished, click the “OK” button to change the series and return to the “Legend Entries (Series)” list in the “Select Data Source” dialog box.

To delete a series shown in the “Legend Entries (Series)” list in the “Select Data Source” dialog box, just click on the name of the series within the list that you want to remove. Then click the “Remove” button in this section to remove the series from being plotted within the chart. Note that this will not delete or otherwise affect the cells used by the series, it simply removes them from the data that is being charted.

If you wish to change the order in which the series are plotted within the chart, start by selecting the series whose position you wish to change from the “Legend Entries (Series)” list in the “Select Data Source” dialog box. Then you can click the small “Move Up” and “Move Down” arrows in the “Legend Entries (Series)” to change the order of the selected series within the series list.

©TeachUcomp, Inc. Intermediate Excel 116
27.5- Changing the Data Range (cont’d.):  

In the “Horizontal (Category) Axis Labels” section of the “Select Data Source” dialog box, you can change which cells are used for the axis labels within your chart. To do this, just click the “Edit” button in the “Horizontal (Category) Axis Labels” section to open the “Axis Labels” dialog box. Here you can select the cell range that is shown in the “Axis label range:” text box, if needed and then click and drag over the cells in your worksheet that contain the axis labels. Use the “Collapse/Expand Dialog Box” button, if needed. Once you have selected these cells, just click the “OK” button to return to the “Select Data Source” dialog box. 

If you wish to set how the chart interprets hidden and empty cells that appear in your data range selection, you can click the “Hidden and Empty Cells” button in the lower left corner of the “Select Data Source” dialog box. In the “Hidden and Empty Cell Settings” dialog box that appears, you can choose the display of empty cells by selecting the desired option from the “Show empty cells as:” section. You can show them as “Gaps” in a line, “Zero” value points in a line, or you can “Connect data points with line.” Once you have set your choice, you can check or uncheck the “Show data in hidden columns or rows” checkbox, as desired. This defaults to being unchecked, which hides the display of data in hidden rows and columns from your chart. You can check it if you wish to display that information within the chart. Once you have set your choices for the display of hidden and empty cells, just click the “OK” button to return to the “Select Data Source” dialog box. Once you have finished using the “Select Data Source” dialog box, just click the “OK” button to apply your changes to your chart data. 

27.6- Switching Column and Row Data:  

While it is possible to switch the charted display of the series and the categories by using the “Select Data Source” dialog box, note that you can also just click the “Switch Row/Column” button in the “Data” group on the “Design” tab on the “Chart Tools” contextual tab within the Ribbon to switch the charting of the selected values between the column values and the row values. Each time you click this button, Excel will toggle the data series being charted to the data contained either in the rows or the columns of the cell range that you selected as the source data for your chart. 

27.7- Choosing a Chart Layout:  

You can use one of the preset chart layouts to quickly and easily create a chart that contains the chart elements that you want to show, including standard chart objects such as the legend, data labels, and a chart title. To apply or change a chart layout, simply select a chart or an element within the chart, first. Then click on the chart layout that you wish to apply to the selected chart from the list shown in the “Chart Layouts” group on the “Design” tab of the “Chart Tools” contextual tab in the Ribbon. 

27.8- Choosing a Chart Style:  

You can use the chart styles that are available to quickly and easily apply a themed style to your chart and its elements. To apply or change a chart style, simply select a chart or an element within the chart, first. Then click on the chart style that you wish to apply to the selected chart from the list shown in the “Chart Styles” group on the “Design” tab of the “Chart Tools” contextual tab in the Ribbon.
27.9- Printing Charts:

To print a chart that is embedded in a worksheet without printing the rest of the worksheet, select the chart or one of the elements of the chart, first. To print an embedded chart in a worksheet along with the accompanying worksheet information, just click into one of the worksheet cells first. To print a chart that is on its own page, just select the worksheet containing the chart.

Once you have made your selection, just print the chart as you normally would using the “Print” command.

27.10- Deleting Charts:

To delete an embedded chart from a worksheet you must first select the chart area. You can do this by selecting “Chart Area” from the “Chart Elements” drop-down menu in the “Current Selection” group on the “Layout” tab in the “Chart Tools” contextual tab in the Ribbon. Next, press the “Delete” key on your keyboard to delete the chart object from the worksheet.

If you have placed the chart on its own worksheet in the workbook, then you should delete the worksheet that contains the chart to remove it from the workbook entirely. You can right-click on the worksheet tab that contains the chart, and then choose the “Delete” command from the pop-up menu that appears. In the confirmation message box that then opens, click the “Delete” button to permanently remove the worksheet chart.
CREATING A CHART WITH THE CHART WIZARD:

1. Select the cell range that contains the data that will be used in the chart - including the row and column labels. This allows the selected data to automatically be used in the chart, saving you the step of having to select it later.

2. Click the “Insert” tab in the Ribbon. In the “Charts” button group, you can see various types of charts that you can insert. To insert a chart based on the selected data, click on the button that represents the general chart type that you want to use, and then click on the specific subtype to use in the button’s drop-down menu.

3. Alternately, you can click the “Create Chart” button in the lower right corner of the “Charts” group to open the “Insert Chart” dialog box. Here you can select a major chart type from the listing shown at the left side of the dialog box, and then select the specific subtype to use by clicking on the desired subtype in the list at the right side of the dialog box. To then insert a chart of the selected type, you can click the “OK” button. Using either method will insert a basic chart of the selected subtype as an embedded chart object in the current worksheet.

4. The next thing that you should immediately notice is that when you have a chart object selected, you will see a new contextual tab appear in the Ribbon. This is the “Chart Tools” tab, and it consists of three separate tabs: “Design,” “Layout,” and “Format.” You will use the buttons that are in the various groups on all three tabs within the “Chart Tools” contextual tab to make changes to the selected chart objects.

SELECTING CHARTS AND CHART ELEMENTS:

1. One way to select chart objects is by using your mouse. You can click on the individual elements within the chart to select them. Note that to select the entire chart, you should click into the “Chart Area.” That is the blank area that surrounds most of the actual elements of the chart.

2. Another way to select a chart or many of the elements of a chart is by using the “Chart Elements” drop-down in the “Current Selection” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon.

3. You can also click on chart elements with your mouse and then inspect the value shown in the “Chart Elements” drop-down to see exactly what you have selected within your chart. This make a great double-check to ensure that you have the correct chart elements selected before you begin a procedure.

MOVING AND RESIZING CHARTS:

1. Select the “Chart Area,” you can either click into the blank area of the chart object to select the entire chart or you can select the “Chart Area” choice from the “Chart Elements” drop-down in the “Current Selection” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon.

2. To move the chart, just click and drag inside the “Chart Area” within the chart. The mouse pointer will appear as a four-pointed arrow while the chart is being moved. You will also see an outline of where the chart will be placed when you release your mouse pointer. When the outline appears in the desired location, release the mouse button to drop the chart into its new location within the worksheet.

(cont’d.)
MOVING AND RESIZING CHARTS (CONT’D.):

3. To resize the chart, place your mouse pointer over one of the dotted resizing areas that appear at the four corners and the four sides of the chart inside of the light blue border. When you are in the correct position, you will see your mouse pointer become a double-pointed arrow. At that point, click and drag to resize the chart area to your desired width and height.

4. If you want the selected chart to appear as the only object in its own worksheet, or if you want to move the chart to a different worksheet but still have it remain as an embedded chart, you can perform either task by selecting the chart area, and then clicking the “Move Chart” button in the “Location” group on the “Design” tab of the “Chart Tools” contextual tab in the Ribbon.

5. In the “Move Chart” dialog box that appears, select either the option button for “New sheet:” or “Object in:.” If you choose “New sheet:,” then type the name for the new worksheet into the text box to the right of the option button. If you select the “Object in:” option, then use the drop-down to the right of that option to select the name of the worksheet into which you want to embed the selected chart object.

6. Once you have made your choice in this dialog box, click the “OK” button to move the chart.

CHANGING THE CHART TYPE:

1. Select the chart or one of the chart elements.

2. Next, click the “Change Chart Type” button in the “Type” group on the “Design” tab of the “Chart Tools” contextual tab in the Ribbon.

3. In the “Change Chart Type” dialog box that appears, you can select the type of chart that you want to use from the various chart types shown in the pane at the left side of the dialog box. When you do that, the different sub-types of the selected chart type will appear in the scrolling list at the right side of the dialog box. Click on the specific chart sub-type that you want to apply.

4. Then click the “OK” button at the bottom of this dialog box to change the selected chart type.

CHANGING THE DATA RANGE:

1. To change the data that is being plotted by a chart, select the chart or a chart element. Then click the “Select Data” button in the “Data” group on the “Design” tab in the “Chart Tools” contextual tab within the Ribbon.

2. In the “Select Data Source” dialog box, you will see a range reference to the cells that have been selected for the data in the “Chart data range:” text box.

3. To change the data range, click the “Collapse/Expand Dialog Box” button at the right end of the “Chart data range:” text box to collapse the “Select Data Source” dialog box. You should be able to view the selected cells within the worksheet, which appear with a blinking marquee encircling them.

4. To select a new data range, just click and drag over the cells in the worksheet that contain the new data that you want to show within the chart.

5. Then click the “Collapse/Expand Dialog Box” button again to show the “Select Data Source” dialog box.

6. You can then just click the “OK” button to chart the newly selected data using the same chart.

7. To use the “Select Data Source” dialog box to edit and modify the legend entries and axis labels used by the chart, open the “Select Data Source” dialog box again by clicking the “Select Data” button in the “Data” group on the “Design” tab in the “Chart Tools” contextual tab within the Ribbon.

(cont’d.)
8. In the “Select Data Source” dialog box, you will see the “Legend Entries (Series)” section and the “Horizontal (Category) Axis Labels” section at the bottom of the dialog box. Note that you can switch the column and row data from your selection by clicking the “Switch Column/Row” button to switch what data is being shown where within the chart.

9. In the “Legend Entries (Series)” section, you can click the “Add” button to add another series to your chart. In the “Edit Series” dialog box that appears, you can click into the “Series name:” text box and then click the worksheet cell that contains the value that you want to use as the label for the series. Alternately, you can just type a name for the series directly into the text box provided. You then click into the “Series values:” text box, and then click and drag over the cells in the worksheet that contain the values that you want to display in the series. If needed, you can use the “Collapse/Expand Dialog Box” buttons to assist you in selecting the cells. Once you have added the necessary cell references, just click the “OK” button to add the series to the list shown in the “Legend Entries (Series)” list.

10. You can edit a selected series in this list to change its title or the cells referenced by the series. To do this, just select the series in the “Legend Entries (Series)” list that you want to change, and then click the “Edit” button in the “Legend Entries (Series)” list. As when adding a new series, the “Edit Series” dialog box appears. You can change the cell references shown in either the “Series name:” or “Series values:” text boxes, just as you would if creating a new series. When finished, click the “OK” button to change the series and return to the “Legend Entries (Series)” list in the “Select Data Source” dialog box.

11. To delete a series shown in the “Legend Entries (Series)” list in the “Select Data Source” dialog box, just click on the name of the series within the list that you want to remove. Then click the “Remove” button in this section to remove the series from being plotted within the chart. Note that this will not delete or otherwise affect the cells used by the series, it simply removes them from the data that is being charted.

12. If you wish to change the order in which the series are plotted within the chart, start by selecting the series whose position you wish to change from the “Legend Entries (Series)” list in the “Select Data Source” dialog box. Then you can click the small “Move Up” and “Move Down” arrows in the “Legend Entries (Series)” to change the order of the selected series within the series list.

13. In the “Horizontal (Category) Axis Labels” section of the “Select Data Source” dialog box, you can change which cells are used for the axis labels within your chart. To do this, just click the “Edit” button in the “Horizontal (Category) Axis Labels” section to open the “Axis Labels” dialog box. Here you can select the cell range that is shown in the “Axis label range:” text box, if needed and then click and drag over the cells in your worksheet that contain the axis labels. Use the “Collapse/Expand Dialog Box” button, if needed. Once you have selected these cells, just click the “OK” button to return to the “Select Data Source” dialog box.

14. If you wish to set how the chart interprets hidden and empty cells that appear in your data range selection, you can click the “Hidden and Empty Cells” button in the lower left corner of the “Select Data Source” dialog box. In the “Hidden and Empty Cell Settings” dialog box that appears, you can choose the display of empty cells by selecting the desired option from the “Show empty cells as:” section. You can show them as “Gaps” in a line, “Zero” value points in a line, or you can “Connect data points with line.” Once you have set your choice, you can check or uncheck the “Show data in hidden columns or rows” checkbox, as desired. This defaults to being unchecked, which hides the display of data in hidden rows and columns from your chart. You can check it if you wish to show that information within the chart.

15. Once you have set your choices for the display of hidden and empty cells, just click the “OK” button to return to the “Select Data Source” dialog box. Once you have finished using the “Select Data Source” dialog box, just click the “OK” button to apply your changes to your chart data.
SWITCHING COLUMN AND ROW DATA:

1. To switch the charted display of the series and the categories in your selected chart, note that you can just click the “Switch Row/Column” button in the “Data” group on the “Design” tab on the “Chart Tools” contextual tab within the Ribbon to switch the charting of the selected values between the column values and the row values. Each time you click this button, Excel will toggle the data series being charted to the data contained either in the rows or the columns of the cell range that you selected as the source data for your chart.

CHOOSING A CHART LAYOUT:

1. To apply or change a chart layout, simply select a chart or an element within the chart, first.
2. Then click on the chart layout that you wish to apply to the selected chart from the list shown in the “Chart Layouts” group on the “Design” tab of the “Chart Tools” contextual tab in the Ribbon.

CHOOSING A CHART STYLE:

1. To apply or change a chart style, simply select a chart or an element within the chart, first.
2. Then click on the chart style that you wish to apply to the selected chart from the list shown in the “Chart Styles” group on the “Design” tab of the “Chart Tools” contextual tab in the Ribbon.

PRINTING CHARTS:

1. To print a chart that is embedded in a worksheet without printing the rest of the worksheet, select the chart or one of the elements of the chart, first.
2. To print an embedded chart in a worksheet along with the accompanying worksheet information, just click into one of the worksheet cells first.
3. To print a chart that is on its own page, just select the worksheet containing the chart.
4. Once you have made your selection, just print the chart as you normally would using the “Print” command.

DELETING CHARTS:

1. To delete an embedded chart from a worksheet you must first select the chart area. You can do this by selecting “Chart Area” from the “Chart Elements” drop-down menu in the “Current Selection” group on the “Layout” tab in the “Chart Tools” contextual tab in the Ribbon.
2. Next, press the “Delete” key on your keyboard to delete the chart object from the worksheet.
3. If you have placed the chart on its own worksheet in the workbook, then you should delete the worksheet that contains the chart to remove it from the workbook entirely. You can right-click on the worksheet tab that contains the chart, and then choose the “Delete” command from the pop-up menu that appears. In the confirmation message box that then opens, click the “Delete” button to permanently remove the worksheet chart.
Purpose:
1. To be able to chart data shown in a worksheet in Excel 2010 or 2007.

Exercises:
1. Open up the “Table Sample” workbook in your “Documents” folder that has been completed through the Exercise at the end of Chapter 25.
2. Select the “Sheet3” worksheet.
3. Type “City” into cell A3.
4. Type “Sum of Daily Sales” into cell B3.
5. Type “Chicago” into Cell A4.
6. Type “Detroit” into cell A5.
7. Type “Lansing” into cell A6.
8. Type “14685” into cell B4.
9. Type “18122” into cell B5.
10. Type “6046” into cell B6.
12. Click the “Insert” tab within the Ribbon.
13. Within this tab, click the “Column” button within the “Charts” button group and then select the “Clustered Column” chart type within the “2-D Column” chart category from the drop-down menu that appears. This should be the chart type in the upper-left corner of the drop-down menu.
14. Click and drag the chart to move the chart so that its upper left corner covers cell D2 in “Sheet3.”
15. Click the “Save” button in the Quick Access Toolbar to save your changes.
16. You can then close the workbook.
CHAPTER 28 - Formatting Charts in Excel 2013

28.1 - Formatting Chart Objects
28.2 - Inserting Objects into a Chart
28.3 - Formatting Axes
28.4 - Formatting Axis Titles
28.5 - Formatting a Chart Title
28.6 - Formatting Data Labels
28.7 - Formatting a Data Table
28.8 - Formatting Error Bars
28.9 - Formatting Gridlines
28.10 - Formatting a Legend
28.11 - Formatting Drop and High-Low Lines
28.12 - Formatting Trendlines
28.13 - Formatting Up/Down Bars
28.14 - Formatting the Chart and Plot Areas
28.15 - Naming Charts
28.16 - Applying Shape Styles
28.17 - Applying WordArt Styles
28.18 - Saving Custom Chart Templates
28.1- Formatting Chart Objects:

You can change the formatting of any object that you can select within a chart. To select a chart object, either choose the name of the object to select from the “Chart Elements” drop-down in the “Current Selection” group on the “Format” tab of the “Chart Tools” contextual tab within the Ribbon, or click directly on the objects in the chart to select them. Next, click the “Format Selection” button in the “Current Selection” group on the “Format” tab of the “Chart Tools” contextual tab in the Ribbon.

When you do this, a “Format (object name)” task pane will appear at the right side of the window. The title of the pane, as well as the categories that appear within the pane will change depending on which chart object you have selected. Click a category icon shown within the task pane to see the formatting options for that category displayed at the bottom of the task pane. You can then change any formatting properties shown. Note that the changes that you make in this task pane are applied to the selected chart object as soon as you make them. When you are done making your formatting changes, click the “X” button in the upper-right corner of the task pane to close it.

Note that if you began your chart formatting by applying a chart style, you can reset your chart’s formatting back to its default style to remove any custom formatting that you have applied. To do this, just click the “Reset to Match Style” button in the “Current Selection” group on the “Format” tab in the “Chart Tools” contextual tab in the Ribbon. When you click this button, the chart’s formatting will revert back to the default chart style that was last applied- removing any custom formatting that you have applied.

28.2- Inserting Objects into a Chart:

You can add pictures, shapes and text boxes to a selected chart to place additional information into your Excel charts.

To insert a picture that you have saved your computer into your chart, first select the chart area. Next, click the “Pictures” button in the “Illustrations” button group on the “Insert” tab in the Ribbon. When you do that, the “Insert Picture” dialog box will appear. Use this dialog box to locate the picture that you want to insert. Then select the image to insert and click the “Insert” button in this dialog box. You can then select the inserted picture within the chart area to resize and format it as needed.

To insert a shape or text box into your chart, first select the chart. Then click the desired type of shape to insert from the choices shown within the scrollable listing within the “Insert Shapes” button group on the “Format” tab of the “Chart Tools” contextual tab in the Ribbon. Note that “Text Box” is simply a shape choice shown within the list.

You can then click with your mouse at the position within the chart at which you want to insert the type of shape that you selected to add a default shape. Alternately, you can instead click and drag over the area within the chart that you want the shape to cover to insert a shape of the size that you choose. Note that if you chose to insert a “Text Box” shape, you will then need to enter the additional text that you want to have appear within the text box.
28.3- Formatting Axes:

You can format the appearance of axes within chart types that contain axes. One way to do this is to select the desired axis to format from the “Chart Elements” drop-down menu within the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area. Alternately, you can right-click on the desired axis to format within the actual chart, and then select the “Format Axis…” command from the pop-up menu that appears.

Using either method will then display the “Format Axis” task pane at the right side of the screen which you use to set the display of the selected axis. In the “Axis Options” category, which is shown by default, you can set the values to display within the selected axis. You can also choose other formatting categories to display within the task pane by simply clicking the desired options to set and then clicking the desired category icon to edit. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category. You can set any options that you would like within the task pane to immediately apply those changes to the chart. When you are finished, click the “X” in the upper-right corner of the task pane to close it.

28.4- Formatting Axis Titles:

If you choose to add titles to your axes within your chart, you can also format the display of these titles within Excel 2013. To format an axis title, you can choose the axis title to format from the “Chart Elements” drop-down in the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area. Alternately, you can right-click on the desired axis title to format within the chart, and then select the “Format Axis Title…” command from the pop-up menu.

Using either method will then display the “Format Axis Title” task pane at the right side of the screen. Here you set the display of the selected axis title. In the “Title Options” category, which is shown by default, you can set the fill and border attributes of the selected axis title. You can also choose other formatting categories to display within the task pane by simply clicking the desired options to set, such as “Title Options” or “Text Options,” and then clicking the desired category icon to edit. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category. You can set any options that you would like within the task pane to immediately apply those changes to the chart. When you are finished, click the “X” in the upper-right corner of the task pane to close it.
28.5- Formatting a Chart Title:

If you choose to add a chart title to your chart, you can format the display of the title within Excel 2013. To format a chart title, choose the “Chart Title” choice from the “Chart Elements” drop-down in the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area. Alternately, you can right-click on the chart title within the actual chart, and then select the “Format Chart Title…” command from the pop-up menu that appears.

Using either method will then display the “Format Chart Title” task pane at the right side of the screen. Here you set the display of the chart title. In the “Title Options” category, which is shown by default, you can set the fill and border attributes of the chart title. You can also choose other formatting categories to display within the task pane by simply clicking the desired options to set, such as “Title Options” or “Text Options,” and then clicking the desired category icon to edit. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category. You can set any options that you would like within the task pane to immediately apply those changes to the chart. When you are finished, click the “X” in the upper-right corner of the task pane to close it.

28.6- Formatting Data Labels:

If you choose to add data labels to your chart, you can format the display of the data labels within Excel 2013. To format data labels, choose the desired set of data labels to format from the “Chart Elements” drop-down in the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area. Alternately, you can right-click on the desired set of data labels to format within the chart and select the “Format Data Labels…” command from the pop-up menu that appears.

Using either method will then display the “Format Data Labels” task pane at the right side of the screen. Here you set the display of the selected set of data labels. In the “Label Options” category, which is shown by default, you can set the values and positioning of the data labels. You can also choose other formatting categories to display within the task pane by simply clicking the desired options to set, such as “Label Options” or “Text Options,” and then clicking the desired category icon to edit. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category. You can set any options that you would like within the task pane to immediately apply those changes to the chart. Then click the “X” in the upper-right corner of the task pane to close it.

©TeachUcomp, Inc.
28.7- Formatting a Data Table:

If you choose to add a data table to your chart, you can format the display of the data table within Excel 2013. To format a data table, choose the “Data Table” choice from the “Chart Elements” drop-down in the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area. Alternately, you can right-click on the data table within the actual chart, and then select the “Format Data Table…” command from the pop-up menu that appears.

Using either method will display the “Format Data Table” task pane at the right side of the screen. Here you set the display of the data table. In the “Table Options” category, you can set the table border attributes and choose if you want to display a legend key. You can also choose other formatting categories to display within the task pane by simply clicking the desired options to set, such as “Table Options” or “Text Options,” and then clicking the desired category icon to edit. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category. You can set any options that you would like within the task pane to immediately apply those changes to the chart. When you are finished, click the “X” in the upper-right corner of the task pane to close it.

28.8- Formatting Error Bars:

If you choose to add error bars to your chart, you can format the display of the error bars within Excel 2013. To format error bars, choose the desired set of error bars to format from the “Chart Elements” drop-down in the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area. Alternately, you can right-click the desired set of error bars to format within the actual chart and select the “Format Error Bars…” command from the pop-up menu that appears.

Using either method will then display the “Format Error Bars” task pane at the right side of the screen. Here you set the display of the selected set of error bars. In the “Error Bar Options” category, you can set the direction, end style, and error amounts of the error bars. You can also choose other formatting categories to display within the task pane by simply clicking the desired category icon to edit within the “Error Bar Options” section. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category. You can set any options that you would like within the task pane to immediately apply those changes to the chart. When you are finished, click the “X” in the upper-right corner of the task pane to close it.
28.9- Formatting Gridlines:

If you have added gridlines to your chart, you can format the display of the gridlines within Excel 2013. To format gridlines, choose the set of gridlines to format from the “Chart Elements” drop-down in the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area. Alternately, you can right-click on the set of gridlines to format within the actual chart, and then select the “Format Gridlines…” command from the pop-up menu that appears.

Using either method will display the “Format Gridlines” task pane at the right side of the screen. Here you set the display of the gridlines. In the “Gridline Options” category, you can set the line style for the gridlines. You can also choose other formatting categories to display within the task pane by simply clicking the desired category icon to edit. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category. You can set any options that you would like within the task pane to immediately apply those changes to the chart. When you are finished, click the “X” in the upper-right corner of the task pane to close it.

28.10- Formatting a Legend:

If you added a legend to your chart, you can format the display of the legend within Excel 2013. To format a legend, choose the “Legend” choice from the “Chart Elements” drop-down in the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area. Alternately, you can right-click the legend within the chart and select the “Format Legend…” command from the pop-up menu.

Using either method will display the “Format Legend” task pane at the right side of the screen. Here you set the display of the legend. In the “Legend Options” category, you can set the position of the legend within the chart. You can also choose other formatting categories to display within the task pane by simply clicking the desired options to set, such as “Legend Options” or “Text Options,” and then clicking the desired category icon to edit. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category. You can set any options that you would like within the task pane to immediately apply those changes to the chart. When you are finished, click the “X” in the upper-right corner of the task pane to close it.

28.11- Formatting Drop and High-Low Lines:

If you choose to add either drop lines or high-low lines to your chart, you can format the display of these lines within Excel 2013. To format lines, choose the set of lines to format from the “Chart Elements” drop-down in the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area. Alternately, you can right-click on the desired set of lines to format within the actual chart, and then select either the “Format Drop Lines…” or “Format High-Low Lines…” command from the pop-up menu.

Using either method will display the “Format Lines” task pane at the right side of the screen. Here you set the display of the set of lines. In the “Line Options” category, you can set the appearance of the desired set of lines within the chart. You can also choose other formatting categories to display within the task pane by simply clicking the desired category icon to edit. The formatting options for the desired
28.11- Formatting Drop and High-Low Lines (cont’d.):  

Category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category. You can set any options that you would like within the task pane to immediately apply those changes to the chart. When you are finished, click the “X” in the upper-right corner of the task pane to close it.

28.12- Formatting Trendlines:  

If you applied trendlines to one or more of the series within your chart, you can format the display of the trendlines within Excel 2013. To format a trendline, choose the desired trendline to format from the “Chart Elements” drop-down in the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area. Alternately, you can right-click on the trendline to format within the actual chart, and then select the “Format Trendline…” command from the pop-up menu that appears.

Using either method will display the “Format Trendline” task pane at the right side of the screen. Here you set the display of the trendline. In the “Trendline Options” category, you can set the type of trendline to display for the selected series within the chart. You can also choose other formatting categories to display within the task pane by simply clicking the desired category icon to edit. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category. You can set any options that you would like within the task pane to immediately apply those changes to the chart. When you are finished, click the “X” in the upper-right corner of the task pane to close it.

28.13- Formatting Up/Down Bars:  

If you choose to add up/down bars to your chart, you can format the display of the up/down bars within Excel 2013. To format up/down bars, choose the desired set of bars to format from the “Chart Elements” drop-down in the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area. Alternately, you can right-click on the set of bars to format within the actual chart, and then select either the “Format Up Bars…” or “Format Down Bars…” command from the pop-up menu that appears.

Using either method will display the “Format Bars” task pane at the right side of the screen. Here you set the display of the selected set of bars. In the “Bar Options” category, you can set the fill and border formatting for the selected set of bars within the chart. You can also choose other formatting categories to display within the task pane by simply clicking the desired category icon to edit. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category. You can set any options that you would like within the task pane to immediately apply those changes to the chart. When you are finished, click the “X” in the upper-right corner of the task pane to close it.
28.14- Formatting Chart and Plot Areas:

You can format the display of both the chart area and plot area within Excel 2013. To format either area within a chart, choose either the “Chart Area” or “Plot Area” choice from the “Chart Elements” drop-down in the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area. Alternately, you can right-click on either the plot area or chart area within the actual chart, and then select either the “Format Chart Area…” or “Format Plot Area…” command from the pop-up menu that appears.

Using either method will display either the “Format Chart Area” or “Format Plot Area” task pane at the right side of the screen. Note that the formatting options are the same for either object. In the task pane, you can set the fill and border attributes for the selected area. You can also choose other formatting categories to display within the task pane by simply clicking the desired options to set, such as “Chart Options,” “Plot Area Options,” or “Text Options,” and then clicking the desired category icon to edit. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category. You can set any options that you would like within the task pane to immediately apply those changes to the chart. When you are finished, click the “X” in the upper-right corner of the task pane to close it.

28.15- Naming Charts:

You can name a chart by first selecting the chart to name within the worksheet. You can then click into the “Name Box” at the left end of the Formula Bar and then enter a new name for your selected chart. Naming your chart allows you to more easily refer to the chart if you have multiple charts within your workbook. This also assists in giving the chart a name for use in VBA (Visual Basic for Applications) coding, if that is needed. After entering a chart name, press “Enter” on your keyboard to apply it.

28.16- Applying Shape Styles:

You can select any chart or chart element and then apply shape style formatting to it by using the preset shape styles listed in the “Shape Styles” group on the “Format” tab of the “Chart Tools” contextual tab within the Ribbon. Simply click on the preset style in the list to apply it to your selection.

To apply your own custom shape formatting to a selected chart or chart element, use the “Shape Fill,” “Shape Outline,” and “Shape Effects” drop-down buttons. To customize the inner fill effect applied to your currently selected chart or chart element, click the “Shape Fill” button. In the drop-down menu that appears, you can select a fill color, picture, gradient, or texture to apply to the selected object.

To customize the appearance of the border of the object that you have selected, click the “Shape Outline” drop-down button. In the drop-down menu that appears, you can then select a border color or line color for the selected object. You can also roll your mouse pointer down to the “Weight,” “Dashes,” or “Arrows” commands and then select a desired choice from the side menu that appears. Also note that many of the side menus have a “More…” command available at the bottom of the menu of choices. You can always select this command to open the formatting task pane for the selected object.

You can also apply a custom shape effect to your selected chart or chart element by clicking the “Shape Effects” drop-down button and then rolling down to the general effect category that you want to apply in the drop-down menu that appears. You can then select the desired variant to apply from the side menu of category choices that are shown.
28.17- Applying WordArt Styles:

You can select any chart or chart element that contains text and apply preset WordArt formatting styles to it to format the appearance of the text within the selected object. To do this, first select the chart or chart element that contains text you want to format as WordArt. Then click on the desired WordArt style that you wish to apply from the listing shown in the “WordArt Styles” group on the “Format” tab in the “Chart Tools” contextual tab within the Ribbon.

To apply your own custom WordArt formatting to a selected chart or text-containing chart element, use the “Text Fill,” “Text Outline” and “Text Effects” drop-down buttons in the “WordArt Styles” group to apply custom formatting to the selected text. If you click the “Text Fill” drop-down button, you will have the option of filling the inner shape of the text in the selected object with a selected color, picture, gradient, or texture. You use the “Text Outline” drop-down button to select the color, weight, and dash style of the outline of the text within the selected object. You use the “Text Effects” drop-down button to select an effect to apply to the text within the selected chart element. Just roll your mouse pointer down to the category of effect that you want to apply to the text, and then select a specific variant of that stylistic category from the side menu of choices that appears.

28.18- Saving Custom Chart Templates:

Once you have a created a chart that you have formatted in the manner that you like, you can save the chart as a custom chart template. Doing that will save any chart modifications that you have made as a chart template. In the future, you can apply the custom chart template to other charts that you create. That saves time by allowing you to apply a saved chart format without having to reformat each newly created chart from scratch each time.

To save a customized chart as a template, just select the chart that contains the chart elements and formatting attributes that you wish to save. Right-click within the “Chart Area” of the selected chart and then choose the “Save as Template...” command from the pop-up menu that appears. In the “Save Chart Template” dialog box that appears, type a name for the template into the “File name:” text box. Do not change the location to which the file will be saved. Then click the “Save” button to finish saving your chart template.

In the future, you can apply the saved custom chart template to any chart that you create. To do this, select the chart to which you want to apply the custom chart template. Then click the “Change Chart Type” button in the “Type” group on the “Design” tab of the “Chart Tools” contextual tab within the Ribbon. This will open the “Change Chart Type” dialog box. Click the “Templates” category from the list at the left side of this dialog box and then select the desired template to apply from the list of saved templates that appears at the right side of the dialog box. Then click the “OK” button to apply the template to the selected chart.

If you want to delete a custom chart type that you have created, you can also do that by using the “Change Chart Type” dialog box. In the “Change Chart Type” dialog box, click the “Manage Templates...” button in the lower left corner of the dialog box. Doing this causes Windows to open the folder where the template files are located on your computer. In the window that appears, select the name of the chart template file that you wish to delete from the list shown. Then press the “Delete” key on your keyboard to delete the file. You can then close the window when you are finished. Then click the “Close” button in the upper right corner of the “Change Chart Type” dialog box to close it.
FORMATTING CHART OBJECTS:

1. To format a chart object, either choose the name of the object to select from the “Chart Elements” drop-down in the “Current Selection” group on the “Format” tab of the “Chart Tools” contextual tab within the Ribbon, or click directly on the objects in the chart to select them.

2. Click the “Format Selection” button in the “Current Selection” group on the “Format” tab of the “Chart Tools” contextual tab in the Ribbon.

3. When you do this, a “Format (object name)” task pane will appear at the right side of the window. The title of the pane, as well as the categories that appear within the pane will change depending on which chart object you have selected.

4. Click a category icon shown within the task pane to see the formatting options for that category displayed at the bottom of the task pane. You can then change any formatting properties shown.

5. When you are done making your formatting changes, click the “X” button in the upper-right corner of the task pane to close it.

6. Note that if you began your chart formatting by applying a chart style, you can reset your chart’s formatting back to its default style to remove any custom formatting that you have applied. To do this, just click the “Reset to Match Style” button in the “Current Selection” group on the “Format” tab in the “Chart Tools” contextual tab in the Ribbon.

INSERTING OBJECTS INTO A CHART:

1. To insert a picture that you have saved your computer into your chart, first select the chart area.

2. Click the “Pictures” button in the “Illustrations” button group on the “Insert” tab in the Ribbon.

3. In the “Insert Picture” dialog box that appears, locate the picture that you want to insert.

4. Select the image to insert and click the “Insert” button in this dialog box.

5. You can then select the inserted picture within the chart area to resize and format it as needed.

6. To insert a shape or text box into your chart, first select the chart.

7. Click the desired type of shape to insert from the choices shown within the scrollable listing within the “Insert Shapes” button group on the “Format” tab of the “Chart Tools” contextual tab in the Ribbon. Note that “Text Box” is simply a shape choice shown within the list.

8. You can then click with your mouse at the position within the chart at which you want to insert the type of shape that you selected to add a default shape.

9. Alternately, you can instead click and drag over the area within the chart that you want the shape to cover to insert a shape of the size that you choose.

10. Note that if you chose to insert a “Text Box” shape, you will then need to enter the additional text that you want to have appear within the text box.
FORMATTING AXES:

1. Select the desired axis to format from the “Chart Elements” drop-down menu within the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area.
2. Alternately, you can right-click on the desired axis to format within the actual chart, and then select the “Format Axis…” command from the pop-up menu that appears.
3. Using either method will then display the “Format Axis” task pane at the right side of the screen which you use to set the display of the selected axis.
4. In the “Axis Options” category, which is shown by default, you can set the values to display within the selected axis.
5. You can also choose other formatting categories to display within the task pane by simply clicking the desired options to set and then clicking the desired category icon to edit.
6. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category.
7. You can set any options that you would like within the task pane to immediately apply those changes to the chart.
8. When you are finished, click the “X” in the upper-right corner of the task pane to close it.

FORMATTING AXIS TITLES:

1. To format an axis title, you can choose the axis title to format from the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area.
2. Alternately, you can right-click on the desired axis title to format within the actual chart, and then select the “Format Axis Title…” command from the pop-up menu that appears.
3. Using either method will then display the “Format Axis Title” task pane at the right side of the screen.
4. In the “Title Options” category, which is shown by default, you can set the fill and border attributes of the selected axis title.
5. You can also choose other formatting categories to display within the task pane by simply clicking the desired options to set, such as “Title Options” or “Text Options,” and then clicking the desired category icon to edit.
6. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category.
7. You can set any options that you would like within the task pane to immediately apply those changes to the chart.
8. When you are finished, click the “X” in the upper-right corner of the task pane to close it.
FORMATTING A CHART TITLE:

1. Choose the “Chart Title” choice from the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area.
2. Alternately, you can right-click on the chart title within the actual chart, and then select the “Format Chart Title…” command from the pop-up menu that appears.
3. Using either method will then display the “Format Chart Title” task pane at the right side of the screen.
4. In the “Title Options” category, which is shown by default, you can set the fill and border attributes of the chart title.
5. You can also choose other formatting categories to display within the task pane by simply clicking the desired options to set, such as “Title Options” or “Text Options,” and then clicking the desired category icon to edit.
6. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category.
7. You can set any options that you would like within the task pane to immediately apply those changes to the chart.
8. When you are finished, click the “X” in the upper-right corner of the task pane to close it.

FORMATTING DATA LABELS:

1. To format data labels, choose the desired set of data labels to format from the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area.
2. Alternately, you can right-click on the desired set of data labels to format within the actual chart, and then select the “Format Data Labels…” command from the pop-up menu that appears.
3. Using either method will then display the “Format Data Labels” task pane at the right side of the screen.
4. In the “Label Options” category, which is shown by default, you can set the values and positioning of the data labels.
5. You can also choose other formatting categories to display within the task pane by simply clicking the desired options to set, such as “Label Options” or “Text Options,” and then clicking the desired category icon to edit.
6. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category.
7. You can set any options that you would like within the task pane to immediately apply those changes to the chart.
8. Then click the “X” in the upper-right corner of the task pane to close it.
ACTIONS-
Formatting Charts in Excel 2013

FORMATTING A DATA TABLE:

1. To format a data table, choose the “Data Table” choice from the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area.
2. Alternately, you can right-click on the data table within the actual chart, and then select the “Format Data Table…” command from the pop-up menu that appears.
3. Using either method will display the “Format Data Table” task pane at the right side of the screen.
4. In the “Table Options” category, you can set the table border attributes and choose if you want to display a legend key.
5. You can also choose other formatting categories to display within the task pane by simply clicking the desired options to set, such as “Table Options” or “Text Options,” and then clicking the desired category icon to edit.
6. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category.
7. You can set any options that you would like within the task pane to immediately apply those changes to the chart.
8. When you are finished, click the “X” in the upper-right corner of the task pane to close it.

FORMATTING ERROR BARS:

1. To format error bars, choose the desired set of error bars to format from the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area.
2. Alternately, you can right-click on the desired set of error bars to format within the actual chart, and then select the “Format Error Bars…” command from the pop-up menu that appears.
3. Using either method will then display the “Format Error Bars” task pane at the right side of the screen.
4. In the “Error Bar Options” category, you can set the direction, end style, and error amounts of the error bars.
5. You can also choose other formatting categories to display within the task pane by simply clicking the desired category icon to edit within the “Error Bar Options” section.
6. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category.
7. You can set any options that you would like within the task pane to immediately apply those changes to the chart.
8. When you are finished, click the “X” in the upper-right corner of the task pane to close it.
FORMATTING GRIDLINES:

1. To format gridlines, choose the set of gridlines to format from the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area.
2. Alternately, you can right-click on the set of gridlines to format within the actual chart, and then select the “Format Gridlines…” command from the pop-up menu that appears.
3. Using either method will display the “Format Gridlines” task pane at the right side of the screen.
4. In the “Gridline Options” category, you can set the line style for the gridlines.
5. You can also choose other formatting categories to display within the task pane by simply clicking the desired category icon to edit.
6. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category.
7. You can set any options that you would like within the task pane to immediately apply those changes to the chart.
8. When you are finished, click the “X” in the upper-right corner of the task pane to close it.

FORMATTING A LEGEND:

1. To format a legend, choose the “Legend” choice from the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area.
2. Alternately, you can right-click on the legend within the actual chart, and then select the “Format Legend…” command from the pop-up menu that appears.
3. Using either method will display the “Format Legend” task pane at the right side of the screen.
4. In the “Legend Options” category, you can set the position of the legend within the chart.
5. You can also choose other formatting categories to display within the task pane by simply clicking the desired options to set, such as “Legend Options” or “Text Options,” and then clicking the desired category icon to edit.
6. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category.
7. You can set any options that you would like within the task pane to immediately apply those changes to the chart.
8. When you are finished, click the “X” in the upper-right corner of the task pane to close it.
FORMATTING DROP LINES AND HIGH-LOW LINES:

1. Choose the set of lines to format from the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area.
2. Alternately, you can right-click on the desired set of lines to format within the actual chart, and then select either the “Format Drop Lines…” or “Format High-Low Lines…” command from the pop-up menu that appears.
3. Using either method will display the “Format Lines” task pane at the right side of the screen.
4. In the “Line Options” category, you can set the appearance of the desired set of lines within the chart.
5. You can also choose other formatting categories to display within the task pane by simply clicking the desired category icon to edit.
6. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category.
7. You can set any options that you would like within the task pane to immediately apply those changes to the chart.
8. When you are finished, click the “X” in the upper-right corner of the task pane to close it.

FORMATTING TRENDLINES:

1. Choose the desired trendline to format from the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area.
2. Alternately, you can right-click on the trendline to format within the actual chart, and then select the “Format Trendline…” command from the pop-up menu that appears.
3. Using either method will display the “Format Trendline” task pane at the right side of the screen.
4. In the “Trendline Options” category, you can set the type of trendline to display for the selected series within the chart.
5. You can also choose other formatting categories to display within the task pane by simply clicking the desired category icon to edit.
6. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category.
7. You can set any options that you would like within the task pane to immediately apply those changes to the chart.
8. When you are finished, click the “X” in the upper-right corner of the task pane to close it.
FORMATTING UP/DOWN BARS:

1. Choose the desired set of bars to format from the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area.
2. Alternately, you can right-click on the set of bars to format within the actual chart, and then select either the “Format Up Bars…” or “Format Down Bars…” command from the pop-up menu that appears.
3. Using either method will display the “Format Bars” task pane at the right side of the screen.
4. In the “Bar Options” category, you can set the fill and border formatting for the selected set of bars within the chart.
5. You can also choose other formatting categories to display within the task pane by simply clicking the desired category icon to edit.
6. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category.
7. You can set any options that you would like within the task pane to immediately apply those changes to the chart.
8. When you are finished, click the “X” in the upper-right corner of the task pane to close it.

FORMATTING THE CHART AREA OR PLOT AREA:

1. To format the chart area or plot area within Excel 2013, choose either the “Chart Area” or “Plot Area” choice from the “Current Selection” button group on the “Format” tab within the “Chart Tools” contextual tab, and then click the “Format Selection” button that appears below the drop-down menu in the same area.
2. Alternately, you can right-click on either the plot area or chart area within the actual chart, and then select either the “Format Chart Area…” or “Format Plot Area…” command from the pop-up menu that appears.
3. Using either method will display either the “Format Chart Area” or “Format Plot Area” task pane at the right side of the screen. Note that the formatting options are the same for either object.
4. In the task pane, you can set the fill and border attributes for the selected area.
5. You can also choose other formatting categories to display within the task pane by simply clicking the desired options to set, such as “Chart Options,” “Plot Area Options,” or “Text Options,” and then clicking the desired category icon to edit.
6. The formatting options for the desired category are then displayed in collapsible and expandable lists at the bottom of the task pane. You can click the titles of each category list shown to expand and collapse the display of the options within that category.
7. You can set any options that you would like within the task pane to immediately apply those changes to the chart.
8. When you are finished, click the “X” in the upper-right corner of the task pane to close it.
NAMING CHARTS:
1. You can name a chart by first selecting the chart to name within the worksheet.
2. You can then click into the “Name Box” at the left end of the Formula Bar and then enter a new name for your selected chart.
3. After entering a chart name, press “Enter” on your keyboard to apply it.

APPLYING SHAPE STYLES:
1. You can select any chart or chart element and then apply shape style formatting to it by using the preset shape styles listed in the “Shape Styles” group on the “Format” tab of the “Chart Tools” contextual tab within the Ribbon. Simply click on the preset style in the list to apply it to your selection.
2. To apply your own custom shape formatting to a selected chart or chart element, use the “Shape Fill,” “Shape Outline,” and “Shape Effects” drop-down buttons.
3. To customize the inner fill effect applied to your currently selected chart or chart element, click the “Shape Fill” button.
4. In the drop-down menu that appears, you can select a fill color, picture, gradient, or texture to apply to the selected object.
5. To customize the appearance of the border of the object that you have selected, click the “Shape Outline” drop-down button.
6. In the drop-down menu that appears, select a border color or line color for the selected object.
7. You can also roll your mouse pointer down to the “Weight,” “Dashes,” or “Arrows” commands and then select a desired choice from the side menu that appears. Note that many of the side menus have a “More…” command available at the bottom of the menu of choices. You can always select this command to open the formatting task pane for the selected object.
8. You can also apply a custom shape effect to your selected chart or chart element by clicking the “Shape Effects” drop-down button and then rolling down to the general effect category that you want to apply in the drop-down menu that appears.
9. You can then select the desired variant to apply from the side menu of category choices that are shown.

APPLYING WORDART STYLES:
1. Select the chart or chart element that contains text you want to format as WordArt.
2. Click on the desired WordArt style that you wish to apply from the listing shown in the “WordArt Styles” group on the “Format” tab in the “Chart Tools” contextual tab within the Ribbon.
3. To apply your own custom WordArt formatting to a selected chart or text-containing chart element, use the “Text Fill,” “Text Outline” and “Text Effects” drop-down buttons in the “WordArt Styles” group to apply custom formatting to the selected text.
4. If you click the “Text Fill” drop-down button, you will have the option of filling the inner shape of the text in the selected object with a selected color, picture, gradient, or texture.
5. You use the “Text Outline” drop-down button to select the color, weight, and dash style of the outline of the text within the selected object.
6. You use the “Text Effects” drop-down button to select an effect to apply to the text within the selected chart element. Roll your mouse pointer down to the category of effect that you want to apply to the text, and then select a specific variant of that stylistic category from the side menu of choices that appears.
SAVING CUSTOM CHART TEMPLATES:

1. To save a customized chart as a template, just select the chart that contains the chart elements and formatting attributes that you wish to save.
2. Right-click within the “Chart Area” of the selected chart and then choose the “Save as Template…” command from the pop-up menu that appears.
3. In the “Save Chart Template” dialog box that appears, type a name for the template into the “File name:” text box.
4. Do not change the location to which the file will be saved.
5. Then click the “Save” button to finish saving your chart template.
6. In the future, you can apply the saved custom chart template to any chart that you create. To do this, select the chart to which you want to apply the custom chart template.
7. Then click the “Change Chart Type” button in the “Type” group on the “Design” tab of the “Chart Tools” contextual tab within the Ribbon.
8. This will open the “Change Chart Type” dialog box.
9. Click the “Templates” category from the list at the left side of this dialog box and then select the desired template to apply from the list of saved templates that appears at the right side of the dialog box.
10. Then click the “OK” button to apply the template to the selected chart.
11. If you want to delete a custom chart type that you have created, you can also do that by using the “Change Chart Type” dialog box.
12. In the “Change Chart Type” dialog box, click the “Manage Templates…” button in the lower left corner of the dialog box.
13. Doing this causes Windows to open the folder where the template files are located on your computer.
14. In the window that appears, select the name of the chart template file that you wish to delete from the list shown.
15. Then press the “Delete” key on your keyboard to delete the file.
16. You can then close the window when you are finished.
17. Then click the “Close” button in the upper right corner of the “Change Chart Type” dialog box to close it.
EXERCISES-
Formatting Charts in Excel 2013

Purpose:
1. To be able to make formatting and layout modifications to a chart in Excel 2013.

Exercises:
1. Open up the “Table Sample” workbook in your “Documents” folder that has been completed through the Exercise at the end of Chapter 26.
2. Click the “Sheet3” worksheet tab.
3. Click on the embedded clustered column chart in “Sheet3” that was created in the Exercise at the end of Chapter 26.
4. Click the “Format” tab in the “PivotChart Tools” contextual tab within the Ribbon.
5. Click the “Text Box” shape button within the “Insert Shapes” button group.
6. Click and drag a small text box area in the lower right corner of the column chart.
7. Type “Created by (your name)” into the text box.
8. Click into the “Chart Area” within the chart to select the entire chart.
9. Click the “Add Chart Element” button within the “Chart Layouts” button group on the “Design” tab of the “PivotChart Tools” contextual tab within the Ribbon.
10. In the drop-down menu that appears, roll down to the “Data Labels” choice.
11. Choose “Outside End” from the side menu of choices that then appears.
12. Click the “Format” tab in the “PivotChart Tools” contextual tab within the Ribbon.
13. Select “Chart Title” from the “Chart Elements” drop-down within the “Current Selection” button group.
14. Click the “Format Selection” button within the “Current Selection” button group to display the “Format Chart Title” task pane at the right side of the Excel application.
15. If needed, click the “Title Options” text option at the top of the task pane.
16. Then click the “Fill & Line” category icon (which looks like a paint can) in the task pane.
17. If needed, click the “Fill” text option to display your formatting choices.
18. Select the “Solid fill” option button in the “Fill” section of the task pane.
19. Use the “Color” drop-down to select “Grey-25%, Background 2” (should be first row, third column) from the drop-down menu of color choices.
20. Use the “Transparency” slider in the “Fill” section of the task pane to select “50%.”
21. Click the “X” in the upper-right corner of the task pane to close it.
22. Use the “Chart Elements” drop-down in the “Current Selection” group of the “Format” tab within the “PivotChart Tools” contextual tab in the Ribbon to choose “Series “Total”” from the drop-down.
23. Click the “Shape Effects” button in the “Shape Styles” group.
24. Roll your mouse pointer down to the “Shadow” category in the button’s drop-down menu.
25. Select the “Offset Diagonal Bottom Right” shadow (upper-left choice) in the “Outer” subcategory in the side menu that appears to apply that shadow style to the pie.
26. Use the “Chart Elements” drop-down in the “Current Selection” group of the “Format” tab within the “PivotChart Tools” contextual tab in the Ribbon to choose “Series “Total” Data Labels” from the drop-down.
27. Select the “Fill - Blue, Accent 1, Shadow” preset WordArt style (should be first row, second column) shown within the list in the “WordArt Styles” button group on the “Format” tab within the “PivotChart Tools” contextual tab in the Ribbon to apply the selected WordArt style to the data labels.
28. Click the “Save” button in the Quick Access Toolbar to save your changes.
29. You can then close the workbook.
CHAPTER 29-
Formatting Charts in Excel 2010 & 2007

29.1- Formatting Chart Objects
29.2- Inserting Objects into a Chart
29.3- Changing Chart Labels
29.4- Changing Axes Display
29.5- Changing the Chart Background
29.6- Applying Chart Analysis Lines
29.7- Naming Charts
29.8- Applying Shape Styles to Chart Elements
29.9- Applying WordArt Styles to Chart Elements
29.10- Saving Custom Chart Templates
29.1- Formatting Chart Objects:

You can change the formatting of all of your chart objects by simply selecting which object you want to format, first. To select a chart object, you can either choose the name of the object that you want to select from the “Chart Elements” drop-down in the “Current Selection” group on the “Layout” tab in the “Chart Tools” contextual tab within the Ribbon, or you can simply click on them directly in the chart to select them. Next, you can click the “Format Selection” button in the “Current Selection” group on the “Layout” tab in the “Chart Tools” contextual tab in the Ribbon.

When you do this, a “Format (object name)” dialog box will appear. The title of the dialog box, as well as the categories that appear within the dialog box will change depending on which object you have selected. Click a category shown at the left side of this dialog box to see your formatting options for that category displayed at the right side of the dialog box. You can then change any formatting properties shown in the right side of the dialog box. Note that the changes that you make in this dialog box are applied to the selected chart object as soon as you make them. When you are done making your formatting changes, click the “Close” button in the lower right corner of the dialog box. Note that if you began your formatting by applying a chart style, you can reset your chart’s formatting back to the default style to remove any custom formatting that you have applied. To do this, just click the “Reset to Match Style” button in the “Current Selection” group on the “Layout” tab in the “Chart Tools” contextual tab in the Ribbon. When you click this button, the chart’s formatting will revert back to the default chart style that was last applied- removing any custom formatting that you have applied.

29.2- Inserting Objects into a Chart:

You can add pictures, shapes and text boxes to a selected chart to place additional information into your Excel charts. For example, if you wanted to add your company’s logo to the chart area, or if you want to add more text to the chart, you can do so by using the buttons that are available in the “Insert” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon.

To insert a picture that you have saved your computer into your chart, first select the chart area. Next, click the “Picture” button in the “Insert” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon. When you do that, the “Insert Picture” dialog box will appear. Use this dialog box to locate the picture that you want to insert. Then select the image to insert and click the “Insert” button in this dialog box.

To insert a drawn shape into your chart area, first select the chart and then click the “Shapes” button in the “Insert” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon. Next, select the shape to draw from the drop-down list that appears. You can then simply double-click with your mouse at the position within the chart at which you want to insert the type of shape that you selected.

If you want to add a text box into which you can enter additional text for your chart, then click the “Text Box” button in the “Insert” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon. Then click and drag over the area within the chart where you want to place the text box. You will then need to enter the additional text that you want to have appear within the text box.

29.3- Changing Chart Labels:

You can change the appearance of the labels that are used in your chart by using the buttons that are shown in the “Labels” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon. The buttons that are shown in this group include the “Chart Title,” “Axis Titles,” “Legend,” “Data Labels,” and the
29.3- Changing Chart Labels (cont’d.):

“Data Table” button. You can click on any one of these buttons to display a drop-down menu that shows your placement and visibility options for the selected label object. You can click on the selection that you want to make to apply it to the selected label type.

Also note that at the bottom of the drop-down menus, there is a general options that says “More (object name) Options...” that you can select to open the “Format (object name)” dialog box. You can change the settings in this dialog box to make additional adjustments to the label’s appearance within the chart. When you have finished making your changes, just click the “Close” button in this dialog box.

29.4- Changing Axes Display:

You can change the display of the axes in your two-dimensional chart types, such as the column and bar chart types. The buttons in the “Axes” group on the “Layout” tab in the “Chart Tools” contextual tab in the Ribbon allow you to set the placement, labeling, and gridline appearance of the axes of the chart. First, select the chart or an element in the chart whose axes you wish to format.

Next, you can click either the “Axes” or “Gridlines” buttons, depending upon what you want to format. Then select which axis or axis gridlines you want to format by rolling over your desired choice in the drop-down menu. You can then apply a selected formatting to the selected axis from the side menus that appear. Using the “Axes” button you can change the positioning and labeling of the selected axis. Using the “Gridlines” button you can change the appearance and labeling of the gridlines that appear on each axis.

Also note that, like the buttons in the “Labels” group, you can select the “More (object name) Options...” choice in the drop-down menus that appear to open the “Format (object name)” dialog box. Here you can set additional formatting options for the selected axis or axis gridlines. Once you have finished making your custom formatting changes, you can then click the “Close” button to close this dialog box.

29.5- Changing the Chart Background:

You can change the display of the background of your chart using the buttons that are available in the “Background” group on the “Layout” tab in the “Chart Tools” contextual tab within the Ribbon. The buttons that are available within this group are “Plot Area,” “Chart Wall,” “Chart Floor,” and “3-D Rotation.” Depending upon the chart type that you selected you may have only some of these buttons available. For example, if you selected a 2-D chart style then the “3-D Rotation” button will be unavailable.

To use one of these buttons, click on the button that corresponds to the element of the chart background that you want to format. Then select whether or not you want to hide the selected element, or display the element with the default fill color applied in the chart. Note that these buttons also contain the “More (object name) Options...” command at the bottom of each button’s drop-down menu. You can select this command to open the “Format (object name)” dialog box. In this dialog box, you can change the appearance of the selected element as desired using the categories and options shown. Once you have finished applying your desired formatting changes, you can click the “Close” button to close the dialog box.
29.6- Applying Chart Analysis Lines:

If you select a chart type that makes uses of analysis lines, such as a “Line” or “Scatter” chart type, then you can use the buttons that are available in the “Analysis” group on the “Layout” tab of the “Chart Tools” contextual tab within the Ribbon to add lines that extend and enhance the information shown within the selected chart. You can add normal trendlines and projected trendlines, error bars, up/down bars, and drop lines to your data markers. The buttons included in this group are “Trendline,” “Lines,” “Up/Down Bars,” and “Error Bars.”

To add one of these types of lines to your selected chart, just click the button that corresponds to the type of line that you want to add and then select your desired choice of analysis line from the drop-down menu that appears. For all of the buttons with the exception of the “Lines” button, you can also choose the “More (object name) Options...” command at the bottom of the drop-down menu to open the “Format (object name)” dialog box. You can then use the categories at the left side and their corresponding options at the right side of the dialog box to set whatever formatting options you want to apply to the analysis lines. Note that if you choose this option for applying some types of analysis lines, you may need to select for which series in your chart you wish to add the analysis line in the “Add (object name)” dialog box that appears. Then you can format the desired analysis line for the selected series, as desired.

29.7- Naming Charts:

You can click into the “Chart Name:” text box in the “Properties” group on the “Layout” tab of the “Chart Tools” contextual tab within the Ribbon to type a name for your currently selected chart object. This allows you to more easily refer to the chart if you have multiple charts in your workbook. This also assists in giving the chart a name for use in VBA (Visual Basic for Applications) coding, if that is needed.

29.8- Applying Shape Styles to Chart Elements:

You can select any chart element within a chart and then apply formatting changes to the shape of the selected chart element by using the preset object styles listed in the “Shape Styles” list in the “Shape Styles” group on the “Format” tab of the “Chart Tools” contextual tab within the Ribbon. To do this, simply select the chart element whose shape you wish to change, and then click on the desired preset shape style in the list to apply it to the selected chart element.

To apply your own custom formatting, you can use the “Shape Fill,” “Shape Outline,” and “Shape Effects” buttons to the selected chart element. If you want to customize the appearance of the inner fill effect applied to your currently selected chart element, then click the “Shape Fill” button. In the drop-down menu that appears, you can select a fill color, a picture, a gradient, or a texture to apply to the selected object.

If you want to customize the appearance of the formatting of the outline, border, or line that you have selected in your chart, then click the “Shape Outline” button. In the drop-down menu that appears, you can then select a color for the selected line. You can also roll your mouse pointer down to the “Weight,” “Dashes,” or “Arrows” commands and then select a desired choice from the side menu that appears. Also note that many of the side menus have a “More (object name)...” command available at the bottom of the menu of choices. You can always select this command to open the “Format (object name)” dialog box, where you can customize the appearance of the selected object down to the last detail. If you do open this dialog box to make custom changes, just click the “Close” button to close it when you are finished.

You can also apply a custom effect to your selected chart element by clicking the “Shape Effects” button and then rolling down to the general effect category that you want to apply in the drop-down menu.
29.8- Applying Shape Styles to Chart Elements (cont'd.):

that appears. You can then select the desired variant to apply in the side menu of category choices shown.

29.9- Applying WordArt Styles to Chart Elements:

You can select any chart element that contains text and apply preset WordArt formatting styles to it to quickly format the appearance of the text within the selected chart element. To do this, first select the chart element that contains text which you want to format. Then click on the desired WordArt style that you wish to apply in the “WordArt Styles” list in the “WordArt Styles” group on the “Format” tab in the “Chart Tools” contextual tab within the Ribbon.

If you wish to apply your own custom formatting to a selected text-containing chart element, you may use the “Text Fill,” “Text Outline” and “Text Effects” buttons in the “WordArt Styles” group to apply your own custom formatting to the selected text. If you click the “Text Fill” button, you will have the option of filling the text in the shape with a selected color, a picture, a gradient, or a texture. You can use the “Text Outline” button to select the color, weight, arrow, and dash style of the outline of the text within the selected chart element. You can then use the “Text Effects” button to select an effect to apply to the text within the selected chart element. Just roll your mouse pointer down to the category of effect that you want to apply to the text, and then select a specific variant of that stylistic category from the side menu of choices that appears.

29.10- Saving Custom Chart Templates:

Once you have a created a chart that you have formatted in the manner that you like, you can save the chart as a custom chart template. Doing that will save any chart modifications that you have made as a chart template. In the future, you can apply the custom chart template to other charts that you create. That saves time by allowing you to apply a saved chart format without having to reformat each newly created chart from scratch each time.

To save a customized chart as a template, just select the chart that you wish to save. Next, click the “Save As Template” button in the “Type” group on the “Design” tab of the “Chart Tools” contextual tab within the Ribbon. In the “Save Chart Template” dialog box that appears, type a name for the template into the “File name:” text box. Do not change the location to which the file will be saved. Then click the “Save” button to finish saving your chart template.

In the future, you can apply the saved custom chart template to any chart that you create. To do this, select the chart to which you want to apply the custom chart template. Then click the “Change Chart Type” button in the “Type” group on the “Design” tab of the “Chart Tools” contextual tab within the Ribbon. This will open the “Change Chart Type” dialog box. Click the “Templates” category from the list at the left side of this dialog box and then select the desired template to apply from the list of saved templates that appears at the right side of the dialog box. Then click the “OK” button to apply the template to the selected chart.

When you want to delete the custom chart type that you have created, you can also do that by using the “Change Chart Type” dialog box. In the “Change Chart Type” dialog box, click the “Manage Templates...” button in the lower left corner of the dialog box. Doing this causes Windows to open the folder where the template files are located on your computer. In the window that appears, select the name of the chart template file that you created and now wish to delete from the list shown. Then press the “Delete” key on your keyboard to delete the file. You can then close the window when you are finished. Then click the “Close” button in the upper right corner of the “Change Chart Type” dialog box to close it.
FORMATTING CHART OBJECTS:

1. Select the name of the chart object that you want to format from the “Chart Elements” drop-down in the “Current Selection” group on the “Layout” tab in the “Chart Tools” contextual tab in the Ribbon, or click on the chart object directly in the chart to select it.

2. Click the “Format Selection” button in the “Current Selection” group on the “Layout” tab in the “Chart Tools” contextual tab in the Ribbon.

3. When you do this, a “Format (object name)” dialog box will appear. The title of the dialog box, as well as the categories that appear within the dialog box will change depending on which object you have selected.

4. Click a category shown at the left side of this dialog box to see your formatting options for that category displayed at the right side of the dialog box. You can then change any formatting properties shown in the right side of the dialog box. Note that the changes that you make in this dialog box are applied to the selected chart object as soon as you make them.

5. When you are done making your formatting changes, click the “Close” button in the lower right corner of the dialog close the dialog box.

6. You can reset your chart’s formatting back to the default style by clicking the “Reset to Match Style” button in the “Current Selection” group on the “Layout” tab in the “Chart Tools” contextual tab in the Ribbon.

INSERTING OBJECTS INTO A CHART:

1. You can add pictures, shapes and text boxes to a selected chart by using the buttons that are available in the “Insert” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon.

2. To insert a picture that you have saved your computer into your chart, first select the chart area.

3. Next, click the “Picture” button in the “Insert” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon. When you do that, the “Insert Picture” dialog box will appear. Use this dialog box to locate the picture that you want to insert.

4. Select the image to insert and click the “Insert” button in the “Insert Picture” dialog box.

5. To insert a drawn shape into your chart area, first select the chart and then click the “Shapes” button in the “Insert” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon.

6. Next, select the shape to draw from the drop-down list that appears. You can then simply double-click with your mouse at the position within the chart at which you want to insert the selected shape.

7. If you want to add a text box into which you can enter additional text for your chart, then click the “Text Box” button in the “Insert” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon.

8. Then click and drag over the area within the chart where you want to place the text box. You will then need to enter the additional text that you want to have appear within the text box.
CHANGING CHART LABELS:

1. You can change the appearance of the labels that are used in your chart by using the buttons that are shown in the “Labels” group on the “Layout” tab of the “Chart Tools” contextual tab in the Ribbon. The buttons that are shown in this group include the “Chart Title,” “Axis Titles,” “Legend,” “Data Labels,” and the “Data Table” button.
2. You can click on any one of these buttons to display a drop-down menu that shows your placement and visibility options for the selected label object.
3. You can click on the selection that you want to make to apply it to the selected label type.
4. Also note that at the bottom of the drop-down menus, there is a general options that says “More (object name) Options…” that you can select to open the “Format (object name)” dialog box.
5. You can change the settings in this dialog box to make additional adjustments to the label’s appearance within the chart.
6. When you have finished making your changes, just click the “Close” button in this dialog box.

CHANGING AXES DISPLAY:

1. The buttons in the “Axes” group on the “Layout” tab in the “Chart Tools” contextual tab in the Ribbon allow you to set the placement, labeling, and gridline appearance of the axes of the chart. To change the axes display, first select the chart or an element in the chart whose axes you wish to format. Using the “Axes” button you can change the positioning and labeling of the selected axis. Using the “Gridlines” button you can change the appearance and labeling of the gridlines that appear on each axis.
2. Next, you can click either the “Axes” or “Gridlines” buttons, depending upon what you want to format.
3. Then select which axis or axis gridlines you want to format by rolling over your desired choice in the drop-down menu.
4. You can then apply a selected formatting to the selected axis from the side menus that appear.
5. Also note that, like the buttons in the “Labels” group, you can select the “More (object name) Options…” choice in the drop-down menus that appear to open the “Format (object name)” dialog box.
6. Here you can set additional formatting options for the selected axis or axis gridlines.
7. Once you have finished making your custom formatting changes, you can then click the “Close” button to close this dialog box.

CHANGING THE CHART BACKGROUND:

1. You can change the display of the background of your chart using the buttons that are available in the “Background” group on the “Layout” tab in the “Chart Tools” contextual tab within the Ribbon. The buttons that are available within this group are “Plot Area,” “Chart Wall,” “Chart Floor,” and “3-D Rotation.” Depending upon the chart type that you selected you may have only some of these buttons available.
2. To use one of these buttons, click on the button that corresponds to the element of the chart background that you want to format.
3. Then select whether or not you want to hide the selected element, or display the element with the default fill color applied in the chart.

(cont’d.)
4. Note that these buttons also contain the “More (object name) Options…” command at the bottom of each button’s drop-down menu. You can select this command to open the “Format (object name)” dialog box.

5. In this dialog box, you can change the appearance of the selected element as desired using the categories and options shown.

6. Once you have finished applying your desired formatting changes, you can click the “Close” button to close the dialog box.

APPLYING CHART ANALYSIS LINES:

1. If you select a chart type that makes uses of analysis lines, such as a “Line” or “Scatter” chart type, then you can use the buttons that are available in the “Analysis” group on the “Layout” tab of the “Chart Tools” contextual tab within the Ribbon to add lines that extend and enhance the information shown within the selected chart. You can add normal trendlines and projected trendlines, error bars, up/down bars, and drop lines to your data markers. The buttons included in this group are “Trendline,” “Lines,” “Up/Down Bars,” and “Error Bars.”

2. To add one of these types of lines to your selected chart, just click the button that corresponds to the type of line that you want to add and then select your desired choice of analysis line from the drop-down menu that appears.

3. For all of the buttons with the exception of the “Lines” button, you can also choose the “More (object name) Options…” command at the bottom of the drop-down menu to open the “Format (object name)” dialog box.

4. You can then use the categories at the left side and their corresponding options at the right side of the dialog box to set whatever formatting options you want to apply to the analysis lines. Note that if you choose this option for applying some types of analysis lines, you may need to select for which series in your chart you wish to add the analysis line in the “Add (object name)” dialog box that appears. Then you can format the desired analysis line for the selected series, as desired.

NAMING CHARTS:

1. You can click into the “Chart Name:” text box in the “Properties” group on the “Layout” tab of the “Chart Tools” contextual tab within the Ribbon to type a name for your currently selected chart.

APPLYING SHAPE STYLES TO CHART ELEMENTS:

1. You can select any chart element within a chart and then apply formatting changes to the shape of the selected chart element by using the preset object styles listed in the “Shape Styles” list in the “Shape Styles” group on the “Format” tab of the “Chart Tools” contextual tab within the Ribbon. To do this, simply select the chart element whose shape you wish to change, and then click on the desired preset shape style in the list to apply it to the selected chart element.

(cont’d.)
ACTIONS - Formatting Charts in Excel 2010 & 2007

APPLYING SHAPE STYLES TO CHART ELEMENTS (CONT'D.):

2. To apply your own custom formatting, you can use the “Shape Fill,” “Shape Outline,” and “Shape Effects” buttons to the selected chart element.
3. If you want to customize the appearance of the inner fill effect applied to your currently selected chart element, then click the “Shape Fill” button. In the drop-down menu that appears, you can select a fill color, a picture, a gradient, or a texture to apply to the selected object.
4. If you want to customize the appearance of the formatting of the outline, border, or line that you have selected in your chart, then click the “Shape Outline” button.
5. In the drop-down menu that appears, you can then select a color for the selected line. You can also roll your mouse pointer down to the “Weight,” “Dashes,” or “Arrows” commands and then select a desired choice from the side menu that appears.
6. Also note that many of the side menus have a “More (object name)” command available at the bottom of the menu of choices. You can always select this command to open the “Format (object name)” dialog box, where you can customize the appearance of the selected object down to the last detail.
7. If you do open this dialog box to make custom changes, just click the “Close” button to close it when you are finished.
8. You can also apply a custom effect to your selected chart element by clicking the “Shape Effects” button and then rolling down to the general effect category that you want to apply in the drop-down menu that appears. You can then select the desired variant to apply in the side menu of category choices shown.

APPLYING WORDART STYLES TO CHART ELEMENTS:

1. Select the chart element that contains text which you want to format. Then click on the desired WordArt style that you wish to apply in the “WordArt Styles” list in the “WordArt Styles” group on the “Format” tab in the “Chart Tools” contextual tab within the Ribbon.
2. If you wish to apply your own custom formatting to a selected text-containing chart element, you may use the “Text Fill,” “Text Outline” and “Text Effects” buttons in the “WordArt Styles” group to apply your own custom formatting to the selected text.
3. If you click the “Text Fill” button, you will have the option of filling the text in the shape with a selected color, a picture, a gradient, or a texture.
4. You can use the “Text Outline” button to select the color, weight, arrow, and dash style of the outline of the text within the selected chart element.
5. You can then use the “Text Effects” button to select an effect to apply to the text within the selected chart element. Just roll your mouse pointer down to the category of effect that you want to apply to the text, and then select a specific variant of that stylistic category from the side menu of choices that appears.
SAVING CUSTOM CHART TEMPLATES:

1. Select the chart that you wish to save.
2. Next, click the “Save As Template” button in the “Type” group on the “Design” tab of the “Chart Tools” contextual tab within the Ribbon.
3. In the “Save Chart Template” dialog box that appears, type a name for the template into the “File name:” text box. Do not change the location to which the file will be saved. Then click the “Save” button to finish saving your chart template.
4. In the future, you can apply the saved custom chart template to any chart that you create. To do this, select the chart to which you want to apply the custom chart template.
5. Then click the “Change Chart Type” button in the “Type” group on the “Design” tab of the “Chart Tools” contextual tab within the Ribbon. This will open the “Change Chart Type” dialog box.
6. Click the “Templates” category from the list at the left side of this dialog box and then select the desired template to apply from the list of saved templates that appears at the right side of the dialog box.
7. Then click the “OK” button to apply the template to the selected chart.
8. When you want to delete the custom chart type that you have created, you can also do that by using the “Change Chart Type” dialog box.
9. In the “Change Chart Type” dialog box, click the “Manage Templates…” button in the lower left corner of the dialog box. Doing this causes Windows to open the folder where the template files are located on your computer.
10. In the window that appears, select the name of the chart template file that you created and now wish to delete from the list shown. Then press the “Delete” key on your keyboard to delete the file.
11. You can then close the window when you are finished.
12. Then click the “Close” button in the upper right corner of the “Change Chart Type” dialog box to close it.
**Purpose:**

1. To be able to make formatting and layout modifications to a chart in Excel 2010 and 2007.

**Exercises:**

1. Open the “Table Sample” workbook completed through the Exercise at the end of Chapter 27.
2. Click the “Sheet3” worksheet.
3. Click on the embedded column chart in “Sheet3” that was created in the Exercise at the end of Chapter 27.
4. Click the “Layout” tab in the “Chart Tools” contextual tab within the Ribbon.
5. Click the “Text Box” button in the “Insert” group.
6. Click and drag a small text box area in the lower-right corner of the column chart.
7. Type “Created by (your name).” into the text box.
8. Click on the “Chart Title” in the chart to select it.
9. Click the “Format” tab in the “Chart Tools” contextual tab within the Ribbon.
10. Click on “Colored Outline- Blue, Accent 1” in the “Shape Styles” list to apply it to the chart title. This is the style in the first row and second column within the listing of styles shown.
11. Select the “Fill- White, Drop Shadow” WordArt style shown in the “WordArt Styles” group to apply the selected style to the chart title. This is the choice in the first row and third column within the listing of styles shown.
12. Use the “Current selection” drop-down in the “Current Selection” group to choose “Series “Sum of Daily Sales”” from the drop-down.
13. Click the “Shape Effects” button in the “Shape Styles” group.
14. Roll your mouse pointer down to the “Shadow” category in the button’s drop-down menu.
15. Select the “Offset Diagonal Bottom Right” shadow in the “Outer” subcategory in the side menu that appears to apply that shadow style to the pie. This is the choice in the upper-left corner of the “Outer” shadow subcategory.
16. Click the “Save” button in the Quick Access Toolbar to save your changes.
17. You can then close the workbook.
# Excel Keyboard Shortcuts

## Category: Using Windows

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch to the next window</td>
<td>Alt + Tab</td>
</tr>
<tr>
<td>Switch to previous window</td>
<td>Alt + Shift + Tab</td>
</tr>
<tr>
<td>Close window</td>
<td>Ctrl + W or Ctrl + F4</td>
</tr>
<tr>
<td>Restore window after maximizing it</td>
<td>Alt + F5</td>
</tr>
<tr>
<td>Move clockwise to task pane</td>
<td>F6</td>
</tr>
<tr>
<td>Move counterclockwise to next task pane</td>
<td>Shift + F6</td>
</tr>
<tr>
<td>Switching windows when multiple windows are open</td>
<td>Ctrl + F6</td>
</tr>
<tr>
<td>Switch to previous window</td>
<td>Ctrl + Shift + F6</td>
</tr>
<tr>
<td>Maximize/Restore window</td>
<td>Ctrl + F10</td>
</tr>
<tr>
<td>Copy screen to clipboard</td>
<td>Print Screen</td>
</tr>
<tr>
<td>Copy window to clipboard</td>
<td>Alt + Print Screen</td>
</tr>
</tbody>
</table>

## Category: Using Dialog Boxes

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch between screen and dialog box (if possible)</td>
<td>Alt + F6</td>
</tr>
<tr>
<td>Move to next option</td>
<td>Tab</td>
</tr>
<tr>
<td>Move to previous option</td>
<td>Alt + Tab</td>
</tr>
<tr>
<td>Move to next tab</td>
<td>Ctrl + Tab</td>
</tr>
<tr>
<td>Move to previous tab</td>
<td>Ctrl + Shift + Tab</td>
</tr>
<tr>
<td>Move between options in a drop-down menu or option group</td>
<td>Arrow keys</td>
</tr>
<tr>
<td>Perform button action or select/clear a checkbox</td>
<td>Spacebar</td>
</tr>
<tr>
<td>Select an option or select/clear a checkbox</td>
<td>Alt + underlined letter in option</td>
</tr>
<tr>
<td>Open a drop-down menu</td>
<td>Alt + Down Arrow</td>
</tr>
<tr>
<td>Select drop-down option</td>
<td>First letter of option</td>
</tr>
<tr>
<td>Close list/ Cancel</td>
<td>Esc</td>
</tr>
<tr>
<td>Run command</td>
<td>Enter</td>
</tr>
</tbody>
</table>

## Category: Text

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to start of text</td>
<td>Home</td>
</tr>
<tr>
<td>Move to end of text</td>
<td>End</td>
</tr>
<tr>
<td>Move left one character</td>
<td>Left Arrow</td>
</tr>
<tr>
<td>Move right one character</td>
<td>Right Arrow</td>
</tr>
<tr>
<td>Move one word to left</td>
<td>Ctrl + Left Arrow</td>
</tr>
<tr>
<td>Move right one word</td>
<td>Ctrl + Right Arrow</td>
</tr>
<tr>
<td>Select/Deselect to left</td>
<td>Shift + Left Arrow</td>
</tr>
<tr>
<td>Select/Deselect to right</td>
<td>Shift + Right Arrow</td>
</tr>
<tr>
<td>Select/Deselect word left</td>
<td>Ctrl + Shift + Left Arrow</td>
</tr>
<tr>
<td>Select/Deselect word right</td>
<td>Ctrl + Shift + Right Arrow</td>
</tr>
<tr>
<td>Select to beginning</td>
<td>Shift + Home</td>
</tr>
<tr>
<td>Select to end</td>
<td>Shift + End</td>
</tr>
</tbody>
</table>

## Category: Using the “Open” and “Save As” Dialog Boxes

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show “Open” dialog box</td>
<td>Ctrl + O or Ctrl + F12</td>
</tr>
<tr>
<td>Show “Save As” dialog box</td>
<td>F12</td>
</tr>
<tr>
<td>Move to previous folder</td>
<td>Alt + 1</td>
</tr>
<tr>
<td>Move up one level</td>
<td>Alt + 2</td>
</tr>
<tr>
<td>Delete selected folder/file</td>
<td>Del or Delete</td>
</tr>
<tr>
<td>Create new folder</td>
<td>Alt + 4</td>
</tr>
<tr>
<td>Switch folder view</td>
<td>Alt + 5</td>
</tr>
<tr>
<td>Show shortcut menu</td>
<td>Shift + F10</td>
</tr>
<tr>
<td>Move between options</td>
<td>Tab</td>
</tr>
<tr>
<td>Open the “Look in” list</td>
<td>F4 or Alt + 1</td>
</tr>
</tbody>
</table>

## Category: Undoing and Redoing Actions

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cancel action</td>
<td>Esc</td>
</tr>
<tr>
<td>Undo Action</td>
<td>Ctrl + Z</td>
</tr>
<tr>
<td>Redo/Repeat Action</td>
<td>Ctrl + Y</td>
</tr>
</tbody>
</table>
## Excel Keyboard Shortcuts

### Category: Moving and Scrolling in Worksheets/Workbooks

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move one cell up, down, left or right</td>
<td>Arrow Keys</td>
</tr>
<tr>
<td>Move to the edge of the current data region</td>
<td>CTRL + arrow key</td>
</tr>
<tr>
<td>Move to the beginning of the row</td>
<td>HOME</td>
</tr>
<tr>
<td>Move to the beginning of the worksheet</td>
<td>CTRL + HOME</td>
</tr>
<tr>
<td>Move to the last cell on the worksheet</td>
<td>CTRL + END</td>
</tr>
<tr>
<td>Move down one screen</td>
<td>PAGE DOWN</td>
</tr>
<tr>
<td>Move up one screen</td>
<td>PAGE UP</td>
</tr>
<tr>
<td>Move one screen to the right</td>
<td>ALT + PAGE DOWN</td>
</tr>
<tr>
<td>Move one screen to the left</td>
<td>ALT + PAGE UP</td>
</tr>
<tr>
<td>Move to the next sheet in the workbook</td>
<td>CTRL + PAGE DOWN</td>
</tr>
<tr>
<td>Move to the previous sheet in the workbook</td>
<td>CTRL + PAGE UP</td>
</tr>
</tbody>
</table>

### Category: Entering Data

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Complete a cell entry and move down in the selection</td>
<td>ENTER</td>
</tr>
<tr>
<td>Start a new line in the same cell</td>
<td>ALT + ENTER</td>
</tr>
<tr>
<td>Fill the selected cell range with the current entry</td>
<td>CTRL + ENTER</td>
</tr>
<tr>
<td>Complete a cell entry and move up in the selection</td>
<td>SHIFT + ENTER</td>
</tr>
<tr>
<td>Complete a cell entry and move to the right in the selection</td>
<td>TAB</td>
</tr>
<tr>
<td>Complete a cell entry and move to the left in the selection</td>
<td>SHIFT + TAB</td>
</tr>
<tr>
<td>Cancel a cell entry</td>
<td>ESC</td>
</tr>
<tr>
<td>Delete the character to the left of the insertion point, or delete the selection</td>
<td>DELETE</td>
</tr>
<tr>
<td>Delete text to the end of the line</td>
<td>CTRL + DELETE</td>
</tr>
<tr>
<td>Move one character up, down, left or right</td>
<td>Arrow Keys</td>
</tr>
<tr>
<td>Move to the beginning of the line</td>
<td>HOME</td>
</tr>
<tr>
<td>Repeat the last action</td>
<td>F4 or CTRL + Y</td>
</tr>
</tbody>
</table>

### Category: Selecting Cells, Columns, or Rows

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extend the selection by one cell</td>
<td>SHIFT + arrow key</td>
</tr>
<tr>
<td>Extend the selection to the last nonblank cell in the same column or row as the active cell</td>
<td>CTRL + SHIFT + arrow key</td>
</tr>
<tr>
<td>Extend the selection to the beginning of the row</td>
<td>SHIFT + HOME</td>
</tr>
<tr>
<td>Extend the selection to the beginning of the worksheet</td>
<td>CTRL + SHIFT + HOME</td>
</tr>
<tr>
<td>Extend the selection to the last used cell on the worksheet (lower-right corner)</td>
<td>CTRL + SHIFT + END</td>
</tr>
<tr>
<td>Select the entire column</td>
<td>CTRL + SPACEBAR</td>
</tr>
<tr>
<td>Select the entire row</td>
<td>SHIFT + SPACEBAR</td>
</tr>
<tr>
<td>Select the entire worksheet</td>
<td>CTRL + A</td>
</tr>
<tr>
<td>Select only the active cell when multiple cells are selected</td>
<td>SHIFT + BACKSPACE</td>
</tr>
<tr>
<td>Extend the selection down one screen</td>
<td>SHIFT + PAGE DOWN</td>
</tr>
<tr>
<td>Extend the selection up one screen</td>
<td>SHIFT + PAGE UP</td>
</tr>
<tr>
<td>Select whole data area around active cell</td>
<td>CTRL + SHIFT + *</td>
</tr>
</tbody>
</table>

### Category: Other Functions

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display the “Print” dialog box</td>
<td>CTRL + P</td>
</tr>
<tr>
<td>Insert a new worksheet</td>
<td>SHIFT + F11</td>
</tr>
</tbody>
</table>

### Category: Inserting, deleting and copying a selection

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy the selection</td>
<td>CTRL + C</td>
</tr>
<tr>
<td>Cut the selection</td>
<td>CTRL + X</td>
</tr>
<tr>
<td>Paste the selection</td>
<td>CTRL + V</td>
</tr>
<tr>
<td>Clear the contents of the selection</td>
<td>DELETE</td>
</tr>
<tr>
<td>Delete the selection</td>
<td>CTRL + HYPHEN</td>
</tr>
<tr>
<td>Copy the selection</td>
<td>CTRL + C</td>
</tr>
</tbody>
</table>
# Excel Keyboard Shortcuts

## Category: Outlining Data

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group rows or columns</td>
<td>ALT + SHIFT + RIGHT ARROW</td>
</tr>
<tr>
<td>Ungroup rows or columns</td>
<td>ALT + SHIFT + LEFT ARROW</td>
</tr>
<tr>
<td>Display or hide outline symbols</td>
<td>CTRL + 8</td>
</tr>
<tr>
<td>Hide selected rows</td>
<td>CTRL + 9</td>
</tr>
<tr>
<td>Unhide selected rows</td>
<td>CTRL + SHIFT + (</td>
</tr>
<tr>
<td></td>
<td>(opening parenthesis)</td>
</tr>
<tr>
<td>Hide selected columns</td>
<td>CTRL + 0 (zero)</td>
</tr>
<tr>
<td>Unhide selected columns</td>
<td>CTRL + SHIFT + )</td>
</tr>
<tr>
<td>(closing parenthesis)</td>
<td></td>
</tr>
</tbody>
</table>

## Category: Working in Cells or the Formula Bar

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit the active cell and then clear it, or delete the preceding character in the active cell as you edit cell contents</td>
<td>BACKSPACE</td>
</tr>
<tr>
<td>Complete a cell entry</td>
<td>ENTER</td>
</tr>
<tr>
<td>Enter a formula as an array formula</td>
<td>CTRL + SHIFT + ENTER</td>
</tr>
<tr>
<td>Cancel an entry in the cell or formula bar</td>
<td>ESC</td>
</tr>
<tr>
<td>Display the Formula Palette after you type a function name in a formula</td>
<td>CTRL + A</td>
</tr>
<tr>
<td>Insert the argument names and parentheses for a function after you type a function name in a formula</td>
<td>CTRL + SHIFT + A</td>
</tr>
<tr>
<td>Insert a hyperlink</td>
<td>CTRL + K</td>
</tr>
<tr>
<td>Activate a hyperlink</td>
<td>ENTER (in a cell with a hyperlink)</td>
</tr>
<tr>
<td>Edit the active cell and position the insertion point at the end of the line</td>
<td>F2</td>
</tr>
<tr>
<td>Paste a defined name into a formula</td>
<td>F3</td>
</tr>
<tr>
<td>Paste a function into a formula</td>
<td>SHIFT + F3</td>
</tr>
<tr>
<td>Calculate all sheets in all open workbooks</td>
<td>F9</td>
</tr>
<tr>
<td>Calculate all sheets in the active workbook</td>
<td>CTRL + ALT + F9</td>
</tr>
</tbody>
</table>

## Category: Working in Cells or the Formula Bar (cont’d.)

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calculate the active worksheet</td>
<td>SHIFT + F9</td>
</tr>
<tr>
<td>Start a formula</td>
<td># (equal sign)</td>
</tr>
<tr>
<td>Insert the AutoSum formula</td>
<td>ALT + = (equal sign)</td>
</tr>
<tr>
<td>Enter the date</td>
<td>CTRL + ; (semicolon)</td>
</tr>
<tr>
<td>Enter the time</td>
<td>CTRL + SHIFT + :</td>
</tr>
<tr>
<td>Copy the value from the cell above the active cell into the cell or the formula bar</td>
<td>CTRL + SHIFT + “</td>
</tr>
<tr>
<td>(quotation mark)</td>
<td></td>
</tr>
<tr>
<td>Alternate between displaying cell values and displaying cell formulas</td>
<td>CTRL + ‘ (single left quotation mark)</td>
</tr>
<tr>
<td>Copy a formula from the cell above the active cell into the cell or the formula bar</td>
<td>CTRL + ‘ (apostrophe)</td>
</tr>
<tr>
<td>Display the AutoComplete list</td>
<td>ALT + DOWN ARROW</td>
</tr>
</tbody>
</table>

## Category: Formatting Data

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display the “Insert” cells dialog box</td>
<td>CTRL + SHIFT + + (plus sign)</td>
</tr>
<tr>
<td>Display the “Delete” cells dialog box</td>
<td>CTRL + SHIFT + - (minus sign)</td>
</tr>
<tr>
<td>Display the Style dialog box</td>
<td>Alt + ‘ (apostrophe)</td>
</tr>
<tr>
<td>Display the Format Cells dialog box</td>
<td>CTRL + 1</td>
</tr>
<tr>
<td>Apply the General number format</td>
<td>CTRL + SHIFT + ~</td>
</tr>
<tr>
<td>Apply the Currency format with two decimal places (negative numbers appear in parentheses)</td>
<td>CTRL + SHIFT + $</td>
</tr>
<tr>
<td>Apply the Percentage format with no decimal places</td>
<td>CTRL + SHIFT + %</td>
</tr>
<tr>
<td>Apply the Exponential number format with two decimal places</td>
<td>CTRL + SHIFT + ^</td>
</tr>
<tr>
<td>Apply the Date format with the day, month and year</td>
<td>CTRL + SHIFT + #</td>
</tr>
</tbody>
</table>
## Category: Formatting Data (cont’d.)

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply the Time format with the hour and minute, and indicate A.M. or P.M.</td>
<td>CTRL + SHIFT + @</td>
</tr>
<tr>
<td>Apply the Number format with two decimal places, thousands separator, and minus sign (-) for negative values</td>
<td>CTRL + SHIFT + !</td>
</tr>
<tr>
<td>Apply the outline border</td>
<td>CTRL + SHIFT + &amp;</td>
</tr>
<tr>
<td>Remove outline border</td>
<td>CTRL + SHIFT + _</td>
</tr>
<tr>
<td>Apply or remove bold formatting</td>
<td>CTRL + B or CTRL + 2</td>
</tr>
<tr>
<td>Apply or remove italic formatting</td>
<td>CTRL + I or CTRL + 3</td>
</tr>
<tr>
<td>Apply or remove an underline</td>
<td>CTRL + U or CTRL + 4</td>
</tr>
<tr>
<td>Apply or remove strikethrough formatting</td>
<td>CTRL + 5 or CTRL + 5</td>
</tr>
<tr>
<td>Hide rows</td>
<td>CTRL + 9</td>
</tr>
<tr>
<td>Unhide rows</td>
<td>CTRL + SHIFT + (</td>
</tr>
<tr>
<td>Toggle between hiding, showing, and showing placeholder for objects</td>
<td>(opening parenthesis)</td>
</tr>
<tr>
<td>Hide columns</td>
<td>CTRL + 0 (zero)</td>
</tr>
<tr>
<td>Unhide columns</td>
<td>CTRL + SHIFT + )</td>
</tr>
<tr>
<td></td>
<td>(closing parenthesis)</td>
</tr>
</tbody>
</table>