# Table of Contents

SPREADSHEETS ........................................................................................................... 4

The Basics of Spreadsheet Programmes ...................................................................... 4
  Spreadsheets .............................................................................................................. 4
  Application ............................................................................................................... 5
  Actions .................................................................................................................... 5

Introduction to the Application .................................................................................. 5
  User Interface ........................................................................................................... 6
  Creating a Simple Calc Document .......................................................................... 8

Basic Actions in Spreadsheet Application Calc ....................................................... 11
  Recommended Layout ............................................................................................. 11
  Selecting Cells ......................................................................................................... 11
  Text Input and Editing ............................................................................................ 12
  Saving a File ............................................................................................................. 14
  Opening a File .......................................................................................................... 14
  Creating an Expression ........................................................................................... 15
  Using Built-in Functions ......................................................................................... 16
  Functions of Spreadsheets ...................................................................................... 21
  Logical Functions .................................................................................................... 21
  Autofill Tool ............................................................................................................. 24

Formatting a Cell ........................................................................................................ 25
  Number Format ........................................................................................................ 26
  Formatting Content .................................................................................................. 27
  Formatting a Cell ...................................................................................................... 28

Actions in a Workbook ............................................................................................... 31
  Modifying Width of Columns, Rows ....................................................................... 32
  Inserting a Column, a Row ...................................................................................... 32
  Inserting a Worksheet .............................................................................................. 33
  Changing the Name of a Worksheet ........................................................................ 33
  Deleting a Row, a Column, a Worksheet ................................................................. 34
  Copying and Moving ............................................................................................... 34

Charts ........................................................................................................................... 40
  Inserting a Chart ...................................................................................................... 40
  Formatting a Chart .................................................................................................. 41
  Formatting Chart Elements ..................................................................................... 42

Work with Data ........................................................................................................... 47
  Data Sorting ............................................................................................................. 47
  Find and Replace ..................................................................................................... 48
  Freezing a Pane ......................................................................................................... 49

Preparation of a Document ......................................................................................... 51
  Formatting a Document Printout ............................................................................. 51
  Creating a Header, Footer ....................................................................................... 53
  Setting a Print Range ............................................................................................... 54
  Adding Column and Row Headers to Printed Pages .............................................. 55

Saving a Worksheet in Different Formats ................................................................. 56
Other Actions in the Calc Application

Help Function

Help in Work with Application
Help in Error Correction
MODULE 4

SPREADSHEETS

In this module, you will learn how to:

- work in the environment of Calc;
- create a workbook;
- to draw up a formula for calculations;
- use built-in options;
- use cell formatting;
- apply changes to Calc document;
- insert charts;
- arrange data in a specific order;
- prepare a document for printing;
- use the Help function.

The Basics of Spreadsheet Programmes

Spreadsheets

Spreadsheet applications are used for fast and accurate calculations and formatting of a data document. The potential of spreadsheets is practically unlimited – they are used for financial documents, reports, invoices, processing information from scientific researches, statistical analysis, calculations of costs for activities, etc. Spreadsheet applications are used as a universal programme for structured data preparation and processing.

Spreadsheets allow creating large and clear schedules, e.g., for the execution of a project.

Spreadsheet software also allows opening files of many other specialized accounting applications.

In practice, a spreadsheet document created and formatted may be used. The user must know how to insert data in a spreadsheet; formulas have already been created and inserted, and a document will be formatted and ready for printing.

Various pictures, charts and drawings may already be added to spreadsheets.

Note!

The tutorial looks at the application OpenOffice.org Calc version 3.2 in the Gnome environment of the operating system Linux Ubuntu 10.10.
The folder 4_izklajlapas4_spreadsheets with the templates of assignments must be copied to the Documents folder of the user’s account.

**Application**

In the OpenOffice.org application suite, spreadsheets are used with the Calc application.

The OpenOffice.org suite also includes a word processor for creation of documents, a presentations application, a database management programme, a drawing programme and several other additional programmes and modules. These programmes are developed and maintained by an online community with the support of software company Oracle. This software is free and is included with the Linux operating system.

**Actions**

In order to achieve successful results with the spreadsheet application, the following tools are available for work:

- The graphical environment of the programme – the user interface;
- The left mouse click;
- The double left mouse click;
- The right-click menu;
- The keyboard for input of data and formula, and commands;
- The „drag-and-drop“ technique;
- Skills in basic actions with text.

**Introduction to the Application**

**To open OpenOffice Calc:**

Perform the command Applications→Office→OpenOffice.org Spreadsheet in the Applications menu of the operating system.

The application document is called a workbook. A workbook consists of worksheets. By default, a new workbook contains three worksheets, but the number of worksheets can be modified. There are maximum 256 worksheets per workbook in the application OpenOffice.org Calc.
Each worksheet is divided into vertical columns and horizontal rows, forming **cells**, in which both information and formulas can be entered.

Columns are identified with letters of the Latin alphabet (and combinations thereof), while rows are identified with ordinal numbers.

A cell is identified by its **column letter (letters) and row number**, e. g., **A4**:

![Spreadsheet Cells](image)

A cell can be considered the basic element of a spreadsheet. Data, formulas are entered in a cell. Cells are formatted, which determines the design and layout of their content.

**Note:**

In work with large documents containing many spreadsheets, the user may come across limits for application capacity, e. g., the number of spreadsheets per workbook, the maximum number of rows and columns. Software developers are constantly updating software and the 3.3. version of the software contains 1,024 columns and 1,048,576 rows.

Limits for amounts of data can be increased by an aid of additional measures. However, specific knowledge is required.

**User Interface**
The menu bar contains menus with commands for various tasks. The names of the menus correspond to the functions of the commands:

- **File** – commands that refer to the entire document such as creating a new OOO document, creating a workbook, saving, a document creation wizard, printing, print preview;
- **Edit** – editing commands, such as copy, paste, find & replace;
- **View** – **adding or removing elements of the user interface**, page break preview;
- **Insert** – Inserting of rows, columns, worksheets, elements and objects;
- **Format** – formatting cells and their content, merging cells, element grouping and sorting, conditional formatting;
- **Tools** – tools for additional tasks, such as spellchecking, document protection, formulas, error correction;
- **Data** – data processing, data sorting and data filter;
- **Window** – opening a new window, freezing cells, list of open OpenOffice.org documents;
- **Help** – the help function, information about an application, the software version.

A triangle indicates submenus in a menu:
If additional input is needed for the execution of a command, the programme opens a dialogue box, in which the user has to make a selection or adjust additional settings.

An ellipsis indicates that a dialogue box will be open:

A toolbar features common commands in the shape of onscreen buttons. By hovering the mouse pointer over a button, the name of the corresponding function appears.

Toolbars can be turned off and on with as needed by performing the command View→Toolbars.

Useful tip:
Descriptions of software often use the terms *default*, *by default*. It refers to the default software settings which are used when the user has not specified otherwise.

For example, cell borders in Calc are black by default, but the user can change this colour as desired.

After the OpenOffice.org Calc activation, default toolbars are seen:
- **Standard** – most frequently used commands from the File, Edit, Insert menus;
- **Formatting** – most frequently used commands for formatting content in a cell;
- **Formula Bar** – a toolbar of a formula used to enter and edit a formula (formulas) and the content of a cell.

Buttons in toolbars can be modified; the user can add buttons to the toolbar, remove them and adjust their sequence.

**Note!**
Toolbars can open and close automatically depending on the selected option in the Calc workbook.

The zoom tool (I – zoom in Image 1) can be used to zoom a worksheet.

Each workbook is opened in a separate Calc.

**Creating a Simple Calc Document**

At this stage, entering data and simple calculations in a worksheet will be mastered, such as a new unit of a company is established and office premises should be arranged.

Useful tip
An action can be reverted by using the menu command **Edit→Undo** or the **Undo** button in the toolbar. An undone action can be restored with the **Redo** button.

**Task 4.1. Create a workbook to register all the costs related with the office arrangements and calculate the total costs.**

1. **Open OpenOffic.org Calc:**
   1.1. Perform the command **Applications→Office→OpenOffice.org Spreadsheet** in the Applications menu of the operating system.

2. **Enter the following data:**

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Position</td>
<td>Quantity</td>
<td>Price</td>
<td>Amount</td>
</tr>
<tr>
<td>3</td>
<td>desk</td>
<td>3</td>
<td>45</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>laptop</td>
<td>3</td>
<td>678.56</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>phone</td>
<td>1</td>
<td>34</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>chair</td>
<td>7</td>
<td>54</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>WFi AP</td>
<td>1</td>
<td>23</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td>Total:</td>
</tr>
</tbody>
</table>

2.1. Left-click on the cell A1;
2.2. Enter the word **Position**;
2.3. Press the **Enter** key;
2.4. Repeat the action to enter data in the first column;
2.5. Left-click on the cell B1;
2.6. Enter data in other columns.

**Note!**
In spreadsheets, it is important to make sure that the correct decimal mark is used. The default setting depends on the operating system, **Calc**, and local cell settings.

The decimal mark can be a period (.) or comma (,).

3. **In the cell E2, enter formula to calculate the costs of each position:**
   3.1. Select the cell E2, left-click on it;
   3.2. Enter the formula: **=C2*D2** (a number multiplied by the costs);

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Position</td>
<td>Quantity</td>
<td>Price</td>
<td>Amount</td>
</tr>
<tr>
<td>3</td>
<td>desk</td>
<td>3</td>
<td>45</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>laptop</td>
<td>3</td>
<td>678.56</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>phone</td>
<td>1</td>
<td>34</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>chair</td>
<td>7</td>
<td>54</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>WFi AP</td>
<td>1</td>
<td>23</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td></td>
<td>Total:</td>
</tr>
</tbody>
</table>

3.3. Press the **Enter** key.

**Note!**
An expression or formula must start with the equals sign (=), otherwise the application identifies it as regular text in a cell (even if a number is entered) and does not perform calculations.

4. Enter the necessary expressions in the cells from \( E_3 \) to \( E_6 \) to multiply the **Quantity** by the **Price**, repeating the previous actions similarly as in item 3.

**Note:**
In spreadsheets, a cell range is identified by the address of the first cell and the address of the last cell, separated with a colon; e.g. \( E_3:E_6 \) refers to cells from \( E_3 \) to \( E_6 \).

5. Calculate the total costs of the office arrangements in the cell \( E_7 \):
   5.1. Select the cell \( E_7 \);
   5.2. Enter a formula: \( E_2+E_3+E_4+E_5+E_6 \)
   5.3. Press the **Enter** key;
6. Save a workbook as **project_budget**;
   6.1. Perform the menu command **File**→**Save** or
   6.1. Click the **Save** button on the **Standard**;
   6.2. In the **File Name field of the Save** dialogue box, enter the name **project_budget**;
   6.3. Confirm the action with the **OK** button;
7. Close a workbook:
   7.1. Perform the menu command **File**→**Exit**.
8. Open the created spreadsheet file:
   8.1. Execute the **Places**→**Documents** menu command with the operating system:
   8.2. Select the file icon with the left mouse click:
   8.3. Press the **Enter** key on the keyboard.
9. Modify data in the table - increase the number of the portable computers:
   9.1. Select the cell \( C_3 \);
   9.2. Enter number **12**;
   9.3. Press the **Enter** key;
   9.4. Check to see if the result was automatically updated in the table.
10. Close a workbook:
    10.1. Click the **Close** button of the application window:
    10.2. Save changes by the **Save** button in the toolbar:
Basic Actions in Spreadsheet Application Calc

To be introduced with the application, following actions had been performed in Task 4.1:

- A new workbook created by opening the application;
- Data entered in separate cells;
- Formulas created;
- A file saved by default on to a computer’s hard drive;
- The created spreadsheet file was opened from its location;
- Data in a table modified;
- Changes saved.

**Note!**

Like in other applications, the **OpenOffice.org Calc** allows performing actions and commands in different ways and achieving the same outcome.

**Recommended Layout**

In practice, spreadsheet documents are created for further usage. A created and formatted workbook can be used anew by changing and restoring data and modifying formulas.

Software should automatically do recalculation corresponding to new data.

A spreadsheet file can also be used by other users therefore it is suggested to use some recommendations for sorting data in a worksheet.

It is recommended to enter even related data in separate cells; e. g., the first and last name of a person should be entered in separate cells.

When arranging data in columns, one should not leave empty rows unless it is necessary. If data is arranged in a table, visually it is better to separate the table from other data with blank, empty cells or with different formatting.

**Selecting Cells**

Text, numbers, formulas and references to other cells can be entered in cells.

Prior to entering or editing information, the cell or a cell range must be specified in the spreadsheet:

- To select a cell to enter information, left-click on it;
- To select the entire column, click on the column header; to select the entire row, click on the row header;
To select a cell range, left-click on the first cell and, without releasing the mouse button, drag the mouse pointer over the cells to be included, until the last cell of the desired range is reached, and then release the button.

To select some non-adjacent cells or non-adjacent cell ranges, at selecting, hold down the Ctrl key;

To select all the cells in a worksheet, click the button in the beginning of the row and column headings:

A selected cell is marked by a black frame.

A selected cell range (ranges) is marked by shading.

**To cancel cell selection,**

Left-click on any blank cell.

**Useful tip:**
The content of the selected cell is displayed in the input field of the toolbar, even when the entire content is not visible in the worksheet itself. The field can also be used to edit the data (G – data input field in Image 1).

A1:B11 specifies the cell range from A1 to B11. An address/location of a cell or a cell range is displayed in the field **Name Box** (F – addresses of selected cells or a name box in Image 1).

Cells must be selected prior to do formatting.

**Text Input and Editing**

Entering text, a number and a formula, deleting and editing require a keyboard.

**To enter text in a cell,**

1. Select a cell;
2. Enter text or other data;
3. Press the **Enter** key on the keyboard.

The content of the cell unlike text editors, can feature various characteristics, e. g., a cell can contain a formula, an outcome of calculation and feature content formatting. Data deleting function can specify elements to be deleted from the content of a cell.

**To delete the content of a cell:**

1. Select a cell (cells) range;
2. Press the **Delete** key on the keyboard;
3. Click in a specific cell to choose a specific menu from the dialogue box;
4. Click the OK button in the dialogue box **Delete Contents**:

![Image 2 Delete cell contents](image)

The following options are available in the **Delete Contents** dialogue box:

- **Delete all** - deletes the entire content of a cell.
- **Text** - deletes text from the cell range selected.
- **Numbers** - deletes numbers from the cell range selected.
- **Date & time** - deletes only date and time from the cell range selected.
- **Formulas** - deletes formulas and outcomes from the cell range selected.
- **Notes** - deletes notes for a cell when any added.
- **Formats** - deletes cell formatting, e. g., removes a fill colour of a number, but a value is not deleted.
- **Objects** - deletes additional elements of a cell, e. g., deletes images.

**Useful tip:**

The **Backspace** key on the keyboard deletes the content of a selected cell or a cell range.

**To edit the content of a cell:**

1. Double left click on a cell;
2. Place the insertion point on location required;
3. Edit the content of a cell;
4. Press the **Enter** key to save changes.
To edit the content of a cell in the formula and data input line:

1. Click on a cell;
2. Place the insertion point in the input line;
3. Edit the content of a cell;
4. Press the Enter key:

![VMware vs-APowerCLI](image1)

To select text in a cell:

1. Place the insertion point on the content of a cell;
2. Perform the left-click;
3. While holding down the mouse button, drag it until the end of the selected area;
4. Release the mouse button:

![VMware vs-APowerCLI](image2)

Saving a File

The OpenOffice.org Calc saves a workbook in a file format with the extension ods.

A folder structure is designed in the operating system and ready for a default use. The user can use this folder structure or create a new one. The Documents folder of the user’s account is the default save location of spreadsheets. The default settings, such as the save location and file format, can be modified and adapted to the user’s needs.

Opening a File

A user should know or be able to find the location on the computer’s hard drive or network where the spreadsheet file is stored. This file can be opened in different ways.

To open a spreadsheet file from the software Calc environment:

1. Execute the menu command File→Open;
2. In the Open dialogue box, select a file from a default folder or find it in another location;
3. Complete the action by clicking the Open button.

To open a spreadsheet file from the folder Documents:

1. Open the folder Documents by executing the operating system menu command Places→Documents:
2. Double left click on the icon of the spreadsheet file.

To open a spreadsheet file with the find function:

1. Execute the operating system menu command Places→Search for Files;
2. In the Name contains field of the Search for Files, enter a full name or a part of the file name;
3. Click the Find button;
4. Double left click on the required result in the list of results:

Creating an Expression

To create a mathematical expression, numbers and (or) variables (cell addresses) are used together with mathematical symbols.

It is better to create expressions with cell addresses rather than numbers, even in the case of small tables. This will allow reusing the created worksheet – it will always be possible to change the cell values without rewriting the expression.

When a cell address used in an expression, the calculation uses the value of the cell at the respective time. Changing the value of a cell used in an expression also changes the result of the expression.
An expression should always begin with the equals sign in the cell where the result is to be displayed.

Mathematical symbols:
- Addition – plus sign (+);
- Subtraction – minus sign (-);
- Division – fraction slash (/);
- Multiplication – asterisk (*);
- Exponentiation - ^ symbol.

Using Built-in Functions

Spreadsheet applications typically have built-in standard functions for mathematical, logical, statistical, date and time, financial and other calculations and functions for actions with text.

A function begins with the equals sign, followed by a function name specified in an application and function argument or several arguments specified in brackets, e.g., cell addresses, numbers, text, constants, and other values or functions.

Useful tip:
If the correct spelling of a function is known, it is possible to enter it in the input line, but it is easier to use the function wizard and just fill the argument fields.

Functions can also be inserted in other functions, which allows for complex calculations without obtaining subtotals.

\[=\text{SUM}(C1:C22)\]

A – function, B – argument

Image 3. Function with a single argument – this example adds all values of cells C1 to C22.

The process of inserting a function is similar for all functions, only the functions-specific arguments and the spelling of the function change.

To enter a function:

1. Select a cell in which to display the result;
2. Enter the function in the input line:
   2.1. Put the equals sign at the beginning;
   2.2. Enter a symbol of a function and focus on correct spelling of a function;
   2.3. Enter function arguments.
3. Press the Enter key;

To enter a function with an aid of a wizard:

1. Select a in which to display the result.
2. Enter a function:
   2.1. Execute the menu command **Insert−Function**;
   or
   2.1. Use the key combination **Ctrl+F2**;
   or
   2.1. Press the **Function Wizard** key in the formula toolbar:

3. Choose a necessary function in the dialogue box of a function wizard;

4. Click the **Next** button;

5. Enter function arguments:
   5.1. Enter function arguments in appropriate fields;
   or
   5.1. Click the **Select** button on the argument field;
5.2. Select an argument cell or a cell group:

![Spreadsheet example]

5.3. Press the Enter key or the Maximize button.

![Function Wizard example]

6. Click the OK button in the Function Wizard dialogue box:

![Function Wizard dialogue box]

In Task 4.1 (Page 9), the sum in cell E7 could have also been obtained with the other methods specified above.

*Calc* features many built-in functions. The examined methods of function insertion can be used to insert any kind of function. The user has to choose a function and specify its argument (arguments).

**Useful tip:**
To find a function in the Function Wizard more easily, a specific function category can be selected from the Category menu.
Sum is one of the most frequently used functions in spreadsheets, so its button is available in the toolbar.

**To use a toolbar button:**

1. Select a cell in which to display the result;
2. Click the **Sum** button in the formula toolbar;

3. Make sure that the correct cell range has been selected for the argument:
   3.1. The blue border marks the cells automatically added;
   or
   3.1. Select cells to be included in the sum;
4. Press the **Enter** key or the **Accept** button on the formula toolbar.

**Task 4.2.** Office employees spend a lot of time online. A system administrator has specified relevant usage time in a spreadsheet table. Calculate the average amount of time in minutes spent on the Internet per person. Change the total time of the Internet use in hours.

1. Open the **internet_time** workbook in the **4.2_funkcijas4.2_functions** subfolder of the **4_izklajlapas4_spreadsheets** folder;
   1.1. Run the **Calc**;
   1.2. Execute the menu command **File−>Open** or use the key combination **Ctrl+O**;
   1.3. In the folder **Documents**, open the subfolder **4_izklajlapas4_spreadsheets** with a double left click;
   1.4. Open the subfolder **4.2_funkcijas4.2_functions**;
   1.5. Select the file **Internet_time.ods**;
   1.6. Click the **Open** button in the dialogue box **Open**.
2. In the cell **B12**, calculate the average time of the Internet use using the function **AVERAGE**:
   2.1. Select the cell **B12**;
   2.2. Execute the command **Insert→Function** or click the **Function Wizard** button;
   2.3. In the category menu of the dialogue box **Function Wizard**, select all functions by **All**;
   2.4. In the **Function** of the dialogue box **Function Wizard**, select the function **AVERAGE**:
   2.5. Click the **Next** button;
   2.6. Indicate the cell range from B2 to B10 in the function argument:
      2.6.1. Enter **B2:B10** in the formula field **Formula** in brackets after the function symbol:
   2.7. Save changes with the **OK** button in the dialogue box **Function Wizard**:

3. Sum up the total time of the Internet use:
   3.1. Select the cell **B14**;
   3.2. Enter the formula **=SUM(B2:B10)/60**;
3.3. Press the **Enter** key;

4. Save document changes on the computer desktop under another name:
   4.1. Perform the command **File**→**Save As**;
   4.2. In the **Places** pane of the **Save** dialogue box, left-click on the folder **Desktop**:

4.3. In the **Name** field of the **Save** dialogue box, enter the file name **users_time**:

4.4. Save changes by the **Save** button in the dialogue box.

5. Close the application box with the following key combination:
   5.1. Press the **Ctrl** key on the keyboard;
   5.2. Without releasing the **Ctrl** key, press the key with **Q** symbol.

**Useful tip:**
The most frequently used commands can also be executed with keyboard shortcuts. They include universal commands that can be used in other applications, as well. A keyboard shortcut is expressed as the order in which the keys are pressed without releasing the previous ones.

Keyboard shortcuts are shown in menus next to the respective command, e.g.:

**Functions of Spreadsheets**

Most frequently used functions are:

- **MIN** - finds the minimum value in a cell range selected.
- **MAX** - finds the maximum value in a cell range selected.
- **COUNTBLANK** - counts blank cells in a cell range selected.
- **COUNTA** - counts values in a cell range selected. The function **COUNTA** does not count blank cells. Function arguments are cell ranges selected, also several cell ranges selected.
- **ROUND** – rounds the value to a specific number of digits. Correct spelling: =ROUND *(number, count)* in which a **number** stands for a number or a cell address; **count** stands for a number of decimals.

**Logical Functions**
OpenOffice.org Calc and other spreadsheet applications also use logical functions that compare values and return a result based on the specified conditions.

Comparative signs (operators):

- = equal to;
- <> does not equal;
- < less than;
- > greater than;
- <= less than or equal to;
- >= greater than or equals to.

Signs of arithmetic and logical actions can be combined in formulas.

**Function IF**

IF is one of the logical functions of spreadsheets. The function gives a statement and specifies two outcome values: one for when the statement is true, another for when it is false. The function tests the statement and displays the result.

The correct spelling of this function is **IF (Test, Then_value, Otherwise_value)**, where **Test** is the logical statement; **Then_value** is the value if the statement is true; and **Otherwise_value** is the value if the statement is false.

E.g., a formula =IF(A1>5,50,300) was entered in the B1 cell and this features the following:

- If the value of the cell A1 exceeds 5, the value 50 is shown in the cell B1;
- If the value of the cell A1 is less than 5, the value 300 is shown in the cell B1;
- If the value of the cell A1 is 5, the value 300 is shown in the cell B1.

**Useful tip:**

Logical functions can also use values in text form. The text must be inside quotation marks, e.g.:

$$f(x) = \begin{cases} \text{IF}(A1>5,50,\text{"small"}) \end{cases}$$

**Task 4.3.** An employee has undertaken to carry out some assignments under a contract. Calculate the due payment for work provided that assignments are completed and if they are not. Use a coefficient for cost calculations.

1. Open the workbook **logical.ods**:
   1.1. Execute the menu command **Places->Documents** with the operating system;
   1.2. Select the folder 4_izklajlapas4_spreadsheets;
   1.3. Press the **Enter** key on the keyboard;
   1.4. Select the folder 4.3_if;
   1.5. Press the **Enter** key on the keyboard;
   1.6. Double left-click on the icon of the file **logical.ods**.
2. Define the payment sum in case assignments are completed:
   2.1. Select the cell D2;
2.2. Enter the function `IF`, use a function wizard:
   2.2.1. Execute the menu command `Insert–Function`;
   2.2.2. In the **Category menu of the Functions tab**, select the logical functions **Logical**;
   2.2.3. Select the function `If` in the pane **Function**:

   ![Function Wizard](image)

   2.2.4. In the dialogue box Function Wizard, click the **Next** button;
   2.2.5. Fill in the function argument fields in the dialogue box Function Wizard:

   ![Function Wizard](image)

   2.2.6. Save changes with the **OK** button;

3. Copy the created formula in the cells **D3:D8**
   3.1. Select the cell **D2**, and if needed, do the following;
   3.2. Position the mouse pointer on the fill handle (the black dot in the bottom right of the box).

   ![Spreadsheet](image)

   3.3. Without releasing the left mouse button, drag it over cells selected;

   ![Spreadsheet](image)

   3.4. Release the mouse button.

4. Check whether calculations are correct:
   4.1. Enter y in the cells **B4, B5, B7**.

5. Save changes in the workbook:
   5.1. Click the **Save** button in the toolbar.

6. Include a factor in the formula to adjust the payment:
   6.1. Left-click in the cell **F1**;
   6.2. Enter text **Bonus Factor**;
   6.3. Click on the cell **D2** that contains a formula created;
6.4. Place the insertion point after the last bracket in the input line;
6.5. Enter the multiply sign *;
6.6. Enter $F$2, use the dollar sign on the keyboard:

6.7. Press the Enter key on the keyboard.

7. Copy changed formula in other cells of the column:
7.1. Click on the cell D2;
7.2. Click on the handle in the cell box;
7.3. Drag the pointer till the cell D8, without releasing the left mouse button;
7.4. Release the mouse button.

8. Apply a coefficient:
8.1. Click on the cell F2;
8.2. Enter 1.05 in the cell;
8.3. Press the Enter key on the keyboard.

9. Save changes in the workbook:
9.1. Click the Save button in the toolbar.

10. Close the workbook:
10.1. Execute the menu command File→Exit.

AutoFill Tool

In Section 3, Task 4.3, the autofill tool was used to copy the function. Data are usually arranged in tables in spreadsheet applications and each following row retains the structure of the previous row. In such a table, the application can automatically adjust the variables of a function for each next row. The autofill tool can be used for cells of rows and columns.

Advice

A formula created for a data row can be copied in the other cells of structured data rows using the autofill tool. Software is to automatically change the addresses of cells included in a function.

A cell address in the form of A4 is called relative. A cell address in the form of $A$4$ (with the dollar sign ($) added before the row, column) are called absolute, and they do not change when the formula is copied. Absolute addresses always indicate the value of a specific cell. For example, the address $A$A$4$ will always be replaced with the value of the cell A4 in an expression.

When an absolute address is changed, for example, to A$4$, the column will change if the formula is copied with the autofill tool, but the row will stay the same. Conversely, if the address is changed to SA$4$, only the row will change.
To apply autofill for a formula:

1. Select a cell that contains a formula;
2. Left-click on the handle in the cell;
3. Without releasing the mouse button, drag across the desired cell range;
4. Release the mouse button.

To apply autofill to a data sequence – arithmetic progression:

1. Enter a number in the first cell;
2. Enter the next number in the next cell;
3. Select both the cells;
4. Left-click on the handle in the cell;
5. Without releasing the mouse button, drag across the desired cell range;
6. Release the mouse button:

![Image of cell with numbers]

Useful tip:
If the autofill tool is used on a cell with a single number, the value of each subsequent cell is increased by one.

Formatting a Cell

The content of a cell, appearance of its borders and number format depend on format applied to a cell. Formatting can be considered a property of the cell.

Formatting can be applied to:
- A number, the result of a formula;
- Font applied to the content of a cell;
- Alignment for cell contents;
- Cell borders;
- Cell background.

Cell formatting can be applied best in the dialogue box **Format Cells** and in tabs. Commands most frequently used are specified on a formatting toolbar **Formatting**:

A – apply style; B – font, C – font size; D – bold, italic, underline; E – alignment as: left, centred, right, justified; F – merge selected cells; G – currency; H – percent; I – add/delete decimal place; J – decrease/increase indent; K – cell border format; L – background colour of a cell; M – font colour in a cell; N – add/remove unformatted cell border.
To open a dialogue box for cell formatting:

1. Select a cell or a cell range (ranges);
2. Execute the menu command **Format**→**Cells**.

**Number Format**

The number format does not affect the value in the cell or the value used for calculations in **Calc**. The actual value or expression can be seen in the data input line.

Formatting can be applied to a single cell, selected cells and selected cell ranges.

![Format Cells dialogue box in Calc](image5.png)

A – number of decimal places; B – inserting a thousand separator; C – regional settings; D – preview of the selected cell

*Image 5 The Numbers tab of the Format Cells dialogue box in Calc*

**To format the numerical value of a cell:**

1. Select a cell or a cell range;
2. Open the dialogue box **Format Cells**, execute the menu command **Format**→**Cells**;
3. In the **Category** pane of the **Numbers** dialogue box, select the number category;
4. In the pane **Format**, select format;
5. In the field **Decimal Places**, specify the number of decimal places;
6. In the checkbox **Thousands Separator**, tick the separator of thousands, if necessary;
7. Check the selection in the preview;
8. Save changes with the **OK** button.

**Useful tip:**
In the **Language** menu of the **Numbers** tab in the **Format Cells** dialogue box, it is possible to change the regional settings and decimal mark of the selected cell (cells) (see page 9).

**To form a value of a cell as currency:**

1. In the pane **Category**, select **Currency**;
2. In the pane **Format**, select a currency symbol and format.

**To format a value of a cell as percentage:**

1. In the pane **Category**, select **Percent**;
2. Under **Options**, choose the number of decimal places.

**Note!**
The percent format multiplies the cell value by 100, and the obtained value is displayed with the percent sign.

It is often necessary to enter values starting with a zero in a cell – e.g., classification or stock-keeping numbers. To prevent the zero before the number from automatically being deleted, text format is assigned to the cell. In this format, the value of the cell is text, exactly as it is entered.

**To form value of a cell as text:**

In the pane **Category**, select **Text**.

**To apply format for entering date:**

1. In the pane **Category**, select **Date**;
2. In the menu **Language**, select the date style of a region or language.

**Formatting Content**

The font can be selected in the **Font** tab of the **Format Cells** dialogue box; effects can be changed in the **Font Effects** tab.
Font effects most frequently used are:

- **Bold** – in the tab **Font**, select **Bold** in the pane **Typeface**;
- **Italic** – in the tab **Font**, select **Italic** in the pane **Typeface**;
- **Font size** – in the tab **Font**, select font size in the pane **Size**;
- **Font colour** – in the tab **Font Effects**, select **Font Color**;
- **Underlining** – in the **Underlining** menu of the **Font Effects** tab, select underlining.

**Useful tip:**
Buttons for font effects most frequently used are displayed also in the **Formatting** and **Text formatting** toolbars (Image 3).

### Formatting a Cell

The appearance of the selected cells – font colour, borders, arrangement of text and numerical data – can be modified in the tabs of the **Format Cells** dialogue box:

- **Alignment** – horizontal alignment of text, rotating text in a specific angle against the cell edges, wrapping text to fit it in a cell;
- **Borders** – appearance of borders, colour, shading, spacing;
- **Background** – background colour of a cell or range of cells.

**Note!**

Cell borders created by the user will be visible when the spreadsheet is printed out. The dividing lines of the worksheet are not printed by default.

**Task 4.4. Format a workbook and data.**

1. Open the workbook **project.ods**:
1.1. Execute the menu command **Places→Documents** in the operating system;  
1.2. Choose the folder **4_izklajlapas4_spreadsheets**;  
1.3. Press the **Enter** key on the keyboard;  
1.4. Choose the folder **4.4_formatesana4.4_format**;  
1.5. Execute the menu command **File→Open**;  
1.6. Right-click on the file **project.ods** icon.  
1.7. Perform the command **Open With OpenOffice.org Spreadsheet** from the right-click menu:

2. Change font size to **14**  
2.1. Select the cell range **A1:E7** (data range);  
2.2. In the toolbar **Formatting**, choose font size **14**.

3. Apply the currency format to values in the columns **D** and **E**:  
3.1. Select the cells **D2:E6**;  
3.2. Press the **Ctrl** key;  
3.3. Without releasing the **Ctrl** key, add the cell **E7** to the cell selection by clicking the left mouse button on it;  
3.4. Execute the command **Format→Cells**;  
3.5. In the dialogue box **Format Cells**, click on the **Numbers** tab, if needed;  
3.6. In the pane **Category** of the dialogue box, select the category **Currency**;  
3.7. In the **Format** menu, select the format **EUR € English (Eire)**;  
3.8. Check that selected format specifies 2 decimal parts of a number;  
3.9. Save changes with the **OK** button in the dialogue box:

**Note!**
The content of a cell in format ### refers to a narrow cell for data. The value of a cell is not changed and it is displayed when the cell is expanded.

4. Adjust a column to show numbers in all the cells:
   4.1. Place the mouse pointer between the columns E and F;
   4.2. Perform a double left click:

   ![Before and after adjustments](image)

5. Centre text in the first row:
   5.1. Select the cells A1:E1;
   5.2. Centre the cells and use the Align Center Horizontally button in the toolbar:

   ![Align Center Horizontally button](image)

6. Apply green borders to cells of a data range:
   6.1. Select the cell range A1:E7 (data range);
   6.2. Execute the menu command Format→Cells;
   6.3. Open Borders tab in the dialogue box Format Cells, left-click on it;
   6.4. Select the line style 1.00 pt in the pane Style:

   ![Line style selection](image)
   6.5. Choose line colour Green in the Color menu;
   6.6. Choose to set outer border and all inner lines in the Line arrangement pane:

   ![Line arrangement settings](image)
   6.7. Save changes with the OK button.

7. Apply red font colour to the cell showing the total sum:
   7.1. Select the cell E7;
   7.2. Execute the menu command Format→Cells;
   7.3. Open the Background tab in the dialogue box Format Cells;
   7.4. Choose red colour;
   7.5. Save changes.

8. Format Quantity in bold and Italic, select red font colour:
   8.1. Select the cells D2:D6;
   8.2. Click the buttons Bold and Italics in the toolbar:
8.3. Click the button **Font color** in the toolbar;

8.4. Choose red colour:

9. Adjust comments so that they fit in one cell:
   9.1. Left-click on the cell **B10**;
   9.2. Execute the menu command **Format->Cells**;
   9.3. Open the tab **Alignment** in the dialogue box, click on its title;
   9.4. Tick the checkbox **Wrap text automatically**;
   9.5. Click the **OK** button in the dialogue box.

10. Place text **Comments** in the upper part of a cell:
   10.1. Left-click on the cell **A10**;
   10.2. Execute the menu command **Format->Cells**;
   10.3. In the dialogue box, open the **Alignment tab**, click on its title, if necessary;
   10.4. In the menu **Vertical**, select a vertical alignment of the content of a cell

   **Top**:

   10.5. Save changes with the **OK** button in the dialogue box.

11. Save changes with the command **File->Save**;

12. Close the workbook with the menu command **File->Close**.

**Actions in a Workbook**

By default, **Calc** opens a workbook with three worksheets. The number of worksheets can be modified. In larger workbooks, it is more convenient to place different types of calculations and document designs in separate worksheets. Similarly, rows, columns can be added to a formatted workbook, width can be changed and merging cells can be executed.

To switch to other workbook:
Click on the tab of the workbook:

Modifying Width of Columns, Rows

Often, information entered in a cell can exceed the cell’s default size. The adjacent cells cover the data, and it is not visible. Similarly, the result of an expression may also not fit in a cell.

To freely change the width of a column (row):

1. Click on the dividing line between columns (rows);
2. Without releasing the left mouse button, drag it to a direction needed.

To modify width of a column (row) in line with size specified:

1. Select a cell from a column (row);
2. Perform the menu command Format→Column→Width (Format→Row→Height);
3. In the dialogue box, set the width of a column (row height) in inches.

Useful tip:
Default units of measurement given in OpenOffice.org Calc application, can be modified in the dialogue box of setup. Open the dialogue box with the menu command Tools→Options:

Inserting a Column, a Row

Often it is necessary to insert a new row (column) in the middle of an existing worksheet.

To insert a new row:

1. Select a cell in the row above which a new row is needed;
2. Execute the menu command Insert→Rows.
To insert a new column:

1. Select a cell in the column above which a new column is needed;
2. Execute the command Insert→Columns.

*Calc* will automatically adjust the existing functions in the table when the cells included in them are moved to a different column (row).

**Inserting a Worksheet**

**To insert a new worksheet:**

1. Select any cell in a worksheet before or after which a new worksheet is needed;
2. Execute the menu column Insert→Sheet;
3. In the dialogue box Insert Sheet, specify additional options:

   ![Insert Sheet Dialogue Box]

   A – before selected worksheet; B – after selected worksheet; C – number of worksheets to be inserted; D – worksheet name

   Image 6 Inserting a worksheet

4. Save changes with the OK button.

**Changing the Name of a Worksheet**

Assigning a name and tab colour to worksheets will make it easier to manage a workbook with many different sheets.

**To change the name of a worksheet:**

1. Select any cell in a worksheet:
2. Execute the menu command Format→Sheet→Rename;
3. In the dialogue box Rename Sheet, enter a new name;
4. Save changes with the OK button;
or
1. Click the right mouse button on the name of a worksheet;
2. In the menu, execute the command **Rename Sheet**.

**To change tab colour of a worksheet:**

1. Click the right mouse button on the name of a worksheet;
2. Choose the command **Tab Color**;
3. Select colour;
4. Save changes with the **OK** button.

**Deleting a Row, a Column, a Worksheet**

The right-click menu is a universal method to execute additional actions in worksheets, rows, columns.

View additional actions with a column.

**To delete a column and relevant data:**

1. Right-click on the name of a column;
2. Execute the command **Delete Columns**: or
1. Select a column;
2. Execute the menu command **Edit**→**Delete Cells**.

**Copying and Moving**

Cells in spreadsheets can contain numbers, text, expressions (formulas) and their results, formatted as desired. The content of a cell can therefore be complex, consisting
of many values. For example, a cell can include an expression, and also the value and format of this expression’s result.

The sequence of actions of copying function is similar to a copying option in other applications and operating systems. Another worksheet, a workbook or an application can be selected as a destination of a copy function.

To copy:

1. Select an object for copying – a cell, a worksheet of a cell range, text or its part in a cell;
2. Perform the copy command;
3. Select the paste location – a cell, worksheet, or range of cells; select the text to be replaced;
4. Perform the paste command.

When copying and pasting the content of a cell, additional paste options can selected in the Paste Special dialogue box.

To copy a cell:

1. Select a cell or a cell range;
2. Perform the copy command:
   2.1. Execute the menu command Edit → Copy;
   or
   2.1. Click the right mouse button on a cell or selected cells;
   2.2. Execute the right-click command Copy;
3. Select a target cell;
4. Paste the content copied:
   4.1. Execute the menu command Edit → Paste;
   or
   4.2. In the right-click menu, execute the command Paste.

To set other paste options:

1. Execute the copy function;
2. Open the dialogue box Paste special:
   2.1. Execute the menu command Edit → Paste Special;
   or
2.2. Perform the right-click command **Paste Special**.

![Menu of paste options](image)

A – paste only text; B – only numbers; C – only formulas; D – formatting a cell or value; E – paste the new cells in a new row, column; F – additional operations with the existing cell content

*Image 7 Menu of paste options*

Actions of moving data or other information are similar to the copy function; however, instead of selecting the **Copy** command, select the command **Cut**.

**Task 4.5. Make additions to and arrange the workbook book.ods**

1. Open the workbooks **book.ods** and **copy.ods** in the subfolder **4.5_darbgramata4.5_workbook** of the folder **4_izklajlapas4_spreadsheets**:
   1.1. Execute the menu command **Places→Documents** with the operating system;
   1.2. Choose the folder **4_izklajlapas4_spreadsheets**;
   1.3. Press the **Enter** key;
   1.4. Double left click on the folder **4.5_darbgramata4.5_workbook**;
   1.5. Press the **Ctrl** key;
   1.6. Click on the **book.ods** icon of the file and on the icon **copy.ods** of the file, without releasing the **Ctrl** key;
   1.7. Execute the menu command **File→Open**.

2. Copy the **Sheet2** worksheet of the **copy.ods** workbook in the **book.ods** workbook:
   2.1. Switch to the workbook **copy.ods**, and, if necessary, click the button in the bottom bar of the desktop:

![Desktop icons](image)

2.2. Click on the **Sheet2** tab in the worksheet to open a worksheet:

![Worksheet tabs](image)

2.3. Execute the menu command **Edit→Sheet→Move/Copy**;
2.4. In the **To document** menu of the **Move/Copy Sheet** dialogue box, select the **book.ods** workbook;
2.5. In the dialogue pane **Insert before**, select the **Sheet3**, to make an insertion above the third worksheet;
2.6. In the dialogue box, tick the **Copy**:

![Copy Sheet Dialogue Box]

2.7. Save changes with the **OK** button;
2.8. Switch to the workbook **book.ods** by clicking the corresponding button in the bottom row of the desktop.

3. Rename worksheets containing data:
3.1. Open the worksheet **Sheet1**, click on its tab, if necessary;
3.2. Execute the menu command **Format→Sheet→Rename**;
3.3. In the dialogue box **Rename Sheet**, enter the **budget** in the name field:

![Rename Sheet Dialogue Box]

3.4. Save changes with the **OK** button;
3.5. Open the worksheet **Sheet2_2**, click on the tab;
3.6. Right-click on the name of the worksheet **Sheet2_2**;
3.7. In the right-click menu, perform the command **Rename Sheet**:

![Rename Sheet Menu]

3.8. In the dialogue box, enter the new name of the worksheet **offerings**;
3.9. Save changes with the **OK** in the dialogue box **Rename Sheet**.

4. Delete odd worksheets:
4.1. Click the right mouse button on the name of the worksheet **Sheet2**;
4.2. In the right-click menu, execute the command **Delete Sheet**;
4.3. Confirm the delete function in the dialogue box with the **Yes** button:
4.4. Click on the tab Sheet3;
4.5. Execute the menu command Edit→Sheet→Delete;
4.6. Confirm the delete option of the worksheet with the Yes button.

5. In the offerings worksheet, without formatting, copy data of the Description column in the budget worksheet:
5.1. Open the worksheet budget, click on the tab;
5.2. Select the cells B1:B6;
5.3. Execute the menu command Edit→Copy;
5.4. Open the worksheet offerings, click on the tab;
5.5. Click on the cell A2;
5.6. Execute the menu command Edit→Paste Special;
5.7. In the dialogue box Paste Special, remove the tick from the Paste All checkbox;
5.8. Untick the Selection in all the checkboxes, except the Text:

![Paste Special dialogue box](image)

5.9. Click the OK button in the dialogue box.

6. Delete the column B:
6.1. Left-click on the column header;
6.2. Execute the command Edit→Delete Cells.

7. Arrange width of columns;
7.1. Position the mouse pointer between the headers of columns A and B;
7.2. Perform a left-click;
7.3. Without releasing the mouse button, drag the mouse pointer to the left until all the data in cells of the column are displayed:

![Column width adjusted](image)

7.4. Select the columns B C D:
7.4.1. Left-click on the header of column B;
7.4.2. Without releasing the button, drag the mouse pointer to the header of column D:

![Selected columns](image)

7.4.3. Release the button over the header of column D.
7.5. Execute the menu command Format→Column→Width;
7.6. In the dialogue box, enter the column width Width 1.5 in inches;
7.7. Confirm the column width selected with the OK button in the dialogue box.

8. Align and centre text in the names of columns:
8.1. Select the cells A2:D2;
8.2. Click the Align Center Horizontally button in the toolbar Formatting.

9. Insert a new row above the table:
9.1. Click on the cell A2;
9.2. Execute the menu command Insert Rows.

10. Merge cells for the name of the table:
10.1. Select the cells A1:D1;
10.2. Click the Merge and Center Cells button in the toolbar Formatting:

11. Rename the worksheet Sheet1 as budget;
12. Delete the worksheets Sheet2 and Sheet3;
13. Create a name of the table:
13.1. Insert a new row above the data range;
13.2. Select the cells A1:E1;
13.3. Merge the cells and use the Merge and Center Cells button in the toolbar Formatting:
13.4. In the dialogue box, confirm the moving of the content of cells selected to the first cell by clicking the Yes button.

14. Format cells containing money values similarly as in the worksheet budget:
14.1. Open the worksheet budget, click on its tab;
14.2. Click on the cell D2;
14.3. Click the Format Paintbrush button in the toolbar Standard:
14.4. Open the worksheet offerings;
14.5. Select the cells B4:D8 with the left mouse button;
14.6. Release the mouse button;
14.7. Click on any cell in the worksheet.

15. Apply green colour to the tab budget of the worksheet:
15.1. Left-click on the tab budget in the worksheet;
15.2. Execute the menu command Format->Sheet->Tab Color;
15.3. Select green colour;
15.4. Save changes with the OK button.

16. Close the workbook:
   16.1. Execute the menu command File->Close;
   16.2. In the dialogue box, click the Yes button to save changes to the workbook.

17. Close the workbook copy.ods:
   17.1. Click the Close button in the title bar of Calc.

Charts

A chart is a graphical presentation of numerical data. When the corresponding data in cells are changed, the chart changes as well.

After a chart is inserted or selected in a spreadsheet with a double left click, the tool and menu bar of OpenOffice.org Calc changes to show chart buttons and commands.

Inserting a Chart

To insert a chart in a worksheet:

1. Select a data range in a spreadsheet;
2. Perform the menu command Insert->Chart;
3. In the Chart Wizard:
   3.1. Select a chart type and appearance, click the Next button;
   3.2. Specify a data range of a chart, if needed;
   3.3. Tick the First row as label checkbox, if the columns in the selected data range have titles; then click Next:
3.4. Change data selection in series, if necessary, press the **Next** button;
3.5. Supplement a chart by the headers, the names of the **X, Y, Z** axes;
3.6. Confirm changes with the **Finish** button.

4. Position the chart in the desired location in the spreadsheet.

**Useful tip**

Moving a chart in a worksheet is easiest by left-clicking on the chart area border and dragging the chart without releasing the button.

**To modify size of a chart:**

1. Select a chart, left-click on it;
2. Drag by one of the handles on the chart border.

**Formatting a Chart**

A chart type can be modified and formatting chart elements can be carried out when it is created and inserted in a worksheet.

**Note!**

In order to use the chart toolbars and menus, it is first necessary to activate the chart edit mode.

**To modify parameters of a chart:**

Double left-click in a **Chart Area**. A grey border appears around the chart:

The chart edit mode with the relevant toolbars and menus is activated. Now it is possible to modify a chart and chart elements.
To modify a type of a chart:

Execute the menu command **Format->Chart Type**

or

Press the **Chart Type** key in the toolbar:

![Chart Type](image)

To add titles to a chart and its axes:

1. Execute the menu command **Insert->Titles**.
2. In the dialogue box **Titles**, fill the necessary fields:

![Titles Dialogue Box](image)

3. Save changes with the **OK** button.

**Formatting Chart Elements**

Typically, a chart consists of several elements, e. g., a chart area, a data range, a legend, data series, axes and titles. The method of changing their appearance is similar for all chart elements.

![Chart Elements Diagram](image)

A – chart area; B – Y axis with values; C – data area axis; D – title; E – data area; F – legend; G – data series column; H – chart floor; I – legends on X axis

*Image 9 Chart elements*
Each of them can be formatted individually in the respective element’s dialogue box, in order to achieve the desired appearance of the chart. It can be done in several ways.

**To format a chart element:**

1. Click on a chart element;
2. Click the **Format Selection** button in the toolbar;

or

1. Double-click on a chart element selected;
2. Apply changes to an element in a specified dialogue box;
3. Save changes with the **OK** button;

or

1. Select a chart element by the title from the menu:

2. Click the **Format Selection** button;
3. Apply changes to the dialogue box;
4. Save changes with the **OK** button.

**Task 4. 6. Insert a chart in a Calc document. Add a title.**

1. Open the document **chart.ods:**
   1.1. Perform the menu command **Places-->Search for Files** in the operating system;
   1.2. In the **Name contains** field of the **Search for Files** dialogue box, enter a part of the file name **chart**;
   1.3. Click the **Find** button in the dialogue box;
   1.4. Left-click on the result **chart.ods** found:
1.5. Press the Enter key on the keyboard.

2. Create a chart from data of the workbook:
   2.1. Select the cells A3:F9 from a data range;
   2.2. Perform the menu command Insert->Chart;
   2.3. In a chart wizard:
      2.3.1. Select a chart type Column;
      2.3.2. Tick the checkbox 3D Look;
      2.3.3. Choose to display the data series as a cylinder – in the pane Shape, select Cylinder;
      2.3.4. Click the Next button in a wizard:

      2.3.5. In the next step, check the data range for correct selection:

      2.3.6. Tick the pane First row as label;
      2.3.7. Click the Next button;
      2.3.8. In the next step, click the Next button, save existing data columns and their setups;
      2.3.9. In the next step, enter the title Fruits for the horizontal axis in the field X axis:

      2.3.10. Click the Finish button.

3. Move a chart below the table in a worksheet:
   3.1. Left-click on a chart’s border (placeholder);
3.2. Without releasing the mouse button, drag a chart to a place below the data table;
3.3. Release the mouse button.
4. Increase the size of a chart to match the table width in the worksheet:
   4.1. Left-click on the handle in the corner of a chart;
   4.2. Without releasing the mouse button, drag a chart until the required size is reached;
   4.3. Release the mouse button:

5. Click on any cell in a worksheet outside a chart;
6. Add a title to a chart:
   6.1. Click on the menu Insert title. View the content of the menu;
   6.2. Double left click on a chart to activate the edit mode;

   **Useful tip**
   If you find the double left click difficult to perform, click on the chart once to select it, then press the Enter key on the keyboard to activate the edit mode.

   6.3. Execute the menu command Insert->Titles;
   6.4. In the Title field of the Titles dialogue box, enter the chart title *Extracts per year*;
   6.5. Save the action with the OK button.
   6.6. Complete insertion.
7. Make a chart in a worksheet stand out with a border and background fill:
   7.1. Left click on an empty space in a chart area;
   7.2. Click the Format Selection button in the toolbar Formatting;
   7.3. In the tab Borders, select a continuous style for a chart in the menu Style Continuous;
   7.4. Specify line width 0.02 by left-clicking on the upward triangle:
7.5. Open the tab *Area*, click on the title;
7.6. In the pane *Fill*, select *Pale yellow*:

7.7. Save changes with the *OK* button.

8. Click on any cell in a workbook outside a chart;
9. Change the colour of the chart title:
   9.1. Double left-click on a chart to activate the edit mode;
   9.2. Click on the title of the chart;
   9.3. Execute the menu command *Format Selection*;
   9.4. In the dialogue box *Main Title*, open the tab *Font Effects*, click on the title;
   9.5. In the menu *Font color*, select *Green* colour for the title of the chart;
   9.6. In the menu *Underlining*, select *Double*;
   9.7. Tick the *Shadow* checkbox to shade the title;
   9.8. Save changes with the *OK* button.

10. Click on any cell in a worksheet outside the chart;
11. Change the font size of the legend:
    11.1. Double left click on a chart to activate the edit mode;
    11.2. Double left click on the legend area;
    11.3. In the dialogue box, open the *Font* tab, click on the name;
    11.4. In the pane *Size*, select the font size 10;
    11.5. Click the *OK* button in the dialogue box.

12. Change the shape and colour of year 2010 data series:
    12.1. Click on any brown cylinder on year 2010 data series;
    12.2. Click the button *Format Selection* in the toolbar;
    12.3. In the dialogue box *Data Series*, open the tab *Layout*;
    12.4. In the pane *Shape*, select *Cone*;
    12.5. In the dialogue box *Data Series*, open the *Area* tab;
    12.6. In the pane *Fill*, select the colour of the series *Magenta*;
    12.7. Save changes with the *OK* button.

13. Add data values to the data series of year 2010:
    13.1. Select the data series of year 2010, if needed;
    13.2. Execute the menu command *Insert*>*Data Labels*;
13.3. In the **Data Labels** tab of the **Data Labels for Data Series ‘2010’** dialogue box, check for the ticked checkbox **Show value as number**;

13.4. Open the tab **Font**;

13.5. In the pane **Size**, select the font size **10**;

13.6. Click the **OK** button in the dialogue box.

14. Click on any cell in a worksheet outside the chart;

15. Save changes to the workbook:

15.1. Click the **Save** button in the toolbar.

16. Close the workbook:

16.1. Press the **Ctrl** key on the keyboard;

16.2. Holding down the **Ctrl** key, press the **Q** character key.

---

**Work with Data**

Spreadsheets are suitable for work with large, structured data arrays arranged in a table. In addition to the ability to change the appearance of these data, **OpenOffice.org Calc** also offers additional tools for arranging data in a certain order, selecting them by specific parameters.

If data in a worksheet do not fit in a single window, vertical and horizontal scrollbars automatically appear:

![Spreadsheet screenshot](image)

**Data Sorting**

It is easy to sort data in ascending or descending alphabetical order. Interrelated data are entries in columns on a single row. When data are sorted in a column, the entire row moves, but the interrelation is preserved.

Successive sorting in several columns is also possible; e.g., first sorting alphabetically by the first column, and then sorting the obtained result again by the second column. **OpenOffice.org Calc** allows successive sorting by three columns.

**To sort data in alphabetic order in line with column data:**

1. Click on a cell in the column by which to sort;
2. Perform data sorting:
   2.1. Click the **Sort Ascending** button in the **Formatting** toolbar;
2.1. Execute the menu command Data→Sort;
2.2. In the Sort Criteria tab of the Sort dialogue box, select Ascending;
2.3. Save changes with the OK button.

Note!
To sort data in the alphabetic order, the application Calc maintains a definite consequence, e. g., first, numbers and afterwards letters are sorted.

To sort entries in a reverse alphabetical order, use the option Descending or the toolbar button Sort Descending.

Sorting can be also applied to a specified and selected data range in a spreadsheet.

Find and Replace

The commands Find and Replace are used to quickly find data in a worksheet and replace text or numbers in cells. It is possible to replace a word (number) partially or entirely.

To replace text or a number in the entire worksheet:

1. Execute the menu command Edit→Find and Replace;
2. Perform actions in the dialogue box Find & Replace:
2.1. In the field **Search for**, enter a word (a number) or a part of a word searched;
2.2. In the field **Replace with**, enter the replacement;
2.3. Click the **Replace All** button to replace all the items found, or click **Replace** to replace the first and each successive item one by one;
2.4. Close the dialogue box with the **Close** button.

**Useful tip**

The dialogue box can also be opened with the Standard toolbar button **Find & Replace**:

To find text or a number in the entire worksheet:

1. Execute the menu command **Edit→Find and Replace**;
2. Perform actions in the dialogue box **Find & Replace**:
   2.1. In the field **Search for**, enter a word (a number) or a part of a word searched;
   2.2. Click **Find All** to return all matching items, or **Find** to return the first and each successive item one by one;
   2.3. Close the dialogue box with the **Close** button.

**Note!**

The **Find** and **Replace** functions begin working from the selected cell in the worksheet and continue downward. When the programme reaches the end of the worksheet, the search is continued at the beginning:

**Freezing a Pane**

When scrolling down a large worksheet that does not fit inside the Calc window, the column headers are no longer visible, which makes handling the data more difficult. The same applies to row headers in a document with many columns.
To make titles of columns, titles of rows always visible:

1. Select a cell below the row that must always be visible and to the right of the column that must always be visible;
2. Execute the menu command Window→Freeze:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>Course Nr</td>
<td>Course name</td>
<td>Course type</td>
</tr>
<tr>
<td>02DECA7Ed01</td>
<td>Oracle SOA Suite</td>
<td>Oracle</td>
</tr>
<tr>
<td>10135</td>
<td>Configuring</td>
<td>Microsoft</td>
</tr>
<tr>
<td>10174A</td>
<td>Configuring and</td>
<td>Microsoft</td>
</tr>
<tr>
<td>10175</td>
<td>Microsoft</td>
<td>Microsoft</td>
</tr>
<tr>
<td>10215A</td>
<td>Implementing and</td>
<td>Microsoft</td>
</tr>
</tbody>
</table>

To unfreeze cells:

In the Window menu, click the mouse button to untick the Freeze command.

**Task 4.7. The document lists courses for products of several software companies. Sort the document to make courses for Cisco products appear at the top of the table.**

1. Open the document kursu_saraksts.ods:
   1.1. Execute the menu command Places→Documents;
   1.2. Double left click to open the folder 4_izklajlapas4_spreadsheets;
   1.3. Double left click to open the folder 4.7_dati4.7_data;
   1.4. Double left click to open the file kursu_saraksts.ods.
2. In the worksheet, find the offer on planning courses:
   2.1. Click the Find & Replace button in the toolbar;
   2.2. In the Search for field of the Find & Replace dialogue box, enter the word Planning;
   2.3. In the dialogue box, click the Find All button;
   2.4. Close the dialogue box with the Close button;
   2.5. View data found by scrolling the mouse wheel or the scroll bar in the Calc box:

   - ITIL v3 Planning
   - ITIL v3 Control and Validation Certificate
   - ITIL v3 Service Design Certificate

3. Sort data in the alphabetic order in the column C:
   3.1. By using the horizontal scrollbar, move the worksheet to have column C visible, if necessary;
   3.2. Left-click in any cell in the column C;
   3.3. Execute the menu command Data→Sort;
   3.4. In the dialogue box Sort, check that in the Sort by menu of the Sort Criteria tab, the column C title Course type is selected:
   3.5. Check for the selection of the alphabetic order Ascending;
   3.6. Click the OK button in the dialogue box;
3.7. Make sure that the table entries have been sorted in ascending alphabetical order by column C.

4. Freeze the titles of columns and course numbers:
   4.1. Click on the cell B2;
   4.2. Execute the menu command Window→Freeze;
   4.3. Review the document and use the vertical and horizontal scroll bar in the Calc box.

5. Replace the text **Open date** by the **Closed** in the entire worksheet:
   5.1. Execute the menu command Edit→Find & Replace;
   5.2. In the Search for field of the Find & Replace dialogue box, enter the text **Open date**;
   5.3. In the field Replace with, enter the word **Closed**;
   5.4. Click the Replace All button in the dialogue box;
   5.5. Check for the changes in the column F in the worksheet;
   5.6. Close the dialogue box Find & Replace with the Close button.

6. Save the file of the workbook in the folder **Documents**, not changing its name:
   6.1. Execute the menu command File→Save As;
   6.2. In the navigation bar of the Save dialogue box, click the Documents button;
   6.3. Click the Save button in the dialogue box.

7. Close the workbook by clicking the Close button in the application window.

**Preparation of a Document**

The size of a document in spreadsheet applications can be indefinite, with a significant number of columns and rows in a worksheet. When such a worksheet is printed, it may not fit inside a standard page. Therefore before printing a document, use the print preview option and modify setups necessary.

Similarly, sometimes it is not needed to print the whole spreadsheet, e.g., a selection of a data range can be printed.

**Formatting a Document Printout**

To view and modify the page breaks of a spreadsheet for printing:

1. Execute the menu command View→Page Break Preview;
2. Change the page breaks by dragging the lines, if necessary.
To return to a normal view of a document:

Perform the menu command View→Normal.

To carry out the print preview function of a document:

1. Execute the menu command File→Page Preview;
2. Carry out actions in the Format Page toolbar.

Image 10 Format Page toolbar

To carry out page formatting of a document:

1. Perform the menu command File→Page Preview;
2. In the toolbar, click the Format Page button;
3. Open the tab Page in the Page Style dialogue box;
4. Apply changes needed;
5. Save changes with the OK button.

Actions to be performed in the Page tab of the dialogue box:

- **Format** – paper format;
- **Orientation** – portrait or landscape orientation;
- **Margins** – page margins; the size of each can be individually adjusted.

To fit the spreadsheet on a specific number of pages for printing:

1. Open the dialogue box Page Style:
   1.1. Execute the menu command Format→Page
or
1.1. Perform the menu command **File→Page Preview**;
1.2. Click the **Format Page** button in the toolbar;
2. Open the **Sheet** tab;
3. From the **Scaling mode** menu, select the **Fit print range(s) on number of pages**;
4. Specify the **Number of pages**;
5. Close the dialogue box.

### To print the cell grid and column, row headers:

1. Open the dialogue box **Page Style**:
   1.1. Execute the menu command **Format→Page**
   or
   1.2. Perform the menu command **File→Page Preview**;
   1.3. In the toolbar, click the **Format Page** button;
2. Open the **Sheet** tab;
3. Tick the **Grid** checkbox;
4. Tick the **Column and row** headers checkbox:
5. Close the dialogue box.

### Creating a Header, Footer

A header is a document area displayed at the top of every page. A footer, conversely, is displayed at the bottom of every page.

### To create the header of a document:

1. Perform the menu command **File→Page Preview**;
2. Click the **Format page** button in the toolbar;
3. In the dialogue box, open the **Header** tab;
4. Tick the **Header on** checkbox;
5. Click the **Edit** button;
6. In the dialogue box **Header**, apply the changes needed.

The header in **Calc** is divided in three areas, with the necessary text or available content fields being inserted in each. The application automatically inserts the necessary items in the fields.
Similarly, create and format page **Footer**.

### Setting a Print Range

A print range is used to print a specific part of a spreadsheet.

**To set print ranges:**

1. Select a cell range in a worksheet;
2. Execute the menu command **Format->Print Ranges->Add**

**To clear print ranges:**

Execute the command **Format->Print Ranges->Remove**

**To print cells selected:**

1. Select a cell range in a worksheet;
2. Execute the menu command **File->Print**;
3. In the dialogue box **Print**, choose **Selected Cells**;
4. Click the **OK** button in the dialogue box:
In the dialogue box **Print**, perform additional actions:

- **Printer name** selects a printer; several printers can be connected to a computer.
- **Print All Sheets** prints all the sheets of a workbook.
- **Selected Sheets** prints only selected sheets or the sheet in which the selected cell is located.
- **Print range** — **All pages** prints all the pages, the **Pages** mode prints a separate page or a page interval.
- **Number of copies** specifies the number of copies.

**Adding Column and Row Headers to Printed Pages**

For larger worksheets, it is useful to repeat the headers of rows and columns on each printed page.

**To set the columns (rows) to repeat:**

1. Perform the menu command **Format**—>**Print Ranges**—>**Edit**;
2. In the **Edit Print Ranges** dialogue box, specify the columns (rows) to repeat on each page:

**Useful tip:**
Check the setup of paper and the **Format** option otherwise the page setup on a computer screen and in the print preview may differ.

## Saving a Worksheet in Different Formats

**Calc** can not only open files created in other data processing software, but also save workbooks in formats compatible with other applications.

**Useful tip:**

Special virtual printers are sometimes used in operating systems. By printing on such a printer, the content of the file is not printed on paper, but to a different file in a specific format. Such printers are used to change the file format.

Most frequently used format options are:

- **ODF Spreadsheet (.ods)** - [OpenOffice.org Calc](https://www.openoffice.org) format;
- **ODF Spreadsheet Template (.ots)** - Calc spreadsheet template;
- **dBASE (.dbf)** – widely used database file format;
- **Text CSV (.csv)** – text file containing comma-separated values, typically used for data exchange among various programmes;
- **HTML Document (OpenOffice.org Calc) (.html)** – Web page format;
- **PDF** – most frequently used, a universal Adobe format of a document;

To save a spreadsheet in other file format:

1. Execute the command **Save** for a newly created document or the **Save As** option for an open and saved document;
2. In the dialogue box **Save**, open the file type menu;
3. Choose file format needed, f. e., **csv**;
4. Save changes with the **Save** button.
To export a workbook in PDF format:

1. Execute the menu command File→Export As PDF;
2. Specify additional parameters in the dialogue box PDF Options, if needed;
3. Click the Export button to complete the action.

**Task 4.8.** Prepare the document kursi.odscourses.ods in the subfolder 4.8_izdruka.8_print of the folder 4_izklajlapas4_spreadsheets: page format A4, landscape, one page wide and eight pages high, grid visible, header must contain page number, document filename and total number of pages, each printed page must repeated the column headers.

1. Open the document kursi.odscourses.ods:
   1.1. Execute the menu command Places→Documents;
   1.2. Select the folder 4_izklajlapas4_spreadsheets;
   1.3. Press the Enter key on the keyboard;
   1.4. Choose the folder 4.8_izdruka.8_print;
   1.5. Press the Enter key on the keyboard;
   1.6. Select the spreadsheet file kursi.odscourses.ods;
   1.7. Press the Enter key on the keyboard.
2. Open a print preview:
   2.1. Perform the command File→Page Preview in the menu of the application window.
3. Set page format A4 and Landscape orientation:
   3.1. Execute the menu command Format→Page;
   3.2. In the dialogue box Page Style, open the tab Page, left-click on the name;
   3.3. In the Format menu of the Paper format pane, select page format A4;
   3.4. Choose the Landscape orientation.
4. Make the printed document one page wide and eight pages high:
   4.1. In the dialogue box Page Style, open the tab Sheet, left-click on the name;
   4.2. In the Scaling mode menu of the Scale pane, select the Fit print range(s) to width/height;
   4.3. Set Width in pages - enter the Width in pages field a number 1, if required;
   4.4. Set the Height to eight pages by increasing the value Height in pages to 8 by clicking on the black upward triangle next to the field:

5. Set visible gridlines:
   5.1. In the Sheet tab of the Page Style dialogue box, tick the Grid checkbox:
6. Create the header:
   6.1. In the dialogue box Page Style, left-click to open the tab Header;
6.2. Left-click the **Header** on pane;
6.3. Click the **Edit** button in the tab **Header**;
6.4. Left-click in the Header **Left area** pane;
6.5. Enter the name **Page**;
6.6. Press the spacebar key on the keyboard;
6.7. Click the **Page** button:

6.8. Left-click in the Header cell **Center area**;
6.9. Click the **Title** button:

6.10. Left-click in the Header cell **Right area**;
6.11. Enter the text **total pages**;
6.12. Press the spacebar key on the keyboard;
6.13. Click the **Title** button:

6.14. Click the **OK** button in the dialogue box **Header**.
6.15. Enlarge **Spacing** up to 0.10 inches (0.25 cm):
6.15.1. Increase the **Spacing** value by clicking the black upward triangle next to the field:

6.16. Click the **OK** button to close the dialogue box **Page Style**.

7. Close the print preview:
7.1. Click the **Close Preview** button in the toolbar:

8. Set the first row to be repeated on all printed pages:
8.1. Execute the menu command **Format→Print Ranges→Edit**;
8.2. Click the **Shrink** button in the box **Rows to Repeat**:

8.3. Left-click in any cell of the first row;
8.4. Press the **Enter key** in the toolbar;
8.5. Click the **OK** button in the dialogue box **Edit Print Ranges**.

9. Check changes in the preview option:
9.1. Execute the menu command **File→Page Preview**;
9.2. Check for column titles in each page;
9.3. Click the **Close Preview** button in the toolbar to close the preview mode.
10. Save changes in a document:
   10.1. Click the Save button in the toolbar.

11. Save a document in comma-separated values format:
   11.1. Execute the menu command File→Save As;
   11.2. In the dialogue box Save, click on the File type;
   11.3. Select the Text CSV (.csv) from the menu of file formats;
   11.4. Click the Save button;
   11.5. In the alert box, click the Keep Current Format button to save format changes:
   11.6. In the Field delimiter menu of the Export of text files dialogue box, select the {Tab}:
   11.7. Click the OK button in the dialogue box Export of text files;
   11.8. In the alert box, click the OK button.

12. Click the Close button in the toolbar to open the Calc application box.

13. View the document in the newly created CSV format:
   13.1. Activate the application OpenOffice.org Calc:
   13.1.1. Perform the menu command Applications→Office→OpenOffice.org Spreadsheet in the top desktop panel.
   13.2. Perform the menu command File→Recent Documents→.../kursicourses.csv;
   13.3. In the dialogue box Text Import, click the OK button.

14. Close all the open boxes:
   14.1. Click the Close button in the title bar.

Other Actions in the Calc Application
When the application is first opened, it has the default appearance set by the software developer. The user can change this default appearance, layout and elements of the window as desired.

It is also possible to change the number of toolbars, save location, default file format, document language, units of measurement, and other settings.

To avoid having to change the settings each time when a new document is created, they are set as the default in the Options dialogue box.

**To open the dialogue box Options:**

Perform the menu command **Tools**→**Options**.

**Examples:**

**To change the default file save location:**

1. In the dialogue box Options, select the Path;
2. In the cell Paths used by OpenOffice.org, select the type My Documents;
3. Click the Edit button;
4. Change the default save location on the computer’s hard drive;
5. Save selection with the OK button;
6. In the dialogue box Options, click the OK button.

**To change the system of measurement from inches to centimetres:**

1. In the dialogue box Options, select OpenOffice.org Calc;
2. Select the general setup General;
3. In the Metrics section, replace units of measurement by Centimeter;
4. Save changes with the OK button.

---

**Help Function**
Help in Work with Application

Calc has a built-in manual with a search function.

To open the Help mode of the OpenOffice.org:

Perform the command Help->OpenOffice.org Help
or
Press the F1 function key on the keyboard.

Image 13 The dialogue box of the Help system

The help system of Calc is opened by default, but it is easy to switch to the help systems on other applications of the OpenOffice.org suite, if necessary. The window of the help system is divided into two sections – the content pane and the text, result area.

To create a bookmark for a topic:

Click the button Add to Bookmarks.

Help in Error Correction

Error messages
If for some reason Calc is unable to make calculations, the cell will display an error message.

Error messages in expressions and formulas:

- #VALUE! - invalid value in an expression. E.g., there is text instead of a number.
- #REF! - invalid cell or cell area address.
- #NAME? - invalid function name or text not placed inside quotation marks.
- #DIV/0! - division by zero.
- Err:509 - message with an error code. E.g., error code 509 means that the expression is missing an operator.

Useful tip:
In these cases, the error message can be seen in the status bar of the application’s window:

Error tracing tools

It is difficult to determine the areas included in an expression in complex, large worksheets. It can be particularly hard in workbooks created by other users. The analysis described here is useful for tracing errors or invalid entries.

In addition to error messages, the software Calc has tools for error tracing.

To define ranges of cells included in a formula:

1. Left-click on a cell with a formula;
2. Perform the menu command Tools→Detective→Trace Error:

To remove traces:

Perform the menu command Tools→Detective→Remove All Traces.

In this module, you learned how to:

- enter data in the spreadsheet application Calc;
Module 4

- make calculations in spreadsheets;
- insert and modify charts;
- prepare a document;
- save a document in various formats;
- use the Help function.
Supplement 1

ECDL requirements for Module 4 Spreadsheets:
- Work with spreadsheets and save them in different file formats;
- Use the built-in options like the Help function within the application to enhance productivity;
- Enter data into cells and use good practice in creating tables. Select, sort and copy, move and delete data;
- Edit rows and columns in a worksheet. Copy, move, delete and appropriately rename worksheets;
- Create mathematical and logical formulas using Standard spreadsheet functions. Use good practice in formula creation and recognize error values in formulas;
- Format numbers and text content in spreadsheets;
- Choose, create and format charts to communicate information meaningfully;
- Adjust a spreadsheet page setup and check and correct spreadsheet content before finally printing spreadsheets.

<table>
<thead>
<tr>
<th>Category</th>
<th>Skill Set</th>
<th>Ref.</th>
<th>Task Item</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>4.1 Using the Application</td>
<td>4.1.1 Working with Spreadsheets</td>
<td>4.1.1.1</td>
<td>Open, close a spreadsheet application. Open and close spreadsheets.</td>
<td>5, 14</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.1.1.2</td>
<td>Create a new spreadsheet based on default template.</td>
<td>8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.1.1.3</td>
<td>Save a spreadsheet to a location on a drive. Save a spreadsheet under another name to a location on a drive.</td>
<td>10</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.1.1.4</td>
<td>Save a spreadsheet as another file type like a template, a text file, software specific file extension and version number.</td>
<td>56</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.1.1.5</td>
<td>Switch between open spreadsheets.</td>
<td>36</td>
</tr>
<tr>
<td>4.1.2 Enhancing Productivity</td>
<td></td>
<td>4.1.2.1</td>
<td>Set basic options/preferences in the application like a username, default folder to open, save spreadsheets.</td>
<td>60</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.1.2.2</td>
<td>Use available Help functions.</td>
<td>61</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.1.2.3</td>
<td>Use magnification/zoom tools.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.1.2.4</td>
<td>Display, hide built-in toolbars or ribbons.</td>
<td>8</td>
</tr>
<tr>
<td>4.2 Cells</td>
<td>4.2.1 Insert, Select</td>
<td>4.2.1.1</td>
<td>Understand that a cell in a worksheet should contain only data element (for example, first name detail in one cell, surname detail in adjacent cell).</td>
<td>11</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.2.1.2</td>
<td>Recognize good practice in creating lists: avoid blank rows and columns in the main body of list, insert a blank row before total row, and ensure cells bordering list is blank.</td>
<td>11</td>
</tr>
<tr>
<td>Category</td>
<td>Skill Set</td>
<td>Ref.</td>
<td>Task Item</td>
<td>Page</td>
</tr>
<tr>
<td>---------------------------</td>
<td>----------------------</td>
<td>------------</td>
<td>---------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.2.1.3</td>
<td>Enter a number, date, text in a cell.</td>
<td>12</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.2.1.4</td>
<td>Select a cell, range of adjacent cells, range of non-adjacent cells, and an entire worksheet.</td>
<td>11</td>
</tr>
<tr>
<td>4.2.2 Edit, Sort</td>
<td></td>
<td>4.2.2.1</td>
<td>Edit cell content, modify existing cell content.</td>
<td>13</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.2.2.2</td>
<td>Use the undo, redo command.</td>
<td>8</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.2.2.3</td>
<td>Use the search command for specific content in a worksheet.</td>
<td>49</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.2.2.4</td>
<td>Use the replace command for specific content in a worksheet.</td>
<td>48</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.2.2.5</td>
<td>Sort a cell range by one criterion in ascending, descending numeric order, ascending, descending alphabetic order.</td>
<td>47</td>
</tr>
<tr>
<td>4.2.3 Copy, Move, Delete</td>
<td></td>
<td>4.2.3.1</td>
<td>Copy the content of a cell, cell range within a worksheet, between worksheets, between open spreadsheets.</td>
<td>35</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.2.3.2</td>
<td>Use the autofill tool/copy handle tool to copy, increment data entries.</td>
<td>25</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.2.3.3</td>
<td>Move the content of a cell, cell range within a worksheet, between worksheets, between open spreadsheets.</td>
<td>36</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.2.3.4</td>
<td>Delete cell contents.</td>
<td>13</td>
</tr>
<tr>
<td>4.3 Managing</td>
<td>4.3.1 Rows and</td>
<td>4.3.1.1</td>
<td>Select a row, range of adjacent rows, range of non-adjacent rows.</td>
<td>11, 12</td>
</tr>
<tr>
<td>Worksheets</td>
<td>Columns</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.3.1.2</td>
<td>Select a column, range of adjacent columns, range of non-adjacent columns.</td>
<td>11, 12</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.3.1.3</td>
<td>Insert, delete rows and columns.</td>
<td>39</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.3.1.4</td>
<td>Modify column widths, row heights to a specified value, to optimal width or height.</td>
<td>32</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.3.1.5</td>
<td>Freeze, unfreeze row and/or column titles.</td>
<td>50</td>
</tr>
<tr>
<td>4.3.2 Worksheets</td>
<td></td>
<td>4.3.2.1</td>
<td>Switch between worksheets.</td>
<td>31</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.3.2.2</td>
<td>Insert a new worksheet, delete a worksheet.</td>
<td>33, 34</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.3.2.3</td>
<td>Recognize good practice in naming worksheets: use meaningful worksheet names rather than accept default names.</td>
<td>33</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.3.2.4</td>
<td>Copy, move, and rename a worksheet within a spreadsheet.</td>
<td>33</td>
</tr>
<tr>
<td>4.4 Formulas and</td>
<td>4.4.1 Arithmetic</td>
<td>4.4.1.1</td>
<td>Recognize good practice in formula creation: refer to cell references rather than type numbers into formulas.</td>
<td>15</td>
</tr>
<tr>
<td>Functions</td>
<td>Formulas</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.4.1.2</td>
<td>Create formulas using cell references and arithmetic operators (addition, subtraction, multiplication, division).</td>
<td>15</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.4.1.3</td>
<td>Identify and understand standard error values associated with using formulas: #NAME?, #DIV/0!, #REF!.</td>
<td>61</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.4.1.4</td>
<td>Understand and use relative, absolute cell referencing in formulas.</td>
<td>24</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.4.2.1</td>
<td>Use sum, average, minimum, maximum, count, counta, round functions.</td>
<td>20, 21</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.4.2.2</td>
<td>Use the logical function if (yielding one of two specific values) with comparison operator: =, &gt;, &lt;.</td>
<td>22</td>
</tr>
<tr>
<td>4.5 Formatting</td>
<td>4.5.1 Numbers/Dates</td>
<td>4.5.1.1</td>
<td>Format cells to display numbers to a specific number of decimal places, to display</td>
<td>26</td>
</tr>
<tr>
<td>Category</td>
<td>Skill Set</td>
<td>Ref.</td>
<td>Task Item</td>
<td>Page</td>
</tr>
<tr>
<td>-----------------------------------</td>
<td>-----------------</td>
<td>------------</td>
<td>---------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.5.1.2</td>
<td>Format cells to display a date style, to display a currency symbol.</td>
<td>27</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.5.1.3</td>
<td>Format cells to display numbers as percentages.</td>
<td>27</td>
</tr>
<tr>
<td>4.5.2 Contents</td>
<td></td>
<td>4.5.2.1</td>
<td>Change cell content appearance: font sizes, font types.</td>
<td>27</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.5.2.2</td>
<td>Apply formatting to cell contents: bold, italic, underline, double underline.</td>
<td>28</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.5.2.3</td>
<td>Apply different colours to cell content, cell background.</td>
<td>28</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.5.2.4</td>
<td>Copy the formatting from a cell, cell range to another cell, cell range.</td>
<td>39</td>
</tr>
<tr>
<td>4.5.3 Alignment, Border Effects</td>
<td></td>
<td>4.5.3.1</td>
<td>Apply text wrapping to contents within a cell, cell range.</td>
<td>28, 31</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.5.3.2</td>
<td>Align cell contents: horizontally, vertically. Adjust cell content orientation.</td>
<td>30, 31</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.5.3.3</td>
<td>Merge cells and centre a title in a merged cell.</td>
<td>39</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.5.3.4</td>
<td>Add border effects to a cell, cell range: lines, colours.</td>
<td>28</td>
</tr>
<tr>
<td>4.6 Charts</td>
<td>4.6.1 Creating</td>
<td>4.6.1.1</td>
<td>Create different types of charts from spreadsheet data: column chart, bar chart, line chart, pie chart.</td>
<td>40</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.6.1.2</td>
<td>Select a chart.</td>
<td>41</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.6.1.3</td>
<td>Change the chart type.</td>
<td>42</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.6.1.4</td>
<td>Move, resize, delete a chart.</td>
<td>41</td>
</tr>
<tr>
<td>4.6.2 Editing</td>
<td>4.6.2.1</td>
<td>4.6.2.1</td>
<td>Add, remove, edit a chart title.</td>
<td>43</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.6.2.2</td>
<td>Add data labels to a chart: values/numbers, percentages.</td>
<td>46</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.6.2.3</td>
<td>Change chart area background colour, legend fill colour.</td>
<td>45</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.6.2.4</td>
<td>Change the column, bar, line, pie slice colours in the chart.</td>
<td>46</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.6.2.5</td>
<td>Change font size and colour of chart title, chart axes, chart legend text.</td>
<td>46</td>
</tr>
<tr>
<td>4.7 Prepare Outputs</td>
<td>4.7.1 Setup</td>
<td>4.7.1.1</td>
<td>Change worksheet margins: top, bottom, left, right.</td>
<td>52</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.7.1.2</td>
<td>Change worksheet orientation: portrait, landscape. Change paper size.</td>
<td>52</td>
</tr>
<tr>
<td>Category</td>
<td>Skill Set</td>
<td>Ref.</td>
<td>Task Item</td>
<td>Page</td>
</tr>
<tr>
<td>-------------------</td>
<td>-----------</td>
<td>------------</td>
<td>---------------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.7.1.3</td>
<td>Adjust page setup to fit worksheet contents on a specified number of pages.</td>
<td>52</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.7.1.4</td>
<td>Add, edit, and delete text in headers, footers in a worksheet.</td>
<td>53</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.7.1.5</td>
<td>Insert and delete fields: page numbering information, date, time, file name, worksheet name into headers, footers.</td>
<td>53</td>
</tr>
<tr>
<td>4.7.2 Check and Print</td>
<td></td>
<td>4.7.2.1</td>
<td>Check and correct spreadsheet calculations and text.</td>
<td>62</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.7.2.2</td>
<td>Turn on, off display of gridlines, display of row and column headings for printing purposes.</td>
<td>53</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.7.2.3</td>
<td>Apply automatic title row(s) printing on every page of a printed worksheet.</td>
<td>55</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.7.2.4</td>
<td>Preview a worksheet.</td>
<td>52</td>
</tr>
<tr>
<td></td>
<td></td>
<td>4.7.2.5</td>
<td>Print a selected cell range from a worksheet, an entire worksheet, number of copies of a worksheet, the entire spreadsheet, a selected chart.</td>
<td>55</td>
</tr>
</tbody>
</table>
**Task 4.9. Test your knowledge by completing the following task**

**Explanation:**
The whole task consists of 32 parts and a point will be awarded for a successful completion of each part of the task.

The task must be completed within 45 minutes.

Although definite steps are suggested for the completion of each part, other relevant and convenient methods can be used.

Try to complete the whole task on your own and without following any directions.

The task is successfully completed if the score achieved exceeds 24 points (i.e., 75% of the maximum possible 32 points).

15. Activate the spreadsheet programme and open the education.ods spreadsheet file.
   Save the document under the name it_centre.ods in the Documents folder:
   15.1. Activate the spreadsheet programme:
       15.1.1. Perform the Applications→Office→OpenOffice.org Spreadsheet menu command in the top panel of the desktop.
   15.2. Open the file:
       15.2.1. Execute the File→Open menu command in Calc;
       15.2.2. In the Places pane of the Open dialogue box, click on the Documents folder, if necessary;
       15.2.3. In the right pane, click on the 4_izklajlapas folder;
       15.2.4. Press the Enter key on the keyboard;
       15.2.5. Click on the 4.9_test folder;
       15.2.6. Press the Enter key on the keyboard;
       15.2.7. Click to select the education.ods file;
       15.2.8. In the Open dialogue box, click the Open button.
   15.3. Save the document under another name:
       15.3.1. Perform the File→Save As menu command;
       15.3.2. In the Name pane of the Save dialogue box, enter a file name it_centre;
       15.3.3. Click the Save button.

16. Adjust the width of the third row in the budget worksheet to display the content of the cells:
   16.1. In the tab, click on the budget worksheet to open it:

16.2. Position the mouse pointer between the third and the fourth row:

16.3. Left-click;

16.4. By holding down the mouse button, drag it downwards until the entire content of the cell is displayed.

17. Apply blue colour to the text in the A1 cell:
   17.1. Left-click on the A1 cell to select it;
17.2. In the **Calc** toolbar, open the menu at the **Font Color** button:

![Font Color button](image)

17.3. Select **Blue**.

18. Add and change data: in the **D7** cell, enter **1234**; in the **C11** cell, enter **4321**, in the **B5** cell, enter **1234** to change the value of the cell:

18.1. Click on the **D7** cell;
18.2. Enter **1234**;
18.3. Press the **Enter** key on the keyboard;
18.4. Repeat steps for the cells **C11** and **B5**.

19. In the **B13** cell, enter a formula to sum up the values of the cells **B5:B12**:

19.1. Click in the **B13** cell;
19.2. Click the **Sum** button in the formula and data toolbar:

![Sum button](image)

19.3. Adjust the selected cell range, if necessary:

19.3.1. Click in the **B5** cell;
19.3.2. By holding down the mouse button, drag it to the **B12** cell;
19.3.3. Release the mouse button:

![Cell range B5:B12](image)

19.4. Press the **Enter** key on the keyboard;

20. Copy the created formula in the cells **C13:F13**. Save the changes to the document:

20.1. Click in the **B13** cell;
20.2. Left-click on the handle in the bottom right corner of the cell **B13**;
20.3. By holding down the mouse button, drag it to the cell **F13**:

![Drag handle](image)

20.4. Release the mouse button;
20.5. In the toolbar of the **Calc** window, click the **Save** button.

21. Apply formatting to the numbers in the **B5:F13** cell range to hide the decimals of the number and to display the thousand separator:

21.1. Select the cell range **B5:F13**:

21.1.1. Left-click in the cell **B5**;
21.1.2. By holding down the mouse button, drag it diagonally downwards to the cell **F13**;
21.1.3. Release the mouse button.
21.2. Perform the **Format->Cells** menu command in **Calc**;
21.3. In the **Format Cells** dialogue box, click on the **Numbers** tab to open it, if necessary;
21.4. In the **Options** checkbox, left-click to tick the **Thousands** separator;
21.5. In the **Decimal places** field, reduce the value to zero, by clicking on the downward triangle at the field:

![Format Cells dialogue box]

21.6. In the dialogue box, click the **OK** button.

**Note**
The appearance of the thousand separator will depend on the **Calc** basic settings. For example, if **Calc** uses the **English (US)** regional settings, the thousand separator will be a comma (,); if the **Latvian** regional settings are used, the thousand separator will be a spacing and the decimal separator will be a coma.

22. In the cell **B16**, insert a formula that shows the biggest revenue in the cells **B5:B12**.
   Copy the formula in the cells **C16:F16**:
   22.1. Click in the cell **B16**;
   22.2. Execute the **Insert->Function List** menu command in **Calc**;
   22.3. In the pane of the functions list, double left-click on the record of the function **MAX**;
   22.4. If there is no **MAX** function included in the list of the most frequently used functions, follow with the next steps:
      22.4.1. Click on the button of the function categories menu;
      22.4.2. Select the category **All**;
      22.4.3. Double click on the **MAX** function record in the functions list:

![Function categories]

22.5. Select the cells **B5:B12**;
22.6. Press the **Enter** key on the keyboard;
22.7. Copy the formula in the cells **C16:F16**:
   22.7.1. Click in the cell **B16**;
   22.7.2. Left-click on the handle in the bottom right corner of the cell **B16**; by holding down the mouse button, drag it to the cell **F16**;
   22.7.3. Release the mouse button;
22.8. Perform the **Insert->Function List** menu command to close the pane of the functions list.

23. In the cell **B17**, insert a formula that shows the smallest revenue in the cells **B5:B12**.
   Copy the formula in the cells **C17:F17**:
23.1. Click in the cell **B17**;
23.2. Click in the input field of the formula and data toolbar;
23.3. Enter the formula **=MIN(B5:B12)**

```
<table>
<thead>
<tr>
<th></th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><img src="image" alt="Formula" /></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
```

23.4. Press the **Enter** key on the keyboard.
23.5. Copy the formula in the cells **C17:F17**:

23.5.1. Click in the cell **B17**;
23.5.2. Left-click on the handle in the bottom right corner of the cell **B17**;
        By holding down the mouse button, drag it to the cell **F17**;
23.5.3. Release the mouse button.

24. In the cell **B18**, enter a formula that shows the number of training courses whose revenue is given in the table:

24.1.1. Click in the cell **B18**;
24.2. Execute the **Insert**—**Function** menu command;
24.3. In the **Category** menu, select all the functions **All**, if necessary;
24.4. Select the **COUNTA** function from the functions list:

```
<table>
<thead>
<tr>
<th>Category</th>
<th>All</th>
</tr>
</thead>
<tbody>
<tr>
<td>Function</td>
<td>COUNTA</td>
</tr>
<tr>
<td></td>
<td>COUNTBLANK</td>
</tr>
<tr>
<td></td>
<td>COUNTIF</td>
</tr>
</tbody>
</table>
```

24.5. In the **Function Wizard** dialogue box, click the **Next** button;
24.6. Click the **Select** value setting button in the field **value 1**:

24.7. Select the cells **B5:B12**;
24.8. Press the **Enter** key on the keyboard;
24.9. In the **Function Wizard** dialogue box, click the **OK** button.

25. In the cell **G5**, enter a formula that shows the ratio between the annual revenue (cell **F5**) from the type of the training courses and the total revenue (cell **F13**). Use the absolute reference to the cell **F13**. Copy this formula for all the course types:

25.1. Click in the cell **G5**;
25.2. Click in the input field of the formula and data toolbar;
25.3. Insert the equals sign **=`**;
25.4. Click in the cell **F5**;
25.5. Insert the division sign **/**;
25.6. Click in the cell **F13**;
25.7. Replace the relative address of the cell **F13** with the absolute address of the **F13** cell:

25.7.1. Add the dollar signs **$** before a row and a column:
25.8. Press the **Enter** key on the keyboard.
25.9. Copy the formula in the cells **G6:G13**:
   25.9.1. Click in the cell **G5**;  
   25.9.2. Double left-click on the handle in the bottom right corner of the cell **G5**.

26. Calculate the difference in the revenue of years 2009 and 2010 in the cell **J8**:
   26.1. Click in the cell **J8**;  
   26.2. Click on the **Function** button in the formula and data toolbar:
   26.3. Click in the cell **J6**;  
   26.4. Insert the subtraction sign **–**;  
   26.5. Click in the cell **G13**;  
   26.6. Press the **Enter** key on the keyboard.

27. Create a formula in the cell **J11** to compare the year 2009 and 2010 revenue. If year 2010 revenue is bigger than the revenue in 2009, the word **Increased** appears in the cell; if year 2010 revenue is smaller, the text from the cell **B25** appears:
   27.1. Click in the cell **J11**;  
   27.2. Click on the **Function Wizard** button in the functions and data toolbar:
   27.3. In the function wizard, select the functions category **Logical**;  
   27.4. Select the **IF** function from the functions list:
   27.5. In the **Function Wizard** dialogue box, click the **Next** button;  
   27.6. In the **Test** field, enter **J6<F13**;  
   27.7. In the **Then_value** field, enter „**Increased**“ (in quotation marks);  
   27.8. In the **Otherwise_value** field, enter the address of the cell **B25**:
   27.9. In the **Function Wizard** dialogue box, click the **OK** button.

28. Apply formatting to the cell **I2** to show the date in the format **Day, Month Date, Year (NNNNMMDD, YYYY):**
28.1. Click in the cell I2;
28.2. Execute the **Format->Cells** menu command in **Calc**;
28.3. Click on the **Numbers** tab to open it, if necessary;
28.4. In the **Format** pane, select the date format in accordance with the task description:

![Format pane with date format options](image)

28.5. Click the **OK** button in the dialogue box;
28.6. Double left-click between the columns I and J to see the entire content of the cell I2;
28.7.

29. Change the **Calc** default regional settings and units of measurement:
29.1. Execute the **Tools->Options** menu command;
29.2. In the dialogue box, expand the **Language Settings** options list:
  29.2.1. Click on the black triangle at the record.
29.3. Click on the **Languages** record to open the **Languages** dialogue box:

![Languages dialogue box](image)

29.4. In the **Locale setting** menu, select Latvian;
29.5. Make sure that there is a tick in **Decimal separator key – Same as locale setting**;
29.6. Select the default currency EUR:

![Currency options](image)

29.7. Expand the **OpenOffice.org Calc** list;
29.8. Select **General**;
29.9. In the **Measurement unit** menu, select **Centimeter**:

![Measurement unit options](image)

29.10. Click the **OK** button in the dialogue box;
29.11. Click the **OK** button in the alert dialogue box.

30. Find the text **This is text to delete** in the **budget** worksheet and delete this text:
30.1. Perform the **Edit->Find & Replace** menu command in the Calc window;
30.2. In the **Search for** field of the **Find & Replace** dialogue box, enter **delete**;

30.3. Click the **Find** button:

30.4. Confirm to continue search from the beginning of the document by clicking the **Yes** button in the dialogue box, if necessary:

30.5. Click the **Close** button to close the dialogue box **Find & Replace**;

30.6. Press the **Delete** key on the keyboard;

30.7. In the **Delete Contents** dialogue box, tick **Delete all**;

30.8. Click the **OK** button:

31. Prepare the document for printing – select the A4 page format, set a 3 cm top and bottom margin to the page and choose the **landscape** orientation:
   31.1. Execute the **Format->Page** menu command;
   31.2. In the **Format** menu of the **Paper format** pane, select **A4**;
   31.3. Select the orientation **Landscape**;
   31.4. In the **Top** field of the **Margins** pane, replace the field value with 3;
   31.5. Enter 3 also in the **Bottom** field:

32. To continue, insert the field for the number of pages on the right side of the header:
   32.1. In the **Page Style** dialogue box, click on the **Header** tab to open it;
   32.2. Tick **Header on**;
   32.3. Click the **Edit** button;
   32.4. Left-click in the **Right area** pane;
   32.5. Enter **Page**;
   32.6. Insert line spacing;
   32.7. Click the **Page** button:
   32.8. In the **Header** dialogue box, click the **OK** button;
   32.9. In the **Page Style** dialogue box, click the **OK** button.

33. Rotate the quarter headings 30 degrees:
   33.1. Select the cells B2:E2;
   33.2. Execute the **Format->Cells** menu command;
   33.3. In the dialogue box, click on the **Alignment** tab to open it;
33.4. In the **Text orientation** pane, place the mouse pointer on the text orientation wheel;
33.5. Left-click;
33.6. By holding down the mouse button, rotate the text orientation wheel 30 degrees:

![Text orientation]

33.7. Release the mouse button;
33.8. In the dialogue box, click the **OK** button;
33.9. Adjust the row width to display the entire content of the cells B2:E2, if necessary:
   33.9.1. Position the mouse pointer between the rows 2 and 3;
   33.9.2. Double left-click.

34. Prepare the document for printing on one page without reducing the font size:
34.1. Perform the **File→Page Preview** menu command in **Calc**;
34.2. Click the **Margins** button in the print preview toolbar:

![Margins]

34.3. Reduce the left margin:
   34.3.1. Left-click on the outline of the left margin;
   34.3.2. Drag it to the left without releasing the mouse button;
   34.3.3. Release the mouse button until the margin is reduced almost twice.

34.4. Similarly, use the same actions to reduce the right margin of the page until the whole document fits into one page;
34.5. Click the **Close Preview** button;
34.6. Save the changes to the document:
   34.6.1. Click the **Save** button in the toolbar.

35. In which cell in the **courses** worksheet the formula version is very unadvisable:
35.1. Click on the **courses** worksheet to open it;
35.2. Check the formula in the cells F5:F9:
   35.2.1. Click in the cell F5;
   35.2.2. View the formula in the input field of the formula and data toolbar;
   35.2.3. Repeat the actions for all the cells in the cell range F6:F9.
35.3. Enter your answer in the cell B12.
36. Delete the H column:
   36.1. Click on the column;
   36.2. Execute the **Edit→Delete Cells** menu command;
   36.3. Save the changes by clicking the **Save** button in the toolbar.

37. Create a chart of a sector type using the data in the **chart** worksheet:
   37.1. Select the cell range A2:B5;
   37.2. Execute the **Insert→Chart** menu command;
   37.3. In **Chart Wizard**, select **Pie**;
   37.4. Tick the checkbox **3D Look**;
   37.5. In the chart wizard, click the **Finish** button;
   37.6. Move the chart under the table:
      37.6.1. Left-click on the outline of the chart area;
      37.6.2. By holding down the mouse button, move the chart;
      37.6.3. Release the mouse button.

38. Add the title **Last Year results** to the chart:
   38.1. Double left-click on the chart area;
   38.2. Execute the **Insert→Titles** menu command of the chart;
   38.3. In the **Title** field of the **Titles** dialogue box, enter the chart title **Last Year results**;
   38.4. In the dialogue box, click the **OK** button;
   38.5. Left-click outside the chart area;
   38.6. Click the **Save** button in the toolbar.

39. Explain the cause of the error in the **error** worksheet:
   39.1. Click on the **error** worksheet to open it;
   39.2. In the cell B12, enter the letter of your answer:
      A. There is an euro sign in the cell which prevents the completion of the formula;
      B. Wrong decimal separator is used;
      C. The value of the formula itself is also summed up;
      D. A blank cell is summed up.

40. Freeze cells to always display the names of the columns and rows in the **list** worksheet:
   40.1. Click on the **list worksheet** to open it;
   40.2. Click in the cell B2;
   40.3. Perform the **Window→Freeze** menu command.

41. Add a currency **EUR** symbol to the data in the **tests** worksheet. Specify the font size 13. Specify 2 decimals:
   41.1. Click on the **tests** worksheet tab to open it;
   41.2. Select the entire worksheet:
      41.2.1. Click on the point of intersection of the rows and columns:
      ![The IT Test Chart](image)
   41.3. In the **Font Size** toolbar menu, select the font size 13:
41.4. Select the cells B3:F10;
41.5. Perform the Format->Cells menu command;
41.6. Click on the Numbers tab to open it, if necessary;
41.7. In the Category pane, select Currency;
41.8. In the Format menu, select EUR € English (Eire);
41.9. In the Format Cells dialogue box, click the OK button.

42. Adjust cells to display the cell gridlines on the printout:
42.1. Perform the Format->Page command;
42.2. Click on the Sheet pane to open it;
42.3. In the Print checkbox, tick Grid;
42.4. Click the OK button in the dialogue box;
42.5. Increase the width of the columns to display the entire content of the cells:
   42.5.1. Position the mouse pointer between the columns B and C;
   42.5.2. Double left-click;
   42.5.3. Repeat these steps for the other columns;
42.6. Save the changes by clicking the Save button in the toolbar;
42.7. Close the document:
   42.7.1. Execute the File->Close menu command.

43. Save the file results.ods in the PDF format:
43.1. Open the results.ods spreadsheet file:
   43.1.1. Perform the Places->Documents command in the top panel of the desktop;
   43.1.2. Double left-click to open the 4_izklajlapas folder;
   43.1.3. Double left-click to open the 4.9_test folder;
   43.1.4. Double left-click to open the results.ods file.
43.2. Execute the File->Export as PDF menu command;
43.3. In the PDF Options dialogue box, accept the default settings by clicking the Export button;
43.4. In the Name field, enter the file name report;
43.5. In the Places pane, select the Desktop folder;
43.6. Click the Save button.

44. Without changing the width of the column, adjust the B cell to display the whole name of the training course:
44.1. Select the cells B2:B20;
44.2. Perform the Format->Cells command;
44.3. In the Format->Cells dialogue box, click on the Alignment tab to open it;
44.4. Tick Wrap text automatically;
44.5. Click the OK button in the dialogue box.

45. In the Sheet3 worksheet, copy the values of the annual revenue from the data worksheet:
45.1. Click on the data tab to open the worksheet;
45.2. Select the cells F2:F9;
45.3. Press the Ctrl key;
45.4. By holding down the Ctrl key, press the C key on the keyboard;
45.5. Release all the keys;
45.6. Click on the Sheet3 tab to open the worksheet;
45.7. Click in the cell A2;
45.8. Perform the Edit->Paste Special menu command;
45.9. In the Paste Special dialogue box, remove the tick from the Paste all checkbox;
45.10. In the Selection pane, remove all other ticks and leave the sole tick in the Numbers pane;
45.11. Click the OK button.
46. Rename the Sheet3 as control;
46.1. Right-click on the tab Sheet3;
46.2. Select the Rename command in the right-click menu;
46.3. In the Name field, enter control;
46.4. Click the OK button;
46.5. Save the changes to the document by clicking the Save button in the toolbar;
46.6. Close the document by clicking the Close button in the title bar.