RSLinx® Classic Getting Results Guide

Getting Results Guide

Performance and Visibility

Allen-Bradley

Rockwell Automation
# Table of contents

## Chapter 1

**Introduction**
- Purpose of the document: 7
- Intended audience: 7
- How does the getting results guide fit in with other Rockwell Software product documentation?: 7
- Help: 7
- Document conventions: 8
- Feedback: 8

## Chapter 2

**Welcome to RSLinx Classic**
- What is RSLinx Classic?: 9
- Differences between RSLinx Classic types: 9
  - RSLinx Classic Lite: 9
  - RSLinx Classic Single Node: 10
  - RSLinx Classic OEM: 10
  - RSLinx Classic Gateway: 11
- Quick start: 11
  - Step 1 Configure a driver: 12
  - Step 2 Configure a topic: 12
  - Step 3 Copy a link to the clipboard: 13
  - Step 4 Paste a link from the clipboard: 14
- Explore RSLinx Classic: 14
  - Title bar: 15
  - Menu bar: 15
  - Toolbar: 16
  - Application workspace: 17
  - Status bar: 17

## Chapter 3

**Install and start RSLinx Classic**
- Before you begin: 19
- System requirements: 19
  - Hardware requirements: 19
  - Software requirements: 20
- Install RSLinx Classic software: 20
- Update an existing installation: 23
- Start RSLinx Classic software: 24
- Troubleshooting installation: 24
# Table of contents

## Chapter 4

**RSWho**
- Use RSWho........................................................................................................... 25
- RSWho browsing ............................................................................................... 26

## Chapter 5

**OPC and DDE Connectivity**
- OPC ....................................................................................................................... 27
- DDE ......................................................................................................................... 27
- DDE/OPC client connectivity ............................................................................... 28

## Chapter 6

**Find the information you need**
- Use the help .......................................................................................................... 29
  - Access help for a control or field .................................................................... 29
  - Find step-by-step procedures ......................................................................... 30
  - Find definitions .................................................................................................. 32
- Access guides ....................................................................................................... 32
- Training .................................................................................................................. 32
- Technical support .................................................................................................. 33
  - When you call .................................................................................................... 33

## Appendix A

**Activation**
- Grace period .......................................................................................................... 35
- Activate RSLinx Classic with FactoryTalk Activation Manager ........... 35
  - How to activate RSLinx Classic ....................................................................... 35
  - Find more information about FactoryTalk Activation ......................... 36

## Appendix B

**Secure RSLinx Classic with FactoryTalk Security**
- How do I set up security in RSLinx Classic? ................................................... 37
  - If you have not used FactoryTalk Security or RSSecurity before .......... 37
  - If you have used RSSecurity but not FactoryTalk Security .......... 40
  - If you have used FactoryTalk Security before ........................................... 43
- What can I secure in RSLinx Classic? ................................................................. 45
  - Considerations when using RSLinx Classic with FactoryTalk Security
    - Network/Local Directory .......................................................................... 46
    - Reset Network Tree .................................................................................. 46
    - Miscellaneous ............................................................................................. 47
Glossary

Index
Chapter 1

Introduction

Purpose of the document

The *Getting Results with RSLinx Classic™* guide provides you with information on how to install and navigate the RSLinx Classic software. It explains how to access and navigate the help, and how to effectively use the RSLinx Classic software.

Intended audience

We assume that you are familiar with:

- IBM-compliant personal computers
- Microsoft® Windows® operating systems
- OPC (OLE for Process Control®) communication
- DDE (Microsoft dynamic data exchange) messaging
- Allen-Bradley PLC™ (programmable logic controllers)
- Rockwell Software PLC programming tools

How does the getting results guide fit in with other Rockwell Software product documentation?

This getting results guide can be considered the entry point into Rockwell Software documentation set for this product. The documentation set contains pertinent, easily accessible product information and ships with the software product. This set ships with the software product, and is designed to free you from tedious paper shuffling and reduce information overload.

Other components of the documentation set include electronic release notes and help.

Help

The help includes all overview, procedural, screen, and reference information for the product. The help contains these basic components: overview topics, quick start topics, step-by-step procedures, and screen element descriptions (for example, text boxes, drop-down lists, and option buttons). All of the help is context-sensitive with the application, and provides you with immediate access to application tasks and screen element descriptions. For a more detailed description of the help, see Chapter Five, *Find the information you need.*
Note: This getting results guide, as well as any reference guides, are included in a PDF (portable document format) on your RSLinx Classic DVD. These files must be viewed using the Adobe Acrobat Reader software, which you can download for free from the Adobe website: http://www.adobe.com

Document conventions

The conventions used throughout this document for the user interface comply with those recommended by Microsoft. If you are not familiar with the Microsoft Windows user interface, read the documentation supplied with the operating system you are using before attempting to use this software.

Feedback

Please use the feedback form packaged with your software to report errors, or let us know what information you would like to see added in future editions of this document. You can also send an email message to info@software.rockwell.com with any comments about Rockwell products and services.
Welcome to RSLinx Classic

This chapter includes the following information:

- What is RSLinx Classic?
- Differences between RSLinx Classic types
- Quick start
- Explore RSLinx Classic

What is RSLinx Classic?

RSLinx Classic for Rockwell Automation Networks and Devices is a comprehensive factory communication solution, providing Allen-Bradley programmable controller access to a wide variety of Rockwell Software and Allen-Bradley applications. These range from device programming and configuration applications such as RSLogix and RSNetWorx, to HMI (Human-Machine Interface) applications such as RSView32, FactoryTalk View SE (Site Edition), and FactoryTalk View ME (Machine Edition), to your own data acquisition applications using Microsoft Office, web pages, or Visual Basic®. RSLinx Classic also incorporates advanced data optimization techniques and contains a set of diagnostics. The API (Application Programming Interface) supports custom applications developed with the RSLinx Classic SDK. RSLinx Classic is an OPC Data Access Compliant Server and a DDE server.

Differences between RSLinx Classic types

RSLinx Classic is available in four versions to meet the demand for a variety of cost and functionality requirements. Depending on the version you are running, some functionality may or may not be operational. Refer to the following sections for specific version functionality.

The RSLinx Classic version you are running appears in the title bar at the top of the main window. If a version of RSLinx Classic is started without the proper activation files, it runs as RSLinx Classic Lite.

RSLinx Classic Lite

RSLinx Classic Lite provides the minimum functionality required to support RSLogix and RSNetWorx. This version is not commercially available, but is bundled with products that require only direct access to the RSLinx Classic network drivers. This version does not support OPC, DDE, or the published RSLinx Classic C API (Application Programming Interface).

RSLinx Classic Lite is used for the following:
• Ladder logic programming using RSLogix products.
• Network and device configuration and diagnostics using RSNetWorx.
• Configuring Ethernet modules and devices (for example, 1756-ENET, 1756-DHRIO, and so on).
• Upgrading firmware using ControlFlash.
• Browsing networks and getting device information such as firmware revision.

RSLinx Classic Single Node

RSLinx Classic Single Node includes the required functionality to supply communication services for all Rockwell Software products. OPC and DDE interfaces are supported, but to only one device. It does not support applications developed for the RSLinx Classic C API, or direct drivers in HMI applications. RSLinx Classic OEM or higher is required for these application types.

RSLinx Classic Single Node is used for the following:

• Data acquisition using OPC or DDE to only one device. This includes clients such as RSView32, FactoryTalk View SE, FactoryTalk View ME Station, Microsoft Office, Visual Basic, and web pages.
• Ladder logic programming using RSLogix products.
• Network and device configuration and diagnostics using RSNetWorx.
• Configuring Ethernet modules and devices (for example, 1756-ENET, 1756-DHRIO, and so on).
• Upgrading firmware using ControlFlash.
• Browsing networks and getting device information such as firmware revision.

RSLinx Classic OEM

RSLinx Classic OEM includes the required functionality to supply communication services for all Rockwell Software products. OPC and DDE clients are supported for any number of devices. It also supports applications developed for the RSLinx Classic C API.

RSLinx OEM version 2.2 and previous versions only supported AdvanceDDE. RSLinx Version 2.3 and subsequent versions support all DDE types except FastDDE.

RSLinx Classic OEM is used for the following:
• Data acquisition using OPC or DDE to any number of devices. This includes clients such as RSView32, FactoryTalk View SE, FactoryTalk View ME Station, Microsoft Office, Visual Basic, and web pages.

• Ladder logic programming using RSLogix products.

• Network and device configuration and diagnostics using RSNetWorx.

• Configuring Ethernet modules and devices (for example, 1756-ENET, 1756-DHRIO, and so on).

• Upgrading firmware using ControlFlash.

• Browsing networks and getting device information such as firmware revision.

### RSLinx Classic Gateway

RSLinx Classic Gateway extends RSLinx Classic-based communication throughout the enterprise by connecting clients over TCP/IP networks. Programming and configuration products such as RSLogix and RSNetWorx use a local RSLinx Classic Lite or better with a Remote Devices via Linx Gateway driver configured to communicate to the RSLinx Classic Gateway. Remote HMIs and VB/VBA applications including Microsoft Office can use remote OPC to communicate to RSLinx Classic Gateway for data collection. This allows you to have multiple distributed computers performing data collection without having RSLinx Classic installed on each machine!

In addition to the capabilities provided in the RSLinx Classic Professional version, RSLinx Classic Gateway offers remote connectivity to:

• Multiple RSView32, FactoryTalk View SE, and FactoryTalk View ME Station clients accessing data through one RSLinx Classic Gateway (remote OPC).

• Remote computer running RSLogix connecting to a plant network over a modem for online program changes.

• Remote Microsoft Office applications showing plant floor data such as Excel.

• A web page showing plant floor data when the web server and RSLinx Classic are on separate computers.

### Quick start

This section outlines the main tasks you need to perform to use the RSLinx Classic software. The quick start information included in this section is intended to be a high-level, conceptual overview. When you are ready to use RSLinx Classic software, follow the detailed procedures found in the Quick Start, which is located in the RSLinx Classic help. To access the Quick Start, click **Help > Quick Start** from within RSLinx Classic. For information about specific controls on RSLinx Classic windows and dialog boxes, right-click any control.
Step 1 Configure a driver

A driver is the software interface to the hardware device that will be used to communicate between RSLinx Classic and your processor. To configure a driver in RSLinx Classic, click **Communications > Configure Drivers**. The **Configure Drivers dialog** box appears, which is used for adding, editing, or deleting drivers. Click a driver to configure from the Available Driver Types list, click **Add New**, and complete the information required in the driver configuration dialog box that shows. The driver configuration dialog box varies depending on which driver you select.

After you complete the driver configuration, the driver name will appear in the **Configured Drivers** list.

![Configure Drivers dialog](image)

Step 2 Configure a topic

In RSLinx Classic, a project is a storage container for one or more topics, and a topic represents a specific path to a processor. By grouping topics together in a project, you can make multiple topics available at the same time. To create or edit a project in RSLinx Classic, select **File > Open Project** (opens the Open Project window). To create or edit a topic, select **DDE/OPC > Topic Configuration** (opens the DDE/OPC Topic Configuration window). If you attempt to create a topic without creating a project, RSLinx Classic creates default project for you.
If you selected Configure New DDE/OPC Topic by right-clicking a station in RSWho, the Topic Name field is pre-filled for you. RSLinx Classic starts with the name of the program running in the processor, and if this topic exists, it adds a number to the end until it finds one that does not exist. If there are any spaces, it converts them to underscores (_). You can change the topic name RSLinx Classic selected for you.

From the Data Source tab, click the device, with which you wish to set up communication. To add a new topic to a project that already has at least one topic configured, click New. To edit an existing topic, click the topic from the list. Use the Data Collection tab to include more detailed information about specific topics.

Step 3 Copy a link to the clipboard

RSLinx Classic provides a mechanism for easily establishing a link from RSLinx Classic to a compatible program. To use the Copy to Clipboard function, choose an RSLinx Classic project that contains topics. Select Edit > Copy DDE/OPC Link, select the topic, and then click OK.

The Copy function takes the information needed to create a link and places it on the Windows clipboard. Some packages support the ability to paste links from the clipboard. The Copy to Clipboard function can be used with these applications only.
Select the topic you just added in the DDE/OPC Topic Configuration dialog box, and browse for the address string for your request.

The Copy to Clipboard function only establishes hot links from RSLinx Classic, the DDE server, to a Windows DDE client application. The Data Table Address, Block Size, Columns per Row, and selected topic are maintained from the last time that you used this function. Changing these values has no effect on the last established link.

**Step 4 Paste a link from the clipboard**

Most Windows applications support a Paste Link operation, and this feature is generally located in the Edit menu.

Go to your application program that supports the Paste Link function. For example, in Microsoft Excel, click an open cell in a spreadsheet where you would like to place the data, click **Edit > Paste Special**, click **Paste Link**, and click **OK**. The hot link is pasted into the spreadsheet at the location you selected and begins to update. If you click **Paste**, instead of **Paste Link**, the item string will get copied.

When you start RSLinx Classic, the Rockwell Software RSLinx Classic application window appears. The application window contains a title bar, a menu bar, a tool bar, the application workspace where opened child windows (RSWho, diagnostics, and so on), and a status bar.
Title bar

The title bar shows the RSLinx Classic icon, the name of the software product (for example, Rockwell Software RSLinx Classic Gateway), the RSWho instance number (RSWho - 1 opens by default when you open RSLinx Classic), and the Minimize, Maximize, and Close button.

To view the Control Menu, click the RSLinx Classic icon on the title bar. The following items appear on the Control Menu.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Restore</td>
<td>Restores the window to its former size after you enlarged it by using the Maximize command or shrunk it by using the Minimize command.</td>
</tr>
<tr>
<td>Move</td>
<td>Allows you to reposition the window on the desktop using the arrow keys on the keyboard.</td>
</tr>
<tr>
<td>Size</td>
<td>Allows you to resize the window by using the arrow keys on the keyboard.</td>
</tr>
<tr>
<td>Minimize</td>
<td>Shrinks the window to an icon, which is located on the task bar. This performs the same function as if you clicked the Minimize button on the title bar.</td>
</tr>
<tr>
<td>Maximize</td>
<td>Enlarges the window to occupy the entire screen. This performs the same function as if you clicked the Maximize button on the title bar.</td>
</tr>
<tr>
<td>Close</td>
<td>Exits the RSLinx Classic application. This performs the same function as if you clicked the Close button on the title bar.</td>
</tr>
</tbody>
</table>

Menu bar

The RSLinx Classic menu bar contains the following menus:

File | Edit | View | Communications | Station | DDE/OPC | Security | Window | Help

Each menu contains options for performing the following tasks:

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>File</td>
<td>Create and open RSLinx Classic projects.</td>
</tr>
<tr>
<td>Edit</td>
<td>Copy DDE and OPC links to the clipboard.</td>
</tr>
<tr>
<td>View</td>
<td>Set and change RSLinx Classic interface shows, open the Event Viewer, and click the RSWho view.</td>
</tr>
<tr>
<td>Communications</td>
<td>Configure drivers, topics, and other RSLinx Classic options, and view driver, DDE, other client application diagnostics.</td>
</tr>
</tbody>
</table>
### Menu Description

<table>
<thead>
<tr>
<th>Menu</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Station</td>
<td>Perform actions on diagnostic counters and view the Data Monitor.</td>
</tr>
<tr>
<td>DDE/OPC</td>
<td>Configure DDE/OPC topics and view event and diagnostic information.</td>
</tr>
<tr>
<td>Security</td>
<td>Set security user and access rights.</td>
</tr>
<tr>
<td>Window</td>
<td>Arrange RSLinx Classic windows.</td>
</tr>
<tr>
<td>Help</td>
<td>View help options for RSLinx Classic and other Rockwell Software products and services.</td>
</tr>
</tbody>
</table>

### Toolbar

The toolbar contains shortcuts to several commonly used RSLinx Classic functions. Each toolbar button is a graphical representation of a command that is also available from the RSLinx Classic menu bar. The following items appear on the RSLinx Classic toolbar.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Menu Selection</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![File]</td>
<td>File &gt; Open Project</td>
<td>Shows the currently defined projects and allows you to open a DDE/OPC project.</td>
</tr>
<tr>
<td>![Communications]</td>
<td>Communications &gt; RSWho</td>
<td>Opens an additional instance of RSWho (one instance is opened by default each time you open RSLinx Classic).</td>
</tr>
<tr>
<td>![Communications]</td>
<td>Communications &gt; Configure Drivers</td>
<td>Shows the currently configured RSLinx Classic software drivers and allows you to add additional drivers for use with your hardware devices.</td>
</tr>
<tr>
<td>![Communications]</td>
<td>Communications &gt; Driver Diagnostics</td>
<td>Shows a list of currently configured drivers and provides the option to view diagnostic information for each driver.</td>
</tr>
<tr>
<td>![Edit]</td>
<td>Edit &gt; Copy DDE/OPC Link</td>
<td>Provides the ability to create a DDE/OPC link between RSLinx Classic and a client application such as Microsoft Excel.</td>
</tr>
<tr>
<td>![DDE/OPC]</td>
<td>DDE/OPC &gt; Topic Configuration</td>
<td>Allows you to create and modify a DDE/OPC topic, which is a specific path to a processor.</td>
</tr>
<tr>
<td>![Help]</td>
<td>Help &gt; What's This?</td>
<td>Changes the cursor to an arrow and a question mark to indicate you are in What's This? help mode. Click any screen item to show help text for that item and to exit What's This? help mode.</td>
</tr>
</tbody>
</table>
Application workspace

The application workspace shows open child windows, such as the RSWho and RSLinx Classic dialog boxes.

Status bar

The status bar at the bottom of the RSLinx Classic screen provides information about the current status of your system.

The left area of the status bar is used to pass messages to the user. For example, when you scroll through the items on the menus, a brief description of the function of that menu item appears in this area of the status bar.

The right area of the status bar shows:

- CAP if the Caps Lock key on your keyboard is toggled for all caps.
- NUM if the Num Lock key on your keyboard is set to enable the numeric keypad on your keyboard.
- SCRL if the Scroll Lock key on your keyboard is set.
- The current date from your computer system clock and calendar.
- The current time from your computer system clock and calendar.
Chapter 3

Install and start RSLinx Classic

This chapter explains how to install and start RSLinx Classic software. This chapter includes information on the following:

- System requirements
- Installation procedure
- Update an existing installation
- Start procedure
- Troubleshooting installation

After installing the software, you are recommended to read the release notes located in the help. The release notes may contain more up-to-date information than was available when this document was published. To view the release notes, start RSLinx Classic, and then choose Help > Release Notes from the main menu.

Before you begin

Rockwell Software uses a software key to implement copy protection for Windows-based software products. Every software product has a unique key. Although, you can install the software on any number of computers, you are only licensed to run the software on one computer at a time. After you install the RSLinx Classic software, the Setup program will prompt you to activate your software. For more information about moving software keys, copy protection, and software activation, refer to Appendix A in this guide.

System requirements

To effectively use RSLinx Classic, your personal computer must meet the following minimum hardware and software requirements:

Hardware requirements

To install RSLinx Classic software, you will need the following hardware:

- Minimum: Intel Pentium III, 600MHz, with at least 512MB (Megabytes) of RAM.
- Recommended: Intel Pentium 4, 2GHz or faster, 1GB or more RAM
- This version of RSLinx Classic will not run on Alpha, MIPS, or Power computer processors.
- At least 2.2GB of available hard drive space; more hard disk space may be required for specific application features.
- A 16-color, SVGA display with 800 by 600 or greater resolution.
- A mouse or other Windows-compatible pointing device.
- An Ethernet card, and Allen-Bradley communication device or cable.

**Software requirements**

To run RSLinx Classic v3.80.00 (CPR 9 Service Release 8), one of the following operating systems is required:

**Supported operating systems**

- Windows 8.x
- Windows 7 Professional, Windows 7 Professional SP1, Windows 7 Home Premium SP1, Windows 7 Enterprise SP1, Windows 7 Ultimate SP1 (64-bit), and Windows Embedded Standard 7 SP1
- Windows Vista SP2 (32-bit)
- Windows Server 2012 Standard (64-bit), Windows Server 2012 Datacenter (64-bit), Windows Server 2012 R2 Standard (64-bit), and Windows Server 2012 R2 Datacenter (64-bit)
- Windows Server 2008 SP2 Standard, Windows Server 2008 R2 Standard (64-bit), Windows Server 2008 R2 SP1 Standard (64-bit), and Windows Server 2008 R2 SP1 Enterprise (64-bit)

For the latest information regarding software platform support, refer to http://www.rockwellautomation.com/compatibility/#/scenarios.

You can install one or more Rockwell Software products to a single personal computer.

**Tip:** To install RSLinx Classic, you must log onto your computer as an Administrator.

To install RSLinx Classic software, perform the following steps:

1. Start your Windows operating system.
2. Insert the RSLinx Classic DVD into the DVD-ROM drive.
• Click **Start**, and then click **Run**. The **Run** dialog box appears.

• In the Open control, type `x:\setup`, where `x` is the letter of the drive containing the RSLinx Classic DVD-ROM, and then click **OK**. The RSLinx Classic opening screen appears.

3. On the **Welcome to the RSLinx Classic Setup Wizard** dialog box, read the RSLinx Classic introductory information. Wait while the wizard is preparing for installation.

• If Adobe Reader XI is installed on the computer, the RSLinx Classic Setup Wizard goes to the next dialog box directly.

• If Adobe Reader XI is not installed on the computer, the installation of Adobe Reader XI starts automatically in a new window. Adobe Reader is required to open the Installation Guide, User Guide, and other documents. Wait for the Adobe Reader XI installation to complete, or click **Cancel** to terminate the Adobe Reader XI installation. Once the Adobe Reader XI installation is completed or terminated, the RSLinx Classic Setup Wizard goes to the next dialog box.

4. On the **Rockwell Software Common Setup** dialog box, follow the instructions that appear on the screen. The general order of the installation will be:
- **Product selection** - Click **View Release Notes for Selected Product** to ensure your system meets the minimum requirements, and to learn about new features included with this version of RSLinx Classic. After you have read the Release Notes, click **Next**.

- **FTA notes** - RSLinx Classic requires activation using FactoryTalk Activation Manager. Even if you previously used a different method of activation, RSLinx Classic v3.80.00 must be activated using FactoryTalk Activation Manager. Read the information about software activation on the dialog box, and then click **Next**.

- **Process Terminating** - During the installation, the Setup Wizard identifies Rockwell Automation software that will be replaced. The Setup Wizard automatically terminates the Rockwell Automation processes that are listed on the dialog box. Read the information on the dialog box and check the Rockwell Automation Software that are listed. Click **Next** to terminate the Rockwell Automation software process and proceed with the installation process. This step is available only if any Rockwell Automation software process needs to be terminate.

  **Important:** This procedure could shut down your process applications! Depending on which applications you are installing or upgrading, it is possible that your factory automation system will become inoperable, shutting down your processes. Be certain you have prepared for this downtime and all of your company's systems are prepared for these applications to be terminated.

- **Customer Information** - Type your user name and the name of your organization, and then click **Next**.

- **License Agreement** - End-user license agreements (EULA) spell out your rights and responsibilities. Depending on the applications being installed, it is possible that there may be more than one license agreement on this page. The individual license agreements are listed above the text box. Read the entire Software License Agreement. Click **Accept all** to continue installation, or click **Decline** to exit the installation.

- **Enable Security** - During the installation, the Setup Wizard detects whether RSSecurity Emulator software is present on the computer. If RSSecurity Emulator is present, you can enable security during the installation. Read the information about security configuration selection. Select the check box to enable the security function, or clear the check box to disable the security function, and then click **Next**. This step is available only if RSSecurity Emulator has been installed on the computer prior to the RSLinx Classic installation.

- **Installation Location** - Select the drive where you want to install the RSLinx Classic software, and then click **Next**.
Tip: The default installation directory for RSLinx Classic software is C:\Program Files\Rockwell Software. If needed, select the list to browse to another drive location.

- **Configuration Summary** - This summary indicates the software that will be included in the installation process. Clicking on any of the prerequisites or Rockwell Software will display a description in the Description window. The bottom of the screen shows the total hard drive space required for the selected application as well as the space required for all products that will be installed. When ready to proceed, click **Install** to start the RSLinx Classic installation process.

5. After the RSLinx Classic software finishes installing, the **Rockwell Software Setup** dialog box opens. Read the installation summary on the dialog box. For RSLinx Classic Professional, RSLinx Classic OEM, RSLinx Classic Gateway, RSLinx Classic Single Node and RSLinx Classic personalized versions, the **software activation** check box appears on this dialog box. Select the check box to activate the software now, or clear the check box to activate the software later. Click **Finish**.

- If you select the check box, the **Software Activation** dialog box opens. See **Activate in Installation Setup Wizard** on page 35 about the activation steps.
- If you clear the check box, proceed to Step 6. You can activate the software later by using FactoryTalk Activation Manager.

6. A window opens and prompts you to restart the computer. Click **Yes** to restart the computer or click **No** to restart later. You must restart your computer before using RSLinx Classic. The RSLinx Classic installation is complete.

7. When you finish installing the software, remove the RSLinx Classic DVD from the DVD-ROM drive, and store it in a safe place.

Perform the following steps to update an existing RSLinx Classic installation to RSLinx Classic v3.80.00 (CPR 9 SR 8):

1. Close your current version of RSLinx Classic.

2. Insert the RSLinx Classic DVD into the DVD-ROM drive. Refer to **Install RSLinx Classic software** on page 20 and perform the installation steps. The old version of RSLinx Classic that exists on your computer is automatically uninstalled when you install RSLinx Classic v3.80.00 (CPR 9 SR 8).
Tip: The Installation Setup Wizard automatically backs up the driver configuration that exists in the old version of RSLinx Classic, and restore the configuration automatically into RSLinx Classic v3.80.00 (CPR 9 SR 8). You can find the backup file BackupFromSystemInstall.rsx in C:\Documents and Settings\<username>\My Documents or C:\users\<username>My Documents.

3. When the upgrade completes, restart your computer.

Start RSLinx Classic software

To start RSLinx Classic software, select Start > Programs > Rockwell Software > RSLinx > RSLinx Classic.

Note: We assume that you used the default names for the directory and program group. If you did not use the default names, substitute the actual names that you specified for the default names shown.

Troubleshooting installation

If RSLinx Classic does not start or run properly, consider the following:

- Does your computer have enough memory? Running RSLinx Classic requires a minimum of 512MB of RAM.
- Does your computer have enough disk space? Running RSLinx Classic requires a minimum of 2.2GB of available hard disk space.
- Do you have the correct activation for RSLinx Classic installed? If your RSLinx Classic installation shows as RSLinx Classic Lite, RSLinx Classic Single Node, or RSLinx Classic OEM, the proper activation files were not installed. See Activate RSLinx Classic with FactoryTalk Activation Manager on page 35 for information about activation files.
- Have you reinstalled an earlier Service Pack or removed a component, such as DCOM, that RSLinx Classic requires?
RSWho

This chapter describes the features of the RSWho network browser interface. RSWho allows you to view all the active network connections from a single screen.

**Use RSWho**

RSWho is RSLogix Classic main window that shows networks and devices in a style similar to Windows Explorer. A variety of integrated configuration and monitoring tools are accessible from the right mouse button in the RSWho. Some of the available tools are the ControlLogix Gateway Configuration Tool for Controlnet, DeviceNet, Ethernet, 1756-DH+IO, and 1756-DH485 modules, and a Data Monitor for monitoring live data out of any ControlLogix, PLC-5, SLC, or MicroLogix family controllers.

The following figure shows the main areas of the RSLogix Classic RSWho.

<table>
<thead>
<tr>
<th>Item</th>
<th>Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Control bar</td>
</tr>
<tr>
<td>2</td>
<td>Tree control (left pane)</td>
</tr>
<tr>
<td>3</td>
<td>List control (right pane)</td>
</tr>
</tbody>
</table>
**RSWho browsing**

The RSWho icon [ ![ RSWho icon ](image) ] indicates a network. If this icon is animated, the network is being browsed. Click a network or device to start browsing.

When the network or device is collapsed (indicated by the + sign), click + or double-click the network or device icon next to the + to expand the view and begin browsing. When the network or device is expanded (indicated by the - sign), click or double-click the network or device icon next to the - to collapse the view.

If the Autobrowse check box is selected, RSWho continuously browses the selected device or network (regardless of whether or not the selection is expanded or collapsed). If Autobrowse check box is cleared, the Refresh button is active. Clicking Refresh instructs RSWho to perform one browse cycle of the selected device or network. Since Refresh only performs one browse cycle, clicking Refresh multiple times may be necessary to discover everything on the network.

Right-click a supported device to select Station Diagnostics, Configure DDE Topic, or other supported services for that device.
Chapter 5

OPC and DDE Connectivity

This chapter describes the features of:

- OPC (OLE for Process Control)
- DDE (Dynamic Data Exchange)

OPC

OPC (OLE for Process Control) is a communication standard based on OLE technology provided by Microsoft, and developed and maintained by the OPC Foundation, a coalition of industrial manufacturing companies, of which Rockwell Automation is a member. The charter of this group is to provide an industrial standard exchange mechanism between plant floor devices and client applications. RSLinx Classic is an OPC-compliant server exposing the required interfaces for an OPC client application to access data consistent with other OPC-compliant servers. The added benefit provided from RSLinx Classic is its ability to provide several DDE formats in addition to OPC.

OPC is designed to allow client applications access to plant floor data in a consistent manner. OPC provides many benefits:

- Hardware manufacturers only have to make one set of software components for customers to use in their applications.
- Software developers do not have to rewrite drivers because of feature changes or additions in a new hardware release.
- Customers have more choices with which to develop world class integrated manufacturing systems.

With OPC, system integration in a heterogeneous computing environment is simple. Leveraging the OLE/COM environment is possible.

RSLinx Classic is an OPC-compliant server. For more information about OPC, visit the OPC Foundation web site at http://www.opcfoundation.org. For more information on using OPC with Rockwell Software products, visit our web site at http://support.rockwellautomation.com.

DDE

DDE (Dynamic Data Exchange) is a standard inter-application communication protocol, which is built into Microsoft Windows operating systems and supported by many applications that run under Windows. DDE takes data from one application and gives it to another application. It allows Windows programs that support DDE to exchange data between themselves.
• A DDE server is a program that has access to data and can provide that data to other Windows programs.

• A DDE client is a program that can obtain data from a server.

By specifying an application, topic, and item, a client application can exchange data with a server application. DDE works like a conversation between two people. The people represent the different applications running under Windows, and the data they share is what they are talking about. RSLogix Classic does not know the type of data it is receiving, it only knows that a DDE link is providing the data.

For example, if you have a DDE link from RSLogix Classic to an Excel spreadsheet, Excel does not know that you are sending a counter value into a spreadsheet. All Excel sees is data.

For example, RSLogix Classic is the application name, PLC5TOPIC1 is an example topic name, and C5:0.ACC is an example item, in this case a counter accumulator in an Allen-Bradley PLC-5.

**Note:** Not all applications that run under Microsoft Windows support DDE. Check with the applications manufacturer before purchasing an application for use with RSLogix Classic.

For more information about DDE, refer to the DDE topic in the RSLogix Classic help.

RSLogix Classic provides connectivity for client applications using OPC or multiple DDE data formats. The OPC and AdvanceDDE interfaces provide optimized read operations by packing multiple requests from multiple clients in a single transaction. In configuring a DDE Topic, you can specify whether or not you want DDE poke operations optimized. Optimized pokes only work with PLC-5 and SLC processors.

The benefit of optimizing DDE poke operations is packing multiple updates in a single write operation, thus reducing the overall number of packets required. Operations such as downloading a recipe can take advantage of this feature.

Other DDE formats supported include FastDDE (for Wonderware clients), XL_Table and CF_Text to support Microsoft Office products, and other generic DDE client applications.
Find the information you need

Use this chapter to review the sources of additional information about RSLinx Classic software. This chapter helps you find what you need efficiently by describing how to:

- Use the help
- Access guides
- Participate in Rockwell Software training courses
- Contact Technical Support

Use the help

RSLinx Classic help provides general overview information, comprehensive step-by-step procedures, and context-sensitive, dialog box control definitions for working with all of the features in the software. To view online help while running RSLinx Classic:

- Choose RSLinx Classic Help from the Help menu on the RSLinx Classic main window,
- Click Help on any RSLinx Classic dialog box or property page,
- Position the cursor over a control, with which you want help and right-click, or
- Press F1.

Access help for a control or field

To show a definition for a control or a field, click the Whats This? icon in the upper right corner of the dialog box, drag the cursor to the selected area, and then click to show the definition. In this example, the Property control was selected.
Find step-by-step procedures

To view a list of tasks related to the current topic, move to the See also section at the bottom of the help window and select one of the listed tasks. The current topic is replaced with a step-by-step procedure for completing the task.

For example, from the What is a driver? help topic, if you select Add a driver under the See also section, the procedure that describes how to add RSLinx Classic drivers shows.
What is a driver?

A driver is the software interface to the hardware device that allows RSLogix Classic to communicate with your PLC. Configuring a software driver is the first step in establishing a DDE hot link.

Select **Communications > Configure Drivers** to display the Configure Drivers dialog box that is used for adding, editing or deleting drivers. The available hardware drivers are shown in the **Available Drivers** list. The presently configured drivers are displayed in the Configured Drivers list.

**Tip:** For specific information on each dialog box control, right-click on the control and select the What’s This? help option.

What do you want to do?

- Add a driver
- Edit a driver
- Delete a driver
- View information on driver diagnostics

Add a driver

**How do I access the dialog?**

1. From the Configure Drivers dialog box, select the desired driver from the Available Drivers list.
2. Click **Add New**. The configuration dialog box for that driver appears.
3. Enter the appropriate parameters for the desired driver in the configuration dialog box.
4. Click **OK** to close the configuration dialog box. The new driver now appears in the Configured Drivers list.
Find definitions

Within the RSLinx Classic help, blue text highlighted with an underline indicates a link to a pop-up definition or a link to a related topic. For example, in the Dynamic Data Exchange help topic, application, topic, and item are pop-up definitions, and DDE link is a link to a related topic.

DDE

DDE (Dynamic Data Exchange) is a standard inter-application communication protocol built into Microsoft Windows operating systems and supported by many applications that run under Windows. DDE takes data from one application and gives it to another application. It allows Windows programs that support DDE to exchange data between themselves.

- A DDE server is a program that has access to data and can provide that data to other Windows programs.
- A DDE client is a program that can obtain data from a server.

By specifying an application, topic, and item, a client application can exchange data with a server application.

DDE works like a conversation between two people. The people represent the different applications running under Windows, and the data they share is what they are talking about. Applications using DDE to talk to RSLinx Classic do not care what kind of data they are getting. All they know is there is a DDE link, and that link is providing data. What that data is and how it will be used is immaterial to the receiving application.

For example, if you have a DDE link from RSLinx Classic to an Excel spreadsheet, Excel does not know that you are sending a counter value into a spreadsheet. All Excel sees is data.

For example, RSLINK is the application name, PLCSTOPI1C is an example topic name, and C510:ACC is an example item, in this case a counter accumulator in an Allen-Bradley PLC-5.

Tip: Not all applications that run under Microsoft Windows support DDE. Check with an application's manufacturer before purchasing an application for use with RSLinx Classic.

Access guides

You can gain immediate access to product documentation through the guides included with RSLinx Classic. The guides include this Getting Results Guide, as well as any reference guides, in an electronic book format. The guides are included in a PDF (portable document format) on your RSLinx Classic DVD. These files must be viewed using the Adobe Acrobat Reader software, which you can download for free from the Adobe website at http://www.adobe.com.

Training

One of the best ways to increase your proficiency at using Rockwell Software products is to attend a Rockwell Software training program. Our training programs can help you master the basics and show you how to unleash the full potential of our software.

Rockwell offers a wide range of training programs, from regularly scheduled classes conducted at Rockwell Software facilities, to custom-tailored classes conducted at your enterprise. The size of each class is kept small intentionally to maximize student engagement.

If you would like more information about Rockwell training programs, visit the Rockwell Software site or contact the Rockwell Software Training Coordinator. Our World Wide Web address and telephone numbers appear on the inside front cover of this document.
Technical support

If you cannot find answers to your questions in the "Getting Results with RSLinx Classic" guide, the help, or the guides, you can call Rockwell Software Technical Support at the numbers listed on the inside front cover of this guide. The technical support staff is available Monday through Friday from 8:00 A.M. to 5:00 P.M. Eastern Time, except holidays. You can also access the Rockwell Software Online Support Library from the web site listed on the inside front cover of this guide.

When you call

When you call, you should be at your computer and prepared to give the following information:

- Product serial numbers
- Product version number
- The product serial numbers and version number can be found in the software by clicking Help > About RSLinx Classic.
- Version of Windows and any service packs that you are using
- Hardware you are using
- Exact wording of any errors or messages that appeared on your screen
- Description of what happened and what you were doing when the problem occurred
- Description of how you attempted to solve the problem
Appendix A

Activation

RSLinx Classic v2.58.00 (CPR 9 Service Release 4) and later only supports activation using FactoryTalk Activation.

**Note:** EvRSl activation is replaced by FactoryTalk Activation. If you are a current user using EvRSl activation and want to upgrade to RSLinx Classic v2.58.00 or later, please contact your local Rockwell Automation Sales office or Rockwell Automation Technical Support for information on migrating your activations to FactoryTalk Activation Manager. For Rockwell Automation Technical Support in the U.S. call 1 (440) 646-3434. Outside the U.S. see http://www.rockwellautomation.com/locations/.

RSLinx Classic v3.80.00 (CPR 9 SR 8) shows a message indicates the activation status when you place the cursor over the tray icon in the notification area. If the activation status changes during runtime, the message shows the new status after you restart RSLinx Classic.

**Grace period**

RSLinx Classic v2.52.00 (CPR 9) and later supports a seven-day activation grace period when a valid activation is not found. During the grace period:

- When the software is started, a message is logged to the FactoryTalk Diagnostic log every four hours until a valid activation is found.
- RSLinx Classic can be started an unlimited number of times. If the grace period ends, and a valid activation has not been found, RSLinx Classic Lite is started.

**Note:** If RSLinx Classic is unable to successfully obtain valid activations (for example, a network failure occurs), the software will attempt to run in grace period for up to seven days.

**Activate RSLinx Classic with FactoryTalk Activation Manager**

**How to activate RSLinx Classic**

RSLinx Classic v3.70.00 introduces the ability to activate the software during the software installation. The new Installation Setup Wizard contains an **Activate products using FactoryTalk Activation** check box. This no longer requires you to open FactoryTalk Activation Manager to activate the software.

To activate your RSLinx Classic v3.70.00 and later in the **RSLinx Classic Installation Setup Wizard**, perform the following steps:
1. Perform the steps in **Install RSLinx Classic software on page 17** on page 20 to install RSLinx Classic software.

2. On the **Rockwell Software Setup** dialog box in the Installation Setup Wizard, select the **Activate products using FactoryTalk Activation** check box and click **Finish**.

3. On the **Software Activation** dialog box, enter the serial number and product key from your Activation Certificate.

4. Select **Activate locally** to activate RSLinx Classic on a single computer, or select **Activate using a dongle** to activate RSLinx Classic on any computer by using a dongle.

   **Note:** The **Activate using a dongle** option requires that you have a dongle to lock the activation.

5. Click **Continue**.

You can still activate RSLinx Classic via FactoryTalk Activation Manager by clicking the **Explore other options** link in the **Software Activation** dialog box. The link provides direct access to the FactoryTalk Activation Manager software. To activate your copy of RSLinx Classic in the FactoryTalk Activation Manager, click **Get New Activations** and follow the instructions in the FactoryTalk Activation Manager.

For more information on using the FactoryTalk Activation Tool, click **More** or **Help** in the FactoryTalk Activation Manager window.

**Find more information about FactoryTalk Activation**

For help with FactoryTalk Activation Manager at any point, you can click:

- **Help** on the FactoryTalk Activation Manager window
- **Help** on the Rockwell Software Activation website: https://licensing.software.rockwell.com

If you cannot connect to the Internet, call Technical Support for help creating an activation file from an e-mail or a fax.

Phone: 440-646-3434 in North America. Outside of North America, call your local support organization.
Secure RSLinx Classic with FactoryTalk Security

FactoryTalk Security™ is intended to improve the security of your automation system by limiting access to those with a legitimate need. FactoryTalk Security authenticates user identities and authorizes user requests to access a FactoryTalk-enabled system. These security services are fully integrated into the FactoryTalk Directory and are included as part of the FactoryTalk Services Platform that installs with many products.

For more information on how to use security services, please refer to FactoryTalk Security help.

RSLinx Classic, along with supporting RSSecurity, also supports FactoryTalk Security. FactoryTalk Security is intended to improve the security of your automation system by limiting access to those with a legitimate need. FactoryTalk Security authenticates the identities of users and authorizes user requests to access a FactoryTalk-enabled system against a set of defined user accounts and access privileges held in the FactoryTalk Directory. For more information on FactoryTalk Security, read the About FactoryTalk Security topic located in RSLinx Classic Help. The following sections explain the steps you would need to perform to implement one of the two security mechanisms (FactoryTalk Security and RSSecurity) supported by RSLinx Classic.

Follow the steps in the sections below to set up security in RSLinx Classic v3.70.00 (CPR 9 SR 7) and later versions.

**Note:** When you install or upgrade the RSLinx Classic software, make sure to install or upgrade a compatible version of FactoryTalk Services Platform. For the compatibility information, refer to http://www.rockwellautomation.com/compatibility/#/scenarios.

If you have not used FactoryTalk Security or RSSecurity before

If you have not used FactoryTalk Security before, and have never configured security using RSSecurity, follow the steps below to set up security in
RSLinx Classic. The steps below take RSLinx Classic v3.70.00 (CPR 9 SR 7) as an example.

1. Install FactoryTalk Services Platform v2.70.00 and RSLinx Classic v3.70.00 using RSLinx Classic Setup Wizard.

2. Install RSSecurity Emulator from Start > All Programs > Rockwell Software > FactoryTalk Tools > RSSecurity Emulator Install.

   **Note:** During the RSSecurity Emulator installation, the FactoryTalk Directory screen appears (see the following figure) where you will be prompted to select the FactoryTalk Directory (Network or Local) that RSSecurity Emulator should use. At this step, be sure to make a note of the directory you choose — you will require this information when adding security policies to FactoryTalk Directory in Step 4.

   ![FactoryTalk Directory Selection](image)

3. Open the Windows Control Panel. Select Add or Remove Programs or Programs and Features in the Control Panel. In the list of installed programs, right click RSLinx Classic 3.70.00 CPR 9 SR 7, and then select Change. The RSLinx Classic Setup Wizard opens. While running the RSLinx Classic Setup Wizard, select Modify in the Program Maintenance page.
Note: In the RSLinx Classic Security Configuration Selection page, select Enable Security. Click Next and follow the instructions until you finish the modification.

4. Open FactoryTalk Administration Console from Start > All Programs > Rockwell Software > FactoryTalk Administration Console to add user accounts and set security settings to secure RSLinx Classic.
Note: • For more information on how to add user accounts, read the Add a user account topic in FactoryTalk Administration Console help, located at Manage FactoryTalk-enabled systems > Log on and configure security > Configure security > How To > Work with user accounts > Add a user account.
• For more information on how to secure RSLinx Classic features, read the Secure Product Features topic in FactoryTalk Security help, located at Configure Security > How to > Set up product policies > Secure product features.
• For more information on what you can secure in RSLinx Classic, read the What can I secure in RSLinx Classic topic in RSLinx Classic Online help, located at How to > Secure RSLinx Classic with FactoryTalk > What can I secure in RSLinx Classic.

5. Open RSLinx Classic from Start > All Programs > Rockwell Software > RSLinx > RSLinx Classic, and click Security > Set Security User from the main menu. In the New User dialog box, enter the username and password of the user you created in FactoryTalk Administration Console in step 4, and click OK.

Note: Because the access to features in RSLinx Classic is governed by the permissions you set for a user in FactoryTalk Administration Console, some features out of the 13 securable features in RSLinx Classic may be inaccessible (for example, if the user you entered in Step 5 does not have the appropriate permission).

This completes the security setup for RSLinx Classic.

If you have used RSSecurity but not FactoryTalk Security

If you have not used FactoryTalk Security before, and want to import an existing RSSecurity Configuration into the FactoryTalk Directory, follow the steps below to configure security in RSLinx Classic. The steps below take RSLinx Classic v3.70.00 (CPR 9 SR 7) as an example.

1. Install FactoryTalk Services Platform v2.70.00 and RSLinx Classic v3.70.00 using RSLinx Classic Setup Wizard.


3. Locate the RSSecurity Configuration (*.bak) file, and select File > Export to backup the *.bak file.

5. Uninstall RSSecurity Server/Client (whichever is installed on this machine) from Windows Control Panel.

6. Install RSSecurity Emulator from Start > All Programs > Rockwell Software > FactoryTalk Tools > RSSecurity Emulator Install.

**Note:** During the RSSecurity Emulator installation, the FactoryTalk Directory page appears. Select the FactoryTalk Directory (Network or Local) which RSSecurity Emulator uses. At this step, be sure to make a note of the directory you choose—this directory information is needed when adding security policies to FactoryTalk Directory in Step 8 below.
7. Open the Windows Control Panel. Select Add or Remove Programs or Programs and Features in the Control Panel. In the list of installed programs, right click RSLinx Classic 3.70.00 CPR 9 SR 7, and then select Change. The RSLinx Classic Setup Wizard opens. While running the RSLinx Classic Setup Wizard, select Modify in the Program Maintenance page.

![RSLinx Classic Setup Wizard](image1)

**Note:** In the RSLinx Classic Security Configuration Selection page, select Enable Security. Click Next and follow the instructions until you finish the modification.

![RSLinx Classic Security Configuration Selection](image2)

8. Import RSSecurity Server database by selecting Start > All Programs > Rockwell Software > FactoryTalk Tools > Import RSSecurity Configuration.
Note: While running the Import RSSecurity Configuration utility, the **FactoryTalk Security Import** dialog box appears. In the Destination directory of the FactoryTalk Security Import dialog box, be sure to import the .bak file to the directory where you installed the Emulator (Local or Network).

9. Open RSLinx Classic, and select **Security > Set Security User** from the main menu. In the New User dialog box, enter the username (domain name\username) and password of the RSSecurity user.

Note:
- If you do not remember the usernames of the users that existed in your old RSSecurity setup, perform the following steps:
  a. Run FactoryTalk Administration Console by selecting **Start > Programs > Rockwell Software > FactoryTalk Administration Console**.
  b. In the Explorer pane, expand the FactoryTalk Local or Network Directory tree, and then expand the Systems folder until the Users folder is visible.
  c. In the Users folder, the users who have domain associated with their usernames (for example, na\Bob) are your RSSecurity users.
- Because access to features in RSLinx Classic is governed by the permissions you set in the security server, some features out of the 13 securable features in RSLinx Classic may be inaccessible (for example, if the user you entered in Step 9 does not have the appropriate permission)

This completes the security setup for RSLinx Classic.

**If you have used FactoryTalk Security before**

If you used FactoryTalk Security before, and want to continue to use FactoryTalk Security when upgrading RSLinx Classic to v3.70.00 or later, follow the steps below to set up security in RSLinx Classic. The steps below take RSLinx Classic v3.70.00 (CPR 9 SR 7) as an example.

1. Install FactoryTalk Services Platform v2.70.00 and RSLinx Classic v3.70.00 using RSLinx Classic Setup Wizard.
Appendix B  Secure RSLinx Classic with FactoryTalk Security

Note: While running the RSLinx Classic Setup Wizard, the RSLinx Classic Security Configuration Selection page appears. Select Enable Security. Click Next and follow the instructions until you finish the installation.

2. Open FactoryTalk Administration Console from Start > All Programs > Rockwell Software > FactoryTalk Administration Console to add user accounts and set security settings to secure RSLinx Classic.

Note:
- For more information on how to add user accounts, read the Add a user account topic in FactoryTalk Administration Console help, located at Manage FactoryTalk-enabled systems > Log on and configure security > Configure security > How To > Work with user accounts > Add a user account.
- For more information on how to secure RSLinx Classic features, read the Secure Product Features topic in FactoryTalk Security help, located at Configure Security > How to > Set up product policies > Secure product features.
- For more information on what you can secure in RSLinx Classic, read the What can I secure in RSLinx Classic topic in RSLinx Classic Online help, located at How to > Secure RSLinx Classic with FactoryTalk > What can I secure in RSLinx Classic.

3. Open RSLinx Classic from Start > All Programs > Rockwell Software > RSLinx > RSLinx Classic, and click Security > Set Security User from the main menu. In the New User dialog box, enter the username and password of the user you created in FactoryTalk Administration Console in Step 2, and click OK.
Secure RSLinx Classic with FactoryTalk Security

Appendix B

Note:
- Because the access to features in RSLinx Classic is governed by the permissions you set for a user in FactoryTalk Administration Console, some features out of the 13 securable features in RSLinx Classic may be inaccessible (for example, if the user you entered in Step 3 does not have the appropriate permission).
- When RSLinx Classic is reinstalled, all security settings that were previously configured for networks and devices are lost. You must redefine these security settings in the Networks and Devices tree, or in RSWho. For more information, see Considerations when using RSLinx Classic with FactoryTalk Security.

This completes the security setup for RSLinx Classic.

What can I secure in RSLinx Classic?

The following table explains the features you can restrict access to in RSLinx Classic. For example, you might restrict the ability to shut down the RSLinx Classic service to a small group of users, to prevent parts of your automation system from going down at runtime.

<table>
<thead>
<tr>
<th>Securable feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clear DDE/OPC Event Log</td>
<td>Shows information on any DDE/OPC error messages logged while running RSLinx Classic with DDE/OPC compliant programs.</td>
</tr>
<tr>
<td>Configure CIP Options</td>
<td>Administers how PCCC requests that use the CIP protocol are sent over networks.</td>
</tr>
<tr>
<td>Configure Client Applications</td>
<td>Maps configured and running RSLinx Classic drivers to legacy INTERCHANGE C API, as well as shows the link identifier of the virtual network maintained by RSLinx Classic for the use of Client Applications in the virtual link unsolicited messaging model.</td>
</tr>
<tr>
<td>Configure ControlLogix Gateway</td>
<td>Provides you with information about the modules in your ControlLogix Gateway.</td>
</tr>
<tr>
<td>Configure DDE/OPC Topic</td>
<td>Configures DDE/OPC topic.</td>
</tr>
<tr>
<td>Configure Drivers and Shortcuts</td>
<td>Configures (add, edit, or delete) drivers and shortcuts that allow RSLinx Classic to communicate with your PLC, and provide quick access to specific networks.</td>
</tr>
<tr>
<td>Configure Gateway</td>
<td>Allows you to enable the RSLinx Classic Gateway.</td>
</tr>
<tr>
<td>Configure Network Properties</td>
<td>Allows you to configure network properties.</td>
</tr>
</tbody>
</table>
### Securable feature Description

<table>
<thead>
<tr>
<th>Securable feature</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit DDE/OPC Project</td>
<td>Allows you to edit your DDE/OPC project.</td>
</tr>
<tr>
<td>Edit Options</td>
<td>Shows the options dialog box, which contains the General and DDE tabs.</td>
</tr>
<tr>
<td>Reset Station Diagnostic Counters</td>
<td>Clears the counters in the station diagnostic screens.</td>
</tr>
<tr>
<td>Shutdown</td>
<td>Shuts down RSLinx Classic.</td>
</tr>
<tr>
<td>View NT Event Log</td>
<td>Records important system occurrences such as RSLinx Classic drivers successfully starting and stopping.</td>
</tr>
</tbody>
</table>

### Considerations when using RSLinx Classic with FactoryTalk Security

Keep the following in mind when using RSLinx Classic with FactoryTalk Security:

#### Network/Local Directory

The FactoryTalk Services Platform can install two completely separate and independent FactoryTalk Directories: Local Directory and Network Directory. User accounts, passwords, and security permissions to securable features are completely separate and cannot be shared between the Network Directory and the Local Directory. Configuring any of these items on one directory does not configure them on the other. Similarly, changing the password to a user account in one directory does not change the password in the other directory, even if the account has the same name in both directories.

When configuring RSLinx Classic to work in one of the two directories, please keep the following in mind:

- RSLinx Classic security policies and RSSecurity Emulator must be installed in the same directory (either Local or Network).
- If you configured RSLinx Classic to work in the Network Directory, you must use FactoryTalk Security to administer centralized security across the network.
- If you configured RSLinx Classic to work in Local Directory and want to use FactoryTalk Security, you can administer security only on a single computer.

#### Reset Network Tree

When RSLinx Classic is reinstalled, all security settings that were previously configured for networks and devices are lost. You must redefine these security settings in the Networks and Devices tree, or in RSWho. For more information, read the Network and Devices are not shown correctly topic in FactoryTalk Security help, located at Configure security >
Troubleshooting security > Network and Devices are not displayed correctly.

Miscellaneous

Keep the following additional FactoryTalk Security considerations in mind:

- If you did not select the **Enable Security** check box during the RSLinx Classic installation, but want to enable security now, you will need to uninstall and then reinstall RSLinx Classic.

- Every time you are in RSLinx Classic, be sure to verify that the Username shown in the Current Security User text box of the **Set Security** dialog box (**Security > Set Security User**) is correct. If it is incorrect, enter the new Username and Password, and click **OK**.
**Activation file** - A hidden, read-only, system file that activates a Rockwell Software product. The software will run only if your system can find the correct activation file.

**Activation key** - Activation files contain a database of activation keys. Each key is particular to a certain product and must be accessible on a local or remote drive for that product to run.

**Driver** - The software interface to the hardware device that will be used to communicate between RSLinx Classic and your processor.

**DDE (Dynamic Data Exchange)** - A form of inter-process communication. When two or more programs that support DDE are running simultaneously, they can exchange information and commands.

**License** - Authorization to use a specified number of instances of software. A products activation key contains a license for each copy of the software you have purchased.

**Links** - The data path established for one or more channels between two or more stations. DDE links can be hot, warm, or cold.

**OPC** - Provides an industry-standard mechanism to communicate and exchange data between clients and servers using OLE technology.

**Packet** - The transmission unit exchanged at the network layer.

**Poke** - DDE version of a write.

**Read** - To acquire data from somewhere (memory, an output, another station).

**Topic** - Represents a specific path to a processor.

**Write** - To load data into somewhere (memory, an output, another station).
## Index

### A
- activation 35
  - FactoryTalk
    - activate 35
- application workspace 17

### C
- classes 32
- close 15
- communications device 19
- configure a driver 12
- configure a topic 12
- context-sensitive help 16, 29
- control definitions 29
- Control menu 15
- copy a link 13
- Customer Information 20

### D
- diagnostics 16
- document conventions 8
- document set 7
- driver configuration 12
- Dynamic Data Exchange 27

### E
- electronic book format 8, 32
- Enable Security 20
- ethernet card 19

### F
- FactoryTalk Activation 35
- FactoryTalk Administration Console 37
- FactoryTalk Security user 37
- feedback 8

### G
- Gateway version 11
- grace period 35

### H
- hard drive space 19
- hardware 19

### I
- Install 20
  - FactoryTalk Services Platform 37
  - RSLinx Classic 19
  - RSSecurity Emulator 37
- intended audience 7

### L
- license 19
- License Agreement 20
- Lite version 9
- Local Directory 46

### M
- maximize 15
- memory 24
- menu bar 15
- minimize 15
- mouse 19
- move 15, 45

### N
- Network Directory 45

### O
- OEM version 10
- OLE for Process Control 27
- online guides 32
- online help 7, 29

### P
- paste a link 14
- pointing device 19
- pop-up definition 32
- Process Terminating 20
- product
Index

serial numbers 33
version number 33

Q
Quick start 11

R
RAM 19, 24
related topic 32
release notes 19
requirements
  hardware 19
  software 20
restore 14, 37, 45
RSLinx Classic icon 15
RSLinx Classic types 9
RSSecurity Emulator 37
RSSecurity user 37

S
security 37
  Add user accounts 37
  considerations 46
  enable security option 47
  FactoryTalk Administration Console 37
  FactoryTalk Security user 37
  FactoryTalk Services Platform 37
  Local Directory 46
  Network Directory 45, 46
  Network Tree 46
  RSSecurity Emulator 37, 46
  RSSecurity user 37
  securable features 45
  Set Security dialog box 47
  set up security 37
serial numbers 33
Single Node version 10
size 15, 45
software 20
starting RSNetWorx for DeviceNet 19, 24
status bar 17
step-by-step procedures 29, 30
support 33
support library 33
SVGA graphics adapter 19

system requirements 19

T
tasks 30
technical support 33
title bar 15
toolbar 16
topic configuration 12
training 32
troubleshooting
  installation 24
types of RSLinx Classic 9

U
updating an existing installation 23

V
version numbers 33

W
Whatâ€™s This? help 29
Legal notices

Copyright Notice

© 2015 Rockwell Automation, Inc. All rights reserved.

This document and any accompanying Rockwell Software products are copyrighted by Rockwell Automation, Inc. Any reproduction and/or distribution without prior written consent from Rockwell Automation, Inc. is strictly prohibited. Please refer to the license agreement for details.

End User License Agreement (EULA)

You can view the Rockwell Automation End-User License Agreement ("EULA") by opening the License.rtf file located in your product's install folder on your hard drive.

Trademark Notices

Allen-Bradley, ControlLogix, Data Highway Plus, DH+, FactoryTalk, Logix5000, PanelView, PLC-2, PLC-3, PLC-5, Rockwell, Rockwell Automation, Rockwell Software, RSLinx, RSLogix, RSNetWorx, RSView, SLC, and Studio 5000 are trademarks of Rockwell Automation, Inc.

Any Rockwell Automation software or hardware not mentioned here is also a trademark, registered or otherwise, of Rockwell Automation, Inc.

Other Trademarks


Adobe, Acrobat, and Reader are either registered trademarks or trademarks of Adobe Systems Incorporated in the United States and other countries.

Oracle is a registered trademarks of Oracle Corporation.

ControlNet is a registered trademark of ControlNet International.

DeviceNet is a trademark of the Open DeviceNet Vendor Association, Inc. (ODVA).

All other trademarks are the property of their respective holders and are hereby acknowledged.

Warranty

This product is warranted in accordance with the product license. The product’s performance may be affected by system configuration, the application being performed, operator control, maintenance, and other related factors. Rockwell Automation is not responsible for these intervening factors. The instructions in this document do not cover all the details or variations in the equipment, procedure, or process described, nor do they provide directions for meeting every possible contingency during installation, operation, or maintenance. This product’s implementation may vary among users.
This document is current as of the time of release of the product; however, the accompanying software may have changed since the release. Rockwell Automation, Inc. reserves the right to change any information contained in this document or the software at any time without prior notice. It is your responsibility to obtain the most current information available from Rockwell when installing or using this product.

Environmental compliance


Contact Rockwell

Customer Support Telephone — 1.440.646.3434
Online Support — http://www.rockwellautomation.com/support
Rockwell Automation support

Rockwell Automation provides technical information on the web to assist you in using its products. At http://www.rockwellautomation.com/support you can find technical and application notes, sample code, and links to software service packs. You can also visit our Support Center at https://rockwellautomation.custhelp.com for software updates, support chats and forums, technical information, FAQs, and to sign up for product notification updates.

In addition, we offer multiple support programs for installation, configuration, and troubleshooting. For more information, contact your local distributor or Rockwell Automation representative, or visit http://www.rockwellautomation.com/services/online-phone.

Installation assistance

If you experience a problem within the first 24 hours of installation, review the information that is contained in this manual. You can contact Customer Support for initial help in getting your product up and running.

<table>
<thead>
<tr>
<th>United States or Canada</th>
<th>1.440.646.3434</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outside United States or Canada</td>
<td>Use the Worldwide Locator available at <a href="http://www.rockwellautomation.com/locations">http://www.rockwellautomation.com/locations</a> <a href="http://www.rockwellautomation.com/locations">http://www.rockwellautomation.com/locations</a>, or contact your local Rockwell Automation representative.</td>
</tr>
</tbody>
</table>

New product satisfaction return

Rockwell Automation tests all of its products to ensure that they are fully operational when shipped from the manufacturing facility. However, if your product is not functioning and needs to be returned, follow these procedures.

<table>
<thead>
<tr>
<th>United States</th>
<th>Contact your distributor. You must provide a Customer Support case number (call the phone number above to obtain one) to your distributor to complete the return process.</th>
</tr>
</thead>
<tbody>
<tr>
<td>Outside United States</td>
<td>Please contact your local Rockwell Automation representative for the return procedure.</td>
</tr>
</tbody>
</table>

Documentation feedback

Your comments will help us serve your documentation needs better. If you have any suggestions on how to improve this document, complete the feedback form, publication RA-DU002 http://literature.rockwellautomation.com/idc/groups/literature/documents/du/ra-du002_-en-e.pdf.

Rockwell Otomasyon Ticaret A.Ş., Kar Plaza İş Merkezi E Blok Kat:6 34752 İçerenköy, İstanbul, Tel: +90 (216) 5698400

www.rockwellautomation.com

Power, Control and Information Solutions Headquarters

Americas: Rockwell Automation, 1201 South Second Street, Milwaukee, WI 53204-2496 USA, Tel: (1) 414.382.2000, Fax: (1) 414.382.4444

Europe/Middle East/Africa: Rockwell Automation NV, Pegasus Park, De Kleeflaan 12a, 1831 Diegem, Belgium, Tel: (32) 2 663 0600, Fax: (32) 2 663 0640

Asia Pacific: Rockwell Automation, Level 14, Core F, Cyberport 3, 100 Cyberport Road, Hong Kong, Tel: (852) 2887 4788, Fax: (852) 2508 1846

Rockwell Automation Publication LINX-GR001O-EN-E – October 2015

Supersedes Publication LINX-GR001N-EN-E

Copyright © 2015 Rockwell Automation, Inc. All rights reserved. Printed in the U.S.A.