Abstract

CrochetCharts is an application specially designed to allow you to create design charts for crochet patterns. This document will describe the features and abilities of CrochetCharts.
# Table of Contents

Introduction ........................................................................................................ iv  
Additional Resources - Videos ........................................................................ iv
1. Installation ........................................................................................................ 1  
  Windows ........................................................................................................ 1  
  Mac ............................................................................................................... 4  
  Linux ............................................................................................................ 4  
  Licensing Wizard ............................................................................................ 4
2. Quick Guide to Making a Chart ................................................................. 7
3. Adding Charts to a Document ................................................................. 10
4. Tools .............................................................................................................. 12  
  Export .......................................................................................................... 12  
  Add Chart .................................................................................................... 12  
  Stitch Edit ................................................................................................... 12  
  Color Edit ................................................................................................... 12  
  Rotation Edit ............................................................................................... 12  
  Scale Edit .................................................................................................... 12  
  Row Edit ...................................................................................................... 13  
  Indicator Edit ............................................................................................... 14  
  Align and Distribute .................................................................................... 14  
  Mirror and Rotate ....................................................................................... 15  
  Color Selector .............................................................................................. 15  
  Show Chart Center ....................................................................................... 15  
  Show Wedge Lines ...................................................................................... 16  
  Grouping ...................................................................................................... 16
5. Exporting Files .............................................................................................. 17  
  Charts .......................................................................................................... 20  
  Instructions .................................................................................................. 21  
  Legends ....................................................................................................... 21
6. Stitch Library ................................................................................................. 24  
  Creating New Stitch Sets ............................................................................ 24  
  Creating New Stitches ................................................................................. 25  
  Adding Stitches to the Default Stitches list .................................................. 25  
  Importing / Exporting Stitch Sets ............................................................... 26  
  Adding Custom Icons .................................................................................. 27  
  Tips on Creating Icons ................................................................................ 27
7. Options / Preferences ................................................................................... 29  
  Application ................................................................................................... 29  
  Charts .......................................................................................................... 30  
  Legends ....................................................................................................... 31
8. Tools .............................................................................................................. 36  
  Check for Updates ....................................................................................... 36  
  About CrochetCharts .................................................................................. 36
9. Limits on Use of Output .............................................................................. 37
10. Troubleshooting ........................................................................................... 38  
     Bugs ......................................................................................................... 38  
     Features .................................................................................................. 38
Introduction

This is the user guide for CrochetCharts by Stitch Works Software. If you have any questions that are not answered in this document please contact me and let me know so that I can answer your questions and improve this guide.

Additional Resources - Videos

There are videos available on my website that will walk you through using CrochetCharts.
Chapter 1. Installation

Because this software is licensed per user you may install it on multiple computers including any combination of the supported platforms below. To install on multiple platforms you may go to the [downloads page](#) and download the installer for other platforms. You will need your serial number to complete the installation. The serial number can be found in the About dialog. If you need help installing on a second platform please [contact me](#).

Windows

CrochetCharts will run on Microsoft Windows XP, Windows Vista, and Windows 7. To install the software you can download the setup file from the [Stitch Works Software website](#).

To install double click the installer and follow the instructions in the Installation Wizard.

![The intro screen of the installation wizard](#)
Choose the installation path for CrochetCharts

Select the Start Menu folder in which you would like to create the program’s shortcuts. You can also enter a name to create a new folder.

Choose the Start Menu folder for CrochetCharts

Select the Start Menu folder in which you would like to create the program’s shortcuts. You can also enter a name to create a new folder.
Installation

The installer will install the needed files for CrochetCharts

Completing the Crochet Charts Setup Wizard

Crochet Charts has been installed on your computer.
Click Finish to close this wizard.

Finish page for the installation of CrochetCharts
Mac

CrochetCharts will run on Mac OS X version 10.5-10.7 (Leopard, Snow Leopard, Lion). To install the software you can download the setup file from the Stitch Works Software website.

Once the file has been downloaded you can install the software by dragging and dropping CrochetCharts into the Applications folder.

![The Mac installer for CrochetCharts](image)

Linux

For Debian/Ubuntu based distributions you can use the .deb package. If you're having any problems please contact me.

Licensing Wizard

The license wizard allows the user to either register or evaluate this software. To use the software you must agree to the End User License Agreement. To evaluate the software you will need to supply your name, and email address. When you register the software you will need to supply your name, email address and serial number. The serial number should have arrived in an email called "Stitch Works Software - License Information for Order#XXXX".
Installation

The license wizard for CrochetCharts

Introduction

This wizard will walk you through the registration of *Crochet Charts*. This licensing wizard requires you to be connected to the internet.

- Register your copy
- Evaluate this software

The license wizard EULA for CrochetCharts

You must agree to the End User License Agreement before you can use this software.

STITCH WORKS SOFTWARE END USER LICENSE AGREEMENT ("EULA")

BY CLICKING THE "I AGREE" BUTTON, OR BY OTHERWISE CONTINUING TO INSTALL, ACCESS OR USE THIS SOFTWARE, YOU ACKNOWLEDGE THAT YOU UNDERSTAND AND AGREE TO BE BOUND BY THE TERMS OF THIS EULA. IF YOU DO NOT AGREE, YOU MAY NOT CONTINUE TO INSTALL, ACCESS OR USE THE SOFTWARE.

This is an agreement between Licensor (Stitch Works Software) and Licensee, who is being licensed to use the named Software.

The Licensee acknowledges that this is only a limited nonexclusive licence. Licensor is and remains the owner of all titles, rights, and interests in the Software (and any copies thereof) and specifically reserve all rights not expressly granted under this EULA.

The Licensee is granted permission to install the Software on more than one computer system, as long as the Licensee is the only person who will use the software. The Licensee will not make copies of the Software or allow copies of the Software to be made by others, unless:

- I agree to the terms of the license

The license wizard EULA for CrochetCharts
The license wizard registration page for CrochetCharts

Register Your Copy of Crochet Charts™
Please fill in all fields. The Serial Number should use the form XXXX-XXXX-XXXX and it should include the dashes.

<table>
<thead>
<tr>
<th>First Name:</th>
<th>Brian</th>
</tr>
</thead>
<tbody>
<tr>
<td>Last Name:</td>
<td>Milco</td>
</tr>
<tr>
<td>Email:</td>
<td><a href="mailto:support@StitchWorksSoftware.com">support@StitchWorksSoftware.com</a></td>
</tr>
<tr>
<td>Serial Number:</td>
<td>0000-0000-0000</td>
</tr>
</tbody>
</table>

Complete Your Registration
An internet connection is no longer required to run this software. However if you are connected when you start the program it will check for updates.

Thank you for purchasing Crochet Charts, I appreciate your business. If you have any questions please contact me.

Brian Milco
Owner, Stitch Works Software

Thanks for registering or trying CrochetCharts
Chapter 2. Quick Guide to Making a Chart

This chapter will give a very quick overview for creating a new chart. For more details about how to use the features referred to in this quick guide follow the links presented.

This is only a general guide and is not the only way to create charts with CrochetCharts. However the work flow presented here is likely the easiest and fastest way to create a chart. Hopefully you will consider this chapter as a starting point and not an ending point.

Sample chart

(1) Create a new Blank chart.

(2) Add the chart center symbol, in the menu Charts → Show Chart Center

(3) Show the Wedge Lines on the chart using Charts → Show Wedge Lines

(4) Create the top wedge of the chart. For best results make sure your stitches are placed within the Wedge Lines so that they translate to the other three quarters of the chart well.
Quick Guide to Making a Chart

(5) Rotate and scale individual stitches as needed, copy, paste and mirror. Use align and distribute to help with spacing. When scaling if you Ctrl-click (Apple-click) on the stitch it will preserve the ratio of the stitch.

(6) Select the wedge of stitches you have just created, copy, paste and rotate 90°, this will give you the right side of the pattern. Paste and rotate 180° gives you the bottom, and paste and rotate 270° gives you the left.

(7) Add indicators for rows, and/or other features you wish to highlight on the chart. Make any other minor adjustments as desired.

The chart after step 4

The chart after step 7
(8) Connect stitches to create the chart rows.

The chart after step 8

(9) Export the chart and legends to your desired file formats for use in documents, or for publication.
Chapter 3. Adding Charts to a Document

When you first open CrochetCharts you are presented with a blank window with a "New Chart Options" dialog at the top. This dialog gives you quick access to create a new document with a single chart. A document can contain any number of charts. To add more charts simply goto Charts → Add Chart.

The Default Stitch is the stitch used when generating Rows or Rounds. You can set which stitch is used as the default in the Options/Preferences.

The Row Spacing option allows you to specify how much distance should be between the rows, the unit of distance is the height of a chain stitch. For your convenience you can give each chart a title so that you can quickly identify which chart you are working with.

Selecting a Blank chart style will present you with a blank canvas from which you can create a free form pattern. This gives you the flexibility to create charts like you would in most drawing programs except CrochetCharts uses stitches instead of pixels and lines.

If you select a Rows chart style then you will get all the functionality of a Blank chart with the addition that the software will create a grid of stitches as defined by the Rows, Stitches, Row Spacing and Default Stitch. The software will add those stitches to the defined Rows.

If you select a Rounds chart style you will get all the functionality of a Blank chart with the addition that the software will create rounds of stitches starting in the center of the chart and working out, increasing by the number of stitches you select for each additional row. The software will add those stitches to the defined Rows.

The main window showing the New Chart Options dialog

While editing the chart you can change the stitches, colors, positions, rotation, and scale of the stitches, you can add new stitches and rows. You can also add an unlimited number of movable indicators to the
chart that can contain text. You can use the indicators as row number indicators, or to draw attention to other parts of the chart.

The main window showing a basic Rows chart

The main window showing a basic Rounds chart
Chapter 4. Tools

The toolbar in CrochetCharts

The tools on the tool bar are listed below in order from left to right: New Document, Open File, Save File, Export, Add Chart, Undo, Redo, Stitch Edit, Color Edit, Rotation Edit, Scale Edit, Row Edit, Indicator Edit, Align and Distribute Tools, Mirror and Rotate Tools, and Color Selector.

Export

File → Export...

This option allows you to export charts, and legends to different file formats: PDF, SVG, PNG, JPEG, TIFF, BMP. The quality of the exports can be controlled and you can adjust it from web quality to publication quality. See Exporting Files for more information about exporting files.

Add Chart

Charts → Add Chart

Add a new chart to this document. A document can contain any number of charts.

Stitch Edit

Modes → Stitch Edit

This mode allows you to add, edit and move stitches on the chart. For minor adjustments to the positioning of a stitch or selection of stitches you can use the arrow keys.

Color Edit

Modes → Color Edit

This mode allows you to edit the background colors used behind the stitches. If you wish to edit the color of the stitches themselves you can change the primary and secondary colors in the Chart Options/Preferences.

Rotation Edit

Modes → Rotation Edit

In this mode you can edit the angle that the stitch is tilted at. You can rotate the stitch 360° relative to the bottom of the stitch. For minor adjustments to the angle of a stitch or selection of stitches you can use the arrow keys. Right or Down are clock-wise and Left or Up are counter-clockwise.

Scale Edit

Modes → Scale Edit
This mode allows you to scale the size of the stitch height and width independently of each other. If you would like to scale the stitch in a 1:1 ratio you can hold the Ctrl (or Apple) key while you scale it. For minor adjustments to the scale you can use the arrow keys. Up and Right increase the height and width respectively, and Down and Left decrease the scale. If you hold down Ctrl (or Apple) the scale will increase both height and width in relation to each other.

**Row Edit**

**Modes → Row Edit**

The user interface for row edit mode

CrochetCharts allows the user to place stitches anywhere on the chart, because of this flexibility there is no way to automatically decide which row a stitch belongs on. The purpose of this interface is to define which stitches belong on each row, and in what order.

Defining rows provides the following benefits: automatically alternate row colors as defined in the settings, and automatically generate written instructions for the chart.

To create a row select the Row Edit mode icon from the tool bar, or select Modes → Row Edit. The Row Edit interface will open as in the screenshot above.

To create your first row go ahead and select the first stitch of the new row. Without releasing the mouse button click and drag to the next stitch in the row. A red line will connect the mouse to the last stitch in the row. When you connect a new stitch to the row it will for a black line between the new stitch and the previous stitch. The red line will now connect the mouse to the new stitch. Continue to connect all the stitches in the row. Once you are done creating the row release the mouse button, and click on the green plus (+) in the Edit Rows dialog at the bottom of the screen. Your row will not be tracked until you've added it to the list with the green plus (+).
The red minus (-) removes the selected row from the list (it does not remove the stitches from the chart), and the up and down arrows change the order of the rows.

If you release the mouse button while creating a row, or if you come back later and want to add more stitches to a row you can do so. If you are adding stitches to the end of a row just click on the last stitch drag the red line to the next stitches in order. If you want to add stitches into the middle of the row you will have to start from the first stitch of the row.

If you want to add stitches to a row select the row from the Row List, the stitches in the row will be selected and the connections between the stitches will be shown as lines joining the stitches. Select the last stitch that is joined and connect it to the new stitches you wish to add to the row.

If you wish to redraw the entire row select the row from the Row List, click on the canvas, which will un-select all of the stitches in the row. Then select all the stitches you would like in the updated row, in order. Once you've finished selecting the stitches click the "Update Row" button.

Once you have finished editing the rows, you can close the Row Edit dialog by clicking on any of the other edit modes.

### Indicator Edit

#### Modes → Indicator Edit

Indicators can be used as row indicators, or to point out pieces of the chart that need special notes. The indicators on the chart can show the dot and/or text based on the Chart Options/Preferences.

Once you're in the Indicator Edit mode you can click on the chart to add a new indicator. If you've setup the indicators with text you can edit the text by clicking on the selected indicator.

### Align and Distribute

#### Stitches → Show Align and Distribute

The **align and distribute tools**

A set of tools that allows you to align and distribute stitches evenly on the chart.

You can align to left edge, right edge, center on the vertical axis, top edge, bottom edge, center on the horizontal axis.

You can distribute equidistantly on left edges, right edges, from the centers horizontally, or on the top edges, bottom edges, or from the centers vertically.
**Mirror and Rotate**

*Stitches → Show Mirror and Rotate*

![Mirror and Rotate Tools](image)

*The mirror and rotate tools*

A set of tools that allows you to mirror and rotate groups of stitches on the chart.

Mirroring can be done up, down, left, and right. Mirroring is done across vertical or horizontal lines. For example if you mirror left, the left most point of the left most selected stitch is used as the mirroring line. Mirroring will automatically make copies of the stitches that are to be mirrored.

Rotating stitches using this tool will be done from bottom left corner of the group of stitches selected, unless you have a chart center on the chart (*Charts → Show Chart Center*) in which case the selection will be rotated around the center of the chart.

There are 3 buttons that represent 90° (on the right), 180° (on the bottom), 270° (on the left), and a fourth button (on the top) representing a custom option that allows you to select exactly how many degrees you want to rotate the selection.

Rotating operates on the selected stitches, unlike mirroring.

**Color Selector**

Select the color that will be used in Color Edit.

To use the color edit mode, Select *Modes → Color Edit*. In the tool bar click on the white color box, with the tool tip reading "Select a color for the background". This tool will allow you to change the color behind each stitch by clicking on them.

**Show Chart Center**

*Charts → Show Chart Center*

This option allows you to show a circle as the center of the chart. If the center is visible it will be used as the pivot point for the rotation functions of the *Mirror and Rotate tools.*
Show Wedge Lines

Charts → Show Wedge Lines

This option show a vertical and horizontal line and two 45° lines that go through the center point of the chart, or if you have the Center symbol visible they cross at the center of the symbol. These lines are very useful when creating a round chart where you want to start by creating a wedge shape design. If you keep your stitches with in the lines when you go to rotate the selection around the center point you will have a consistent looking repeat.

Grouping

Stitches → Group and Stitches → Ungroup

This option allows you to group and ungroup stitches together. When stitches are grouped they can be moved and changed as one unit.
Chapter 5. Exporting Files

All pieces of your work can be exported to formats that are commonly used on websites, in magazines, and in publication.

You can export to any of the following file formats: PDF, SVG, JPEG, PNG, TIFF, and BMP. The first two formats are vectored graphics which means they will not pixelate when you zoom in or blow up the image. For this reason they are commonly used in magazines and publications. JPEG and PNG are also sometimes accepted by magazines and publications, however if the publisher accepts them they usually want a resolution of 300 DPI. Before sending a file to a publisher you should ask them what file types they will accept.

To export any part of your document as images click on the Export icon in the toolbar or goto File → Export. From this dialog you may choose to export some or all of the charts, the stitch legend or the color legend.

Options window for export as a pdf
Options window for export as a svg
Options window for export as a jpeg, png, tiff, or bmp

The above screenshots show all the possible options for exporting images. Below is an explanation of these options.

**Selection**
This allows you to choose to export the chart, stitch legend, or color legend. Additionally if you export to PDF you can export all charts into one file with each chart on it's own page.

**Resolution**
The quality of the image output. 96 dpi is usually considered standard quality, and 300 dpi is print or publication quality. You should be aware that higher quality means larger file size, and that you should weigh that against your intended use of the file.

**Page to Chart Size**
By default the page size is set for a standard A4 letter page and the chart is scaled to fit onto the page. If the *Page to Chart Size* option is checked then the page size is set to the size of the chart.
Height and Width
Set the dimensions of the image to be generated. You should be aware that higher quality means larger file size, and that you should weigh that against your intended use of the file.

Charts

Options window for export a chart

When you export a chart you are presented with the standard options for all exports. You can choose the resolution, height, width, and page to chart size options depending on the file type you want to export to.
Instructions

The main window highlighting the Copy Instructions button

From the main interface you can export the written instructions for the chart by pressing the Copy Instructions button on the bottom left of the application. This button will add the row numbers, capitalize the first letter, put a period at the end of the row, and generate repeats among other features. You can tell CrochetCharts that you don't want it to generate text repeats in the Chart Options/Preferences, if you'd rather have every stitch written out. This cleaned up version of the written instructions will automatically be copied to the clipboard where you can then paste it directly into another application as plain text.

Legends

CrochetCharts supports output of Stitch Legends, and Color Legends. These legends contain all the stitches or colors (respectively) used on all tabs in the document. The Pattern Stitches and Pattern Colors docks on the main interface give an interactive view of what the legends will contain.
Stitch Legends

Options window for export a Stitch Legend

When you export a stitch legend you are presented with the standard export options at the top of the dialog, and Stitch Legend specific options at the bottom. Those options include showing a title for the legend, showing a border around the legend, showing the stitch descriptions, and specifying the column count for the legend. If you have settings that you prefer and would like to see whenever you use the export dialog you can make them the defaults by setting them in the Legend Options/Preferences.
Color Legends

The main window highlighting the Copy Instructions button

When you export a stitch legend you are presented with the standard export options at the top of the dialog, and Color Legend specific options at the bottom. Those options include showing a title for the legend, showing a border around the legend, showing the hexadecimal value of the color (the standard representation of colors for the internet), user selected prefix for colors, and specifying the column count for the legend. If you have settings that you prefer and would like to see whenever you use the export dialog you can make them the defaults by setting them in the Legend Options/Preferences.
Chapter 6. Stitch Library

The Stitch Library can consist of multiple sets of stitches. Each stitch within a set must have a unique name, however you may have multiple sets that have a stitch with the same name in them. The Default Stitches set contains all the stitches that will appear in the main application for use on charts. You can customize this list however you want. Any stitches not in this list will not show up the Stitches list dock. The library loads the stitches as follows: first it loads the built in stitches, then it loads any additional sets you may have added, and finally it loads any customizations or changes you have made on top of the existing stitches.

The main window of the Stitch Library

To open the Stitch Library goto Tools → Stitch Library. From here you can add and remove Stitches, Stitch Sets and Icons, print the set and reset the library to it's original state.

Creating New Stitch Sets

The prompt for a new Stitch Set

To create a new Stitch Set click on the Add Set button. You will be prompted to enter a set name. Once you have entered a new set name a new list will be loaded in the Stitch Library with a new stitch ready for editing. From this point you can edit the stitch like normal and add more stitches to the set. To use the new stitches on a chart you need to add the stitches to the Default Stitches list.
Creating New Stitches

To create a new stitch click on the **Add Stitch** button and supply a new name for the stitch. You will then be dropped back to the Stitch Library with a new row added containing the name of the new stitch, and a question mark for an icon. To change any of the information about the stitch just click on each section. The Icon and Categories will open a drop down lists that you have to click on again to show you the options. If you want to add icons to the list of selections you can add your own custom icons. If you've added the stitch to a new set and you want to use it to create charts you will need to add the stitch to the Default Stitch list.

Adding Stitches to the Default Stitches list

To use custom stitches to create charts you have to include the stitches in the Default Stitches list. To include your custom stitches check the “Selected” check box next to the stitch or stitches you wish to add and press the **Add To List** button.

The Default Stitches set like any stitch set in CrochetCharts can only have uniquely named stitches. If you try to include a stitch name that is already in the list you will be prompted to either replace the existing stitch, keep the original stitch as is, or stop adding stitches if you are adding more than one stitch.
Importing / Exporting Stitch Sets

If you have a set of stitches that you want to share with your friends, co-workers, or others you can Export the set to a single file. To export the Stitch Set in the Stitch Library click on the Export Set button and you will be prompted to supply a file name. The currently displayed set will be exported into a single stand alone file that other users of CrochetCharts can import and use themselves.

To import a set that someone has given you go into the Stitch Library and click on the Import Set button. You will be prompted to select the file you wish to import. If the name of the set conflicts with a set you already have in the library you will be prompted to give the set a new name, override the existing set, or to stop the import process.
Adding Custom Icons

To add custom icons click on the Manage Icons button in the Stitch Library. This will take you to the Stitch Icon List where you can Add Icons, Remove Icons and Save Icons.

When you add an icon to the Stitch Library the software makes a copy of the icon so that you don't have to worry about moving or deleting the icons you've added. Removing the icon from the list deletes the copy. The Save Icons function allows you to saved a copy of the icon or icons and copy them to a useful location where you can make changes and they save them back into the library later. All of the functions for Managing the icons (Add Icons, Remove Icons, and Save Icons) can be used on groups of icons as well as individual icons.

Tips on Creating Icons

To create icons for CrochetCharts you should use your favorite drawing program to create files in one of the following formats:

**SVG, SVGZ**
Can have a transparent background and scales properly

**PNG**
Can have a transparent background, but does not scale nicely

**GIF**
Can have a transparent background, but does not scale nicely

**JPG, JPEG**
Does not have a transparent background, and does not scale nicely
Transparent backgrounds are useful if you want to place color behind the stitches or if some of the stitches overlap. Proper scaling is good because it means that no matter how much you zoom in on the chart or scale up the stitches they will always look good.

I recommend using the SVG file format when possible. SVG is not as well known a format as the others, but it is becoming an industry standard. Here are a few applications that can generate SVG files if you choose to use it: Inkscape, LibreOffice Draw, OpenOffice Draw, Google Docs, and Adobe Illustrator.

I recommend starting with a canvas size of 32x32 px. If you need to use a different size I recommend changing the size in increments of 16 or 32. So a single crochet is 32x32, a half double crochet is 32x64, and a double crochet is 32x80. Once you have the basic size you can modify it from there as needed.

If you want your stitches to match the default stitches I'm using a stroke width of 4.0 and rounded caps and joints. Also if you want the software to change the color of the stitches for alternate rows then the stitch you create should be black (#000000) any other colors in the stitch will not be modified.

If you use one of the other file types (png, gif) that support transparent background you should be aware that most drawing applications do not turn on transparency by default. You should consult the documentation for your application on the proper way to enable it.
Chapter 7. Options / Preferences

The options have been divided into sections. The first section contains the general application settings. The Charts section contains settings that effect the creation and layout of charts and their written instructions. The Legend section contains the default settings for generating stitch and color legends. Usually, these settings can be overridden at the point at which they are used. For example, if you set default options on the Legends you can change them, temporarily, while you are on the File → Export dialog.

If you change the settings and you are unhappy with them you can always return the application to the default state by clicking the Restore Defaults button.

Application

The application options dialog

Check for Updates on Startup
Every time you start CrochetCharts it will attempt to connect to www.StitchWorksSoftware.com to check for updates. If an update is found you will be prompted to download and install it. Even if this feature is disable you can still check for updates manually by going to Tools → Check for Updates.

File Location
This is the default folder that opens when you go to load or save a file, an icon, or export a document.

Maximum Recent Files
This option allows you to specify how many recent files to list in File → Recent Files.
Options / Preferences

Charts

The chart options dialog

Default Stitch
The default stitch used when creating new Rows and Rounds chart. This option can be overridden when you create a new chart.

Rows
The default number of rows to create on new Rows or Rounds charts.

Stitches
The default number of stitches to create on a new Rows or Rounds chart.

Show Chart Center
Show the chart center symbol (a ring) on Rounds charts.

Style
The default chart style to use when creating a new chart. A Blank chart start with no stitches on the canvas. A Rows chart creates a grid of stitches on the canvas with Row rows and Stitch columns of stitches. A Rounds chart creates rounds of stitches on the canvas the first round contains Stitch stitches and each subsequent row contains an additional 12 stitches.

Alternate row colors
Use the Primary / Alternate colors to draw the stitches in each row.

Row indicator style
Use either a number, a dot, or both to indicate anything you want on the chart. By default the indicator text will contain the current count of indicators on the chart.

Indicator color
The color to use for the indicator dot.

Generate Repeats
If unchecked the software will write out all the stitches individually.
Legends

The legend options dialog

Stitch Legends

When exporting a Stitch Legend any of the options below can be used together to create the stitch legend of your choosing. These values can be overridden in the Export dialog.

An example stitch legend with all options turned on and column count set to 2

Show Title
This will show the title block and the top of the legend.
Options / Preferences

The stitch legend without the title

**Show Border**
Show the border around the entire outside edge of the legend.

**Stitch Legend**

<table>
<thead>
<tr>
<th>dc - double crochet</th>
<th>sc - single crochet</th>
</tr>
</thead>
<tbody>
<tr>
<td>hdc - half double crochet</td>
<td></td>
</tr>
</tbody>
</table>

Border turned off

**Show Description**
Show the stitch descriptions in the legend.

**Stitch Legend**

<table>
<thead>
<tr>
<th>dc</th>
<th>sc</th>
</tr>
</thead>
<tbody>
<tr>
<td>hdc</td>
<td></td>
</tr>
</tbody>
</table>

A legend with the descriptions turned off

**Column Count**
This allows you to specify the number of columns in the legend. The software will try to fit the stitches into the columns evenly.
Options / Preferences

A legend with 3 columns

A legend with 1 column

A legend with all options turned off

Color Legends

An example color legend with all options turned on

Show Title
This will show the title block and the top of the legend.
**Options / Preferences**

**Show Border**
Show the border around the entire outside edge of the legend.

**Show Hex Value**
Show the hexadecimal (hex) value of the color. The hex value is a common standard for communicating colors on the internet.

**Color Prefix**
The color prefix can be no characters or it can be multiple characters.
Options / Preferences

A color legend with no prefix

A color legend with the word Color as a prefix

Column Count
This allows you to specify the number of columns in the legend. The software will try to create even columns.

A color legend with 7 columns

A color legend with all the options turned off
Chapter 8. Tools

Check for Updates

By default the software will silently check for updates every time you start the software. If it finds an update you will be prompted to install the new version. If you do not wish the software to check for update on startup you can disable this feature by going to the Application Options/Preferences and un-check the option for this feature.

The dialog when there are no updates

The dialog when a new version is available for download

About CrochetCharts

The About dialog can be accessed by going to the Help → About CrochetCharts option, or on the Mac by going to CrochetCharts → About CrochetCharts.

This dialog contains the full version string and build date, copyright notice, description, dedication and license information. The license information is required to use the software. The license information was provided to you when you purchased the software, but is presented here for your convenience.
Chapter 9. Limits on Use of Output

There are no limits on what you can do with the charts, or output you create in CrochetCharts. However I would appreciate it if you included a credit in any patterns, or publications where you used this software. For example: Charts created with CrochetCharts by Stitch Works Software.
Chapter 10. Troubleshooting

Bugs

If you find a defect, or unexpected behavior in this software please contact me so I can look into the issue. I take bugs and defects very seriously and the sooner I know about them the sooner I can fix them.

Features

Is the software missing a feature? Do you have an idea that should be included in the software? You should contact me and let me know. I want this software to make creating charts easy for the users and the best way to do that is to have the users give me feedback about what is and isn't working for them.