# Table of Contents

**Chapter 1: Introduction** ............................................................... 1  
  Typical Applications .................................................................. 3  
  What’s in this Guide? ................................................................. 3  
  For Help .................................................................................... 4  

**Chapter 2: Quick Start** ................................................................. 5  
  Check Processor Compatibility .................................................. 5  
  Install the Module .................................................................... 6  
    Bias and Termination (SNAP-SCM-485-422 and SNAP-SCM-PROFI Only) .................................................. 7  
  Attach Serial Devices ................................................................. 7  
    SNAP-SCM-232 .................................................................... 7  
    SNAP-SCM-485-422 .............................................................. 8  
    SNAP-SCM-W2 .................................................................. 9  
    SNAP-SCM-PROFI ............................................................. 9  
    SNAP-SCM-CAN2B ............................................................ 10  
    SNAP-SCM-ST2 .................................................................. 10  
  Apply Power to the Rack ............................................................. 11  
  Configure the Module ............................................................... 11  
    SNAP-SCM-232 and SNAP-SCM-485-422 Configuration ......... 11  
    SNAP-SCM-PROFI Configuration .......................................... 12  
    SNAP-SCM-W2 Configuration ............................................. 12  
    SNAP-SCM-CAN2B Configuration ....................................... 12  
    SNAP-SCM-ST2 Configuration ............................................. 12  
  Establish an Ethernet Connection .............................................. 13  
  Send and Receive Data through the Module. .............................. 14  

**Chapter 3: Module Configuration** .................................................. 15  
  Changing SNAP-SCM-232 and SNAP-SCM-485-422 Communication Parameters ........................................... 15  
  Changing Basic Parameters ...................................................... 15  
  Configuring Flow Control and 2- or 4-Wire Mode .......................... 18  
  Changing SNAP-SCM-PROFI Communication Parameters .......... 20  
  Configuring Wiegand Modules ................................................... 23  
  Sample Strategy ...................................................................... 23
Introduction

This user’s guide includes the following serial communication modules, all designed for use with Opto 22’s SNAP PAC System:

- SNAP-SCM-232
- SNAP-SCM-485-422
- SNAP-SCM-W2
- SNAP-SCM-PROFI
- SNAP-SCM-CAN2B
- SNAP-SCM-ST2

These modules conveniently provide serial data at a remote Ethernet location.
Many industrial applications require digital, analog, and serial data to provide a complete solution. Traditionally, either separate serial network cabling is required for the serial devices, or an expensive data processor or PC must be used just to interface with the serial devices.

The SNAP serial communication modules eliminate this problem by providing high-speed, isolated serial communications packaged in the compact SNAP module form. The SNAP-SCM-232, SNAP-SCM-485-422, SNAP-SCM-W2, and SNAP-SCM-ST2 modules each provides two channels of serial data (one channel for a 4-wire SNAP-SCM-485-422). The SNAP-SCM-PROFI and SNAP-SCM-CAN2B modules each provides one channel.

Using the SNAP serial communication module as a converter, non-Ethernet devices can be connected to an Ethernet network and be available for control, monitoring, or data acquisition by any authorized PC or other device on the Ethernet network.

All SNAP serial communication modules snap into Opto 22 SNAP PAC mounting racks right beside SNAP I/O® digital and analog modules, to provide the mix of analog, digital, and serial channels you need at any location.
Typical Applications

Typical applications for the SNAP-SCM-232 and the SNAP-SCM-485-422 include interfacing with printers, scales, chart recorders, and barcode systems.

- The SNAP-SCM-232 interfaces to auxiliary serial equipment via two RJ-45 plug-in data connectors, providing two RS-232 serial ports. This model also supports optional RTS/CTS flow control.

- The SNAP-SCM-485-422 uses a simple screw-type connector for easy wiring of two 2-wire RS-485 ports or one 4-wire RS-485/422 port.


- The SNAP-SCM-PROFI integrates a PROFIBUS DP* network into your system. It uses a built-in DB-9 connector to provide a standard electrical interface between Ethernet-based Opto 22 SNAP I/O systems and PROFIBUS DP networks. For information on how to integrate an Opto 22 controller with a PROFIBUS DP network, see form 1591, the PROFIBUS DP Master Technical Note.

- The SNAP-SCM-CAN2B provides an interface to a Controller Area Network (CAN) that allows your SNAP PAC system to receive data from CAN devices. Once the module is installed, integration with your system is done using the CAN Integration Kit, part number PAC-INT-CAN, which is a free download from the Product section of our website, www.opto22.com.

- The SNAP-SCM-ST2 provides pulse and direction signals for up to two stepper motors which can be controlled by a SNAP PAC controller running a PAC Control™ strategy.

What’s in this Guide?

This guide assumes that you have some familiarity with Ethernet networking and serial communication. If you are using a SNAP Wiegand module, you should be familiar with the Wiegand interface. If you are using a SNAP PROFIBUS DP module, you should understand the PROFIBUS DP protocol. Commercial resources are available for learning about these subjects. To learn more about the SNAP PAC System, visit the Opto 22 website at www.opto22.com.

This guide includes the following sections:

- Quick Start to get your serial module up and running quickly

- Instructions for changing communication parameters, configuring Wiegand and CAN2B modules, using ST2 commands, loading new firmware, building cables, and more

- Specifications, LEDs, and Module Switches

**NOTE:** This guide does not cover SNAP-SCM-MCH16 or SNAP-SCM-SSI modules. For the SNAP-SCM-MCH16, see form 1673, the SNAP PAC Motion Control User’s Guide. For the SNAP-SCM-SSI, see form 1931, the SNAP SSI (Serial Synchronization Interface) Module User’s Guide.
For Help

If you have problems installing or using SNAP serial communication modules and cannot find help in this guide or on our website, you can contact Opto 22 Product Support.

Phone: 800-TEK-OPTO (800-835-6786) 951-695-3080 (Hours are Monday through Friday, 7 a.m. to 5 p.m. Pacific Time)

Fax: 951-695-3017

Email: support@opto22.com

Opto 22 website: www.opto22.com

When calling for technical support, be prepared to provide the following information about your system to the Product Support engineer:

- Software and version being used
- Controller firmware version (if applicable)
- PC configuration
- A complete description of your hardware, including:
  - IP addresses and net masks for devices on the system
  - type of power supply (brand and model)
  - types of I/O units installed
  - third-party devices installed (for example, barcode readers)
  - jumper configuration, if applicable
  - accessories installed (such as expansion cards)
- Specific error messages seen.

NOTE: Email messages and phone calls to Opto 22 Product Support are grouped together and answered in the order received.
In this chapter:
Check Processor Compatibility.............................................. page 5
Install the Module ..................................................................... page 6
Attach Serial Devices............................................................... page 7
Apply Power to the Rack.......................................................... page 11
Configure the Module.............................................................. page 11
Establish an Ethernet Connection......................................... page 13
Send and Receive Data through the Module ....................... page 14

Check Processor Compatibility

SNAP serial communication modules can be used with any of the following SNAP PAC rack-mounted controllers and brains:

SNAP-PAC-R1       SNAP-PAC-EB1
SNAP-PAC-R1-FM     SNAP-PAC-EB1-FM
SNAP-PAC-R1-W      SNAP-PAC-EB1-W
SNAP-PAC-R2        SNAP-PAC-EB2
SNAP-PAC-R2-FM     SNAP-PAC-EB2-FM
SNAP-PAC-R2-W      SNAP-PAC-EB2-W

These modules cannot be used with SNAP PAC serial-based brains (SNAP-PAC-SB1 and SNAP-PAC-SB2). If you are using an older brain or rack-mounted controller, such as SNAP Ultimate or SNAP Ethernet, see Appendix B, "Using SNAP Serial Modules with Legacy Hardware," to determine compatibility.
Install the Module

SNAP serial communication modules can be installed in any position on an Opto 22 SNAP PAC mounting rack. Do not install more than eight serial communication modules of any type on the same rack.

NOTE: SNAP serial communication modules draw considerably more power than a standard SNAP analog or digital module. The rack can handle a maximum of eight serial modules, plus the processor and up to eight digital or analog modules. See serial module specifications on page 47. Make sure you have sufficient power for the processor and all modules on the rack.

1. Turn off power to the rack.
   WARNING: Make sure power is off before continuing, or you will severely damage the module.

2. Remove the module from its packaging.

3. Position the module over the connector on the rack, aligning the small slot at the base of the module with the retention bar on the rack. If it is next to another module, make sure the male and female module keys are aligned, as shown at right.

4. Push straight down on the module to snap it into position.
   If you need to remove the module, see page 34.
Bias and Termination (SNAP-SCM-485-422 and SNAP-SCM-PROFI Only)

If you are using the SNAP-SCM-485-422 or SNAP-SCM-PROFI, use the small switches on the top of the module to provide bias or termination on the RS-485/422 or PROFIBUS DP network as required. Bias and termination switches are shown in the diagrams at right.

**Termination**

If the port is physically the first or last device on the network, provide termination as follows:

**SNAP-SCM-485-422**—Move the Term switch to ON.

**SNAP-SCM-PROFI**—If you are using an official PROFIBUS cable, termination is provided in the cable; therefore, switch the termination to ON in the cable and move the Term switch to OFF in the SNAP-SCM-PROFI module.

**Bias**

Provide bias at one point on the network by moving both the Pull Up and Pull Down switches to ON.

---

**Attach Serial Devices**

**SNAP-SCM-232**

If you have a SNAP-SCM-232, use the supplied cable and adapters to connect a serial device to each port on the module.

Pinouts for the RJ-45 connectors and DB-9 (male) adapters on the SNAP-SCM-232 are shown below.
NOTE: RTS/CTS is optional; to use this mode, see “Configuring Flow Control and 2- or 4-Wire Mode” on page 18.

**SNAP-SCM-485-422**

If you have a SNAP-SCM-485-422, use the supplied terminal strip to connect serial devices to each port, as shown in the diagrams and tables below. Two-wire mode is the default; to use four-wire mode, see “Configuring Flow Control and 2- or 4-Wire Mode” on page 18.

**NOTE:** Vcc on the SNAP-SCM-485-422 is 5 VDC and is supplied by the module itself. Do not use this voltage to power another device, as it can interfere with normal module operation.

### Two-Wire Mode

<table>
<thead>
<tr>
<th>Pin</th>
<th>Port</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>A</td>
<td>Vcc</td>
</tr>
<tr>
<td>2</td>
<td>A</td>
<td>TX/RX +</td>
</tr>
<tr>
<td>3</td>
<td>A</td>
<td>TX/RX -</td>
</tr>
<tr>
<td>4</td>
<td>A</td>
<td>Sig Gnd</td>
</tr>
<tr>
<td>5</td>
<td>B</td>
<td>Vcc</td>
</tr>
<tr>
<td>6</td>
<td>B</td>
<td>TX/RX +</td>
</tr>
<tr>
<td>7</td>
<td>B</td>
<td>TX/RX -</td>
</tr>
<tr>
<td>8</td>
<td>B</td>
<td>Sig Gnd</td>
</tr>
</tbody>
</table>
SNAP-SCM-W2

If you have a SNAP-SCM-W2, use the supplied terminal strip to connect a Wiegand serial device to each port on the module, as shown in the diagram and table below.

**IMPORTANT:** Some devices such as card readers can use other protocols. Make certain that your device has been correctly configured to use the Wiegand protocol.

<table>
<thead>
<tr>
<th>Pin</th>
<th>Port</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>A</td>
<td>Vcc</td>
</tr>
<tr>
<td>2</td>
<td>A</td>
<td>TX +</td>
</tr>
<tr>
<td>3</td>
<td>A</td>
<td>TX –</td>
</tr>
<tr>
<td>4</td>
<td>A</td>
<td>Sig Gnd</td>
</tr>
<tr>
<td>5</td>
<td>A</td>
<td>Vcc</td>
</tr>
<tr>
<td>6</td>
<td>A</td>
<td>RX +</td>
</tr>
<tr>
<td>7</td>
<td>A</td>
<td>RX –</td>
</tr>
<tr>
<td>8</td>
<td>A</td>
<td>Sig Gnd</td>
</tr>
</tbody>
</table>

SNAP-SCM-W2 Top View

SNAP-SCM-PROFI

Pinouts for the DB-9 connector on the SNAP-SCM-PROFI are shown in the diagram and table below. For information on how to set the communication switches, see "Module Switches—SNAP-SCM-PROFI" on page 55.

<table>
<thead>
<tr>
<th>Pin</th>
<th>Port</th>
<th>Color</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>A</td>
<td>Black</td>
<td>Common</td>
</tr>
<tr>
<td>2</td>
<td>A</td>
<td>White</td>
<td>Data One</td>
</tr>
<tr>
<td>3</td>
<td>A</td>
<td>Green</td>
<td>Data Zero</td>
</tr>
<tr>
<td>4</td>
<td>A</td>
<td>--</td>
<td>Do not use</td>
</tr>
<tr>
<td>5</td>
<td>B</td>
<td>Black</td>
<td>Common</td>
</tr>
<tr>
<td>6</td>
<td>B</td>
<td>White</td>
<td>Data One</td>
</tr>
<tr>
<td>7</td>
<td>B</td>
<td>Green</td>
<td>Data Zero</td>
</tr>
<tr>
<td>8</td>
<td>B</td>
<td>--</td>
<td>Do not use</td>
</tr>
</tbody>
</table>
SNAP-SCM-CAN2B
Pins 1-4 are in parallel to pins 5-8. V+ is not used by the SNAP-SCM-CAN2B module.

SNAP-SCM-ST2
Connect a stepper motor to each port on the module, as shown in the diagram and table below.
Apply Power to the Rack

Power can usually be supplied by an Opto 22 SNAP-PS5 power supply; however, check total power requirements for all modules and the processor.

When you apply power to the rack, the SNAP-SCM-232 and the SNAP-SCM-485-422 respond by blinking their TX LEDs (see diagram above for LED location). Additionally, on the SNAP-SCM-232 and SNAP-SCM-485-422, unless you have changed the default, a test message similar to the following is sent to the attached serial devices:

Opto 22 SNAP-SCM232, Ver 00.01.01.01, Module 7, Port 0, 9600,N,8,1

Configure the Module

SNAP-SCM-232 and SNAP-SCM-485-422 Configuration

Default communication parameters for the SNAP-SCM-232 and SNAP-SCM-485-422 are as follows:

- 1 start bit
- 9600 baud
- No parity
- 8 data bits
- 1 stop bit
- SNAP-SCM-232: No flow control
- SNAP-SCM-485-422: Two-wire mode
If you plan to use the default parameters, configuration is already finished. If you need to change the communication parameters, see page 15.

**SNAP-SCM-PROFI Configuration**

Default communication parameters for the SNAP-SCM-PROFI module are as follows:

- 1 start bit
- 9600 baud
- Even parity
- 8 data bits
- 1 stop bit
- Send a test message when the module is turned on.

If you plan to use the default parameters, configuration is already finished. If you need to change the communication parameters, see page 20. Note that on the SNAP-SCM-PROFI module you can configure only the Baud Rate, Power-up Test Message, and EOM Character List.

**SNAP-SCM-W2 Configuration**

Use PAC Manager to configure SNAP-SCM-W2 serial modules, which involves telling the module what bit pattern you are using to transmit site and badge code data. For detailed configuration instructions see page 23.

**SNAP-SCM-CAN2B Configuration**

The SNAP-SCM-CAN2B module has the following default settings. Use PAC Manager to change the settings as described on page 26.

- IP Port Number: This number is different for each slot.
- Baud Rate: 250000
- Data Masks and Filters: These are all set to 0.

If you plan to use the default parameters, configuration is already finished. Otherwise, see “Configuring CAN Modules” on page 26.

**SNAP-SCM-ST2 Configuration**

Once you have established an Ethernet connection (see below) you are ready to use the ST2’s output commands. For more information, see “Using the SNAP-SCM-ST2 Module Commands” on page 29. No other configuration is necessary.
Establish an Ethernet Connection

An Ethernet connection in the software application is required in order to establish communication with the serial device that is attached to the SNAP serial communication module. In Opto 22’s PAC Control, for example, you would do the following things:

- Use the comm handle in the Open Outgoing Communication command, and follow that with the Communication Open? command. See form 1701, the PAC Control Command Reference. In the legacy software OptoControl™, you would use the command Open Ethernet Session.

To establish an Ethernet connection, you need the IP address of the I/O unit. You also need the IP Port number of the module’s serial port from the following table. Note that SNAP-SCM-PROFI and SNAP-SCM-CAN2B modules have only one port, port A.

(This table shows the default port numbers. You can change them if necessary using PAC Manager. See “Changing SNAP-SCM-232 and SNAP-SCM-485-422 Communication Parameters” on page 15 or “Configuring Wiegand Modules” on page 23.)

<table>
<thead>
<tr>
<th>Module Position</th>
<th>Port</th>
<th>IP Port Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>A</td>
<td>22500</td>
</tr>
<tr>
<td></td>
<td>B</td>
<td>22501</td>
</tr>
<tr>
<td>1</td>
<td>A</td>
<td>22502</td>
</tr>
<tr>
<td></td>
<td>B</td>
<td>22503</td>
</tr>
<tr>
<td>2</td>
<td>A</td>
<td>22504</td>
</tr>
<tr>
<td></td>
<td>B</td>
<td>22505</td>
</tr>
<tr>
<td>3</td>
<td>A</td>
<td>22506</td>
</tr>
<tr>
<td></td>
<td>B</td>
<td>22507</td>
</tr>
<tr>
<td>4</td>
<td>A</td>
<td>22508</td>
</tr>
<tr>
<td></td>
<td>B</td>
<td>22509</td>
</tr>
<tr>
<td>5</td>
<td>A</td>
<td>22510</td>
</tr>
<tr>
<td></td>
<td>B</td>
<td>22511</td>
</tr>
<tr>
<td>6</td>
<td>A</td>
<td>22512</td>
</tr>
<tr>
<td></td>
<td>B</td>
<td>22513</td>
</tr>
<tr>
<td>7</td>
<td>A</td>
<td>22514</td>
</tr>
<tr>
<td></td>
<td>B</td>
<td>22515</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Module Position</th>
<th>Port</th>
<th>IP Port Number</th>
</tr>
</thead>
<tbody>
<tr>
<td>8</td>
<td>A</td>
<td>22516</td>
</tr>
<tr>
<td></td>
<td>B</td>
<td>22517</td>
</tr>
<tr>
<td>9</td>
<td>A</td>
<td>22518</td>
</tr>
<tr>
<td></td>
<td>B</td>
<td>22519</td>
</tr>
<tr>
<td>10</td>
<td>A</td>
<td>22520</td>
</tr>
<tr>
<td></td>
<td>B</td>
<td>22521</td>
</tr>
<tr>
<td>11</td>
<td>A</td>
<td>22522</td>
</tr>
<tr>
<td></td>
<td>B</td>
<td>22523</td>
</tr>
<tr>
<td>12</td>
<td>A</td>
<td>22524</td>
</tr>
<tr>
<td></td>
<td>B</td>
<td>22525</td>
</tr>
<tr>
<td>13</td>
<td>A</td>
<td>22526</td>
</tr>
<tr>
<td></td>
<td>B</td>
<td>22527</td>
</tr>
<tr>
<td>14</td>
<td>A</td>
<td>22528</td>
</tr>
<tr>
<td></td>
<td>B</td>
<td>22529</td>
</tr>
<tr>
<td>15</td>
<td>A</td>
<td>22530</td>
</tr>
<tr>
<td></td>
<td>B</td>
<td>22531</td>
</tr>
</tbody>
</table>

NOTE: If a connection is not established, the serial module buffers incoming characters and saves them until a connection is established. For REVISION A modules (those manufactured in June 2003 or after), the buffer holds 999 characters. For modules prior to REVISION A, the buffer holds 247 characters.
Send and Receive Data through the Module

Once the Ethernet connection is established, you use a normal Ethernet send or recv to send or receive characters over the serial port. In PAC Control, for example, you would use commands such as Transmit String, Transmit Numeric Table, and Receive String Table.
Module Configuration

In this chapter:
Changing SNAP-SCM-232 and SNAP-SCM-485-422 Communication Parameters........ page 15
Changing SNAP-SCM-PROFI Communication Parameters ................................................ page 20
Configuring Wiegand Modules .......................................................................................... page 23
Configuring CAN Modules ................................................................................................ page 26
Using the SNAP-SCM-ST2 Module Commands ................................................................. page 29
Configuring Serial Events and Reactions ......................................................................... page 32

Changing SNAP-SCM-232 and SNAP-SCM-485-422 Communication Parameters

Communication parameters on the SNAP-SCM-232 and SNAP-SCM-485-422 serial modules can be changed using PAC Manager utility software. PAC Manager comes on a CD with all SNAP PAC brains and controllers and is also available for free download from our website, www.opto22.com.

Default configuration parameters for the SNAP-SCM-232 and SNAP-SCM-485-422 are:
- 1 start bit (not configurable)
- 9600 baud
- No parity
- 8 data bits
- 1 stop bit
- Send a test message when the module is turned on.
- SNAP-SCM-232: No flow control
- SNAP-SCM-485-422: 2-wire mode

Changing Basic Parameters

You will need to have a PC with PAC Manager installed on the same Ethernet network as the I/O unit.
CHANGING SNAP-SCM-232 AND SNAP-SCM-485-422 COMMUNICATION PARAMETERS

All parameters listed above except the last two (flow control and 2- or 4-wire mode) can be changed in the I/O unit’s configuration file using the following steps. For flow control and 2- or 4-wire mode, see the steps on page 18.

1. On the PC, choose Start > Programs > Opto 22 > PAC Project > PAC Manager.
2. In the PAC Manager main window, click the Open button or choose File > Open. Navigate to the location of the configuration file and double-click the filename.
3. In the configuration tree, right-click the name of the I/O unit the serial module is on. From the pop-up menu, choose Configure.

The Configure I/O Units dialog box opens.

4. Make sure the correct I/O unit is highlighted. Click the Modules button and choose Serial Modules from the pop-up menu.

5. Click the status cell for the module number and port number whose parameters you want to change. From the pop-up menu, choose Enabled.

The Status changes to Enabled.
6. To change a communication parameter, click the cell you want to change within the highlighted line. Choose from the drop-down list, if there is one, or type the new value in the cell.

EOM Chars: The device can check any one of up to four characters as the end-of-message indicator. EOM checking occurs only when using the serial module port with serial events. Enter up to four characters in hex. Example: 0x0D0A0000 looks for a 13 (hex 0D) or a 10 (hex 0A).

**NOTE:** The start bit is not configurable. To set flow control and 2- or 4-wire mode, see the steps on page 18.

7. When you have finished changing parameters for serial modules, click OK. Then click Close.

8. With the configuration file open, choose Tools > Send Configuration to I/O Unit.

The Send Configuration dialog box appears:

![Send Configuration dialog box](image)

The list on the left shows all the I/O units in this configuration file. When you click a unit, the Address List shows the IP addresses for all I/O units to receive the same configuration.

9. Highlight the I/O unit configuration(s) you want to send.

10. Highlight the IP addresses to receive the I/O unit configuration.

   If you don't highlight any addresses, the configuration will be sent to the entire list.

   **NOTE:** If you highlighted more than one unit configuration, each unit configuration will automatically be sent to all the IP addresses associated with it.

11. If necessary, change the Timeout field.

   The timeout field shows how long, in milliseconds, PAC Manager will try to communicate with the I/O unit before returning a timeout error.

12. To save the configuration file to flash memory as well as to RAM, check Save to Flash. To also restart the unit, check Restart I/O Unit.

   **IMPORTANT:** If you have changed an IP Port number, you must save the change to flash and restart the I/O unit.

13. Click Send.

   The configuration data is sent to the I/O units whose IP addresses you chose.
Configuring Flow Control and 2- or 4-Wire Mode

You can configure flow control on a SNAP-SCM-232 and 2- or 4-wire mode on a SNAP-SCM-485-422 using PAC Manager. However, these configurations cannot be saved to a configuration file. The I/O unit that contains the serial module must be on the same network as your PC, and the configuration is sent directly to the I/O unit.

1. On a PC on the same Ethernet network as the I/O unit, choose Start > Programs > Opto 22 > PAC Project > PAC Manager.

2. In the PAC Manager main window, click the Inspect icon or choose Tools > Inspect.

3. In the Device Name field, type the name or IP address of the I/O unit, or choose it from the drop-down list. Click the Communications button and choose Serial Modules from the menu.
4. Click the Serial Module Number drop-down list and choose the module’s position number on the rack to see the module’s communication parameters.

5. To change a parameter, click its value in the Value column and choose from the drop-down list or enter a new value.

**NOTE:** This is the only way to change hardware flow control for a SNAP-SCM-232 or 2- or 4-wire mode for a SNAP-SCM-485-422. You can also change other parameters in this dialog box if necessary. However, parameters changed in this dialog box are NOT saved to the configuration file.

This example shows how to change Hardware Flow Control on a SNAP-SCM-232:
Changing SNAP-SCM-PROFI Communication Parameters

Communication parameters on the SNAP-SCM-PROFI serial module can be changed using PAC Manager.

Default communication parameters for the SNAP-SCM-PROFI are:

- 1 start bit (not configurable)
- 9600 baud
- Even parity (not configurable)
- 8 data bits (not configurable)
- 1 stop bit (not configurable)
- Send a test message when the module is turned on.

To change parameters, you will need a PC on the same Ethernet network as the I/O unit.

1. On the PC, choose Start > Programs > Opto 22 > PAC Project > PAC Manager.
2. In the PAC Manager main window, click the Open button or choose File > Open. Navigate to the location of the configuration file and double-click the filename.
3. In the configuration tree, right-click the name of the I/O unit the SNAP-SCM-PROFI module is on. From the pop-up menu, choose Configure.

6. When you have finished changing parameters for this module, click Apply. The configuration changes are sent to the I/O unit.
The Configure I/O Units dialog box opens:

4. Make sure the correct I/O unit is highlighted. Click the Modules button and choose Profibus Modules from the pop-up menu.

5. In the Number field, choose the Profibus module's position from the drop-down list. Click to put a check mark in the Used box.

6. To change a communication parameter, click the cell you want to change within the highlighted line. Choose from the drop-down list, if there is one, or type the new value in the cell.

EOM Chars: The device can check any one of up to four characters as the end-of-message indicator. EOM checking occurs only when using the serial module port with serial events. Enter up to four characters in hex. Example: 0x0D0A0000 looks for a 13 (hex 0D) or a 10 (hex 0A).

NOTE: You can configure only IP Port Number, Baud Rate, Power-up Test Message?, and EOM Character List. The other parameters are not configurable.
7. When you have finished changing parameters for the SNAP-SCM-PROFI module, click OK. Configure another module or click Close.

8. With the configuration file open, choose Tools > Send Configuration to I/O Unit. The Send Configuration dialog box appears:

![Send Configuration to Opto 22 Device](image)

The list on the left shows all the I/O units in this configuration file. When you click a unit, the Address List shows the IP addresses for all I/O units to receive the configuration.

9. Highlight the I/O unit configuration(s) you want to send.

10. Highlight the IP addresses to receive the I/O unit configuration.
    If you don’t highlight any addresses, the configuration will be sent to the entire list.

    **NOTE:** If you highlighted more than one unit configuration, each unit configuration will automatically be sent to all the IP addresses associated with it.

11. If necessary, change the Timeout field.
    The timeout field shows how long, in milliseconds, PAC Manager will try to communicate with the I/O unit before returning a timeout error.

12. To save the configuration file to flash memory as well as to RAM, check Save to Flash. To also restart the unit, check Restart I/O Unit.

    **IMPORTANT:** If you have changed an IP Port number, you must save the change to flash and restart the I/O unit.

13. Click Send.
    The configuration data is sent to the I/O units whose IP addresses you chose.
Configuring Wiegand Modules

This section includes step-by-step instructions for telling a SNAP-SCM-W2 what bit pattern you are using to transmit site and badge code data.

Sample Strategy

If you are using the SNAP Wiegand module for card reader access to 16 or fewer doors by 4200 or fewer users, you can download and use the sample control strategy and utility software available on our website at www.opto22.com. (The sample strategy is an ioControl strategy but can be opened in PAC Control.) The strategy configures the modules, processes card reader data, and sends SNMP traps for security monitoring. The utility manages user names and entry permissions.

The sample strategy assumes a 37-bit code with the following format:

\[
\begin{align*}
\text{Bits:} & \quad 1234 \quad 5678 \quad 9012 \quad 3456 \quad 7890 \quad 1234 \quad 5678 \quad 9012 \quad 3456 \quad 7 \\
\text{Code:} & \quad P000 \quad 0000 \quad SSSS \quad SSSS \quad SBBB \quad BBBBB \quad BBBBB \quad BBBBB \quad P \\
\text{Key:} & \quad P = \text{parity bit} \\
& \quad 0 = \text{zero-filled} \\
& \quad S = \text{Site code} \\
& \quad B = \text{Badge code}
\end{align*}
\]

Both samples include source code and can be used as is or modified to fit your application. See Opto 22 form 1366, the Door Access Manager Technical Note, for more information.

If your situation does not match the sample strategy, you can follow the steps below to configure SNAP-SCM-W2 modules. For additional information on configuration, see Opto 22 Form 1704, the PAC Manager User’s Guide, available from our website at www.opto22.com:

Configuring Your Own Modules

IMPORTANT: Some serial devices such as card readers can use other protocols. Make sure your device has been correctly configured to use the Wiegand protocol.

The SNAP-SCM-W2 conforms to the data transmission standards of the Wiegand 26-bit reader interface protocol. However, note the following:

- The first and last few bits of the transmission can optionally be parity bits, but due to the number of possible variations, no parity or CRC checking is done by the SNAP Wiegand module.

- The SNAP Wiegand module can accommodate transmissions from 26 bits to 64 bits. The site code always comes before the badge code and can be a maximum of 32 bits. The badge code immediately follows the site code (regardless of the length of the site code) and can also be a maximum of 32 bits. Parity bits at the beginning and end of the transmission, if used, reduce the total number of possible site and badge code bits.

To configure Wiegand modules, use PAC Manager on a PC on the same network as the I/O unit.

1. On the PC, choose Start > Programs > Opto 22 > PAC Project > PAC Manager.
2. In the PAC Manager main window, click the Open button or choose File > Open. Navigate to the location of the configuration file and double-click the filename.
3. In the configuration tree, right-click the name of the I/O unit the Wiegand module is on. From the pop-up menu, choose Configure.
The Configure I/O Units dialog box opens:

4. Make sure the correct I/O unit is highlighted. Click the Modules button and choose Wiegand Modules from the pop-up menu.
5. In the Number field, choose the Wiegand module's position from the drop-down list. Click to put a check mark in the Used box.

6. If you need to change port numbers, enter the new numbers for each port in the IP Port Number fields.

7. Click the Format/Value cell, and from the drop-down list, choose a standard data format (shown by its total data length) or choose C for custom.

   **NOTE:** O is the 37-bit Opto 22 format used in the sample control strategy.

8. Change the following fields if necessary to match your Wiegand hardware device:
   - Data Length—total length of data in the transmission
   - Site Position—first bit of the site code
   - Site Length—length of the site code, in bits
   - Badge Position—first bit of the badge code (should be the next bit after the site code)
   - Badge Length—length of the badge code, in bits

9. When data for both ports is correct, repeat from step 5 for additional Wiegand modules.

10. When all Wiegand modules are configured, click OK. Close the Configure I/O units dialog box.

11. In the main PAC Manager window, choose Tools > Send Configuration to I/O Unit.
    The Send Configuration dialog box appears:

```
Send Configuration to Opto 22 Device

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Port</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>2001</td>
</tr>
</tbody>
</table>

Address List

10.192.95.69

Send
Clear Flash
Close
Help

Save to Flash
Restart Device

Timeout (ms): 10000
```

The list on the left shows all the I/O units in this configuration file. When you click a unit, the Address List shows the IP addresses for all I/O units to receive the configuration.

12. Highlight the I/O unit configuration(s) you want to send.

13. Highlight the IP addresses to receive the I/O unit configuration.
    If you don't highlight any addresses, the configuration will be sent to the entire list.

   **NOTE:** If you highlighted more than one unit configuration, each unit configuration will automatically be sent to all the IP addresses associated with it.

14. If necessary, change the Timeout field.
    The timeout field shows how long, in milliseconds, PAC Manager will try to communicate with the I/O unit before returning a timeout error.

15. To save the configuration file to flash memory as well as to RAM, check Save to Flash. To also restart the unit, check Restart I/O Unit.
16. Click Send.

The configuration data is sent to the I/O units whose IP addresses you chose.

Configuring CAN Modules

Configuration for the SNAP-SCM-CAN2B module is normally done in a PAC Control strategy using the example charts from the CAN Integration Kit for PAC Project, part number PAC-INT-CAN, a free download available on our website, www.opto22.com. As described below, you can also use PAC Manager to change the IP Port Number, Baud Rate, Data Masks, or Filters for the SNAP-SCM-CAN2B serial module. However, the settings in your strategy will override the settings in PAC Manager for each module.

1. Using a PC on the same Ethernet network as the I/O unit, choose Start > Programs > Opto 22 > PAC Project > PAC Manager.

2. In the PAC Manager main window, click the Inspect icon or choose Tools > Inspect.

3. In the Device Name field, type in the name or IP address of the I/O unit, or choose it from the drop-down list.

4. Click the Communications button and choose CAN Modules from the pop-up menu. Information from the I/O unit is displayed in the window.
5. Click the CAN Module number drop-down list and choose the module's position number on the rack to see the module's communication parameters.

6. To change a parameter, click its value in the Value column.
   To change the Baud Rate on a SNAP-SCM-CAN2, choose from the drop-down list.
   To change the Filter or Data Mask values, see the next section below.

7. When you have finished changing parameters for this module, click Apply.
   The configuration changes are sent to the I/O unit. In the next steps you will store the configuration to flash memory.

8. Click Status Write.
9. In the Operation Command list at the bottom of the window, highlight Store configuration to flash.

Note that this command saves to flash the things you can configure in PAC Manager. It does not affect a PAC Control strategy, which is saved to flash via PAC Control or PAC Terminal.

**CAUTION:** If you are using PAC Manager 9.0 or newer, firmware 9.0 or newer, and loader version 6.0 or newer, and if a controller has a microSD card installed and the card already contains configuration data, that data will be overwritten. See the controller user’s guide for complete information about microSD.

10. Click Send Command.

The configuration data is stored to flash memory and a Success message appears.

**SNAP-SCM-CAN2B Filters and Data Masks**

The filters and data masks for each CAN2B module are normally configured in a PAC Control strategy using the example charts provided in the CAN Integration Kit for PAC Project, part number PAC-INT-CAN. You can also use PAC Manager to configure these settings. However, the filter and data mask settings in your PAC Control strategy will override the settings in PAC Manager for each module.

In PAC Manager the Data Masks and Filters are all set to 0 by default, which means that all CAN packets will be received. If you want the SNAP-SCM-CAN2B module to provide filtering, then you’ll have to configure the Data Masks and Filters. Always start with the highest priority mask and filter, Data Mask 0 and Filter 0.

The memory map addresses for module slot 0 are 0xF03A9008, 0xF03A900C, 0xF03A9010, 0xF03A9014, 0xF03A9018, 0xF03A901C, 0xF03A9020, and 0xF03A9024.
Use the following table to determine how CAN packets are accepted or rejected. For example, if you want to receive CAN ID 0x00FF0500 and only care about the part in bold, then set your Mask to 0x00FFFF00 and your Filter to 0x00FF0500.

<table>
<thead>
<tr>
<th>Data Mask Bit</th>
<th>Filter Bit</th>
<th>CAN ID Bit</th>
<th>Accept/Reject</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>X*</td>
<td>X*</td>
<td>Accept</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>0</td>
<td>Accept</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
<td>1</td>
<td>Reject</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>0</td>
<td>Reject</td>
</tr>
<tr>
<td>1</td>
<td>1</td>
<td>1</td>
<td>Accept</td>
</tr>
</tbody>
</table>

* X = Don't Care

In the following examples, the bits we care about are determined by the Data Mask.

**Packet Accepted Example.**
This packet is accepted because the Filter bits match the CAN Packet bits.

Data Mask = 0000 0000 1111 1111 1111 1111 0000 0000

Filter = XXXX XXXX 1111 1111 0000 0101 XXXX XXXX

CAN Packet = XXXX XXXX 1111 1111 0001 0111 XXXX XXXX

**Packet Rejected Example.**
This packet is rejected because the Filter bits do not match the CAN Packet bits.

Data Mask = 0000 0000 1111 1111 1111 1111 0000 0000

Filter = XXXX XXXX 1111 1111 0000 0101 XXXX XXXX

CAN Packet = XXXX XXXX 1111 1111 0001 0111 XXXX XXXX

### Using the SNAP-SCM-ST2 Module Commands

In order to use the commands for this module, first you need to establish an Ethernet connection in the software application that communicates with the serial device attached to the ST2 module. For instructions, first see "Establish an Ethernet Connection" on page 13.

The SNAP-SCM-ST2 module supports the following pulse output commands in PAC Control:

- **SetPulseFrequency** outputs a set frequency until instructed to do otherwise.
- **SetPulseSequence** ramps from one frequency to another.
- **ReadPulseFrequency** returns a string representing a channel's current frequency.

These commands are not part of the PAC Control command set. Rather, they are entered in a PAC Control strategy as parameters in a Transmit/Receive String command (or OptoScript TransmitReceiveString command).
The Transmit/Receive String command sends the pulse output command to the processor and then waits for a response. For more information on the Transmit/Receive String command, see the PAC Control Command Reference, form 1701.

Command examples shown below are in OptoScript, but you can accomplish the same thing with the standard command. Syntax for the OptoScript TransmitReceiveString command is:

```
TransmitReceiveString(String, Communication Handle, Put Result in)
```

ReadPulseFrequency

NOTE: This command requires SNAP-SCM-ST2 module firmware version R1.0d or newer, which is available as a download file on the Opto 22 website. For installation instructions, see form 1704, the PAC Manager User’s Guide.

If successful, this command returns a string representing a channel’s current frequency. If the command fails, it returns 00 (0x3030).

The command has no parameters.

The returned frequency always shows four decimal places, and the sign reflects the channel’s current direction. The string is terminated with an end-of-message character.

Examples of returned strings:

- 5000.0000
- 12.3456
- 0.0000
- –1.4290

**Example**

This example places the current frequency for `comSCMStPort1` into the `chan1Frequency` string variable:

```plaintext
nStatus = TransmitReceiveString(">ReadPulseFrequency()");
```

SetPulseFrequency

Outputs a set frequency until instructed otherwise.

The Frequency parameter indicates in hertz (Hz) the desired output frequency.

If Frequency is positive, then the module will assert the Direction pin. If Frequency is negative, then it will deassert the Direction pin. See "SNAP-SCM-ST2" on page 10 for descriptions of the Direction output pins.

**Example 1**

This OptoScript example outputs 50 kHz, 50% duty cycle, direction pin asserted. The result is placed in `sReturn`.

```plaintext
nStatus = TransmitReceiveString(">SetPulseFrequency(50000)");
```

**NOTE:** The `>` in the string is required to parse the serial data sent to the module.
Example 2
This example stops pulsing on the channel. The result is placed in sReturn\(^1\).

\[
n\text{Status} = \text{TransmitReceiveString}("\text{SetPulseFrequency(0)}", \text{comScmStPort1, sReturn});
\]

Example 3
This example outputs 30 kHz, 50% duty cycle, direction pin deasserted. The result is placed in sReturn\(^1\).

\[
n\text{Status} = \text{TransmitReceiveString}("\text{SetPulseFrequency(-30000)}", \text{comScmStPort1, sReturn});
\]

1 Return string. If the command succeeds, it returns a string equal to an ASCII value of 01 (3031 hex). If the command fails, it returns 00 (3030 hex). No change occurs if it fails. Strings are terminated with an End-Of-Message (EOM) character.
The default EOM character is a Carriage Return, 0xD. To change it, write to memory map address 0xF03A8200 for Module 0 Channel 0, 0xF03A8210 for Module 0 Channel 1, 0xF03A8220 for Module 1 Channel 0, etc. Only the most significant byte is used, bits 24 through 31. Also change this byte with the Set End-Of-Message Terminator in PAC Control.

SetPulseSequence
Ramps from one frequency to another. Once the Stop Frequency is reached, it continues to output the Stop Frequency until told otherwise.

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Units</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Frequency</td>
<td>Hz</td>
<td>The initial frequency. Must be nonzero.</td>
</tr>
<tr>
<td>Stop Frequency</td>
<td>Hz</td>
<td>The frequency you want to ramp to. May be zero.</td>
</tr>
<tr>
<td>Delta Frequency</td>
<td>Hz</td>
<td>Frequency increments/decrements based on the Time Slice. Must be non-zero.</td>
</tr>
<tr>
<td>Time Slice</td>
<td>ms</td>
<td>How often the Delta Frequency is applied to the current frequency. The maximum value is 42,949,672.</td>
</tr>
</tbody>
</table>

a. If the Start Frequency and Stop Frequency are positive, the module will assert the Direction pin during the pulse sequence. If the Start and Stop Frequency are negative, it will deassert the Direction pin.
b. Start Frequency and Stop Frequency cannot have opposite signs (for example, you cannot ramp from –3000 to 1000 Hz).
c. If Time Slice is less than one half the period of the current frequency, then the Delta Frequency is boosted proportionately.
Example: Current frequency = 100 Hz, Time Slice = 1 ms, and Delta Frequency = 10 Hz.
You would expect the frequency to increase/decrease 10 Hz every 1 ms. But since the frequency can only change as fast as one half the period (see note c) it won’t update for at least 5 ms. At this time it will temporarily boost the Delta Frequency 5x, or increase the current frequency from 100 Hz to 150 Hz to make up for the missed Time Slices.
d. Frequency can only change as fast as one half the period. In other words, at least one pulse must be executed before changing the frequency.
Example: If the current frequency is 100 Hz, then the period is 1 ÷ 100 Hz = 0.01 s = 10 ms.
The pulse width is equal to half the period (5 ms in this example). So the frequency stays at 100 Hz for 5 ms minimum before changing. If Time Slice is less than half the period, see note b.
Example 1
This example ramps from 1 kHz to 25 kHz, 50% duty cycle, in 100 Hz steps every 10 milliseconds. Direction pin is asserted. Result is placed in sReturn.

\[
\text{nStatus = TransmitReceiveString(">SetPulseSequence(1000, 25000, 100, 10)", comScmStPort1, sReturn);}\]

Example 2
This example ramps from 1 kHz to 25 kHz, 50% duty cycle, in 100 Hz steps every 10 milliseconds. Direction pin is deasserted. The result is placed in sReturn.

\[
\text{nStatus = TransmitReceiveString(">SetPulseSequence(-1000, -25000, 100, 10)", comScmStPort1, sReturn);}\]

Example 3
NOTE: If you use "current" as the Start Frequency parameter, the module ramps to the stop frequency from its current frequency.

This example ramps from the channel's current frequency to 25 kHz, 50% duty cycle, in 1 Hz steps every 1 ms. Direction pin is asserted. The result is placed in sReturn.

\[
\text{nStatus = TransmitReceiveString(">SetPulseSequence(current, 25000, 1, 1)", comScmStPort1, sReturn);}\]

1 Return string. If the command succeeds, it returns a string equal to an ASCII value of 01 (3031 hex). If the command fails, it returns 00 (3030 hex). No change occurs if it fails. Strings are terminated with an End-Of-Message (EOM) character. The default EOM character is a Carriage Return, 0x0D. To change it, write to memory map address 0xF03A8200 for Module 0 Channel 0, 0xF03A8210 for Module 0 Channel 1, 0xF03A8220 for Module 1 Channel 0, etc. Only the most significant byte is used, bits 24 through 31. Also change this byte with the Set End-Of-Message Terminator in PAC Control.

Configuring Serial Events and Reactions
Data transmitted through a serial module can be used in any of the ways supported by the processor's multiple methods of communication. If you are using PAC Control, use logic in the PAC Control strategy to read and write serial data. See the PAC Control User's Guide (form 1700) for more information.

If you are not using PAC Control, you can use PAC Manager to trigger reactions in response to a specific string received through a serial module. The string transmitted through the module is the event; the reaction in response to that event may include sending an SNMP trap, sending an email message, or turning bits on or off in the processor's Scratch Pad. To configure events and reactions, see the chapter “Setting Up Events and Reactions” in the PAC Manager User's Guide, form 1704.
In this chapter:

Loading New Firmware .................................................................................................................... page 33
Removing a Serial Module ................................................................................................................ page 34
Building a Three-Wire Cable for SNAP-SCM-232 ....................................................................... page 34
Using the SNAP-SCM-232 or SNAP-SCM-485-422 as a Windows COM Port .................... page 34

Loading New Firmware

All SNAP Ethernet-based processors and SNAP serial communication modules contain firmware. Each device is shipped from the factory with the latest firmware installed.

If you need to load new firmware, see form 1704, the PAC Manager User’s Guide, for instructions.
Removing a Serial Module

To remove a serial module, use the SNAP module tool that came with the module.

1. Turn off power to the rack.

   **WARNING:** Make sure power is off before continuing, or you will severely damage the module.

2. Holding the SNAP module tool as shown in the illustration at right, insert it into the notch at the base of the module.

   **NOTE:** If you are facing the rack with the processor on the left side, the notch is on the back of the module.

3. Squeeze the module tool against the module to open the release latch, and pull straight up on the module to remove it.

Building a Three-Wire Cable for SNAP-SCM-232

Two short, unshielded twisted-pair cables and two RJ45 to DB-9 (male) adapters are included with the SNAP-SCM-232 for easy connection to all types of RS-232 devices. If you need to build a three-wire cable to run from the PC to a serial module, use the table at right as a guide.

See the diagram on page 53 for pin locations.

<table>
<thead>
<tr>
<th>RJ-45 pin number (on serial module)</th>
<th>Female DB-9 pin number (on PC)</th>
</tr>
</thead>
<tbody>
<tr>
<td>2 (RX)</td>
<td>3 (TX)</td>
</tr>
<tr>
<td>3 (TX)</td>
<td>2 (RX)</td>
</tr>
<tr>
<td>5 (GND)</td>
<td>5 (GND)</td>
</tr>
</tbody>
</table>

Using the SNAP-SCM-232 or SNAP-SCM-485-422 as a Windows COM Port

For data collection from remote serial devices, where it is impossible or impractical to run serial cables, you can use a third-party software driver to redirect virtual Windows COM ports through the SNAP-SCM-232 or SNAP-SCM-485-422 module. In this way you can connect an existing Windows application that understands only serial communication to a remote SNAP Ethernet-based I/O unit attached to serial devices such as barcode readers, intelligent transducers, point-of-sale (POS) equipment, serial display devices, scanners, and weather monitoring equipment.
The COM port redirect expands the range of your serial application because it eliminates the necessity of a serial link between the PC and the serial device. The normal direct connection from the PC application to a serial device is shown in the following diagram:

With redirection, the direct serial connection is not necessary. Serial devices can talk through a SNAP serial communication module to the PC application over a local area network or over the Internet using TCP/IP, as shown in the diagram below:

The third-party software driver you can use for redirection is a product of Tactical Software, LLC and is available from their website at www.tacticalsoftware.com.

CAUTION: The serial port redirector captures Windows COM port data and routes it through a TCP/IP socket to the SNAP serial module. The overhead associated with redirection and network transport time may cause serial data to be intermittently transmitted. Data protocols relying on character timing transmission intervals are not recommended for redirection applications.

Also note that serial port handshaking signals, such as RTS and CTS, are not redirected. Some binary data protocols may not correctly function; check with the manufacturer.

Requirements

- Opto 22 SNAP Ethernet-based processor

NOTE: A wireless SNAP Ethernet brain can be used, but you may find that bandwidth and response times are not sufficient for your application.
USING THE SNAP-SCM-232 OR SNAP-SCM-485-422 AS A WINDOWS COM PORT

• Opto 22 SNAP-SCM-232 or SNAP-SCM-485-422 serial communication module(s), on a SNAP rack attached to the processor
• Tactical Software's Serial/IP™ COM port redirector (from www.tacticalsoftware.com)
• Opto 22 PAC Manager (included on the CD that came with the processor, or available from our website at www.opto22.com.

Configuring SNAP Serial Modules

Following directions in “Changing SNAP-SCM-232 and SNAP-SCM-485-422 Communication Parameters” on page 15, use PAC Manager to change serial module configuration as follows:

• Set Baud, Parity, Data Bits, and Stop Bits as required by the serial device you are communicating with.
• Set the EOM Char List to zeroes to allow data to pass through.
• Set Power-Up Test Message to NO, so that unwanted characters will not be sent to the Windows COM port application.

Installing Software

Read and follow Tactical Software's Serial/IP documentation to install the Windows serial port redirector.

Configuring Redirected COM Ports

When you install the driver, the Select Ports dialog box appears:

1. Check the box for each COM port you wish to redirect. Then click OK.
The COM ports you checked appear in the next dialog box:

![Configuration window with COM ports]

2. For each COM port, do the following:
   a. Click the COM port to highlight it.
   b. In the IP Address of Server field, enter the IP address of the SNAP Ethernet-based I/O unit this COM port will communicate with.
   c. In the Port Number field, enter the port number on the serial communication module where the device is connected (see the list of port numbers on page 13).
   d. In the Connection Protocol area, click Raw TCP Connection.
   e. Under COM Port Options, click Restore Failed Connections to make sure that the serial redirector will try to restore communication with the I/O unit if the I/O unit is reset or loses power. The DTR and DSR boxes can remain checked.
When you have finished, the dialog box will look something like this:

3. Click the Configuration Wizard button.
4. In the Configuration Wizard dialog box, press the Start button in the lower-left corner to test the connection.

Messages similar to the following appear in the Status and Log areas of the wizard:

```
The driver is ready to use. You can close the window, as the driver runs in the background.
Consult the Serial/IP user's guide for additional information and troubleshooting.
```

The driver is ready to use. You can close the window, as the driver runs in the background.
Consult the Serial/IP user’s guide for additional information and troubleshooting.
If you are having trouble establishing an Ethernet connection or sending and receiving data to a SNAP-SCM-232, you may want to test the module without using an application such as PAC Control. The following steps use the Microsoft Windows® applications Telnet and HyperTerminal to talk to each other through the serial module.

1. Make sure you have not changed the serial module’s default of sending a powerup test message. (See page 15.) Leave power to the SNAP Ethernet-based I/O unit turned off, so that HyperTerminal can capture the test message.

2. Plug the module’s serial port into a PC serial port using a three-wire cable.
   If you need to build the cable, see page 34.

3. Start HyperTerminal (Start > Programs > Accessories > HyperTerminal) and open the serial port using the module’s default settings: 9600 baud, no parity, 8 data bits, 1 stop bit, and no handshaking.

4. Turn on the I/O unit. Watch the TX LEDs on the serial module.
   The TX LEDs blink in the following pattern: three quick blinks to indicate power; then two blinks to indicate a connection to the processor; and finally a single blink to indicate transmittal of a test message like the following:
   Opto 22 SNAP-SCM232, Ver 00.01.01.01, Module 7, Port 0, 9600,N,8,1
   NOTE: The final single blink that indicates test message transmittal may be turned off. You can enable or disable it using the Configure Serial Module dialog box in PAC Manager.

5. From the Start menu, open a command prompt. Establish a Telnet connection to the port, using the IP address of the I/O unit and the IP port number of the serial port on the module.
   For example, type `Telnet 10.192.55.62 22500` to establish a connection to serial port 22500 (port 0 of the serial module in position zero) on an I/O unit with the IP address 10.192.55.62. See the table on page 13 for other port numbers.

6. Type anything in HyperTerminal.
   The characters should be transmitted through the serial port and appear on Telnet.

7. Type characters in Telnet.
   They are transmitted through the serial port and should appear on HyperTerminal.

If you continue to have trouble communicating with the module, contact Opto 22 Product Support. See page 4 for contact information.
In this appendix:
Overview ............................................................. page 43
Checking the Firmware Version ............... page 44

Overview

Some SNAP serial communication modules can also be used with the following legacy I/O processors on M-series or B-series mounting racks. Make certain you have the correct rack for the processor you are using (see the processor’s user guide for information).

SNAP Ethernet:       SNAP-B3000-ENET
                     SNAP-ENET-RTC

SNAP Simple:          SNAP-ENET-S64

SNAP Ultimate:        SNAP-UP1-ADS
                     SNAP-UP1-M64

Minimum firmware for current and legacy processors is shown in the following table. Firmware must be the version shown or newer in order to work with the module described.

<table>
<thead>
<tr>
<th>Module</th>
<th>Minimum Processor Firmware</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>SNAP PAC R</td>
</tr>
<tr>
<td>SNAP-SCM-232 (No flow control)</td>
<td>All</td>
</tr>
<tr>
<td>SNAP-SCM-232 (With flow control)</td>
<td>All</td>
</tr>
<tr>
<td>SNAP-SCM-485 or SNAP-SCM-485-422 (2-wire RS-485)</td>
<td>All</td>
</tr>
</tbody>
</table>
Checking the Firmware Version

If you need to check the processor’s firmware version, follow these steps. You’ll need to have PAC Manager installed on your computer. PAC Manager is located on the CD that came with the processor and is also available for free download from our website at www.opto22.com.

1. On a PC on the same Ethernet network as the processor, choose Start > Programs > Opto 22 > PAC Project > PAC Manager.

2. In the PAC Manager main window, click the Inspect icon or choose Tools > Inspect.

3. In the Device Name field, type in the IP address of the I/O unit. Click the Status Read button at the top left side of the Inspect window.

<table>
<thead>
<tr>
<th>Module</th>
<th>Minimum Processor Firmware</th>
</tr>
</thead>
<tbody>
<tr>
<td>SNAP-SCM-485-422 (4-wire RS-485/422)</td>
<td>SNAP PAC R All, SNAP PAC EB All, SNAP Ethernet R5.0a, SNAP Simple All, SNAP Ultimate R5.0a</td>
</tr>
<tr>
<td>SNAP-SCM-W2</td>
<td>SNAP Ethernet R3.0k (3.0.2.10), SNAP Simple All, SNAP Ultimate R1.0 (1.0.2.B)</td>
</tr>
<tr>
<td>SNAP-SCM-PROFI</td>
<td>SNAP Ethernet R6.1c, SNAP Simple R6.1c, SNAP Ultimate R6.1c</td>
</tr>
<tr>
<td>SNAP-SCM-CAN2B</td>
<td>Not supported</td>
</tr>
<tr>
<td>SNAP-SCM-ST2</td>
<td>9.2a, Not supported</td>
</tr>
</tbody>
</table>
The status information from the I/O unit is displayed in the window:

4. Find the value for Firmware revision (in the example above, R5.1g) and compare it to the required firmware version number in the table on page 43. If the version number is older than the minimum processor firmware shown, follow instructions in the processor’s user guide to download new firmware.
Specifications, LEDs, and Module Switches

In this appendix:
Specifications ............................................................. page 48
LED Indicators ............................................................. page 53
Module Switches ........................................................... page 55
## Specifications

### SNAP-SCM-232 and SNAP-SCM-485-422 Specifications

<table>
<thead>
<tr>
<th>Specification</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Baud rates</td>
<td>300–115,200*</td>
</tr>
<tr>
<td>Channel-to-channel isolation</td>
<td>750 V&lt;sub&gt;RMS&lt;/sub&gt;</td>
</tr>
<tr>
<td>Logic supply voltage</td>
<td>5.0 VDC</td>
</tr>
<tr>
<td>Logic supply current</td>
<td>250 mA DC</td>
</tr>
<tr>
<td>Number of ports per module</td>
<td>2 (1 if SNAP-SCM-485-422 in 4-wire mode)</td>
</tr>
<tr>
<td>Max. number of modules per rack**</td>
<td>8</td>
</tr>
<tr>
<td>Maximum cable length, point-to-point</td>
<td>50 feet</td>
</tr>
<tr>
<td>(SNAP-SCM-232)</td>
<td></td>
</tr>
<tr>
<td>Maximum cable length, multidrop</td>
<td>1,000 feet at 115,200 Kbd</td>
</tr>
<tr>
<td>(SNAP-SCM-485-422)</td>
<td></td>
</tr>
<tr>
<td>Processor compatibility</td>
<td>SNAP PAC R-series controllers and SNAP PAC EB brains, both standard wired and Wired+Wireless models. Also SNAP-B3000-ENET, SNAP-ENET-RTC, SNAP-ENET-S64, SNAP-UP1-ADS, and SNAP-UP1-M64.</td>
</tr>
<tr>
<td>Operating temperature</td>
<td>0 to 70 °C</td>
</tr>
<tr>
<td>Storage temperature</td>
<td>-30 to 85 °C</td>
</tr>
<tr>
<td>Torque, hold-down screws</td>
<td>4 in-lb (0.45 N-m)</td>
</tr>
<tr>
<td>Torque, connector screws</td>
<td>5.26 in-lb (0.6 N-m)</td>
</tr>
<tr>
<td>Agency Approvals</td>
<td>CE, FM, RoHS, DFARS</td>
</tr>
<tr>
<td>Warranty</td>
<td>30 months</td>
</tr>
</tbody>
</table>

* Module performance is limited by the number of serial modules on the SNAP rack. Each rack backplane provides approximately 2.5 Mbps of bandwidth.  
** Maximum number of modules per rack assumes an Opto 22 SNAP power supply and SNAP rack.
## SNAP-SCM-PROFI Specifications

<table>
<thead>
<tr>
<th>Specification</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>Baud rates</td>
<td>9600 to 1.5 MBaud*</td>
</tr>
<tr>
<td>Channel-to-channel isolation</td>
<td>750 Vrms</td>
</tr>
<tr>
<td>Logic supply voltage</td>
<td>5.0 VDC</td>
</tr>
<tr>
<td>Logic supply current</td>
<td>250 mA</td>
</tr>
<tr>
<td>Number of ports per module</td>
<td>1</td>
</tr>
<tr>
<td>Maximum number of modules per rack</td>
<td>8</td>
</tr>
<tr>
<td>Processor compatibility</td>
<td>SNAP PAC R-series controllers and SNAP PAC EB brains, both standard wired and Wired+Wireless models. Also SNAP-B3000-ENET, SNAP-ENET-RTC, SNAP-ENET-S64, SNAP-UP1-ADS, and SNAP-UP1-M64.</td>
</tr>
<tr>
<td>Processor firmware</td>
<td>Firmware 6.1c or newer required</td>
</tr>
<tr>
<td>Operating temperature</td>
<td>0 to 70 °C</td>
</tr>
<tr>
<td>Storage temperature</td>
<td>-30 to 85 °C</td>
</tr>
<tr>
<td>Torque, hold-down screws</td>
<td>4 in-lb (0.45 N-m)</td>
</tr>
<tr>
<td>Torque, connector screws</td>
<td>5.26 in-lb (0.6 N-m)</td>
</tr>
<tr>
<td>Agency Approvals</td>
<td>CE, RoHS, DFARS</td>
</tr>
<tr>
<td>Warranty</td>
<td>30 months</td>
</tr>
</tbody>
</table>

* Module performance is limited by the number of serial modules on the SNAP rack. Each rack backplane provides approximately 2.5 Mbps of bandwidth.

** With Opto 22 SNAP power supply and SNAP rack
### SNAP-SCM-W2 Specifications

<table>
<thead>
<tr>
<th>Specification</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Channel-to-channel isolation</td>
<td>250 Vrms</td>
</tr>
<tr>
<td>Logic supply voltage</td>
<td>5.0 VDC (± 0.15)</td>
</tr>
<tr>
<td>Logic supply current</td>
<td>250 mA</td>
</tr>
<tr>
<td>Number of ports per module</td>
<td>2</td>
</tr>
<tr>
<td>Maximum number of modules per rack*</td>
<td>8</td>
</tr>
<tr>
<td>Maximum cable length</td>
<td>See table below</td>
</tr>
<tr>
<td>Processor compatibility</td>
<td>SNAP PAC R-series controllers and SNAP PAC EB brains, both standard wired and Wired+Wireless models. Also SNAP-B3000-ENET, SNAP-ENET-RTC, SNAP-ENET-S64, SNAP-UP1-ADS, and SNAP-UP1-M64.</td>
</tr>
<tr>
<td>Operating Temperature</td>
<td>0 to 70 °C operating</td>
</tr>
<tr>
<td>Storage Temperature</td>
<td>-30 to 85 °C storage</td>
</tr>
<tr>
<td>Torque, hold-down screws</td>
<td>4 in-lb (0.45 N-m)</td>
</tr>
<tr>
<td>Torque, connector screws</td>
<td>5.26 in-lb (0.6 N-m)</td>
</tr>
<tr>
<td>Agency Approvals</td>
<td>CE, RoHS, DFARS</td>
</tr>
<tr>
<td>Warranty</td>
<td>30 months</td>
</tr>
</tbody>
</table>

* With Opto 22 SNAP power supply and SNAP rack

### SNAP-SCM-W2 Maximum Cable Lengths for Conductor Size

<table>
<thead>
<tr>
<th>Cable Length</th>
<th>Conductor Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>Up to 200 ft. (60 m)</td>
<td>22 GA stranded or larger</td>
</tr>
<tr>
<td>Up to 300 ft. (90 m)</td>
<td>20 GA stranded or larger</td>
</tr>
<tr>
<td>Up to 500 ft. (150 m)</td>
<td>18 GA stranded or larger</td>
</tr>
</tbody>
</table>
### SNAP-SCM-CAN2B Specifications

<table>
<thead>
<tr>
<th>Specification</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Baud rates</td>
<td>10–1000 Kbpe*</td>
</tr>
<tr>
<td>Logic supply voltage</td>
<td>5.0 VDC</td>
</tr>
<tr>
<td>Logic supply current</td>
<td>250 mA DC</td>
</tr>
<tr>
<td>Number of ports per module</td>
<td>1</td>
</tr>
<tr>
<td>Max. number of modules per rack**</td>
<td>8</td>
</tr>
<tr>
<td>Processor compatibility</td>
<td>SNAP PAC R-series controllers and SNAP PAC EB brains, both standard wired and Wired+Wireless models, with firmware 9.2a or newer.</td>
</tr>
<tr>
<td>Operating temperature</td>
<td>0 to 70 °C</td>
</tr>
<tr>
<td>Storage temperature</td>
<td>-30 to 85 °C</td>
</tr>
<tr>
<td>Torque, hold-down screws</td>
<td>4 in-lb (0.45 N-m)</td>
</tr>
<tr>
<td>Torque, connector screws</td>
<td>5.26 in-lb (0.6 N-m)</td>
</tr>
<tr>
<td>Agency Approvals</td>
<td>CE, FM, RoHS, DFARS</td>
</tr>
<tr>
<td>Warranty</td>
<td>30 months from date of manufacture</td>
</tr>
</tbody>
</table>

* Module performance is limited by the number of serial modules on the SNAP rack. Each rack backplane provides approximately 2.5 Mbps of bandwidth.

** Maximum number of modules per rack assumes an Opto 22 SNAP power supply and SNAP rack.

### SNAP-SCM-ST2 Specifications

<table>
<thead>
<tr>
<th>Specification</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Frequency Range</td>
<td>0.13–50,000 Hz</td>
</tr>
<tr>
<td>Pulse Width Range&lt;sup&gt;1&lt;/sup&gt;</td>
<td>3.84 Sec to 10 µSec</td>
</tr>
<tr>
<td>Pulse Width Accuracy&lt;sup&gt;2&lt;/sup&gt;</td>
<td>0–2 Hz, 2–30 Hz, 30–50,000 Hzv (see graphs on the next page)</td>
</tr>
<tr>
<td>Output Format</td>
<td>CMOS/TTL Compatible</td>
</tr>
<tr>
<td>Logic Supply Voltage</td>
<td>5.0 VDC</td>
</tr>
<tr>
<td>Logic Supply Current</td>
<td>200 mA</td>
</tr>
<tr>
<td>Compatible I/O Processors</td>
<td>SNAP PAC R-series controllers and EB-series brains with R9.1a or newer firmware</td>
</tr>
<tr>
<td>Duty Cycle</td>
<td>Fixed at 50%</td>
</tr>
<tr>
<td>Number of Ports per Module</td>
<td>2</td>
</tr>
<tr>
<td>Operating Temperature Range</td>
<td>0–60 °C</td>
</tr>
<tr>
<td>Storage Temperature Range</td>
<td>-30–85 °C</td>
</tr>
<tr>
<td>Warranty</td>
<td>30 months from date of manufacture</td>
</tr>
<tr>
<td>--------------------------</td>
<td>-----------------------------------</td>
</tr>
</tbody>
</table>

1Pulse Width is equal to one-half the period.
2To find the frequency error in Hz:
   Frequency Error (+/-) = Desired Frequency - (1 + (Pulse Width Resolution + (1 + Desired Frequency))).
LED Indicators

SNAP-SCM-232 and SNAP-SCM-485 LEDs

LEDs are the same for SNAP-SCM-232 and SNAP-SCM-485-422 modules. Transmit and receive LEDs are provided for each port as shown in the diagram at right.

If you are using the SNAP-SCM-485-422 in 4-wire mode, only LEDs 1 and 3 are used.

Since SNAP-SCM-W2 modules receive but do not transmit, LEDs 1 and 2 are not used. LEDs 3 and 4 function as shown in the diagram.

SNAP-SCM-PROFI LEDs

<table>
<thead>
<tr>
<th>LED</th>
<th>Indication</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>TEST</td>
</tr>
<tr>
<td>2</td>
<td>TRANSMIT</td>
</tr>
<tr>
<td>3</td>
<td>POWER</td>
</tr>
<tr>
<td>4</td>
<td>RECEIVE</td>
</tr>
</tbody>
</table>

SNAP-SCM-CAN2B LEDs

<table>
<thead>
<tr>
<th>LED</th>
<th>Type</th>
<th>Indicates</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>CAN Bus Activity</td>
<td>Communication activity with the CAN controller. This LED illuminates when the CAN controller is configured or when a CAN packet is accepted by the module.</td>
</tr>
<tr>
<td>2</td>
<td>STATUS</td>
<td>2 Blinks: SNAP-SCM-CAN2B firmware has started. 5 Blinks: firmware error. 8 Blinks: CAN Controller error.</td>
</tr>
<tr>
<td>3</td>
<td>POWER</td>
<td>Power is applied to the module.</td>
</tr>
<tr>
<td>4</td>
<td>ERROR</td>
<td>Error on the CAN bus. See below.</td>
</tr>
</tbody>
</table>

SNAP-SCM-CAN2B Error Codes. The #4 LED indicates an error on the CAN bus. See the OptoMMP Protocol Guide, form 1465, for the memory map addresses required to access the error codes. Reading the error code from the memory map clears the error. Possible error codes include the following:

<table>
<thead>
<tr>
<th>Error Codes</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Error—Active State. The SNAP-SCM-CAN2B has received less than 96 errors.</td>
</tr>
</tbody>
</table>
SNAP-SCM-ST2 LEDs

<table>
<thead>
<tr>
<th>LED</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Blinks when outputting pulses on channel 1</td>
</tr>
<tr>
<td>2</td>
<td>Positive/Negative direction indicator on channel 1</td>
</tr>
<tr>
<td>3</td>
<td>Blinks when outputting pulses on channel 2</td>
</tr>
<tr>
<td>4</td>
<td>Positive/Negative direction indicator on channel 2</td>
</tr>
</tbody>
</table>

**Error Codes**

<table>
<thead>
<tr>
<th>Error Code</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>-1</td>
<td>Error—Active State. The SNAP-SCM-CAN2B has received 96 or more errors but less than 128 errors.</td>
</tr>
<tr>
<td>-2</td>
<td>Receiver Overflow. A CAN packet was dropped. This happens when the SNAP-SCM-CAN2B can't keep up with the traffic on the CAN bus. This means the internal buffer on the CAN2B module is full. This could happen if the strategy isn't reading the data fast enough or too many serial modules are on the rack. To resolve it you can configure the Data Masks and Filters to receive less CAN packets, reduce the number of serial modules on the rack, or increase the frequency the strategy reads the module.</td>
</tr>
<tr>
<td>-3</td>
<td>Error—Passive State. The SNAP-SCM-CAN2B has received 128 or more errors but less than 255 errors.</td>
</tr>
</tbody>
</table>
Module Switches

Module Switches—SNAP-SCM-PROFI

The SNAP-SCM-PROFI module is designed to work with either a standard PROFIBUS DP® cable or a custom-built PROFIBUS DP cable. The positions of the communication switches when used with a standard PROFIBUS cable are shown in the diagram at left. If you are using a cable other than a standard PROFIBUS cable, set the switches as appropriate for the layout of your system.

Module Switches—SNAP-SCM-W2

The switches on the top of the SNAP-SCM-W2 are set at the factory and should not be changed from their factory defaults. Factory default positions are shown in the diagram at left.