GPS Master Quick Guide V1.2

1. Installation

GPS MASTER software installation is simple and strict forward. Step by step installation procedure is illustrated below:

1.1 Windows 7 (32-bit) and Vista (32-bit) installation

1. DO NOT connect USB clip cable to the PC. Run GPS_Master_v1.1.0_Setup.exe to start installation

2. Uninstall previous software if you have been installed it earlier. If not click “Next”

3. Change path and name of folder if you want to. Otherwise click “Next” to continue
4. Change the Start Menu Folder name if you want to otherwise click “Next” to continue.

5. Change the Start Menu Folder name if you want to otherwise click “Next” to continue.

6. Click “Install this driver software anyway”

7. Installation complete. Click “Finish”

Recommend to restart computer to before running the software.
1.2 Windows XP (32-bit) Installation

1. **DO NOT** connect USB clip cable to the PC. Run GPS_Master_v1.1.0_Setup.exe to start installation.

2. Uninstall previous software if you have been installed it earlier. If not click “Next”.

3. Change path and name of folder if you want to. Other click “Next” to continue.

4. Click “Install” to start installation. It will be complete in a few seconds.
5. Installation is undergoing

![Image showing installation progress]

6. Click “Continue Anyway” button

![Image showing warning message]

7. Installation complete. Click “Finish”

![Image showing completion message]

Recommend to restart computer to before running the software.
1.3 Connect the USB clip cable to the PC

1. Windows will ask you the location of driver. Select “No, not this time” and click “Next” button

2. “Sunplus USB to Serial COM Port” is detected. Select “Install the software automatically (Recommended) and click “Next” button

3. Click “Continue Anyway” button

4. The “Sunplus USB to Serial COM Port” driver is installed completely. Click “Finish” button.
2. Introduction

GPS Master is a simple and yet powerful software. It operates on Windows 7, Vista, and XP. If the software has been successfully installed, you may read workout history, track logs, and paths from GPS watch in just a few clicks. Communication between watch and PC is done through the dedicate USB clip cable. It comes together with the GPS watch. If you require 3D satellite map viewing of track logs and paths, you need to install Google Earth (GE) separately. GE is free from Google. You can download it from this link:

http://earth.google.com/download-earth.html

It is recommended to download GE and install GE before using GPS Master. Please make sure that you have the USB clip cable and GPS watch ready with you when you use GPS Master.

2.1 Features:

- Support multi users that share a single or multiple watches
- Show multiple workout graphs in one screen
- Interactive logged track transfer to GE
- Easy path editing in embedded Google Map environment
- Easy to use workout history hierarchy
- Tracks or paths can be transfer to friends electronically. So that they can follow and share your wonderful experience.

An panorama view of GPS Master workout log together with Google Earth
2.2 Create User and Login to GPS Master

If you use GPS Master for the first time, you will see the following screen:

![User Login Screen]

If you want to change the database location other than the default one, you may do that in the “Data Path” box.

The user database is empty after the first time installation. You have to create new user(s) now. If you have more than users you can add as many as you want here. Just click the “Add” button and give it a name in the “User Name” box.

![User Dialog]

If you forgot to add the 2nd or more users, you still can do that afterward in the User menu. As you have finished adding users select the user you want to play with, then click “Login” button.
3. Operating Instructions

GPS Master Screen Layout

The main screen is divided into 5 sections:
I. menu bar
II. calendar
III. workout history
IV. summary of selected workout
V. 3 graphical views of the logged data

Workout History

- The workout history without GPS log
- The workout history with GPS log

You can click the workout history with icon on the left hand side to launch the Google Earth. The Google Earth setting can be set in the menu (Setting → Option)

Note:
There is no effect when you click the workout history with on the left hand side. Google Earth will NOT be launched since there is no GPS data in file.
**Workout History Remark**
You can make a short note for a workout. It is limited to 64 characters long. This remark is saved in the selected workout file.

**Report**
Click the “Report” button to generate the daily, weekly, monthly and yearly report. Statistics of distance, speed/pace, heart rate, and calorie are provided in this summary report.

**Activities**
Workouts can be classified and stored into different activity categories such as running, cycling, hiking, etc. GPS Master creates the <default> activity after installation. All workouts are placed into this activity unless it is changed manually. The <default> activity can neither be deleted nor removed. You are free to create and manage your own activities with the following buttons:

a. Click “+” button to add a new activity. You may add as many activities as you want provided that the hard disk storage is sufficient.
b. Click “-” button to delete current selected activity. Be aware that all the track logs under this activity will be removed at the same time. If you want to keep part of the workouts you must move them to other activity deliberately.
c. Click “a→b” button to rename current selected activity.

To select a different activity, click the combo box next to “Activity” and select the desire activity from the given list. All data downloaded from watch will be stored into this activity afterward. To move a workout to a different activity, right click the workout, a popup menu will be displayed and select “Move to activity”. The following dialog will be shown. (e.g. Running and hiking activities were previously added)

![Move Dialog]

Select an activity and press “Move” button to confirm.
Step by Step Menu description

3.1 File

You can issue IMPORT, EXPORT workout log functions here. All workout logs are stored in a directory specified by the Data Location path. Data Location path can be modified in Setting → Options menu. There are 2 types of files in the database. One has file extension .ss and the other .tkl. A .tkl file contains workout with GPS track log. A .ss file contains workout without GPS log. Files names are derived by its date and time stamp. For example if a workout was logged at 20:26:08 on Jan 7, 2010 with GPS data. The corresponding file name should be “20100107202608.tkl” after it has been transferred into PC.

3.1.1 IMPORT function reads a WORKOUT file and places it into the database of the current user. In order to save the file to proper location in the database. The file name should follow the naming convention described above.

3.1.2 EXPORT function saves the selected WORKOUT in either GPS Master format (.tkl) or several other file formats supported by some popular softwares. GPS Master can export:

- **.kml**  – supported by Google Earth
- **.gpx**  - GPX (the GPS eXchange Format) is a light-weight XML data format for the interchange of GPS data (waypoints, routes, and tracks) between applications and web services on the Internet.
- **.nmea**  – The National Marine Electronics Association (NMEA) has developed a specification that defines the interface between various pieces of marine electronic equipment. The standard permits marine electronics to send information to computers and to other marine equipment. Most GPS devices support NMEA file format.
- **.pth**  – The select workout track is converted to a PATH. It can be loaded to the watch for navigation directly. You have to define either maximum number of waypoints (N) or the distance between 2 waypoints (D). Change one setting will affect the other. Maximum number of waypoint is limited to 99. The whole track is divided into N-1 equal distance segment. Waypoint is created at the end of each segment. The newly created PATH is stored in the Path Library folder.
- **.csv**  - A comma-separated values (CSV) file is used for storage of data structured in a table of lists form, where each associated item in a group is in association with others also separated by the commas of its set. Each line in the CSV file corresponds to a row in the table. Within a line, fields are separated by commas, each field belonging to one table column. You may import .csv file into Excel spreadsheet directly.
3.2 **View→Refresh**

Re-read WORKOUT history and update hierarchical tree

3.3 **User**

3.3.1 **User→Add**
Create new database structure for a new user

3.3.2 **User→Switch user**
Log-in to a different user. The last USER working environment (e.g., size and location of GPS Master) will be sustained when GPS Master run next time.

3.4 **Data Transfer**

3.4.1 **Data Transfer → Receive watch data**

Before you activate this function please make sure that USB cable has been plugged into PC and the clip has been attached to the watch correctly and securely. Once everything is fine, data transmission will be complete in a couple of minutes.

Browsing around workout information in GPS Master is simple. Imported items are placed in
the **Workout History** tree. It is arranged in a tree fashion hierarchy in order. New tree nodes are created automatically after new workout data has been read from watch or imported from a file. Just select or click the activity as you are interested in the **History** section, then associated summary information will be shown in the **Summary** section. If track log is available, track data can be viewed from GE immediately. Meanwhile 3 selected graphical charts are plotted on the left. Each chart can be customized to specific workout data. A button attached at top left corner of each chart is dedicated for this purpose. Kick and pick the desired type of data to be plotted in the y-axis of this chart. The selection box at the bottom right corner depicts the x-axis to be either **TIME** or **DISTANCE**. The calendar provides a shortcut for searching for workouts which are far away from current workout item.

Selecting the “Smoothing data” check box, moving average filter is applied. Short-term fluctuations will be smoothed out.
3.5 Path → Path Manager

3.5.1 Path Manager

GPS Master watch has 10 individual paths (or routes). A path has maximum 99 waypoints. Paths can be created by the embedded Google Maps (GMAP) path editor. Paths can also be read from the watch after they have been created manually. Or they can be created by GE and import to here. Please refer to the detail instruction of Add→Path section in GE.

There are 3 major sections in Path Manager: Current Paths, Path Library, and embedded GMAP path editor.

a. Path Library Section

User can store unlimited number of paths in the path library. Path in library can be edited and transfer to current path section by pressing button \( \gg \) and then upload to the watch.

Workout track can be transformed to path and placed in path library in the
b. Current Path Section
This is a temporary buffer storage for the 10 paths read and write to watch. All 10 paths are transferred to and from watch at the same time. Reading path from watch overwrites existing content in the buffer. If you want to keep a copy for later use, you have to copy it to the Path Library using the << button. Similarly paths in Library can be brought to Current Path by clicking >> button. Path name can be edited. Select a desire path, then either push F2 key or click the a→b button. Path name is limited to 32 characters long.

<table>
<thead>
<tr>
<th>Icon</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>![PC]</td>
<td>Send paths from watch to PC</td>
</tr>
<tr>
<td>![PC]</td>
<td>Send paths from PC to watch</td>
</tr>
<tr>
<td>![Up/Down]</td>
<td>Change the order of selected path in Current Path section</td>
</tr>
<tr>
<td>![Import]</td>
<td>Import a .kml file generated by Google Earth (Please refer to section 3.5.2) OR Import a .pth file generated by GPS Master</td>
</tr>
<tr>
<td>![Del.]</td>
<td>Delete current selected path</td>
</tr>
<tr>
<td>![a→b]</td>
<td>Rename current selected path</td>
</tr>
<tr>
<td>![&lt;&lt;]</td>
<td>Copy a selected path in Current Path section to Path Library</td>
</tr>
<tr>
<td>![Export to GE]</td>
<td>Open selected path with Google Earth</td>
</tr>
</tbody>
</table>

c. Path Editor Section
As you select a path, disregard it is from Current Path or Library, it is plotted graphically in GMAP. Waypoints are shown with place mark. Waypoint name is displayed when mouse cursor is put on waypoint marker. Name can be edited by double clicking the marker. Waypoint name is limited to 10 characters long.
To create a new path from scratch, press “New Path” button, path editor will load Google MAPS as below:
1. Press map control to pan in four directions, and to zoom-in and zoom-out. Left-click mouse button to place a placemark. The green placemark is the active placemark. “Delete a waypoint” button deletes the active placemark.

2. After you have created a path, press button “Save path”. You are prompted to enter a path description. You can select the save location either “Path Library” or “Current Path”. Then press “Save & Exit” button to finish.
3.5.2 Create a path using Google Earth

a. Open Google Earth and select menu “Add->Path”
b. Left-click mouse button to add new waypoints to the path as the Add->Path dialog is opened.
c. Right click the newly created PATH under the Temporary Places in the middle of the sidebar then saves it as a .kml file as shown in the picture below.

Now you can import this path to GPS Master’s Path Manager by clicking the Import button and browse for the path (.kml) file created by Google Earth.
3.6 Setting \rightarrow Watch Configuration

3.6.1 Setting \rightarrow Watch Configuration \rightarrow View Setting

The Watch offers 5 activity profile (Running, Cycling, Hiking, Sailing and User by default). Each profile has 3 views with 3 data lines each. Users may create any combination that and review their performance easily. Profile setting can be done in watch. Or it can be manipulated in PC more easily. Transfer profiles to and from PC only takes a few seconds.

Press "Write setting to watch" button writes all Workout Views to the watch. Reset View settings to factory default by pressing "Reset to default" button. Please note that watch’s workout Views are downloaded at the same time when workout data is being transferred to PC.

Activity profile name (max. 10 characters) can be modified by pressing “Rename” button. Profile name editing cannot be done in watch. Activity view setting is saved to an .ACT file in the ActivityLib folder under the user’s own directory eg. “c:\program files\GPS Master\User\John\ActivityLib”. They can be reloaded by clicking “Load” button and then to transfer to the watch later. That means your are not only limited to 5 activity profiles. You can customize any activity profile, store it in PC, and retrieve to watch as you wish.
3.6.2 **Setting → Watch Configuration → User Data**

User’s gender, birthday and weight can be set here.

3.6.3 **Setting → Watch Configuration → Unit**

In “unit” tab, measuring units and time format are set here.
3.6.4 Setting → Option

a. **Receive workout history only**
   Both workout history and paths are stored in watch’s memory. Select “Receive workout history only”, the workout history will be downloaded from watch to PC. But paths stored in watch WILL NOT be transferred at the same time. User can separately upload or download paths in Path → Path Manager.

b. **Receive workout history and paths**
   Select “Receive workout history and paths”, the workout history and paths will be downloaded from watch to PC at the same time.

c. **Auto-clear memory**
   If this option is activated, workout history in watch will be cleared after data transfer has complete.
d. **Database location**

GPS Master maintains users’ workout history databases and paths in a particular subdirectory. This is the root directory of GPS Master’s database. Every user has its own subdirectory under the root directory. Workout files are arranged under the user subdirectories in chronological manner. Name of a user subdirectory is the same as the user’s login name. The whole database or data of individual users can be backup by copying the corresponding directory to another backup location.

e. **Google Earth Setting**

GPS Master allows users to launch Google Earth by either single-click or double-click mouse button. If “Disable” option is selected, it will NOT launch Google Earth.

f. **Language**

User can change the language of GPS Master. Press “Save & Exit” button to confirm
Troubleshooting and FAQ

1. Why does it show “Open virtual COM port error” when I receive watch data?

Solution

a. Please check if the USB driver is installed or not.

Select “Control Panel->System->Hardware->Device Manager”. Expand “Ports”

If the icon next to “Sunplus USB to Serial COM Port” has a cross or exclamation mark, the driver is not installed correctly. When the driver is installed properly, it will show as follows:

![Device Manager](device_manager.png)

b. Please make sure USB clip cable has been plugged into PC and the clip has been attached to the watch correctly and securely.

c. Make sure ONLY ONE “GPS Master” software is running. Do not run many copies of “GPS Master” software in a PC.

2. Why does it show “Error in communicating with watch!” when I receive watch data?

Solution:

a. Please make sure that USB clip cable has been plugged into PC and the clip has been attached to the watch correctly and securely. Once connected USB clip cable between watch and PC, “Connected icon” will be shown on watch screen.

![Connected icon](connected_icon.png)

3. Why does it show “Cannot find Google Earth in your system!” when I click the workout history with GPS data?

Solution:

a. Google Earth is not included in the CD. Please download it from http://earth.google.com/download-earth.html
After Google Earth is installed, the GPS Master software will launch Google Earth when you click workout history with GPS data 🗺.

### 4. Why does it not call Google Earth when I click the workout history?

**Solution:**

a. Please make sure clicking the workout history with GPS log (there is a 🗺 icon on the left hand side of the workout history). Clicking the workout history with 🗺 icon will not launch Google Earth since there is no GPS log in the history file.

b. Make sure Google Earth is installed in your system and work properly.

c. Check the setting in the menu (Option -> Setting)

```
Google Earth Setting
- Single-click launch
- Double-click launch
- Disable
```

Make sure “Disable” option is not selected. If “Disable” setting is selected, Google Earth will not be launched by GPS Master software even Google Earth is installed in your system.

### 5. Why does it show nothing when I click a path in “Path Manager”?

**Solution:**

a. Please check internet connection. GPS Master needs the internet connection to reach Google Map web site.