PUBLIC

How to Work with Crystal Reports in SAP Business One

Release Family 8.8

Applicable Release:
SAP Business One 8.81

All Countries
English
September 2010
# Table of Contents

**Introduction** ................................................................................................................................. 4  
  Prerequisites ........................................................................................................................................... 5  
  Installing the Crystal Reports Version for SAP Business One ......................................................... 5  
  Performing Tasks ................................................................................................................................. 5  
  Terms and Definitions .......................................................................................................................... 6  
  Related Documentation ....................................................................................................................... 6  

**Overview** ........................................................................................................................................ 8  

**Working with Crystal Reports Layouts and Reports for Solutions** ................................................... 9  
  Creating a New Report ......................................................................................................................... 9  
    Connecting to a Data Source ......................................................................................................... 9  
    Creating Selection Criteria Dialog Boxes ................................................................................. 15  
    Viewing and Running Selection Criteria Dialog Boxes in SAP Business One ....................... 18  
    Working with Selection Criteria Tokens ..................................................................................... 19  
    Tokens for Creating SAP Business One Controls ....................................................................... 19  
    Syntax and Rules for Defining Tokens ......................................................................................... 26  
    Working with Parameters ............................................................................................................. 29  
  Saving Crystal Reports .rpt Files ....................................................................................................... 33  
  Running Reports Created with the Crystal Reports Software ....................................................... 35  
  Editing Reports ................................................................................................................................. 35  
  Deleting Reports ............................................................................................................................... 37  
  Creating New Crystal Reports Layouts ............................................................................................ 37  
  Editing Crystal Reports Layouts ....................................................................................................... 38  
  Deleting Crystal Reports Layouts ..................................................................................................... 40  
  Logging Off from a Data Source ....................................................................................................... 41  

**Setting Authorizations for Reports Created with the Crystal Reports Software** ............................. 42  

**Developing Crystal Reports Solutions Using the SDK API** ............................................................. 44  

**Creating Master Layouts** ................................................................................................................... 45  

**Exporting Reports Created with the Crystal Reports Software** ..................................................... 46  

**Exporting Layouts Created with the Crystal Reports Software** ..................................................... 46  

**Importing Reports Created with the Crystal Reports Software** ..................................................... 51  
  Importing Report-Type Crystal Reports .rpt Files ........................................................................... 55  
  Creating a New Report Folder in the Main Menu .......................................................................... 59  
  Importing an SAP Business One .b1p Package File Containing Reports ..................................... 61  

**Importing Layouts Created with the Crystal Reports Software** ...................................................... 67  
  Importing Layout-Type Crystal Reports .rpt Files ......................................................................... 67  

© SAP AG 2010
Introduction

The SAP Business One 8.8 release provides integration with the Crystal Reports software, version for the SAP Business One application, allowing you to create, view, and manage reports and layouts. The key features of the integration include:

- **Crystal Reports software, version for the SAP Business One application**
  
  You can save reports and layouts from within the Crystal Reports version for SAP Business One to the SAP Business One database. You can create reports and layouts more easily using an abstraction layer of SAP Business One database tables that are arranged according to the modules in the SAP Business One Main Menu.

  Using the Crystal Reports software, you can draw data from SAP Business One tables and company databases into selection criteria. Additionally, you can create controls in reports and layouts that are aligned with standard SAP Business One user interface elements.

  **Note**

  This document includes the processes and procedures involved in working with the Crystal Reports software. However, these processes and procedures relate to the SAP Business One context only. For more detailed information about working with the Crystal Reports software, see the Crystal Reports 2008 online help that is accessible from the Crystal Reports software, or from the Crystal Reports DVD.

- **Crystal Reports Viewer**
  
  A WYSIWYG (What You See Is What You Get) application that provides you with an accurate print preview of reports and documents and enables exporting of reports to PDF and other formats. In addition, you can use the filtering functionality of the viewer, by entering different values in the Parameter Panel. For more information, see Viewing Crystal Reports Layouts and Reports in SAP Business One.

- **Report and Layout Management**
  
  In SAP Business One 8.8, you can access a report and layout management window, where layouts for printing documents can be defined and saved. From one location, you can manage the properties of reports and layouts created with the Crystal Reports software as well as Print Layout Designer (PLD) layouts. In addition, you can define layout print sequences. The Report and Layout Manager window allows you to export and import reports and layouts that are created with the Crystal Reports software. For more information, see Report and Layout Manager Window.

- **Master Layouts**
  
  You can create a master layout for sales and purchasing documents that can be applied to various other sales and purchasing document types. For example, a master layout that is created for a sales invoice can be applied to sales quotations or deliveries. For more information, see Creating Master Layouts.

- **Accessibility of Source Documents**
  
  To drill down to a source master data window, you can click a Link Arrow icon when previewing reports in SAP Business One that are created with the Crystal Reports software. For more information, see Link Arrow Icon.

  **Note**

  In addition to the Crystal Reports software, SAP Business One supports Print Layout Designer (PLD). You can use either one to create layouts for SAP Business One documents. For more information about working with PLD, see http://service.sap.com/smb/sbocustomer/documentation.
Prerequisites

- You have installed the Crystal Reports version for SAP Business One.

**Recommendation**

The SAP Business One data source provides a hierarchy tree for the database tables that is sorted according to the modules in the SAP Business One Main Menu. To ensure that the SAP Business One data source is available in the Crystal Reports version for SAP Business One, we recommend that you first install the Crystal Reports software before installing SAP Business One.

If you cannot first install the Crystal Reports software, follow the procedure below for installing the SAP Business One data source and SAP Business One Add-ins menu: Installing the Crystal Reports Version for SAP Business One.

- You have installed SAP Business One 8.8.

**Note**

You can run the Crystal Reports version for SAP Business One with either Microsoft SQL Server 2005 or 2008.

Installing the Crystal Reports Version for SAP Business One

**Recommendation**

We recommend that you install the Crystal Reports software before installing SAP Business One 8.8.

Follow the installation sequence below:

1. On the Crystal Reports DVD that is provided with SAP Business One 8.8, locate the setup files for the following and run them in the order shown below:
   a. Crystal Reports 2008 SP1
   b. Crystal Reports 2008 FP3
2. Install SAP Business One 8.8.

**Note**

For further information about installing the Crystal Reports software and installing and upgrading SAP Business One, see the Administrator’s Guide that is provided on the SAP Business One product DVD.

Performing Tasks

This document provides instructions for performing the following tasks:

- Creating a New Report
- Creating New Crystal Reports Layout
- Creating Master Layouts
- Exporting Reports Created with the Crystal Reports
- Exporting Layouts Created with the Crystal Reports Software
- Importing Reports
- Importing Layouts Created with the Crystal Reports Software
• Viewing Crystal Reports Layouts and Reports in SAP Business One
• Working with Preview and Printing Options in SAP Business One
• Working with Printing Sequences
• Running Reports Created with the Crystal Reports Software in SAP Business One

Terms and Definitions

The following terms are used in this document.

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report in Crystal Reports software</td>
<td>An .rpt file that is created with the Crystal Reports software. When you generate a report using the Crystal Reports software, it is displayed in Crystal Reports Viewer.</td>
</tr>
<tr>
<td>Crystal Reports software, version for the SAP Business One application</td>
<td>Software that is designed to work in conjunction with SAP Business One for creating reports and layouts using the Crystal Reports software for SAP Business One reports and documents.</td>
</tr>
<tr>
<td>Layout in Crystal Reports software</td>
<td>An .rpt file that is created with the Crystal Reports software. A Crystal Reports layout determines the print preview and printed appearance of a report or document. You can define a Crystal Reports layout as a master layout.</td>
</tr>
<tr>
<td>Crystal Reports Viewer</td>
<td>A fully integrated component of SAP Business One 8.8 that lets you view reports and layouts that are created with the Crystal Reports software.</td>
</tr>
<tr>
<td>master layout</td>
<td>A Crystal Reports layout that you define to be applicable to multiple document types and reports.</td>
</tr>
<tr>
<td>print sequence</td>
<td>A defined set of rules for printing a report. You define these rules in SAP Business One, in the Report and Layout Manager window.</td>
</tr>
<tr>
<td>SAP Business One data source</td>
<td>You connect to this data source to get SAP Business One tables arranged by module in a hierarchy tree in the Crystal Reports software.</td>
</tr>
<tr>
<td>token</td>
<td>A special format of parameter name containing SQL-syntax code in a report or layout created with the Crystal Reports software. You use tokens to create different types of report selection criteria and their controls for use in SAP Business One.</td>
</tr>
</tbody>
</table>

Related Documentation

The documents listed below are referred to in this document. The documents are located on the SAP Business One Customer Portal [http://service.sap.com/smb/sbocustomer/documentation](http://service.sap.com/smb/sbocustomer/documentation) unless indicated otherwise.

• User Interface Standards & Guidelines
• SDK online help file, SDK_EN.CHM, available on the SAP Business One product DVD or in the download package from SAP Service Marketplace.
• SAP Business One *Administrator’s Guide*, available on the SAP Business One product DVD or in the download package from SAP Service Marketplace.
• Crystal Reports 2008 online help; available from within the Crystal Reports software.
• Crystal Reports *User Guide*, available on the Crystal Reports DVD.
Overview

There are many procedures and sub procedures involved in the processes of working with the Crystal Reports software. A typical high-level flow of procedures for working with .rpt files that are created with the Crystal Reports software is as follows:

1. Creating a new report or layout
2. Exporting a report or layout
3. Importing a report or layout

Note

For a more detailed list of the processes and procedures included in this document, see Performing Tasks.

The following is a high-level representation of the workflow for working with the Crystal Reports software:

Figure 1: Working with Crystal Reports Layouts and Reports
Working with Crystal Reports Layouts and Reports for Solutions

You can create Crystal Reports layouts and reports in the Crystal Reports software.

Note
You do not need to install Crystal Reports Viewer in a separate procedure. It is an integral part of the SAP Business One 8.8 core product.

The procedures for creating Crystal Reports layouts and reports are described in the subsections below.

Creating a New Report

This section provides the following sequence of procedures involved in creating a new report with the Crystal Reports software:

1. Connecting to a Data Source
2. Creating Selection Criteria Dialog Boxes
3. Saving Crystal Reports.rpt File
4. Running Reports Created with the Crystal Reports Software

Prerequisites

- SAP Business One supports the following data sources in the Crystal Reports software:
  - SAP Business One
  - OLE DB (ADO)

Recommendation
We recommend that you connect to the SAP Business One data source.

You must connect to a data source before you can begin creating a new report in the Crystal Reports software. For more information, see Connecting to a Data Source and Installing the Crystal Reports Version for SAP Business One.

Connecting to a Data Source

Note
For more information about data sources, see the Crystal Reports 2008 online help.

1. In the Crystal Reports Start Page, choose Blank report.

Note
If you prefer, you can work with the Standard Report Creation wizard. Instead of Blank report, choose Standard Report and enter the requested information. For more information about the Standard Report Creation wizard, see the Crystal Reports online help.
2. In the Database Expert window, in the Available Data Sources pane on the left side of the screen, select the SAP Business One data source, and in the SAP Business One log on screen, enter the required information.

<table>
<thead>
<tr>
<th>SAP Business One Server:</th>
<th>&lt;server_name&gt;</th>
</tr>
</thead>
<tbody>
<tr>
<td>License Server:</td>
<td>&lt;computer_name&gt;:30000</td>
</tr>
<tr>
<td>Server Type:</td>
<td>MSSQL2005</td>
</tr>
<tr>
<td>Company Database:</td>
<td>&lt;company_name&gt;</td>
</tr>
<tr>
<td>Company User ID:</td>
<td></td>
</tr>
<tr>
<td>Company User Password:</td>
<td></td>
</tr>
<tr>
<td>Trusted Connection (optional):</td>
<td></td>
</tr>
<tr>
<td>Database User ID (optional):</td>
<td>sa</td>
</tr>
<tr>
<td>Database Password (optional):</td>
<td></td>
</tr>
</tbody>
</table>

**Recommendation**

If you select the SAP Business One data source, the table names are grouped by type, such as A/R Sales or Human Resources. You can use the 15 External Tables folder to save and share tables for partner-created add-ons. See the screen capture below.

**Note**

You can choose the OLE DB (ADO) data source if you prefer.

3. In the Database Expert window, in the Available Data Sources pane, do one of the following:
   - If you have connected to the SAP Business One data source, under the B1 Tables node, select a categorized table.
   - If you have connected to a different data source, select from all available tables by choosing the following path:
     
     `<connected database> → dbo → Tables`
4. Select one or more tables whose data you want to include in the new report and using the Add (> or Add All (>>) arrow buttons, move the selected tables to the Selected Tables pane.

Note

For more information about SAP Business One database tables, see the SDK_EN.CHM file on the SAP Business One product DVD or in the download package.
Note
To find out a table name that is related to a specific SAP Business One window, pane, or field, you need to display the system information. To do so, in the SAP Business One menu bar, choose View → System Information. Then, by moving your cursor around the window, you can see the window's table information displayed in the SAP Business One status bar at the bottom of the screen. In the example below, the table is OINV and the Name field that the cursor is pointing to is based on the CardName column of the OINV table.

5. Choose the OK button. If you select more than one table in step 4, the Links tab appears and displays the tables and their relationships.

Note
The Crystal Reports software automatically creates a foreign key relationship between tables when you select more than one table on which to base a new report.

6. Choose the OK button. On the Design tab, in the work space on the left, a new report appears in Design view.

Recommendation
To view a generated report print preview, you can open the Preview tab for quick viewing of your report.

In the menu bar, choose: View → Print Preview. The Preview tab appears next to the Design tab on the left side of the screen.

Viewing Table Information in the SAP Business One Data Source
To enable viewing table information in the SAP Business One data source:

1. In the Database Expert window, in the Available Data Sources pane, in the hierarchy tree under SAP Business One, right-click B1 Tables and choose Options.

2. In the Options window, in the Tables and Fields area, select the Show Both radio button.
3. Choose the **OK** button.

A description is shown for each SAP Business One table in the hierarchy tree as shown below.
Creating Selection Criteria Dialog Boxes

In the Crystal Reports window, on the Design tab, you can use tokens to create selection criteria dialog boxes for filtering criteria, such as the selection criteria dialog boxes shown in theexamples below:

Example

Report Selection Criteria

Choose the (...) button:  
OK  Cancel

In the above window, when you choose the Browse (...) button, the Items List - Selection Criteria dialog box opens, as shown below:

Items List - Selection Criteria

Item No. From  To  
Group  
Item Properties  Ignore  
Hide Items with No Quantity in Stock  
OK  Cancel

For each selection criteria dialog box that you want to create, you create a blank report (.rpt file), and then you add several parameters, each one containing a different SQL token. For example, when you are creating a new selection criteria dialog box for a report, you use different specific SAP Business One tokens for adding a title, a separator line, or a dropdown list. You can then change the order of these parameters to define the order in which the various related UI elements appear in the dialog box.

Note

For more information about SQL tokens and parameters, see Working with Selection Criteria Tokens.

The procedure described below demonstrates how to create the example selection criteria dialog boxes shown above. Following the procedure, in the Working with Selection Criteria Tokens section, these subsections provide more specific information:

- Tokens for Creating SAP Business One Controls
- Syntax and Rules for Defining Tokens
- Working with Parameters

Procedure

To create the example dialog boxes shown above:

1. In the Crystal Reports window, create a blank report and connect to a data source as described in Connecting to a Data Source above.
2. In the Database Expert window, select the OITM (item master data) table and choose the OK button.
### Note
You can work with any SAP Business One tables to create selection criteria dialog boxes. The selection of the **OITM** table in this procedure is for creating the specific example dialog boxes shown above.

To find out a table name that is related to a specific SAP Business One window, pane, or field, you need to display the system information. To do so, in the SAP Business One menu bar, choose **View → System Information**. Then, by moving your cursor around the window, you can see the window's table information displayed in the SAP Business One status bar at the bottom of the screen. In the example below, the table is **OINV** and the **Name** field that the cursor is pointing to is based on the **CardName** column of the **OINV** table.

3. In the **Field Explorer** pane on the right, open the **Database Fields** node, then open the **OITM** node.
4. Drag each of the following fields to the **Design** tab work space on the left and drop them in the **Details** area:
   - **ItemCode**
   - **ItemName**

   The fields appear in the **Details** area with their associated labels in the **Header** area. You can edit the label text. For more information, see the Crystal Reports 2008 online help.
5. In the **Field Explorer** pane, close the **OITM** node.
6. In the **Field Explorer** pane, right-click the **Parameter Fields** node and select **New**.

   **Note**
   For more information about parameters, see [Working with Parameters](#).
7. In the **Create New Parameter** window, in the **Name** field, enter the following token:
   ```sql
   MyParameter@SELECT * FROM OITM
   ```
8. In the **Value Options** list at the bottom of the window, set the values in one of the following configurations:
Choose from List field

To create the choose-from-list field as shown in the Report Selection Criteria dialog box below, set the options according to the table below the screen captures:

When you choose the Choose from List icon shown above, the following List of Items window appears:

Note

It is not necessary to change the value options that do not appear below. For more information about value options settings, see the Crystal Reports 2008 online help.

Choose from List settings:

<table>
<thead>
<tr>
<th>Value Options</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prompt Text</td>
<td>Select an item</td>
</tr>
<tr>
<td>Allow multiple values</td>
<td>False</td>
</tr>
<tr>
<td>Allow discrete values</td>
<td>True</td>
</tr>
<tr>
<td>Allow range values</td>
<td>False</td>
</tr>
</tbody>
</table>

Browse (...) button type

To create the Browse (...) button type of Report Selection Criteria dialog box shown below:
When you choose the Browse button above, the following Items List - Selection Criteria dialog box opens:

![Items List - Selection Criteria](image)

**Note**

It is not necessary to change the value options that do not appear below. For more information about value options settings, see the Crystal Reports 2008 online help.

Multiple selection criteria settings:

<table>
<thead>
<tr>
<th>Value Options</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prompt Text</td>
<td>Choose the (...) button</td>
</tr>
<tr>
<td>Allow multiple values</td>
<td>True</td>
</tr>
<tr>
<td>Allow discrete values</td>
<td>True</td>
</tr>
<tr>
<td>Allow range values</td>
<td>False</td>
</tr>
</tbody>
</table>

9. In the Create New Parameter window, choose the OK button.

**Viewing and Running Selection Criteria Dialog Boxes in SAP Business One**

After you have followed the steps in the example above, you can view the new dialog box in SAP Business One as described in the following procedure.

**Procedure**

1. In the Crystal Reports window, in the menu bar, choose Add-ins → SAP Business One → Preview in SAP Business One.

![Crystal Reports Basic 2008 for SAP Business One](image)

The Report Selection Criteria dialog box opens in SAP Business One.

2. Choose the Choose from List icon or Browse (...) button, depending on which type of selection criteria you set in the previous section.
3. In the selection window that opens, select the required criteria and choose the OK button.

4. In the Report Selection Criteria dialog box, choose the OK button.

The report opens in Crystal Reports Viewer. For more information about Crystal Reports Viewer, see Viewing Crystal Reports Layouts and Reports in SAP Business One.

You may now save your new report and run it in SAP Business One. For more information, see the following:

- Saving Crystal Reports .rpt File
- Running Reports Created with the Crystal Reports Software

**Working with Selection Criteria Tokens**

You can create controls that align with standard SAP Business One UI elements.

This section provides explanations about and examples of about SAP Business One tokens as shown in the list below:

- Tokens for Creating SAP Business One Controls
- Syntax and Rules for Defining Tokens
- Working with Parameters

**Prerequisites**

- You are familiar with the guidelines for working with the SAP Business One user interface.

  **Note**

  For more information about working with the SAP Business One user interface, see User Interface Standards & Guidelines [http://service.sap.com/smb/sbocustomer/documentation](http://service.sap.com/smb/sbocustomer/documentation). User Interface Standards and Guidelines provides the best practices for designing the SAP Business One interface. This document describes the structure and appearance of the interface, and the rules used to perform actions that affect the system.

  By following these guidelines, you can improve the quality and consistency of the application. The document offers the latest GUI design rules and recommendations. It also includes relevant GUI information, including a glossary, case studies, reusable components, and international support standards.

- You are familiar with SQL syntax, which is required for creating the tokens described in the following sections.

**Tokens for Creating SAP Business One Controls**

SAP Business One provides the tokens that are described in the sections below. You can use them to create standard SAP Business One controls.

Most of these tokens contain SQL statements that you can use to dynamically select data from tables and fields in SAP Business One. You can use other tokens to create UI elements such as titles and horizontal separator lines.

  **Note**

  For more information about SAP Business One databases, tables, and fields, see the SDK online help file, *SDK_EN.CHM*, on the SAP Business One product DVD or in the download package.
Basic Token Structure

Use the following basic structure to create SQL tokens in reports that you want to run in SAP Business One:

```sql
<parameter_name>@<SQL_Expression>
```

**Example**

An example of `<SQL_Expression>` might be:

```sql
SELECT * FROM OITM WHERE OnHand > 100.
```

In this case, the condition in the WHERE subclause specifies the query scope.

Titles

You can assign a title token to group selection criteria, such as checkboxes. In the example below, *Business Partner Type* is the title.

<table>
<thead>
<tr>
<th>Business Partner Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customer</td>
</tr>
<tr>
<td>Vendor</td>
</tr>
</tbody>
</table>

To create a title, use the following token:

```sql
<parameter_name>@title
```

To define the text that you want to appear in the title, in the *Value Options* list, in the *Prompt Text* field, enter the required text. In the example above, the user entered *Business Partner Type* in the *Prompt Text* field.

Separators

Separators are horizontal lines that span the width of a window. You can use separators to separate selection criteria groups as in the example below:

<table>
<thead>
<tr>
<th>From 01/01/08 To 12/31/08</th>
</tr>
</thead>
<tbody>
<tr>
<td>From 01/01/08 To 12/31/08</td>
</tr>
<tr>
<td>From 01/01/08 To 12/31/08</td>
</tr>
</tbody>
</table>

To create a separator, use the following token:

```sql
<parameter_name>@separator
```

No other specific values are required for this token.
Item Selection Criteria Groups

This token groups different selection criteria types together. In the example below, the selection criteria relate to item data. If you define a token to select fields from the OITM table (relating to item data), and the parameter is defined as the multi-value type, you can create a selection criteria control such as the one below:

<table>
<thead>
<tr>
<th>Code</th>
<th>From</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item Group</td>
<td>All</td>
<td></td>
</tr>
</tbody>
</table>

Properties: Ignore

To create a group of item selection criteria such as the one shown above, use the following token:

```
<parameter_name>@SELECT * FROM OITM
```

**Example**

For specific instructions about creating the item token shown above, see Creating Selection Criteria Dialog Boxes.

**Note**

If the parameter allows multiple values, a Browse button appears in the selection criteria dialog box when you run the report. When you choose the Browse button, it opens another window.

If the parameter does not allow multiple values, a field with a Choose from List icon appears in the selection criteria dialog box when you run the report. For more information, see Creating Selection Criteria Dialog Boxes.

Business Partner Selection Criteria

You can define a token that selects business partner data from the OCRD table as in the example shown below.

<table>
<thead>
<tr>
<th>Code</th>
<th>From</th>
<th>To</th>
</tr>
</thead>
<tbody>
<tr>
<td>Customer Group</td>
<td>All</td>
<td></td>
</tr>
<tr>
<td>Vendor Group</td>
<td>All</td>
<td></td>
</tr>
</tbody>
</table>

Properties: Ignore

To create selection criteria controls related to business partners, you can use the following example tokens.

- Use the following token to create a control that includes all types of business partners:
  
  `<parameter_name>@FROM OCRD`

- Use the following token to create a control that includes only customer-type business partners:
  
  `<parameter_name>@FROM OCRD WHERE cardType='c'`

- Use the following token to create a control that includes only vendor-type business partners:
  
  `<parameter_name>@FROM OCRD WHERE cardType='s'`
Date Format Selection Criteria

You can define date selection criteria using either of the following two types of date controls:

- **Date Selector** calendar window – Allows the user to enter any date by choosing the *Calendar* icons in the fields shown below:

  | Date From  | 01/01/08 | To  | 12/31/08 |

To create this control: in Crystal Reports, define the parameter type as `Date` and select the required range of values.

- **Choose From List** control – Allows the user to choose only specific periods by choosing the *Choose from List* icon as shown in the fields below:

  | Date From  | 01/01/2008 | To  | 31/12/2008 |

To create this specific control, use the following token, which draws data in this case from the `OFPR` table:

```<parameter_name>@SELECT * FROM OFPR>```

Account Tree

The **Account Tree** object in SAP Business One allows the user to view different account levels and multiple selection options of the nodes.

To create an account tree, use the following token, which allows you to define multiple values:

```<parameter_name>@FROM OACT>```

By Location and By Warehouse

Location and warehouse information is usually grouped together as tabs as in the examples below.
To create this control, use the following token, which selects data from the OWHS table. Make sure to set the Allow multiple values value option to True.

<parameter_name>@SELECT * FROM OWHS

Multiple Selection Grid

Each of the Browse (...) buttons in the following dialog box opens the same grid control, shown below, for selecting multiple values. Each Browse button includes a checkbox for indicating if a value or values have been selected.

To ensure that a multiple selection grid like the one shown below appears when you choose a Browse button in the example above, do the following:

1. In the Create Parameter or Edit Parameter window, in the Value list, enter a list of valid values.
   In the example below, the following values have been set:
   - Low
   - Medium
   - High

2. In the Value Options area, set the Allow multiple values option to True.

Note

If you set the Allow multiple values option to False, a dropdown list appears, such as the example business-partner type control shown below, instead of the Browse buttons and checkboxes above.
Link Arrow Icon

You can add drilldown functionality to a Crystal Reports layout or report with a Link Arrow icon as shown in the example below. In this case, when you preview it in SAP Business One and click the Link Arrow icon next to an item, the Item Master Data window opens to display item details.

To create this specific example, do the following:

1. Manually insert the Link Arrow icon graphic into the Crystal Reports layout.
2. Right-click the graphic and select Format Graphic. The Format Editor window opens.
3. On the Hyperlink tab, do the following:
   a. In the Hyperlink Type area, select the A Website on the Internet radio button.
   b. In the Hyperlink Information area, in the Website Address field, enter the following string:
      \texttt{http://$b1$/link?table=OITM&key=I001}
4. Click the **Formula** button to the right of the **Website Address** field. The **Formula Workshop – Format Formula Editor – Hyperlink Text** window opens.

**Note**

The **Formula** button changes color when data has been added to the **Website Address** field. For more information about the **Formula** button, see the Crystal Reports online help.
5. In the work area, enter the following string as shown below:

'http://$b1$/link?table=OITM&key='+(DOC1.ItemCode)

**Note**

In this example, the string includes a reference to the OITM table in order to create the drilldown to the Item Master Data window. You can insert references to other tables in SAP Business One to create drilldowns to other windows. <DOC1> means the first subtable of a main sales or purchasing document. For example, INV1 is the first subtable of the A/R invoice table (OINV), and PCH1 is the first subtable of A/P invoice table (OPCH).

6. In the toolbar, choose the Save and Close button.

7. In the Format Editor window, choose the OK button.

**Syntax and Rules for Defining Tokens**

When defining tokens for use in SAP Business One, you must follow the following rules:

- Parameter names must start with an alphanumeric character or an underscore (_).
- The at sign (@) is reserved for SAP Business One tokens and must follow the parameter name with no space between them.
  
  For example, “My Parameter@” means that this parameter is specific for SAP Business One.
- An SQL statement usually follows the at sign (@), with no space after the at sign (@).
• The general syntax for creating SAP Business One tokens is:

```plaintext
<Parameter Name>@ SELECT ... FROM ... WHERE
```

When you are creating tokens, the `SELECT` command is not always mandatory for all SAP Business One tables. For example, `SELECT` is not mandatory for the `OCRD` (business partners) and `OACT` (G/L accounts) tables. For an example where `SELECT` is not applied, see Business Partner Selection Criteria.

• A parameter name (that is, token) may include another parameter name. This means that a second parameter may depend on a first parameter. For example, a state parameter depends on a country parameter. If you do not choose a country, the state dropdown list has no data. If you choose United States as the country, the states of the United States appear in a State dropdown list.

The syntax must include the first parameter name including the at sign (`@`), as in the examples below. The first statement lists all countries, while the second statement calls “Country”. For the second statement to work, you must have a parameter called `Country`.

**Examples**

```plaintext
Country@SELECT distinct Country FROM OCST
State@SELECT code, name FROM OCST WHERE (Country = '@Country')
```

• The `DocKey@` token is mandatory in a Crystal Reports `.rpt` file that you want to use as a layout. The `DocKey@` token is used to identify the current active document. SAP Business One populates its value when you preview or print a layout.

When you apply the `DocKey@` token, in the Select Expert window, you need to specify a filter condition, such as:

```plaintext
{OINV.DocEntry}={DocKey@}
```

If the `DocKey@` token does not exist, create a new parameter with the following settings:

- In the Name field, enter `DocKey@
- In the Type dropdown list, select Number
- In all other fields, leave the default settings

**Note**

For more information about the Select Expert window, see the Crystal Reports online help.

• The `ObjectId@` token is recommended for inclusion in Crystal Reports layouts that you want to assign to multiple sales and purchasing documents. For example, you can include the `ObjectId@` token if you want to include dynamic titles that change according to different document types. However, this token is optional in a Crystal Reports `.rpt` file that you want to use as a layout for one document type:

The `ObjectId@` token provides specific document-type information.

If the `ObjectId@` token does not exist, create a new parameter with the following settings:

- In the Name field, enter `ObjectId@
- In the Type dropdown list, select Number
- In all other fields, leave the default settings
Note

For more information about Crystal Reports layouts, see Creating New Crystal Reports Layouts.

Recommendation

We recommend that you do not use the ONLY keyword in Crystal Reports layouts that you want to set as master layouts for multiple sales and purchasing document types.

- The UserCode@ parameter is an optional token that is recommended for inclusion only in Crystal Reports layouts where you want to display the currently logged on SAP Business One user code, such as “manager”. The parameter type is String. This token is only for layouts; you cannot use it in reports.

- The FolioPref@ and FolioNum@ parameters are optional tokens that are recommended for inclusion only in Crystal Reports layouts in which you want to display a Folio prefix and a Folio number. SAP Business One populates them with the Folio prefix and Folio number you assign to the document for the first printing. SAP Business One prompts users to enter the Folio prefix and Folio number in some legal documents for the first printing. The values are taken for the subsequent printing. These parameters are available only for Mexico, Chile, Costa Rica, and Guatemala.

Dropdown Lists and Choose from List Icons

If the SQL query part of a parameter name (token) does not specify which column to select from database, such as aaa@SELECT * from OITM, SAP Business One provides a field with a standard Choose from List icon that opens a window with a list, in this case a list of existing items.

If the token specifies columns, such as bbb@SELECT code, name FROM OCST, SAP Business One provides a dropdown list control.

If two SELECT columns are specified, the first one is used as dropdown list’s key, and the second column is used as descriptions for the dropdown list.

More Token SQL Code Examples

The table below provides SAP Business One SQL token examples and descriptions.

<table>
<thead>
<tr>
<th>SAP Business One SQL Token</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;parameter_name&gt;@SELECT * FROM OPRJ</td>
<td>This expression returns all projects whose name starts with “World”.</td>
</tr>
<tr>
<td>WHERE PrjName LIKE 'World%'</td>
<td></td>
</tr>
<tr>
<td>&lt;parameter_name&gt;@SELECT CurrCode FROM OCRN</td>
<td>This expression returns all currency codes defined in SAP Business One except for the Canadian dollar.</td>
</tr>
<tr>
<td>WHERE ISOCurrCod &lt;&gt; 'CAD'</td>
<td></td>
</tr>
<tr>
<td>&lt;parameter_name&gt;@SELECT * FROM ODSC</td>
<td>This expression returns all U.S. banks defined in SAP Business One.</td>
</tr>
<tr>
<td>WHERE CountryCod = 'US'</td>
<td></td>
</tr>
</tbody>
</table>
Working with Parameters

In the Crystal Reports window, in the Field Explorer pane on the right, right-click Parameter Fields and select New. The Create New Parameter window appears.

The following table provides a list of parameter types and their related control types as they appear in SAP Business One:

<table>
<thead>
<tr>
<th>Parameter Type</th>
<th>Control Type</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boolean</td>
<td>Checkbox</td>
<td>Fixed values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• True</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• False</td>
</tr>
<tr>
<td>Currency</td>
<td>Edit box with a calculator</td>
<td></td>
</tr>
<tr>
<td>Date</td>
<td>Calendar-type date picker; that is, an edit box with a calendar</td>
<td></td>
</tr>
<tr>
<td>Date Time</td>
<td>Calendar-type date picker; that is, an edit box with a calendar</td>
<td>Note: Because SAP Business One does not have a time control, this parameter provides a default time of 00:00.</td>
</tr>
<tr>
<td>Number</td>
<td>Edit box with a calculator</td>
<td></td>
</tr>
<tr>
<td>String</td>
<td>Edit box</td>
<td></td>
</tr>
<tr>
<td>Time</td>
<td>Not supported</td>
<td></td>
</tr>
</tbody>
</table>
List of Values Options

Values can be defined as one of the following:

- **Static**
  
  Recommended. A static prompt is one that always contains the same values. For example, if your parameter prompts for a country value, you could create a static prompt because the country list represents a set of values that does not change often. If the token syntax is applied to the parameter name, the option values are dynamically populated for this parameter.
  
  Provides the following options:

  ![Note]
  
  This option provides a field with a *Choose from List* button if *Allow multiple values* is set to *False*, but if you set this value to *True*, it provides a *Browse* button that opens a dialog box with multiple data selection options.

  - Simple Parameters (Display options)
  - Hard-coded list of values such as Customer/Vendor/Lead
  - For complex dynamic values

  ![Note]
  
  If you include a token in the parameter name, SAP Business One fetches the data list from the database dynamically.

- **Dynamic**
  
  Not recommended. The values of a dynamic prompt are retrieved from the data source and are not stored within the report. For example, if you are prompting for customer name, you could create a dynamic prompt because the names in your customer database probably change frequently.

  ![Recommendation]
  
  You can get the data dynamically and directly from database, but the static type with token and SQL statement provide a better way to get the option list because the user can filter by adding a *WHERE* clause in the SQL part of the parameter name. For example, regarding *Bind to DB Field only*, the customized filter is not allowed.

You can always set the *List of Values* type to *Static*. You can either enter fixed values or Crystal Reports reads data from the database using the SQL code in the parameter name.

**Value and Description Fields**

The values that you enter in the *Value* fields appear for selection in SAP Business One selection criteria dialog boxes.
Value Options and Settings

In the Create New Parameter or Edit Parameter window, you can define settings for value options. See the table below or for more information about these values and settings, see the Crystal Reports 2008 online help.

<table>
<thead>
<tr>
<th>Value Option</th>
<th>SAP Business One Control Type</th>
<th>Setting Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show on (Viewer) Panel</td>
<td>n/a</td>
<td>Determines the Parameter Panel options in Crystal Reports Viewer:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Do not show</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Editable (default)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Read only</td>
</tr>
<tr>
<td>Prompt Text</td>
<td>n/a</td>
<td>Appears in the SAP Business One control as a UI string providing an instruction to the user, such as “Enter a value”.</td>
</tr>
<tr>
<td>Prompt With Description Only</td>
<td>n/a</td>
<td>Fixed values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• True – Prompts the user with only a description</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• False (default) – Prompts the user with a value and its description</td>
</tr>
<tr>
<td>Optional Prompt</td>
<td>n/a</td>
<td>Set this to True if you want to allow the user to bypass entering a value for this parameter. Set this to False if the parameter is mandatory.</td>
</tr>
<tr>
<td>Default Value</td>
<td>n/a</td>
<td>Add a value to this field if you want a default to appear when the program prompts your users to select a value. If the user does not change it, the default value is applied.</td>
</tr>
<tr>
<td>Allow custom values</td>
<td>Not supported</td>
<td>n/a</td>
</tr>
<tr>
<td>Allow multiple values</td>
<td>Browse button that can pop up a new window to allow user to select multiple values</td>
<td>Fixed values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• True</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• False</td>
</tr>
<tr>
<td>Value Option</td>
<td>SAP Business One Control Type</td>
<td>Setting Descriptions</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Allow discrete values</td>
<td>Dropdown list</td>
<td>User can select only one singular value.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>If you have <em>Allow multiple values</em> selected, you will be able to select more than one discrete value for your parameter field, though those discrete values will continue to function singularly as opposed to a range value. You can choose discrete values for your parameter field after you choose the <em>Refresh Report Data</em> command.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Fixed values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• True (default)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• False</td>
</tr>
<tr>
<td>Allow range values</td>
<td>From/To fields</td>
<td>Fixed values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• True – Provides From and To dropdown lists</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• False – Provides a Choose from List icon</td>
</tr>
<tr>
<td>Min length</td>
<td>n/a</td>
<td>Value/From</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Restricts values, depending on the type. For example, if the type is String, this value becomes “Min Length”. If the type is Date, the value becomes “From”. If the type is number/currency, the value becomes “Min value”.</td>
</tr>
<tr>
<td>Max length</td>
<td>n/a</td>
<td>Similar to above.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Restricts values, depending on the type. For example, if the type is String, this value becomes “Max Length”. If the type is Date, the value becomes “To”. If the type is number/currency, the value becomes “Max value”.</td>
</tr>
<tr>
<td>Edit mask</td>
<td>n/a</td>
<td>n/a</td>
</tr>
</tbody>
</table>
Saving Crystal Reports .rpt Files

It is in the Save or Save As option in the Add-ins menu that you define your Crystal Reports .rpt file as a report or a layout. When you save an .rpt file using this menu, the report or layout is saved to the SAP Business One database.

**Prerequisite**
- You have superuser permissions in SAP Business One.

**Procedure**

**Note**
If you want to save a Crystal Reports .rpt file to your local computer, in the Crystal Reports window, choose File → Save or File → Save As. If you decide later that you want to save the .rpt file to SAP Business One, you can import it using the Import wizard. For more information, see Importing Reports or Importing Layouts Created with the Crystal Reports Software.

To save your .rpt file:

1. In the toolbar, choose Add-ins → SAP Business One → Save or Save As.

**Note**
If you are not logged on to SAP Business One, the Log On window appears. Enter your details and choose the OK button.

2. In the Save As window:
a. In the *Name* field, enter a name for the `.rpt` file.
b. Select one of the following *Type* radio buttons:

- **Report**
  
  The report is saved to the *Lost Reports* folder in the *Report and Layout Manager* window.

- **Layout**
  
  In the *Select Type* list, select a type.

c. In the *Select Type* list, select a type.
d. Choose the OK button. You can now access the file in the Report and Layout Manager window, in the Lost Reports folder. For more information, see Lost Reports Folder or Creating a New Report Folder in the Main Menu.

**Running Reports Created with the Crystal Reports Software**

If you save the .rpt file as a report as described in the previous section, you can run it in SAP Business One.

To run a report created with the Crystal Reports software, do one of the following:

- Run the report from the Report and Layout Manager window:
  a. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.
  b. In the Report and Layout Manager window, in the navigation pane on the left, drill down to the report you want to run and select it.

  **Note**
  If you have not assigned an imported report to a folder, it may be in the Lost Reports folder.
  c. In the work area on the right, choose the Run Report button. The relevant selection criteria dialog box appears.
  d. In the selection criteria dialog box, select the criteria you want to appear in the report and choose the OK button.

The report appears in Crystal Reports Viewer.

  **Note**
  For more information about the viewing reports, see Viewing Crystal Reports Layouts and Reports in SAP Business One.

- Run the report from its module and folder location in the SAP Business One Main Menu.

  **Note**
  For more information, see Running Reports Created with the Crystal Reports Software in SAP Business One.

**Viewing Layouts**

If you save the .rpt file as a layout, you can preview it in SAP Business One.

  **Note**
  For more information about previewing, see Working with Preview and Printing Options in SAP Business One.

  **Note**
  For more information about creating Crystal Reports layouts, see Creating New Crystal Reports Layout.

**Editing Reports**

To edit a report created with the Crystal Reports software:
1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.

2. In the Report and Layout Manager window, in the navigation pane on the left, drill down to the report you want to edit.

3. In the work space on the right, choose the Edit button.

   The Crystal Reports software opens to the report you have selected and you can make any required changes.

4. In the menu bar, do one of the following:
   - Choose Add-ins → SAP Business One → Save to save the changes to the report in the SAP Business One database.
   - Choose Add-ins → SAP Business One → Save As to save the updated report with a new file name in the SAP Business One database.
   - Choose File → Save to save the changes in your local computer.
   - Choose File → Save As to save the changes save the updated report with a new file name in your local computer.

5. In the window that opens, choose the Report radio button.

6. Choose the OK button.

   Note

   Each report that you open for editing appears in a separate Crystal Reports window.
Deleting Reports

**Note**

Only users who have superuser permissions in SAP Business One can delete reports in SAP Business One.

**CAUTION**

You cannot delete a system PLD-type report that is provided with the core product.

To delete a report:

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.
2. In the Report and Layout Manager window, in the navigation pane on the left, drill down to the report you want to delete.
3. In the work space on the right, choose the **Delete** button.

Creating New Crystal Reports Layouts

To create a new Crystal Reports layout:

1. Follow the instructions for creating a new report, [Creating a New Report](#), including [Connecting to a Data Source](#).
2. In the Crystal Reports software, after you have connected to a data source and opened a blank report, you can design a layout for a report or marketing document.

**Recommendation**

For more information about creating and formatting layouts in the Crystal Reports software, see the Crystal Reports online help.
Note
You can create the layout for one marketing document and apply this layout to another marketing document. When you view the layout for the latter marketing document, SAP Business One automatically redirects you to the tables relevant to that document and displays the correct data, although the layout itself contains the table information relevant to the former marketing document.

For example, you create a layout with the tables OINV, INV1, and so on, which are relevant for an A/R invoice and you apply the layout to a sales order. When you view the layout in sales orders, SAP Business One redirects you to the tables ORDR, RDR1, and so on, which are relevant to sales orders.

To avoid the automatic redirection, do the following:

After you add tables for the layouts in the Database Expert window, rename the tables with the postfix "_ONLY".

CAUTION
It is important to note that a Crystal Reports .rpt file that you want to define as a layout in SAP Business One must contain a parameter with the DocKey@ token. For more information, see Working with Selection Criteria Tokens.

3. Save your Crystal Reports layout according to the instructions in the section Saving Crystal Reports .rpt File.

Editing Crystal Reports Layouts

To edit a Crystal Reports layout:

1. To open a Crystal Reports layout, do one of the following:
   a. Open the layout in the Report and Layout Manager window:
      i. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.
      ii. In the Report and Layout Manager window, in the navigation pane on the left, drill down to the document type of the layout you want to edit.
      iii. In the work space on the right, select the Crystal Reports layout you want to edit and choose the Edit button.

   Note
   If you want to edit a PLD-type layout, select a PLD layout and choose the Edit button. The Print Layout Designer opens. For more information, see the Print Layout Designer documentation http://service.sap.com/smb/sbocustomer/documentation

   b. Open the layout in the relevant window
      i. From SAP Business One Main Menu, navigate to the relevant window.
      ii. In the toolbar, Click the Edit button.
      iii. Select the layout you want to edit and choose the Edit button.

2. The Crystal Reports software opens to the Crystal Reports layout you have selected and you can make any required changes.

3. In the menu bar, do one of the following:
Choose **Add-ins → SAP Business One → Save** to save the changes to the layout in the SAP Business One database.

Choose **Add-ins → SAP Business One → Save As** to save the updated layout with a new file name in the SAP Business One database.

Choose **File → Save** to save the changes in your local computer.

Choose **File → Save As** to save the changes save the updated layout with a new file name in your local computer.

4. In the window that opens, select the **Layout** radio button.

5. Choose the **OK** button.

*Note*

Each Crystal Reports layout that you open for editing appears in a separate Crystal Reports window.
Deleting Crystal Reports Layouts

Note

Only users who have superuser permissions in SAP Business One can delete Crystal Reports layouts in SAP Business One.

To delete a Crystal Reports layout:

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.

2. In the Report and Layout Manager window, in the navigation pane on the left, drill down to the document type of the layout you want to delete.

3. In the work space on the right, choose the Delete button.

Note

You cannot delete a PLD-type layout that is provided in the SAP Business One core product.
Logging Off from a Data Source

To log off from a data source, in the Crystal Reports menu bar, choose Add-ins → SAP Business One → Log Off.
Setting Authorizations for Reports Created with the Crystal Reports Software

You can define permissions for users in SAP Business One who will be running reports created in the Crystal Reports software.

Procedure

To set authorizations for a report:

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.

2. In the Report and Layout Manager window, in the pane on the left, navigate to the report whose permissions you want to define and choose the Set Authorization button.
3. In the Authorizations window, on the left side of the window, select the user whose permissions you want to define.

4. In the Subject column, select the report whose permissions you want to set for the user you selected in step 3.

5. In the Authorizations column, in the dropdown list select one of the following:
   - Full Authorization
   - No Authorization

   **Note**
   You cannot apply read-only permissions to reports created with the Crystal Reports software.

6. Choose the Update button, then choose the OK button.

   **Note**
   For more information about setting authorizations in SAP Business One, see the online help.
Developing Crystal Reports Solutions Using the SDK API

The SAP Business One DI API enables you to create add-ons that import Crystal Reports .rpt files either as reports or layouts. The ReportsLayoutService object lets you do the following:

• Import an .rpt file as a layout and assign it to one or more document types. For more information, see Creating Master Layouts.

• Import an .rpt file as a report, which adds the report to the Lost Reports folder of the Report and Layout Manager window. You can then assign the report a menu entry and permissions.

Note

For more information about SAP Business One APIs, see the SDK Help Center.

Procedure

To access the SDK Help Center:


2. Under BUSINESS ONE KNOWLEDGE CENTER, click the link of the SAP Business One release version you want.

3. Click the SDK Help Center link.
Creating Master Layouts

Using the Crystal Reports software, you can create master layouts for different sales and purchasing document types in SAP Business One.

You define a Crystal Reports layout as a master layout during the import process. During the import process, you can apply the layout to specific document types and reports.

**Note**

You can define and apply master layouts only when you import .blp package files that contains layouts. You cannot define a single imported .rpt file as a master layout. For more information, see Importing Layouts Created with the Crystal Reports Software.
Exporting Reports Created with the Crystal Reports Software

SAP Business One lets you export reports that you create in the Crystal Reports software. When you export one or more reports, SAP Business One creates a .blp package file containing the reports. SAP Business One .blp package files may contain any number of reports.

**Note**

You can export only reports created with the Crystal Reports software, but not standard SAP Business One reports.

**Note**

SAP Business One exports all reports in .blp package files. Even if you export a single .rpt file, it is included in a .blp package file.

When you import a .blp package file, SAP Business One automatically detects whether the contents are reports or layouts created with the Crystal Reports software. For more information about exporting Crystal Reports layouts, see [Exporting Layouts Created with the Crystal Reports Software](#).

**Note**

When you export a batch of .rpt files, they must all be of the same type; that is, they must all be either reports or layouts.

**Prerequisites**

- You have installed the following:
  - SAP Business One 8.8
  - Crystal Reports software, version for the SAP Business One application
- You have superuser permissions in SAP Business One.
- You have created one or more reports with the Crystal Reports software that are ready to be exported.

**Procedure**

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.

2. In the Report and Layout Manager window, in the navigation pane on the left, navigate to the module and folder containing the report or reports that you want to export and select a report.
The report details appear in the work area on the right.

**Note**

You can export only reports created with the Crystal Reports software, and not standard SAP Business One reports. If the report code in the *Report Code* field starts with `RCRI`, then it is a report that has been created with the Crystal Reports software.

3. In the work area on the right, choose the *Export* button. The *Report and Layout Export Wizard* window opens.
4. To start the export process, choose the *Next* button.

5. In the *Report Selection* window, in the *Name* column, click the arrows to open the nodes containing the reports you want to export.
   
   To open all the nodes at once, choose the *Expand* button.
   
   To close all the nodes at once, choose the *Collapse* button.
6. Select the checkboxes of the reports you want to export.

7. To continue, choose the Next button.

8. In the Package Details window, enter the following:
   - Package name
   - Description – Entering a description is optional. The description that you enter here will be visible to the user who imports the file into SAP Business One.
   - Folder location – Specify a location on your computer where you want to save the .b1p file.
9. To complete the export, choose the Finish button.

An SAP Business One .b1p package file is created. The Export Complete window appears, displaying the export details.

10. To exit the wizard, choose the Close button.
Exporting Layouts Created with the Crystal Reports Software

SAP Business One lets you export Crystal Reports layouts that you have created with the Crystal Reports software. When you export one or more Crystal Reports layouts, SAP Business One creates a .blp package file containing the Crystal Reports layouts. SAP Business One .blp package files may contain any number of Crystal Reports layouts.

**Note**
You can export only layouts created with the Crystal Reports software, but not standard SAP Business One reports.

**Note**
SAP Business One exports all layouts in .blp package files. Even if you export a single .rpt file, it is included in a .blp package file.

When you import a .blp package file, SAP Business One automatically detects whether the contents are layouts or reports created with the Crystal Reports software. For more information about exporting reports, see Exporting Reports Created with the Crystal Reports.

**Note**
When you export a batch of .rpt files, they must all be of the same type; that is, they must all be either reports or layouts.

Prerequisites

- You have installed the following:
  - SAP Business One 8.8
  - Crystal Reports software, version for the SAP Business One application
- You have superuser permissions in SAP Business One.
- You have created one or more Crystal Reports layouts that are ready to be exported. For each layout that you want to define as a master layout, you need to include the `ObjectId@` SQL token. For more information about working with the `ObjectId@` SQL token, see Syntax and Rules for Defining Tokens.

Procedure

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.
2. In the Report and Layout Manager window, in the navigation pane on the left, navigate to the module and document type of the Crystal Reports layout or layouts that you want to export.

   A list of layouts that are defined for the document type appears in the work area on the right.

   The layouts for SAP Business One add-ons are located in both the Add-On Layouts folder and the document type folder of the SAP Business One module.

   **Note**
   You can export only Crystal Reports layouts, but not standard SAP Business One layouts that have been created in the PLD. You can check the layout type in the work area on the right, on the Layouts tab, in the Type column.
In the work area on the right, choose the Export button. The Report and Layout Export Wizard window opens.

3. To start the export process, choose the Next button.

4. In the Layout Selection window, in the Name column, click the arrows to open the nodes of the document types for the layouts you want to export.
The add-on layouts appear in the *Add-On Layouts* folder.

To open all the nodes at once, choose the *Expand* button.

To close all the nodes at once, choose the *Collapse* button.

5. Select the checkbox to the left of each layout you want to export.

6. To continue with the export process, choose the *Next* button.

7. In the *Package Details* window, enter the following:
   - Package name
   - Description – Entering a description is optional. The description that you enter here will be visible to the user who imports the file into SAP Business One.
   - Folder location – Specify a location on your computer where you want to save the .b1p file.
8. To complete the export, choose the *Finish* button.

An SAP Business One .b1p package file is created. The *Export Complete* window appears, displaying the export details.

9. To exit the wizard, choose the *Close* button.
Importing Reports Created with the Crystal Reports Software

You can import reports created with the Crystal Reports software into SAP Business One with the report and layout import wizard.

Prerequisites

- You know the file name and extension (file type) regarding the file you want to import.

  **Recommendation**
  If the file is a Crystal Reports .rpt file, verify with the provider whether the file is a layout or report.

  **Note**
  When you import an SAP Business One .b1p file, SAP Business One automatically detects whether the file contains reports or layouts.

- You have superuser permissions in SAP Business One.

Importing Report-Type Crystal Reports .rpt Files

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.

2. In the Report and Layout Manager window, on the bottom right, choose the *Import* button.
   The Report and Layout Import Wizard window opens.
3. Choose the Next button.
4. In the Select Import File window, choose the Browse button.
5. In the Open dialog box, navigate to the .rpt file you want to import. Choose the Open button.
6. Under Content Type, select the Report radio button.

**Note**

If you are not sure whether the .rpt file is a report or a layout, verify this with the person who provided the file.

**Note**

If you want to import a layout, see Importing Layouts Created with the Crystal Reports Software.
7. Choose the *Browse* (…) button. The *Menu Selection Form* window opens.

8. In the *Menu Selection Form* window, select the SAP Business One report folder where you want to save the new report file.
9. Choose the OK button to complete your selection and to return to the Select Import File window in the Report and Layout Import Wizard.

**Note**

You can create a new folder in the Main Menu of SAP Business One. For more information, see Creating a New Report Folder in the Main Menu.

10. In the Select Import File window, choose the Finish button.

If the .rpt file that you want to import already exists in SAP Business One, the RPT File window opens.

Do one of the following:

- To overwrite the existing .rpt file with the new .rpt file, select the Overwrite radio button, then choose the OK button.

  ![RPT File Overwrite](image)

  **CAUTION**

  When you select the Overwrite option, the previous .rpt file is permanently deleted, even if it is located in a different folder or module.

- To keep the existing .rpt file and continue with the import of the new .rpt file, select the Rename radio button, enter a new name in the field, and choose the OK button.

  ![RPT File Rename](image)

- In the Import Summary window, a summary containing the import results appears. To exit the wizard, choose the Close button.
Creating a New Report Folder in the Main Menu

You can create new folders in the SAP Business One Main Menu in either of the following ways:

- During the layout import process. This method is described below.
- In the SAP Business One Organize My Menu or Add to My Menu window. For more information, see the SAP Business One online help.

Note

You cannot create a new folder in the Administration folder.
Procedure

To create a new folder in the SAP Business One Main Menu during the layout import process:

1. In the Menu Selection Form window, select a module or folder where you want to create a new folder.

   ![Menu Selection Form](image)

2. Choose the New Folder button.

3. In the Create New Folder dialog box, enter a name for the new folder.

   ![Create New Folder](image)

4. Choose the Add button.

5. In the Menu Selection Form window, choose the OK button. The new folder appears in the SAP Business One folder you selected in step 1.
Importing an SAP Business One .b1p Package File Containing Reports

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.

2. In the Report and Layout Manager window, on the bottom right, choose the Import button. The Report and Layout Import Wizard window opens.
3. Choose the Next button.

4. In the Select Import File window, choose the Browse button.

5. In the Open dialog box, navigate to the SAP Business One .b1p package file you want to import. Choose the Open button.

**Note**

SAP Business One automatically detects whether a SAP Business One .b1p package file contains layouts or reports.

A description appears in the Description text box if a description has been added in the export process.

**Note**

For more information about the export process, see Exporting Reports Created with the Crystal Reports Software.
6. Choose the **Next** button.

The **Select Reports for Import** window appears with a list of reports contained in the `.b1p` package file that you specified in the previous step. In the **Overwrite** column, a checkbox appears for each report that already exists in SAP Business One with the same file name. You can choose whether to rename or overwrite each of these files in a later step.

Add-on layouts appear in the relevant documents.

To open all the nodes at once, choose the **Expand** button.

To close all the nodes at once, choose the **Collapse** button.
7. In the Select Reports for Import window, select the checkbox to the left of each report you want to import.

8. In the Overwrite column, select the checkbox for each report file that you want to overwrite with the new imported file of the same name.

   **Note**

   If you do not select the Overwrite checkbox for a report, you will be prompted to rename it later on.

9. In the Authorization column, select one of the following permission levels for each report you are importing:

   - Full – All users are assigned full authorization for the report.
   - None – Only superusers have full authorization for the report.

   **Note**

   For more information about authorizations in SAP Business One, see the online help.

10. Choose the Finish button.

    The Rename window opens if you have not selected the Overwrite checkbox in step 8 for one or more reports that you want to import.

    a. In the Rename window, in the New Name column, enter a new file name for each report that appears in the Existing Name column.
How to Work with Crystal Reports in SAP Business One

b. Choose the OK button.

The Import Summary window appears with a summary of the import details.
11. To exit the wizard, choose the Close button.
Importing Layouts Created with the Crystal Reports Software

You can import Crystal Reports layout files into SAP Business One with the Report and Layout Import Wizard.

In the layout import process, you can define any Crystal Reports layout as a master layout. This means that you can apply one Crystal Reports layout to several document types. You can define master layouts only during the process of importing .b1p package files.

Recommendation

After you define a master layout but before you start working with its defined document types, make sure the layout appears properly. If not, make the required corrections to the layout.

Prerequisites

- You know the following information regarding the file you want to import:
  - File name and extension (file type).
    - If the file is an .rpt file, verify with the provider whether the file is a layout or report.

Note

When you import an SAP Business One .b1p file, SAP Business One automatically detects whether the file contains reports or layouts.

- You have superuser permissions in SAP Business One.

Importing Layout-Type Crystal Reports .rpt Files

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.
2. In the Report and Layout Manager window, on the bottom right, choose the **Import** button. The Report and Layout Import Wizard window opens.

3. Choose the **Next** button.

4. In the Select Import File window, choose the **Browse** button.
5. In the Open dialog box, navigate to the layout-type .rpt file you want to import. Choose the Open button.

6. Under Content Type, select the Layout radio button.

   Note
   If you are not sure whether the .rpt file is a report or a layout, verify this with the person who provided the file.

   Note
   If you want to import a report, see Importing Reports Created with the Crystal Reports Software.

7. Choose the Browse (…) button. The List of Report Type window opens.
8. In the *List of Report Type* window, select the document type or report to which you want to apply the layout.

Select the relevant document type folder for add-on layouts. After import, the add-on layouts appear in both the *Add-On Layouts* folder and the relevant folder of the SAP Business One module.

**Note**

In the *List of Report Type* window, the list of document types that appears is similar to the document list in the Print Layout Designer (PLD). There is an entry for each specific document type, such as A/R invoice (items).

9. Choose the *Choose* button to complete your selection and to return to the *Select Import File* window in the *Report and Layout Import Wizard*.

10. Choose the *Finish* button.

In the *Import Summary* window, a summary appears, containing the import results.
11. To exit the wizard, choose the Close button.

**Importing SAP Business One .b1p Package Files Containing Layouts**

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.
2. In the Report and Layout Manager window, on the bottom right, choose the Import button. The Report and Layout Import Wizard window opens.

3. Choose the Next button.
4. In the Select Import File window, choose the Browse button.

5. In the Open dialog box, navigate to the SAP Business One .b1p package file you want to import. Choose the Open button.

**Note**

SAP Business One automatically detects whether a SAP Business One .b1p package file contains layouts or reports.

A description appears in the Description text box if a description has been added in the export process.

**Note**

For more information about the export process, see Exporting Layouts Created with the Crystal Reports Software.
6. Choose the *Next* button.

The *Select Layouts for Import* window appears with a list of reports contained in the `.b1p` package file you specified in the previous step. In the *Overwrite* column, a checkbox appears for each layout file that already exists in SAP Business One with the same file name. You can choose whether to rename or overwrite each of these files in a later step.

To open all the nodes at once, choose the *Expand* button.

To close all the nodes at once, choose the *Collapse* button.
7. In the Select Layouts for Import window, select the checkbox to the left of each layout you want to import.

The add-on layouts appear in both the Add-On Layouts folder and the relevant folder of the SAP Business One module after import.

For each of these layouts, when you select the checkbox in the Master Layout column, the Set Master Layout window opens.
How to Work with Crystal Reports in SAP Business One

© SAP AG 2010

1. In the Set Master Layout window, select the checkboxes to the left of the document types to which you want to apply the master layout.

2. If the layout name exists, a checkbox appears in the "Overwrite" column. To overwrite the existing layout, select the checkbox. If you do not select the checkbox, you are prompted to rename the imported layout when you choose the "OK" button.

   ![Set Master Layout Window]

   a. In the Set Master Layout window, select the checkbox for each document type to which you want to apply the imported layout.

   **Note**

   After you have completed the import process, the layouts you import appear in the Report and Layout Manager window. Before you start working with the defined document types, make sure the layout appear properly. If not, make the required corrections to the layout.

   To overwrite a layout file that already exists in SAP Business One with the same name, select the checkbox in the Overwrite column.

   b. Choose the OK button.

   If you have not selected the checkbox in the Select Layouts for Import window or in the Set Master Layout window, in the Overwrite column for a layout, the Rename window opens immediately after you choose the OK button in the Set Master Layout window.

   i. In the Rename window, in the New Name column, enter a new file name for each Crystal Reports layout that appears in the Existing Name column.
ii. Choose the OK button.

7. Choose the Finish button.

The Import Summary window appears with a summary of the import details.
8. To exit the wizard, choose the Close button.
Report and Layout Manager Window

You can use the Report and Layout Manager window to do the following:

- View and change the details of reports created with the Crystal Reports software
- View the details of:
  - Layouts created with the Crystal Reports software
  - Standard SAP Business One layouts (PLD type)
- Access the export wizard for exporting Crystal Reports layouts and reports
- Access the import wizard for importing Crystal Reports layouts and reports
- Access the Crystal Reports software to edit or create Crystal Reports layouts and reports
- Set authorizations for reports created with the Crystal Reports software
- Run reports created with the Crystal Reports software
- Work with print sequences

Prerequisite

- For following actions, you need to have superuser permissions in SAP Business One:
  - Exporting Crystal Reports layouts and reports
  - Importing Crystal Reports layouts and reports
  - Deleting Crystal Reports layouts and reports

Note

The Import, Export, and Delete buttons are inactive for users who do not have superuser permissions.

Interface Details

To open the Report and Layout Manager window, from the SAP Business One Main Menu, choose:

Administration → Setup → General → Report and Layout Manager
Opening Screen

The following is the opening screen of the Report and Layout Manager window:

The table below provides a description of the UI elements of the screen shown above.

<table>
<thead>
<tr>
<th>UI Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Navigation pane</td>
<td>Use the navigation pane on the left to drill down to SAP Business One modules and their contents, including Crystal Reports layouts and reports, and standard SAP Business One reports and layouts (PLD type).</td>
</tr>
<tr>
<td>Import button</td>
<td>Opens the import wizard. For more information, see Importing Reports Created with the Crystal Reports Software and Importing Layouts Created with the Crystal Reports Software.</td>
</tr>
<tr>
<td>Refresh button</td>
<td>Refreshes the layouts.</td>
</tr>
</tbody>
</table>

Document Type Layout and Print Sequence Details

To view the details of specific document type layouts and print sequences, in the navigation pane, drill down and select the document type whose details you want to view.
Layouts Tab

In the work area on the right, the Layouts tab appears.

The following table provides descriptions of the UI elements of the Layouts tab shown above.

<table>
<thead>
<tr>
<th>UI Element</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Layout ID</strong></td>
<td>The ID code for the layout. The naming convention is:</td>
</tr>
<tr>
<td></td>
<td>&lt;document_type_acronym&gt;_&lt;sequential_number&gt;</td>
</tr>
<tr>
<td><strong>Layout Name</strong></td>
<td>The layout name.</td>
</tr>
<tr>
<td><strong>Type</strong></td>
<td>The type of layout.</td>
</tr>
<tr>
<td><strong>Language</strong></td>
<td>The assigned language.</td>
</tr>
<tr>
<td><strong>ID</strong></td>
<td>The same ID code as shown in the Layout ID column above.</td>
</tr>
<tr>
<td><strong>Name</strong></td>
<td>The layout name as shown in the Layout Name column above.</td>
</tr>
<tr>
<td><strong>Layout Type</strong></td>
<td>The layout type as shown in the Type column above.</td>
</tr>
<tr>
<td><strong>Last Updated</strong></td>
<td>The date that the layout was last updated.</td>
</tr>
<tr>
<td><strong>Author</strong></td>
<td>The name of the author who created the layout. If the author name of layout is System, the layout is a system layout and cannot be changed. A system layout may be PLD type, or Crystal Reports type.</td>
</tr>
<tr>
<td><strong>Status</strong></td>
<td>Displays Active or Inactive. For system layouts, the status cannot be changed.</td>
</tr>
<tr>
<td><strong>B1 Version</strong></td>
<td>The SAP Business One release number.</td>
</tr>
<tr>
<td><strong>CR Version</strong></td>
<td>The Crystal Reports release number.</td>
</tr>
<tr>
<td><strong>Description</strong></td>
<td>Layout description.</td>
</tr>
</tbody>
</table>
### UI Element Description

| **Printer** | The printer assigned to the layout. |
| **1st page printer** | The printer for the first page of a layout. |
| **No. of copies** | The number of printed copies. |
| **Localization** | The localization assigned to the layout. |
| **Language** | The assigned language, as shown in the Language column above. You can change the language for non-system layouts. |
| **Use foreign currency** | Select this checkbox to indicate where to apply foreign currency. This setting is available only for PLD-type layouts. |
| **Export** | Choose this button to export a Crystal Reports layout using the export wizard. You cannot export PLD-type layouts so the button is inactive for these. |
| **Note** | This button is active only if the logged-on user has superuser permissions. |
| **Edit** | Choose this button to change the layout details. If the layout is a Crystal Reports type, the Crystal Reports software opens. If the layout is PLD-type, Print Layout Designer (PLD) opens. |
| **Delete** | Choose this button to delete a layout that is not a system layout. |
| **Note** | This button is active only if the logged-on user has superuser permissions. |
| **Import** | Choose this button to import .rpt and .blp files into SAP Business One using the import wizard. |
| **Note** | This button is active only if the logged-on user has superuser permissions. |

### Printing Seqs Tab

In the work area on the right, select the **Printing Seqs** tab. For more information about the buttons and fields on this tab, see [Working with Printing Sequences](#).
Report Details

To view the details of specific reports, in the navigation pane, drill down and select the report whose details you want to view.

You can change the information in the following fields:

- **Name**
- **Author**
- **Status**
- **Printer**
- **1st Page Printer**
- **No. of Copies**
- **Menu Location**
Lost Reports Folder

In the Report and Layout Manager window, in the navigation pane on the left, at the bottom of the hierarchy tree is the Lost Reports folder. This folder contains:

- Any .rpt files that you have saved in SAP Business One from the Add-ins menu in the Crystal Reports software.
- Currently unassigned .rpt files whose folders may have been deleted.

Note

For information about creating new report folders in the SAP Business One Main Menu, see Creating a New Report Folder in the Main Menu.

Add-On Layouts Folder

The Add-On Layouts folder appears in the Report and Layout Manager window, in the navigation pane on the left, at the bottom of the hierarchy tree. This folder contains the layouts for SAP Business One add-ons. Each add-on layout is located in both the Add-On Layouts folder and the folder of the SAP Business One module.

For example, the Crystal Reports layout for the FA history sheet is located in the following folders:

- Add-On Layouts → Fixed Assets
- Financials → Fixed Assets → Asset History Sheet

Note

For information about creating new report folders in the SAP Business One Main Menu, see Creating a New Report Folder in the Main Menu.
Viewing Crystal Reports Layouts and Reports in SAP Business One

You can view Crystal Reports layouts and reports in SAP Business One using Crystal Reports Viewer. Crystal Reports Viewer is fully integrated in the SAP Business One core product and provides the following functionality:

- Exporting reports
- Working with report parameters
- Showing and hiding the group tree
- Navigating to specific report pages
- Searching for text

**Note**
You do not need to install Crystal Reports Viewer as a separate procedure. It is an integral part of the SAP Business One core product.

**Note**
When an SAP Business One language is not supported in Crystal Reports Viewer, English is displayed. The following languages are supported in Crystal Reports Viewer:

- Chinese-Simplified
- Chinese-Traditional
- German
- Dutch
- English
- Spanish
- French
- Italian
- Japanese
- Korean
- Brazilian Portuguese
- Swedish

**Prerequisites**
You have done one or more of the following:

- You have imported a Crystal Reports layout or report into SAP Business One. For more information, see Importing Reports and Importing Layouts Created with the Crystal Reports Software.
- In the Crystal Reports window, in the menu bar, you have chosen Add-ins → Save or Save As to save a report in SAP Business One. For more information, see Saving Crystal Reports .rpt File.
Viewing Layouts or Reports

Procedure
To view a report created with the Crystal Reports software, do one of the following:

- Run the report from the Report and Layout Manager window. For more information, see Running Reports Created with the Crystal Reports Software in SAP Business One.
- Run the report from the SAP Business One Main Menu:
  a. From the SAP Business One Main Menu, choose the module, folder, and report you want to view.
  b. In the report selection criteria window, enter the required data.
  c. Choose the OK button.
     The report is displayed in Crystal Reports Viewer.

Procedure
To view a layout created with the Crystal Reports software:

1. In SAP Business One, open a document whose layout you want to view.
2. Choose one of the following menu paths:
   - File → Preview
     Choose this option if the default layout of the document type has been defined with a Crystal Reports-type layout.
   - File → Preview Layouts
     Choose this option if you want to select a non-default layout that has been created with the Crystal Reports software.

The document appears in Crystal Reports Viewer.

Note
You can create the layout for one marketing document and apply this layout to another marketing document. When you view the layout for the latter marketing document, SAP Business One automatically redirects you to the tables relevant to the latter marketing document and displays the correct data, although the layout contains the table information relevant to the former market document.

For example, you create a layout with the tables OINV, INV1, and so on, which are relevant for an A/R invoice, and you apply the layout to a sales order. When you view the layout in sales orders, SAP Business One redirects you to the tables ORDR, RDR1, and so on, which are relevant to sales orders.

To avoid the automatic redirection, do the following:
1. Open the layout.
2. In the Database Expert window, rename the tables with the postfix “_ONLY”.
3. Save the layout. For more information, see Saving Crystal Reports .rpt Files.

When you are viewing a report or layout in Crystal Reports Viewer, you can perform the following:

- Exporting Crystal Reports Layouts or Reports
- Displaying and Hiding the Parameter Panel
- Filtering Report Parameters
• Displaying the Group Tree
• Navigating to Report Pages
• Searching for Text
• Changing the Zoom Factor

You can perform the following on reports only:
• Displaying and Hiding the Parameter Panel
• Filtering Report Parameters
• Displaying the Group Tree

Exporting Crystal Reports Layouts or Reports

You can export a Crystal Reports layout or report to your computer as any of the following file types:
• Crystal Reports (*.rpt)
• PDF (*.pdf)
• Microsoft Excel [97-2003] (.xls)
• Microsoft Excel [97-2003] Data-Only (.xls)
• Microsoft Word [97-2003] (.doc)
• Microsoft Word [97-2003] - Editable (.rtf)
• Rich Text Format (RTF) (*.rtf)
• XML (*.xml)

Procedure

To export a layout or report:

1. In Crystal Reports Viewer, in the toolbar, click the Export Report icon.
2. In the Export Report window, navigate to the folder on your computer where you want to save your report.
3. In the File name field, enter a name for the file you are exporting.
4. In the Save as type dropdown list, select a file type.
5. Choose the Save button.

Working with the Parameter Panel

In the Crystal Reports Viewer Parameter Panel, you can modify the report parameters to create different report views.

Displaying and Hiding the Parameter Panel

To display or hide the Parameter Panel, in the toolbar, click the Toggle Parameter Panel icon.
Filtering Report Parameters

You can change the view of a report by filtering its parameters in Crystal Reports Viewer.

Note

You cannot filter the parameters of every report type. Some report types may not have different parameters available for different views. In these cases, to filter parameters, you need to rerun the report in SAP Business One.

You can access the report parameters through the following:

- Parameter dropdown list
- Advanced dialog box

Parameter Value List

You can modify the report parameters in the list of parameter values in the Parameter Panel, including the following possible types:

- Dropdown list: Select an option.
- Field: Enter a valid value.

To change the parameter values of a report, do one of the following:

- To work with the values in the list in the Parameter Panel:
  a. For each parameter you want to modify, select or enter a valid value.
  b. Choose the Apply button at the top of the Parameter Panel.
     The new report view appears in the workspace on the right.

Note

If a parameter is not defined as mandatory, you can delete it in the Parameter Panel by selecting it and then choosing the Delete button at the top of the Parameter Panel.

- To work with the values in an advanced dialog box, do the following for each parameter in the list in the Parameter Panel:
  a. In the Parameter Panel, click in the field or dropdown box of a parameter. An icon appears to the right of the field or dropdown box.
  b. Click the icon. The Enter Parameter Values dialog box appears.
  c. Do one of the following:
     - If the parameter values appear in a dropdown list, select an option.
     - If a parameter field appears, enter a valid value.
  d. Choose the OK button.
  e. At the top of the Parameter Panel, click the Apply icon.
Displaying the Group Tree
To show or hide the Group Tree panel:

1. In the toolbar, click the Group Tree icon.
2. In the Group Tree panel, select a group.
   A red box appears in the report to highlight the relevant data in the report.

Navigating to Report Pages
To navigate to different pages of a report, do one of the following:

- In the toolbar, click any of the following icons:
  - Go to First Page
  - Go to Previous Page
  - Go to Next Page
  - Go to Last Page
- In the toolbar, in the page number field, enter a page number.

Searching for Text
To search for text in the report:

1. In the toolbar, click the Find Text icon.
2. In the Find Text dialog box, in the Find What field, enter the text you want to find.
3. Choose the Find Next button. To find multiple instances of the text, choose the Find Next button as many times as you require.

Changing the Zoom Factor
To change the zoom factor in a report:

1. In the toolbar, click the Zoom icon.
2. In the list, select an option.

To define a zoom factor that does not appear in the list:

1. In the Zoom list, select Customize. The Zooming dialog box appears.
2. In the field, enter a value from 25 to 400.
3. Choose the OK button.
Working with Preview and Printing Options in SAP Business One

You can preview and print Crystal Reports layouts and reports in the following SAP Business One menus:

- **File menu**
  Lets you preview and print Crystal Reports layouts that you have imported into SAP Business One. For more information about importing Crystal Reports layouts, see [Importing Layouts Created with the Crystal Reports Software](#).

- **Tools menu**
  Lets you preview Crystal Reports layouts and reports that you have not imported into SAP Business One.

### File Menu Options

In the SAP Business One toolbar, in the **File** menu, you can select any of the following preview and printing options:

<table>
<thead>
<tr>
<th>File</th>
<th>Edit</th>
<th>View</th>
<th>Data</th>
<th>Goto</th>
<th>Modules</th>
<th>In</th>
</tr>
</thead>
<tbody>
<tr>
<td>Close</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Save as Draft</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Page Setup...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Preview...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Preview Layouts...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Print...</td>
<td>Ctrl+P</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Select Layout and Print...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Print Sequence...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Send</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Export</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Launch Application...</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Lock Screen</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Exit</td>
<td>Ctrl+Q</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- **Preview**
  Provides a preview window displaying a printing preview of the open document or report based on the default layout. If the document or report has a default Crystal Reports layout, the print preview opens in Crystal Reports Viewer. Alternatively, you can click the ![icon](#) icon in the toolbar. For more information about Crystal Reports Viewer, see [Viewing Crystal Reports Layouts and Reports in SAP Business One](#).

- **Preview Layouts**
  Opens the *Choose Layout* window, displaying both Crystal Reports layouts and PLD-type layouts. You can select a layout other than the default layout to view the open document or report. If you select a Crystal Reports layout, the document or report is displayed in Crystal Reports Viewer. Alternatively, you can click the ![icon](#) icon in the toolbar. For more information about Crystal Reports Viewer, see [Viewing Crystal Reports Layouts and Reports in SAP Business One](#).
• **Print**
  
  Opens the standard Microsoft Windows *Print* dialog box. Alternatively, you can click the 🗽 icon in the toolbar.

• **Select Layout and Print**
  
  Opens the *Choose Layout* window, displaying both Crystal Reports layouts and PLD-type layouts. You can select any layout to print the open document or report. The standard Microsoft Windows *Print* dialog box opens. Alternatively, you can click the 🗽 icon in the toolbar.

• **Print Sequence**
  
  Opens the *Print Sequence* window. Select a print sequence that you want to apply for an open sales or purchasing document, and choose the *Print* button. For more information about printing sequences, see [Working with Printing Sequences](#).

  **Note**
  
  When you choose *File* → *Print Sequence*, the *Print Sequence* window opens, but there are no items listed if no print sequence has been created for the specific open sales or purchasing document.

  **Note**
  
  For more information about printing in SAP Business One, see *Printing in SAP Business One* in the online help.

### Tools Menu Option

You can preview Crystal Reports layouts and reports that you have not yet imported into SAP Business One.

**Procedure**

1. In the SAP Business One toolbar, in the *Tools* menu, select *Preview External Crystal Report*:

2. In the *Preview External Crystal Report* window, choose the *Browse* button.
3. In the *Select Crystal Reports*.rpt File window, specify a file on your computer that you want to preview in SAP Business One.

4. Choose the *Open* button.

5. In the *Preview External Crystal Report* window, choose the *OK* button.

6. The external report appears in Crystal Reports Viewer.

**Note**

You may need to enter selection criteria the same way as you would when you run a report created with the Crystal Reports software. For more information, see [Running Reports Created with the Crystal Reports Software in SAP Business One](#).
Working with Printing Sequences

You can create printing sequences for reports, layouts, and documents in SAP Business One. You can apply printing sequences to the following:

- Standard SAP Business One reports and layouts
- Layouts that you have created or edited using Print Layout Designer (PLD)
- Crystal Reports layouts

Prerequisite

- Only users who have superuser permissions in SAP Business One can perform the following actions regarding printing sequences:
  - Create a printing sequence
  - Modify a printing sequence
  - Delete a printing sequence

Creating Printing Sequences

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager. The Report and Layout Manager window opens.

2. In the navigation pane on the left side of the window, select a document type for which you want to create a new printing sequence, such as A/R Invoice (Items).

3. In the work area on the right side of the window, select the Printing Seqs tab.
4. On the *Printing Seqs* tab, choose the *New* button. The *Sequence Details* window opens.

![Sequence Details Window](image)

5. In the *Sequence Details* window, do the following:

   a. In the *Sequence Name* field at the top of the window, enter a printing sequence name.

   ![Note]
   
   The document type for the new sequence is indicated in the *Document Type* field at the top right of the window. This field cannot be edited. If you want to create a printing sequence for a different document type, close the *Sequence Details* window and in the navigation pane on the left, select a different document type.

   b. In the *Object* column, in the dropdown list, select a document subtype for which you want to create this new printing sequence.

   c. In the *Layout* column, select a layout.

   d. In the *Copies* column, enter the number of copies that you want to be printed each time this sequence is used.

   e. In the *Printer* column, select a printer that you want to print each time this printing sequence is used.

   f. In the *1st Page Printer* column, select a printer for printing the first page of the printing sequence.

   ![Note]
   
   This step is optional. If you do not select a first-page printer, the printer you select in the *Printer* column prints the entire sequence including the first page.

   g. Choose the *Add* button.

The new printing sequence appears in the table on the *Printing Seqs* tab.
Running Printing Sequences

To run a printing sequence:

1. Open the document whose printing sequence you want to run.
2. In the SAP Business One toolbar, choose File → Print Sequence.
3. In the Print Sequence window, select a sequence and choose the Print button.
4. The document is printed according to the defined printing sequence.

Modifying Printing Sequences

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager. The Report and Layout Manager window opens.
2. In the navigation pane on the left side of the window, select a document type for which you want to modify a printing sequence, such as A/R Invoice (Items).
3. In the work area on the right side of the window, select the Printing Seqs tab.
4. On the Printing Seqs tab, select the row of the printing sequence you want to modify and choose the Edit button. The Sequence Details window opens.
5. In the Sequence Details window, change the required parameters.
6. Choose the Update button, then choose the OK button. The printing sequence now includes the revised parameters.
Deleting Printing Sequences

CAUTION
Deleting a printing sequence is irreversible.

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager. The Report and Layout Manager window opens.

2. In the navigation pane on the left side of the window, select a document type for which you want to delete a printing sequence.

3. In the work area on the right side of the window, select the Printing Seqs tab.

4. On the Printing Seqs tab, select the row of the printing sequence you want to delete and choose the Delete button.

   The printing sequence is permanently deleted from SAP Business One.
Running Reports Created with the Crystal Reports Software in SAP Business One

You can run reports created with the Crystal Reports software in SAP Business One in any of the following ways:

- From the Report and Layout Manager window
- From the SAP Business One Main Menu
- From the Crystal Reports software

When you run a report created with the Crystal Reports software, the report appears in Crystal Reports Viewer. For more information about Crystal Reports Viewer, see Viewing Crystal Reports Layouts and Reports in SAP Business One.

Running Reports from the Report and Layout Manager Window

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.

2. In the navigation pane on the left, drill down to the report you want to run.

   **Note**
   
   You can perform this step on reports created with the Crystal Reports software only. You run standard PLD-type reports from the SAP Business One Main Menu. For more information, see Running Reports from the Main Menu.

3. Choose the Run Report button. The report is displayed in Crystal Reports Viewer.
Running Reports from the Main Menu

1. From the SAP Business One Main Menu, choose the module, folder, and report you want to generate.
   
   If the report selection criteria window is associated with the Crystal Reports software, a Crystal Reports icon appears to the left of the report name.

2. In the report selection criteria window, select the relevant parameters for the report you want to generate and choose the OK button.

Running Reports from the Crystal Reports Software

1. In the Crystal Reports software, you have opened a report.

2. In the toolbar, choose Add-ins → SAP Business One → Preview in SAP Business One.

3. The report opens in SAP Business One.
Copyrights, Trademarks, and Disclaimers

© Copyright 2010 SAP AG. All rights reserved.

The current version of the copyrights, trademarks, and disclaimers at [http://service.sap.com/smb/sbocustomer/documentation](http://service.sap.com/smb/sbocustomer/documentation) is valid for this document.