Advanced Excel

TeachUcomp, Inc.
...it’s all about you
Copyright:

Copyright © 2012 by TeachUcomp, Inc. All rights reserved. This publication, or any part thereof, may not be reproduced or stored in a retrieval system, or transmitted in any form or by any means, electronic, mechanical, recording, photocopying, or otherwise, without the express written permission of TeachUcomp, Inc.

For PDF manuals, TeachUcomp, Inc. allows the owner of the PDF manual to make up to 2 additional copies of the PDF manual that the owner may place on up to 2 additional non-shared computer hard drives for ease of use when using the accompanying CD-ROM tutorials. TeachUcomp, Inc. also grants unlimited personal printing rights to the owner, strictly limited to the purposes of not-for-profit personal or private education or research.

The unauthorized reproduction or distribution of this copyrighted work is illegal. Criminal copyright infringement, including infringement without monetary gain, is investigated by the FBI and is punishable by up to five years in federal prison and a fine of $250,000.

Trademark Acknowledgements:


Disclaimer:

While every precaution has been made in the production of this book, TeachUcomp, Inc. assumes no responsibility for errors or omissions. Nor is any liability assumed for damages resulting from the use of the information contained herein. These training materials are provided without any warranty whatsoever, including, but not limited to, the implied warranties of merchantability or fitness for a particular purpose. All names of persons or companies in this manual are fictional, unless otherwise noted.
Welcome to Teachucomp, Inc.’s Advanced Excel course. This class caps the student’s knowledge of Microsoft Excel, one of the most popular spreadsheet programs available today. This class is designed to give the student a firm grasp of the advanced concepts in Excel.

Excel is an excellent program to learn, as the skills that we learn in Excel apply to many other programs as well, especially Access. It is the recommended starting point for learning database programs as it contains some basic database functionality and features.

Excel is a multi-featured spreadsheet program in which you can create powerful spreadsheets that can manipulate numbers and store data for you. It is a very powerful program, and has many advanced features that can automate and simplify your work. Whether you want it to create charts, spreadsheets, or data sources, Excel can assist you in accomplishing your tasks quickly and easily.

This class will focus on the advanced concepts of the Excel program. You will learn how to create and manage data models, use PivotTables and PivotCharts, create Power View visualizations and use the PowerPivot Add-in in Excel Professional Plus 2013, use slicers, apply security, and set up macros.
## Table of Contents

### Chapters/Lessons:  Page(s):  
**CHAPTER 30 - Data Models - 2013**  
30.1 - Creating a Data Model from External Relational Data  6  
30.2 - Creating a Data Model from Excel Tables  7  
30.3 - Relating Tables in a Data Model  8  
30.4 - Managing a Data Model  9  
Data Models -  2013- Actions  10-12  
Data Models -  2013- Exercises  13-15  
**CHAPTER 31 - PivotTables and PivotCharts - 2013**  
31.1 - Creating Recommended PivotTables  17-18  
31.2 - Manually Creating a PivotTable  19  
31.3 - Creating a PivotChart  20  
31.4 - Manipulating a PivotTable or PivotChart  20-21  
31.5 - Changing Calculated Value Fields  21  
31.6 - Formatting PivotTables  22  
31.7 - Formatting PivotCharts  22  
31.8 - Setting PivotTable Options  22  
31.9 - Sorting and Filtering Using Field Headers  23  
PivotTables and PivotCharts - 2013- Actions  24-29  
PivotTables and PivotCharts - 2013- Exercises  30  
**CHAPTER 32 - PivotTables and PivotCharts - 2010:2007**  
32.1 - Creating PivotTables and PivotCharts  32  
32.2 - Manipulating a PivotTable  32-33  
32.3 - Changing Calculated Value Fields  33  
32.4 - Applying PivotTable Styles  34  
32.5 - Creating a PivotChart  34  
32.6 - Setting PivotTable Options  34  
32.7 - Sorting and Filtering PivotTable Data  35  
PivotTables and PivotCharts - 2010:2007- Actions  36-39  
PivotTables and PivotCharts - 2010:2007- Exercises  40  
**CHAPTER 33 - PowerPivot**  
33.1 - Starting PowerPivot  42  
33.2 - Managing the Data Model  42  
33.3 - Calculated Columns and Fields  43-44  
33.4 - Creating KPIs  45  
33.5 - Creating and Managing Perspectives  46  
33.6 - PowerPivot PivotTables and PivotCharts  47  
PowerPivot- Actions  48-51  
PowerPivot- Exercises  52-54  
**CHAPTER 34 - Power View**  
34.1 - Starting Power View  56  
34.2 - Adding Report Visualizations  56-57  
34.3 - Changing the Layout of Report Visualizations  57  
34.4 - Using Undo and Redo in Power View  57  
34.5 - Formatting the Power View Sheet  58  
34.6 - Creating Multiples in a Chart  58  
Power View- Actions  59-61  
Power View- Exercises  62-63  
**CHAPTER 35 - Slicers and Timelines**  
35.1 - Inserting and Deleting Slicers  65  
35.2 - Modifying Slicers  65  
35.3 - Inserting and Deleting Timelines  66  
35.4 - Modifying Timelines  66  
Slicers and Timelines- Actions  67-68  
Slicers and Timelines- Exercises  69  
**CHAPTER 36 - Security Features**  
36.1 - Unlocking Cells  71  
36.2 - Worksheet Protection  72  
36.3 - Workbook Protection  72  
36.4 - Password Protecting Excel Files- 2013  73  
36.5 - Password Protecting Excel Files- 2010:2007  73-74  
Security Features - Actions  75-77  
Security Features - Exercises  78  
**CHAPTER 37 - Making Macros**  
37.1 - Recording Macros  80  
37.2 - Running and Deleting Recorded Macros  81  
37.3 - The Personal Macro Workbook  81  
Making Macros - Actions  82  
Making Macros - Exercises  83  
**Glossary of Functions Index**  84-86  
**Glossary of Functions**  87-189  
**Keyboard Shortcuts**  190-193  

©TeachUcomp, Inc.  
Advanced Excel
CHAPTER 30 -
Data Models - 2013

30.1 - Creating a Data Model from External Relational Data

30.2 - Creating a Data Model from Excel Tables

30.3 - Relating Tables in a Data Model

30.4 - Managing a Data Model
30.1- Creating a Data Model from External Relational Data:

You can use a data model in Excel to store multiple tables of information that can then be used a data source for PivotTables and PivotCharts, as well as Power View reports. Note that the choice to add a selected table to a data model is given when manually creating a PivotTable in Excel 2013. This effectively allows you to use a relational data source within Excel. Note that you can also create relationships between the data within the table fields in Excel, relating them as needed for your reports. Also note that the tables that are saved into the data model within an Excel workbook can be tables within Excel worksheets or external data tables.

In this lesson you will learn how to create a data model within Excel 2013 from external relational data, such as a Microsoft Access database file. If you choose to import multiple tables from a relational data source, the data model will be created automatically.

To import multiple tables from an external relational data source, click the “Data” tab within the Ribbon and then click the desired button within the “Get External Data” button group. For example, if you wanted to add tables from an Access database to the data model in Excel, click the “From Access” button within the “Get External Data” button group on the “Data” tab within the Ribbon. In this case, the “Select Data Source” dialog box will appear. You can then use this dialog box to navigate to and then select the desired Access database file to open. Then click the “Open” button to continue.

Next, you will see the “Select Table” dialog box appear. To enable the selection of multiple tables from the database file, be sure to check the “Enable selection of multiple tables” checkbox at the top of this dialog box. Then check the checkboxes next to the tables that you wish to add to the data model in the Excel workbook. Then click the “OK” button to continue.

You will then see the “Import Data” dialog box appear within Excel. You can then choose the option that you prefer within the “Select how you want to view this data in your workbook” section. You can then choose where to place the imported data by selecting an option within the “Where do you want to put the data?” section. Note that depending upon the choice made in the first section, not every option will necessarily be available within the latter section. Once you have decided where to place the type of data that you want to import, click the “OK” button to finish.

At that point, Excel will create the data connection and then import the necessary data into the data model within Excel. It will also create any visual representation of the data that you chose to import and place it into the selected location.
30.2- Creating a Data Model from Excel Tables:

You can also manually add multiple Excel tables to manually create a data model within a workbook which you can then use as the data source for PivotTables, PivotCharts and Power View reports. Before you can do this, however, you must first create the necessary tables within Excel and ensure that the information is formatted as a table within the worksheets. Only table data that has been formatted as a table with a “Table Name” value that can be referenced can be added as a data source when adding tables to the data model. Also note, however, that the tables can be available within any opened workbook in Excel and do not necessarily need to be included within the workbook into which they will be added to the data model.

Once you have the tables opened and available in Excel, simply open the workbook where you want to include the tables within the data model. Then click the “Data” tab within the Ribbon. Then click the “Connections” button within the “Connections” button group on the “Data” tab to open the “Workbook Connections” dialog box. This dialog box normally displays workbook connections that are available to a workbook and where those connections are used within the workbook.

To add Excel tables to the data model within this dialog box, click the drop-down arrow button that appears to the right of the “Add…” button within the “Workbook Connections” dialog box. From the drop-down menu that appears, select the “Add to the Data Model…” command. When you do this, the “Existing Connections” dialog box will appear. Click the “Tables” tab within the “Existing Connections” dialog box to view a list of the available Excel tables within any opened workbooks. Select the desired table that you want to add to the data model, and then click the “Open” button to add that table as the initial table to the data model within the workbook. You can then see the table reference shown within the “Workbook Connections” dialog box. You can then repeat this process, starting by clicking the “Add…” button’s drop-down menu again, to repeat the same steps to continue adding any other Excel tables that you would like to the data model. Once you have finished adding the necessary tables to the data model, click the “Close” button within the “Workbook Connections” dialog box to close it.

At that point, you can then select the data model as the desired data source when creating PivotTables and PivotCharts. Within the “Create PivotTable” or “Create PivotChart” dialog boxes, you can select the “Use an external data source” option button and then click the “Choose Connection…” button to open the “Existing Connections” dialog box. Here you can select the “Tables” tab and then click on the “Tables in Workbook Data Model” choice within the “This Workbook Data Model” shown. Then click the “Open” button to return to the “Create PivotTable” or “Create PivotChart” dialog boxes, where you can finish creating the desired objects.
30.3- Relating Tables in a Data Model:

When you add fields from multiple tables into a PivotTable or PivotChart, the data within the tables must be related for the resultant data within the PivotTable to make sense and be of any use. Note that if you create a data model from data tables in a relational database file, Excel can often create the needed relationships “behind the scenes” when it imports the data. For all other cases, the tables must be manually related.

If you add data fields from multiple tables within a data model to a PivotChart or PivotTable without first relating the tables, you will see a warning message appear within the task pane at the right side of the window informing you that “Relationships between tables may be needed.” You can click the “Create…” button that appears next to this message to open the “Create Relationship” dialog box where you can create the needed relationship between the two tables.

You can also create relationships between tables within a data model prior to adding any fields to the PivotTable or PivotChart. You can create multiple relationships between data tables, if needed, so as to avoid any warning message prompts when adding fields to PivotTables or PivotCharts within the workbook. To create a relationship, simply click the “Relationships” button within the “Data Tools” button group on the “Data” tab in the Ribbon. In the “Manage Relationships” window that appears, click the “New…” button to open the “Create Relationship” dialog box.

In the “Create Relationship” dialog box, you must select the names of the two tables that you wish to relate and also select the fields within each that share the common data. Within one of the tables, the field with the shared, or common, data must contain only unique values. This is the “Primary” field. Within the other table with the field that contains the shared data, the values within the field may or may not be unique. This is the “Foreign” field. Start by selecting the name of the table with the “Foreign” field values from the “Table” drop-down menu. Then select the name of the “Foreign” field within that table from the “Column (Foreign)” drop-down menu. Then select the name of the table with the “Primary” field values from the “Related Table” drop-down. Then select the name of the “Primary” field within that table that contains the common data with unique values from the “Related Column (Primary)” drop-down. Then click the “OK” button to create the relationship between the two tables.

When you create relationships within this window, the relationship created needs to be either a “one to one” relationship or a “one to many” relationship between the fields. Excel will not allow you to create any other type of relationship between table fields. For users who are familiar with the concepts of relating tables within a relational database, this should come as no surprise. However, if you are unfamiliar with relational database table design, this may seem perplexing. While a full discussion of relational database table design is not within the scope of this particular tutorial, it is discussed at length in the “Mastering Access Made Easy” tutorial by TeachUcomp, Inc. In essence, you can only create a relationship between fields within tables where the values contained within one field in one of the tables are unique. This field can then be joined to associated data within another table where the values may or may not be unique.

After creating the relationship it will appear within the “Manage Relationships” window. Note that you can continue creating additional relationships between tables if needed in this window by simply clicking the “New…” button and repeating the process. Also note that you can only have one active table relationship between tables that are used within a PivotTable or PivotChart. If you have multiple relationships between two tables that are available, only one of the relationships can be active at a time. The active relationship is shown within the “Manage Relationships” window. You can select an active relationship shown in this window and then click the “Deactivate” button to deactivate it. You can also select an inactive relationship and then click the “Activate” button to enable it again. You can also select a relationship in this window and click the “Delete” button to delete a relationship or click the “Edit…” button to edit the relationship.

©TeachUcomp, Inc.  Advanced Excel 8
30.4- Managing a Data Model:

After you have created a data model, you may need to return to it at some later point in time to remove tables or external data connections from the data model if you no longer need them. You can also set the properties of the data connections within a workbook’s data model. In this lesson we will examine some of the tasks that can be involved with managing a workbook’s data model.

You can manage the tasks related to your workbook’s data model by using the buttons within the “Connections” button group on the “Data” tab in the Ribbon. If your workbook uses external data connections, you can click the “Refresh All” button to refresh all of the external data connections and access the most recent data available.

You can click the “Connections” button to open the “Workbook Connections” dialog box to manage the data connections within your workbook’s data model. You can then select a specific connection shown in the listing at the top of this dialog box to manage it. You can click the “Remove” button at the right side of this dialog box to remove a selected connection from the workbook. You will then need to click the “OK” button in the warning message box that appears to remove the selected connection.

You can click the “Properties” button for a selected connection to open the “Connection Properties” dialog box. You can set the properties of the data connections on the “Usage” tab within this dialog box. Under the “Refresh control” section, you can set the refresh rate for the selected data connection. This can save time in that it can allow the selected connection’s data to be automatically refreshed within the workbook. Below that section, you can use the “OLAP Server Formatting” and “OLAP Drill Through” sections to set any additional parameters for OLAP data sources. When you are finished setting any properties you want in this dialog box, click the “OK” button to apply them.

You can also manually refresh a selected data connection by clicking the “Refresh” button at the right side of the “Workbook Connections” dialog box to manually refresh the data connection.

You can also view the area within a workbook where a selected data connection is used. To do this, first select the connection whose usage you want to inspect. Then click the “Click here to see where the selected connections are used” hyperlink in the section at the bottom of the dialog box. The cells within the selected worksheet that make use of the data connection will then be displayed in a list within the area at the bottom of the dialog box. You can then click one of the listings shown to select those cells within the workbook.

When you are finished using the “Workbook Connections” dialog box to manage your workbook connections, click the “Close” button to close it.
CREATING A DATA MODEL FROM EXTERNAL RELATIONAL DATA:

1. To import multiple tables from an external relational data source, click the “Data” tab within the Ribbon.
2. Then click the button associated with the data type to import within the “Get External Data” button group.
3. The “Select Data Source” dialog box will appear.
4. Use this dialog box to navigate to and then select the desired database file to open.
5. Then click the “Open” button to continue.
6. To enable the selection of multiple tables from the database file, be sure to check the “Enable selection of multiple tables” checkbox at the top of the “Select Table” dialog box that appears.
7. Then check the checkboxes next to the tables that you wish to add to the data model.
8. Then click the “OK” button to continue.
9. You will then see the “Import Data” dialog box appear within Excel.
10. Choose the preferred option within the “Select how you want to view this data in your workbook” section.
11. You can then choose where to place the imported data by selecting an option within the “Where do you want to put the data?” section. Note that depending upon the choice made in the first section, not every option will necessarily be available within the latter section.
12. Click the “OK” button to finish.
13. At that point, Excel will create the data connection and import the data into the data model. It will also create any visual representation of the imported data and place it into the selected location.

CREATING A DATA MODEL FROM EXCEL TABLES:

1. Once you have the Excel tables to add to the data model opened and available in Excel, open the workbook where you want to include the tables within the data model.
2. Click the “Connections” button within the “Connections” button group on the “Data” tab in the Ribbon to open the “Workbook Connections” dialog box.
3. To add Excel tables to the data model within this dialog box, click the drop-down arrow button that appears to the right of the “Add…” button within the “Workbook Connections” dialog box.
4. From the drop-down menu that appears, select the “Add to the Data Model…” command.
5. In the “Existing Connections” dialog box that appears, click the “Tables” tab within the “Existing Connections” dialog box to view a list of the available Excel tables within any opened workbooks.
6. Select the desired table that you want to add to the data model, and then click the “Open” button to add that table as the initial table to the data model within the workbook. You can then see the table reference shown within the “Workbook Connections” dialog box.
7. You can then repeat steps 4 through 7 above to continue adding any other Excel tables that you would like to the data model.
8. Once you have finished adding the necessary tables to the data model, click the “Close” button within the “Workbook Connections” dialog box to close it.
9. You can then select the data model as the data source when creating PivotTables and PivotCharts.
10. Within the “Create PivotTable” or “Create PivotChart” dialog boxes, select the “Use an external data source” option button and then click the “Choose Connection…” button to open the “Existing Connections” dialog box.
11. Select the “Tables” tab and then click the “Tables in Workbook Data Model” choice within the “This Workbook Data Model” shown.
12. Then click the “Open” button to return to the “Create PivotTable” or “Create PivotChart” dialog boxes, where you can finish creating the desired objects.
RELATING TABLES IN A DATA MODEL:

1. Note that if you create a data model from data tables in a relational database file, Excel can often create the needed relationships “behind the scenes” when it imports the data. For all other cases, the tables must be manually related.

2. If you add data fields from multiple tables within a data model to a PivotChart or PivotTable without first relating the tables, you will see a warning message appear within the task pane at the right side of the window informing you that “Relationships between tables may be needed.” You can click the “Create…” button that appears next to this message to open the “Create Relationship” dialog box where you can create the needed relationship between the two tables.

3. You can also create relationships between tables within a data model prior to adding any fields to the PivotTable or PivotChart. You can create multiple relationships between data tables, if needed, so as to avoid any warning message prompts when adding fields to PivotTables or PivotCharts within the workbook.

4. To create a relationship, simply click the “Relationships” button within the “Data Tools” button group on the “Data” tab in the Ribbon. In the “Manage Relationships” window that appears, click the “New…” button to open the “Create Relationship” dialog box.

5. In the “Manage Relationships” window that appears, click the “New…” button to open the “Create Relationship” dialog box.

6. In the “Create Relationship” dialog box, you must select the names of the two tables that you wish to relate and also select the fields within each that share the common data.

7. Within one of the tables, the field with the shared, or common, data must contain only unique values. This is the “Primary” field. Within the other table with the field that contains the shared data, the values within the field may or may not be unique. This is the “Foreign” field.

8. Select the name of the table with the “Foreign” field values from the “Table” drop-down menu.

9. Select the name of the “Foreign” field within that table from the “Column (Foreign)” drop-down menu.

10. Select the name of the table with the “Primary” field values from the “Related Table” drop-down.

11. Select the name of the “Primary” field within that table that contains the common data with unique values from the “Related Column (Primary)” drop-down.

12. Then click the “OK” button to create the relationship between the two tables.

13. After creating the relationship it will appear within the “Manage Relationships” window.

14. Note that you can continue creating additional relationships between tables if needed in this window by simply clicking the “New…” button and repeating the process in steps 6 through 12.

15. Also note that you can only have one active table relationship between tables that are used within a PivotTable or PivotChart. If you have multiple relationships between two tables that are available, only one of the relationships can be active at a time. The active relationship is shown within the “Manage Relationships” window.

16. You can select an active relationship shown in this window and then click the “Deactivate” button to deactivate it.

17. You can also select an inactive relationship and then click the “Activate” button to enable it again.

18. You can also select a relationship in this window and click the “Delete” button to delete a relationship or click the “Edit…” button to edit the relationship.
MANAGING A DATA MODEL:

1. You can manage the tasks related to your workbook’s data model by using the buttons within the “Connections” button group on the “Data” tab in the Ribbon.
2. If your workbook uses external data connections, you can click the “Refresh All” button to refresh all of the external data connections and access the most recent data available.
3. You can click the “Connections” button to open the “Workbook Connections” dialog box to manage the data connections within your workbook’s data model.
4. You can then select a specific connection shown in the listing at the top of this dialog box to manage it.
5. You can click the “Remove” button at the right side of this dialog box to remove a selected connection from the workbook.
6. You will then need to click the “OK” button in the warning message box that appears to remove the selected connection.
7. You can click the “Properties” button for a selected connection to open the “Connection Properties” dialog box.
8. You can set the properties of the data connections on the “Usage” tab within this dialog box.
9. Under the “Refresh control” section, you can set the refresh rate for the selected data connection. This can save time in that it can allow the selected connection’s data to be automatically refreshed within the workbook.
10. Below that section, you can use the “OLAP Server Formatting” and “OLAP Drill Through” sections to set any additional parameters for OLAP data sources.
11. When you are finished setting any properties you want in this dialog box, click the “OK” button to apply them.
12. You can also manually refresh a selected data connection by clicking the “Refresh” button at the right side of the “Workbook Connections” dialog box to manually refresh the data connection.
13. You can also view the area within a workbook where a selected data connection is used. To do this, first select the connection whose usage you want to inspect.
14. Then click the “Click here to see where the selected connections are used” hyperlink in the section at the bottom of the dialog box.
15. The cells within the selected worksheet that make use of the data connection will then be displayed in a list within the area at the bottom of the dialog box.
16. You can then click one of the listings shown to select those cells within the workbook.
17. When you are finished using the “Workbook Connections” dialog box to manage your workbook connections, click the “Close” button to close it.
EXERCISES
Data Models- 2013

Purpose:
1. To be able to create and manage a data model in Excel 2013.

Exercises:
1. Open up the Excel application.
2. Create a new blank workbook.
3. Enter the data into “Sheet1” of the new workbook as shown in the picture below.

<table>
<thead>
<tr>
<th>Salesperson ID</th>
<th>First Name</th>
<th>Last Name</th>
<th>Region</th>
<th>Order Date</th>
<th>Salesperson ID</th>
<th>Order Total</th>
<th>Region</th>
<th>State</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Sam</td>
<td>Smith</td>
<td>North</td>
<td>1/5/2012</td>
<td>1</td>
<td>550</td>
<td>North</td>
<td>Michigan</td>
</tr>
<tr>
<td>2</td>
<td>Jenny</td>
<td>White</td>
<td>East</td>
<td>8/5/2012</td>
<td>1</td>
<td>650</td>
<td>South</td>
<td>Texas</td>
</tr>
<tr>
<td>3</td>
<td>Sam</td>
<td>Black</td>
<td>South</td>
<td>11/5/2012</td>
<td>5</td>
<td>600</td>
<td>East</td>
<td>New York</td>
</tr>
<tr>
<td>4</td>
<td>Erin</td>
<td>Brown</td>
<td>West</td>
<td>10/5/2012</td>
<td>3</td>
<td>900</td>
<td>West</td>
<td>California</td>
</tr>
<tr>
<td>5</td>
<td>Joe</td>
<td>Smith</td>
<td>North</td>
<td>8/5/2012</td>
<td>4</td>
<td>550</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>8/5/2012</td>
<td>2</td>
<td>575</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>11/5/2012</td>
<td>1</td>
<td>600</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td>10/5/2012</td>
<td>3</td>
<td>1000</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Region</td>
<td>Department</td>
<td>Actual Expenses</td>
<td>Budgeted Expenses</td>
<td>Order Date</td>
<td>Region</td>
<td>State</td>
<td></td>
<td></td>
</tr>
<tr>
<td>North</td>
<td>Administration</td>
<td>35000</td>
<td>40000</td>
<td>11/5/2012</td>
<td>North</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>North</td>
<td>Marketing</td>
<td>110000</td>
<td>100000</td>
<td>10/5/2012</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>North</td>
<td>Human Resources</td>
<td>40000</td>
<td>40000</td>
<td>11/5/2012</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>South</td>
<td>Administration</td>
<td>35356</td>
<td>35000</td>
<td>9/5/2012</td>
<td>South</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>South</td>
<td>Marketing</td>
<td>99000</td>
<td>100000</td>
<td>11/5/2012</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>South</td>
<td>Human Resources</td>
<td>67896</td>
<td>40000</td>
<td>7/5/2012</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>East</td>
<td>Administration</td>
<td>32000</td>
<td>35000</td>
<td>8/5/2012</td>
<td>East</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>East</td>
<td>Marketing</td>
<td>103500</td>
<td>100000</td>
<td>11/5/2012</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>East</td>
<td>Human Resources</td>
<td>37850</td>
<td>40000</td>
<td>7/5/2012</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>West</td>
<td>Administration</td>
<td>38875</td>
<td>40000</td>
<td>8/5/2012</td>
<td>West</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>West</td>
<td>Marketing</td>
<td>95500</td>
<td>100000</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>West</td>
<td>Human Resources</td>
<td>45000</td>
<td>40000</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

5. Click the “Format as Table” button in the “Styles” button group on the “Home” tab within the Ribbon.
6. Select the “Table Style Light 1” choice from the drop-down menu that appears.
7. Ensure that there is a checkmark in the “My table has headers” checkbox in the “Format As Table” dialog box that appears, and then click the “OK” button within this dialog box to create the first table.
8. Type “Salespeople” into the “Table Name” field in the “Properties” button group of the “Design” tab in the “Table Tools” contextual tab within the Ribbon to name the table.
9. Select the cell range of A10:D22.
10. Click the “Format as Table” button in the “Styles” button group on the “Home” tab within the Ribbon.
11. Select the “Table Style Light 2” choice from the drop-down menu that appears.
12. Ensure that there is a checkmark in the “My table has headers” checkbox in the “Format As Table” dialog box that appears, and then click the “OK” button within this dialog box to create the first table.
13. Type “Budgets” into the “Table Name” field in the “Properties” button group of the “Design” tab in the “Table Tools” contextual tab within the Ribbon to name the table.
14. Select the cell range of F1:H20.
15. Click the “Format as Table” button in the “Styles” button group on the “Home” tab within the Ribbon.
16. Select the “Table Style Light 3” choice from the drop-down menu that appears.
17. Ensure that there is a checkmark in the “My table has headers” checkbox in the “Format As Table”
dialog box that appears, and then click the “OK” button within this dialog box to create the first table.
18. Type “Sales” into the “Table Name” field in the “Properties” button group of the “Design” tab in the
“Table Tools” contextual tab within the Ribbon to name the table.
19. Select the cell range of J1:K5.
20. Click the “Format as Table” button in the “Styles” button group on the “Home” tab within the Ribbon.
21. Select the “Table Style Light 4” choice from the drop-down menu that appears.
22. Ensure that there is a checkmark in the “My table has headers” checkbox in the “Format As Table”
dialog box that appears, and then click the “OK” button within this dialog box to create the first table.
23. Type “Regions” into the “Table Name” field in the “Properties” button group of the “Design” tab in the
“Table Tools” contextual tab within the Ribbon to name the table.
25. Click the “Accounting Number Format” button within the “Number” button group on the “Home” tab
within the Ribbon to format the selection as currency.
26. Select cell A7 to break your current cell selections.
27. Click the “Save” button within the Quick Access Toolbar to open the “Save As” backstage view.
28. Save the workbook to your computer’s “My Documents” folder with the file name of “Advanced Excel.”
29. Click the “Connections” button in the “Connections” button group on the “Data” tab within the Ribbon to
open the “Workbook Connections” dialog box.
30. Within the “Workbook Connections” dialog box, click the drop-down arrow to the right of the “Add…”
button and then select the “Add to the Data Model…” command to open the “Existing Connections”
dialog box.
31. Click the “Tables” tab within the “Existing Connections” dialog box.
32. Select the “Salespeople” table and then click the “Open” button.
33. Within the “Workbook Connections” dialog box, click the drop-down arrow to the right of the “Add…”
button and then select the “Add to the Data Model…” command to open the “Existing Connections”
dialog box.
34. Click the “Tables” tab within the “Existing Connections” dialog box.
35. Select the “Budgets” table and then click the “Open” button.
36. Within the “Workbook Connections” dialog box, click the drop-down arrow to the right of the “Add…”
button and then select the “Add to the Data Model…” command to open the “Existing Connections”
dialog box.
37. Click the “Tables” tab within the “Existing Connections” dialog box.
38. Select the “Sales” table and then click the “Open” button.
39. Within the “Workbook Connections” dialog box, click the drop-down arrow to the right of the “Add…”
button and then select the “Add to the Data Model…” command to open the “Existing Connections”
dialog box.
40. Click the “Tables” tab within the “Existing Connections” dialog box.
41. Select the “Regions” table and then click the “Open” button.
42. Click the “Close” button within the “Workbook Connections” dialog box to close it.
43. Click the “Relationships” button within the “Data Tools” button group on the “Data” tab within the Ribbon
to open the “Manage Relationships” dialog box.
44. Click the “New…” button at the right side of the “Manage Relationships” dialog box to open the “Create
Relationship” dialog box.
45. Select “Sales” from the “Table” drop-down field.
46. Select “Salesperson ID” from the “Column (Foreign)” drop-down field.
47. Select “Salespeople” from the “Related Table” drop-down field.
48. Select “Salesperson ID” from the “Related Column (Primary)” drop-down field.
49. Click the “OK” button within the “Create Relationship” dialog box to return to the “Manage Relationships”
   dialog box where the new relationship should now be shown within the listing of relationships.
50. Click the “New…” button at the right side of the “Manage Relationships” dialog box to open the “Create
   Relationship” dialog box.
51. Select “Salespeople” from the “Table” drop-down field.
52. Select “Region” from the “Column (Foreign)” drop-down field.
53. Select “Regions” from the “Related Table” drop-down field.
54. Select “Region” from the “Related Column (Primary)” drop-down field.
55. Click the “OK” button within the “Create Relationship” dialog box to return to the “Manage Relationships”
   dialog box where the new relationship should now be shown within the listing of relationships.
56. Click the “New…” button at the right side of the “Manage Relationships” dialog box to open the “Create
   Relationship” dialog box.
57. Select “Budgets” from the “Table” drop-down field.
58. Select “Region” from the “Column (Foreign)” drop-down field.
59. Select “Regions” from the “Related Table” drop-down field.
60. Select “Region” from the “Related Column (Primary)” drop-down field.
61. Click the “OK” button within the “Create Relationship” dialog box to return to the “Manage Relationships”
   dialog box where the new relationship should now be shown within the listing of relationships.
62. Click the “Close” button within the “Manage Relationships” dialog box.
63. Click the “Save” button within the Quick Access toolbar to save your changes.
64. You may close the workbook, if you would like to.
65. Keep this workbook, as you will need the information within it to perform the Exercises at the
   end of the following chapters within this manual! The Exercises should be completed in
   sequential order.
CHAPTER 31
PivotTables and PivotCharts- 2013

31.1- Creating Recommended PivotTables
31.2- Manually Creating a PivotTable
31.3- Creating a PivotChart
31.4- Manipulating a PivotTable or PivotChart
31.5- Changing Calculated Value Fields
31.6- Formatting PivotTables
31.7- Formatting PivotCharts
31.8- Setting PivotTable Options
31.9- Sorting and Filtering Using Field Headers
31.1- Creating Recommended Pivot Tables:

You can use the PivotTable feature of Excel to access some of the most powerful data analysis that Excel can provide. PivotTables allow you to organize massive amounts of data in more coherent and meaningful ways to extract from the data exactly what you want to know. Probably the most helpful feature of PivotTables is the ability to be reorganized quickly and easily to change what information they are displaying and calculating. When you create a PivotTable, you are comparing information in your worksheet and then calculating intersecting values of your choosing. In addition to the PivotTables you can also create PivotCharts, which use the data from PivotTables but display it in a graphic format.

The best way to learn how to use a PivotTable is to actually create one with which you can experiment and practice. Excel makes it easy to create a PivotTable from your data. Starting in Excel 2013, Excel makes creating PivotTables even easier by offering suggestions as to what types of data you may want to view within a selected data set or table. These are called “Recommended PivotTables.” When you create a recommended PivotTable, Excel simply offers suggestions as to what type of data you may want to initially view within the PivotTable based on the data selected. You can then choose a recommendation and Excel will automatically create a PivotTable that shows you the selected type of data within a new worksheet. You can then edit and change the PivotTable as you would any manually created PivotTable. Using a recommended PivotTable simply speeds up and simplifies the process of creating a PivotTable in Excel.

To create a recommended PivotTable, click the “Insert” tab in the Ribbon. Then click the “Recommended PivotTables” button in the “Tables” button group.

You must then select the source of data for the PivotTable in the “Choose Data Source” dialog box that appears. Your choices are: “Select a table or range,” which pulls the data from your Excel workbook; or “Use an external data source,” which allows you to use data from an existing data connection in your workbook or on your computer. Select the option button for the choice that you prefer.

If you select the “Select a table or range” option button, then click the “Collapse/Expand Dialog Box” button at the right end of the “Table/Range” field to collapse the dialog box down to a single line. You can then click and drag over the cell range of table that you want to use as the data source for your PivotTable. You can then click the same “Collapse/Expand Dialog Box” button again to expand the dialog box when you have finished selecting the data cells within your workbook. Alternately, if you want to use a named table as you data source, you can also simply type the name of the table into the “Table/Range” field instead of manually selecting the cell range reference. You could also type an absolute cell range reference into the “Table/Range” field, if desired, instead of manually selecting the cell range.

If you select the “Use an external data source” option button, then click the “Choose Connection...” button to open the “Existing Connections” dialog box. Within the “Existing Connections” dialog box you will see any connections available. You can use the “Show” drop-down at the top of the dialog box to select the “All Connections” choice, if needed. That will then display all data connections within your workbook, computer, and network within three separate sections within this dialog box. Select the data connection that you would like to use for your PivotTable from the connections shown within this dialog box, and then click the “Open” button to return to the “Choose Data Source” dialog box. Note that while you can select data tables from existing data connections to external data sources, such as an Access database, you cannot select Excel tables that you have added to the workbook’s data model when creating a “Recommended PivotTable.” To use Excel tables that have been saved to the workbook’s data model as your data source, you must manually create the PivotTable using the “PivotTable” button. We will cover doing this in the next lesson.

When you are finished selecting a data source, click the “OK” button to continue. Excel will then display the “Recommended PivotCharts” dialog box. The left side of this dialog box will display several
31.1- Creating Recommended Pivot Tables- (cont’d.):

different types of data analysis that you can view within a PivotTable. Select the type of PivotTable that you wish to create from this listing. You can then see a large preview of the selected PivotTable in the area to the right. You can then click the “OK” button at the bottom of this dialog box to create the selected PivotTable. Note that if your data selection did not include enough data fields, or contained too many blank or repetitive cell entries, you may not be able to create a recommended PivotTable. If this is the case, then Excel will inform you of that fact within this dialog box. However, you can still click the “OK” button to continue and insert a blank PivotTable into a new workbook. You will simply need to manually create the data that you want to show within the PivotTable by using the “PivotTable Fields” task pane.

After you have created a PivotTable, you will see the “PivotTable Fields” task pane appear at the side of your workbook window. In the “PivotTable Fields” pane, you will see the information from your data source. Note the fields that have been added to your PivotTable, and into which quadrant at the bottom of the pane those field have been placed. These settings determine the values displayed within your PivotTable.

You can change the values displayed within the PivotTable by using the “PivotTable Fields” task pane. You can check the checkbox next to each field in the “Choose fields to add to report:” section that you want to add to the PivotTable. If you check a field, Excel will add that field into one of the four quadrants shown in the “Drag fields between areas below:” section at the bottom of the task pane. For PivotTables, these quadrants are “Filters,” “Columns,” “Rows,” and “Values.” At that point, you can click and drag the fields shown from one quadrant to another, based on what function or layout you want the PivotTable to show. Note that fields that are placed into the “Values” section are calculated using the SUM function, by default.
31.2- Manually Creating a PivotTable:

You can also manually create a blank PivotTable that you can then customize as desired. To do this, click the “Insert” tab in the Ribbon and then click the “PivotTable” button in the “Tables” button group. You will then see the “Create PivotTable” dialog box appear. Within this dialog box you must first select the source of data for the PivotTable within the “Choose the data that you want to analyze” section. If you select the “Select a table or range” option button, then click the “Collapse/Expand Dialog Box” button at the right end of the “Table/Range” field to collapse the dialog box down to a single line. You can then click and drag over the cell range or table that you want to use as the data source for your PivotTable. You can then click the same “Collapse/Expand Dialog Box” button again to expand the dialog box when you have finished selecting the data cells within your workbook. Alternately, if you want to use a named table as your data source, you can also simply type the name of the table into the “Table/Range” field instead of manually selecting the cell range reference. You could also type an absolute cell range reference into the “Table/Range” field, if desired, instead of manually selecting the cell range.

If you select the “Use an external data source” option button, then click the “Choose Connection...” button to open the “Existing Connections” dialog box. Within the “Existing Connections” dialog box you will see any connections available. You can use the “Show” drop-down at the top of the dialog box to select the “All Connections” choice, if needed. That will then display all data connections within your workbook, computer, and network within three separate sections within this dialog box. Select the data connection that you would like to use for your PivotTable from the connections shown within this dialog box, and then click the “Open” button to return to the “Create PivotTable” dialog box. If you want to use Excel tables from your workbook’s data model as your PivotTable’s data source, click the “Tables” tab at the top of the “Existing Connections” dialog box. Then select either an individual table or select the “Tables in Workbook Data Model” choice to select all the tables within the data model. Then click the “Open” button to return to the “Create PivotTable” dialog box.

Next you must choose the location where you want to place the PivotTable from the options shown within the “Choose where you want the PivotTable report to be placed” section. You can select the “New Worksheet” option button to place the PivotTable into a new worksheet. You can select the “Existing Worksheet” option button to select a location within an existing worksheet. If you select this option, then you can either enter an absolute cell address location into the “Location:” text box or use the “Collapse/Expand Dialog Box” button at the right end of the field to collapse the dialog box down to a single line so that you can click on the cell that you want to select within an existing worksheet. You can then click the same button again to expand the dialog box when you are finished. Note that the cell that you enter or select will become the upper left corner of the PivotTable.

Next, if you want to add your selected data to an internal data model used by your Excel workbook, then check the “Add this data to the Data Model” checkbox. This will add the selected data to the data model in your Excel workbook. In Excel 2013, you can store and relate data from multiple tables in a data model which you can then manipulate and analyze using PivotTables. When you are finished, click the “OK” button to create your new PivotTable. Then you will see the “PivotTable Fields” task pane appear at the side of your workbook window. In the “PivotTable Fields” pane, you will see the fields within your data source. You can change the values displayed within the PivotTable by using the “PivotTable Fields” task pane. You can check the checkbox next to each field in the “Choose fields to add to report:” section that you want to add to the PivotTable. If you check a field, Excel will add that field into one of the four quadrants shown in the “Drag fields between areas below:” section at the bottom of the task pane. For PivotTables, these quadrants are “Filters,” “Columns,” “Rows,” and “Values.” You can click and drag the fields shown from one quadrant to another, based on what function or layout you want the PivotTable to show. Note that fields that are placed into the “Values” section are calculated using the SUM function, by default.
31.3- Creating a PivotChart:

A PivotChart shows the data from an associated PivotTable in a graphic format. You can create a PivotChart along with an associated PivotTable in Excel 2013. You can then manipulate the PivotChart data in the same way that you manipulate the PivotTable data. Starting in Excel 2013, you can also choose to de-couple a PivotChart from its associated PivotTable, if needed. You can create a PivotChart as you create a PivotTable in Excel, or you can add a PivotChart to an existing PivotTable if you didn’t create one when you initially created the PivotTable.

One way to create a PivotChart is to click the “PivotChart” drop-down button within the “Charts” button group on the “Insert” tab within the Ribbon. You can then select “PivotChart” to insert only a PivotChart or select “PivotChart & PivotTable” to insert both objects. Excel will then launch the “Create PivotChart” dialog box. This dialog box is exactly the same as the “Create PivotTable” dialog box.

Once you have finished making your choices within the “Create PivotChart” dialog box and then click the “OK” button to continue, Excel will then insert a PivotChart, and possibly an accompanying PivotTable, into the location that you selected within the workbook.

You can then add fields from your data source to the various areas within the PivotChart or the PivotTable. If you inserted both objects, then note that data added or changed within one of the items will be reflected in the other. When you select the PivotChart, you can add data fields into the quadrants shown within the “PivotChart Fields” task pane. Note that this task pane functions in the same way as the “PivotTable Fields” task pane does. The quadrants are: “Filters,” “Legend (Series),” “Axis (Categories),” and “Values.”

You can also add a PivotChart to an existing PivotTable within Excel. To do this, simply click into any cell within the PivotTable to which you want to add an accompanying PivotChart. Then click the “PivotChart” button within the “Charts” button group on the “Insert” tab within the Ribbon.

Excel will then display the “Insert Chart” dialog box. Here you will select the chart type and specific subtype that you want to use for your PivotChart. Then click the “OK” button to insert the selected chart into the worksheet. You can then use the “PivotTable Field” task pane to manipulate the PivotChart and its associated PivotTable.

31.4- Manipulating a PivotTable or PivotChart:

Now you will see the ways that you can alter a PivotTable or PivotChart to change what data is displayed and calculated within them. You can check and uncheck the fields shown in the “Choose fields to add to report:” list within the “PivotTable Fields” or “PivotChart Fields” task panes to add or remove them. Once the fields have been added to any one of the four quadrants shown at the bottom of the task panes, you may click and drag the fields shown in these areas from one quadrant to another to rearrange the display of the data, if needed.

When working with the fields in your PivotTable, note that if you click into a worksheet cell outside of the PivotTable area, the PivotTable will become de-selected and the “PivotTable Fields” task pane will be hidden. You can simply click back into a cell within the PivotTable to reactivate the PivotTable and display the “PivotTable Fields” task pane again. This same principle of selection also applies to PivotCharts.

You can also make use of the buttons shown in the “Active Field” button group on the “Analyze” tab of the “PivotTable Tools” or “PivotChart Tools” contextual tabs within the Ribbon to change the appearance of your PivotTable and PivotChart data. When you click into a field cell within a PivotTable, the name of the active field will be displayed in the “Active Field” text box within this button group. The “Expand Field” and “Collapse Field” buttons in the “Active Field” button group on the “Analyze” tab can be used to collapse and

©TeachUcomp, Inc.  Advanced Excel  20
31.4- Manipulating a PivotTable or PivotChart (cont'd.):

expand the detail data for any actively selected field in an outlined group. In this same button group, you can click the “Field Settings” button to open a dialog box where you can change the settings of the active field within the PivotTable or PivotChart.

If you need to enable or disable the display of the “PivotTable Fields” or “PivotChart Fields” task pane for any reason, you can click the “Field List” button in the “Show” button group on the “Analyze” tab within the “PivotTable Tools” contextual tab in the Ribbon to show and hide the “PivotTable Fields” task pane. This same button is located within the “Show/Hide” button group on the “Analyze” tab within the “PivotChart Tools” contextual tab within the Ribbon when you have a PivotChart selected, instead.

31.5- Changing Calculated Value Fields:

When you add a field into the “Values” section of either the “PivotTable Fields” or “PivotChart Fields” task pane, the data within the field is added together using the “Sum” function. You can change the function used to calculate the data, if you wish. There are also several other features of value fields that you can alter, if needed.

To change the properties of value fields, click the small drop-down arrow to the right of the field name displayed in the “Values” section of the “PivotTable Fields” or “PivotChart Fields” task pane. Select the “Value Field Settings…” command from the menu that appears to open the “Value Field Settings” dialog box.

The “Source Name” field shows the original field name from which the calculated field derives its values. You can type a name for the field to display into the “Custom Name” text box. On the “Summarize Values By” tab, click on the name of the function by which you wish to summarize the source field selected.

You can click the “Number Format” button in the lower left corner of this dialog box to open a simplified version of the “Format Cells” dialog box which you can use to set the appearance of the numeric formatting used by the numbers in the selected value field. Then you can click the “OK” button to return to the “Value Field Settings” dialog box.

You can click the “Show Values As” tab in the “Value Field Settings” dialog box to select how you want to show the data from the field. You can select another summarization option from the “Show values as:” drop-down. You can compare the values listed in the rows or columns as a percentage of the column, row, or field total. You can also choose to show the number as the difference of another field.

If you select a comparison option that requires another field against which to compare the value, you can select that field’s name from the “Base field:” list and then select the value against which to compare from that field from the “Base item:” list. Note that if you change settings on either the “Summarize Values By” or “Show Values As” tabs, then you may need to re-enter any changes made to the “Custom Name” field or formats applied in the “Format Cells” dialog box to apply them to the new calculated field’s values before you click the ‘OK’ button. Once you have set the options that you want for your value field, click the “OK” button to set the appearance of the value field.
31.6- Formatting PivotTables:

You can use PivotTable styles to apply preset formatting to your PivotTables in Excel. To do this, just click into any cell within your PivotTable. Then click on the desired style that you want to apply in the listing of PivotTable styles shown in the “PivotTable Styles” group on the “Design” tab of the “PivotTable Tools” contextual tab within the Ribbon.

You can modify the settings of the preset PivotTable styles by checking the desired checkboxes in the “PivotTable Style Options” group on the “Design” tab of the “PivotTable Tools” contextual tab within the Ribbon. Doing this will allow you to select the areas within the PivotTable to which special formatting is applied. You can select to apply special formatting to the “Row Headers” and “Column Headers” by checking those checkboxes. You can also apply banding to the row or columns within the PivotTable by checking the “Banded Rows” or “Banded Columns” checkboxes.

You can also easily change the summarization and layout of a PivotTable by using the buttons shown within the “Layout” button group on the “Design” tab of the “PivotTable Tools” contextual tab within the Ribbon. You can click the “Subtotals” button to choose a layout for subtotals within a selected PivotTable from the drop-down menu that appears. You can also click the “Grand Totals” button to choose the display of grand totals within a selected PivotTable from the drop-down menu that appears. You can click the “Report Layout” drop-down button to choose a desired layout for your selected PivotTable from the menu of choices shown. Finally, you can click the “Blank Rows” drop-down button to choose the display of blank rows within a selected PivotTable from the menu of choices that appears.

31.7- Formatting PivotCharts:

You can format PivotCharts in the same way that you can format any other chart that is available in Excel. To format a PivotChart, first select the PivotChart to format within the worksheet. You can then use the available formatting options that are found on the “Design” and “Format” tabs within the “PivotChart Tools” contextual tab within the Ribbon to apply formatting to the selected PivotChart. The options that are available are the same for PivotChart as for normal charts.

31.8- Setting PivotTable Options:

If you wish to view and edit the general options for a selected PivotTable, then click the “Options” button in the “PivotTable” group on the “Analyze” tab in the “PivotTable Tools” contextual tab within the Ribbon. Doing this will open the “PivotTable Options” dialog box where you can set several general options that control the appearance and behavior of the selected PivotTable.

At the top of this dialog box, you can type a name for the PivotTable into the “PivotTable Name:” text box. Below that, there are several tabs that represent the various PivotTable option categories.

On the “Layout & Format” tab, you can check or uncheck the options shown to set the appearance of PivotTable data. You can click the “Totals & Filters” tab to change the display of totals and subtotals in the PivotTable and also set the general filtering and sorting behaviors that are available. On the “Display” tab, you can set options that determine the appearance of the PivotTable in the worksheet. On the “Printing” tab to set the appearance of the PivotTable when printed. On the “Data” tab, you can set options that control the relationship that is shared between the PivotTable and its source data. Finally, on the “Alt Text” tab, you can enter a text description of the PivotTable. After setting the options that you want your PivotTable to posses in these tabs, click the “OK” button to apply the options to the selected PivotTable.
31.9- Sorting and Filtering Using Field Headers:

You can sort and filter the data by using the “Field Headers” that you have added to your PivotTable fields. Note that you can show and hide the display of field headers within a selected PivotTable by clicking the “Field Headers” button within the “Show” group on the “Analyze” tab within the “PivotTable Tools” contextual tab within the Ribbon. When field headers are enabled, you will see the “Row Labels” and “Column Labels” text appear next to a drop-down arrow within a cell above the columns and rows. You can use the drop-down that appears within these cells to sort and filter the fields within the columns and rows in the PivotTable.

If you click the drop-down arrow, you will see a menu that shows you the sorting and filtering options available. If you have added multiple fields to either the columns or the rows, then you will see another drop-down menu called “Select field” appear at the top within the drop-down menu. You can then select the desired field to sort or filter from the field choices shown within this drop-down menu.

For the selected field, you can choose the “Sort A to Z” command to sort the field data in ascending order. You can choose the “Sort Z to A” to sort the field data in descending order. You can also select the “More Sort Options…” command to show the “Sort” dialog box where you can set any advanced sorting options that you wish. If you open the “Sort” dialog box, just click the “OK” button to apply any sorting options that you set when you are finished.

You can also apply filtering to a field to include or exclude data specific values from being displayed within the PivotTable. To manually select which field values to display, simply check or uncheck the values listed in the field’s drop-down listing. Then click the “OK” button at the bottom of the menu to apply the filters.

You can also select either the “Label Filters” or “Value Filters” commands to display a side menu of comparison choices. You can then select the desired comparison operator from the side menu to display a “Value Filter” dialog box. Here you can enter the value or values needed to filter the field’s data. Then click the “OK” button to apply the filter.

If, after applying a filter, you want to show all of the field’s values again, you can click the drop-down arrow button again and then select either the “(Select All)” checkbox or select the “Clear Filter” command from the drop-down menu. If you select the “(Select All)” checkbox, then click the “OK” button at the bottom of the menu to finish removing the filters.
CREATING A RECOMMENDED PIVOTTABLE:

1. To create a recommended PivotTable, click the “Insert” tab in the Ribbon.
2. Then click the “Recommended PivotTables” button in the “Tables” button group.
3. You must then select the source of data for the PivotTable in the “Choose Data Source” dialog box that appears. Your choices are: “Select a table or range” or “Use an external data source.” Select the option button for the choice that you prefer.
4. If you select the “Select a table or range” option button, then click the “Collapse/Expand Dialog Box” button at the right end of the “Table/Range” field to collapse the dialog box down to a single line.
5. Then click and drag over the cell range or table you want to use as the data source for your PivotTable.
6. You can then click the same “Collapse/Expand Dialog Box” button again to expand the dialog box when you have finished selecting the data cells within your workbook.
7. Alternately, if you want to use a named table as you data source, you can also simply type the name of the table into the “Table/Range” field instead of manually selecting the cell range reference.
8. You could also type an absolute cell range reference into the “Table/Range” field, if desired, instead of manually selecting the cell range.
9. If you select the “Use an external data source” option button, then click the “Choose Connection...” button to open the “Existing Connections” dialog box.
10. Within the “Existing Connections” dialog box you will see any connections available. You can use the “Show” drop-down at the top of the dialog box to select the “All Connections” choice, if needed. That will then display all data connections within your workbook, computer, and network within three separate sections within this dialog box.
11. Select the data connection you would like to use for your PivotTable from the connections shown within this dialog box, and then click the “Open” button to return to the “Choose Data Source” dialog box.
12. When you are finished selecting a data source, click the “OK” button to continue.
13. Excel will then display the “Recommended PivotCharts” dialog box. The left side of this dialog box will display several different types of data analysis that you can view within a PivotTable.
14. Select the type of PivotTable that you wish to create from this listing. You can then see a large preview of the selected PivotTable in the area to the right.
15. You can then click the “OK” button at the bottom of this dialog box to create the selected PivotTable.
16. Note that if your data selection did not include enough data fields, or contained too many blank or repetitive cell entries, you may not be able to create a recommended PivotTable. If this is the case, then Excel will inform you of that fact within this dialog box. However, you can still click the “OK” button to continue and insert a blank PivotTable into a new workbook. You will simply need to manually create the data that you want to show within the PivotTable by using the “PivotTable Fields” task pane.
17. After you have created a PivotTable, you will see the “PivotTable Fields” task pane appear at the side of your workbook window. Note the fields that have been added to your PivotTable, and into which quadrant at the bottom of the pane those field have been placed. These settings determine the values displayed within your PivotTable.
18. You can change the values displayed within the PivotTable by using the “PivotTable Fields” task pane. You can check the checkbox next to each field in the “Choose fields to add to report:” section that you want to add to the PivotTable.
19. If you check a field, Excel will add that field into one of the four quadrants shown in the “Drag fields between areas below:” section at the bottom of the task pane. For PivotTables, these quadrants are “Filters,” “Columns,” “Rows,” and “Values.”
20. At that point, you can click and drag the fields shown from one quadrant to another, based on what function or layout you want the PivotTable to show.
MANUALLY CREATING A PIVOTTABLE:

1. Click the “Insert” tab in the Ribbon and then click the “PivotTable” button in the “Tables” button group.
2. In the “Create PivotTable” dialog box, select the option button that corresponds to the source of data for the PivotTable within the “Choose the data that you want to analyze” section.
3. If you select the “Select a table or range” option button, then click the “Collapse/Expand Dialog Box” button at the right end of the “Table/Range” field to collapse the dialog box down to a single line.
4. Then click and drag over the cell range or table that you want to use as the data source.
5. You can then click the same “Collapse/Expand Dialog Box” button again to expand the dialog box when you have finished selecting the data cells within your workbook.
6. Alternately, if you want to use a named table as your data source, you can also simply type the name of the table into the “Table/Range” field instead of manually selecting the cell range reference.
7. You could also type an absolute cell range reference into the “Table/Range” field, if desired, instead of manually selecting the cell range.
8. If you select the “Use an external data source” option button, then click the “Choose Connection...” button to open the “Existing Connections” dialog box. Within the “Existing Connections” dialog box you will see any connections available.
9. You can use the “Show” drop-down at the top of the dialog box to select the “All Connections” choice, if needed. That will then display all data connections within your workbook, computer, and network within three separate sections within this dialog box.
10. Select the data connection that you would like to use for your PivotTable from the connections shown within this dialog box, and then click the “Open” button to return to the “Create PivotTable” dialog box.
11. If you want to use Excel tables from your workbook’s data model as your PivotTable’s data source, click the “Tables” tab at the top of the “Existing Connections” dialog box. Then select either an individual table or select the “Tables in Workbook Data Model” choice to select all the tables within the data model. Then click the “Open” button to return to the “Create PivotTable” dialog box.
12. Next, choose the location to place the PivotTable from the options shown within the “Choose where you want the PivotTable report to be placed” section of the “Create PivotTable” dialog box.
13. You can select the “New Worksheet” option button to place the PivotTable into a new worksheet.
14. You can select the “Existing Worksheet” option button to select a location within an existing worksheet.
15. If you select this option, then you can either enter an absolute cell address location into the “Location:” text box or use the “Collapse/Expand Dialog Box” button at the right end of the field to collapse the dialog box down to a single line so that you can click on the cell that you want to select within an existing worksheet. You can then click the same button again to expand the dialog box when you are finished. Note that the cell that you enter or select will become the upper left corner of the PivotTable.
16. If you want to add your selected data to an internal data model used by your Excel workbook, check the “Add this data to the Data Model” checkbox.
17. When finished, click the “OK” button to create your new PivotTable.
18. You will see the “PivotTable Fields” task pane appear at the side of your workbook window.
19. You can check the checkbox next to each field in the “Choose fields to add to report:” section that you want to add to the PivotTable.
20. If you check a field, Excel will add that field into one of the four quadrants shown in the “Drag fields between areas below:” section at the bottom of the task pane. For PivotTables, these quadrants are “Filters,” “Columns,” “Rows,” and “Values.”
21. You can click and drag the fields shown from one quadrant to another, based on what function or layout you want the PivotTable to show.
CREATING A PIVOTCHART:

1. One way to create a PivotChart is to click the “PivotChart” drop-down button within the “Charts” button group on the “Insert” tab within the Ribbon.
2. You can then select “PivotChart” to insert only a PivotChart or select “PivotChart & PivotTable” to insert both objects. Excel will then launch the “Create PivotChart” dialog box. This dialog box is exactly the same as the “Create PivotTable” dialog box.
3. Once you have finished making your choices within the “Create PivotChart” dialog box and then click the “OK” button to continue, Excel will then insert a PivotChart, and possibly an accompanying PivotTable, into the location that you selected within the workbook.
4. You can then add fields from your data source to the various areas within the PivotChart or the PivotTable. If you inserted both objects, then note that data added or changed within one of the items will be reflected in the other.
5. When you select the PivotChart, you can add data fields into the quadrants shown within the “PivotChart Fields” task pane. Note that this task pane functions in the same way as the “PivotTable Fields” task pane does. The quadrants are: “Filters,” “Legend (Series),” “Axis (Categories),” and “Values.”
6. You can also add a PivotChart to an existing PivotTable within Excel. To do this, simply click into any cell within the PivotTable to which you want to add an accompanying PivotChart. Then click the “PivotChart” button within the “Charts” button group on the “Insert” tab within the Ribbon.
7. Excel will then display the “Insert Chart” dialog box. Here you will select the chart type and specific subtype that you want to use for your PivotChart. Then click the “OK” button to insert the selected chart into the worksheet. You can then use the “PivotTable Field” task pane to manipulate the PivotChart and its associated PivotTable.

MANIPULATING A PIVOTTABLE OR PIVOTCHART:

1. You can check and uncheck the fields shown in the “Choose fields to add to report:” list within the “PivotTable Fields” or “PivotChart Fields” task panes to add or remove them.
2. Once the fields have been added to any one of the four quadrants shown at the bottom of the task panes, you may click and drag the fields shown in these areas from one quadrant to another to rearrange the display of the data, if needed.
3. When working with the fields in your PivotTable, note that if you click into a worksheet cell outside of the PivotTable area, the PivotTable will become de-selected and the “PivotTable Fields” task pane will be hidden. You can simply click back into a cell within the PivotTable to reactivate the PivotTable and display the “PivotTable Fields” task pane again. This same principle of selection also applies to PivotCharts.
4. You can also make use of the buttons shown in the “Active Field” button group on the “Analyze” tab of the “PivotTable Tools” or “PivotChart Tools” contextual tabs within the Ribbon to change the appearance of your PivotTable and PivotChart data.
5. When you click into a field cell within a PivotTable, the name of the active field will be displayed in the “Active Field” text box within this button group.
6. The “Expand Field” and “Collapse Field” buttons in the “Active Field” button group on the “Analyze” tab can be used to collapse and expand the detail data for any actively selected field in an outlined group.
7. In this same button group, you can click the “Field Settings” button to open a dialog box where you can change the settings of the active field within the PivotTable or PivotChart.

(cont’d.)
MANIPULATING A PIVOTTABLE OR PIVOTCHART (CONT’D.):

8. If you need to enable or disable the display of the “PivotTable Fields” or “PivotChart Fields” task pane for any reason, you can click the “Field List” button in the “Show” button group on the “Analyze” tab within the “PivotTable Tools” contextual tab in the Ribbon to show and hide the “PivotTable Fields” task pane.

9. This same button is located within the “Show/Hide” button group on the “Analyze” tab within the “PivotChart Tools” contextual tab within the Ribbon when you have a PivotChart selected, instead.

CHANGING CALCULATED VALUE FIELDS:

1. To change the properties of fields placed into the “Values” section of either the “PivotChart Fields” or “PivotTable Fields” task pane, click the small drop-down arrow to the right of the field name displayed in the “Values” section of the “PivotTable Fields” or “PivotChart Fields” task pane.

2. Select the “Value Field Settings…” command to open the “Value Field Settings” dialog box.

3. The “Source Name” field shows the original field name from which the calculated field derives its values.

4. You can type a name for the field to display into the “Custom Name” text box.

5. On the “Summarize Values By” tab, click the name of the function to use to summarize the source field.

6. You can click the “Number Format” button in the lower left corner of this dialog box to open a simplified version of the “Format Cells” dialog box which you can use to set the appearance of the numeric formatting used by the numbers in the selected value field.

7. Then you can click the “OK” button to return to the “Value Field Settings” dialog box.

8. You can click the “Show Values As” tab in the “Value Field Settings” dialog box to select how you want to show the data from the field.

9. You can select another summarization option from the “Show values as:” drop-down. You can compare the values listed in the rows or columns as a percentage of the column, row, or field total. You can also choose to show the number as the difference of another field.

10. If you select a comparison option that requires another field against which to compare the value, you can select that field’s name from the “Base field:” list and then select the value against which to compare from that field from the “Base item:” list.

11. Note that if you change settings on either the “Summarize Values By” or “Show Values As” tabs, then you may need to re-enter any changes made to the “Custom Name” field or formats applied in the “Format Cells” dialog box to apply them to the new field’s values before you click the “OK” button.

12. Once you have set the options that you want for your value field, click the “OK” button.

APPLYING PIVOTTABLE STYLES:

1. Click into any cell within your PivotTable.

2. Click on the desired style that you want to apply in the listing of PivotTable styles shown in the “PivotTable Styles” group on the “Design” tab of the “PivotTable Tools” contextual tab within the Ribbon.

3. You can modify the settings of the preset PivotTable styles by checking the desired checkboxes in the “PivotTable Style Options” group on the “Design” tab of the “PivotTable Tools” contextual tab within the Ribbon to select the areas within the PivotTable to which special formatting is applied.

4. You can select to apply special formatting to the “Row Headers” and “Column Headers” by checking those checkboxes.

(cont’d.)
APPLYING PIVOTTABLE STYLES (CONT’D.):

5. You can also apply banding to the row or columns within the PivotTable by checking the “Banded Rows” or “Banded Columns” checkboxes.

6. You can also easily change the summarization and layout of a PivotTable by using the buttons shown within the “Layout” button group on the “Design” tab of the “PivotTable Tools” contextual tab within the Ribbon.

7. You can click the “Subtotals” button to choose a layout for subtotals within a selected PivotTable from the drop-down menu that appears.

8. You can also click the “Grand Totals” button to choose the display of grand totals within a selected PivotTable from the drop-down menu that appears.

9. You can click the “Report Layout” drop-down button to choose a desired layout for your selected PivotTable from the menu of choices shown.

10. Finally, you can click the “Blank Rows” drop-down button to choose the display of blank rows within a selected PivotTable from the menu of choices that appears.

FORMATTING PIVOTCHARTS:

1. To format a PivotChart, first select the PivotChart to format within the worksheet.

2. Then use the available formatting options that are found on the “Design” and “Format” tabs within the “PivotChart Tools” contextual tab within the Ribbon to apply formatting to the selected PivotChart.

3. The options that are available are the same for PivotChart as for normal charts.

SETTING PIVOTTABLE OPTIONS:

1. If you wish to view and edit the general options for a selected PivotTable, then click the “Options” button in the “PivotTable” group on the “Analyze” tab in the “PivotTable Tools” contextual tab within the Ribbon.

2. Doing this will open the “PivotTable Options” dialog box where you can set several general options that control the appearance and behavior of the selected PivotTable.

3. At the top of this dialog box, you can type a name for the PivotTable into the “PivotTable Name” text box.

4. Below that, there are several tabs that represent the various PivotTable option categories.

5. On the “Layout & Format” tab, you can check or uncheck the options shown to set the appearance of PivotTable data.

6. You can click the “Totals & Filters” tab to change the display of totals and subtotals in the PivotTable and also set the general filtering and sorting behaviors that are available.

7. On the “Display” tab, you can set options that determine the appearance of the PivotTable in the worksheet.

8. On the “Printing” tab to set the appearance of the PivotTable when printed.

9. On the “Data” tab, you can set options that control the relationship that is shared between the PivotTable and its source data.

10. Finally, on the “Alt Text” tab, you can enter a text description of the PivotTable.

11. After setting the options that you want your PivotTable to posses in these tabs, click the “OK” button to apply the options to the selected PivotTable.
SORTING AND FILTERING USING FIELD HEADERS:

1. You can sort and filter the data by using the “Field Headers” that you have added to your PivotTable fields.
2. Note that you can show and hide the display of field headers within a selected PivotTable by clicking the “Field Headers” button within the “Show” group on the “Analyze” tab within the “PivotTable Tools” contextual tab within the Ribbon.
3. When field headers are enabled, you will see the “Row Labels” and “Column Labels” text appear next to a drop-down arrow within a cell above the columns and rows. You can use the drop-down that appears within these cells to sort and filter the fields within the columns and rows in the PivotTable.
4. If you click the drop-down arrow, you will see a menu that shows you the sorting and filtering options available.
5. If you have added multiple fields to either the columns or the rows, then you will see another drop-down menu called “Select field” appear at the top within the drop-down menu.
6. You can then select the desired field to sort or filter from the field choices shown within this “Select field” drop-down menu.
7. For the selected field, you can choose the “Sort A to Z” command to sort the field data in ascending order.
8. You can also select the “Sort Z to A” to sort the field data in descending order.
9. You can also select the “More Sort Options…” command to show the “Sort” dialog box where you can set any advanced sorting options that you wish.
10. If you open the “Sort” dialog box, just click the “OK” button to apply any sorting options that you set when you are finished.
11. You can also apply filtering to a field to include or exclude data specific values from being displayed within the PivotTable.
12. To manually select which field values to display, simply check or uncheck the values listed in the field’s drop-down listing.
13. Then click the “OK” button at the bottom of the menu to apply the filters.
14. You can also select either the “Label Filters” or “Value Filters” commands to display a side menu of comparison choices.
15. You can then select the desired comparison operator from the side menu to display a “Value Filter” dialog box.
16. Here you can enter the value or values needed to filter the field’s data. Then click the “OK” button to apply the filter.
17. If, after applying a filter, you want to show all of the field’s values again, you can click the drop-down arrow button again and then select either the “(Select All)” checkbox or select the “Clear Filter” command from the drop-down menu.
18. If you select the “(Select All)” checkbox, then click the “OK” button at the bottom of the menu to finish removing the filters.
Purpose:
1. To be able to create and manipulate a PivotTable in Excel 2013.

Exercises:
1. Open the “Advanced Excel” workbook that has been completed through the Exercise at the end of the previous chapter.
2. Select cell A10 within the “Budgets” table.
3. Click the “Recommended PivotTables” button within the “Tables” button group on the “Insert” tab within the Ribbon to launch the “Recommended PivotTables” dialog box.
4. Select the “Sum of Actual Expenses by Region” PivotTable choice from the left side of the “Recommended PivotTables” dialog box, and then click the “OK” button.
5. The PivotTable will be inserted into a new worksheet within the workbook titled “Sheet2.”
6. In the “PivotTable Fields” pane at the right side of the worksheet, click the drop-down arrow that appears at the right end of the “Sum of Actual Expenses” field within the “Values” section.
7. Select the “Value Field Settings…” command from the drop-down menu of choices to open the “Value Field Settings” dialog box.
8. Click the “Number Format” button in the lower left corner of the “Value Field Settings” dialog box to open the “Format Cells” dialog box.
9. Select “Currency” from the “Category” list within the “Format Cells” dialog box and then click the “OK” button.
10. Click the “OK” button within the “Value Field Settings” dialog box to apply the currency format to the values shown within the PivotTable.
11. Now you will alter the PivotTable to display actual expenses per department within each region. You can do this by clicking and dragging the “Department” field from the “PivotTable Fields” list and then dropping it below the “Region” field within the “Rows” section at the bottom of the pane.
12. Now you will alter the PivotTable to display actual expenses per region as well as actual expenses per department for all regions. You can do this by clicking and dragging the “Department” field from the “Rows” section and then dropping it into the “Columns” section at the bottom of the “PivotTable Fields” pane.
13. Now you will display the sum of both the budgeted and actual expenses per department per region. You can do this by clicking and dragging the “Budgeted Expenses” field from the top of the “PivotTable Fields” pane and then dropping it at the top of the “Values” section at the bottom of the pane.
14. In the “PivotTable Fields” pane at the right side of the worksheet, click the drop-down arrow that appears at the right end of the “Sum of Budgeted Expenses” field within the “Values” section.
15. Select the “Value Field Settings…” command from the drop-down menu of choices to open the “Value Field Settings” dialog box.
16. Click the “Number Format” button in the lower left corner of the “Value Field Settings” dialog box to open the “Format Cells” dialog box.
17. Select “Currency” from the “Category” list within the “Format Cells” dialog box and then click the “OK” button.
18. Click the “OK” button within the “Value Field Settings” dialog box to apply the currency format to the values shown within the PivotTable.
19. Click the “Save” button within the Quick Access toolbar to save the changes.
20. You can close the workbook, but be sure to keep it as you will need it to perform the Exercises at the end of the following chapters within this manual.
CHAPTER 32-
PivotTables and PivotCharts- 2010:2007

32.1- Creating PivotTables and PivotCharts
32.2- Manipulating a PivotTable
32.3- Changing Calculated Value Fields
32.4- Applying PivotTable Styles
32.5- Creating a PivotChart
32.6- Setting PivotTable Options
32.7- Sorting and Filtering PivotTable Data
32.1- Creating Pivot Tables and PivotCharts:

You can use the PivotTable feature of Excel to access some of the most powerful data-analysis that Excel can provide. PivotTables allow you to organize massive amounts of data in more coherent and meaningful ways to extract from the data exactly what you want to know. Probably the most helpful feature of PivotTables is the ability that they have to be reorganized quickly and easily to change what information they are displaying and calculating. When you create a PivotTable, you are composing information in your worksheet and then calculating intersecting values of your choosing. In addition to the PivotTables, you can also create PivotCharts, which use the data from PivotTables but display it in a graphic format.

The best way to learn how to use PivotTables is to actually create one with which you can experiment and practice. Excel makes it easy to create a PivotTable from your data. To create a PivotTable, first select the worksheet that contains the data from which you want to create a PivotTable. Next, click the “Insert” tab in the Ribbon. Click the “PivotTable” drop-down button in the “Tables” group and choose either the “PivotTable” or “PivotChart” command, as desired.

Either way, next you will see the “Create PivotTable” dialog box appear. Here you must select the source of data for the PivotTable. Your choices are: “Select a table or range,” which pulls the data from your Excel worksheet, or “Use an external data source,” which allows you to use data from a query or an open database connection.

Below that area, you have to select whether you want to place the PivotTable or PivotChart into a new worksheet or an existing worksheet. If you click the “Existing Worksheet” choice, then you’ll have to click into the “Location:” text box and then click into the worksheet to select the cell that will become the upper left corner of the PivotTable or PivotChart. When you are finished, click “OK” to create your new PivotTable or PivotChart.

Next you will see the “PivotTable Field List” task pane appear at the side of your workbook window. If you elected to create a PivotChart, you will see the “PivotChart Filter Pane” appear. In the “PivotTable Field List” pane, you will see the information from your data source. Now you have to click the checkbox next to each field in the “Choose fields to add to report:” section that you want to add to the PivotTable. As you check each field, Excel will add it into one of the four quadrants shown in the “Drag fields between areas below:” section at the bottom of the task pane. For PivotTables, these fields are “Report Filter,” “Column Labels,” “Row Labels,” and “Values.” For PivotCharts these fields are “Report Filter,” “Legend Fields (Series),” “Axis Fields (Categories),” or “Values.” At that point, you can click and drag the fields shown from one quadrant to another, based on what function or layout you want the PivotTable to show. Note fields that are placed into the “Values” section are calculated using the SUM function, by default.

32.2- Manipulating a PivotTable:

Now you will see the ways that you can alter a PivotTable to change what data is displayed and calculated within the PivotTable. As was seen in the last lesson, you can check and uncheck the fields shown in the “Choose fields to add to report:” list within the “PivotTable Field List” task pane to show or hide their display in the PivotTable. Once the fields have been added to any one of the four quadrants shown at the bottom of the task pane, you may click and drag the fields shown in these areas from one quadrant to another to rearrange the display of the data, if needed.

When working with the fields in your PivotTable, note that if you click into a worksheet cell outside of the PivotTable area, the PivotTable will become de-selected and the “PivotTable Field List” will be hidden. You can simply click back into a cell within the PivotTable to re-activate the PivotTable and display the “PivotTable Field List” again.

You can also filter what information is displayed within each of the columns and rows. Notice that
32.2- Manipulating a PivotTable (cont’d.):

Each time that you add fields to the PivotTable, the field will appear with a small drop-down arrow to the right of the field name within the actual PivotTable. You can click this drop-down arrow to show a menu listing all of the unique values within that column or row. Values that are checked will display in the PivotTable and values that are unchecked will be hidden from the PivotTable. You can check and uncheck the values in each column or row, as needed, to display just the data that you want to see. When you are finished checking and unchecking value items in the drop-down menu, click “OK” at the bottom to set your filter choices. Note that you can select the “(Select All)” option at the top of the manual filter list to select all values in the field for display once again.

You can also make use of the buttons shown in the “Options” and “Design” tabs of the “PivotTable Tools” contextual tab within the Ribbon to change the appearance of your PivotTable data. The “Expand Entire Field” and “Collapse Entire Field” buttons in the “Active Field” group on the “Options” tab can be used to collapse and expand the detail data for any selected field in an outlined group. In this same group, you can click the “Field Settings” button to open a dialog box where you can change the settings of the currently selected field within the PivotTable.

Also, if you need to enable the display of the “Field List” for any reason, you can click the “Field List” button in the “Show” group on the “Options” tab to show and hide the “PivotTable Field List” in the program.

32.3- Changing Calculated Value Fields:

When you add a field into the “Values” section of the “PivotTable Field List” task pane, the information in the field is added together using the Sum function. You can change the function used, if you wish. There are also several other features of value fields that you can alter, if desired.

To change the properties of your value fields, click the small drop-down arrow to the right of the field name displayed in the “Values” section of the “PivotTable Field List.” Select the “Value Field Settings…” command from the pop-up menu that appears. Doing this will open the “Value Field Settings” dialog box.

The “Source Name:” field shows the original field name from which the value field derives its data. You can type a name for the field to display in the PivotTable into the “Custom Name:” text box. On the “Summarize by” tab, click on the name of the function by which you wish to summarize the source field selected. You can click the “Number Format” button in the lower left corner of this dialog box to open a simplified version of the “Format Cells” dialog box which you can use to set the appearance of the numeric formatting used by the numbers in the selected PivotTable value field. Then you can click the “OK” button to return to the “Value Field Settings” dialog box.

You can click the “Show values as” tab in the “Value Field Settings” dialog box, to select how you want to show the data from the field. You can select another summarization option from the “Show values as:” drop-down. You can compare the values listed in the rows or columns as a percentage of the column, row, or field total. You can also choose to show the number as the difference of another field. If you select a comparison option that requires you to select another field against which you wish to compare the value, you can select that field’s name from the “Base field:” list and then select the value against which to compare from that field from the “Base item:” list. Once you have set the options that you want for your value field, click the “OK” button to set the appearance of the value field.
32.4- Applying PivotTable Styles:

You can use PivotTable styles to apply preset formatting to your PivotTables in Excel. To do this, just click into any cell within your PivotTable. Then click on the desired style that you want to apply in the listing of PivotTable styles shown in the “PivotTable Styles” group on the “Design” tab of the “PivotTable Tools” contextual tab within the Ribbon.

You can modify the settings of the preset PivotTable styles by checking the desired checkboxes in the “PivotTable Style Options” group on the “Design” tab of the “PivotTable Tools” contextual tab within the Ribbon. Doing this will allow you to select the areas within the PivotTable to which special formatting is applied. You can select to apply special formatting to the “Row Headers” and “Column Headers” by checking those checkboxes. You can also apply banding to the rows or columns within the PivotTable by checking the “Banded Rows” or “Banded Columns” checkboxes.

32.5- Creating a PivotChart:

A PivotChart shows the data from an associated PivotTable in a graphic format. You can easily create a PivotChart from the data that is displayed in your PivotTable after you have created the PivotTable if you didn’t create one when you initially created the PivotTable.

To create a PivotChart to accompany your PivotTable, click into the PivotTable that you want to view as a PivotChart. Then click the “PivotChart” button in the “Tools” group on the “Options” tab of the “PivotTable Tools” contextual tab within the Ribbon.

When you do this, Excel will open the “Insert Chart” dialog box. Here you will select the chart type and specific subtype that you want to use to represent the data from your PivotTable. Then click the “OK” button to insert the selected chart into the worksheet. You can click the drop-down arrows in the “PivotTable Field List” to filter what data is shown within the PivotChart, just like you can do with the PivotTable. Also note that changes that you make to one object will be reflected in the other, as the PivotTable is just the data source for the PivotChart.

32.6- Setting PivotTable Options:

If you wish to view and edit your general PivotTable options, you can do so by clicking “Options” button in the “PivotTable” group on the “Options” tab in the “PivotTable Tools” contextual tab within the Ribbon. Doing this will open the “PivotTable Options” dialog box where you can set several properties that control the appearance and behavior of the selected PivotTable.

At the top of this dialog box, you can type a name for the PivotTable into the “Name:” text box. Below that, you have several tabs that represent the various PivotTable option categories.

In the “Layout & Format” tab, you can check or uncheck the options shown to set the appearance of the PivotTable data. You can click the “Totals & Filters” tab to change the display of totals and subtotals in the PivotTable and also set the general filtering and sorting behaviors you have available. On the “Display” tab, you can set options that determine the appearance of the PivotTable in the worksheet. You can click the “Printing” tab to set the appearance of the PivotTable when printed. Finally, on the “Data” tab, you can set options that control the relationship that is shared between the PivotTable and its source data in the worksheet. After setting or removing any additional options that you want your PivotTable to possess in these tabs, click the “OK” button to set the options for the selected PivotTable.
32.7- Sorting and Filtering PivotTable Data:

You can sort and filter the data by using the drop-down fields that you have added to the PivotTable. If you click the drop-down arrow next to a selected data field, you will see a pop-up menu that shows you the sorting and filtering options that you have available.

You can select the “Sort A to Z” command to sort the field data in ascending order. You can choose the “Sort Z to A” to sort the field data in descending order. You can also select the “More Sort Options…” command to show the “Sort” dialog box. Here you can set any more advanced sorting options that you wish, and then click the “OK” button to apply them to your field data.

You can also apply filtering to a data field to include or exclude data records from display within the PivotTable. To manually select which field values to display, simply check or uncheck the values listed in the field’s drop-down listing. You can also select either the “Label Filters” or “Value Filters” commands to display a side menu of comparison choices. You can then select the desired comparison operator from the side menu to display a “Value Filter” dialog box. Here you can enter the value or values needed to filter the field’s data.

If, after applying a filter, you want to show all of the field’s values again, you can click the field’s drop-down arrow button and then select either the “(Select All)” checkbox or select the “Clear Filter” command from the drop-down menu.
CREATING PIVOTTABLES OR PIVOTCHARTS:

1. To create a PivotTable, first select the worksheet that contains the data from which you want to create a PivotTable.
2. Next, click the “Insert” tab in the Ribbon. Click the “PivotTable” drop-down button in the “Tables” group and choose either the “PivotTable” or “PivotChart” command, as desired.
3. Either way, next you will see the “Create PivotTable” dialog box appear. Here you must select the source of data for the PivotTable. Your choices are: “Select a table or range,” which pulls the data from your Excel worksheet, or “Use an external data source,” which allows you to use data from a query or an open database connection.
4. Below that area, you have to select whether you want to place the PivotTable or PivotChart into a new worksheet or an existing worksheet. If you click the “Existing Worksheet” choice, then you’ll have to click into the “Location:” text box and then click into the worksheet to select the cell that will become the upper left corner of the PivotTable or PivotChart. When you are finished, click “OK” to create your new PivotTable or PivotChart.
5. Next you will see the “PivotTable Field List” task pane appear at the side of your workbook window. If you elected to create a PivotChart, you will see the “PivotChart Filter Pane” appear. In the “PivotTable Field List” pane, you will see the information from your data source. Now you have to click the checkbox next to each field in the “Choose fields to add to report:” section that you want to add to the PivotTable.
6. As you check each field, Excel will add it into one of the four quadrants shown in the “Drag fields between areas below:” section at the bottom of the task pane. For PivotTables, these fields are “Report Filter,” “Column Labels,” “Row Labels,” and “Values.” For PivotCharts these fields are “Report Filter,” “Legend Fields (Series),” “Axis Fields (Categories),” or “Values.”
7. At that point, you can click and drag the fields shown from one quadrant to another, based on what function or layout you want the PivotTable to show. Note fields that are placed into the “Values” section are calculated using the SUM function, by default.

MANIPULATING A PIVOTTABLE:

1. You can check and uncheck the fields shown in the “Choose fields to add to report:” list within the “PivotTable Field List” task pane to show or hide their display within the PivotTable.
2. Once the fields have been added to any one of the four quadrants shown at the bottom of the task pane, you may click and drag the fields shown in these areas from one quadrant to another to rearrange the display of the data, if needed.
3. When working with the fields in your PivotTable, note that if you click into a worksheet cell outside of the PivotTable area, the PivotTable will become de-selected and the “PivotTable Field List” will be hidden. You can simply click back into a cell within the PivotTable to reactivate the PivotTable and display the “PivotTable Field List” again.
4. You can click the small drop-down arrow to the right of any field name within the actual PivotTable to show a menu listing all of the unique values within that column or row. Values that are checked will display in the PivotTable and values that are unchecked will be hidden from the PivotTable. You can check and uncheck the values in each column or row, as needed, to display just the data that you want to see. When you are finished checking and unchecking value items in the drop-down menu, click “OK” at the bottom to set your filter choices. Note that you can select the “(Select All)” option at the top of the manual filter list to select all values in the field for display once again.

(cont’d.)
MANIPULATING A PIVOTTABLE (CONT’D.):

5. You can also make use of the buttons shown in the “Options” and “Design” tabs of the “PivotTable Tools” contextual tab within the Ribbon to change the appearance of your PivotTable data. The “Expand Entire Field” and “Collapse Entire Field” buttons in the “Active Field” group on the “Options” tab can be used to collapse and expand the detail data for any selected field in an outlined group.

6. In this same group, you can click the “Field Settings” button to open a dialog box where you can change the settings of the currently selected field within the PivotTable.

7. Also, if you need to enable the display of the “Field List” for any reason, you can click the “Field List” button in the “Show” group on the “Options” tab to show and hide the “PivotTable Field List” in the program.

CHANGING CALCULATED VALUE FIELDS:

1. To change the properties of your value fields, click the small drop-down arrow to the right of the field name displayed in the “Values” section of the “PivotTable Field List.”

2. Select the “Value Field Settings…” command from the pop-up menu that appears. Doing this will open the “Value Field Settings” dialog box.

3. The “Source Name:” field shows the original field name from which the value field derives its data.

4. You can type a name for the field to display in the PivotTable into the “Custom Name:” text box.

5. On the “Summarize by” tab, click on the name of the function by which you wish to summarize the source field selected.

6. You can click the “Number Format” button in the lower left corner of this dialog box to open a simplified version of the “Format Cells” dialog box which you can use to set the appearance of the numeric formatting used by the numbers in the selected PivotTable value field. Then you can click the “OK” button to return to the “Value Field Settings” dialog box.

7. You can click the “Show values as” tab in the “Value Field Settings” dialog box, to select how you want to show the data from the field.

8. You can select another summarization option from the “Show values as:” drop-down. You can compare the values listed in the rows or columns as a percentage of the column, row, or field total. You can also choose to show the number as the difference of another field. If you select a comparison option that requires you to select another field against which you wish to compare the value, you can select that field’s name from the “Base field:” list and then select the value against which to compare from that field from the “Base item:” list.

9. Once you have set the options that you want for your value field, click the “OK” button to set the appearance of the value field.

APPLYING PIVOTTABLE STYLES:

1. Click into any cell within your PivotTable and then click on the desired style that you want to apply in the listing of PivotTable styles shown in the “PivotTable Styles” group on the “Design” tab of the “PivotTable Tools” contextual tab within the Ribbon.

2. You can modify the settings of the preset PivotTable styles by checking the desired checkboxes in the “PivotTable Style Options” group on the “Design” tab of the “PivotTable Tools” contextual tab within the Ribbon.
CREATING A PIVOT CHART:

1. To create a PivotChart to accompany your PivotTable, click into the PivotTable that you want to view as a PivotChart.
2. Then click the “PivotChart” button in the “Tools” group on the “Options” tab of the “PivotTable Tools” contextual tab within the Ribbon.
3. When you do this, Excel will open the “Insert Chart” dialog box. Here you will select the chart type and specific subtype that you want to use to represent the data from your PivotTable. Then click the “OK” button to insert the selected chart into the worksheet.
4. You can click the drop-down arrows in the “PivotTable Field List” to filter what data is shown within the PivotChart, just like you can do with the PivotTable.
5. Also note that changes that you make to one object will be reflected in the other, as the PivotTable is just the data source for the PivotChart.

SETTING PIVOTTABLE OPTIONS:

1. If you wish to view and edit your general PivotTable options, you can do so by clicking “Options” button in the “PivotTable” group on the “Options” tab in the “PivotTable Tools” contextual tab within the Ribbon.
2. In the “PivotTable Options” dialog box, you can type a name for the PivotTable into the “Name:” text box.
3. On the “Layout & Format” tab, you can check or uncheck the options shown to set the appearance of the PivotTable data.
4. You can click the “Totals & Filters” tab to change the display of totals and subtotals in the PivotTable and also set the general filtering and sorting behaviors you have available.
5. On the “Display” tab, you can set options that determine the appearance of the PivotTable in the worksheet.
6. You can click the “Printing” tab to set the appearance of the PivotTable when printed.
7. Finally, on the “Data” tab, you can set options that control the relationship that is shared between the PivotTable and its source data in the worksheet.
8. After setting or removing any additional options that you want your PivotTable to possess in these tabs, click the “OK” button to set the options for the selected PivotTable.

SORTING AND FILTERING PIVOTTABLE DATA:

1. If you click the drop-down arrow next to a selected data field within the PivotTable, you will see a pop-up menu that shows you the sorting and filtering options that you have available.
2. You can select the “Sort A to Z” command to sort the field data in ascending order.
3. You can choose the “Sort Z to A” to sort the field data in descending order.
4. You can also select the “More Sort Options…” command to show the “Sort” dialog box. Here you can set any more advanced sorting options that you wish, and then click the “OK” button to apply them to your field data.
5. To manually select which field values to display, simply check or uncheck the values listed in the field’s drop-down listing.
6. You can also select either the “Label Filters” or “Value Filters” commands to display a side menu of comparison choices.
(cont’d.)
SORTING AND FILTERING PIVOTTABLE DATA (CONT'D.):

7. You can then select the desired comparison operator from the side menu to display a “Value Filter” dialog box. Here you can enter the value or values needed to filter the field’s data.

8. After applying a filter, if you want to show all of the field’s values again, you can click the field’s drop-down arrow button and then select either the “(Select All)” checkbox or select the “Clear Filter” command from the drop-down menu.
**Purpose:**

1. There are no exercises for this chapter.

**Exercises:**

1. None.
33.1- Starting PowerPivot:

PowerPivot is an add-in that is included in Microsoft Excel Professional Plus 2013. It was also available in Excel 2010, but has seen many improvements to its functionality in the 2013 version. PowerPivot is not available in Excel 2007. PowerPivot essentially expands the abilities of the Excel data model to allow for robust data management and reporting for PivotTables and PivotCharts.

Before you can begin using PowerPivot, however, you must enable it within Excel. PowerPivot is an “Add-in” program that must be enabled within Excel before you can use it. To enable PowerPivot, click the “File” tab in the Ribbon to open the backstage view. Then click the “Options” category at the left side of the backstage view to open the “Excel Options” window. Within this window, click the “Add-Ins” category shown at the left side. At the bottom right side of this window, select “COM Add-ins” from the “Manage” drop-down and then click the “Go...” button to open the “COM Add-Ins” window. Check the checkbox for the “Microsoft Office PowerPivot for Excel” add-in, and then click the “OK” button to the right to enable the add-in.

At this point, you should see a new “PowerPivot” tab appear within the Ribbon. You can click this tab within the Ribbon to view the commands used to manage your PowerPivot data within Excel.

33.2- Managing the Data Model:

You can click the “Manage” button within the “Data Model” button group on the “PowerPivot” tab within the Ribbon to open a separate, visual instance of the workbook’s data model that you can then manage in Excel. The Ribbon within the “PowerPivot for Excel” window has four tabs: “File,” “Home,” “Design,” and “Advanced.” Below that is the Formula Bar within the data model. Below the Formula Bar is the “Data View” of the tables within the data model. In a separate pane below the data area is the “Calculation Area.” Below the calculation area you can see the names of the various tables within the data model displayed as tabs. You can click these tabs to switch between the tables within the data model. A recordset navigator is displayed for the currently selected table at the bottom of the window. You can click the buttons within the navigator to move back and forth through the records within the selected table.

In addition to the “Data View” of the data model, you can also view the “Diagram View” of the data model by clicking the “Diagram View” button within the “View” button group on the “Home” tab of the Ribbon within the data model window. This view allows you to see the tables in the data model as diagrams that display the links, or relationships, between fields in the tables. You can also create relationships between tables by simply clicking and dragging a field from one table and then dropping it onto the related field within another table. You can also right-click on the relationship line shown between two fields, and then select the “Edit Relationship” command to open the “Edit Relationship” window, if needed. You could also select the “Delete” command from the pop-up menu to delete a selected relationship from the data model. Note that you will need to click the “Delete from Model” button in the confirmation dialog box that appears to delete the relationship, if desired. You can click the “Data View” button within the “View” button group in the Ribbon again to toggle the view back to “Data View” when you are finished.
33.3- Calculated Columns and Fields:

You can create calculated columns and calculated fields within the tables shown in the PowerPivot data model to create values within a table which you can then add to PivotTables and PivotCharts. This is one of the primary reasons to use PowerPivot add-in versus the standard PivotTables within Excel. There are many different types of formulas that are available within the PowerPivot data model that allow you to calculate values of the existing columns within a table. Note that these formulas are not always exactly the same as the standard workbook formulas used within Excel. These formulas are called DAX formulas, and sometimes use a slightly different function and syntax to calculate values that normal Excel functions. However the syntaxes are very similar. Excel will assist you in creating the DAX formulas for calculated columns and fields so that you won’t need to worry about the syntax of the formulas that you create.

You create calculated columns within a table to create a column value that you can then summarize within the PivotChart or PivotTable in the “Values” section. For example, if you had both a “Quantity” and “Unit Price” field within an “Order Details” table, you could create a new calculated column that would display the result of the product of these two columns as an “Order Total” calculated column. You could then add this column to the “Values” section of a PivotChart or PivotTable to find the sum of order totals for a given grouping. Other uses for a calculated column would be to derive a new column that you can use in the “Row” or “Columns” sections within a PivotTable or PivotChart. For example, if you had the “Order Date” field within an “Orders” table, but wanted to group results based on the quarter of the year in which the order was placed, you could create a calculated column within the table that would display the quarter of the year for each associated “Order Date” value. You could then add this newly created column into the desired section within a PivotChart or PivotTable to be able to group by the values returned by this calculated column.

To create a calculated column in a table within the PowerPivot data model, first select the tab of the table within the data model window. Then click into the topmost cell within the “Add Column” column at the far right end of the table. You can then enter the formula that you want the column to calculate into the selected field.

Note that for formulas that you enter by hand, the formula is displayed within the Formula Bar. You start by entering the equal sign, followed by the field names enclosed in brackets, joined together by the standard mathematical operators. Note that you can also simply click on the field names of the fields within the table to add a field reference to the formula that you enter. Then simply click the checkmark button in the Formula Bar or press the “Enter” key on your keyboard to accept the formula.

Note that you can also create a formula that uses a function by clicking the “Insert Function” button within the “Calculations” button group on the “Design” tab in the Ribbon of the data model’s window to open the “Insert Function” dialog box. This dialog box shows the functions that you can insert. You can select a function within this listing to see the function and any additional arguments that the function requires shown at the bottom of the dialog box. Select a function to use for the formula from the listing shown and then click the “OK” button to insert it into the Formula Bar. You can then finish entering the additional arguments that the function requires into the Formula Bar. Then simply click the checkmark button in the Formula Bar or press the “Enter” key on your keyboard to accept the formula.

You can also create a calculated field, called a “measure” in PowerPivot for Excel 2010, to display information within the “Values” section of a PivotChart or PivotTable that is more complex than the usual functions allow. Normally, the values of a selected column are calculated using the “SUM” function or other aggregate function in the “Values” section of a PivotTable or PivotChart. This is what is called an “implicit” calculated field within a PivotChart or PivotTable. However, these types of fields within the normal PivotTables and PivotCharts are limited to performing one aggregate function, such as “SUM,” on the field
33.3- Calculated Columns and Fields (cont’d.):

that is placed into the “Values” section. Using PowerPivot, you can create an “explicit” calculated field that is derived from the values within table columns, which you can then add to the “Values” section within a PivotTable or PivotChart. For example, if you wanted to display a field within the “Values” section that was the sum of an “Order Totals” column within a table with a 10% increase to its value as a fiscal projection, you would need to create that field as an “explicit” calculated field within the data model window of PowerPivot. The formula would look something like \( =\text{SUM}([\text{Order Totals}]) \times 1.10 \).

To create a calculated field within the PowerPivot data model window, you can click into the upper-left cell within the “Calculation Area” shown at the bottom of the “Data View” of the data model. Note that you can select any cell within the calculation area, if desired. Some people like to place the calculated fields at the bottom of the columns to which the aggregate calculated field refers. Once you have selected a cell in this area, you can then enter a formula for the calculated field and press the “Enter” key on your keyboard when finished. Note that if you want to rename the field, you can select the text within the Formula Bar that appears before the colon symbol and then type a new name for the field. Once again, click the checkmark button in the Formula Bar or press the “Enter” key on your keyboard to set the name of the field when finished. If you prefer, you can simply type the name to give to the calculated field into the formula as you enter it. Using the previous example, you could name the field “Projected Increase” by entering the following into the Formula Bar for the selected cell: \( \text{Projected Increase} = \text{SUM}([\text{Total Sales}]) \times 1.10 \). Also note that you can use the “Insert Function” button within the “Calculations” button group on the “Design” tab in the Ribbon to insert a function versus typing one manually, if needed. Once the calculated field has been created, it can then be used within the associated PivotTables and PivotCharts in the workbook.
33.4- Creating KPIs:

Another useful feature of creating “explicit” calculated fields within the data model in PowerPivot is the ability to then extend these fields to create KPIs, or “Key Performance Indicators,” within a data model. A KPI is a value, and often associated symbol, that is used to gauge the performance of a base field in attaining a set value. Therefore, you must have three elements before creating a KPI within a data model.

First, you must have a base value. The base value is an “explicit” calculated field that is to be evaluated. Often this is a simple aggregate function over a field that is explicitly defined within the calculation area of the data model for the sole purpose of establishing a base value within a KPI.

Second, you must have a target value. This can either be another “explicit” calculated field within the calculation area, or it can simply be an absolute value that you enter when you create the KPI.

Third, you must define the status threshold within the KPI. This is simply the range between a low and high threshold that determines how well the base value performed in attaining the target value. This is often displayed as a graphic within a PivotTable that shows the performance.

For example, if you had departmental budget information within a table that had a field for “Actual Expenses” and “Budgeted Expenses,” you could create a KPI for the data based on these fields. In this case, you could define two “explicit” calculated fields in the calculation area of the table that were simple AutoSum values over the two columns. In this case the =SUM([Actual Expenses]) calculated field would be the base value, which would then be compared to the =SUM([Budgeted Expenses]) calculated field, which is the targeted value. You could then set the status threshold of the KPI to 100%, meaning that the goal is to spend 100% of the budgeted amount.

To create a KPI once you have created the necessary calculated field or fields, select the calculated field that is to be the base value field for the KPI within the calculation area. Then click the “Create KPI” button within the “Calculations” button group on the “Home” tab within the Ribbon of the data model window. In the “Key Performance Indicator (KPI)” dialog box that appears, the selected field will appear at the top of the dialog box within the “KPI base field (value)” field. Next, in the “Define target value” section, you can select the desired option button for your KPI target value: “Calculated Field” or “Absolute value.” If you select the “Calculated Field” choice, then select the name of the target value field you created from the adjacent drop-down menu. If you select “Absolute value,” then enter the desired value into the adjacent field. Below that, in the “Define status thresholds” section, drag the percentage sliders into the desired locations. Then select a desired icon to represent these threshold values from the listing shown in the “Select icon style” section. When you are ready to create your KPI, click the “OK” button to finish.

The KPI indicator will appear as another type of field that you can insert into the quadrants within the associated PivotTable. You can insert the “Value,” the “Goal,” or the “Status” of the KPI into the “Values” quadrant within the “PivotTable Fields” task pane.
33.5- Creating and Managing Perspectives:

If you are using a data model that is connected to a large relational database as its data source, then you may often find that you are using the same data fields within multiple related tables as the source of information for your PivotTables and PivotCharts in your workbook. It can sometimes be difficult to remember which columns you need to use within which tables in the relational database when constructing these PivotTables and PivotCharts. In order to help assist users in accessing a more manageable data set of only the columns of data that they will need to use, you can create a perspective within the PowerPivot data model. A perspective, much like a “view” in traditional relational database terminology, is simply a definition of which columns from which tables should be displayed within a single view of your data source. While a perspective does not exist in the same way that a traditional base table within the database does, it is created temporarily to allow access to only the columns of data you select from tables within a single view of the data. Creating a perspective can result in less scrolling and hunting through the columns of data that you will need to use within large tables in a data model.

To create a perspective of your data within the data model window in PowerPivot, click the “Create and Manage” button within the “Perspectives” button group on the “Advanced” tab within the Ribbon. Note that if you do not see the “Advanced” tab within the data model window, then you may be running PowerPivot in “Normal” mode. You can switch to “Advanced” mode, and thus display the “Advanced” tab in the Ribbon, by clicking the “File” tab in the Ribbon of the data model window and then selecting the “Switch to Advanced Mode” command from the menu that appears.

Within the “Perspectives” dialog box that then appears, you will see the tables in the data model listed in an expandable and collapsible list at the left side of the dialog box. Click the plus sign next to the names of any tables whose columns you wish to add to the perspective to view the column names.

To then create a new perspective, click the “New Perspective” button at the top of the dialog box. Then type a name for the new perspective into the top of the column that appears. Underneath the column name, click the checkbox that appears to the right of any column that you want to add to the perspective from the tables within the data model. When you are finished adding columns to the perspective, click the “OK” button to finish.

To then filter the view of the data model to only the columns that are selected within the perspective, click the “Select” drop-down button within the “Perspectives” button group on the “Advanced” tab in the Ribbon. Then select the name of the perspective to use from the drop-down list that appears. The tables within the data model will then be filtered to only display the selected columns from the selected tables.

To view all of the data within the data model again, click the “Select” drop-down button within the “Perspectives” button group on the “Advanced” tab in the Ribbon. Then select the “Default” choice from the drop-down list that appears to view all data within the data model again.

You can also edit and delete perspectives that you have created. Once again, open the “Perspectives” dialog box by clicking the “Create and Manage” button within the “Perspectives” button group on the “Advanced” tab within the Ribbon. You can then edit the definitions of the perspectives shown by simply checking or unchecking the checkboxes within the perspective’s column. To delete a perspective, hold your mouse pointer over the perspective definition that you want to delete. You will then see three buttons appear at the top of the selected perspective definition. You can click the leftmost button of the three buttons shown to delete the selected perspective. Then click the “OK” button when you are finished managing your perspectives.
33.6- PowerPivot PivotTables and PivotCharts:

You can also easily insert PivotTables and PivotCharts into your workbook from within the data model window of PowerPivot. To do this, click the drop-down part of the “PivotTable” button within the “Home” tab in the Ribbon of the data model window. You will then see a drop-down menu of the various PivotTable and PivotChart layouts that are available. Note that there are many more choices shown here than are normally available when inserting a PivotTable or PivotChart within Excel. Simply click on the type of PivotTable or PivotChart layout that you want to insert to open the “Insert PivotTable” dialog box where you can then choose where to insert the selected item or items. Once the items have been inserted, you can then use the fields shown within the “PivotTable Field List” or “PivotChart Field List” task panes to add the data from the data model into the desired quadrants within the selected PivotTable or PivotChart.
STARTING POWERPIVOT:

1. To enable PowerPivot in Excel Professional Plus 2013, click the “File” tab in the Ribbon to open the backstage view.
2. Click the “Options” category at the left side of the backstage view to open the “Excel Options” window.
3. Within this window, click the “Add-Ins” category shown at the left side.
4. At the bottom right side of this window, select “COM Add-ins” from the “Manage” drop-down and then click the “Go…” button to open the “COM Add-Ins” window.
5. Check the checkbox for the “Microsoft Office PowerPivot for Excel” add-in, and then click the “OK” button to the right to enable the add-in.
6. At this point, you should see a new “PowerPivot” tab appear within the Ribbon. You can click this tab within the Ribbon to view the commands used to manage your PowerPivot data within Excel.

MANAGING THE DATA MODEL:

1. You can click the “Manage” button within the “Data Model” button group on the “PowerPivot” tab within the Ribbon to open a separate, visual instance of the workbook’s data model.
2. The Ribbon within the “PowerPivot for Excel” window has four tabs: “File,” “Home,” “Design,” and “Advanced.”
3. Below that is the Formula Bar within the data model.
4. Below the Formula Bar is the “Data View” of the tables within the data model.
5. In a separate pane below the data area is the “Calculation Area.”
6. Below the calculation area you can see the names of the various tables within the data model displayed as tabs. You can click these tabs to switch between the tables within the data model.
7. A recordset navigator is displayed for the currently selected table at the bottom of the window. You can click the buttons within the navigator to move back and forth through the records in the selected table.
8. In addition to the “Data View” of the data model, you can also view the “Diagram View” of the data model by clicking the “Diagram View” button within the “View” button group on the “Home” tab of the Ribbon within the data model window. This view allows you to see the tables in the data model as diagrams that display the links, or relationships, between fields in the tables.
9. You can create relationships between tables by simply clicking and dragging a field from one table diagram and then dropping it onto the related field within another table diagram in this view.
10. You can also right-click on the relationship line shown between two fields, and then select the “Edit Relationship” command to open the “Edit Relationship” window, if needed.
11. You could also select the “Delete” command from the pop-up menu to delete a selected relationship from the data model. Note that you will need to click the “Delete from Model” button in the confirmation dialog box that appears to delete the relationship, if desired.
12. You can click the “Data View” button within the “View” button group in the Ribbon again to toggle the view back to “Data View” when you are finished.
CREATING CALCULATED COLUMNS AND FIELDS:

1. To create a calculated column in a table within the PowerPivot data model, first select the tab of the table within the data model window.
2. Click into the topmost cell within the “Add Column” column at the far right end of the table.
3. Enter the formula that you want the column to calculate into the selected field.
4. Note that for formulas that you enter by hand, the formula is displayed within the Formula Bar. You start by entering the equal sign, followed by the field names enclosed in brackets, joined together by the standard mathematical operators. Note that you can also simply click on the field names of the fields within the table to add a field reference to the formula that you enter.
5. Click the checkmark button in the Formula Bar or press the “Enter” key on your keyboard to accept the formula.
6. Note that you can also create a formula that uses a function by clicking the “Insert Function” button within the “Calculations” button group on the “Design” tab in the Ribbon of the data model’s window to open the “Insert Function” dialog box. This dialog box shows the functions that you can insert.
7. You can select a function within this listing to see the function and any additional arguments that the function requires shown at the bottom of the dialog box.
8. Select a function to use for the formula from the listing shown and then click the “OK” button to insert it into the Formula Bar.
9. You can then finish entering the additional arguments that the function requires into the Formula Bar.
10. Then click the checkmark button in the Formula Bar or press the “Enter” key on your keyboard to accept the formula.

11. To create a calculated field within the PowerPivot data model window, click into the upper-left cell within the “Calculation Area” shown at the bottom of the “Data View” of the data model. Note that you can select any cell within the calculation area, if desired. Some people like to place the calculated fields at the bottom of the columns to which the aggregate calculated field refers.
12. Once you have selected a cell in this area, you can then enter a formula for the calculated field and press the “Enter” key on your keyboard when finished.
13. Note that if you want to rename the field, you can select the text within the Formula Bar that appears before the colon symbol and then type a new name for the field.
14. Once again, click the checkmark button in the Formula Bar or press the “Enter” key on your keyboard to set the name of the field when finished.
15. Also note that you can use the “Insert Function” button within the “Calculations” button group on the “Design” tab in the Ribbon to insert a function versus typing one manually, if needed.
CREATING A KPI:

1. First, you must have a base value. The base value is an “explicit” calculated field that is to be evaluated. Often this is a simple aggregate function over a field that is explicitly defined within the calculation area of the data model for the sole purpose of establishing a base value within a KPI.
2. Second, you must have a target value. This can either be another “explicit” calculated field within the calculation area, or it can simply be an absolute value that you enter when you create the KPI.
3. Third, you must define the status threshold within the KPI. This is simply the range between a low and high threshold that determines how well the base value performed in attaining the target value. This is often displayed as a graphic within a PivotTable that shows the performance.
4. To create a KPI once you have created the necessary calculated field or fields, select the calculated field that is to be the base value field for the KPI within the calculation area.
5. Click the “Create KPI” button within the “Calculations” button group on the “Home” tab within the Ribbon of the data model window.
6. In the “Key Performance Indicator (KPI)” dialog box that appears, the selected field will appear at the top of the dialog box within the “KPI base field (value)” field.
7. In the “Define target value” section, you can select the desired option button for your KPI target value: “Calculated Field” or “Absolute value.”
8. If you select the “Calculated Field” choice, then select the name of the target value field you created from the adjacent drop-down menu.
9. If you select “Absolute value,” then enter the desired value into the adjacent field.
10. Below that, in the “Define status thresholds” section, drag the percentage sliders into the desired locations.
11. Then select a desired icon to represent these threshold values from the listing shown in the “Select icon style” section.
12. When you are ready to create your KPI, click the “OK” button to finish.
13. The KPI indicator will appear as another type of field that you can insert into the quadrants within the associated PivotTable.
14. You can insert the “Value,” the “Goal,” or the “Status” of the KPI into the “Values” quadrant within the “PivotTable Fields” task pane.
CREATING AND MANAGING PERSPECTIVES:

1. To create a perspective of your data within the data model window in PowerPivot, click the “Create and Manage” button within the “Perspectives” button group on the “Advanced” tab within the Ribbon.

2. Note that if you do not see the “Advanced” tab within the data model window, then you may be running PowerPivot in “Normal” mode. You can switch to “Advanced” mode, and thus display the “Advanced” tab in the Ribbon, by clicking the “File” tab in the Ribbon of the data model window and then selecting the “Switch to Advanced Mode” command from the menu that appears.

3. Within the “Perspectives” dialog box that then appears, you will see the tables in the data model listed in an expandable and collapsible list at the left side of the dialog box.

4. Click the plus sign next to the names of any tables whose columns you wish to add to the perspective to view the column names.

5. To then create a new perspective, click the “New Perspective” button at the top of the dialog box.

6. Then type a name for the new perspective into the top of the column that appears.

7. Underneath the column name, click the checkbox that appears to the right of any column that you want to add to the perspective from the tables within the data model.

8. When you are finished adding columns to the perspective, click the “OK” button to finish.

9. To then filter the view of the data model to only the columns that are selected within the perspective, click the “Select” drop-down button within the “Perspectives” button group on the “Advanced” tab in the Ribbon.

10. Then select the name of the perspective to use from the drop-down list that appears. The tables within the data model will then be filtered to only display the selected columns from the selected tables.

11. To view all of the data within the data model again, click the “Select” drop-down button within the “Perspectives” button group on the “Advanced” tab in the Ribbon.

12. Then select the “Default” choice from the drop-down list that appears to view all data within the data model again.

13. You can also edit and delete perspectives that you have created. Once again, open the “Perspectives” dialog box by clicking the “Create and Manage” button within the “Perspectives” button group on the “Advanced” tab within the Ribbon.

14. You can then edit the definitions of the perspectives shown by simply checking or unchecking the checkboxes within the perspective’s column.

15. To delete a perspective, hold your mouse pointer over the perspective definition that you want to delete. You will then see three buttons appear at the top of the selected perspective definition.

16. You can click the leftmost button of the three buttons shown to delete the selected perspective.

17. Then click the “OK” button when you are finished managing your perspectives.

INSERTING PIVOTTABLES AND PIVOTCHARTS WITHIN POWERPIVOT:

1. Click the drop-down part of the “PivotTable” button within the “Home” tab in the Ribbon of the data model window.

2. Click on the type of PivotTable or PivotChart layout that you want to insert to open the “Insert PivotTable” dialog box where you can then choose where to insert the selected item or items.

3. Once the items have been inserted, you can then use the fields shown within the “PivotTable Field List” or “PivotChart Field List” task panes to add the data from the data model into the desired quadrants within the selected PivotTable or PivotChart.
Purpose:

1. To be able to enable and use PowerPivot within Excel Professional Plus 2013.

Exercises:

2. Open the “Advanced Excel” workbook that has been completed through the Exercise at the end of Chapter 31.
3. If you do not already have PowerPivot enabled within Excel 2013, you must first enable the feature by clicking the “File” tab in the Ribbon to open the backstage view.
4. Click the “Options” category at the left side of the backstage view to open the “Excel Options” window.
5. Within this window, click the “Add-Ins” category shown at the left side.
6. At the bottom right side of this window, select “COM Add-ins” from the “Manage” drop-down and then click the “Go…” button to open the “COM Add-Ins” window.
7. Check the checkbox for the “Microsoft Office PowerPivot for Excel” add-in, and then click the “OK” button to the right to enable the add-in.
8. Click the “PowerPivot” tab within the Ribbon.
9. Select the “Sheet1” worksheet.
10. Click the “Manage” button within the “Data Model” button group on the “PowerPivot” tab in the Ribbon to open the “PowerPivot for Excel” window.
11. Click the “Diagram View” button within the “View” button group on the “Home” tab within the Ribbon of the “PowerPivot for Excel” window to show the relationships between the tables in the data model.
12. Click the “Data View” button within the “View” button group on the “Home” tab within the Ribbon of the “PowerPivot for Excel” window to show the data within the tables in the data model. The names of the tables are shown as tabs in the lower left corner of the window.
13. Select the “Salespeople” table tab shown in the lower left corner of the “PowerPivot for Excel” window to display its data within the window.
14. Click into the top cell within the leftmost column titled “Add Column.”
15. Click into the formula bar above the column area and enter the following formula into the formula bar: =CONCATENATE([First Name],CONCATENATE(“ “,[Last Name]))
16. Press the “Enter” key on your keyboard to enter the formula into the new calculated column.
17. Right-click the gray column heading of the new “CalculatedColumn1” and then select the “Rename Column” command from the pop-up menu that appears.
18. Type “Full Name” as the new name of the column and then press the “Enter” key on your keyboard to set the new column name.
19. Click the “Save” button in the Quick Access toolbar at the top of the “PowerPivot for Excel” window to save your changes to the data model.
20. Select the “Sales” table tab shown in the lower left corner of the “PowerPivot for Excel” window to display its data within the window.
21. Click into the topmost cell underneath the “Order Total” column within the “Calculation Area” at the bottom of the “PowerPivot for Excel” window.
22. Click the drop-down button to the right of the “AutoSum” button within the “Calculations” button group on the “Home” tab within the Ribbon of the “PowerPivot for Excel” window and then select the “Average” command from the drop-down menu that appears.
23. With the same cell still selected, click the “Create KPI” button within the “Calculations” button group on the “Home” tab within the Ribbon of the “PowerPivot for Excel” window to set that value as a KPI.
24. In the “Key Performance Indicator (KPI)” dialog box, select the “Absolute value” option button and then enter “650” into the adjacent field to the right.
25. In the “Define status thresholds” section, click into the text field above the rightmost slider and then type “651” into the field to move the slider and set that as the “Green” status indicator value.
26. Then, in the same area, click into the text field above the leftmost slider and then type “649” into the field. That will effectively move that slider to the same “Target” area as the lower “Red” status threshold.
27. Then click the “OK” button to create the KPI.
28. Click the “Save” button within the “Quick Access Toolbar” at the top of the “PowerPivot for Excel” window to save your changes.
29. Click the drop-down part of the “PivotTable” button within the “Home” tab of the Ribbon in the “PowerPivot for Excel” window and then select the “Chart and Table (Horizontal)” choice from the drop-down menu that appears.
30. In the “Insert Pivot” dialog box that appears, select the “New Worksheet” option button and then click the “OK” button to insert the new PivotTable and PivotChart into a new worksheet titled “Sheet3.”
31. Switch back to the “PowerPivot for Excel” window and then click the “Close” button in the Upper-right corner of the window to close the data model.
32. Select “Sheet3” within the workbook, and then click on the PivotTable within the worksheet to select it.
33. In the “PivotTable Fields” pane at the right side of the screen, click the small arrow to the left of the “Salespeople” table to expand it and display its fields.
34. Click and drag the “Full Name” field from the field list into the “Rows” section at the bottom of the “PivotTable Fields” pane.
35. In the “PivotTable Fields” pane, click the small arrow to the left of the “Sales” table to expand it and display its fields.
36. Click and drag the “Order Total” field from the field list into the “Values” section at the bottom of the “PivotTable Fields” pane.
37. In the “PivotTable Fields” pane, click the small arrow to the left of the “Average of Order Total” KPI to expand it and display its fields.
38. Click and drag the “Value (Average of Order Total)” KPI field from the field list and then drop it at the bottom of the “Values” section.
39. Click the checkmark next to the “Goal” KPI field within the field list to add it to the “Values” section.
40. Click the checkmark next to the “Status” KPI field within the field list to add it to the bottom of the “Values” section.
41. Click the PivotChart within the “Sheet3” worksheet to select it.
42. In the “PivotChart Fields” pane at the right side of the screen, click the small arrow to the left of the “Salespeople” table to expand it and display its fields.
43. Click and drag the “Full Name” field from the field list into the “Axis (Categories)” section at the bottom of the “PivotChart Fields” pane.
44. In the “PivotChart Fields” pane, click the small arrow to the left of the “Sales” table to expand it and display its fields.
45. Click and drag the “Order Total” field from the field list into the “Values” section at the bottom of the “PivotChart Fields” pane.
46. In the “PivotChart Fields” pane, click the small arrow to the left of the “Regions” table to expand it and display its fields.
47. Click and drag the “Region” field from the field list into the “Filters” section at the bottom of the “PivotChart Fields” pane.
**Exercises- (cont’d.):**

48. Click the “Region” drop-down filter field that appears in the upper left corner of the PivotChart.
49. Check the “Select Multiple Items” checkbox at the bottom of the drop-down menu.
50. Click the plus sign next to the “All” category to expand it and show the regions available.
51. Click the checkmark next to the “All” category to deselect all of the checkboxes.
52. Click to place a checkmark next to the checkboxes for “North” and “West.”
53. Click the “OK” button within the drop-down menu to filter the PivotChart to only display employee sales for those two selected regions.
54. Click the “Save” button within the Quick Access toolbar to save your changes to the “Advanced Excel” workbook.
55. You may close the workbook, if you would like to.
56. Keep this workbook, as you will need the information within it to perform the Exercises at the end of the following chapters within this manual! The Exercises should be completed in sequential order.
34.1- Starting Power View
34.2- Adding Report Visualizations
34.3- Changing the Layout of Report Visualizations
34.4- Using Undo and Redo in Power View
34.5- Formatting the Power View Sheet
34.6- Creating Multiples in a Chart
34.1- Starting Power View:

Power View is a reporting tool that is available in Microsoft Office Excel Professional Plus 2013. You must first enable Power View in Excel 2013 before you can use the reporting and visualization features of the tool. Note that to use Power View, you must also have Internet Explorer with the Silverlight add-in installed. If you do not, you will be prompted to install Silverlight when you initially enable Power View in Excel 2013.

To enable Power View in Excel 2013, click the “Insert” tab in the Ribbon and then click the “Power View” button in the “Reports” button group. If this is the first time that you have used Power View a dialog box will appear that tells you to enable this feature. Click the “Enable” button to turn Power View on. Excel 2013 will then insert a Power View reporting worksheet into your Excel workbook. If you need to install Microsoft Silverlight, you will then see a message at the top of the Power View worksheet informing you of that fact. You can click the “Install” hyperlink in the message bar to install Silverlight and then click the “Reload” button in the message bar to reload the Power View worksheet.

Once you have enabled Power View in Excel, you can then insert a Power View worksheet into a workbook by simply clicking the “Power View” button in the “Reports” button group on the “Insert” tab within the Ribbon. You will then see the “Power View” tab appear within the Ribbon.

Note that you can insert a Power View worksheet that uses a selected table as a data source by simply clicking into the table within the worksheet, first. You can then click the “Power View” button in the “Reports” button group on the “Insert” tab within the Ribbon. Alternately, you can select an empty cell within a worksheet and then click the “Power View” button to create a blank Power View worksheet to which you can add fields from the workbook’s data model by using the “Power View Fields” task pane that appears at the right side of the Power View worksheet, just as you would if creating a PivotChart or PivotTable.

34.2- Adding Report Visualizations:

You can visualize the report data within the Power View worksheet. To add data visualizations to a Power View worksheet, simply drag a data field shown within the “Power View Field” task pane into the “Fields” section within the task pane, or directly into the large visualization area to the left beneath the Power View report title. The field will be added as a table, complete with column headings within the visualization area. If you would like to display other fields within the default data visualization, then simply click and drag the other fields to add into the desired locations within the “Fields” listing in the task pane.

You can change the display of a selected data visualization by clicking into the desired data visualization. You will note that a visualization is selected when you see gray resizing handles appear around the perimeter of the visualization. You will also see a new “Design” tab appear within the Ribbon. You can use the buttons found within the “Switch Visualizations” button group on the “Design” tab in the Ribbon to change the type of visualization used for the selected data. These buttons are: “Table,” “Bar Chart,” “Column Chart,” “Other Chart,” and “Map.” Simply click the desired button and then make a choice from the drop-down if needed, to select a new type of data visualization.

Note that if any of these buttons appear “greyed-out” or un-selectable, that simply means that Power View has determined that your currently selected data cannot support that type of visualization. For example, you must have some type of geographic data to use the “Map” visualization. Also note that each of these buttons, with the exception of the “Map” button is a drop-down button that will allow you to select from multiple possible variations of the selected visualization type.

Also note that you have options for your selected visualization within the button groups that are shown on the “Design” tab within the Ribbon. For some selected types of visualizations, such as the “Card”
Power View

34.2- Adding Report Visualizations- (cont’d.):

type, you can use the buttons within the “Tiles” button group to choose the layout of the tiles of information within the visualization.

For data visualizations that are added to the Power View sheet that could act as a filter for the information, you can select the desired data visualization within the Power View sheet and then click the “Slicer” button to have the data visualization act as a way of visually filtering, or slicing the data displayed. Simply click on the value to display within the slicer to filter the other data visualizations by the selection.

If you have a card, table, or matrix data visualization selected, you can often use the buttons within the “Options” button group on the “Design” tab to set the display style of the information within the visualization from the three drop-down buttons that appears within this group.

The “Number” button group allows you to set the formatting of numbers within the selected data visualization and the “Text” button group allows you to set the size of text within the selected visualization. You can use the buttons within the “Arrange” button group to change the stacking order of data visualizations that overlap within the Power View sheet.

34.3- Changing the Layout of Report Visualizations:

You can also change the layout of selected “Chart” and “Map” type report visualizations by using the “Layout” tab that appears within the Ribbon when you have one of these types of data visualizations selected within the Power View sheet. On this tab, you can use the “Title,” “Legend,” “Data Labels” and “Map Background” buttons in the “Labels” button group to select a layout for the corresponding elements within the currently selected data visualization. You can use the “Type” drop-down button within the “Axis” button group to choose the behavior of the x-axis within chart data visualizations. For data visualizations based on multiple field values that are added to the “Vertical Multiples” and “Horizontal Multiples” sections within the “Power View Fields” pane, you can use the “Grid Height” and “Grid Width” drop-down buttons to set the display of multiple field values within the data visualization. Finally, you can use the “Axes,” “Colors,” and “Bubbles” buttons within the “Synchronize” button group to synchronize the display of those elements within a selected data visualization that contains horizontal and/or vertical multiples.

34.4- Using Undo and Redo in Power View:

As you make changes to the data visualizations within the Power View sheet, note that you cannot use the “Undo” and “Redo” buttons that appear in the Quick Access toolbar to reverse changes that are made to the Power View sheet. To undo changes made to the Power View sheet, click the “Power View” tab within the Ribbon and then click the “Undo” button within the “Undo/Redo” button group. You can also click the “Redo” button to redo changes that were undone by using the “Undo” button, if needed.
34.5- Formatting the Power View Sheet:

If you click the “Power View” tab within the Ribbon, you will see the button groups that you can use to format the appearance of the Power View sheet itself. At the far left end of this tab is the “Clipboard” button group which contains buttons that allow you to cut, copy and paste visualizations within Power View. That is followed by the “Undo/Redo” button group that allows you to undo and redo actions taken within the Power View sheet. You can use the buttons within the “Themes” button group to apply and customize a theme for your Power View sheet. This includes changing the “Font,” “Text Size” and “Background” applied to the elements within the Power View sheet.

If you want to add a custom image to the background of the Power View sheet, you can click the “Set Image” drop-down button within the “Background Image” button group and then select the “Set Image” command from the drop-down menu to open a dialog box that allows you to select an image to use from the files on your computer. You can click this same button and then select the “Remove Image” command to remove an image you have added to the background, if needed. You can also use the “Image Position” and “Transparency” buttons to set the placement and transparency of an inserted background image.

You can use the “Refresh” and “Relationships” button within the “Data” button group to refresh the underlying data within the data source and create relationships within the data source, if needed.

You can click the buttons within the “View” button group to toggle the display of the corresponding elements within the Power View sheet on and off. You can click the buttons within the “Insert” button group to select a type of object to insert: “Power View,” “Text Box,” or “Picture.” You can select an object within the Power View sheet and then click the “Arrange” button in the “Arrange” button group to change the placement of the objects within a stack of objects, if needed.

34.6- Creating Multiples in a Chart:

For many types of data visualizations that use an x and y axis, such as the chart type data visualizations, you can choose to plot multiple fields within the same x and y axes in the chart by making use of the “multiples” feature within Power View. This allows you to plot multiple field values, such as “Quantity Ordered” and “Quantity Shipped” within the same chart using the same x and y axis values.

To add a field value to a selected data visualization, place the field you want to add as a multiple into either the “Vertical Multiples” or “Horizontal Multiples” sections within the “Power View Fields” pane when the desired data visualization is selected. The fields will be displayed within the same selected data visualization, but in adjacent areas either above or to the right of the primary field shown.
STARTING POWER VIEW:

1. To enable Power View in Excel Professional Plus 2013, click the “Insert” tab in the Ribbon and then click the “Power View” button in the “Reports” button group.
2. If this is the first time that you have used Power View a dialog box will appear that tells you to enable this feature.
3. Click the “Enable” button to turn Power View on.
4. Excel Professional Plus 2013 will then insert a Power View worksheet into your Excel workbook.
5. If you need to install Microsoft Silverlight, you will then see a message at the top of the Power View worksheet informing you of that fact.
6. You can click the “Install” hyperlink in the message bar to install Silverlight and then click the “Reload” button in the message bar reload the Power View worksheet.
7. Once you have enabled Power View in Excel, you can then insert a Power View worksheet into a workbook by simply clicking the “Power View” button in the “Reports” button group on the “Insert” tab within the Ribbon. You will then see the “Power View” tab appear within the Ribbon.
8. Note that you can insert a Power View worksheet that uses a selected table as a data source by simply clicking into the table within the worksheet, first.
9. You can then click the “Power View” button in the “Reports” button group on the “Insert” tab within the Ribbon.
10. Alternately, you can select an empty cell within a worksheet and then click the “Power View” button to create a blank Power View worksheet to which you can add fields from the workbook’s data model by using the “Power View Fields” task pane that appears at the right side of the Power View worksheet, just as you would if creating a PivotChart or PivotTable.

ADDITION REPORT VISUALIZATIONS:

1. Drag a data field shown within the “Power View Field” task pane into the “Fields” section within the task pane or directly into the large visualization area to the left beneath the Power View report title.
2. If you would like to display other fields within the default data visualization, then simply click and drag the other fields to add into the desired locations within the “Fields” listing in the task pane.
3. You can change the display of a selected data visualization by clicking into the desired data visualization. Note that a visualization is selected when you see gray resizing handles appear around the perimeter of the visualization. You will also see a new “Design” tab appear within the Ribbon.
4. You can use the buttons found within the “Switch Visualizations” button group on the “Design” tab in the Ribbon to change the type of visualization used for the selected data. These buttons are: “Table,” “Bar Chart,” “Column Chart,” “Other Chart,” and “Map.” Simply click the desired button and then make a choice from the drop-down if needed, to select a new type of data visualization.
5. Note that you have options for your selected visualization within the button groups that are shown on the “Design” tab within the Ribbon. For some selected types of visualizations, such as the “Card” type, you can use the buttons within the “Tiles” button group to choose the layout of the tiles of information within the visualization.
6. For data visualizations added to the Power View sheet that could act as a filter for the information, you can select the desired data visualization within the Power View sheet and then click the “Slicer” button to have the data visualization act as a way of visually filtering, or slicing the data displayed. Simply click on the value to display within the slicer to filter the other data visualizations by the selection.

(cont’d.)
ADDING REPORT VISUALIZATIONS- (CONT’D.):

7. If you have a card, table, or matrix data visualization selected, you can often use the buttons within the “Options” button group on the “Design” tab to set the display style of the information within the visualization from the three drop-down buttons that appears within this group.
8. The “Number” button group allows you to set the formatting of numbers within the selected data visualization and the “Text” button group allows you to set the size of text within the selected visualization.
9. You can use the buttons within the “Arrange” button group to change the stacking order of data visualizations that overlap within the Power View sheet.

CHANGING THE LAYOUT OF REPORT VISUALIZATIONS:

1. You can also change the layout of selected “Chart” and “Map” type report visualizations by using the “Layout” tab that appears within the Ribbon when you have one of these types of data visualizations selected within the Power View sheet.
2. On this tab, you can use the “Title,” “Legend,” “Data Labels” and “Map Background” buttons in the “Labels” button group to select a layout for the corresponding elements within the currently selected data visualization.
3. You can use the “Type” drop-down button within the “Axis” button group to choose the behavior of the x-axis within chart data visualizations.
4. For data visualizations based on multiple field values that are added to the “Vertical Multiples” and “Horizontal Multiples” sections within the “Power View Fields” pane, you can use the “Grid Height” and “Grid Width” drop-down buttons to set the display of multiple field values within the data visualization.
5. You can use the “Axes,” “Colors,” and “Bubbles” buttons within the “Synchronize” button group to synchronize the display of those elements within a selected data visualization that contains horizontal and/or vertical multiples.

USING UNDO AND REDO IN POWER VIEW:

1. To undo changes made to the Power View sheet, click the “Power View” tab within the Ribbon and then click the “Undo” button within the “Undo/Redo” button group.
2. You can also click the “Redo” button to redo changes that were undone by using the “Undo” button, if needed.
FORMATTING THE POWER VIEW SHEET:

1. If you click the “Power View” tab within the Ribbon, you will see the button groups that you can use to format the appearance of the Power View sheet itself.
2. At the far left end of this tab is the “Clipboard” button group which contains buttons that allow you to cut, copy and paste visualizations within Power View.
3. That is followed by the “Undo/Redo” button group that allows you to undo and redo actions taken within the Power View sheet.
4. You can use the buttons within the “Themes” button group to apply and customize a theme for your Power View sheet. This includes changing the “Font,” “Text Size” and “Background” applied to the elements within the Power View sheet.
5. If you want to add a custom image to the background of the Power View sheet, you can click the “Set Image” drop-down button within the “Background Image” button group and then select the “Set Image” command from the drop-down menu to open a dialog box that allows you to select an image to use from the files on your computer.
6. You can click this same button and then select the “Remove Image” command to remove an image you have added to the background, if needed.
7. You can also use the “Image Position” and “Transparency” buttons to set the placement and transparency of an inserted background image.
8. You can use the “Refresh” and “Relationships” button within the “Data” button group to refresh the underlying data within the data source and create relationships within the data source, if needed.
9. You can click the buttons within the “View” button group to toggle the display of the corresponding elements within the Power View sheet on and off.
10. You can click the buttons within the “Insert” button group to select a type of object to insert: “Power View,” “Text Box,” or “Picture.”
11. You can select an object within the Power View sheet and then click the “Arrange” button in the “ Arrange” button group to change the placement of the objects within a stack of objects, if needed.

CREATING MULTIPLES IN A CHART:

1. To add a field value to a selected data visualization, place the field you want to add as a multiple into either the “Vertical Multiples” or “Horizontal Multiples” sections within the “Power View Fields” pane when the desired data visualization is selected.
2. The fields will be displayed within the same selected data visualization, but in adjacent areas either above or to the right of the primary field shown.
Purpose:

1. To be able to create and manipulate data visualizations in Power View in Excel Professional Plus 2013.

Exercises:

1. Open Excel Professional Plus 2013 and then open the “Advanced Excel” workbook completed through the Exercise at the end of the previous chapter.
2. Select cell A1 in “Sheet3.”
3. Click the “Insert” tab in the Ribbon and then click the “Power View” button in the “Reports” button group.
4. If this is the first time that you have used Power View a dialog box will appear that tells you to enable this feature. Click the “Enable” button to turn Power View on.
5. If you need to install Microsoft Silverlight, you will then see a message at the top of the Power View worksheet informing you of that fact. You can click the “Install” hyperlink in the message bar to install Silverlight and then click the “Reload” button in the message bar reload the Power View worksheet.
6. At this point you should have a new worksheet titled “Power View)” displayed within Excel 2013.
7. Click and drag the “Region” field from the “Regions” table shown within the “Power View Fields” pane and then drop it into the large data visualization area to the right, below the title text.
8. Click and drag the “Department” field from the “Regions” table shown within the “Power View Fields” pane and then drop it into the data visualization that you just created to add that column to the same data visualization.
9. Click and drag the “Budgeted Expenses” field from the “Regions” table shown within the “Power View Fields” pane and then drop it into the data visualization that you just created to add that column to the same data visualization.
10. Click and drag the “Actual Expenses” field from the “Regions” table shown within the “Power View Fields” pane and then drop it into the data visualization that you just created to add that column to the same data visualization.
11. With the data visualization selected, click the “Table” drop-down button within the “Switch Visualization” button group on the “Design” tab in the Ribbon and then choose the “Matrix” command from the drop-down menu that appears to switch the data visualization into a matrix.
12. Click the “Tiles” button within the “Tiles” button group to change the display of the matrix to a set of tiles for the regions displayed across the top of the data visualization.
13. If needed, place your mouse pointer over the lower-right corner of the data visualization and then click and drag diagonally down and to the right to increase the size of the data visualization so that you can easily see all of the data. Use this resizing method to change the size of the data visualization so that it extends to the bottom of the displayed screen area, and is wide enough to display all of the data within the columns.
14. Click the “All” command at the top of the “Power View Fields” pane at the right side of the screen to display all of the tables within the data model in the pane.
15. Click and drag the “State” field from the “Regions” table and drop it into the existing data visualization. It will insert itself as its own related data visualization within the larger data visualization.
16. With the new “State” data visualization still selected, click the “Map” button within the “Switch Visualization” button group on the “Design” tab in the Ribbon to switch the new data visualization to a map.
17. Place your mouse pointer over the top edge of the new data visualization until your mouse pointer turns into an upward pointing hand. At that point, click and drag the new data visualization below and to the far left side of its existing data visualization, so that the top of it is placed below the “Total.”
Exercises-(cont’d.):

18. Once the data visualization is in place, put your mouse pointer over its lower-right corner until the mouse pointer turns into the double-pointed resizing arrows. At that point, click and drag the data visualization diagonally down and to the right until it fills up the bottom of the larger data visualization within which it has been placed. You should now be able to see a blue dot for the selected state within the map shown.

19. Click the “Layout” tab within the Ribbon.

20. Click the “Map Background” drop-down button within the “Labels” button group on the “Layout” tab within the Ribbon and then select the “Aerial (Satellite Photo) Map Background choice from the drop-down menu.

21. Click into the text at the top of the Power View sheet that displays the text “Click here to add a title,” and then type “Departmental Budgets” as the new Power View report title. The Power View should now resemble the picture shown at the bottom of this page.

22. Click the “North” choice within the primary data visualization to view the changes to the budget data within the primary visualization as well as the map.

23. Click the “South” choice within the primary data visualization to view the changes to the budget data within the primary visualization as well as the map.

24. Click the “West” choice within the primary data visualization to view the changes to the budget data within the primary visualization as well as the map.

25. When finished, click the “Save” button within the Quick Access toolbar to save the changes to the “Advanced Excel” workbook.

26. You may close the workbook, if you would like to.

27. Keep this workbook, as you will need the information within it to perform the Exercises at the end of the following chapters within this manual! The Exercises should be completed in sequential order.
CHAPTER 35 - Slicers and Timelines

35.1 - Inserting and Deleting Slicers

35.2 - Modifying Slicers

35.3 - Inserting and Deleting Timelines

35.4 - Modifying Timelines
35.1- Inserting and Deleting Slicers:

Within Excel, slicers are used to visually filter data within Tables, PivotTables, PivotCharts, data visualizations in Power View, and PowerPivot tables and charts. To insert a slicer into a worksheet, select one of these types of objects within a worksheet. Then click the “Slicer” button within the “Filters” button group on the “Insert” tab within the Ribbon to open the “Insert Slicer” dialog box. This dialog box will then display the names of the fields within the associated tables of the selected object. Click to place a checkmark in the checkbox next to the name of the field by which you want to filter the data within a slicer. Then click the “OK” button to add a slicer for the selected object into the worksheet.

You can click and drag the slicer panel around within the worksheet to reposition it, if needed. You can also use the resizing handles that appear around the perimeter of the object to resize it, if desired. The slicer will display buttons that represent the unique values contained within the selected field. To filter the selected object, click the button within the slider to choose the associated values to display within the associated object. The selected data object will then be filtered by your selection within the slicer and only display records for the current button selection. Note that you can use the multiple selection techniques of holding the “Shift” or “Ctrl” keys and then clicking on multiple buttons within the slicer to select multiple adjacent or non-adjacent slicer buttons to filter for multiple values, if needed. You can clear any slicer filters applied by clicking the “Clear Filters” button in the upper-right corner of the slicer pane.

To delete a slicer, click the slicer pane to select it and then press the “Del” or “Delete” key on your keyboard to delete the selected slicer. Alternately, you may right-click on the slicer pane and then select the “Remove (field name)” command from the pop-up menu to delete a slicer. Note that the (field name) value will be the name of the field used to slice the data.

35.2- Modifying Slicers:

After inserting a slicer into your worksheet, you should see a new “Options” tab within a new “Slicer Tools” contextual tab in the Ribbon. You will see this tab appear within the Ribbon any time that you have the slicer selected within the workbook. You can use the buttons within this tab to modify the slicer settings and make other adjustments to the slicer.

In the “Slicer” button group at the left end of this tab, you can see and edit the name of the “Slicer Caption” within the text box shown. You can also click the “Slicer Settings” button here to open the “Slicer Settings” dialog box. This dialog box allows you to edit the title of the slicer pane and set sorting and display options for the selected slicer. You can make any changes you want to apply here and then click the “OK” button. You can click the “Report Connections” button to open the “Report Connections” dialog box where you can select the PivotTable and PivotChart reports to connect to the selected filter by checking the checkbox next to the names of the reports you want to filter with this slicer. You can then click the “OK” button to apply your choices.

In the “Slicer Styles” button group, you can click on the style that you wish to apply to your selected slicer to change its appearance. You can use the buttons that appear within the “Arrange” button group to change the alignment and placement of the slicer pane within the worksheet.

You can use the “Columns,” “Height,” and “Width” buttons within the “Buttons” button group to change the size and number of columns used to display the buttons within the selected slicer pane. Finally, you can use the “Height” and “Width” buttons within the “Size” button group to set the size of the selected slicer pane itself.
35.3- Inserting and Deleting Timelines:

Within Excel, Timelines are used to visually filter date-based data within PivotTables, PivotCharts, data visualizations in Power View, and PowerPivot tables and charts. Timelines are simply date-based slicers. To insert a timeline into a worksheet, select one of these types of objects within a worksheet. Then click the “Timeline” button within the “Filters” button group on the “Insert” tab within the Ribbon to open the “Insert Timeline” dialog box. This dialog box will then display the names of any date-based fields within the associated tables of the selected object. Click to place a checkmark in the checkbox next to the name of the field by which you want to filter the data within a timeline. Then click the “OK” button to add a timeline for the selected object into the worksheet.

You can click and drag the timeline panel around within the worksheet to reposition it, if needed. You can also use the resizing handles that appear around the perimeter of the object to resize it, if desired. The timeline will display buttons that represent the unique values contained within the selected field. To filter the selected object, click the buttons within the slider to choose the associated date values to display within the associated object. The selected data object will then be filtered by your selection within the timeline and only display records for the current button selection. Note that you can use the multiple selection technique of holding the “Shift” key and then clicking on multiple buttons within the timeline to select multiple adjacent timeline buttons to filter for multiple values, if needed. You can also click and drag over the time periods that you want to select to filter for only those dates, as well. However, note that you cannot use the timeline to select multiple, non-adjacent dates. You can clear any timeline filters applied by clicking the “Clear Filters” button in the upper-right corner of the timeline pane. You can also click the time increments label shown in the upper-right corner of the timeline and then select another time increment to display within the timeline from the drop-down menu that appears.

To delete a timeline, click the timeline pane to select it and then press the “Del” or “Delete” key on your keyboard to delete the selected timeline. Alternately, you may right-click on the timeline pane and then select the “Remove Timeline” command from the pop-up menu to delete a timeline.

35.4- Modifying Timelines:

After inserting a timeline into your worksheet, you should see a new “Options” tab within a new “Timeline Tools” contextual tab appear in the Ribbon. You will see this tab appear within the Ribbon any time that you have the timeline selected within the workbook. You can use the buttons within this tab to modify the timeline settings and make other adjustments to the timeline.

In the “Timeline” button group at the left end of this tab, you can see and edit the name of the “Timeline Caption” within the text box shown. You can click the “Report Connections” button to open the “Report Connections” dialog box where you can select the PivotTable and PivotChart reports to connect to the selected filter by checking the checkbox next to the names of the reports you want to filter with this timeline. You can then click the “OK” button to apply your choices.

In the “Timeline Styles” button group, you can click on the style that you wish to apply to your selected timeline to change its appearance. You can use the buttons that appear within the “Arrange” button group to change the alignment and placement of the timeline pane within the worksheet.

You can use the “Height” and “Width” buttons within the “Size” button group to set the size of the selected timeline pane itself. Finally, you can check or uncheck the checkboxes in the “Show” group to show or hide the selected elements within the timeline.
ACTIONS-
SLICERS AND TIMELINES

INSERTING AND DELETING SLICERS:

1. **To insert a slicer**, select either a Table, PivotTable, PivotChart, data visualization in Power View, or PowerPivot table or chart within a worksheet.
2. Click the “Slicer” button within the “Filters” button group on the “Insert” tab within the Ribbon to open the “Insert Slicer” dialog box.
3. This dialog box will then display the names of the fields within the associated tables of the selected object. Click to place a checkmark in the checkbox next to the name of the field by which you want to filter the data within a slicer.
4. Click the “OK” button to add a slicer for the selected object into the worksheet.
5. You can click and drag the slicer panel around within the worksheet to reposition it, if needed.
6. You can use the resizing handles that appear around the perimeter of the object to resize it, if desired.
7. **To filter the selected object**, click the button within the slider to choose the associated values to display within the associated object. Note that you can use the multiple selection techniques of holding the “Shift” or “Ctrl” keys and then clicking on multiple buttons within the slicer to select multiple adjacent or non-adjacent slicer buttons to filter for multiple values, if needed.
8. **To clear any filters applied**, click the “Clear Filters” button in the upper-right corner of the slicer pane.
9. **To delete a slicer**, click the slicer pane to select it and then press the “Del” or “Delete” key on your keyboard to delete the selected slicer.
10. Alternately, you may right-click on the slicer pane and then select the “Remove (field name)” command from the pop-up menu to delete a slicer. Note that the (field name) value will be the name of the field used to slice the data.

MODIFYING SLICERS:

1. Select the slicer within the worksheet that you wish to modify.
2. Click the “Options” tab within the “Slicer Tools” contextual tab in the Ribbon.
3. In the “Slicer” button group at the left end of this tab, you can see and edit the name of the “Slicer Caption” within the text box shown.
4. You can click the “Slicer Settings” button here to open the “Slicer Settings” dialog box. This dialog box allows you to edit the title of the slicer pane and set sorting and display options for the selected slicer. You can make any changes you want to apply here and then click the “OK” button.
5. You can click the “Report Connections” button to open the “Report Connections” dialog box where you can select the PivotTable and PivotChart reports to connect to the selected filter by checking the checkbox next to the names of the reports you want to filter with this slicer. You can then click the “OK” button to apply your choices.
6. In the “Slicer Styles” button group, you can click on the style that you wish to apply to your selected slicer to change its appearance.
7. You can use the buttons that appear within the “Arrange” button group to change the alignment and placement of the slicer pane within the worksheet.
8. You can use the “Columns,” “Height,” and “Width” buttons within the “Buttons” button group to change the size and number of columns used to display the buttons within the selected slicer pane.
9. You can use the “Height” and “Width” buttons within the “Size” button group to set the size of the selected slicer pane itself.
ACTIONS-
Slicers and Timelines

INSERTING AND DELETING TIMELINES:

1. **To insert a timeline**, select either a PivotTable, PivotChart, data visualization in Power View, or PowerPivot table or chart within a worksheet.
2. Click the “Timeline” button within the “Filters” button group on the “Insert” tab within the Ribbon to open the “Insert Timeline” dialog box.
3. This dialog box will display the names of any date-based fields within the associated tables of the selected object. Click to place a checkmark in the checkbox next to the name of the field by which you want to filter the data within a timeline. Then click the “OK” button to add a timeline for the selected object into the worksheet.
4. You can click and drag the timeline panel around within the worksheet to reposition it, if needed.
5. You can use the resizing handles that appear around the perimeter of the object to resize it, if desired.
6. **To filter the selected object**, click the buttons within the slider to choose the associated date values to display within the associated object. Note that you can use the multiple selection technique of holding the “Shift” key and then clicking on multiple buttons within the timeline to select multiple adjacent timeline buttons to filter for multiple values, if needed. You can also click and drag over the time periods that you want to select to filter for only those dates, as well. However, note that you cannot use the timeline to select multiple, non-adjacent dates.
7. **To clear any timeline filters applied**, click the “Clear Filters” button in the upper-right corner of the timeline pane.
8. You can click the time increments label shown in the upper-right corner of the timeline and then select another time increment to display within the timeline from the drop-down menu that appears.
9. **To delete a timeline**, click the timeline pane to select it and then press the “Del” or “Delete” key on your keyboard to delete the selected timeline.
10. Alternately, you may right-click on the timeline pane and then select the “Remove Timeline” command from the pop-up menu to delete a timeline.

MODIFYING TIMELINES:

1. Select the timeline within the worksheet that you wish to modify.
2. Click the “Options” tab within the “Timeline Tools” contextual tab in the Ribbon.
3. In the “Timeline” button group at the left end of this tab, you can see and edit the name of the “Timeline Caption” within the text box shown.
4. You can click the “Report Connections” button to open the “Report Connections” dialog box where you can select the PivotTable and PivotChart reports to connect to the selected filter by checking the checkbox next to the names of the reports you want to filter with this timeline. You can then click the “OK” button to apply your choices.
5. In the “Timeline Styles” button group, you can click on the style that you wish to apply to your selected timeline to change its appearance.
6. You can use the buttons that appear within the “Arrange” button group to change the alignment and placement of the timeline pane within the worksheet.
7. You can use the “Height” and “Width” buttons within the “Size” button group to set the size of the selected timeline pane itself.
8. You can check or uncheck the checkboxes in the “Show” group to show or hide the selected elements within the timeline.
**EXERCISES - SLICERS AND TIMELINES**

**Purpose:**
1. To be able to use a slicer within a worksheet.

**Exercises:**

1. Open up the “Advanced Excel” workbook and select “Sheet1.”
2. Click the “Slicer” button within the “Filters” button group on the “Insert” tab within the Ribbon to open the “Insert Slicers” dialog box.
3. Check the “Region” checkbox within the “Insert Slicers” dialog box, and then click the “OK” button.
4. Click and drag the “Region” slicer pane by its header and drop it to the right of the “Sales” table so that it is not covering any data within the worksheet.
5. Click the “East” button within the “Region” slicer pane to filter the “Budgets” table to display only records for the “East” region.
6. Hold down the “Ctrl” key on your keyboard and then click the “West” button within the “Region” slicer pane to add that filter choice to the list of records displayed within the “Budgets” table. You can then release the “Ctrl” key on your keyboard after clicking the “West” button to then display the records for the “East” and “West” regions within the “Budgets” table.
7. Click the “Clear Filter” button in the upper-right corner of the “Region” slicer pane to remove all filters and display all records within the “Budgets” table once again.
8. Click the “Slicer Style Light 2” choice within the “Slicer Styles” button group on the “Options” tab of the “Slicer Tools” contextual tab within the Ribbon to change the appearance of the selected slicer.
9. Use the “Columns” spinner box within the “Buttons” button group on the “Options” tab of the “Slicer Tools” contextual tab within the Ribbon to enter the number “2” to display the buttons within the “Region” slicer pane in two columns.
10. Place your mouse pointer over the bottom resizing handle of the “Region” slicer pane until it turns into a double-pointed arrow. When it does this, click and drag the bottom of the pane upward to shrink the height of the pane until the bottom of the pane is below the buttons shown.
11. Right-click on the “Region” slicer pane, and then click the “Remove ‘Region’” command from the pop-up menu that appears to delete the “Region” slicer pane.
12. Click the “Save” button within the Quick Access toolbar to save the changes to the “Advanced Excel” workbook.
13. You may close the workbook, if you would like to.
14. **Keep this workbook, as you will need the information within it to perform the Exercises at the end of the following chapters within this manual!** The Exercises should be completed in sequential order.
CHAPTER 36-
SECURITY FEATURES

36.1- Unlocking Cells
36.2- Worksheet Protection
36.3- Workbook Protection
36.4- Password Protecting Excel Files - 2013
36.5- Password Protecting Excel Files - 2010:2007
36.1- Unlocking Cells:

You can prevent changes to your worksheets and workbooks in Excel. If worksheet protection is turned on, you cannot change any information in cells that are “locked.” This is a nice feature, but it renders the worksheet useless because all cells in a worksheet are “locked” by default! Therefore, before you protect your worksheets, you must “unlock” the cells where you know that data entry will need to occur.

To unlock worksheet cells, just select the cells that you know people will need to change within the worksheet that you want to protect. Then click the “Format Cells” dialog box button in the lower right corner of the “Font” group on the “Home” tab in the Ribbon to open the “Format Cells” dialog box. In the “Format Cells” dialog box, click the “Protection” tab and then click the checkbox in front of the word “Locked” to remove the check from the box and de-select the locking of those cells. Then click “OK” to close the “Format Cells” dialog box. If using Excel 2013:2010, you can also click the “Format” button in the “Cells” button group on the “Home” tab in the Ribbon and then select the “Lock Cells” command from the drop-down menu to unlock the selected cells. Now you are ready to apply worksheet protection.

Alternately, you also have a tool that allows you to create specified ranges of cells into which users can perform data entry within a protected worksheet, if they have the password that you specify. If there are ranges of cells which you wish some users could access, but not most general users, then you can specify an editable range of cells in the worksheet and then password protect it. Then people who wish to perform data entry within the range (once worksheet protection has been applied) will be prompted to enter the password to make the selected cell range editable. This varies from the “unlocking” of the worksheet cells in that these cells will be read-only for users who lack the password to edit them, while “unlocking” a cell makes it editable by all users.

To apply selective cell access, select the range of cells in the worksheet to which you wish to allow selective access. Then click the “Allow Users to Edit Ranges” button in the “Changes” group on the “Review” tab in the Ribbon. This will launch the “Allow Users to Edit Ranges” dialog box. Here, you can click the “New…” button at the right side of the dialog box to launch the “New Range” dialog box. In the “New Range” dialog box, enter a name for the cell range into the “Title:” text box. The cells that you selected will be shown in the “Refers to cells:” text box. In the “Range password:” text box, type the password that you want to use to allow users to edit this range. Then click “OK.” You will have to re-type the password again in the next dialog box, and then click “OK” to confirm the password. Like all passwords, this needs to be written down in a secure location, because if you forget it you will not be able to selectively modify the range while worksheet protection is enforced.

You will now see the defined range in the “Allow Users to Edit Ranges” dialog box. Note that you can also select a range once you have created it, and click the “Modify…” button at the right to change the cell range defined by the title, the title itself, or the password for editing access in the “Modify Range” dialog box. You can also select a range to delete in the “Allow Users to Edit Ranges” dialog box and then click the “Delete” button at the right side of the “Allow Users to Edit Ranges” dialog box to delete the definition of the editable range if no longer needed. When finished, click the “OK” button to apply the selective cell access.
36.2- Worksheet Protection:

When you protect a worksheet, you prevent accidental or malicious changes to the worksheet. Once worksheet protection is in place, no one can change the “locked” cells until the worksheet protection is removed. “Locked” cells can be changed freely as long as the worksheet isn’t protected, which is why you must first “unlock” the cells that you want to change before you apply worksheet protection.

In Excel, you have many options, displayed as several checkboxes, that you can check to allow users to perform. There is quite a bit of control over exactly what users can and can’t do. Optionally, you can also type a password that is required to be entered before the worksheet can be “unprotected.” This option is a bit risky, because if you forget the password, you will not be able to remove the worksheet protection.

To apply worksheet protection, select the worksheet to protect in the workbook and then click the “Protect Sheet” button in the “Changes” group on the “Review” tab in the Ribbon. Alternately, in Excel 2013:2010 you can click the “Format” button in the “Cells” button group on the “Home” tab in the Ribbon and then select “Protect Sheet...” from the drop-down menu that appears. This will launch the “Protect Sheet” dialog box. Here you check the checkboxes for actions you want users to be able to accomplish. You can enter a password that allows you to unprotect the worksheet, if desired, by typing it into the Password to unprotect sheet:” text box. You will need to then re-enter the password in a confirmation dialog box that appears. Then click “OK” when you are finished.

When you unprotect a worksheet you are removing your specified worksheet security. To remove worksheet protection from a worksheet, click the “Unprotect Sheet” button in the “Changes” group on the “Review” tab in the Ribbon. Alternately, in Excel 2013:2010 you can click the “Format” button in the “Cells” button group on the “Home” tab in the Ribbon and then select “Unprotect Sheet...” from the drop-down menu that appears. If there is an associated password, it will prompt you to enter it into the “Unprotect Sheet” dialog box, and then click “OK.” After doing that, the worksheet will be unprotected.

36.3- Workbook Protection:

When you protect a workbook, you prevent changes to the workbook’s structure and its windows. You can prevent people from changing the size or shape of the workbook window. With the structural protection, people will not be allowed to add, delete, hide or move worksheets within the workbook.

You can protect the “Windows” and “Structure” in a workbook. You can also provide an optional password that is required to be entered before the workbook can be unprotected. This option is also a bit risky, because if you forget the password you will not be able to remove the workbook protection.

To apply workbook security, click the “Protect Workbook” button in the “Changes” group on the “Review” tab in the Ribbon. This will launch the “Protect Workbook” dialog box. Check the boxes for the objects that you want to protect, and enter a password, if desired. If you enter a password, you will need to re-enter it into the confirmation dialog box that appears, and then click the “OK” button. Then click “OK” when you are finished.

To remove workbook protection, click the “Protect Workbook” button (“Unprotect Workbook” button in Excel 2010:2007) in the “Changes” group on the “Review” tab in the Ribbon to toggle workbook protection back off. If there is an associated password, it will prompt you to enter it into the “Unprotect Workbook” dialog box and then click “OK.”
36.4- Password Protecting Excel Files-2013:

When you password protect an Excel 2013 file, you prevent people from opening the file without knowing the required password. Once password protection is enabled on a file, no one can open the file without supplying the appropriate password. Password protecting files poses a risk, because if you forget the password you will not be able to open the files in the future.

To apply password protection to an Excel file, open the file to which you want to apply password protection. Next, click the “File” tab in the Ribbon and then click the “Info” command at the left side of the backstage view. In the area to the right, click the Protect Workbook” button to display a drop-down menu of choices. Select the “Encrypt with Password” choice from the drop-down menu.

In the “Encrypt Document” dialog box that appears, enter the password that you want to apply to this file. Then click the “OK” button to set the password. You will then need to confirm this password by retyping it into the “Confirm Password” dialog box that appears. Then click the “OK” button to finish.

Now in the future when a user tries to open the file they will need to enter the password to open the file that you specified into the “Password” dialog box that appears.

To remove the password protection, open the file. Note that you will need to supply the password to do this. Click the “File” tab in the Ribbon and then click the “Info” command at the left side of the backstage view. In the area to the right, click the Protect Workbook” button to display a drop-down menu of choices. Select the “Encrypt with Password” choice from the drop-down menu.

In the “Encrypt Document” dialog box that appears, delete the password from the text box within this dialog box. Then just click “Ok.” You will then need to re-save the file as usual to remove the password protection.

36.5- Password Protecting Excel Files- 2010:2007:

When you password protect an Excel file, you prevent people from opening or modifying the file without knowing the password required to accomplish the specified operation. Once password protection is enabled on a file, no one can open or modify the file without supplying the appropriate passwords for both tasks.

Password protecting files poses a risk, because if you forget the password to either open or modify the files, you will not be able to open or modify the files in the future.

To apply password protection to an Excel file, open the file to which you want to apply password protection. Then if using Excel 2007, click the Microsoft Office button, and click the “Save As” command. If using Excel 2010, click the “File” tab in the Ribbon, and then click the “Save As” command.

In either version, this will open the “Save As” dialog box. Select the “Tools” button in the lower right corner of the “Save As” dialog box and then select the “General Options…” command to view the “General Options” dialog box. Here you can set the password protection on the file before saving it.

In the “File sharing” section of the “General Options” dialog box, enter any passwords that you want to apply to this file. You can set passwords to both “open” and/or “modify” the file. You can then click “OK” to set the passwords. You will need to reconfirm these passwords by retyping them in the confirmation dialog box that appears, and then click “OK” to return to the “Save As” dialog box where you will proceed to save the file, as normal.

Now in the future when a user tries to open the file they will need to enter the password to open the file that you specified. Once opened and viewable, if they try to make changes, they will then be prompted to enter the password to modify the file that you specified.

To remove the password protection, you will need to know the passwords for both opening and...
modifying the file, if any. Then, open the file (you’ll need to supply the password to do this), and then open
the “Save As” dialog box again. In the “Save As” dialog box, click the “Tools” button and then select the
“General Options…” command to open the “General Options” dialog box again. This time, delete both
passwords from the “File sharing” section of the “General Options” dialog box. Then just click “OK.” You will
then need to re-save the file as usual to remove the password protection.
UNLOCKING WORKSHEET CELLS:
1. Select the cells in the worksheet which you want to unlock for future access.
2. Click the “Format Cells” dialog box button in the lower right corner of the “Font” group on the “Home” tab in the Ribbon to open the “Format Cells” dialog box.
3. Click the “Protection” tab.
4. Deselect the “Locked” check box.
5. Click “OK” to save your changes.
6. If using Excel 2013:2010, you can also click the “Format” button in the “Cells” button group on the “Home” tab in the Ribbon and then select the “Lock Cell” command from the drop-down menu to unlock the selected cells.

SPECIFYING EDITABLE RANGES:
1. Select the cells in the worksheet which you want to specify as an editable range.
2. Click the “Allow Users to Edit Ranges” button in the “Changes” group on the “Review” tab in the Ribbon.
3. In the “Allow Users to Edit Ranges” dialog box, click the “New…” button.
4. In the “New Range” dialog box, enter a name for the range into the “Title:” text box.
5. If needed, you can click the “Collapse Dialog” button at the right end of the “Refers to cells:” dialog box to collapse the dialog box down to select the cells for the range. However, if you selected the cells in Step 1, then you shouldn’t need to perform this step.
6. In the “Range password:” text box, type in the password that you want to use to allow editing of the selected cells after worksheet protection is applied.
7. Click “OK.”
8. In the “Confirm Password” dialog box, re-type the password to confirm it.
9. Click “OK.”
10. When finished, click the “OK” button to apply the selective cell access.

MODIFYING EDITABLE RANGES:
1. Open the worksheet in which you want to modify an editable range.
2. Click the “Allow Users to Edit Ranges” button in the “Changes” group on the “Review” tab in the Ribbon.
3. In the “Allow Users to Edit Ranges” dialog box, select the name of the range to modify.
4. Click the “Modify…” button.
5. Make any changes to the selected range that you desire.
6. Click “OK.”

DELETING EDITABLE RANGES:
1. Open the worksheet in which you want to delete an editable range.
2. Click the “Allow Users to Edit Ranges” button in the “Changes” group on the “Review” tab in the Ribbon.
3. In the “Allow Users to Edit Ranges” dialog box, select the name of the range to delete.
4. Click the “Delete” button.
5. Click “OK.”
PROTECTING A WORKSHEET:

1. Open the worksheet to protect and click the “Protect Sheet” button in the “Changes” group on the “Review” tab in the Ribbon.
2. Alternately, in Excel 2013:2010 you can click the “Format” button in the “Cells” button group on the “Home” tab in the Ribbon and then select “Protect Sheet…” from the drop-down menu that appears.
3. Check any activities that you want to allow your users to perform.
4. Enter a password that you will need to unprotect the worksheet, if you like.
5. Click “OK.”
6. If you entered a password, you will need to re-enter the password in a separate confirmation dialog box and then click “OK” when finished.

UNPROTECTING A WORKSHEET:

1. Open the worksheet to which you applied worksheet protection.
2. Click the “Unprotect Sheet” button in the “Changes” group on the “Review” tab in the Ribbon.
3. Alternately, in Excel 2013:2010 you can click the “Format” button in the “Cells” button group on the “Home” tab in the Ribbon and then select “Unprotect Sheet…” from the drop-down menu that appears.
4. Type the password and click “OK,” if required.

PROTECTING A WORKBOOK:

1. Open the workbook to protect and click the “Protect Workbook” button in the “Changes” group on the “Review” tab in the Ribbon.
2. Select which properties of the workbook to protect by checking the checkboxes for “Structure” and/or “Windows.”
3. Enter a password for the workbook that you will need to enter to unprotect the workbook, if you like.
4. Click “OK.”
5. Re-enter the password, if you opted to enter a password, and click “OK.”

UNPROTECTING A WORKBOOK:

1. To remove workbook protection, click the “Protect Workbook” button (“Unprotect Workbook” button in Excel 2010:2007) in the “Changes” group on the “Review” tab in the Ribbon to toggle workbook protection back off.
2. If there is an associated password, it will prompt you to enter it into the “Unprotect Workbook” dialog box and then click “OK.”
PASSWORD PROTECTING EXCEL FILES - 2013:

1. Open the file to which you want to apply password protection in Excel.
2. Click the “File” tab in the Ribbon and then click the “Info” command at the left side of the backstage view.
3. In the area to the right, click the Protect Workbook” button to display a drop-down menu of choices.
4. Select the “Encrypt with Password” choice from the drop-down menu.
5. In the “Encrypt Document” dialog box that opens, enter the password you want to apply to this file.
6. Click the “OK” button to set the password.
7. Confirm this password by retyping it into the “Confirm Password” dialog box that appears.
8. Click the “OK” button to finish.
9. Now in the future when a user tries to open the file they will need to enter the password to open the file that you specified into the “Password” dialog box that appears.
10. To remove password protection, open the file. Note that you will need to supply the password to do this.
11. Click the “File” tab in the Ribbon and then click the “Info” command at the left side of the backstage view.
12. In the area to the right, click the Protect Workbook” button to display a drop-down menu of choices.
13. Select the “Encrypt with Password” choice from the drop-down menu.
14. In the “Encrypt Document” dialog box that appears, delete the password from the text box within this dialog box.
15. Then just click “OK.” You will then need to re-save the file as usual to remove the password protection.

PASSWORD PROTECTING EXCEL FILES - 2010:2007:

1. Open the file to which you want to apply password protection.
2. Then if using Excel 2007, click the Microsoft Office button, and click the “Save As” command. If using Excel 2010, click the “File” tab in the Ribbon, and then click the “Save As” command.
3. In either version, select the “Tools” button in the lower right corner of the “Save As” dialog box and then select the “General Options…” command to view the “General Options” dialog box.
4. In the “File sharing” section of the “General Options” dialog box, enter any passwords that you want to apply to this file. You can set passwords to both “open” and/or “modify” the file.
5. You can then click “OK” to set the passwords.
6. You will need to reconfirm these passwords by retyping them in the confirmation dialog box that appears, and then click “OK” to return to the “Save As” dialog box where you will proceed to save the file, as normal.

REMOVING PASSWORD PROTECTION FROM EXCEL FILES - 2010:2007:

1. Open the file (you’ll need to supply the password to do this), and then open the “Save As” dialog box again.
2. In the “Save As” dialog box, click the “Tools” button again and then select the “General Options…” command to open the “General Options” dialog box.
3. This time, delete both passwords from the “File sharing” section of the “General Options” dialog box.
4. Then click the “OK” button.
5. You will then need to re-save the file as usual to remove the password protection.
**Purpose:**

1. To be able to lock and unlock cells and apply and remove worksheet protection.

**Exercises:**

1. Open up the “Advanced Excel” workbook and select “Sheet1.”
2. Select columns A through K.
3. Click the “Format Cells” dialog box button in the lower right corner of the “Font” group on the “Home” tab in the Ribbon.
4. Click the “Protection” tab.
5. Remove the check from the “Locked” check box.
6. Click “OK.”
7. Click the “Protect Sheet” button in the “Changes” group on the “Review” tab in the Ribbon.
8. Click the “OK” button within the “Protect Sheet” dialog box that appears.
9. Select cell L1, and try to type something into it.
10. Click “OK” in the message box that appears onscreen telling you that the cell is protected.
12. Type “Greene” into cell C2.
13. Press the “Tab” key on your keyboard to exit the cell and save the change to the table.
14. Click the “Unprotect Sheet” button in the “Changes” group on the “Review” tab in the Ribbon.
15. Click the “Save” button in the Quick Access Toolbar to save your changes.
16. You may close the workbook, if you would like to.
17. **Keep this workbook, as you will need the information within it to perform the Exercises at the end of the following chapters within this manual! The Exercises should be completed in sequential order.**
CHAPTER 37-
MAKING MACROS

37.1- RECORDING MACROS

37.2- RUNNING AND DELETING RECORDED MACROS

37.3- THE PERSONAL MACRO WORKBOOK
37.1- Recording Macros:

Macros are small programs that record your keystrokes as you perform a task, and then save the actions you performed as a Visual Basic Module- a type of program file. When you run the macro later, it will repeat your keystrokes, thus repeating your actions. This is why they are great for automating repetitive tasks. For example, pretend that you wanted to place your name and your company’s information in the upper left cell of a worksheet. You could use a macro to record your keystrokes as you create it once, and then run the macro in the future. It would repeat the exact same keystrokes that you entered, effectively repeating the process instantaneously.

While you can see advanced options for creating macros on the “Developer” tab in the Ribbon, if it is enabled, you can also use the “Macros” group on the “View” tab in the Ribbon to record and playback basic macros that you record. In this lesson, we will examine how to record a basic macro using the commands found within this group in the Ribbon.

To begin to record a macro, you can click the “Macros” drop-down button in the “Macros” group on the “View” tab in the Ribbon. From the drop-down menu that appears, select the “Record Macro…” command. This will open the “Record Macro” dialog box. In the “Record New Macro” dialog box, enter a name for your new macro in the “Macro name” text box. Note that macro names cannot contain spaces!

Next, select the name of the workbook to which you want to attach the macro by selecting its name from the “Store macro in:” drop-down. If you do not change it, it will default to saving the macro into the current workbook. This is important only because a macro can only be run if it is attached to an open workbook, or stored in the “Personal Macro Workbook,” which we will discuss later. You can also create a custom keyboard shortcut to use in conjunction with the “Ctrl” key by typing the desired shortcut key letter into the text box next to the “Ctrl +.” If you decide to do this, make sure you don’t overwrite an existing shortcut! For example the shortcut character of “p” would be a bad choice as “Ctrl + P,” is already a keyboard shortcut for the “Print” command. If you aren’t familiar with the keyboard shortcuts, it may be better if you don’t assign one. When you are ready to start recording your actions, click “OK.”

While recording your macro, you cannot use your mouse very much and you should minimize your mouse movements during the recording of the macro. Instead, try to use the keyboard as much as possible. Once you have finished recording your macro, click the “Macros” drop-down button in the “Macros” group on the “View” tab in the Ribbon. Select the “Stop Recording” command to stop recording the macro.

Unlike macros in the other Microsoft Office programs, in Excel the types of cell references that you make while recording a macro can be adjusted. For example, assume that when you began recording your macro, your “active cell” was cell A1. From there, you clicked into cell D1. When Excel records you doing that, it can either record that action as a relative reference or an absolute reference. That action, if recorded using relative references, would make the “active cell” move four cells to the right of whatever cell it was in when you started to playback the macro. If you recorded it in absolute terms, it would always move to cell D1 from wherever you started the macro. You can adjust the types of referencing used when recording a macro by clicking the “Macros” drop-down button in the “Macros” group and then selecting the “Use Relative References” command. By default, Excel macros will use absolute references. You can click this button to switch to relative cell referencing during your macro. You can click it again to switch back to absolute referencing when needed during or after recording.

Also remember that if you want to save a workbook that contains macros in Excel 2007 or later, you need to select the “Excel Macro-Enabled Workbook” choice from the “File type:” drop-down in the “Save As” dialog box.
37.2- Running and Deleting Macros:

To run a recorded macro, you can click the “Macros” drop-down button in the “Macros” group on the “View” tab in the Ribbon. If there are macros that are available to run, then you can choose the “View Macros” command from the button’s drop-down. If you do not see this command, then you may not have any recorded macros available for use. Otherwise, once you select this command, you will see the “Macro” dialog box appear. You use this dialog box to manage your macros.

A listing of the macros that are available will appear in the large white list box shown within the “Macro” dialog box. To run a macro shown in this list, click on its name it select it. Then click the “Run” button to run the selected macro.

You can also delete macros that you no longer want or need using this dialog box. To delete a macro, select the name of the macro from the macro list and then click the “Delete” button. Click the “Yes” button in the confirmation message box that appears to delete the selected macro. Once you have finished using the “Macro” dialog box, click the “Close” button to close it.

37.3- The Personal Macro Workbook:

When you record macros, they are attached to the workbook in which you create them, by default. When a workbook that contains macros is open, the macros attached to it are available for use by all open workbooks. However, once you close the workbook to which the macros are attached, they are no longer available for use by other workbooks.

To remedy this, Excel provides a “Personal Macro Workbook” as a place to which you can store macros which you want to be universally accessible by all open workbooks on your computer. The “Personal Macro Workbook” is a workbook that opens every time you open Excel. However, it is a hidden workbook, so you do not normally see it and very many people aren’t even aware that it exists. However, you can store your macros here to make them available to all open workbooks on your PC. Since the “Personal Macro Workbook” is always open and always hidden, it is always usable by all other open workbooks at that computer.

To save a macro into the “Personal Macro Workbook,” you need to select “Personal Macro Workbook” from the “Store macro in” drop-down that is available in the “Record Macro” dialog box. Then the macro that you record will be stored in that workbook.

Once you have stored macros to the “Personal Macro Workbook,” you will need to unhide the workbook to edit or delete the macros in it. To hide and unhide the “Personal Macro Workbook,” you must click the “Hide” or “Unhide” buttons in the “Window” group on the “View” tab in the Ribbon.

If you click the “Unhide” button after you have saved at least one macro to the “Personal Macro Workbook,” you’ll be presented with the “Unhide” dialog box. To unhide the “Personal Macro Workbook,” select the “PERSONAL” file, and then click “OK.” You will then see the “Personal Macro Workbook” appear. You can then edit or delete any macros saved to that workbook by using the “Macro” dialog box.

When you are finished, make sure that you still have the “Personal Macro Workbook” displayed, and then click the “Hide” button in the “Window” group on the “View” tab in the Ribbon to hide the “Personal Macro Workbook” again. Always remember to hide the “Personal Macro Workbook” when you are done editing or deleting its macros to ensure that the workbook doesn’t get deleted accidentally.
RECORDING MACROS:

1. Click the “Macros” drop-down button in the “Macros” group on the “View” tab in the Ribbon, and then select the “Record Macro…” command to open the “Record Macro” dialog box.
2. In the “Record New Macro” dialog box, enter a name for your new macro in the “Macro name” text box.
3. You can also create a custom keyboard shortcut to use in conjunction with the “Ctrl” key by typing the desired shortcut key letter into the text box next to the “Ctrl +.” If you decide to do this, make sure you don’t overwrite an existing shortcut!
4. Next, select the name of the workbook to which you would like to attach the macro from the “Store macro in:” drop-down.
5. Click the “OK” button to begin recording your macro.
6. Once you have finished recording, click the “Macros” drop-down button in the “Macros” group on the “View” tab in the Ribbon. Select the “Stop Recording” command to stop recording the macro.
7. Also, if necessary, you can choose the “Pause Recording” command from the button’s drop-down menu to pause the macro while recording. You can click the “Macro” button, and then select the Resume Recorder command to resume recording the macro when you are ready to continue. You can also adjust the types of referencing used when recording a macro by clicking the “Macros” drop-down button in the “Macros” group and then selecting the “Use Relative References” command. By default, Excel macros will use absolute references. You can click this button to switch to relative cell referencing during your macro. You can click it again to switch back to absolute referencing when needed during or after recording.

RUNNING AND DELETING MACROS:

1. To run a recorded macro, you can click the “Macros” drop-down button in the “Macros” group on the “View” tab in the Ribbon. Once you select this command, you will see the “Macro” dialog box appear.
2. A listing of the macros that are available will appear in the large white list box shown within the “Macro” dialog box. To run a macro shown in this list, click on its name it select it. Then click the “Run” button to run the selected macro.
3. You can also delete macros that you no longer want or need using this dialog box. To delete a macro, select the name of the macro from the macro list and then click the “Delete” button.
4. Click the “Yes” button in the confirmation message box that appears to delete the macro.
5. Once you have finished using the “Macro” dialog box, click the “Close” button to close it.

UNHIDING AND HIDING THE PERSONAL MACRO WORKBOOK:

1. If you click the “Unhide” button in the “Window” group on the “View” tab in the Ribbon after you have saved at least one macro to the “Personal Macro Workbook,” you will open the “Unhide” dialog box.
2. To unhide the “Personal Macro Workbook,” select the “PERSONAL” file, and then click “OK.”
3. You will then see the “Personal Macro Workbook” appear. You can then edit or delete any macros saved to that workbook by using the “Macro” dialog box.
4. When you are finished, make sure that you still have the “Personal Macro Workbook” displayed, and then click the “Hide” button in the “Window” group on the “View” tab in the Ribbon to hide the “Personal Macro Workbook” again. Always remember to hide the “Personal Macro Workbook” when you are done editing or deleting its macros to ensure that the workbook doesn’t get deleted accidentally.
EXERCISES-
Making Macros

Purpose:

1. To be able to create and run a macro.

Exercises:

1. Create a new workbook in Excel and select “Sheet1.”
3. Click the “Macros” drop-down button in the “Macros” button group on the “View” tab in the Ribbon and then select the “Use Relative References” command from the button’s drop-down menu to enable that feature.
4. Click the “Macros” drop-down button in the “Macros” button group on the “View” tab in the Ribbon and then select the “Record Macro…” command from the button’s drop-down menu.
5. For the “Macro name:” type “SignAndDate.”
6. Select “This Workbook” from the “Store macro in:” drop-down.
7. Click “OK.”
8. Type “Created by (your name)” into cell A1.
9. Press the “Enter” key on your keyboard to move down to the next cell, A2.
10. Type the formula “=NOW()” into cell A2.
11. Press the “Enter” key on your keyboard to exit the cell.
12. Click the “Macros” drop-down button in the “Macros” button group on the “View” tab in the Ribbon and then select the “Stop Recording” command from the button’s drop-down menu.
13. If using Excel 2013, click the “New Sheet” button to add a new worksheet titled “Sheet2.”
14. Select “Sheet2.”
15. Select cell C5 in “Sheet2.”
16. Click the “Macros” drop-down button in the “Macros” button group on the “View” tab in the Ribbon and then select the “View Macros” command from the button’s drop-down menu.
17. In the “Macro” dialog box, select the “SignAndDate” macro, and then click the “Run” button.
18. You do not need to save your workbook, however if you wish to save a workbook that contains macros, you should select “Excel Macro-Enabled Workbook” in the “Save As” dialog box.
19. Click the “X” button in the upper right corner of the application window to exit the program.
# Glossary of Functions

## Index

<table>
<thead>
<tr>
<th>Function:</th>
<th>Page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Compatibility Functions</td>
<td></td>
</tr>
<tr>
<td>BETADIST</td>
<td>52</td>
</tr>
<tr>
<td>BETAINV</td>
<td>52</td>
</tr>
<tr>
<td>BINOMDIST</td>
<td>52</td>
</tr>
<tr>
<td>CHIDIST</td>
<td>106</td>
</tr>
<tr>
<td>CHINV</td>
<td>106</td>
</tr>
<tr>
<td>CHITEST</td>
<td>106</td>
</tr>
<tr>
<td>CONFIDENCE</td>
<td>106</td>
</tr>
<tr>
<td>COVAR</td>
<td>107</td>
</tr>
<tr>
<td>CRITBINOM</td>
<td>107</td>
</tr>
<tr>
<td>EXPONDIST</td>
<td>108</td>
</tr>
<tr>
<td>FDIST</td>
<td>108</td>
</tr>
<tr>
<td>FINV</td>
<td>108</td>
</tr>
<tr>
<td>FTTEST</td>
<td>109</td>
</tr>
<tr>
<td>GAMMADIST</td>
<td>109</td>
</tr>
<tr>
<td>GAMMAINV</td>
<td>110</td>
</tr>
<tr>
<td>HYPGEOMDIST</td>
<td>111</td>
</tr>
<tr>
<td>LOGINV</td>
<td>113</td>
</tr>
<tr>
<td>LOGNORMDIST</td>
<td>114</td>
</tr>
<tr>
<td>MODE</td>
<td>115</td>
</tr>
<tr>
<td>NEGBINOMDIST</td>
<td>115</td>
</tr>
<tr>
<td>NORMDIST</td>
<td>115</td>
</tr>
<tr>
<td>NORMINV</td>
<td>115</td>
</tr>
<tr>
<td>NORMSDIST</td>
<td>115</td>
</tr>
<tr>
<td>NORMSINV</td>
<td>116</td>
</tr>
<tr>
<td>PERCENTILE</td>
<td>116</td>
</tr>
<tr>
<td>PERCENTRANK</td>
<td>116</td>
</tr>
<tr>
<td>POISSON</td>
<td>117</td>
</tr>
<tr>
<td>QUARTILE</td>
<td>117</td>
</tr>
<tr>
<td>RANK</td>
<td>117</td>
</tr>
<tr>
<td>STDEV</td>
<td>119</td>
</tr>
<tr>
<td>STDEVP</td>
<td>119</td>
</tr>
<tr>
<td>TDIST</td>
<td>119</td>
</tr>
<tr>
<td>TINV</td>
<td>120</td>
</tr>
<tr>
<td>TTEST</td>
<td>120</td>
</tr>
<tr>
<td>VAR</td>
<td>121</td>
</tr>
<tr>
<td>VARP</td>
<td>121</td>
</tr>
<tr>
<td>WEIBULL</td>
<td>121</td>
</tr>
<tr>
<td>ZTEST</td>
<td>122</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Cube Functions</th>
<th>Page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>CUBEKPIMEMBER</td>
<td>52</td>
</tr>
<tr>
<td>CUBEEMEMBER</td>
<td>52</td>
</tr>
<tr>
<td>CUBEEMEMBERPROPERTY</td>
<td>52</td>
</tr>
<tr>
<td>CUBERANKEDMEMBER</td>
<td>52</td>
</tr>
<tr>
<td>CUBESET</td>
<td>53</td>
</tr>
<tr>
<td>CUBESETCOUNT</td>
<td>53</td>
</tr>
<tr>
<td>CUBEVALUE</td>
<td>53</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Database Functions</th>
<th>Page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>DAVG</td>
<td>52</td>
</tr>
<tr>
<td>DCOUNT</td>
<td>52</td>
</tr>
<tr>
<td>DCOUNTA</td>
<td>52</td>
</tr>
<tr>
<td>DGET</td>
<td>52</td>
</tr>
<tr>
<td>DMAX</td>
<td>53</td>
</tr>
<tr>
<td>DMIN</td>
<td>53</td>
</tr>
<tr>
<td>DPRODUCT</td>
<td>53</td>
</tr>
<tr>
<td>DSTDEV</td>
<td>53</td>
</tr>
<tr>
<td>DSDEVP</td>
<td>54</td>
</tr>
<tr>
<td>DSEM</td>
<td>54</td>
</tr>
<tr>
<td>DVAR</td>
<td>54</td>
</tr>
<tr>
<td>DVARP</td>
<td>54</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Date and Time Functions</th>
<th>Page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>DATE</td>
<td>55</td>
</tr>
<tr>
<td>DATENAME</td>
<td>55</td>
</tr>
<tr>
<td>DAY</td>
<td>55</td>
</tr>
<tr>
<td>DAYS</td>
<td>55</td>
</tr>
<tr>
<td>DAYS360</td>
<td>55</td>
</tr>
<tr>
<td>EDATE</td>
<td>55</td>
</tr>
<tr>
<td>EOMONTH</td>
<td>56</td>
</tr>
<tr>
<td>HOUR</td>
<td>56</td>
</tr>
<tr>
<td>MINUTE</td>
<td>56</td>
</tr>
<tr>
<td>MONTH</td>
<td>56</td>
</tr>
<tr>
<td>NETWORKDAYS</td>
<td>56</td>
</tr>
<tr>
<td>NETWORKDAYS.INTL</td>
<td>56</td>
</tr>
<tr>
<td>NOW</td>
<td>56</td>
</tr>
<tr>
<td>SECOND</td>
<td>57</td>
</tr>
<tr>
<td>TIME</td>
<td>57</td>
</tr>
<tr>
<td>TIMEVALUE</td>
<td>57</td>
</tr>
<tr>
<td>TODAY</td>
<td>57</td>
</tr>
<tr>
<td>WEEKDAY</td>
<td>57</td>
</tr>
<tr>
<td>WORKDAY</td>
<td>58</td>
</tr>
<tr>
<td>WORKDAY.INTL</td>
<td>58</td>
</tr>
<tr>
<td>YEAR</td>
<td>58</td>
</tr>
<tr>
<td>YEARFRAC</td>
<td>58</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Engineering Functions</th>
<th>Page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>BESSELI</td>
<td>58</td>
</tr>
<tr>
<td>BESSELJ</td>
<td>58</td>
</tr>
<tr>
<td>BESSELK</td>
<td>58</td>
</tr>
<tr>
<td>BESSELY</td>
<td>58</td>
</tr>
<tr>
<td>BIN2DEC</td>
<td>59</td>
</tr>
<tr>
<td>BIN2HEX</td>
<td>59</td>
</tr>
<tr>
<td>BIN2OCT</td>
<td>60</td>
</tr>
<tr>
<td>BITAND</td>
<td>60</td>
</tr>
<tr>
<td>BITLSHIFT</td>
<td>60</td>
</tr>
<tr>
<td>BITOR</td>
<td>60</td>
</tr>
<tr>
<td>BITRSHIFT</td>
<td>60</td>
</tr>
<tr>
<td>BITXOR</td>
<td>60</td>
</tr>
<tr>
<td>COMPLEX</td>
<td>60</td>
</tr>
<tr>
<td>CONVERT</td>
<td>60-61</td>
</tr>
<tr>
<td>DEC2BIN</td>
<td>61</td>
</tr>
<tr>
<td>DEC2HEX</td>
<td>61</td>
</tr>
<tr>
<td>DEC2OCT</td>
<td>61</td>
</tr>
<tr>
<td>DELTA</td>
<td>62</td>
</tr>
<tr>
<td>ERF</td>
<td>62</td>
</tr>
<tr>
<td>ERF.PRECISE</td>
<td>62</td>
</tr>
<tr>
<td>ERFC</td>
<td>62</td>
</tr>
<tr>
<td>ERFC.PRECISE</td>
<td>62</td>
</tr>
<tr>
<td>GESTEP</td>
<td>62</td>
</tr>
<tr>
<td>HEX2BIN</td>
<td>62</td>
</tr>
<tr>
<td>HEX2DEC</td>
<td>63</td>
</tr>
<tr>
<td>HEX2OCT</td>
<td>63</td>
</tr>
<tr>
<td>IMABS</td>
<td>63</td>
</tr>
<tr>
<td>IMAGINARY</td>
<td>63</td>
</tr>
<tr>
<td>IMARGUMENT</td>
<td>63</td>
</tr>
<tr>
<td>IMCONJUGATE</td>
<td>64</td>
</tr>
<tr>
<td>IMCOS</td>
<td>64</td>
</tr>
<tr>
<td>IMCOSH</td>
<td>64</td>
</tr>
<tr>
<td>IMCOT</td>
<td>64</td>
</tr>
<tr>
<td>IMCSC</td>
<td>64</td>
</tr>
<tr>
<td>IMCSCH</td>
<td>64</td>
</tr>
<tr>
<td>IMDIV</td>
<td>64</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Financial Functions</th>
<th>Page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACCRINT</td>
<td>69</td>
</tr>
<tr>
<td>ACCRINTM</td>
<td>169</td>
</tr>
<tr>
<td>AMORDEGRC</td>
<td>70</td>
</tr>
<tr>
<td>AMORLINC</td>
<td>70</td>
</tr>
<tr>
<td>COUPDAYBS</td>
<td>71</td>
</tr>
<tr>
<td>COUPDAYS</td>
<td>71</td>
</tr>
<tr>
<td>COUPDAYSNC</td>
<td>71</td>
</tr>
<tr>
<td>COUPNCD</td>
<td>72</td>
</tr>
<tr>
<td>COUPNUM</td>
<td>72</td>
</tr>
<tr>
<td>COUPPCD</td>
<td>72</td>
</tr>
<tr>
<td>CUMIPMT</td>
<td>73</td>
</tr>
<tr>
<td>CUMPRINC</td>
<td>73</td>
</tr>
<tr>
<td>DB</td>
<td>73</td>
</tr>
<tr>
<td>DDB</td>
<td>73</td>
</tr>
<tr>
<td>DISC</td>
<td>74</td>
</tr>
<tr>
<td>DOLLARDE</td>
<td>74</td>
</tr>
<tr>
<td>DOLLARFR</td>
<td>74</td>
</tr>
<tr>
<td>DURATION</td>
<td>74</td>
</tr>
<tr>
<td>EFFECT</td>
<td>75</td>
</tr>
<tr>
<td>FV</td>
<td>75</td>
</tr>
<tr>
<td>FVSCHEDULE</td>
<td>75</td>
</tr>
<tr>
<td>INTRATE</td>
<td>75</td>
</tr>
<tr>
<td>IPMT</td>
<td>76</td>
</tr>
<tr>
<td>IRR</td>
<td>76</td>
</tr>
<tr>
<td>ISMRT</td>
<td>76</td>
</tr>
<tr>
<td>MDURATION</td>
<td>77</td>
</tr>
<tr>
<td>MIRR</td>
<td>77</td>
</tr>
<tr>
<td>NORMINAL</td>
<td>77</td>
</tr>
<tr>
<td>NPER</td>
<td>78</td>
</tr>
<tr>
<td>NPV</td>
<td>78</td>
</tr>
<tr>
<td>ODDLPRICE</td>
<td>78</td>
</tr>
<tr>
<td>ODDFYIELD</td>
<td>79</td>
</tr>
<tr>
<td>ODDLYIELD</td>
<td>79</td>
</tr>
<tr>
<td>ODDLYIELD</td>
<td>80</td>
</tr>
<tr>
<td>PDURATION</td>
<td>80</td>
</tr>
<tr>
<td>PMT</td>
<td>80</td>
</tr>
<tr>
<td>PPMT</td>
<td>80</td>
</tr>
<tr>
<td>PRICE</td>
<td>81</td>
</tr>
<tr>
<td>PRICEDISC</td>
<td>81</td>
</tr>
<tr>
<td>PRICEMAT</td>
<td>81</td>
</tr>
<tr>
<td>PV</td>
<td>81</td>
</tr>
<tr>
<td>RATE</td>
<td>82</td>
</tr>
<tr>
<td>RECEIVED</td>
<td>82</td>
</tr>
<tr>
<td>RRI</td>
<td>82</td>
</tr>
<tr>
<td>SLN</td>
<td>82</td>
</tr>
<tr>
<td>SYD</td>
<td>82</td>
</tr>
<tr>
<td>TBILLET</td>
<td>83</td>
</tr>
<tr>
<td>TBILLPRICE</td>
<td>83</td>
</tr>
<tr>
<td>TBILLYIELD</td>
<td>83</td>
</tr>
<tr>
<td>VDB</td>
<td>83</td>
</tr>
<tr>
<td>XIRR</td>
<td>83</td>
</tr>
<tr>
<td>XNPV</td>
<td>84</td>
</tr>
<tr>
<td>YIELD</td>
<td>84</td>
</tr>
<tr>
<td>YIELDDISC</td>
<td>84</td>
</tr>
<tr>
<td>YIELDMAT</td>
<td>84</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Information Functions</th>
<th>Page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>CELL</td>
<td>85</td>
</tr>
<tr>
<td>ERROR.TYPE</td>
<td>86</td>
</tr>
<tr>
<td>INFO</td>
<td>86</td>
</tr>
<tr>
<td>ISBLANK</td>
<td>87</td>
</tr>
<tr>
<td>ISERR</td>
<td>87</td>
</tr>
<tr>
<td>ISERROR</td>
<td>87</td>
</tr>
<tr>
<td>ISEVEN</td>
<td>87</td>
</tr>
<tr>
<td>ISFORMULA</td>
<td>87</td>
</tr>
<tr>
<td>ISLOGICAL</td>
<td>87</td>
</tr>
<tr>
<td>ISNA</td>
<td>87</td>
</tr>
<tr>
<td>ISNONTEXT</td>
<td>88</td>
</tr>
<tr>
<td>ISNUMBER</td>
<td>88</td>
</tr>
<tr>
<td>ISODD</td>
<td>88</td>
</tr>
<tr>
<td>ISREF</td>
<td>88</td>
</tr>
<tr>
<td>ISTEXT</td>
<td>88</td>
</tr>
<tr>
<td>N</td>
<td>89</td>
</tr>
<tr>
<td>NA</td>
<td>89</td>
</tr>
<tr>
<td>SHEET</td>
<td></td>
</tr>
<tr>
<td>SHEETS</td>
<td></td>
</tr>
<tr>
<td>TYPE</td>
<td>89</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Logical Functions</th>
<th>Page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>AND</td>
<td>89</td>
</tr>
<tr>
<td>FALSE</td>
<td>89</td>
</tr>
<tr>
<td>IF</td>
<td>89</td>
</tr>
<tr>
<td>IFERROR</td>
<td></td>
</tr>
<tr>
<td>IFNA</td>
<td></td>
</tr>
<tr>
<td>NOT</td>
<td>90</td>
</tr>
<tr>
<td>OR</td>
<td>90</td>
</tr>
<tr>
<td>TRUE</td>
<td>90</td>
</tr>
<tr>
<td>XOR</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Lookup and Reference Functions</th>
<th>Page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADDRESS</td>
<td>90</td>
</tr>
<tr>
<td>AREAS</td>
<td>90</td>
</tr>
<tr>
<td>CHOOSE</td>
<td>91</td>
</tr>
<tr>
<td>COLUMN</td>
<td>91</td>
</tr>
<tr>
<td>COUNT</td>
<td>91</td>
</tr>
<tr>
<td>FORMULATEXT</td>
<td></td>
</tr>
<tr>
<td>GETPIVOTDATA</td>
<td></td>
</tr>
<tr>
<td>HLOOKUP</td>
<td></td>
</tr>
<tr>
<td>HYPERLINK</td>
<td>92</td>
</tr>
<tr>
<td>INDEX</td>
<td>92</td>
</tr>
<tr>
<td>INDEX</td>
<td>93</td>
</tr>
<tr>
<td>Function:</td>
<td>Page:</td>
</tr>
<tr>
<td>-----------</td>
<td>-------</td>
</tr>
<tr>
<td>INDIRECT</td>
<td>92</td>
</tr>
<tr>
<td>LOOKUP</td>
<td>93</td>
</tr>
<tr>
<td>MATCH</td>
<td>93</td>
</tr>
<tr>
<td>OFFSET</td>
<td>93</td>
</tr>
<tr>
<td>ROW</td>
<td>94</td>
</tr>
<tr>
<td>ROWS</td>
<td>94</td>
</tr>
<tr>
<td>RTD</td>
<td>94</td>
</tr>
<tr>
<td>TRANSPOSE</td>
<td>94</td>
</tr>
<tr>
<td>VLOOKUP</td>
<td>94</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Function:</th>
<th>Page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRODUCT</td>
<td>100</td>
</tr>
<tr>
<td>QUOTIENT</td>
<td>10</td>
</tr>
<tr>
<td>RAD</td>
<td>100</td>
</tr>
<tr>
<td>RAND</td>
<td>100</td>
</tr>
<tr>
<td>RANDBETWEEN</td>
<td>100</td>
</tr>
<tr>
<td>ROMAN</td>
<td>101</td>
</tr>
<tr>
<td>ROUND</td>
<td>101</td>
</tr>
<tr>
<td>ROUNDDOWN</td>
<td>101</td>
</tr>
<tr>
<td>ROUNDUP</td>
<td>101</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Function:</th>
<th>Page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>SEC</td>
<td>102</td>
</tr>
<tr>
<td>SECH</td>
<td>102</td>
</tr>
<tr>
<td>SERIESUM</td>
<td>101</td>
</tr>
<tr>
<td>SUM</td>
<td>103</td>
</tr>
<tr>
<td>SUMIF</td>
<td>103</td>
</tr>
<tr>
<td>SUMIFS</td>
<td>103</td>
</tr>
<tr>
<td>SUMPRODUCT</td>
<td>103</td>
</tr>
<tr>
<td>SUMSQ</td>
<td>103</td>
</tr>
<tr>
<td>SUMX2MY2</td>
<td>104</td>
</tr>
<tr>
<td>SUMX2PY2</td>
<td>104</td>
</tr>
<tr>
<td>SUMXMY2</td>
<td>104</td>
</tr>
<tr>
<td>TAN</td>
<td>104</td>
</tr>
<tr>
<td>TANH</td>
<td>104</td>
</tr>
<tr>
<td>TRUNC</td>
<td>104</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Function:</th>
<th>Page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>AVEDEV</td>
<td>105</td>
</tr>
<tr>
<td>AVERAGE</td>
<td>105</td>
</tr>
<tr>
<td>AVERAGEA</td>
<td>105</td>
</tr>
<tr>
<td>AVERAGEIF</td>
<td>105</td>
</tr>
<tr>
<td>AVERAGEIFS</td>
<td>105</td>
</tr>
<tr>
<td>BETADIST</td>
<td>105</td>
</tr>
<tr>
<td>BETAINV</td>
<td>105</td>
</tr>
<tr>
<td>BINOMDIST</td>
<td>105</td>
</tr>
<tr>
<td>BINOMDISTRANGE</td>
<td>105</td>
</tr>
<tr>
<td>CHISQDIST</td>
<td>106</td>
</tr>
<tr>
<td>CHISQRT</td>
<td>106</td>
</tr>
<tr>
<td>CHISQINV</td>
<td>106</td>
</tr>
<tr>
<td>CHISQTEST</td>
<td>106</td>
</tr>
<tr>
<td>CONFIDENCE.NORM</td>
<td>106</td>
</tr>
<tr>
<td>CONFIDENCE.T</td>
<td>106</td>
</tr>
<tr>
<td>CORREL</td>
<td>106</td>
</tr>
<tr>
<td>COUNT</td>
<td>107</td>
</tr>
<tr>
<td>COUNTA</td>
<td>107</td>
</tr>
<tr>
<td>COUNTBLANK</td>
<td>107</td>
</tr>
<tr>
<td>COUNTIF</td>
<td>107</td>
</tr>
<tr>
<td>COUNTIFS</td>
<td>107</td>
</tr>
<tr>
<td>COVARIANCE.P</td>
<td>107</td>
</tr>
<tr>
<td>COVARIANCE.S</td>
<td>107</td>
</tr>
<tr>
<td>DEVSQ</td>
<td>108</td>
</tr>
<tr>
<td>EXPONDIST</td>
<td>108</td>
</tr>
<tr>
<td>F.DIST</td>
<td>108</td>
</tr>
<tr>
<td>F.DISTRT</td>
<td>108</td>
</tr>
<tr>
<td>F.INV</td>
<td>108</td>
</tr>
<tr>
<td>F.INVRT</td>
<td>108</td>
</tr>
<tr>
<td>F.TEST</td>
<td>108</td>
</tr>
<tr>
<td>FISHER</td>
<td>108</td>
</tr>
<tr>
<td>FISHERINV</td>
<td>109</td>
</tr>
<tr>
<td>FORECAST</td>
<td>109</td>
</tr>
<tr>
<td>FREQUENCY</td>
<td>109</td>
</tr>
<tr>
<td>GAMMA</td>
<td>109</td>
</tr>
<tr>
<td>GAMMA.DIST</td>
<td>109</td>
</tr>
<tr>
<td>GAMMA.INV</td>
<td>109</td>
</tr>
<tr>
<td>GAMMALN</td>
<td>110</td>
</tr>
<tr>
<td>GAMMALNPRECISE</td>
<td>110</td>
</tr>
<tr>
<td>GEOMEAN</td>
<td>110</td>
</tr>
<tr>
<td>GROWTH</td>
<td>110</td>
</tr>
<tr>
<td>HARMEAN</td>
<td>111</td>
</tr>
<tr>
<td>HYPGEOMDIST</td>
<td>111</td>
</tr>
<tr>
<td>INTERCEPT</td>
<td>111</td>
</tr>
<tr>
<td>KURT</td>
<td>111</td>
</tr>
<tr>
<td>LARGE</td>
<td>111</td>
</tr>
<tr>
<td>L unserem</td>
<td>112</td>
</tr>
<tr>
<td>LOGEST</td>
<td>113</td>
</tr>
<tr>
<td>LOGNORMDIST</td>
<td>113</td>
</tr>
<tr>
<td>LOGNORMINV</td>
<td>113</td>
</tr>
<tr>
<td>MAX</td>
<td>114</td>
</tr>
<tr>
<td>MAXA</td>
<td>114</td>
</tr>
<tr>
<td>MEDIAN</td>
<td>114</td>
</tr>
<tr>
<td>MIN</td>
<td>114</td>
</tr>
<tr>
<td>MINA</td>
<td>114</td>
</tr>
<tr>
<td>MOD</td>
<td>115</td>
</tr>
<tr>
<td>MODE.MULT</td>
<td>115</td>
</tr>
<tr>
<td>MODE.SNGL</td>
<td>115</td>
</tr>
<tr>
<td>NEGBINOMDIST</td>
<td>115</td>
</tr>
<tr>
<td>NORMDIST</td>
<td>115</td>
</tr>
<tr>
<td>NORMINV</td>
<td>115</td>
</tr>
<tr>
<td>NORM.S.DIST</td>
<td>115</td>
</tr>
<tr>
<td>NORM.S.INV</td>
<td>116</td>
</tr>
<tr>
<td>PEARSON</td>
<td>116</td>
</tr>
<tr>
<td>PERCENTILE.EXC</td>
<td>116</td>
</tr>
<tr>
<td>PERCENTILE.INC</td>
<td>116</td>
</tr>
<tr>
<td>PERCENTRANK.EXC</td>
<td>116</td>
</tr>
<tr>
<td>PERCENTRANK.INC</td>
<td>116</td>
</tr>
<tr>
<td>PHIL</td>
<td>116</td>
</tr>
<tr>
<td>PHONETIC</td>
<td>124</td>
</tr>
<tr>
<td>PROPER</td>
<td>125</td>
</tr>
<tr>
<td>REPLACE</td>
<td>125</td>
</tr>
<tr>
<td>REPT</td>
<td>125</td>
</tr>
<tr>
<td>RIGHT</td>
<td>125</td>
</tr>
<tr>
<td>SEARCH</td>
<td>125</td>
</tr>
<tr>
<td>SUBSTITUTE</td>
<td>126</td>
</tr>
<tr>
<td>T</td>
<td>126</td>
</tr>
<tr>
<td>TEXT</td>
<td>126</td>
</tr>
<tr>
<td>TRIM</td>
<td>126</td>
</tr>
<tr>
<td>UThursday CHARCODE</td>
<td>127</td>
</tr>
<tr>
<td>VALUE</td>
<td>127</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Function:</th>
<th>Page:</th>
</tr>
</thead>
<tbody>
<tr>
<td>ABS</td>
<td>95</td>
</tr>
<tr>
<td>ACOS</td>
<td>95</td>
</tr>
<tr>
<td>ACOSH</td>
<td>95</td>
</tr>
<tr>
<td>ACOT</td>
<td>95</td>
</tr>
<tr>
<td>ACOTH</td>
<td>96</td>
</tr>
<tr>
<td>AGGREGATE</td>
<td>96</td>
</tr>
<tr>
<td>ARABIC</td>
<td>95</td>
</tr>
<tr>
<td>ASIN</td>
<td>95</td>
</tr>
<tr>
<td>ASINH</td>
<td>95</td>
</tr>
<tr>
<td>ATAN</td>
<td>95</td>
</tr>
<tr>
<td>ATAN2</td>
<td>95</td>
</tr>
<tr>
<td>ATANH</td>
<td>96</td>
</tr>
<tr>
<td>BASE</td>
<td>96</td>
</tr>
<tr>
<td>CEILING</td>
<td>96</td>
</tr>
<tr>
<td>CEILING.MATH</td>
<td>96</td>
</tr>
</tbody>
</table>
*Note on Functions:

An important point to note in Excel 2013 is that functions may return slightly different results based on whether the computer running the function is a PC using x86 or x86-x64 architecture or is a Windows RT PC using ARM architecture. This is due to a difference in the processors used between the machines.

Also note that not all functions listed here are available by default in Excel. Many of these functions must be loaded into Excel using the “Add-ins” available. To load an add-in click the Microsoft Office button and then click the “Excel Options” button. In the “Excel Options” window, select the “Add-Ins” category to the left. Use the “Manage:” drop-down at the bottom of this window to select “Excel Add-Ins.” Then click the “Go…” button to open the “Add-Ins” dialog box.

Here you can check which add-ins you wish to load by placing a check next to the name of the add-in set you want. For example, if you wanted to use many of the financial functions, you will need to load the “Analysis ToolPak” add-in. Once you have selected the desired add-ins to load, click “OK.” That will then load the selected add-ins and their related functions. You only need to load the functions once per computer.

If you try to type the name of one of the functions that are loaded from an add-in set that you have not yet loaded, you will probably receive the “#NAME?” error message. If this is the case, make sure that you have typed the name of the function correctly (no spaces) and that you have the correct add-ins installed.

Also note that for Excel 2013, the functions listed within the “Compatibility” category are only retained for compatibility with older versions of Excel. These functions have been replaced with newer, more accurate versions that you should consider using instead, as the functions within the “Compatibility” category may no longer appear in future versions of Excel.
Glossary of Functions

BETADIST (Deprecated):
Description: Using the BETADIST function returns the beta cumulative distribution function.
General Syntax: =BETADIST(x,alpha,beta,a,b)
Arguments: x is the value between a and b at which to evaluate the function. alpha is a parameter of the distribution. beta is a parameter of the distribution. a is an optional lower bound of the interval x. b is an optional upper bound of the interval x.
Replacement Function: BETA.DIST

BETAINV (Deprecated):
Description: Using the BETAINV function returns the inverse of the cumulative distribution function for a specified beta distribution. That is, if probability = BETADIST(x,...), then BETAINV(probability,...) = x. The beta distribution can be used in project planning to model probable completion times given an expected completion time and variability.
General Syntax: =BETAINV(probability,alpha,beta,a,b)
Arguments: probability is a is a probability associated with the beta distribution. alpha is a parameter of the distribution. beta is a parameter of the distribution. a is an optional lower bound of the interval x. b is an optional upper bound of the interval x.
Replacement Function: BETA.INV

BINOMDIST (Deprecated):
Description: Using the BINOMDIST function returns the individual term binomial distribution probability. Use BINOMDIST in problems with a fixed number of tests or trials, when the outcomes of any trial are only success or failure, when trials are independent, and when the probability of success is constant throughout the experiment.
General Syntax: =BINOMDIST(success,trials,probability,cumulative)
Arguments: success is the number of successes in trials. trials is the number of independent trials. probability is the probability of success on each trial. cumulative is a logical value that determines the form of the function. If cumulative is TRUE, then BINOMDIST returns the cumulative distribution function, which is the probability that there are at most number successes; if FALSE, it returns the probability mass function, which is the probability that there are number successes.
Replacement Function: BINOM.DIST

CHIDIST (Deprecated):
Description: Using the CHIDIST function returns the one-tailed probability of the chi-squared distribution. The c2 distribution is associated with a c2 test. Use the c2 test to compare observed and expected values.
General Syntax: =CHIDIST(x,degrees)
Arguments: x is the values at which you want to evaluate the distribution. degrees is the number of degrees of freedom to use.
Replacement Functions: CHISQ.DIST and CHISQ.DIST.RT
Glossary of Functions

CHIINV (Deprecated):

Description: Using the CHIINV function returns the inverse of the one-tailed probability of the chi-squared distribution. If probability = CHIDIST(x,...), then CHIINV(probability,...) = x. Use this function to compare observed results with expected ones to decide whether your original hypothesis is valid.

General Syntax: =CHIINV(x,degrees)

Arguments: x is a probability associated with the chi-squared distribution.
degrees is the number of degrees of freedom to use.

Replacement Functions: CHISQ.INV and CHISQ.INV.RT

CHITEST (Deprecated):

Description: Using the CHITEST function returns the test for independence. CHITEST returns the value from the chi-squared (c²) distribution for the statistic and the appropriate degrees of freedom. You can use c² tests to determine whether hypothesized results are verified by an experiment.

General Syntax: =CHITEST(actual_range,expected_range)

Arguments: actual_range is the range of data that contains observations to test against expected values.
expected_range is the range of data that contains the ratio of the product of row totals and column totals to the grand total.

Replacement Function: CHISQ.TEST

CONFIDENCE (Deprecated):

Description: Using the CONFIDENCE function returns a value that you can use to construct a confidence interval for a population mean. The confidence interval is a range of values. Your sample mean, x, is at the center of this range and the range is x ± CONFIDENCE.

General Syntax: =CONFIDENCE(alpha,st_dev,size)

Arguments: alpha is the significance level used to compute the confidence level.
st_dev is the population standard deviation for the data range and is assumed to be known.
size is the sample size.

Replacement Functions: CONFIDENCE.NORM and CONFIDENCE.T

COVAR (Deprecated):

Description: Using the COVAR function returns covariance, the average of the products of deviations for each data point pair. Use covariance to determine the relationship between two data sets.

General Syntax: =COVAR(array1,array2)

Arguments: array1 is the first cell range of integers.
array2 is the second cell range of integers.

Replacement Functions: CONVARIANCE.P and COVARIANCE.S
CRITBINOM (Deprecated):

Description: Using the CRITBINOM function returns the smallest value for which the cumulative binomial distribution is greater than or equal to a criterion value. Use this function for quality assurance applications.

General Syntax: =CRITBINOM(trials,s_prob,alpha)

Arguments:
- trials is the number of Bernoulli trials.
- s_prob is the probability of a success on each trial.
- alpha is the criterion value.

Replacement Function: BINOM.INV

EXPONDIST (Deprecated):

Description: Using the EXPONDIST function returns the exponential distribution.

General Syntax: =EXPONDIST(x,lambda,cumulative)

Arguments:
- x is the value of the function.
- lambda is the parameter value.
- cumulative is a logical value that indicates which form of the exponential function to provide. If cumulative is TRUE, it returns the cumulative distribution function; if FALSE, it returns the probability density function.

Replacement Function: EXPON.DIST

FDIST (Deprecated):

Description: Using the FDIST function returns the F probability distribution. You can use this function to determine whether two data sets have different degrees of diversity.

General Syntax: =FDIST(x,f_degrees1,f_degrees2)

Arguments:
- x is the value at which the function is evaluated.
- f_degrees1 is the numerator's degrees of freedom.
- f_degrees2 is the denominator's degrees of freedom.

Replacement Functions: F.DIST and F.DIST.RT

FINV (Deprecated):

Description: Using the FINV function returns the inverse of the F probability distribution. If p = FDIST(x,...), then FINV(p,...) = x. The F distribution can be used in an F-test that compares the degree of variability in two data sets.

General Syntax: =FINV(probability,f_degrees1,f_degrees2)

Arguments:
- probability is a probability associated with the F cumulative distribution.
- f_degrees1 is the numerator's degrees of freedom.
- f_degrees2 is the denominator's degrees of freedom.

Replacement Functions: F.INV and F.INV.RT
### FTEST (Deprecated):

**Description:**
Using the FTEST function returns the result of an F-test. An F-test returns the one-tailed probability that the variances in array1 and array2 are not significantly different. Use this function to determine whether two samples have different variances.

**General Syntax:**
= FTEST(array1, array2)

**Arguments:**
- array1 is the first array or range of data.
- array2 is the second array or range of data.

**Replacement Function:**
F.TEST

### GAMMADIST (Deprecated):

**Description:**
Using the GAMMADIST function returns the gamma distribution. You can use this function to study variables that may have a skewed distribution. The gamma distribution is commonly used in queueing analysis.

**General Syntax:**
= GAMMADIST(x, alpha, beta, cumulative)

**Arguments:**
- x is the value at which to evaluate the function.
- alpha is a parameter to the distribution.
- beta is a parameter to the distribution. If beta = 1, it returns the standard gamma distribution.
- cumulative is a logical value that determines the form of the function. If cumulative is TRUE, it returns the cumulative distribution function; if FALSE, it returns the probability density function.

**Replacement Function:**
GAMMA.DIST

### GAMMAINV (Deprecated):

**Description:**
Using the GAMMAINV function returns the inverse of the gamma cumulative distribution.

**General Syntax:**
= GAMMAINV(x, alpha, beta, cumulative)

**Arguments:**
- probability is the probability associated with the gamma distribution.
- alpha is a parameter to the distribution.
- beta is a parameter to the distribution. If beta = 1, it returns the standard gamma distribution.

**Replacement Function:**
GAMMA.INV

### HYPGEOMDIST (Deprecated):

**Description:**
Using the HYPGEOMDIST function returns the hypergeometric distribution. HYPGEOMDIST returns the probability of a given number of sample successes, given the sample size, population successes, and population size. Use HYPGEOMDIST for problems with a finite population, where each observation is either a success or a failure, and where each subset of a given size is chosen with equal likelihood.

**General Syntax:**
= HYPGEOMDIST(sample_s, number_sample, population_s, number_population)

**Arguments:**
- sample_s is the number of successes in the sample.
- number_sample is the size of the sample.
- population_s is the number of successes in the population.
- number_population is the population size.

**Replacement Function:**
HYPGEOM.DIST
# Glossary of Functions

## LOGINV (Deprecated):

**Description:**
Using the LOGINV function returns the inverse of the lognormal cumulative distribution function of x, where ln(x) is normally distributed with parameters mean and standard_dev. If p = LOGNORMDIST(x,...) then LOGINV(p,...) = x. Use the lognormal distribution to analyze logarithmically transformed data.

**General Syntax:**
=LOGINV(probability,mean,standard_dev)

**Arguments:**
- **probability** is a probability associated with the lognormal distribution.
- **mean** is the mean of ln(x).
- **standard_dev** is the standard deviation of ln(x).

**Replacement Function:**
LOGNORM.INV

## LOGNORMDIST (Deprecated):

**Description:**
Using the LOGNORMDIST function returns the cumulative lognormal distribution of x, where ln(x) is normally distributed with parameters mean and standard_dev. Use this function to analyze data that has been logarithmically transformed.

**General Syntax:**
=LOGNORMDIST(x,mean,standard_dev)

**Arguments:**
- **x** is the value at which you want to evaluate the function.
- **mean** is the mean of ln(x).
- **standard_dev** is the standard deviation of ln(x).

**Replacement Function:**
LOGNORM.DIST

## MODE (Deprecated):

**Description:**
Using the MODE function returns the most frequently occurring, or repetitive, value in an array or range of data.

**General Syntax:**
=MODE(numbers)

**Arguments:**
- **numbers** is a comma-separated list of 1 to 255 numbers for which you want the mode.

**Replacement Functions:**
MODE.MULT and MODE.SNGL

## NEGBINOMDIST (Deprecated):

**Description:**
Using the NEGBINOMDIST function returns the negative binomial distribution. NEGBINOMDIST returns the probability that there will be **number_f** failures before the **number_s**-th success, when the constant probability of a success is **probability_s**. This function is similar to the binomial distribution, except that the number of successes is fixed, and the number of trials is variable. Like the binomial, trials are assumed to be independent.

**General Syntax:**
=NEGBINOMDIST(number_f,number_s,probability_s)

**Arguments:**
- **number_f** is the number of failures.
- **number_s** is the threshold number of successes.
- **probability_s** is the probability of a success.

**Replacement Function:**
NEGBINOM.DIST
# Glossary of Functions

## NORMDIST (Deprecated):

**Description:**
Using the NORMDIST function returns the normal distribution for the specified mean and standard deviation. This function has a very wide range of applications in statistics, including hypothesis testing.

**General Syntax:**
= NORMDIST(x, mean, standard_dev, cumulative)

**Arguments:**
- `x` is the value for which you want the distribution.
- `mean` is the arithmetic mean of the distribution.
- `standard_dev` is the standard deviation of the distribution.
- `cumulative` is a logical value that determines the form of the function. If cumulative is TRUE, NORMDIST returns the cumulative distribution function; if FALSE, it returns the probability mass function.

**Replacement Function:**
NORM.DIST

## NORMINV (Deprecated):

**Description:**
Using the NORMINV function returns the inverse of the normal cumulative distribution for the specified mean and standard deviation.

**General Syntax:**
= NORMINV(probability, mean, standard_dev)

**Arguments:**
- `probability` is a probability corresponding to the normal distribution.
- `mean` is the arithmetic mean of the distribution.
- `standard_dev` is the standard deviation of the distribution.

**Replacement Function:**
NORM.INV

## NORMSDIST (Deprecated):

**Description:**
Using the NORMSDIST function returns the standard normal cumulative distribution function. The distribution has a mean of 0 (zero) and a standard deviation of one. Use this function in place of a table of standard normal curve areas.

**General Syntax:**
= NORMSDIST(z)

**Arguments:**
- `z` is the value for which you want the distribution.

**Replacement Function:**
NORM.S.DIST

## NORMSINV (Deprecated):

**Description:**
Using the NORMSINV function returns the inverse of the standard normal cumulative distribution. The distribution has a mean of zero and a standard deviation of one.

**General Syntax:**
= NORMSINV(probability)

**Arguments:**
- `probability` is a probability corresponding to the normal distribution.

**Replacement Function:**
NORM.S.INV
Glossary of Functions

PERCENTILE (Deprecated):

Description: Using the PERCENTILE function returns the \( k \)-th percentile of values in a range. You can use this function to establish a threshold of acceptance.

General Syntax: \( =\text{PERCENTILE}(\text{array}, k) \)

Arguments: array is the array or range of data that defines relative standing.
\( k \) is the percentile value in the range 0..1, inclusive.

Replacement Functions: PERCENTILE.EXC and PERCENTILE.INC

PERCENTRANK (Deprecated):

Description: Using the PERCENTRANK function returns the rank of a value in a data set as a percentage of the data set. This function can be used to evaluate the relative standing of a value within a data set.

General Syntax: \( =\text{PERCENTRANK}(\text{array}, x, \text{significance}) \)

Arguments: array is the array or range of data with numeric values that defines relative standing.
\( x \) is the value for which you want to know the rank.
\( \text{significance} \) is an optional value that identifies the number of significant digits for the returned percentage value. If omitted, it uses three digits (0.xxx).

Replacement Functions: PERCENTRANK.EXC and PERCENTRANK.INC

POISSON (Deprecated):

Description: Using the POISSON function returns the Poisson distribution. A common application of the Poisson distribution is predicting the number of events over a specific time, such as the number of cars driving through an intersection in an hour.

General Syntax: \( =\text{POISSON}(x, \text{mean}, \text{cumulative}) \)

Arguments: \( x \) is the number of events.
\( \text{mean} \) is the expected numeric value.
\( \text{cumulative} \) is a logical value that determines the form of the probability distribution returned. If \( \text{cumulative} \) is TRUE, it returns the cumulative Poisson probability that the number of random events occurring will be between zero and \( x \) inclusive; if FALSE, it returns the Poisson probability mass function that the number of events occurring will be exactly \( x \).

Replacement Function: POISSON.DIST

QUARTILE (Deprecated):

Description: Using the QUARTILE function returns the quartile of a data set. Quartiles often are used in sales and survey data to divide populations into groups.

General Syntax: \( \text{QUARTILE}(\text{array}, \text{quart}) \)

Arguments: array is the array or cell range of numeric values for which you want the quartile value.
\( \text{quart} \) indicates which value to return.

If \( \text{quart} \) equals: QUARTILE returns:
0 Minimum value
1 First quartile (25th percentile)
2 Median value (50th percentile)
3 Third quartile (75th percentile)
4 Maximum value

Replacement Functions: QUARTILE.EXC and QUARTILE.INC
**Glossary of Functions**

### RANK (Deprecated):

**Description:**
Using the RANK function returns the rank of a number in a list of numbers. The rank of a number is its size relative to other values in a list.

**General Syntax:**
=RANK(number,ref,order)

**Arguments:**
- **number** is the number whose rank you want to find.
- **ref** is an array of, or a reference to, a list of numbers. Nonnumeric values in ref are ignored.
- **order** is a number specifying how to rank number. If order is 0 (zero) or omitted, Excel ranks number as if ref were a list sorted in descending order. If order is any nonzero value, Excel ranks number as if ref were a list sorted in ascending order.

**Replacement Functions:**
RANK.AVG and RANK.EQ

### STDEV (Deprecated):

**Description:**
Using the STDEV function estimates standard deviation based on a sample. The standard deviation is a measure of how widely values are dispersed from the average value (the mean).

**General Syntax:**
=STDEV(numbers)

**Arguments:**
- **numbers** is a comma-separated list of 1 to 255 number arguments corresponding to a sample of a population. You can also use a single array or a reference, instead.

**Replacement Function:**
STDEV.S

### STDEVP (Deprecated):

**Description:**
Using the STDEVP function calculates standard deviation based on the entire population given as arguments. The standard deviation is a measure of how widely values are dispersed from the average value (the mean).

**General Syntax:**
=STDEVP(numbers)

**Arguments:**
- **numbers** is a comma-separated list of 1 to 255 number arguments corresponding to an entire population. You can also use a single array or a reference, instead.

**Replacement Function:**
STDEV.P

### TDIST (Deprecated):

**Description:**
Using the TDIST function returns the Percentage Points (probability) for the Student t-distribution where a numeric value (x) is a calculated value of t for which the Percentage Points are to be computed. The t-distribution is used in the hypothesis testing of small sample data sets. Use this function in place of a table of critical values for the t-distribution.

**General Syntax:**
=TDIST(x,degrees_freedom,tails)

**Arguments:**
- **x** is the numeric value at which to evaluate the distribution.
- **degrees_freedom** is an integer indicating the number of degrees of freedom.
- **tails** specifies the number of distribution tails to return. If tails = 1, TDIST returns the one-tailed distribution. If tails = 2, TDIST returns the two-tailed distribution.

**Replacement Functions:**
T.DIST.2T and T.DIST.RT
**Glossary of Functions**

**TINV (Deprecated):**

**Description:**
Using the TINV function returns the t-value of the Student's t-distribution as a function of the probability and the degrees of freedom.

**General Syntax:**
= TINV(probability, degrees_freedom)

**Arguments:**
- **probability** is the probability associated with the two-tailed Student's t-distribution.
- **degrees_freedom** is the number of degrees of freedom with which to characterize the distribution.

**Replacement Function:**
T.INV.2T and T.INV

**TTEST (Deprecated):**

**Description:**
Using the TTEST function returns the probability associated with a Student's t-Test. Use TTEST to determine whether two samples are likely to have come from the same two underlying populations that have the same mean.

**General Syntax:**
= TTEST(array1, array2, tails, type)

**Arguments:**
- **array1** is the first data set.
- **array2** is the second data set.
- **tails** specifies the number of distribution tails. If tails = 1, TTEST uses the one-tailed distribution. If tails = 2, TTEST uses the two-tailed distribution.
- **type** is the kind of t-Test to perform.

<table>
<thead>
<tr>
<th>Type equals:</th>
<th>Test performed:</th>
<th>Type equals:</th>
<th>Test performed:</th>
<th>Type equals:</th>
<th>Test performed:</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Paired</td>
<td>2</td>
<td>Two-sample equal variance</td>
<td>3</td>
<td>Two-sample unequal variance</td>
</tr>
</tbody>
</table>

**Replacement Function:**
T.TEST

**VAR (Deprecated):**

**Description:**
Using the VAR function estimates variance based on a sample.

**General Syntax:**
= VAR(numbers)

**Arguments:**
- **numbers** is a comma-separated list of 1 to 255 numbers corresponding to a sample of a population.

**Replacement Function:**
VAR.S

**VARP (Deprecated):**

**Description:**
Using the VARP function calculates variance based on the entire population.

**General Syntax:**
= VARP(numbers)

**Arguments:**
- **numbers** is a comma-delimited list of 1 to 255 numbers corresponding to a population.

**Replacement Function:**
VAR.P
WEIBULL (Deprecated):

Description: Using the WEIBULL function returns the Weibull distribution. Use this distribution in reliability analysis, such as calculating a device's mean time to failure.

General Syntax: \[ =\text{WEIBULL}(x,\alpha,\beta,\text{cumulative}) \]

Arguments:
- \( x \) is the value at which to evaluate the function.
- \( \alpha \) is a parameter to the distribution.
- \( \beta \) is a parameter to the distribution.
- \( \text{cumulative} \) determines the form of the function.

Replacement Function: WEIBULL.DIST

ZTEST (Deprecated):

Description: Using the ZTEST function Returns the one-tailed probability-value of a z-test. For a given hypothesized population mean, \( \mu_0 \), ZTEST returns the probability that the sample mean would be greater than the average of observations in the data set (array)—that is, the observed sample mean.

General Syntax: \[ =\text{ZTEST}(\text{array},\mu_0,\sigma) \]

Arguments:
- \( \text{array} \) is the array or range of data against which to test \( \mu_0 \).
- \( \mu_0 \) is the value to test.
- \( \sigma \) is the population (known) standard deviation. If omitted, the sample standard deviation is used.

Formula: ZTEST is calculated as follows when \( \sigma \) is not omitted:

\[
\text{ZTEST} = \frac{x - \mu_0}{s/\sqrt{n}}
\]

or when \( \sigma \) is omitted:

\[
\text{ZTEST} = \frac{x - \mu_0}{s/\sqrt{n}}
\]

where \( x \) is the sample mean \( \text{AVERAGE}(\text{array}) \); \( s \) is the sample standard deviation \( \text{STDEV}(\text{array}) \); and \( n \) is the number of observations in the sample \( \text{COUNT}(\text{array}) \).

ZTEST represents the probability that the sample mean would be greater than the observed value \( \text{AVERAGE}(\text{array}) \), when the underlying population mean is \( \mu_0 \). From the symmetry of the Normal distribution, if \( \text{AVERAGE}(\text{array}) < \mu_0 \), ZTEST will return a value greater than 0.5.

The following Excel formula can be used to calculate the two-tailed probability that the sample mean would be further from \( \mu_0 \) (in either direction) than \( \text{AVERAGE}(\text{array}) \), when the underlying population mean is \( \mu_0 \):

\[
=2 \times \text{MIN}(\text{ZTEST}(\text{array},\mu_0,\sigma),1-\text{ZTEST}(\text{array},\mu_0,\sigma)).
\]

Replacement Function: Z.TEST
Glossary of Functions

CUBEKPIMEMBER:

Description: Returns a key performance indicator (KPI) property and displays the KPI name in the cell. The CUBEKPIMEMBER function is supported only when the workbook is connected to a Microsoft SQL Server 2005 Analysis Services or later data source.

General Syntax: =CUBEKPIMEMBER(connection,kpi_name,kpi_property,caption)

Arguments:
- connection is a text string of the name of the data cube connection.
- kpi_name is a text string of the name of the KPI in the cube.
- kpi_property is the KPI component returned. It can be one of the following values: 1 for “KPIValue” 2 for “KPIGoal” 3 for “KPIStatus” 4 for KPI Trend” 5 for “KPIWeight” or 6 for “KPI CurrentTimeMember.”
- caption is an optional argument that is a text string value that can be displayed in the cell versus using kpi_name and kpi_property.

CUBEMEMBER:

Description: Returns a member or tuple from the cube. Use to validate that the member or tuple exists in the cube.

General Syntax: =CUBEMEMBER(connection,member_expression,caption)

Arguments:
- connection is a text string of the name of the data cube connection.
- member_expression is a text string of a multidimensional expression (MDX) that evaluates to a unique member in the cube. Alternatively, member_expression can be a tuple, specified as a cell range or an array constant.
- caption is an optional argument that is a text string value that can be displayed in the cell versus a caption, if one is defined, from the cube. When a tuple is returned, the caption used is for the last member in the tuple.

CUBEMEMBERPROPERTY:

Description: Returns the value of a member property from the cube. Use to validate that a member name exists within the cube and to return the specified property for this member.

General Syntax: =CUBEMEMBERPROPERTY(connection,member_expression,property)

Arguments:
- connection is a text string of the name of the data cube connection.
- member_expression is a text string of a multidimensional expression (MDX) that evaluates to a unique member in the cube. Alternatively, member_expression can be a tuple, specified as a cell range or an array constant.
- property is a text string of the name of the property returned or a reference to a cell that contains the name of the property.

CUBERANKEDMEMBER:

Description: Returns the nth, or ranked, member in a set. Use to return one or more elements in a set, such as the top salesperson, or the top 10 best-selling products.

General Syntax: =CUBERANKEDMEMBER(connection,set_expression,rank,caption)

Arguments:
- connection is a text string of the name of the data cube connection.
- set_expression is a text string of a of a set expression, or the CUBESET function, or a reference to a cell that contains the CUBESET function.
- rank is an integer specifying the top value to return. If rank is 1, it returns the top value, if rank is 2, it returns the second most top value, and so forth.
- caption is an optional argument that is a text string displayed in the cell instead of the caption, if one is defined, from the cube.
## CUBESET:

**Description:**
Defines a calculated set of members or tuples by sending a set expression to the cube on the server, which creates the set, and then returns that set to Microsoft Excel.

**General Syntax:**
= CUBESET(connection, set_expression, caption, sort_order, sort_by)

**Arguments:**
- `connection` is a text string of the name of the data cube connection.
- `set_expression` is a text string of a set expression that results in a set of members or tuples. It can also be a cell reference to an Excel range that contains one or more members, tuples, or sets included in the set.
- `caption` is an optional argument that is a text string value that can be displayed in the cell.
- `sort_order` is an option expression. It can be one of the following values: 0 for “SortNone” 1 for “SortAscending” 2 for “SortDescending” 3 for “SortAlphaAscending” 4 for Sort_Alpha_Descending” 5 for “Sort_Natural_Ascending” or 6 for “Sort_Natural_Descending.”
- `sort_by` is an optional text string expression of the values by which to sort. Used when the `sort_order` argument is either 1 or 2.

## CUBESETCOUNT:

**Description:**
Returns the number of items within a set.

**General Syntax:**
= CUBESETCOUNT(set)

**Arguments:**
- `set` is a text string of a Microsoft Excel expression that evaluates to a set defined by the CUBESET function. Set can also be the CUBESET function, or a reference to a cell that contains the CUBESET function.

## CUBEVALUE:

**Description:**
Returns an aggregated value from the cube.

**General Syntax:**
= CUBEMEMBERPROPERTY(connection, member_expression1, member_expression2, …)

**Arguments:**
- `connection` is a text string of the name of the data cube connection.
- `member_expression` is an optional text string of a multidimensional expression (MDX) that evaluates to a member or tuple within the cube. Alternatively, it can be a set defined with the CUBESET function. Use it as a slicer to define the portion of the cube for which the aggregated value is returned. If no measure is specified, the default measure for that cube is used.
**DAVERAGE:**

**Description:**
Using the DAVERAGE function will return the average of selected database entries. It will find the average of a field in a table or database, based on specified criteria.

**General Syntax:**
=DAVERAGE(database,field,criteria)

**Arguments:**
- **database** is the reference to the cell range or named range of the database or table which you want to use in the function.
- **field** is the name of the field in the database upon which you perform the function. If this is entered as text, place it inside of double-quotes (" "). You may also reference the field by its column number within the database (with the left-most column in the table or database being column number 1).
- **criteria** is the cell reference of the criteria range used to filter the database or table.

**DCOUNT:**

**Description:**
Using the DCOUNT function will return the count of cells that contain number values for selected database entries. It will find the count of cells that contain numbers in a field of a table or database, based on specified criteria.

**General Syntax:**
=DCOUNT(database,field,criteria)

**Arguments:**
- **database** is the reference to the cell range or named range of the database or table which you want to use in the function.
- **field** is the name of the field in the database upon which you perform the function. If this is entered as text, place it inside of double-quotes (" "). You may also reference the field by its column number within the database (with the left-most column in the table or database being column number 1). This is an optional argument.
- **criteria** is the cell reference of the criteria range used to filter the database or table.

**DCOUNTA:**

**Description:**
Using the DCOUNTA function will return the count of cells that are not blank for selected database entries. It will find the count of cells that do not contain blanks in a field of a table or database, based on specified criteria.

**General Syntax:**
=DCOUNTA(database,field,criteria)

**Arguments:**
- **database** is the reference to the cell range or named range of the database or table which you want to use in the function.
- **field** is the name of the field in the database upon which you perform the function. If this is entered as text, place it inside of double-quotes (" "). You may also reference the field by its column number within the database (with the left-most column in the table or database being column number 1). This is an optional argument.
- **criteria** is the cell reference of the criteria range used to filter the database or table.

**DGET:**

**Description:**
Using the DGET function will return the unique value found within a field of a table or database, based on specified criteria. If no record matches the criteria, this function will return the "#VALUE!" error. If more than one record matches the criteria, it will return the "#NUM!" error.

**General Syntax:**
=DGET(database,field,criteria)

**Arguments:**
- **database** is the reference to the cell range or named range of the database or table which you want to use in the function.
- **field** is the name of the field in the database upon which you perform the function. If this is entered as text, place it inside of double-quotes (" "). You may also reference the field by its column number within the database (with the left-most column in the table or database being column number 1).
- **criteria** is the cell reference of the criteria range used to filter the database or table.
## Glossary of Functions

### DMAX:

**Description:**
Using the DMAX function will return the largest number found within a field of a table or database, based on specified criteria.

**General Syntax:**
=DMAX(database, field, criteria)

**Arguments:**
- **database** is the reference to the cell range or named range of the database or table which you want to use in the function.
- **field** is the name of the field in the database upon which you perform the function. If this is entered as text, place it inside of double-quotes (" "). You may also reference the field by its column number within the database (with the left-most column in the table or database being column number 1).
- **criteria** is the cell reference of the criteria range used to filter the database or table.

### DMIN:

**Description:**
Using the DMIN function will return the smallest number found within a field of a table or database, based on specified criteria.

**General Syntax:**
=DMIN(database, field, criteria)

**Arguments:**
- **database** is the reference to the cell range or named range of the database or table which you want to use in the function.
- **field** is the name of the field in the database upon which you perform the function. If this is entered as text, place it inside of double-quotes (" "). You may also reference the field by its column number within the database (with the left-most column in the table or database being column number 1).
- **criteria** is the cell reference of the criteria range used to filter the database or table.

### DPRODUCT:

**Description:**
Using the DPRODUCT function will multiply the values found within a field of a table or database, based on specified criteria.

**General Syntax:**
=DPRODUCT(database, field, criteria)

**Arguments:**
- **database** is the reference to the cell range or named range of the database or table which you want to use in the function.
- **field** is the name of the field in the database upon which you perform the function. If this is entered as text, place it inside of double-quotes (" "). You may also reference the field by its column number within the database (with the left-most column in the table or database being column number 1).
- **criteria** is the cell reference of the criteria range used to filter the database or table.

### DSTDEV:

**Description:**
Using the DSTDEV function will estimate the standard deviation of values found within a field of a table or database, based on specified criteria.

**General Syntax:**
=DSTDEV(database, field, criteria)

**Arguments:**
- **database** is the reference to the cell range or named range of the database or table which you want to use in the function.
- **field** is the name of the field in the database upon which you perform the function. If this is entered as text, place it inside of double-quotes (" "). You may also reference the field by its column number within the database (with the left-most column in the table or database being column number 1).
- **criteria** is the cell reference of the criteria range used to filter the database or table.
Glossary of Functions

DSTDEV:  
Description: Using the DSTDEV function will estimate the standard deviation of a population based on the entire population of values found within a field of a table or database using the records that match the specified criteria.

General Syntax: =DSTDEV(database,field,criteria)

Arguments:  
database is the reference to the cell range or named range of the database or table which you want to use in the function.
field is the name of the field in the database upon which you perform the function. If this is entered as text, place it inside of double-quotes (" "). You may also reference the field by its column number within the database (with the left-most column in the table or database being column number 1).
criteria is the cell reference of the criteria range used to filter the database or table.

DSUM:  
Description: Using the DSUM function will add the values found within a field of a table or database, based on specified criteria.

General Syntax: =DSUM(database,field,criteria)

Arguments:  
database is the reference to the cell range or named range of the database or table which you want to use in the function.
field is the name of the field in the database upon which you perform the function. If this is entered as text, place it inside of double-quotes (" "). You may also reference the field by its column number within the database (with the left-most column in the table or database being column number 1).
criteria is the cell reference of the criteria range used to filter the database or table.

DVAR:  
Description: Using the DVAR function will estimate the variance of a population found within a field of a table or database, based on specified criteria.

General Syntax: =DVAR(database,field,criteria)

Arguments:  
database is the reference to the cell range or named range of the database or table which you want to use in the function.
field is the name of the field in the database upon which you perform the function. If this is entered as text, place it inside of double-quotes (" "). You may also reference the field by its column number within the database (with the left-most column in the table or database being column number 1).
criteria is the cell reference of the criteria range used to filter the database or table.

DVARP:  
Description: Using the DVARP function will estimate the variance of a population based on the entire population of values found within a field of a table or database using the records that match the specified criteria.

General Syntax: =DVARP(database,field,criteria)

Arguments:  
database is the reference to the cell range or named range of the database or table which you want to use in the function.
field is the name of the field in the database upon which you perform the function. If this is entered as text, place it inside of double-quotes (" "). You may also reference the field by its column number within the database (with the left-most column in the table or database being column number 1).
criteria is the cell reference of the criteria range used to filter the database or table.
Glossary of Functions

**DATE:**

*Description:* Using the DATE function returns the serial number that represents a specific date. If the cell into which you enter this formula is formatted as “General” before creating the formula the output will still be displayed as a date.

*General Syntax:* =DATE(year,month,day)

*Arguments:* 
- **year** is the reference to the cell or value (of 1 to 4 digits) that represents the year.
- **month** is the reference to the cell or value that represents the month.
- **day** is the cell reference or value that represents the day.

**DATEVALUE:**

*Description:* Use the DATEVALUE function to return the serial number of a date that is entered as a text string, enclosed in double-quotes (“”).

*General Syntax:* =DATEVALUE(date_as_text)

*Arguments:* 
- **date_as_text** is the date text string, enclosed in double-quotes, for which you wish to find the serial number. E.g. “8/2/1975.”

**DAY:**

*Description:* Use the DAY function to return the “day” number (from 1 to 31) of a date value that is entered by hand or referenced in a cell. Will not work on dates entered as “text” values.

*General Syntax:* =DAY(date)

*Arguments:* 
- **date** is the date value from which you wish to extract the “day” number.

**DAYS:**

*Description:* Returns the number of days between two dates.

*General Syntax:* =DAYS(end_date, start_date)

*Arguments:* 
- **start_date** is the first date value.
- **end_date** is the last date value.

**DAYS360:**

*Description:* Use the DAYS360 function to return the number of days between two date values, based on a 360 day year (twelve 30-day months). Used by some accounting calculations to compute payments based on a 12-month 30-day accounting system.

*General Syntax:* =DAYS360(start_date,end_date,method)

*Arguments:* 
- **start_date** is the first date in the date range.
- **end_date** is the last date in the date range.
- **method** is an optional argument that can be either “TRUE” or “FALSE.” If omitted, “FALSE” is assumed. Use “TRUE” for the European method of calculation where the 31st is always equal to the 30th of the same month.

**EDATE:**

*Description:* Using the EDATE function returns the date value that is the indicated number of months before or after the date value specified. Often used to calculate maturity or due dates that fall on the same date as the month of issue.

*General Syntax:* =EDATE(date,months)

*Arguments:* 
- **date** is the date value referenced by the formula.
- **months** is the number of months before or after the date value specified. Can be either positive or negative.
Glossary of Functions

**EOMONTH:**

*Description:* Using the EOMONTH function returns the date value of the end of the month that is the indicated number of months before or after the date value specified. Often used to calculate maturity or due dates that fall on the last day of the month.

*General Syntax:* 
=EOMONTH(date,months)

*Arguments:* 
- **date** is the date value referenced by the formula.
- **months** is the number of months before or after the date value specified. Can be either positive or negative.

**HOUR:**

*Description:* Using the HOUR function returns the “hour” number (from 0 to 23) of a time value. The “hour” ranges from 0 (12:00 AM) to 23 (11:00 PM).

*General Syntax:* 
=HOUR(time)

*Arguments:* 
- **time** is the time value referenced by the formula, which contains the hour you want to find.

**ISOWEEKNUM:**

*Description:* Returns number of the ISO week number of the year for a given date.

*General Syntax:* 
=ISOWEEKNUM(date)

*Arguments:* 
- **date** is the date-time code used by Excel for date and time calculation.

**MINUTE:**

*Description:* Using the MINUTE function returns the “minute” number (from 0 to 59) of a time value.

*General Syntax:* 
=MINUTE(time)

*Arguments:* 
- **time** is the time value referenced by the formula, which contains the minute you want to find.

**MONTH:**

*Description:* Using the MONTH function returns the “month” number (from 1 to 12) of a date value. The “month” ranges from 1 (January) to 12 (December).

*General Syntax:* 
=MONTH(date)

*Arguments:* 
- **date** is the date value referenced by the formula, which contains the month you want to find.

**NETWORKDAYS:**

*Description:* Using the NETWORKDAYS function returns the number of work days between two dates specified by the formula. This function excludes weekends and days identified as holidays.

*General Syntax:* 
=NETWORKDAYS(start_date,end_date,holidays)

*Arguments:* 
- **start_date** is the starting date value.
- **end_date** is the ending date value.
- **holidays** is an optional cell range reference to a range of cells that contain a listing of any date values between **start_date** and **end_date** to be excluded from the number of net work days.
Glossary of Functions

NETWORKDAYS.INTL:
Description: Using the NETWORKDAYS.INTL function returns the number of work days between two dates specified by the formula. This function excludes weekends and days identified as holidays.

General Syntax: =NETWORKDAYS.INTL(start_date, end_date, weekend, holidays)

Arguments:
- **start_date** is the starting date value.
- **end_date** is the ending date value.
- **weekend** is an optional integer that indicates the days of the week that are weekend days and are not included in the number of whole working days between **start_date** and **end_date**. Weekend is a weekend number that specifies when weekends occur:
  - 1 or omitted = Saturday, Sunday
  - 2 = Sunday, Monday
  - 3 = Monday, Tuesday
  - 4 = Tuesday, Wednesday
  - 5 = Wednesday, Thursday
  - 6 = Thursday, Friday
  - 7 = Friday, Saturday
  - 11 = Sunday only
  - 12 = Monday only
  - 13 = Tuesday only
  - 14 = Wednesday only
  - 15 = Thursday only
  - 16 = Friday only
  - 17 = Saturday only
- **holidays** is an optional cell range reference to a range of cells that contain a listing of any date values between **start_date** and **end_date** to be excluded from the number of work days.

NOW:
Description: Using the NOW function returns the date/time value of the current date and time.

General Syntax: =NOW()

Arguments: None.

SECOND:
Description: Using the SECOND function returns the “second” number (from 0 to 59) of a time value.

General Syntax: =SECOND(time)

Arguments:
- **time** is the time value referenced by the formula, which contains the second you want to find.

TIME:
Description: Using the TIME function returns the decimal number that represents the time specified. If the cell into which you enter this formula is formatted as “General” before entering this function, the result is displayed as a date/time value.

General Syntax: =TIME(hour,minute,second)

Arguments:
- **hour** is the number that represents the “hour” value.
- **minute** is the number that represents the “minute” value.
- **second** is the number that represents the “second” value.
## Glossary of Functions

### TIMEVALUE:

**Description:**
Using the TIMEVALUE function returns the decimal number of the time specified by a text string (enclosed in double-quotes).

**General Syntax:**
=TIMEVALUE(time_as_text)

**Arguments:**
- time_as_text is the time text string, enclosed in double-quotes, for which you wish to find the serial number. E.g. "11:11 PM."

### TODAY:

**Description:**
Using the TODAY function returns the date value of the current date. If the cell into which you enter this formula is formatted as “General” before entering this function, the result is displayed as a date value.

**General Syntax:**
=TODAY()

**Arguments:**
None.

### WEEKDAY:

**Description:**
Using the WEEKDAY function returns the number of the day of the week (from 1 to 7) of a specified date value. The "weekday" number returned ranges from 1 (Sunday) to 7 (Saturday), by default.

**General Syntax:**
=WEEKDAY(date,day_number)

**Arguments:**
- date is the date value referenced by the formula for which you want to find the day of the week.
- day_number is a number that determines which integer is used to represent which day. If 1, or omitted, returns 1 to 7 value for Sunday to Saturday. If 2, returns 1 to 7 value for Monday through Sunday. If 3, uses 0 to 6 for Monday through Sunday.

### WEEKNUM:

**Description:**
Using the WEEKNUM function returns a number that indicates in which week of the year the date specified in the formula falls.

**General Syntax:**
=WEEKNUM(date,week_number)

**Arguments:**
- date is the date value referenced by the formula.
- week_number is a number that determines on which day the week begins. If 1, or omitted, the week begins on a Sunday. If 2, the week begins on a Monday.

### WORKDAY:

**Description:**
Using the WORKDAY function returns a date value that is the number of working days before or after the date specified in the formula.

**General Syntax:**
=WORKDAY(date,days,holidays)

**Arguments:**
- date is the date value specified by the formula.
- days is the number of non-weekend and non-holiday days before or after the date specified. Can be either positive or negative.
- holidays is an optional cell range reference to a range of cells that contain a listing of any date values to be excluded.
Glossary of Functions

WORKDAY.INTL:

Description: Using the WORKDAY.INTL function returns the serial number of the date before or after a specified number of workdays with custom weekend parameters. Weekend parameters indicate which and how many days are weekend days. Weekend days and any days that are specified as holidays are not considered as workdays.

General Syntax: 

=WORKDAY(start_date, days, weekend, holidays)

Arguments:
- start_date is the start date truncated to an integer.
- days is the number of workdays before or after the start_date. A positive value yields a future date; a negative value yields a past date; a zero value yields the start_date. Days is truncated to an integer.
- weekend is an optional integer that indicates the days of the week that are weekend days and are not included in the number of whole working days between start_date and end_date. Weekend is a weekend number that specifies when weekends occur:
  1 or omitted = Saturday, Sunday
  2 = Sunday, Monday
  3 = Monday, Tuesday
  4 = Tuesday, Wednesday
  5 = Wednesday, Thursday
  6 = Thursday, Friday
  7 = Friday, Saturday
  11 = Sunday only
  12 = Monday only
  13 = Tuesday only
  14 = Wednesday only
  15 = Thursday only
  16 = Friday only
  17 = Saturday only
- holidays is an optional cell range reference to a range of cells that contain a listing of any date values to be excluded.

YEAR:

Description: Using the YEAR function returns the “year” number of a specified date value.

General Syntax: 

=YEAR(date)

Arguments:
- date is the date value referenced by the formula, which contains the year you want to find.

YEARFRAC:

Description: Using the YEARFRAC function returns the fraction of the year represented by the number of whole days between the first and last dates specified in the formula.

General Syntax: 

=YEARFRAC(start_date,end_date,basis)

Arguments:
- start_date is the first date in the date range.
- end_date is the last date in the date range.
- basis is an optional numeric argument (from 0 to 4) that represents the day count to use. If 0, or omitted, it uses the “US 30/360” day count. If 1, uses “Actual/actual.” If 2, uses “Actual/360.” If 3, uses “Actual/365.” If 4, uses “European 30/360.”
Glossary of Functions

**BESSELI:**

*Description:* Using the BESSELI function returns the modified Bessel function: the Bessel function evaluated for purely imaginary arguments.

*General Syntax:* =BESSELI(x,n)

*Arguments:*
- x is the value at which you want to evaluate the formula.
- n is the order of the Bessel function as an integer.

*Function:* The \( n \)th order modified Bessel function of the variable \( x \) is:

\[
I_n(x) = (i)^{-n} J_n(ix)
\]

**BESSELJ:**

*Description:* Using the BESSELJ function returns the Bessel function.

*General Syntax:* =BESSELJ(x,n)

*Arguments:*
- x is the value at which you want to evaluate the formula.
- n is the order of the Bessel function as an integer.

*Function:* The \( n \)th order Bessel function of the variable \( x \) is:

\[
J_n(x) = \sum_{k=0}^{\infty} \frac{(-1)^k}{k! \Gamma(n+k+1)} \left( \frac{x}{2} \right)^{n+2k}
\]

where the Gamma function is:

\[
\Gamma(n+k+1) = \int_0^\infty e^{-x} x^{n+k} \, dx
\]

**BESSELK:**

*Description:* Using the BESSELK function returns the modified Bessel function: the Bessel function evaluated for purely imaginary arguments.

*General Syntax:* =BESSELK(x,n)

*Arguments:*
- x is the value at which you want to evaluate the formula.
- n is the order of the Bessel function as an integer.

*Function:* The \( n \)th order modified Bessel function of the variable \( x \) is:

\[
K_n(x) = \frac{\pi}{2} \left( J_n(ix) + i Y_n(ix) \right)
\]

where \( J_n \) is the \( J \) Bessel function and \( Y_n \) is the \( Y \) Bessel function.

**BESSELY:**

*Description:* Using the BESSELY function returns the Bessel function. The Bessel function is also known as the “Weber function” or the “Neumann function.”

*General Syntax:* =BESSELY(x,n)

*Arguments:*
- x is the value at which you want to evaluate the formula.
- n is the order of the Bessel function as an integer.

*Function:* The \( n \)th order Bessel function of the variable \( x \) is:

\[
Y_n(x) = \lim_{\nu \to n} \frac{J_\nu(x) \cos(\nu \pi) - J_{-\nu}(x)}{\sin(\nu \pi)}
\]

where:

\[
ERF(z) = \frac{2}{\sqrt{\pi}} \int_0^z e^{-t^2} \, dt
\]
**BIN2DEC:**

*Description:* Using the BIN2DEC function converts a binary number to a decimal number.

*General Syntax:*  
  =BIN2DEC(number)

*Arguments:*  
  number is the binary number that you want to convert to a decimal number.

**BIN2HEX:**

*Description:* Using the BIN2HEX function converts a binary number to a hexadecimal number.

*General Syntax:*  
  =BIN2HEX(number,places)

*Arguments:*  
  number is the binary number that you want to convert to a hexadecimal number.  
  places is an optional argument that determines the number of characters to use. If omitted, uses the minimum number of characters necessary. Useful for padding the result with leading zeros.

**BIN2OCT:**

*Description:* Using the BIN2OCT function converts a binary number to an octal number.

*General Syntax:*  
  =BIN2OCT(number,places)

*Arguments:*  
  number is the binary number that you want to convert to an octal number.  
  places is an optional argument that determines the number of characters to use. If omitted, uses the minimum number of characters necessary. Useful for padding the result with leading zeros.

**BITAND:**

*Description:* Returns a bitwise ‘AND’ of two numbers.

*General Syntax:*  
  =BITAND(number1,number2)

*Arguments:*  
  number1 is a number that must be in decimal form and greater than or equal to 0.  
  number2 is a number that must be in decimal form and greater than or equal to 0.

**BITLSHIFT:**

*Description:* Returns a number shifted left by the specified number of bits.

*General Syntax:*  
  =BITLSHIFT(number,shift_amount)

*Arguments:*  
  number is a number that must an integer that is greater than or equal to 0.  
  shift_amount is a number that must be an integer.

**BITOR:**

*Description:* Returns a bitwise ‘OR’ of two numbers.

*General Syntax:*  
  =BITOR(number1,number2)

*Arguments:*  
  number1 is a number that must be in decimal form and greater than or equal to 0.  
  number2 is a number that must be in decimal form and greater than or equal to 0.
Glossary of Functions

BITRSHIFT:
Description: Returns a number shifted right by the specified number of bits.
General Syntax: =BITRSHIFT(number,shift_amount)
Arguments: number is a number that must an integer that is greater than or equal to 0. shift_amount is a number that must be an integer.

BITXOR:
Description: Returns a bitwise ‘XOR’ (exclusive or) of two numbers.
General Syntax: =BITXOR(number1,number2)
Arguments: number1 is a number that must be greater than or equal to 0. number2 is a number that must be greater than or equal to 0.

COMPLEX:
Description: Using the COMPLEX function returns a complex number of the form x + yi or x + yj for a specified real and imaginary coefficient.
General Syntax: =COMPLEX(real_num,i_num,suffix)
Arguments: real_num is the real coefficient of the complex number. i_num is the imaginary coefficient of the complex number. suffix is the suffix for the imaginary component of the complex number. If omitted, is assumed to be “i.” You may use either “i” or “j” as the suffix, but not “I” and “J.” All functions that accept two or more complex numbers require that all suffixes match.

CONVERT:
Description: Using the CONVERT function converts a number from one system of measurement to another system of measurement.
General Syntax: =CONVERT(number,from,to)
Arguments: number is the number of units from to convert. from is the measurement unit of which you have number amount. to is the measurement unit to which you wish to convert the number.
Specific Syntax: The following is a list of measurement system units that can be used as the from and to argument values. These must be entered in double-quotes in the function:

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Unit</th>
<th>Measurement</th>
<th>Unit</th>
<th>Measurement:</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Weight and Mass:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Gram</td>
<td>“g”</td>
<td>Slug</td>
<td>“slg”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>U (atomic mass)</td>
<td>“u”</td>
<td>Ounce Mass</td>
<td>“ozm”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>U.S. (short)</td>
<td>“cwt” or “shweight”</td>
<td>Stone</td>
<td>“stone”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Imperial hundredweight</td>
<td>“uk_cwt” or “lcwt”</td>
<td>Tonn</td>
<td>“ton”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Imperial ton</td>
<td>“uk_ton” or “LTON”</td>
<td>Tonn</td>
<td>“ton”</td>
</tr>
<tr>
<td>Distance:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Meter</td>
<td>“m”</td>
<td>Statute Mile</td>
<td>“mi”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Inch</td>
<td>“in”</td>
<td>Foot</td>
<td>“ft”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Angstrom</td>
<td>“ang”</td>
<td>Ell</td>
<td>“ell”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Parsec</td>
<td>“parsec” or “pc”</td>
<td>Pica (1/72 in.)</td>
<td>“Pica”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>(1/in.) “pica”</td>
<td></td>
<td>Pica</td>
<td></td>
</tr>
<tr>
<td>Time:</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Year</td>
<td>“yr”</td>
<td>Day</td>
<td>“day”</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Minute</td>
<td>“mn”</td>
<td>Second</td>
<td>“sec”</td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Glossary of Functions

CONVERT (cont.):

Specific Syntax (cont.): The following is a list of measurement system units that can be used as the from and to argument values. These must be entered in double-quotes in the function:

<table>
<thead>
<tr>
<th>Measurement</th>
<th>Unit</th>
<th>Measurement</th>
<th>Unit</th>
<th>Measurement</th>
<th>Unit</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pressure</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Pascal</td>
<td>“Pa”</td>
<td>Atmosphere</td>
<td>“atm”</td>
<td>mm of Mercury</td>
<td>“mmHg”</td>
</tr>
<tr>
<td>PSI</td>
<td>“psi”</td>
<td>Torr</td>
<td>“torr”</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Force</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Newton</td>
<td>“N”</td>
<td>Dyne</td>
<td>“dyn”</td>
<td>Pound force</td>
<td>“lb”</td>
</tr>
<tr>
<td>Pond</td>
<td>“pond”</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Energy</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Joule</td>
<td>“J”</td>
<td>Erg</td>
<td>“e”</td>
<td>Thermodynamic Calorie</td>
<td>“C”</td>
</tr>
<tr>
<td>IT Calorie</td>
<td>“cal”</td>
<td>Electron volt</td>
<td>“eV”</td>
<td>Horsepower-hour</td>
<td>“HP”</td>
</tr>
<tr>
<td>Watt-hour</td>
<td>“Wh”</td>
<td>Foot-pound</td>
<td>“flb”</td>
<td>BTU</td>
<td>“BTU”</td>
</tr>
<tr>
<td>Power</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Horsepower</td>
<td>“HP”</td>
<td>Pferdestarke</td>
<td>“PS”</td>
<td>Watt</td>
<td>“W”</td>
</tr>
<tr>
<td>Magnetism</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Tesla</td>
<td>“T”</td>
<td>Gauss</td>
<td>“ga”</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Temperature</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Degree Celsius</td>
<td>“C”</td>
<td>Degree Fahrenheit</td>
<td>“F”</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Degrees Rankine</td>
<td>“Rank”</td>
<td></td>
<td>“Reau”</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Liquid Measure</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Teaspoon</td>
<td>“tsp”</td>
<td>Modern teaspoon</td>
<td>“tspm”</td>
<td>Tablespoon</td>
<td>“tbs”</td>
</tr>
<tr>
<td>Fluid ounce</td>
<td>“oz”</td>
<td>Cup</td>
<td>“cup”</td>
<td>U.S. Pint</td>
<td>“pt”</td>
</tr>
<tr>
<td>U.K. Pint</td>
<td>“uk_pt”</td>
<td></td>
<td>“qt”</td>
<td>Imperial Quart</td>
<td>“uk_qt”</td>
</tr>
<tr>
<td>Gallon</td>
<td>“gal”</td>
<td>Imperial Gallon</td>
<td>“uk_gal”</td>
<td>Liter</td>
<td>“l”</td>
</tr>
<tr>
<td>Cubic angstrom</td>
<td>“ang3”</td>
<td></td>
<td></td>
<td>U.S. oil barrel</td>
<td>“barrel”</td>
</tr>
<tr>
<td>Cubic feet</td>
<td>“ft3”</td>
<td>Cubic inch</td>
<td>“in3”</td>
<td>Cubic light-year</td>
<td>“ly3”</td>
</tr>
<tr>
<td>Cubic meter</td>
<td>“m3”</td>
<td>Cubic mile</td>
<td>“mi3”</td>
<td>Cubic yard</td>
<td>“yd3”</td>
</tr>
<tr>
<td>Cubic Nautical mile</td>
<td>“Nm3”</td>
<td>Cubic pica</td>
<td>“Picapt3”</td>
<td>or “Pica3”</td>
<td></td>
</tr>
<tr>
<td>Gross Registered Ton</td>
<td></td>
<td></td>
<td>“GRT”</td>
<td>Measurement Ton</td>
<td>“MTON”</td>
</tr>
<tr>
<td>Area</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>International acre</td>
<td>“uk_acre”</td>
<td></td>
<td></td>
<td>Square angstrom</td>
<td>“ang2”</td>
</tr>
<tr>
<td>Are</td>
<td>“ar”</td>
<td>Square Feet</td>
<td>“ft2”</td>
<td>Hectare</td>
<td>“ha”</td>
</tr>
<tr>
<td>Square inches</td>
<td>“in2”</td>
<td>Square light-years</td>
<td>“ly2”</td>
<td>Square meters</td>
<td>“m2”</td>
</tr>
<tr>
<td>Morgen</td>
<td>“Morgen”</td>
<td></td>
<td></td>
<td>Square Nautical miles</td>
<td>“Nmi2”</td>
</tr>
<tr>
<td>Square Pica</td>
<td>“Picapt2”</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Square Yards</td>
<td>“yd2”</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Information</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Bit</td>
<td>“bit”</td>
<td>Byte</td>
<td>“byte”</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Speed</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Admiredty knot</td>
<td>“admkn”</td>
<td></td>
<td></td>
<td>Meters per hour</td>
<td>“m/h”</td>
</tr>
<tr>
<td>Meters per second</td>
<td>“m/s”</td>
<td>Miles per hour</td>
<td>“mph”</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Prefixes:
The following abbreviated unit prefixes can be added before any metric unit used:

<table>
<thead>
<tr>
<th>Prefix</th>
<th>Abbreviation</th>
<th>Prefix</th>
<th>Abbreviation</th>
<th>Prefix</th>
<th>Abbreviation</th>
<th>Prefix</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>“Y”</td>
<td></td>
<td>“Z”</td>
<td></td>
<td>“exa”</td>
<td>“E”</td>
</tr>
<tr>
<td></td>
<td>“P”</td>
<td></td>
<td>“T”</td>
<td></td>
<td>“giga”</td>
<td>“G”</td>
</tr>
<tr>
<td></td>
<td>“M”</td>
<td></td>
<td>“k”</td>
<td></td>
<td>“hecto”</td>
<td>“h”</td>
</tr>
<tr>
<td></td>
<td>“e”</td>
<td></td>
<td>“d”</td>
<td></td>
<td>“centi”</td>
<td>“c”</td>
</tr>
<tr>
<td></td>
<td>“m”</td>
<td></td>
<td>“u”</td>
<td></td>
<td>“nano”</td>
<td>“n”</td>
</tr>
<tr>
<td></td>
<td>“p”</td>
<td></td>
<td>“f”</td>
<td></td>
<td>“atto”</td>
<td>“a”</td>
</tr>
</tbody>
</table>

The following is a list of abbreviated binary prefixes:

<table>
<thead>
<tr>
<th>Prefix</th>
<th>Abbreviation</th>
<th>Prefix</th>
<th>Abbreviation</th>
<th>Prefix</th>
<th>Abbreviation</th>
<th>Prefix</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>“Yi”</td>
<td></td>
<td>“Zi”</td>
<td></td>
<td>“exbi”</td>
<td>“E”</td>
</tr>
<tr>
<td></td>
<td>“Pi”</td>
<td></td>
<td>“Ti”</td>
<td></td>
<td>“gibi”</td>
<td>“Gi”</td>
</tr>
</tbody>
</table>
## Glossary of Functions

### DEC2BIN:
**Description:**
Using the DEC2BIN function converts a decimal number to a binary number.

**General Syntax:**
=DEC2BIN(number, places)

**Arguments:**
- `number` is the decimal number that you want to convert to a binary number.
- `places` is an optional argument that determines the number of characters to use. If omitted, uses the minimum number of characters necessary. Useful for padding the result with leading zeros.

### DEC2HEX:
**Description:**
Using the DEC2HEX function converts a decimal number to a hexadecimal number.

**General Syntax:**
=DEC2HEX(number, places)

**Arguments:**
- `number` is the decimal number that you want to convert to a hexadecimal number.
- `places` is an optional argument that determines the number of characters to use. If omitted, uses the minimum number of characters necessary. Useful for padding the result with leading zeros.

### DEC2OCT:
**Description:**
Using the DEC2OCT function converts a decimal number to an octal number.

**General Syntax:**
=DEC2OCT(number, places)

**Arguments:**
- `number` is the decimal number that you want to convert to an octal number.
- `places` is an optional argument that determines the number of characters to use. If omitted, uses the minimum number of characters necessary. Useful for padding the result with leading zeros.

### DELTA:
**Description:**
Using the DELTA function tests whether or not two number values are equal. The function returns a "1" if they are equal or a "0" if they are not equal.

**General Syntax:**
=DELTA(number1, number2)

**Arguments:**
- `number1` is the first number to compare.
- `number2` is the second number to compare. If omitted, is assumed to be zero.

### ERF:
**Description:**
Using the ERF function returns the error function integrated between the upper limit and lower limit specified.

**General Syntax:**
=ERF(lower, upper)

**Arguments:**
- `lower` is the lower limit for integrating ERF.
- `upper` is the upper limit for integrating ERF. If omitted, ERF integrates between zero and the lower limit.

**Function:**
\[
ERF(z) = \frac{2}{\sqrt{\pi}} \int_0^z e^{-t^2} dt
\]

\[
ERF(a, b) = \frac{2}{\sqrt{\pi}} \int_a^b e^{-t^2} dt = ERF(b) - ERF(a)
\]
**Glossary of Functions**

**ERF.PRECISE:**

*Description:* Using the ERF.PRECISE function returns the error function.

*General Syntax:*  
=ERF.PRECISE(x)

*Arguments:*  
x is the lower limit for integrating ERF.PRECISE.

**ERFC:**

*Description:* Using the ERFC function returns the complimentary ERF function integrated between the lower bound specified and infinity.

*General Syntax:*  
=ERFC(lower)

*Arguments:*  
lower is the lower bound for integrating ERF.

*Function:*  
\[ \text{ERFC}(x) = \frac{2}{\sqrt{\pi}} \int_x^\infty e^{-t^2} dt = 1 - \text{ERF}(x) \]

**ERFC.PRECISE:**

*Description:* Using the ERFC.PRECISE function returns the complementary ERF function integrated between \( x \) and infinity.

*General Syntax:*  
=ERFC.PRECISE(x)

*Arguments:*  
x is the lower limit for integrating ERFC.PRECISE.

**GESTEP:**

*Description:* Using the GESTEP function returns a “1” if the number used is greater than the step, otherwise returns a zero.

*General Syntax:*  
=GESTEP(number, step)

*Arguments:*  
number is the number that you want to test against the step.  
step is the threshold value. If omitted, uses “0.”

**HEX2BIN:**

*Description:* Using the HEX2BIN function converts a hexadecimal number to a binary number.

*General Syntax:*  
=HEX2BIN(number, places)

*Arguments:*  
number is the hexadecimal number that you want to convert to binary.  
places is an optional argument that determines the number of characters to use. If omitted, uses the minimum number of characters necessary. Useful for padding the result with leading zeros.
Glossary of Functions

**HEX2DEC:**
**Description:** Using the HEX2DEC function converts a hexadecimal number to a decimal number.
**General Syntax:** =HEX2DEC(number)
**Arguments:** number is the hexadecimal number that you want to convert to a decimal number.

**HEX2OCT:**
**Description:** Using the HEX2OCT function converts a hexadecimal number to an octal number.
**General Syntax:** =HEX2OCT(number,places)
**Arguments:** number is the hexadecimal number that you want to convert to an octal number. places is an optional argument that determines the number of characters to use. If omitted, uses the minimum number of characters necessary. Useful for padding the result with leading zeros.

**IMABS:**
**Description:** Using the IMABS function returns the absolute value, or “modulus,” of a complex number in the x + yi or x + yj format.
**General Syntax:** =IMABS(inumber)
**Arguments:** inumber is the complex number for which you want the absolute value returned.
**Formula:** The absolute value of a complex number is represented by the function:
$$\text{IMABS}(z) = |z| = \sqrt{x^2 + y^2}$$
where $z = x + yi$.

**IMAGINARY:**
**Description:** Using the IMAGINARY function returns the imaginary coefficient of a complex number in either the x + yi or x + yj format.
**General Syntax:** =IMAGINARY(inumber)
**Arguments:** inumber is the complex number for which you want the imaginary coefficient.

**IMARGUMENT:**
**Description:** Using the IMARGUMENT function returns the theta argument ($\theta$), an angle expressed in radians, such that:
$$x + yi = |x + yi|e^{i\theta} = |x + yi|(\cos\theta + i\sin\theta)$$
**General Syntax:** =IMARGUMENT(inumber)
**Arguments:** inumber is the complex number for which you want the argument theta ($\theta$).
**Function:**
$$\text{IMARGUMENT}(z) = \tan^{-1}\left(\frac{y}{x}\right) = \theta \text{ where } \theta \in [-\pi; \pi] \text{ and } z=x+yi.$$

©TeachUcomp, Inc.  Advanced Excel 113
## Glossary of Functions

### IMCONJUGATE:

**Description:**
Using the IMCONJUGATE function returns complex conjugate of a complex number in the $x + yi$ or $x + yj$ format, entered as a text value.

**General Syntax:**
=IMCONJUGATE(inumber)

**Arguments:**
inumber is the complex number for which you want the conjugate.

**Formula:**
The conjugate of a complex number is: $\overline{\text{IMCONJUGATE}(x + yi)} = \overline{z} = (x - yi)$

### IMCOS:

**Description:**
Using the IMCOS function returns the cosine of a complex number in the $x + yi$ or $x + yj$ format, entered as a text value.

**General Syntax:**
=IMCOS(inumber)

**Arguments:**
inumber is the complex number for which you want the cosine.

**Formula:**
The cosine of a complex number is: $\cos(x + yi) = \cos(x) \cosh(y) - \sin(x) \sinh(y)i$

### IMCOSH:

**Description:**
Using the IMCOSH function returns the hyperbolic cosine of a complex number in the $x + yi$ or $x + yj$ format, entered as a text value.

**General Syntax:**
=IMCOSH(inumber)

**Arguments:**
inumber is the complex number for which you want the hyperbolic cosine.

### IMCOT:

**Description:**
Using the IMCOT function returns the cotangent of a complex number in the $x + yi$ or $x + yj$ format, entered as a text value.

**General Syntax:**
=IMCOT(inumber)

**Arguments:**
inumber is the complex number for which you want the cotangent.

### IMCSC:

**Description:**
Using the IMCSC function returns the cosecant of a complex number in the $x + yi$ or $x + yj$ format, entered as a text value.

**General Syntax:**
=IMCSC(inumber)

**Arguments:**
inumber is the complex number for which you want the cosecant.

### IMCSCH:

**Description:**
Using the IMCSCH function returns the hyperbolic cosecant of a complex number in the $x + yi$ or $x + yj$ format, entered as a text value.

**General Syntax:**
=IMCSCH(inumber)

**Arguments:**
inumber is the complex number for which you want the hyperbolic cosecant.
**Glossary of Functions**

**IMDIV:**

**Description:** Using the IMDIV function returns the quotient of two complex numbers in the \( x + yi \) or \( x + yj \) format, entered as a text value.

**General Syntax:**

\[ =\text{IMDIV}(\text{inumber1},\text{inumber2}) \]

**Arguments:**

- \( \text{inumber1} \) is the complex number that is the numerator, or dividend.
- \( \text{inumber2} \) is the complex number that is the denominator, or divisor.

**Formula:**

The quotient of two complex numbers is:

\[ \text{IMDIV}(z_1, z_2) = \frac{(a + bi)}{(c + di)} = \frac{(ac + bd) - (bc - ad)i}{c^2 + d^2} \]

**IMEXP:**

**Description:** Using the IMEXP function returns the exponential of a complex number in the \( x + yi \) or \( x + yj \) format, entered as a text value.

**General Syntax:**

\[ =\text{IMEXP}(\text{inumber}) \]

**Arguments:**

- \( \text{inumber} \) is the complex number for which you want the exponential.

**Function:**

The exponential of a complex number is:

\[ \text{IMEXP}(z) = e^{x+yi} = e^x e^{yi} = e^x (\cos y + i \sin y) \]

**IMLN:**

**Description:** Using the IMLN function returns the natural logarithm of a complex number in the \( x + yi \) or \( x + yj \) format, entered as a text value.

**General Syntax:**

\[ =\text{IMLN}(\text{inumber}) \]

**Arguments:**

- \( \text{inumber} \) is the complex number for which you want the natural logarithm.

**Function:**

The natural logarithm of a complex number is:

\[ \ln(x + yi) = \ln(\sqrt{x^2 + y^2}) + i \tan^{-1}\left(\frac{y}{x}\right) \]

where \( \theta \in [-\pi; \pi] \)

**IMLOG10:**

**Description:** Using the IMLOG10 function returns the common logarithm of a complex number in the \( x + yi \) or \( x + yj \) format, entered as a text value.

**General Syntax:**

\[ =\text{IMLOG10}(\text{inumber}) \]

**Arguments:**

- \( \text{inumber} \) is the complex number for which you want the common logarithm.

**Function:**

The common logarithm of a complex number can be calculated from the natural logarithm as shown:

\[ \log_{10}(x + yi) = (\log_{10} e) \ln(x + yi) \]
### Glossary of Functions

#### IMLOG2:

**Description:** Using the IMLOG2 function returns the base-2 logarithm of a complex number in the \( x + yi \) or \( x + yj \) format, entered as a text value.

**General Syntax:**

\[ = \text{IMLOG2}(\text{inumber}) \]

**Arguments:**

- **inumber** is the complex number for which you want the base-2 logarithm.

**Function:**

The base-2 logarithm of a complex number can be calculated from the natural logarithm as shown:

\[ \log_2(x + yi) = (\log_2 e) \ln(x + yi) \]

#### IMPOW:

**Description:** Using the IMPOW function returns a complex number in the \( x + yi \) or \( x + yj \) format raised to a specified power and displayed as a text value.

**General Syntax:**

\[ = \text{IMPOW}(\text{inumber}, \text{number}) \]

**Arguments:**

- **inumber** is the complex number that you want to raise to a power.
- **number** is the power to which you want to raise the complex number.

**Function:**

A complex number raised to a power can be calculated as shown:

\[ (x + yi)^n = r^n e^{i\theta} = r^n \cos \theta + ir^n \sin \theta \]

where: \( r = \sqrt{x^2 + y^2} \)

and: \( \theta = \tan^{-1} \left( \frac{y}{x} \right) \)

and: \( \theta \in [-\pi, \pi] \)

#### IMPROD:

**Description:** Using the IMPROD function returns the product of 2 to 29 complex numbers in the \( x + yi \) or \( x + yj \) format, entered as text values.

**General Syntax:**

\[ = \text{IMPROD}(\text{inumbers}) \]

**Arguments:**

- **inumbers** is the set of 2 to 29 complex numbers, separated by commas, for which you want the product.

**Formula:**

The product of \( (a + bi)(c + di) = (ac - bd) + (ad + bc)i \)

#### IMREAL:

**Description:** Using the IMREAL function returns the real coefficient of a complex number in the \( x + yi \) or \( x + yj \) format, displayed as a text value.

**General Syntax:**

\[ = \text{IMREAL}(\text{inumber}) \]

**Arguments:**

- **inumber** is the complex number for which you want the real coefficient.

#### IMSEC:

**Description:** Using the IMSEC function returns the secant of a complex number in the \( x + yi \) or \( x + yj \) format, entered as a text value.

**General Syntax:**

\[ = \text{IMSEC}(\text{inumber}) \]

**Arguments:**

- **inumber** is the complex number for which you want the secant.
<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>General Syntax</th>
<th>Arguments</th>
<th>Formula</th>
</tr>
</thead>
<tbody>
<tr>
<td>IMSECH</td>
<td>Using the IMSECH function returns the hyperbolic secant of a complex number in the x + yi or x + yj format, entered as a text value.</td>
<td>=IMSECH(inumber)</td>
<td>inumber</td>
<td>The difference of two complex numbers is: ((a + bi) - (c + di) = (a - c) + (b - d)i)</td>
</tr>
<tr>
<td>IMSIN</td>
<td>Using the IMSIN function returns the sine of a complex number in the x + yi or x + yj format, entered as a text value.</td>
<td>=IMSIN(inumber)</td>
<td>inumber</td>
<td>The sine of a complex number is: (\sin(x + yi) = \sin(x) \cosh(y) - \cos(x) \sinh(y)i)</td>
</tr>
<tr>
<td>IMSINH</td>
<td>Using the IMSINH function returns the hyperbolic sine of a complex number in the x + yi or x + yj format, entered as a text value.</td>
<td>=IMSINH(inumber)</td>
<td>inumber</td>
<td>The square root of a complex number is: (\sqrt{x + yi} = \sqrt{r} \cos\left(\frac{\theta}{2}\right) + i \sqrt{r} \sin\left(\frac{\theta}{2}\right)) where: (r = \sqrt{x^2 + y^2}) and: (\theta = \tan^{-1}\left(\frac{y}{x}\right)) and: (\theta \in [-\pi; \pi])</td>
</tr>
<tr>
<td>IMSQRT</td>
<td>Using the IMSQRT function returns the square root of a complex number in the x + yi or x + yj format, entered as a text value.</td>
<td>=IMSQRT(inumber)</td>
<td>inumber</td>
<td>The difference of two complex numbers is: ((a + bi) - (c + di) = (a - c) + (b - d)i)</td>
</tr>
<tr>
<td>IMSUB</td>
<td>Using the IMSUB function returns the difference of two complex numbers in the x + yi or x + yj format, entered as a text value.</td>
<td>=IMSUB(inumber1,inumber2)</td>
<td>inumber1, inumber2</td>
<td>The difference of two complex numbers is: ((a + bi) - (c + di) = (a - c) + (b - d)i)</td>
</tr>
</tbody>
</table>
### Glossary of Functions

**IMSUM:**
- **Description:** Using the IMSUM function returns the sum of 2 to 29 complex numbers in the \( x + yi \) or \( x + yj \) format, entered as text values.
- **General Syntax:** `=IMSUM(inumbers)`
- **Arguments:** `inumbers` are the complex numbers for which you want the sum, separated by commas.
- **Formula:** The sum of two complex numbers is: \((a + bi) + (c + di) = (a + c) + (b + d)i\)

**IMTAN:**
- **Description:** Using the IMTAN function returns the tangent of a complex number in the \( x + yi \) or \( x + yj \) format, entered as text values.
- **General Syntax:** `=IMTAN(inumber)`
- **Arguments:** `inumber` is the complex number for which you want the tangent.

**OCT2BIN:**
- **Description:** Using the OCT2BIN function converts an octal number to a binary number.
- **General Syntax:** `=OCT2BIN(number,places)`
- **Arguments:** `number` is the octal number that you want to convert to a binary number. `places` is an optional argument that determines the number of characters to use. If omitted, uses the minimum number of characters necessary. Useful for padding the result with leading zeros.

**OCT2DEC:**
- **Description:** Using the OCT2DEC function converts an octal number to a decimal.
- **General Syntax:** `=OCT2DEC(number)`
- **Arguments:** `number` is the octal number that you want to convert to a decimal number.

**OCT2HEX:**
- **Description:** Using the OCT2HEX function converts an octal number to a hexadecimal number.
- **General Syntax:** `=OCT2HEX(number,places)`
- **Arguments:** `number` is the octal number that you want to convert to a hexadecimal number. `places` is an optional argument that determines the number of characters to use. If omitted, uses the minimum number of characters necessary. Useful for padding the result with leading zeros.
Glossary of Functions

ACCRINT:

Description:
Using the ACCRINT function returns the accrued interest on a security that pays periodic interest.

General Syntax:
=ACCRINT(issue, first_interest, settlement, rate, par, frequency, basis, calc_method)

Arguments:
issue is the date of the security’s issue.
first_interest is the security’s first interest date.
settlement is the security’s settlement date. This is the date after the issue date when the security is traded to the buyer.
rate is the security’s annual coupon rate.
par is the security’s par value. Excel assumes it is $1,000, if omitted.
frequency is the number of coupon payments per year. For annual payments, input 1. For semiannual payments, input 2. For quarterly payments, input 4.
basis is the optional integer that represents which type of day count basis to use.

calc_method is an optional logical value (1 = TRUE, 0= FALSE) that specifies the way to calculate the total accrued interest when the date of settlement is later than the date of first_interest. A value of TRUE (1) returns the total accrued interest from issue to settlement. A value of FALSE (0) returns the accrued interest from first_interest to settlement. If you do not enter the argument, it defaults to TRUE.

Formula:
The function is calculated as: 

where:

A is the number of accrued days counted according to a monthly basis. For interest at maturity items, the number of days from the issue date to the maturity date is used.

D is the Annual Year Basis.

ACCRINTM:

Description:
Using the ACCRINTM function returns the accrued interest on a security that pays interest at maturity.

General Syntax:
=ACCRINTM(issue, maturity, rate, par, basis)

Arguments:
issue is the date of the security’s issue.
maturity is the security’s maturity date.
rate is the security’s annual coupon rate.
par is the security’s par value. Excel assumes it is $1,000, if omitted.
basis is the optional integer that represents which type of day count basis to use.

Integer: Day Count Basis:
0 or omitted US (NASD) 30/360
1 Actual/Actual
2 Actual/360
3 Actual/365
4 European 30/360

Formula:
The function is calculated as: 

where:

A is the number of accrued days counted according to a monthly basis. For interest at maturity items, the number of days from the issue date to the maturity date is used.

D is the Annual Year Basis.
AMORDEGRC:

Description:
Using the AMORDEGRC function returns the depreciation for each accounting period. Used in the French accounting system. If an asset is purchased in the middle of the accounting period, the prorated depreciation is taken into account. The function is similar to AMORLINC, except that a depreciation coefficient is applied in the calculation depending on the life of the asset. If the life of the asset (1/rate) is between 3 and 4 years, the coefficient used is 1.5. If it is between 5 and 6 years, it uses 2. If it is more than 6 years, the coefficient used is 2.5.

General Syntax:
=AMORDEGRC(cost,purchase_date,first_period,salvage,period,rate,basis)

Arguments:
cost is the cost of the asset.
purchase_date is the date of the purchase of the asset.
first_period is the date of the end of the first period.
salvage is the salvage value at the end of the life of the asset.
period is the period.
rate is the rate of depreciation.
basis is an integer that represents which year basis to use.

Integer: Date System:
0 or omitted 360 (NASD)
1 Actual
3 365 days in a year
4 360 days in a year (European method)

AMORLINC:

Description:
Using the AMORLINC function returns the depreciation for each accounting period. This function is provided for the French accounting system. If an asset is purchased in the middle of the accounting period, the prorated depreciation is taken into account.

General Syntax:
=AMORLINC(cost,purchase_date,first_period,salvage,period,rate,basis)

Arguments:
cost is the cost of the asset.
purchase_date is the date of the purchase of the asset.
first_period is the date of the end of the first period.
salvage is the salvage value at the end of the life of the asset.
period is the period.
rate is the rate of depreciation.
basis is an integer that represents which year basis to use.

Integer: Date System:
0 or omitted 360 (NASD)
1 Actual
3 365 days in a year
4 360 days in a year (European method)
COUPDAYBS:

**Description:**
Using the COUPDAYBS function returns the number of days from the beginning of the coupon period to the settlement date.

**General Syntax:**
=COUPDAYBS(settlement,maturity,frequency, basis)

**Arguments:**
- `settlement` is the security’s settlement date.
- `maturity` is the security’s maturity date: the date the security expires.
- `frequency` is the number of coupon payments per year. For annual payments, input 1. For semiannual payments, input 2. For quarterly payments, input 4.
- `basis` is the integer that represents which type of day count basis to use.

<table>
<thead>
<tr>
<th>Integer</th>
<th>Day Count Basis:</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 or omitted</td>
<td>US (NASD) 30/360</td>
</tr>
<tr>
<td>2</td>
<td>Actual/360</td>
</tr>
<tr>
<td>4</td>
<td>European 30/360</td>
</tr>
</tbody>
</table>

COUPDAYS:

**Description:**
Using the COUPDAYS function returns the number of days in the coupon period that contains the settlement date.

**General Syntax:**
=COUPDAYS(settlement,maturity,frequency, basis)

**Arguments:**
- `settlement` is the security’s settlement date.
- `maturity` is the security’s maturity date: the date the security expires.
- `frequency` is the number of coupon payments per year. For annual payments, input 1. For semiannual payments, input 2. For quarterly payments, input 4.
- `basis` is the integer that represents which type of day count basis to use.

<table>
<thead>
<tr>
<th>Integer</th>
<th>Day Count Basis:</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 or omitted</td>
<td>US (NASD) 30/360</td>
</tr>
<tr>
<td>1</td>
<td>Actual/Actual</td>
</tr>
<tr>
<td>2</td>
<td>Actual/360</td>
</tr>
<tr>
<td>3</td>
<td>Actual/365</td>
</tr>
<tr>
<td>4</td>
<td>European 30/360</td>
</tr>
</tbody>
</table>

COUPDAYSNC:

**Description:**
Using the COUPDAYSNC function returns the number of days from the settlement date to the next coupon date.

**General Syntax:**
=COUPDAYSNC(settlement,maturity,frequency, basis)

**Arguments:**
- `settlement` is the security’s settlement date.
- `maturity` is the security’s maturity date: the date the security expires.
- `frequency` is the number of coupon payments per year. For annual payments, input 1. For semiannual payments, input 2. For quarterly payments, input 4.
- `basis` is the integer that represents which type of day count basis to use.

<table>
<thead>
<tr>
<th>Integer</th>
<th>Day Count Basis:</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 or omitted</td>
<td>US (NASD) 30/360</td>
</tr>
<tr>
<td>1</td>
<td>Actual/Actual</td>
</tr>
<tr>
<td>2</td>
<td>Actual/360</td>
</tr>
<tr>
<td>3</td>
<td>Actual/365</td>
</tr>
<tr>
<td>4</td>
<td>European 30/360</td>
</tr>
</tbody>
</table>
Glossary of Functions

COUPNCD:

Description: Using the COUPNCD function returns a number that represents the next coupon date after the settlement date. Make sure that the cell into which you enter this formula is formatted as a date cell to view the resulting number as a date value.

General Syntax: \[=\text{COUPNCD(settlement,maturity,frequency,\_basis)}\]

Arguments:
- settlement is the security's settlement date.
- maturity is the security's maturity date: the date the security expires.
- frequency is the number of coupon payments per year. For annual payments, input 1. For semiannual payments, input 2. For quarterly payments, input 4.
- _basis_ is the integer that represents which type of day count basis to use.

<table>
<thead>
<tr>
<th>Integer</th>
<th>Day Count Basis</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 or omitted</td>
<td>US (NASDAQ) 30/360</td>
</tr>
<tr>
<td>1</td>
<td>Actual/Actual</td>
</tr>
<tr>
<td>2</td>
<td>Actual/360</td>
</tr>
<tr>
<td>3</td>
<td>Actual/365</td>
</tr>
<tr>
<td>4</td>
<td>European 30/360</td>
</tr>
</tbody>
</table>

COUPNUM:

Description: Using the COUPNUM function returns the number of coupons payable between the settlement date and maturity date, rounded up to the nearest whole coupon.

General Syntax: \[=\text{COUPNUM(settlement,maturity,frequency,\_basis)}\]

Arguments:
- settlement is the security's settlement date.
- maturity is the security's maturity date: the date the security expires.
- frequency is the number of coupon payments per year. For annual payments, input 1. For semiannual payments, input 2. For quarterly payments, input 4.
- _basis_ is the integer that represents which type of day count basis to use.

<table>
<thead>
<tr>
<th>Integer</th>
<th>Day Count Basis</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 or omitted</td>
<td>US (NASDAQ) 30/360</td>
</tr>
<tr>
<td>1</td>
<td>Actual/Actual</td>
</tr>
<tr>
<td>2</td>
<td>Actual/360</td>
</tr>
<tr>
<td>3</td>
<td>Actual/365</td>
</tr>
<tr>
<td>4</td>
<td>European 30/360</td>
</tr>
</tbody>
</table>

COUPPCD:

Description: Using the COUPPCD function returns a number that represents the previous coupon date before the settlement date. Make sure that the cell into which you enter this formula is formatted as a date cell to view the resulting number as a date value.

General Syntax: \[=\text{COUPPCD(settlement,maturity,frequency,\_basis)}\]

Arguments:
- settlement is the security's settlement date.
- maturity is the security's maturity date: the date the security expires.
- frequency is the number of coupon payments per year. For annual payments, input 1. For semiannual payments, input 2. For quarterly payments, input 4.
- _basis_ is the integer that represents which type of day count basis to use.

<table>
<thead>
<tr>
<th>Integer</th>
<th>Day Count Basis</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 or omitted</td>
<td>US (NASDAQ) 30/360</td>
</tr>
<tr>
<td>1</td>
<td>Actual/Actual</td>
</tr>
<tr>
<td>2</td>
<td>Actual/360</td>
</tr>
<tr>
<td>3</td>
<td>Actual/365</td>
</tr>
<tr>
<td>4</td>
<td>European 30/360</td>
</tr>
</tbody>
</table>
CUMIPMT:

Description:
Using the CUMIPMT function returns the cumulative interest paid on a loan between two periods specified.

General Syntax:
=CUMIPMT(rate,nper,pv,start_period,end_period,type)

Arguments:
- *rate* is the interest rate.
- *nper* is the total number of payment periods.
- *pv* is the present value.
- *start_period* is the first period in the calculation. Payment periods are numbered beginning with 1.
- *end_period* is the last period used in the calculation.
- *type* is the timing of the payment. If 0, the payment is at the end of the period. If 1, payment is at the beginning of the period.

CUMPRINC:

Description:
Using the CUMPRINC function returns the cumulative principal paid on a loan between *start_period* and *end_period*.

General Syntax:
=CUMPRINC(rate,nper,pv,start_period,end_period,type)

Arguments:
- *rate* is the interest rate.
- *nper* is the total number of payment periods.
- *pv* is the present value.
- *start_period* is the first period in the calculation. Payment periods are numbered beginning with 1.
- *end_period* is the last period used in the calculation.
- *type* is the timing of the payment. If 0, the payment is at the end of the period. If 1, payment is at the beginning of the period.

DB:

Description:
Using the DB function returns the depreciation of an asset for a specified period using the fixed-declining balance method.

General Syntax:
=DB(cost,salvage,life,period,month)

Arguments:
- *cost* is the initial cost of the asset.
- *salvage* is the value of the asset after depreciation.
- *life* is the number of periods over which the asset is depreciated.
- *period* is the period for which you want to calculate the amount of depreciation.
- *month* is the number of months in the first year. If omitted, is assumed to be 12.

Formula:
The formula used to calculate depreciation using the fixed-declining method is:

\[
= \frac{(cost - total\,depreciation\,from\,prior\,periods) \times rate}{(salvage/cost) \times (1/life)},\text{ rounded to 3 decimal places.}
\]

The calculation used is different for the first and last periods. When calculating the first period, DB uses the following calculation:

\[
(cost \times rate \times month/12).
\]

In the last period, DB uses the following calculation:

\[
((cost - total\,depreciation\,from\,prior\,periods) \times rate \times (12-month))/12.
\]

DDB:

Description:
Using the DDB function Returns the depreciation of an asset for a specified period using the double-declining balance method or some other method you specify. All arguments must be positive.

General Syntax:
=DB(cost,salvage,life,period,factor)

Arguments:
- *cost* is the initial cost of the asset.
- *salvage* is the value of the asset after depreciation.
- *life* is the number of periods over which the asset is depreciated.
- *period* is the period for which you want to calculate the amount of depreciation.
- *factor* is the rate at which the balance declines. If omitted, it is 2 (the double-declining balance method).
**Glossary of Functions**

**DISC:**

**Description:**
Using the DISC function returns the discount rate for a security.

**General Syntax:**
=DISC(settlement,maturity,pr,redemption,basis)

**Arguments:**
- **settlement** is the security’s settlement date: the date after issue when the security is traded to the buyer.
- **maturity** is the date when the security expires.
- **pr** is the security’s price per $100 face value.
- **redemption** is the security’s redemption value per $100 face value.
- **basis** is the integer that represents which type of day count basis to use.

<table>
<thead>
<tr>
<th>Integer</th>
<th>Day Count Basis</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 or omitted</td>
<td>US (NASD) 30/360</td>
</tr>
<tr>
<td>1</td>
<td>Actual/Actual</td>
</tr>
<tr>
<td>2</td>
<td>Actual/360</td>
</tr>
<tr>
<td>3</td>
<td>Actual/365</td>
</tr>
<tr>
<td>4</td>
<td>European 30/360</td>
</tr>
</tbody>
</table>

**DOLLARDE:**

**Description:**
Using the DOLLARDE function converts a dollar price expressed as a fraction into a dollar price expressed as a decimal number. Used to convert fractional dollar numbers, like securities prices, into decimal numbers.

**General Syntax:**
=DOLLARDE(fractional_dollar,fraction)

**Arguments:**
- **fractional_dollar** is the dollar value expressed as a fraction.
- **fraction** is the integer used in the denominator of the fraction.

**DOLLARFR:**

**Description:**
Using the DOLLARFR function converts a dollar price expressed as a decimal into a dollar price expressed as a fraction.

**General Syntax:**
=DOLLARFR(decimal_dollar,fraction)

**Arguments:**
- **decimal_dollar** is the dollar value expressed as a decimal.
- **fraction** is the integer to use in the denominator of the fraction.

**DURATION:**

**Description:**
Using the DURATION function returns the Macauley duration for an assumed par value of $100. Duration is defined as the weighted average of the present value of the cash flows and is used as a measure of a bond price's response to changes in yield.

**General Syntax:**
=DURATION(settlement,maturity,coupon,yld,frequency,basis)

**Arguments:**
- **settlement** is the security’s settlement date: the date after issue when the security is traded to the buyer.
- **maturity** is the date when the security expires.
- **coupon** is the security’s annual coupon rate.
- **yld** is the security’s annual yield.
- **frequency** is the number of coupon payments per year, expressed as an integer.
- **basis** is the integer that represents which type of day count basis to use.

<table>
<thead>
<tr>
<th>Integer</th>
<th>Day Count Basis</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 or omitted</td>
<td>US (NASD) 30/360</td>
</tr>
<tr>
<td>1</td>
<td>Actual/Actual</td>
</tr>
<tr>
<td>2</td>
<td>Actual/360</td>
</tr>
<tr>
<td>3</td>
<td>Actual/365</td>
</tr>
<tr>
<td>4</td>
<td>European 30/360</td>
</tr>
</tbody>
</table>
**Glossary of Functions**

**EFFECT:**

*Description:* Using the EFFECT function returns the effective annual interest rate, given the nominal annual interest rate and the number of compounding periods per year.

*General Syntax:* =EFFECT(rate,nperiods)

*Arguments:*  
- `rate` is the nominal interest rate.  
- `nperiods` is the number of compounding periods per year.

*Formula:* The function is calculated according to the following formula:

\[
EFF\text{C}T = \left(1 + \frac{N\text{ominal\_rate}}{N\text{pery}}\right)^{N\text{pery}} - 1
\]

**FV:**

*Description:* Using the FV function returns the future value of an investment based on periodic, constant payments and a constant interest rate.

*General Syntax:* =FV(rate,nper,pmt,pv,type)

*Arguments:*  
- `rate` is the interest rate per period.  
- `nper` is the total number of payment periods in an annuity.  
- `pmt` is the payment made each period; it cannot change over the life of the annuity. Typically, `pmt` contains principal and interest but no other fees or taxes. If `pmt` is omitted, you must include the `pv` argument.  
- `pv` is the present value, or the lump-sum amount that a series of future payments is worth right now. If `pv` is omitted, it is assumed to be 0 (zero), and you must include the `pmt` argument.  
- `type` is the timing of the payment. If 0, the payment is at the end of the period. If 1, payment is at the beginning of the period.

**FVSCHEDULE:**

*Description:* Using the FVSCHEDULE function returns the future value of an initial principal after applying a series of compound interest rates. Use FVSCHEDULE to calculate the future value of an investment with a variable or adjustable rate.

*General Syntax:* =FVSCHEDULE(principal,schedule)

*Arguments:*  
- `principal` is the present value.  
- `schedule` is an array of interest rates to apply. These are usually entered as a cell range reference to the rates listed in the worksheet. If entered numerically, they must all be enclosed in braces {}, with each rate separated by a comma from the other rate.

**INTRATE:**

*Description:* Using the INTRATE function returns the interest rate for a fully invested security.

*General Syntax:* =INTRATE(settlement,maturity,investment,redemption,basis)

*Arguments:*  
- `settlement` is the date after issue when the security is traded to the buyer.  
- `maturity` is the date when the security expires.  
- `investment` is the amount invested in the security.  
- `redemption` is the amount to be received at maturity.  
- `basis` is the integer that represents which type of day count basis to use.

<table>
<thead>
<tr>
<th>Integer</th>
<th>Day Count Basis</th>
<th>Integer</th>
<th>Day Count Basis</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 or omitted</td>
<td>US (NASD) 30/360</td>
<td>1</td>
<td>Actual/Actual</td>
</tr>
<tr>
<td>2</td>
<td>Actual/360</td>
<td>3</td>
<td>Actual/365</td>
</tr>
<tr>
<td>4</td>
<td>European 30/360</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
**IPMT:**

*Description:* Using the IPMT function returns the interest payment for a given period for an investment based on periodic, constant payments and a constant interest rate.

*General Syntax:*  
\[ \text{=IPMT(rate,per,nper,pv,fv,type)} \]

*Arguments:*
- **rate** is the interest rate per period.
- **per** is the period for which you want to find the interest.
- **nper** is the total number of payment periods in an annuity.
- **pv** is the present value that a series of future payments is worth right now.
- **fv** is the future value that you want to attain after the last payment is made. If omitted, is assumed to be zero.
- **type** is the timing of the payment. If 0, the payment is at the end of the period. If 1, payment is at the beginning of the period.

**IRR:**

*Description:* Using the IRR function returns the internal rate of return for a series of cash flows represented by the numbers in values. These cash flows do not have to be even, as they would be for an annuity. However, the cash flows must occur at regular intervals, such as monthly or annually. The internal rate of return is the interest rate received for an investment consisting of payments (negative values) and income (positive values) that occur at regular periods.

*General Syntax:*  
\[ \text{=IRR(values,guess)} \]

*Arguments:*
- **values** is an array (as either a cell range reference, or as numbers listed in braces { }) of the numbers for which you want to calculate the internal rate of return. Must contain at least one positive and one negative value. Uses the order of values to determine the order of cash flows. Be sure to place values in the desired order.
- **guess** is a number that you guess is close to the result of IRR. Excel uses an iterative technique for calculating IRR. Starting with guess, IRR cycles through the calculation until the result is accurate within 0.00001 percent. If IRR can't find a result that works after 20 tries, the #NUM! error value is returned. In most cases you do not need to provide guess for the IRR calculation. If guess is omitted, it is assumed to be 0.1 (10 percent).

**ISPMT:**

*Description:* Using the ISPMT function returns the interest paid during a specific period of an investment. This function is provided for compatibility with Lotus 1-2-3.

*General Syntax:*  
\[ \text{=ISPMT(rate,per,nper,pv)} \]

*Arguments:*
- **rate** is the interest rate for the investment.
- **per** is the period for which you want to find the interest.
- **nper** is the total number of payment periods for the investment.
- **pv** is the present value of the investment right now.
**Glossary of Functions**

**MDURATION:**

*Description:* Using the MDURATION function returns the modified Macauley duration for a security with an assumed par value of $100.

*General Syntax:* 

\[
=\text{MDURATION}(\text{settlement}, \text{maturity}, \text{coupon}, \text{yld}, \text{frequency}, \text{basis})
\]

*Arguments:*

- **settlement** is the security’s settlement date: the date after issue when the security is traded to the buyer.
- **maturity** is the date when the security expires.
- **coupon** is the security’s annual coupon rate.
- **yld** is the security’s annual yield.
- **frequency** is the number of coupon payments per year, expressed as an integer.
- **basis** is the integer that represents which type of day count basis to use.

<table>
<thead>
<tr>
<th>Integer</th>
<th>Day Count Basis</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 or omitted</td>
<td>US (NASD) 30/360</td>
</tr>
<tr>
<td>1</td>
<td>Actual/Actual</td>
</tr>
<tr>
<td>2</td>
<td>Actual/360</td>
</tr>
<tr>
<td>3</td>
<td>Actual/365</td>
</tr>
<tr>
<td>4</td>
<td>European 30/360</td>
</tr>
</tbody>
</table>

*Formula:* The modified duration is defined as follows:

\[
\text{MDURATION} = \frac{\text{DURATION}}{1 + \left(\frac{\text{Market yield}}{\text{Coupon payments per year}}\right)}
\]

**MIRR:**

*Description:* Using the MIRR function returns the modified internal rate of return for a series of periodic cash flows. MIRR considers both the cost of the investment and the interest received on reinvestment of cash.

*General Syntax:* 

\[
=\text{MIRR}(\text{values}, \text{finance_rate}, \text{reinvest_rate})
\]

*Arguments:*

- **values** is an array (as either a cell range reference, or as numbers listed in braces {} of the numbers for which you want to calculate the internal rate of return. Must contain at least one positive and one negative value. Uses the order of values to determine the order of cash flows. Be sure to place values in the desired order.
- **finance_rate** is the interest rate you pay on the money used in the cash flows.
- **reinvest_rate** is the interest rate you receive on the cash flows as you reinvest them.

*Formula:* If \( n \) is the number of cash flows in values, \( r_{\text{rate}} \) is the finance_rate, and \( r_{\text{rate}} \) is the reinvest rate, then the formula for calculating MIRR is as follows:

\[
\left( \frac{\text{NPV}(r_{\text{rate}}, \text{values}[\text{positive}]) * (1 + r_{\text{rate}})^n}{\text{NPV}(r_{\text{rate}}, \text{values}[\text{negative}]) * (1 + r_{\text{rate}})} \right)^{\frac{1}{n-1}} - 1
\]

**NOMINAL:**

*Description:* Using the NOMINAL function returns the nominal annual interest rate, given the effective rate and the number of compounding periods per year.

*General Syntax:* 

\[
=\text{NOMINAL}(\text{effective_rate}, \text{npery})
\]

*Arguments:*

- **effective_rate** is the effective interest rate.
- **npery** is the number of compounding periods per year.
**Glossary of Functions**

**NPER:**

*Description:* Using the NPER function returns the number of periods for an investment based on periodic, constant payments and a constant interest rate.

*General Syntax:* \( = \text{NPER}(\text{rate}, \text{pmt}, \text{pv}, \text{fv}, \text{type}) \)

*Arguments:*
- *rate* is the interest rate per period.
- *pmt* is the payment made each period; it cannot change over the life of the annuity. Typically, *pmt* contains principal and interest but no other fees or taxes.
- *pv* is the present value, or the lump-sum amount that a series of future payments is worth right now.
- *fv* is the future value that you want to attain after the last payment is made. If omitted, is assumed to be zero.
- *type* is the timing of the payment. If 0, the payment is at the end of the period. If 1, payment is at the beginning of the period.

**NPV:**

*Description:* Using the NPV function calculates the net present value of an investment by using a discount rate and a series of future payments (negative values) and income (positive values).

*General Syntax:* \( = \text{NPV}(\text{rate}, \text{values}) \)

*Arguments:*
- *rate* is the rate of discount over the length of one period.
- *values* are 1 to 29 arguments representing the payments and income. Values must be equally spaced in time and occur at the end of each period. NPV uses the values to interpret the order of cash flows. Be sure to enter your payment and income values in the correct sequence.

*Formula:* If \( n \) is the number of cash flows, the formula for \( \text{NPV} \) is: \( \text{NPV} = \sum_{i=1}^{n} \frac{\text{values}_i}{(1 + \text{rate})^i} \)

**ODDFPRICE:**

*Description:* Using the ODDFPRICE function returns the price per $100 face value of a security having an odd (short or long) first period.

*General Syntax:* \( = \text{ODDFPRICE}(\text{settlement}, \text{maturity}, \text{issue}, \text{first_coupon}, \text{rate}, \text{yld}, \text{redemption}, \text{frequency}, \text{basis}) \)

*Arguments:*
- *settlement* is the date after issue when the security is traded to the buyer.
- *maturity* is the date when the security expires.
- *issue* is the security’s issue date.
- *first_coupon* is the security’s first coupon date.
- *rate* is the security’s interest rate.
- *yld* is the security’s annual yield.
- *redemption* is the security’s redemption value per $100 face value.
- *frequency* is the number of coupon payments per year, expressed as an integer.
- *basis* is the integer that represents which type of day count basis to use.

*Integer* | *Day Count Basis* |
--- | --- |
0 | US (NASD) 30/360 |
1 | Actual/Actual |
2 | Actual/360 |
3 | Actual/365 |
4 | European 30/360 |
Glossary of Functions

ODDFYIELD:

Description: Using the ODDFYIELD function returns the yield of a security having an odd (short or long) first period.

General Syntax: =ODDFYIELD(settlement, maturity, issue, first_coupon, rate, pr, redemption, frequency, basis)

Arguments:

- settlement is the date after issue when the security is traded to the buyer.
- maturity is the date when the security expires.
- issue is the security's issue date.
- first_coupon is the security's first coupon date.
- rate is the security's interest rate.
- pr is the security's price.
- redemption is the security's redemption value per $100 face value.
- frequency is the number of coupon payments per year, expressed as an integer.
- basis is the integer that represents which type of day count basis to use.

Integer: Day Count Basis:
0 or omitted  US (NASD) 30/360
1  Actual/Actual
2  Actual/360
3  Actual/365
4  European 30/360

ODDLPRICE:

Description: Using the ODDLPRICE function returns the price per $100 face value of a security having an odd (short or long) last period.

General Syntax: =ODDLPRICE(settlement, maturity, last_interest, rate, yld, redemption, frequency, basis)

Arguments:

- settlement is the date after issue when the security is traded to the buyer.
- maturity is the date when the security expires.
- last_interest is the security's last coupon date.
- rate is the security's interest rate.
- yld is the security's annual yield.
- redemption is the security's redemption value per $100 face value.
- frequency is the number of coupon payments per year, expressed as an integer.
- basis is the integer that represents which type of day count basis to use.

Integer: Day Count Basis:
0 or omitted  US (NASD) 30/360
1  Actual/Actual
2  Actual/360
3  Actual/365
4  European 30/360
Glossary of Functions

ODDLYIELD:

Description:
Using the ODDLYIELD function returns the yield of a security having an odd (short or long) last period.

General Syntax:
=ODDLYIELD(settlement, maturity, last_interest, rate, pr, redemption, frequency, basis)

Arguments:
- settlement is the date after issue when the security is traded to the buyer.
- maturity is the date when the security expires.
- last_interest is the security's last coupon date.
- rate is the security's interest rate.
- pr is the security's price.
- redemption is the security's redemption value per $100 face value.
- frequency is the number of coupon payments per year, expressed as an integer.
- basis is the integer that represents which type of day count basis to use.

Integer: Day Count Basis:
0 or omitted  US (NASD) 30/360
1            Actual/Actual
2            Actual/360
3            Actual/365
4            European 30/360

PDTURATION:

Description:
Using the PDURATION function returns the number of periods required by an investment to reach a specified value.

General Syntax:
=PDURATION(rate, pv, fv)

Arguments:
- rate is the interest rate per period.
- pv is the present value of the investment.
- fv is the desired future value of the investment.

PMT:

Description:
Using the PMT function calculates the payment for a loan based on constant payments and a constant interest rate.

General Syntax:
=PMT(rate, nper, pv, fv, type)

Arguments:
- rate is the interest rate for the loan.
- nper is the total number of payments for the loan.
- pv is the present value, or principal.
- fv is the future value that you want to attain after the last payment is made. If omitted, is assumed to be zero.
- type is the timing of the payment. If 0, the payment is at the end of the period. If 1, payment is at the beginning of the period.

PPMT:

Description:
Using the PPMT function returns the payment on the principal for a given period for an investment based on periodic, constant payments and a constant interest rate.

General Syntax:
=PPMT(rate, per, nper, pv, fv, type)

Arguments:
- rate is the interest rate per period.
- per specifies the period.
- nper is the total number of payment periods.
- pv is the present value.
- fv is the future value that you want to attain after the last payment is made. If omitted, is assumed to be zero.
- type is the timing of the payment. If 0, the payment is at the end of the period. If 1, payment is at the beginning of the period.
PRICE:

Description: Using the PRICE function returns the price per $100 face value of a security that pays periodic interest.

General Syntax: =PRICE(settlement,maturity,rate,yld,redemption,frequency,basis)

Arguments:
- settlement is the date after issue when the security is traded to the buyer.
- maturity is the date when the security expires.
- rate is the security's annual coupon rate.
- yld is the security's annual yield.
- redemption is the security's redemption value per $100 face value.
- frequency is the number of coupon payments per year, expressed as an integer.
- basis is the integer that represents which type of day count basis to use.

PRICEDISC:

Description: Using the PRICEDISC function returns the price per $100 face value of a discounted security.

General Syntax: =PRICEDISC(settlement,maturity,discount,redemption,basis)

Arguments:
- settlement is the date after issue when the security is traded to the buyer.
- maturity is the date when the security expires.
- discount is the security's discount rate.
- redemption is the security's redemption value per $100 face value.
- frequency is the number of coupon payments per year, expressed as an integer.
- basis is the integer that represents which type of day count basis to use. If omitted, uses the US (NASD) 30/360 day count.

PRICEMAT:

Description: Using the PRICEMAT function returns the price per $100 face value of a security that pays interest at maturity.

General Syntax: =PRICEMAT(settlement,maturity,issue,rate,yld,basis)

Arguments:
- settlement is the date after issue when the security is traded to the buyer.
- maturity is the date when the security expires.
- issue is the security's issue date.
- rate is the security's interest rate at date of issue.
- yld is the security's annual yield.
- basis is the integer that represents which type of day count basis to use. If omitted, uses the US (NASD) 30/360 day count.

PV:

Description: Using the PV function returns the present value of an investment.

General Syntax: =PV(rate,nper,pmt,fv,type)

Arguments:
- rate is the interest rate per period.
- nper is the total number of payment periods.
- pmt is the payment made each period.
- fv is the future value that you want to attain after the last payment is made. If omitted, is assumed to be zero.
- type is the timing of the payment. If 0, the payment is at the end of the period. If 1, payment is at the beginning of the period.
Glossary of Functions

RATE:
Description: Using the RATE function returns the interest rate per period of an annuity. RATE is calculated by iteration and can have zero or more solutions. If the successive results of RATE do not converge to within 0.0000001 after 20 iterations, RATE returns the #NUM! error value.

General Syntax: =RATE(nper,pmt,pv,fv,type,guess)
Arguments:
- nper is the total number of payment periods in an annuity.
- pmt is the payment made each period.
- pv is the present value.
- fv is the future value that you want to attain after the last payment is made. If omitted, is assumed to be zero.
- type is the timing of the payment. If 0, the payment is at the end of the period. If 1, payment is at the beginning of the period.

RECEIVED:
Description: Using the RECEIVED function returns the amount received at maturity for a fully invested security.

General Syntax: =RECEIVED(settlement,maturity,investment,discount,basis)
Arguments:
- settlement is the date after issue when the security is traded to the buyer.
- maturity is the date when the security expires.
- investment is the amount invested in the security.
- discount is the security's discount rate.
- basis is the integer that represents which type of day count basis to use. If omitted, uses the US (NASD) 30/360 day count.

RRI:
Description: Using the RRI function returns an equivalent interest rate for the growth of an investment.

General Syntax: =RRI(nper,pv,fv)
Arguments:
- nper is the number of periods for the investment.
- pv is the present value of the investment.
- fv is the future value of the investment.

SLN:
Description: Using the SLN function returns the straight-line depreciation of an asset for a period.

General Syntax: =SLN(cost,salvage,life)
Arguments:
- cost is the initial cost of the asset.
- salvage is the value of the asset after depreciation.
- life is the number of periods over which the asset is depreciated.

SYD:
Description: Using the SYD function returns the sum-of-years’ digits depreciation of an asset for a specified period.

General Syntax: =SYD(cost,salvage,life,per)
Arguments:
- cost is the initial cost of the asset.
- salvage is the value of the asset after depreciation.
- life is the number of periods over which the asset is depreciated.
- per is the period and must use the same units as life.
### Glossary of Functions

**TBILLEQ:**

*Description:* Using the TBILLEQ function returns the bond-equivalent yield for a Treasury bill.

*General Syntax:* 

\[ =\text{TBILLEQ(settlement,maturity,discount)} \]

*Arguments:*

- `settlement` is the date after issue when the bill is traded to the buyer.
- `maturity` is the date when the bill expires.
- `discount` is the bill's discount rate.

**TBILLPRICE:**

*Description:* Using the TBILLPRICE function returns the price per $100 face value for a Treasury bill.

*General Syntax:* 

\[ =\text{TBILLPRICE(settlement,maturity,discount)} \]

*Arguments:*

- `settlement` is the date after issue when the bill is traded to the buyer.
- `maturity` is the date when the bill expires.
- `discount` is the bill's discount rate.

**TBILLYIELD:**

*Description:* Using the TBILLYIELD function returns the yield for a Treasury bill.

*General Syntax:* 

\[ =\text{TBILLYIELD(settlement,maturity,pr)} \]

*Arguments:*

- `settlement` is the date after issue when the bill is traded to the buyer.
- `maturity` is the date when the bill expires.
- `pr` is the Treasury bill's price per $100 face value.

**VDB:**

*Description:* Using the VDB function returns the depreciation of an asset for any period you specify, including partial periods, using the double-declining balance method or some other method you specify.

*General Syntax:* 

\[ =\text{VDB(cost,salvage.life.start_period.end_period.factor,no.switch)} \]

*Arguments:*

- `cost` is the initial cost of the asset.
- `salvage` is the value of the asset after depreciation.
- `life` is the number of periods over which the asset is depreciated.
- `start_period` is the starting period for which you want to calculate depreciation.
- `end_period` is the ending period for which you want to calculate depreciation.
- `factor` is the rate at which the balance declines. If omitted, 2 (double-declining) is assumed.
- `no_switch` is a logical value that specifies whether or not to switch to straight-line depreciation when the depreciation is greater than the declining balance calculation. If omitted, or FALSE, Excel will switch. If TRUE, it will not switch.

**XIRR:**

*Description:* Using the XIRR function returns the internal rate of return for a schedule of cash flows that is not necessarily periodic. To calculate the internal rate of return for a series of periodic cash flows, use the IRR function.

*General Syntax:* 

\[ =\text{XIRR(values,dates,guess)} \]

*Arguments:*

- `values` is a series of cash flows that corresponds to a schedule of payments in dates. The first payment is optional and corresponds to a cost or payment that occurs at the beginning of the investment. If the first value is a cost or payment, it must be a negative value. All succeeding payments are discounted based on a 365-day year. The series of values must contain at least one positive and one negative value.
- `dates` is a schedule of payment dates that corresponds to the cash flow payments. The first payment date indicates the beginning of the schedule of payments. All other dates must be later than this date, but they may occur in any order.
- `guess` is a number that you guess is close to the result of XIRR. Excel uses an iterative technique for calculating XIRR. Starting with guess, XIRR cycles through the calculation until the result is accurate within 0.00001 percent. If XIRR can't find a result that works after 100 tries, the #NUM! error value is returned. In most cases you do not need to provide guess for the XIRR calculation. If guess is omitted, it is assumed to be 0.1 (10 percent).
# Glossary of Functions

## XNPV:

**Description:**
Using the XNPV function returns the net present value for a schedule of cash flows that is not necessarily periodic.

**General Syntax:**

\[ \text{XNPV}(\text{rate}, \text{values}, \text{dates}) \]

**Arguments:**
- **rate** is the discount rate to apply to the cash flows.
- **values** is a series of cash flows that corresponds to a schedule of payments in dates. The first payment is optional and corresponds to a cost or payment that occurs at the beginning of the investment. If the first value is a cost or payment, it must be a negative value. All succeeding payments are discounted based on a 365-day year. The series of values must contain at least one positive value and one negative value.
- **dates** is a schedule of payment dates that corresponds to the cash flow payments. The first payment date indicates the beginning of the schedule of payments. All other dates must be later than this date, but they may occur in any order.

## YIELD:

**Description:**
Using the YIELD function returns the yield on a security that pays periodic interest. Use YIELD to calculate bond yield.

**General Syntax:**

\[ \text{YIELD}(\text{settlement}, \text{maturity}, \text{rate}, \text{pr}, \text{redemption}, \text{frequency}, \text{basis}) \]

**Arguments:**
- **settlement** is the date after issue when the security is traded to the buyer.
- **maturity** is the date when the security expires.
- **rate** is the security’s annual coupon rate.
- **pr** is the security’s price per $100 face value.
- **redemption** is the security’s redemption value per $100 face value.
- **frequency** is the number of coupon payments per year, expressed as an integer.
- **basis** is the integer that represents which type of day count basis to use. If omitted, uses the US (NASD) 30/360 day count.

## YIELDDISC:

**Description:**
Using the YIELDDISC function returns the annual yield on a discounted security.

**General Syntax:**

\[ \text{YIELDDISC}(\text{settlement}, \text{maturity}, \text{pr}, \text{redemption}, \text{basis}) \]

**Arguments:**
- **settlement** is the date after issue when the security is traded to the buyer.
- **maturity** is the date when the security expires.
- **pr** is the security’s price per $100 face value.
- **redemption** is the security’s redemption value per $100 face value.
- **basis** is the integer that represents which type of day count basis to use. If omitted, uses the US (NASD) 30/360 day count.

## YIELDMAT:

**Description:**
Using the YIELDMAT function returns the annual yield of a security that pays interest at maturity.

**General Syntax:**

\[ \text{YIELDMAT}(\text{settlement}, \text{maturity}, \text{issue}, \text{rate}, \text{pr}, \text{basis}) \]

**Arguments:**
- **settlement** is the date after issue when the security is traded to the buyer.
- **maturity** is the date when the security expires.
- **issue** is the security’s issue date.
- **rate** is the security’s interest rate at the date of issue.
- **pr** is the security’s price per $100 face value.
- **redemption** is the security’s redemption value per $100 face value.
- **basis** is the integer that represents which type of day count basis to use. If omitted, uses the US (NASD) 30/360 day count.
Glossary of Functions

CELL:

Description:
Using the CELL function returns information about the formatting, location, or contents of the upper-left cell in a reference. The CELL function is provided for compatibility with other spreadsheet programs. Not available in the Excel Web App.

General Syntax:
=CELL(info_type, reference)

Arguments:
info_type is a text value that specifies what type of cell information you want. This table lists the possible values and their corresponding results:

<table>
<thead>
<tr>
<th>info_type</th>
<th>returns</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;address&quot;</td>
<td>Reference of the first cell in reference, as text.</td>
</tr>
<tr>
<td>&quot;col&quot;</td>
<td>Column number of the cell in reference.</td>
</tr>
<tr>
<td>&quot;color&quot;</td>
<td>1 if the cell is formatted in color for negative values; otherwise returns zero (zero).</td>
</tr>
<tr>
<td>&quot;contents&quot;</td>
<td>Value of the upper-left cell in reference; not a formula.</td>
</tr>
<tr>
<td>&quot;filename&quot;</td>
<td>Filename (including full path) of the file that contains reference, as text. Returns empty text (&quot;&quot;&quot;) if the worksheet that contains reference has not yet been saved.</td>
</tr>
<tr>
<td>&quot;format&quot;</td>
<td>Text value corresponding to the number format of the cell. The text values for the various formats are shown in the following table. Returns &quot;-&quot; at the end of the text value if the cell is formatted in color for negative values. Returns &quot;( )&quot; at the end of the text value if the cell is formatted with parentheses for positive or all values.</td>
</tr>
<tr>
<td>&quot;parentheses&quot;</td>
<td>1 if the cell is formatted with parentheses for positive or all values; otherwise returns zero.</td>
</tr>
<tr>
<td>&quot;prefix&quot;</td>
<td>Text value corresponding to the &quot;label prefix&quot; of the cell. Returns single quotation mark (') if the cell contains left-aligned text, double quotation mark (&quot;) if the cell contains right-aligned text, caret (^) if the cell contains centered text, backslash () if the cell contains fill-aligned text, and empty text (&quot;&quot;&quot;) if the cell contains anything else.</td>
</tr>
<tr>
<td>&quot;protect&quot;</td>
<td>0 if the cell is not locked, and 1 if the cell is locked.</td>
</tr>
<tr>
<td>&quot;row&quot;</td>
<td>Row number of the cell in reference.</td>
</tr>
<tr>
<td>&quot;type&quot;</td>
<td>Text value corresponding to the type of data in the cell. Returns &quot;b&quot; for blank if the cell is empty, &quot;l&quot; for label if the cell contains a text constant, and &quot;v&quot; for value if the cell contains anything else.</td>
</tr>
<tr>
<td>&quot;width&quot;</td>
<td>Column width of the cell rounded off to an integer. Each unit of column width is equal to the width of one character in the default font size.</td>
</tr>
</tbody>
</table>

reference is the cell that you want information about. If omitted, information specified in info_type is returned for the last cell that was changed. The following list describes the text values CELL returns when info_type is "format," and reference is a cell formatted with a built-in number format.

If the Microsoft Excel format is: | CELL returns:
---|---
General | "G"
0 | "F0"
#.##0 | ",0"
0.00 | "F2"
#.##0.00 | ",2"
$#.##0_0_0_0_0($#.##00) | "C0"
$#.##0_0_0_0_0_0($#.##00) | "C6"
$#.##0.00_0_0_0_0_0($#.##00) | "C2"
0% | "P2"
0.00% | "S2"
0.00E+00 | ",G"
# ?/? or # ??/?? | "D4"
m/d/yyyy or m/dd/yyyy | "D1"
d-mmm-yy or dd-mmm-yy | "D2"
d-mmm or dd-mmm | "D3"
mmm-yy | "D5"
mm/dd | "D7"
h:mm AM/PM | "D6"
h:mm:ss AM/PM | "D9"
h:mm | "D8"
**GLOSSARY OF FUNCTIONS**

**ERROR.TYPE:**
*Description:* Using the ERROR.TYPE function returns a number corresponding to one of the error values in Microsoft Excel or returns the #N/A error if no error exists. You can use ERROR.TYPE in an IF function to test for an error value and return a text string, such as a message, instead of the error value.

*General Syntax:* =ERROR.TYPE(error_val)

*Arguments:* error_val is the error value whose identifying number you want to find. Although error_val can be the actual error value, it will usually be a reference to a cell containing a formula that you want to test.

<table>
<thead>
<tr>
<th>If error_val is:</th>
<th>ERROR.TYPE returns:</th>
</tr>
</thead>
<tbody>
<tr>
<td>#NULL!</td>
<td>1</td>
</tr>
<tr>
<td>#DIV/0!</td>
<td>2</td>
</tr>
<tr>
<td>#VALUE!</td>
<td>3</td>
</tr>
<tr>
<td>#REF!</td>
<td>4</td>
</tr>
<tr>
<td>#NAME?</td>
<td>5</td>
</tr>
<tr>
<td>#NUM!</td>
<td>6</td>
</tr>
<tr>
<td>#N/A</td>
<td>7</td>
</tr>
<tr>
<td>Anything else</td>
<td>#N/A</td>
</tr>
</tbody>
</table>

**INFO:**
*Description:* Using the INFO function returns information about the current operating environment. You should use this feature with caution as sensitive or confidential information could be revealed to other users! This function is not available in Excel Web App.

*General Syntax:* =INFO(type_text)

*Arguments:* type_text is the text value that specifies what type of information you want returned.

<table>
<thead>
<tr>
<th>Type_text:</th>
<th>Returns:</th>
</tr>
</thead>
<tbody>
<tr>
<td>&quot;directory&quot;</td>
<td>Path of the current directory or folder.</td>
</tr>
<tr>
<td>&quot;memavail&quot;</td>
<td>Amount of memory available, in bytes.</td>
</tr>
<tr>
<td>&quot;memused&quot;</td>
<td>Amount of memory being used for data.</td>
</tr>
<tr>
<td>&quot;numfile&quot;</td>
<td>Number of active worksheets in the open workbooks.</td>
</tr>
<tr>
<td>&quot;origin&quot;</td>
<td>Absolute A1-style reference, as text, prepended with &quot;$A:&quot; for Lotus 1-2-3 release 3.x compatibility. Returns the cell reference of the top and leftmost cell visible in the window, based on the current scrolling position.</td>
</tr>
<tr>
<td>&quot;osversion&quot;</td>
<td>Current operating system version, as text.</td>
</tr>
<tr>
<td>&quot;recalc&quot;</td>
<td>Current recalculation mode; returns &quot;Automatic&quot; or &quot;Manual&quot;.</td>
</tr>
<tr>
<td>&quot;release&quot;</td>
<td>Version of Microsoft Excel, as text.</td>
</tr>
<tr>
<td>&quot;system&quot;</td>
<td>Name of the operating environment: Macintosh = &quot;mac; Windows = &quot;pcdos;&quot;</td>
</tr>
<tr>
<td>&quot;totmem&quot;</td>
<td>Total memory available, including memory already in use, in bytes.</td>
</tr>
</tbody>
</table>

**ISBLANK:**
*Description:* You use the ISBLANK function in conjunction with the IF function to test whether or not the cell to which you refer is blank.

*General Syntax:* =IF(ISBLANK(cell),true_value,false_value)

*Arguments:* cell is the cell that you want to test to see if it contains information. true_value is the value to return if the cell is empty. false_value is the value to return if the cell is not empty.
**Glossary of Functions**

**ISERR:**
*Description:* You use the ISERR function in conjunction with the IF function to test whether or not the cell to which you refer contains any error value (other than the "#N/A" error).

*General Syntax:* \( =IF(ISERR(cell),true\_value,false\_value) \)

*Arguments:*
- `cell` is the cell that you want to test to see if it contains an error message.
- `true\_value` is the value to return if the `cell` does contain an error.
- `false\_value` is the value to return if the `cell` does not contain an error.

**ISERROR:**
*Description:* You use the ISERROR function in conjunction with the IF function to test whether or not the cell to which you refer contains any error value (including the "#N/A" error).

*General Syntax:* \( =IF(ISERROR(cell),true\_value,false\_value) \)

*Arguments:*
- `cell` is the cell that you want to test to see if it contains an error message.
- `true\_value` is the value to return if the `cell` does contain an error.
- `false\_value` is the value to return if the `cell` does not contain an error.

**ISEVEN:**
*Description:* You use the ISEVEN function in conjunction with the IF function to test whether or not the cell to which you refer contains an even number.

*General Syntax:* \( =IF(ISEVEN(cell),true\_value,false\_value) \)

*Arguments:*
- `cell` is the cell that you want to test to see if it contains an even number.
- `true\_value` is the value to return if the `cell` does contain an even number.
- `false\_value` is the value to return if the `cell` does not contain an even number.

**ISFORMULA:**
*Description:* You use the ISFORMULA to check if there is a formula in a cell reference.

*General Syntax:* \( =ISFORMULA\_reference \)

*Arguments:*
- `reference` is a reference to the cell you want to test. Reference can be a cell reference, a formula, or a name that refers to a cell.

**ISLOGICAL:**
*Description:* You use the ISLOGICAL function in conjunction with the IF function to test whether or not the cell to which you refer contains a logical value (TRUE or FALSE).

*General Syntax:* \( =IF(ISLOGICAL(cell),true\_value,false\_value) \)

*Arguments:*
- `cell` is the cell that you want to test to see if it contains a logical value.
- `true\_value` is the value to return if the `cell` does contain a logical value.
- `false\_value` is the value to return if the `cell` does not contain a logical value.

**ISNA:**
*Description:* You use the ISNA function in conjunction with the IF function to test whether or not the cell to which you refer contains an "#N/A" error message (value unavailable).

*General Syntax:* \( =IF(ISNA(cell),true\_value,false\_value) \)

*Arguments:*
- `cell` is the cell that you want to test to see if it contains the "#N/A" value.
- `true\_value` is the value to return if the `cell` does contain the "#N/A" value.
- `false\_value` is the value to return if the `cell` does not contain the "#N/A" value.
ISNONTEXT:
Description: You use the ISNONTEXT function in conjunction with the IF function to test whether or not the cell to which you refer contains a non-text value (even a blank cell).
General Syntax: =IF(ISNONTEXT(cell),true_value,false_value)
Arguments:
- cell is the cell that you want to test to see if it contains a non-text value.
- true_value is the value to return if the cell does contain the a non-text value.
- false_value is the value to return if the cell does not contain a non-text value.

ISNUMBER:
Description: You use the ISNUMBER function in conjunction with the IF function to test whether or not the cell to which you refer contains a number.
General Syntax: =IF(ISNUMBER(cell),true_value,false_value)
Arguments:
- cell is the cell that you want to test to see if it contains a number.
- true_value is the value to return if the cell does contain the a number.
- false_value is the value to return if the cell does not contain a number.

ISODD:
Description: You use the ISODD function in conjunction with the IF function to test whether or not the cell to which you refer contains an odd number.
General Syntax: =IF(ISODD(cell),true_value,false_value)
Arguments:
- cell is the cell that you want to test to see if it contains an odd number.
- true_value is the value to return if the cell does contain an odd number.
- false_value is the value to return if the cell does not contain an odd number.

ISREF:
Description: You use the ISREF function in conjunction with the IF function to test whether or not the value to which you refer is a cell reference.
General Syntax: =IF(ISREF(value),true_value,false_value)
Arguments:
- value is the value that you want to test to see if it contains a reference.
- true_value is the value to return if the value does contain a reference.
- false_value is the value to return if the value does not contain a reference.

ISTEXT:
Description: You use the ISTEXT function in conjunction with the IF function to test whether or not the cell to which you refer contains a text value.
General Syntax: =IF(ISTEXT(cell),true_value,false_value)
Arguments:
- cell is the cell that you want to test to see if it contains a text value.
- true_value is the value to return if the cell does contain a text value.
- false_value is the value to return if the cell does not contain a text value.
Glossary of Functions

N:
Description: Using the N function returns a value converted to a number.
General Syntax: \( =N(value) \)
Arguments: value is the value you want to convert to a number. If value is a number, the function returns that number. If value is a date, the function returns the serial number of that date. If value is TRUE, the function returns 1. If value is FALSE, the function returns 0. If value is an error, the function returns that error. If value is anything else, the function returns 0.

NA:
Description: You use the NA function to return the "#N/A" error message. Used to mark empty cells.
General Syntax: \( =NA() \)
Arguments: none.

SHEET:
Description: You use the SHEET function to return the sheet number of the reference sheet.
General Syntax: \( =SHEET(value) \)
Arguments: value is an optional argument that is the name of a sheet or a reference for which you want the sheet number. If value is omitted, SHEET returns the number of the sheet that contains the function.

SHEETS:
Description: You use the SHEETS function to return the number of sheets in a reference.
General Syntax: \( =SHEETS(value) \)
Arguments: value is an optional argument that is a reference for which you want to know the number of sheets it contains. If omitted, SHEETS returns the number of sheets in the workbook that contains the function.

TYPE:
Description: You use the TYPE function to return a number which indicates the type of data in the value that you test.
General Syntax: \( =TYPE(value) \)
Arguments: value is any Excel value that you want to test for its data type. If TYPE returns a 1, the value is a number. If TYPE returns a 2, the value is text. If TYPE returns a 4, the value is a logical value. If TYPE returns a 16, the value is an error message. If TYPE returns a 64, the value is an array.
Glossary of Functions

AND:
Description: You use the AND function to verify that multiple conditions specified by logical tests given in the arguments are all TRUE. If so, the AND function returns TRUE, otherwise it will return FALSE if any test returns FALSE.
General Syntax: =AND(test1,test2,...)
Arguments: test1,test2,... are a series of logical conditions, each separated by a comma, that must all evaluate to a TRUE value for the AND function to return a TRUE value.

FALSE:
Description: You use the FALSE function to return a logical FALSE value. You may also type the word FALSE into a cell and Excel will interpret that as the logical value FALSE.
General Syntax: =FALSE()
Arguments: none.

IF:
Description: Using the IF function will evaluate a logical test and will return one result if the logical test returns a TRUE value. It will return another result if the logical test returns a FALSE value.
General Syntax: =IF(logical_test,true_result,false_result)
Arguments: logical_test is a logical test or statement that can be evaluated to either TRUE or FALSE. true_result is the value to be returned if the logical_test evaluates to a TRUE value. false_value is the value to be returned if the logical_test evaluates to a FALSE value.

IFERROR:
Description: Using the IFERROR function returns a value you specify if a formula evaluates to an error; otherwise, returns the result of the formula. Use the IFERROR function to trap and handle errors in a formula.
General Syntax: =IFERROR(value,value_if_error)
Arguments: value is the argument that is checked for an error. value_if_error is the value to return if the formula evaluates to an error. The following error types are evaluated: #N/A, #VALUE!, #REF!, #DIV/0!, #NUM!, #NAME?, or #NULL!.

IFNA:
Description: Using the IFNA function returns a value you specify if a formula evaluates to an #N/A error.
General Syntax: =IFNA(value,value_if_na)
Arguments: value is the argument that is checked for the #N/A error. value_if_na is the value to return if the formula evaluates to an #N/A error.

NOT:
Description: Using the NOT function will reverse the logical value returned by its argument.
General Syntax: =NOT(logical_test)
Arguments: logical_test is a logical test or statement that can be evaluated to either TRUE or FALSE.
GLOSSARY OF FUNCTIONS

OR:
Description: You use the OR function to verify that any condition given in set of logical tests returns a TRUE value. If so, the OR function returns TRUE, otherwise it will return FALSE if all tests return FALSE values.
General Syntax: =OR(test1,test2,…)
Arguments: test1,test2,… are a series of logical conditions, each separated by a comma.

TRUE:
Description: You use the TRUE function to return a logical TRUE value. You may also type the word TRUE into a cell and Excel will interpret that as the logical value TRUE.
General Syntax: =TRUE()
Arguments: none.

XOR:
Description: You use the XOR function to return a logical Exclusive Or of all arguments.
General Syntax: =TRUE(logical1, logical2, …)
Arguments: logical1, logical2, … are the 1 to 255 logical conditions you want to test that can be either TRUE or FALSE, and can be logical values, arrays, or references. Logical1 is required and the rest are optional.

ADDRESS:
Description: Using the ADDRESS function will create a cell address as a text value, given the row and column references.
General Syntax: =ADDRESS(row,column,abs_num,a1,sheet_text)
Arguments:
row is the row number to use in the cell reference.
column is the column letter to use for the cell reference.
abs_num is an integer that specifies what type of cell reference to return. If 1, or omitted, returns an absolute cell reference. If 2, returns an absolute row and relative column reference. If 3, returns a relative row and absolute column reference. If 4, returns a relative cell reference.
a1 is a logical value (TRUE or FALSE) that specifies either an A1 style cell reference (e.g. B5) or an R1C1 style reference (e.g. R5C2). If TRUE, or omitted, returns an A1 style cell reference.
sheet_text is a text reference to the name of the worksheet. Used for external cell references. If omitted, no sheet name is used in the cell reference.

AREAS:
Description: Using the AREAS function will return the number of areas in a reference. An area is a range of contiguous cells or a single cell.
General Syntax: =AREAS(reference)
Arguments:
reference is a reference to a cell or range of cells and can refer to multiple areas. If you want to specify several references as a single argument, then you must include extra sets of parentheses so that Microsoft Excel will not interpret the comma as a field separator.
CHOOSE:
Description: Using the CHOOSE function will return a value from a list of available values (up to 29) based on an index number specified.
General Syntax: =CHOOSE(index_number,value1,value2…)
Arguments: index_number is an integer (from 1 to 29) that represents which value of the listed values will be returned.
value1,value2… are the values (up to 29) that the CHOOSE function returns, based on the order that they are entered and the selected index_number.

COLUMN:
Description: Using the COLUMN function will return the column number of the given reference.
General Syntax: =COLUMN(reference)
Arguments: reference is the cell for which you want the column number. If omitted, returns the column of the cell into which the function is placed.

COLUMNS:
Description: Using the COLUMNS function will return the number of columns in a reference.
General Syntax: =COLUMNS(array)
Arguments: array is the cell range or reference for which you want the number of columns.

FORMULATEXT:
Description: Using the FORMULATEXT function returns a formula as a string.
General Syntax: =FORMULATEXT(reference)
Arguments: reference is a reference to a cell or range of cells.

GETPIVOTDATA:
Description: Using the GETPIVOTDATA function will return visible data stored in a PivotTable report. Note that this formula may be needlessly complex, as you can enter a formula by typing = and the reference to the cell that contains the data you want.
General Syntax: =GETPIVOTDATA(data_field,pivot_table,field1,item1,field2,item2,...)
Arguments: data_field is the name of the data field that contains the data you want to retrieve.
pivot_table is a reference to any cell in a PivotTable report. Used to determine which PivotTable report contains the data you want to retrieve.
field1,item1,field2,item2,... are up to 14 pairs of field names and item names that describe the data you want to retrieve. Field names and names for items other than dates and numbers are enclosed in quotation marks.
Glossary of Functions

HLOOKUP:
Description: Using the HLOOKUP function searches for a value in the top row of a table, and returns a value in the same column from a row you specify.
General Syntax: =HLOOKUP(lookup_value,table,row_number,range_lookup)
Arguments: lookup_value is the value to be looked up in the first row of the table. table is a range reference or named range of the table in which you want to look. row_number is the number of the row from which a matching value will be returned. range_lookup is a logical value. If TRUE, or omitted, will return the next lowest value under the lookup_value if lookup_value doesn’t match a value exactly. If FALSE, will return the exact match of the lookup_value.

HYPERLINK:
Description: Using the HYPERLINK function will create a link to the file given in the arguments.
General Syntax: =HYPERLINK(link,friendly_name)
Arguments: link is the location of the internet address, network address, or file location of the item that you want to open when the user clicks the cell. Must be enclosed in double quotes. friendly_name is displayed text for the cell to be shown instead of the link. If omitted, will display the link instead.

INDEX:
Description: Using the INDEX function will return a value or the reference to a value from within a table or range. There are two forms of the INDEX() function: array and reference. The array form always returns a value or an array of values; the reference form always returns a reference.
Array Syntax: =INDEX(array,row_num,column_num)
Array Arguments: array is a range of cells or an array constant, enclosed in braces {}. row_num is the row number in the array from which to return a value. column_num is the column number in the array from which to return a value.
Reference Syntax: =INDEX(reference,row_num,column_num,area_num)
Reference Arguments: reference is a reference to one or more cell ranges. row_num is the row number in reference from which to return a reference. column_num is the column number in reference from which to return a reference. area_num is a range in reference from which to return the intersection of row_num and column_num. If omitted, uses area 1.

INDIRECT:
Description: Using the INDIRECT function returns the reference specified by a text string, immediately evaluated to display its contents. Use INDIRECT when you want to change the reference to a cell within a formula without changing the formula itself.
General Syntax: =INDIRECT(ref_text,a1)
Arguments: ref_text is a cell reference. a1 is a logical value that specifies the style of reference. If TRUE, or omitted, assumes the reference is in the A1 style. If FALSE, assumes a R1C1 style.
LOOKUP:

Description: Using the LOOKUP function returns a value either from a one-row or one-column range or from an array. The LOOKUP function has two syntax forms: vector and array. The vector form of LOOKUP looks in a one-row or one-column range (known as a vector) for a value and returns a value from the same position in a second one-row or one-column range. The array form of LOOKUP looks in the first row or column of an array for the specified value and returns a value from the same position in the last row or column of the array.

Vector Syntax: 
=LOOKUP(lookup_value,lookup_vector,result_vector)

Vector Arguments: 
lookup_value is the value to be looked up in the first vector.
lookup_vector is the range that contains only one row or one column. Must be placed in ascending order or the function may not work correctly.
result_vector is an adjacent range of the same size and shape as lookup_vector.

Array Syntax: 
=LOOKUP(lookup_value,array)

Array Arguments: 
lookup_value is the value to be looked up in the array.
array is the range of cells that contains text, numbers, or logical values that you want to compare with lookup_value. The values in array must be placed in ascending order for this function to work correctly. If array covers an area that is wider than it is tall (more columns than rows), LOOKUP searches for lookup_value in the first row. If array is square or is taller than it is wide (more rows than columns), LOOKUP searches in the first column. With HLOOKUP and VLOOKUP, you can index down or across, but LOOKUP always selects the last value in the row or column.

MATCH:

Description: Using the MATCH function returns the relative position of an item in an array that matches a specified value in a specified order. Use MATCH instead of one of the LOOKUP functions when you need the position of an item in a range returned instead of the item itself returned.

General Syntax: 
=MATCH(lookup_value,lookup_array,match_type)

Arguments: 
lookup_value is the value to be looked up.
lookup_array is a contiguous range of cells containing possible lookup values. Lookup_array must be an array or an array reference.
match_type specifies how Excel matches lookup_value with the lookup_array. If 1, or omitted, returns the largest value that is less than or equal to lookup_value. If 0, returns the first value that is exactly equal to lookup_value. If -1, returns the smallest value that is greater than or equal to lookup_value.

OFFSET:

Description: Using the OFFSET function returns a reference to a range that is a specified number of rows and columns from a cell or range of cells. The reference that is returned can be a single cell or a range of cells. You can specify the number of rows and the number of columns to be returned.

General Syntax: 
=OFFSET(reference,rows(cols),height,width)

Arguments: 
reference the cell or cell range from which you want to base the offset.
rows is the number of rows, up or down from the reference to which you want the upper left cell to refer. Can be positive or negative.
cols is the number of columns, to the left or right from the reference to which you want the upper left cell to refer. Can be positive or negative.
height is the number of rows to return. Must be positive. If omitted, returns the same number of rows as the reference.
width is the number of columns to return. Must be positive. If omitted, returns the same number of columns as the reference.
## Glossary of Functions

### ROW:

<table>
<thead>
<tr>
<th>Description</th>
<th>Using the ROW function will return the row number of the given reference.</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Syntax</td>
<td><code>=ROW(reference)</code></td>
</tr>
<tr>
<td>Arguments</td>
<td><code>reference</code> is the cell for which you want the row number. If omitted, returns the row of the cell into which the function is placed.</td>
</tr>
</tbody>
</table>

### ROWS:

<table>
<thead>
<tr>
<th>Description</th>
<th>Using the ROWS function will return the number of rows in a reference.</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Syntax</td>
<td><code>=ROWS(array)</code></td>
</tr>
<tr>
<td>Arguments</td>
<td><code>array</code> is the cell range or reference for which you want the number of rows.</td>
</tr>
</tbody>
</table>

### RTD:

<table>
<thead>
<tr>
<th>Description</th>
<th>Retrieves real-time data from a program that supports COM automation.</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Syntax</td>
<td><code>=RTD(prog_id, server, topic1, topic2, etc…)</code></td>
</tr>
<tr>
<td>Arguments</td>
<td><code>prog_id</code> is the name of the ProgID of a registered COM automation add-in that has been installed on the local computer. Enclose the name in quotation marks. <code>server</code> is the name of the server where the add-in should be run. If there is no server, and the program is run locally, leave the argument blank. <code>topic1, topic2, etc…</code> is 1 to 28 parameters that together represent a unique piece of real-time data.</td>
</tr>
</tbody>
</table>

### TRANSPOSE:

<table>
<thead>
<tr>
<th>Description</th>
<th>The TRANSPOSE function returns a vertical range of cells as a horizontal range, or vice versa. TRANSPOSE must be entered as an array formula in a range that has the same number of rows and columns, respectively, as an array has columns and rows. Use TRANSPOSE to shift the vertical and horizontal orientation of an array on a worksheet.</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Syntax</td>
<td><code>=TRANSPOSE(array)</code></td>
</tr>
<tr>
<td>Arguments</td>
<td><code>array</code> is an array of cells on the worksheet that you would like to transpose.</td>
</tr>
</tbody>
</table>

### VLOOKUP:

<table>
<thead>
<tr>
<th>Description</th>
<th>Using the VLOOKUP function searches for a value in the leftmost column of a table, and returns a value in the same row from a column that you specify.</th>
</tr>
</thead>
<tbody>
<tr>
<td>General Syntax</td>
<td><code>=VLOOKUP(lookup_value, table, col_number, range_lookup)</code></td>
</tr>
<tr>
<td>Arguments</td>
<td><code>lookup_value</code> is the value to be looked up in the first column of the table. <code>table</code> is a range reference or named range of the table in which you want to look. <code>col_number</code> is the number of the column from which a matching value will be returned. <code>range_lookup</code> is a logical value. If TRUE, or omitted, will return the next lowest value under the lookup_value if lookup_value doesn't match a value exactly. If FALSE, will return the exact match of the lookup_value.</td>
</tr>
</tbody>
</table>

Sample - for evaluation purposes only!
**ABS:**

*Description:* Using the ABS function returns the absolute value of a number.

*General Syntax:* 

\[\text{ABS(number)}\]

*Arguments:* 

- number is the number for which you want the absolute value.

**ACOS:**

*Description:* Using the ACOS function returns the arccosine, or inverse cosine, of a number.

*General Syntax:* 

\[\text{ACOS(number)}\]

*Arguments:* 

- number is the cosine of the angle that you want and must be from -1 to 1.

**ACOSH:**

*Description:* Using the ACOSH function returns the inverse hyperbolic cosine of a number. The number must be greater than or equal to 1. The inverse hyperbolic cosine is the value whose hyperbolic cosine is number, so ACOSH(COSH(number)) equals number.

*General Syntax:* 

\[\text{ACOSH(number)}\]

*Arguments:* 

- number is any real number equal to or greater than 1.

**ACOT:**

*Description:* Using the ACOT function returns the principal value of the arccotangent, or inverse cotangent, of a number.

*General Syntax:* 

\[\text{ACOT(number)}\]

*Arguments:* 

- number is the cotangent of the angle you want. This must be a real number.

**ACOTH:**

*Description:* Using the ACOTH function returns the inverse hyperbolic cotangent of a number.

*General Syntax:* 

\[\text{ACOTH(number)}\]

*Arguments:* 

- number is the absolute value of this argument must be greater than 1.
Glossary of Functions

AGGREGATE:
Description: Using the AGGREGATE function returns an aggregate in a list or database.
Reference Syntax: =AGGREGATE(function_num, options, ref1, [ref2], ...)
Array Syntax: =AGGREGATE(function_num, options, array, [k])
Arguments:
- function_num is the number of the function to use. 1=AVERAGE, 2=COUNT, 3=COUNTA, 4=MAX, 5=MIN, 6=PRODUCT, 7=STDEV.S, 8=STDEV.P, 9=SUM, 10=VAR.S, 11=VAR.P, 12=MEDIAN, 13=MODE.SNGL, 14=LARGE, 15=SMALL, 16=PERCENTILE.INC, 17=QUARTILE.INC, 18=PERCENTILE.EXC, 19=QUARTILE.EXC.
- options is a numerical value that determines which values to ignore in the evaluation range for the function. 0 or omitted=Ignore nested SUBTOTAL and AGGREGATE functions, 1=Ignore hidden rows, nested SUBTOTAL and AGGREGATE functions, 2=Ignore error values, nested SUBTOTAL and AGGREGATE functions, 3=Ignore hidden rows, error values, nested SUBTOTAL and AGGREGATE functions, 4=Ignore nothing, 5=Ignore hidden rows, 6=Ignore error values, 7=Ignore hidden rows and error values.
- ref1 is the first numeric argument for functions that take multiple numeric arguments for which you want the aggregate value.
- ref2 is often optional. They are arguments 2 to 253 for which you want the aggregate value. For functions that take an array, ref1 is an array, an array formula, or a reference to a range of cells for which you want the aggregate value. Ref2 is a second argument that is required for certain functions. The following functions require a ref2 argument: LARGE(array,k), SMALL(array,k), PERCENTILE.INC(array,k), QUARTILE.INC(array,quart), PERCENTILE.EXC(array,k), QUARTILE.EXC(array,quart).

ARABIC:
Description: Using the ARABIC function converts a Roman numeral to an Arabic numeral.
General Syntax: =ARABIC(text)
Arguments:
- text is a string enclosed in quotation marks, an empty string (""), or a reference to a cell containing text.

ASIN:
Description: Using the ASIN function returns the arcsine, or inverse sine, of a number.
General Syntax: =ASIN(number)
Arguments:
- number is the sine of the angle you want and must be from -1 to 1.

ASINH:
Description: Using the ASINH function returns the inverse hyperbolic sine of a number.
General Syntax: =ASINH(number)
Arguments:
- number is any real number.

ATAN:
Description: Using the ATAN function returns the arctangent, or inverse tangent, of a number.
General Syntax: =ATAN(number)
Arguments:
- number is the tangent of the angle that you want.
**Glossary of Functions**

**ATAN2:**
*Description:* Using the ATAN2 function returns the arctangent, or inverse tangent, of the specified x and y coordinates. The arctangent is the angle from the x axis to a line containing the origin (0,0) and a point with coordinates (x_num,y_num).

*General Syntax:*  
=ATAN2(x_num,y_num)

*Arguments:*  
x_num is the x-coordinate of the point.  
y_num is the y-coordinate of the point.

**ATANH:**
*Description:* Using the ATANH function returns the inverse hyperbolic tangent of a number.

*General Syntax:*  
=ATANH(number)

*Arguments:*  
number is any real number between 1 and -1.

**BASE:**
*Description:* Using the BASE function converts a number into a text representation with the given radix (base).

*General Syntax:*  
=BASE(number, radix, min_len)

*Arguments:*  
number is the number that you want to convert. Must be an integer greater than or equal to 0 and less than 2^53.  
radix is the base radix that you want to convert the number into. Must be an integer greater than or equal to 2 and less than or equal to 36.  
min_len is the minimum length of the returned string. Must be an integer greater than or equal to 0.

**CEILING:**
*Description:* Using the CEILING function returns the number rounded up, away from zero, to the nearest multiple of significance.

*General Syntax:*  
=CEILING(number, significance)

*Arguments:*  
number is the number that you wish to round.  
significance is the multiple to which you wish to round.

**CEILING.MATH:**
*Description:* Using the CEILING.MATH function rounds a number up to the nearest integer or to the nearest multiple of significance.

*General Syntax:*  
=CEILING.MATH(number, significance, mode)

*Arguments:*  
number is a number must be less than 9.99E+307 and greater than -2.229E-308.  
significance is the multiple to which number is to be rounded.  
mode is optional. For negative numbers, it controls whether number is rounded toward or away from zero.

**CEILING.PRECISE:**
*Description:* Using the CEILING.PRECISE function returns a number rounded up to the nearest integer or nearest multiple of significance. Regardless of the sign of the number, the number is rounded up. However, if the number or the significance is zero, zero is returned.

*General Syntax:*  
=CEILING(number, significance)

*Arguments:*  
number is the number that you wish to round.  
significance is the multiple to which you wish to round.
Glossary of Functions

COMBIN:
Description: Using the COMBIN function returns the number of combinations for a given number of items. Use COMBIN to determine the total possible number of groups for a given number of items.
General Syntax: =COMBIN(number,number_chosen)
Arguments:
number is the number of items.
number_chosen is the number of items per combination.

COS:
Description: Using the COS function returns the cosine of a given angle.
General Syntax: =COS(number)
Arguments:
number is the angle (in radians) for which you want the cosine. If the angle is in degrees, you can multiply the angle by PI()/180 or use the RADIANS function to return the radians of the angle before using the COS function.

COSH:
Description: Using the COSH function returns the hyperbolic cosine of a number.
General Syntax: =COSH(number)
Arguments:
number is any real number for which you want to find the hyperbolic cosine.

COT:
Description: Using the COT function returns the cotangent of an angle specified in radians.
General Syntax: =COT(number)
Arguments:
number is the angle in radians for which you want the cotangent.

COTH:
Description: Using the COTH function returns the hyperbolic cotangent of a hyperbolic angle.
General Syntax: =COTH(number)
Arguments:
number is the desired number to evaluate. The absolute value of number must be less than 2^27.

CSC:
Description: Using the CSC function returns the cosecant of an angle specified in radians.
General Syntax: =CSC(number)
Arguments:
number is the desired number to evaluate. The absolute value of number must be less than 2^27.

CSCH:
Description: Using the CSCH function returns the hyperbolic cosecant of an angle specified in radians.
General Syntax: =CSCH(number)
Arguments:
number is the desired number to evaluate. The absolute value of number must be less than 2^27.
**Glossary of Functions**

**DECIMAL:**
*Description:* Using the DECIMAL function converts a text representation of a number in a given base into a decimal number.
*General Syntax:* =DECIMAL(text, radix)
*Arguments:* text is the text representation of a number.
radix must be an integer.

**DEGREES:**
*Description:* Using the DEGREES function converts an angle given in radians to degrees.
*General Syntax:* =DEGREES(angle)
*Arguments:* angle is the angle (in radians) that you want to convert.

**EVEN:**
*Description:* Using the EVEN function returns a number rounded up to the nearest even integer.
*General Syntax:* =EVEN(number)
*Arguments:* number is the number that you want to round.

**EXP:**
*Description:* Using the EXP function returns $e$ (the base of the natural logarithm) raised to the specified power.
*General Syntax:* =EXP(number)
*Arguments:* number is the power to which you want to raise the value $e$.

**FACT:**
*Description:* Using the FACT function returns the factorial of a number. The factorial is equal to $1 \times 2 \times 3 \times \ldots \times \text{number}$. Negative numbers will cause an error.
*General Syntax:* =FACT(number)
*Arguments:* number is the number for which you want the factorial.

**FACTDOUBLE:**
*Description:* Using the FACTDOUBLE function returns the double factorial of a number. Negative numbers will cause an error.
*General Syntax:* =FACTDOUBLE(number)
*Arguments:* number is the number for which you want the double factorial.
## Glossary of Functions

### FLOOR:
**Description:**
Using the FLOOR function returns the number rounded down, towards zero, to the nearest multiple of significance.

**General Syntax:**
= FLOOR(number, significance)

**Arguments:**
- `number` is the number that you wish to round.
- `significance` is the multiple to which you wish to round.

### FLOOR.MATH:
**Description:**
Using the FLOOR.MATH function rounds a number down to the nearest integer or to the nearest multiple of significance.

**General Syntax:**
= FLOOR.MATH(number, significance, mode)

**Arguments:**
- `number` is the number that you wish to round.
- `significance` is the multiple to which you wish to round.
- `mode` is the direction (toward or away from 0) to round negative numbers.

### FLOOR.PRECISE:
**Description:**
Using the FLOOR.PRECISE returns a number rounded down to the nearest integer or nearest multiple of significance. Regardless of the sign of the number, the number is rounded down. However, if the number or the significance is zero, zero is returned.

**General Syntax:**
= FLOOR.PRECISE(number, significance)

**Arguments:**
- `number` is the number that you wish to round.
- `significance` is the multiple to which you wish to round. If omitted, 1 is used.

### GCD:
**Description:**
Using the GCD function returns the greatest common divisor of two or more integers. The greatest common divisor is the largest integer that divides the given numbers without a remainder.

**General Syntax:**
= GCD(numbers)

**Arguments:**
- `numbers` are 1 to 29 comma-separated numbers for which you want the GCD.

### INT:
**Description:**
Using the INT function rounds the given number down to the nearest integer.

**General Syntax:**
= INT(number)

**Arguments:**
- `number` is the real number you want to round down to an integer.

### ISO.CEILING:
**Description:**
Using the ISO.CEILING function returns a number rounded up to the nearest integer or nearest multiple of significance. Regardless of the sign of the number, the number is rounded up. However, if the number or the significance is zero, zero is returned.

**General Syntax:**
= ISO.CEILING(number, significance)

**Arguments:**
- `number` is the value to round.
- `significance` is the optional multiple to which number is to be rounded. If omitted, 1 is used.
Glossary of Functions

**LCM:**
*Description:* Using the LCM function returns the least common multiple of integers. The least common multiple is the smallest positive integer that is a multiple of all integer arguments given.

*General Syntax:*  
=LCM(numbers)

*Arguments:*  
numbers are 1 to 29 comma-separated numbers for which you want the LCM.

**LN:**
*Description:* Using the LN function returns the natural logarithm of a number. Natural logarithms are based on the constant e (2.71828182845904).

*General Syntax:*  
=LN(number)

*Arguments:*  
number is the positive real number for which you want the natural logarithm.

**LOG:**
*Description:* Using the LOG function returns the logarithm of a number to the base you specify.

*General Syntax:*  
=LOG(number,base)

*Arguments:*  
number is the positive real number for which you want the logarithm,  
base is the base of the logarithm. If base is omitted, it is assumed to be 10.

**LOG10:**
*Description:* Using the LOG10 function returns the base-10 logarithm of a number.

*General Syntax:*  
=LOG10(number)

*Arguments:*  
number is the positive real number for which you want the base-10 logarithm.

**MDETERM:**
*Description:* Using the MDETERM function returns the matrix determinant of an array.

*General Syntax:*  
=MDETERM(array)

*Arguments:*  
array is the numeric array that contains an equal number of columns and rows.

**MINVERSE:**
*Description:* Using the MINVERSE function returns the inverse matrix for the matrix stored in an array.

*General Syntax:*  
=MINVERSE(array)

*Arguments:*  
array is the numeric array that contains an equal number of columns and rows.
### MMULT:

**Description:**
Using the MMULT function returns the matrix product of two arrays. The result is an array with the same number of rows as `array1` and the same number of columns as `array2`.

**General Syntax:**
`=MMULT(array1, array2)`

**Arguments:**
- `array1`, `array2` are the arrays that you wish to multiply.

### MOD:

**Description:**
Using the MOD function returns the remainder after `number` is divided by `divisor`. The result has the same sign as `divisor`.

**General Syntax:**
`=MOD(number, divisor)`

**Arguments:**
- `number` is the number to divide by the `divisor`.
- `divisor` is the number by which you want to divide the `number`.

### MROUND:

**Description:**
Using the MROUND function returns a number rounded to the desired multiple.

**General Syntax:**
`=MROUND(number, multiple)`

**Arguments:**
- `number` is the value to round.
- `multiple` is the multiple to which you want to round the `number`.

### MULTINOMIAL:

**Description:**
Using the MULTINOMIAL function returns the ratio of the factorial of a sum of values to the product of factorials.

**General Syntax:**
`=MULTINOMIAL(numbers)`

**Arguments:**
- `numbers` are 1 to 29 comma-separated values for which you want the multinomial.

### MUNIT:

**Description:**
Using the MUNIT function returns the unit matrix for the specified dimension.

**General Syntax:**
`=MUNIT(dimension)`

**Arguments:**
- `dimension` is an integer specifying the dimension of the unit matrix that you want to return. It returns an array. The dimension has to be greater than zero.

### ODD:

**Description:**
Using the ODD function returns the `number` rounded up to the nearest odd integer.

**General Syntax:**
`=ODD(number)`

**Arguments:**
- `number` is the number to round.

### PI:

**Description:**
Using the PI function returns the number 3.14159265358979, the mathematical constant pi, accurate to 15 digits.

**General Syntax:**
`=PI()`

**Arguments:**
- none.
POWER:
Description: Using the POWER function returns the result of a number raised to a power.
General Syntax: =POWER(number,power)
Arguments: number is the base number that you want to raise to the specified power.
           power is the exponent to which the number is raised.

PRODUCT:
Description: Using the PRODUCT function multiplies all numbers and returns the product.
General Syntax: =PRODUCT(numbers)
Arguments: numbers are a comma-separated list of 1 to 255 values that you want to multiply.

QUOTIENT:
Description: Using the QUOTIENT function returns the integer portion of a division. Use this function when you want to discard the remainder of a division.
General Syntax: =QUOTIENT(numerator,demonimator)
Arguments: numerator is the number that you want to divide.
           denominator is the number by which you want to divide the numerator.

RADIANS:
Description: Using the RADIANS function converts an angle (in degrees) to radians.
General Syntax: =RADIANS(angle)
Arguments: angle is the number (in degrees) of the angle that you want to convert.

RAND:
Description: Using the RAND function returns an evenly distributed random number greater than or equal to 0 and less than 1. A new random number is returned every time the worksheet is calculated.
General Syntax: =RAND()
Arguments: none.

RANDBETWEEN:
Description: Using the RANDBETWEEN function returns a random number between the numbers you specify. A new random number is returned every time the worksheet is calculated.
General Syntax: =RANDBETWEEN(bottom,top)
Arguments: bottom is the lowest number possibly generated.
           top is the highest number possibly generated.
### ROMAN:

**Description:**
Using the ROMAN function converts an Arabic numeral to Roman, as a text value.

**General Syntax:**
\[=\text{ROMAN}(\text{number}, \text{form})\]

**Arguments:**
- **Number** is the Arabic number that you want to convert.
- **form** is an optional number argument that, if omitted, assumes 0, and provides the "Classic" Roman number format. You may use the numbers 1 to 4 for a more concise expression of the value, if needed.

### ROUND:

**Description:**
Using the ROUND function rounds a number to a specified number of digits.

**General Syntax:**
\[=\text{ROUND}(\text{number}, \text{decimals})\]

**Arguments:**
- **number** is the number to round.
- **decimals** is the number of digits to display after the decimal point. If negative, rounds to the left of the decimal point.

### ROUNDDOWN:

**Description:**
Using the ROUNDDOWN function rounds a number “down,” or towards zero.

**General Syntax:**
\[=\text{ROUNDDOWN}(\text{number}, \text{decimals})\]

**Arguments:**
- **number** is the number to round.
- **decimals** is the number of digits to display after the decimal point. If negative, rounds to the left of the decimal point.

### ROUNDUP:

**Description:**
Using the ROUNDUP function rounds a number “up,” or away from zero.

**General Syntax:**
\[=\text{ROUNDUP}(\text{number}, \text{decimals})\]

**Arguments:**
- **number** is the number to round.
- **decimals** is the number of digits to display after the decimal point. If negative, rounds to the left of the decimal point.

### SEC:

**Description:**
Using the SEC function returns the secant of an angle.

**General Syntax:**
\[=\text{SEC}(\text{number})\]

**Arguments:**
- **number** is the angle in radians for which you want the secant.

### SECH:

**Description:**
Using the SECH function returns the hyperbolic secant of an angle.

**General Syntax:**
\[=\text{SECH}(\text{number})\]

**Arguments:**
- **number** is the angle in radians for which you want the hyperbolic secant.
SERIESSUM:
Description: The SERIESSUM function returns the sum of a power series based on the following:
\[ \text{SERIES}(x, n, m, a) = a_1 x^n + a_2 x^{(n+m)} + a_3 x^{(n+2m)} + \ldots + a_i x^{(n+(i-1)m)} \]
General Syntax: =SERIESSUM(x, n, m, coefficients)
Arguments: x is the input value to the power series. n is the initial power to which you want to raise x. m is the step by which to increase n for each term in the series. coefficients is the set of coefficients by which each successive power of x is multiplied. The number of values in coefficients determines the number of terms in the power series.

SIGN:
Description: Using the SIGN function returns a 1 if the number is positive, a 0 if the number is zero, and a -1 if the number is negative.
General Syntax: =SIGN(number)
Arguments: number is the number for which you want the sign.

SIN:
Description: Using the SIN function returns the sine of a given angle.
General Syntax: =SIN(angle)
Arguments: angle is the number (in radians) of the angle for which you want the sine.

SINH:
Description: Using the SINH function returns the hyperbolic sine of a number.
General Syntax: =SINH(number)
Arguments: number is any real number.

SQRT:
Description: Using the SQRT function returns a positive square root.
General Syntax: =SQRT(number)
Arguments: number is the number for which you want the square root.

SQRTPI:
Description: Using the SQRTPI function returns the square root of (number * pi).
General Syntax: =SQRTPI(number)
Arguments: number is the number by which pi is multiplied.
Glossary of Functions

SUBTOTAL:
Description: Using the SUBTOTAL function returns a subtotal in a table or database.
General Syntax: =SUBTOTAL(function_num,refs)
Arguments:
function_num is a number that determines which function to use and whether or not the function should include or ignore hidden values in a table.

<table>
<thead>
<tr>
<th>function</th>
<th>includes hidden</th>
<th>excludes hidden</th>
</tr>
</thead>
<tbody>
<tr>
<td>AVERAGE</td>
<td>1</td>
<td>101</td>
</tr>
<tr>
<td>COUNT</td>
<td>2</td>
<td>102</td>
</tr>
<tr>
<td>COUNTA</td>
<td>3</td>
<td>103</td>
</tr>
<tr>
<td>MAX</td>
<td>4</td>
<td>104</td>
</tr>
<tr>
<td>MIN</td>
<td>5</td>
<td>105</td>
</tr>
<tr>
<td>PRODUCT</td>
<td>6</td>
<td>106</td>
</tr>
<tr>
<td>STDEV</td>
<td>7</td>
<td>107</td>
</tr>
<tr>
<td>STDEVP</td>
<td>8</td>
<td>108</td>
</tr>
<tr>
<td>SUM</td>
<td>9</td>
<td>109</td>
</tr>
<tr>
<td>VAR</td>
<td>10</td>
<td>110</td>
</tr>
<tr>
<td>VARP</td>
<td>11</td>
<td>111</td>
</tr>
</tbody>
</table>
refs is a comma-separated listing of 1 to 29 ranges or references for which you want the subtotal. Note that if you have nested subtotals in these ranges, they are ignored by this function to avoid duplication of values.

SUM:
Description: Using the SUM function adds the numbers in a range of cells.
General Syntax: =SUM(numbers)
Arguments:
numbers is a comma-separated list of numbers or references which you want to add.

SUMIF:
Description: Using the SUMIF function adds the numbers in cells that match a specified criteria.
General Syntax: =SUMIF(range,criteria,sum_range)
Arguments:
range is the range of cells which you want to match against the criteria.
criteria is the criteria against which you wish to match the values in the range.
sum_range is the range of cells to add.

SUMIFS:
Description: Using the SUMIFS function adds the numbers in cells that match multiple criteria.
General Syntax: =SUMIFS(sum_range, criteria_range1, criteria1, criteria_range2, criteria2, ...)
Arguments:
sum_range is one or more cells to sum, including numbers or names, ranges, or cell references that contain numbers. Blank and text values are ignored.
criteria_range1 is the first range in which to evaluate the associated criteria.
criteria1 is the criteria in the form of a number, expression, cell reference, or text that define which cells in the criteria_range1 argument will be added.
criteria_range2, criteria2, ... are the optional, additional ranges and their associated criteria. Up to 127 range/criteria pairs are allowed.
# Glossary of Functions

## SUMPRODUCT:

**Description:** Using the SUMPRODUCT function multiplies corresponding components in the given arrays, and returns the sum of those products.

**General Syntax:**

\[ =\text{SUMPRODUCT}(\text{array1, array2, ...}) \]

**Arguments:**

array1, array2... is the list of arrays whose components you wish to multiply and then add together.

## SUMSQ:

**Description:** Using the SUMSQ function returns the sum of the squares of the arguments.

**General Syntax:**

\[ =\text{SUMSQ}(\text{numbers}) \]

**Arguments:**

numbers is a comma-separated list of 1 to 255 arguments or an array for which you want the sum of the squares.

## SUMX2MY2:

**Description:** Using the SUMX2MY2 function returns the sum of the difference of squares of corresponding values in two arrays.

**General Syntax:**

\[ =\text{SUMX2MY2}(\text{array1, array2}) \]

**Arguments:**

array1 is the first array or range of values.
array2 is the second array or range of values.

## SUMX2PY2:

**Description:** Using the SUMX2PY2 function returns the sum of the sum of squares of corresponding values in two arrays. The sum of the sum of squares is a common term in many statistical calculations.

**General Syntax:**

\[ =\text{SUMX2PY2}(\text{array1, array2}) \]

**Arguments:**

array1 is the first array or range of values.
array2 is the second array or range of values.

## SUMXMY2:

**Description:** Using the SUMXMY2 function returns the sum of squares of differences of corresponding values in two arrays.

**General Syntax:**

\[ =\text{SUMXMY2}(\text{array1, array2}) \]

**Arguments:**

array1 is the first array or range of values.
array2 is the second array or range of values.

## TAN:

**Description:** Using the TAN function returns the tangent of a given angle.

**General Syntax:**

\[ =\text{TAN}(\text{angle}) \]

**Arguments:**

angle is the number (in radians) of the angle for which you want the tangent.
TANH:

Description: Using the TANH function returns the hyperbolic tangent of a number.

General Syntax: =TANH(number)

Arguments: number is any real number.

TRUNC:

Description: Using the TRUNC function truncates a number to an integer by removing the fractional part of the number.

General Syntax: =TRUNC(number,decimals)

Arguments: number is the number that you want to truncate.
           decimals is the number that specifies the precision of the truncation. If omitted, is 0.
**Glossary of Functions**

**AVEDEV:**

*Description:* Using the AVERAGE function returns the average of the absolute deviations of data points from their mean.

*General Syntax:* =AVEDEV(numbers)

*Arguments:* numbers is a comma-separated list of 1 to 255 arguments for which you want the average of the absolute deviations.

---

**AVERAGE:**

*Description:* Using the AVERAGE function returns the average (arithmetic mean) of the arguments.

*General Syntax:* =AVERAGE(numbers)

*Arguments:* numbers is a comma-separated list of 1 to 255 arguments for which you want the average.

---

**AVERAGEA:**

*Description:* Using the AVERAGEA function returns the average (arithmetic mean) of the values in the list of arguments. In addition to numbers, text and logical values such as TRUE and FALSE are included in the calculation.

*General Syntax:* =AVERAGEA(numbers)

*Arguments:* numbers is a comma-separated list of 1 to 255 arguments for which you want the average.

---

**AVERAGEIF:**

*Description:* Using the AVERAGEIF function the average (arithmetic mean) of all the cells in a range that meet a given criteria.

*General Syntax:* =AVERAGEIF(range, criteria, average_range)

*Arguments:* range is the range of cells to average,

criteria is the criteria criteria in the form of a number, expression, cell reference, or text that defines which cells in the range are averaged.

average_range is the actual set of cells to average. If omitted, range is used.

---

**AVERAGEIFS:**

*Description:* Using the AVERAGEIFS function the average (arithmetic mean) of all the cells in a range that meet multiple criteria.

*General Syntax:* =AVERAGEIFS(average_range, criteria_range1, criteria1, criteria_range2, criteria2, …)

*Arguments:* average_range is one or more cells to average, including numbers or names, ranges, or cell references that contain numbers. Blank and text values are ignored.

criteria_range1 is the first range in which to evaluate the associated criteria.

criteria1 is the criteria in the form of a number, expression, cell reference, or text that define which cells in the criteria_range1 argument will be averaged.

criteria_range2, criteria2, … are the optional, additional ranges and their associated criteria. Up to 127 range/criteria pairs are allowed.
Glossary of Functions

**BETA.DIST:**

Description: Using the BETA.DIST function returns the beta distribution.

General Syntax: 

=BETA.DIST(x,alpha,beta, cumulative,a,b)

Arguments: 

- x is the value between a and b at which to evaluate the function.
- alpha is a parameter of the distribution.
- beta is a parameter of the distribution.
- cumulative is a logical value that determines the form of the function. If TRUE, it returns the cumulative distribution function; if FALSE, it returns the probability density function.
- a is an optional lower bound to the interval x.
- b is an optional upper bound to the interval x.

**BETA.INV:**

Description: Using the BETA.INV function returns the inverse of the beta cumulative probability density function (BETA.DIST). If probability = BETA.DIST(x,...,TRUE), then BETA.INV(probability,...) = x. The beta distribution can be used in project planning to model probable completion times given an expected completion time and variability.

General Syntax: 

=BETA.INV(probability,alpha,beta,a,b)

Arguments: 

- probability is a probability associated with the beta distribution.
- alpha is a parameter of the distribution.
- beta is a parameter of the distribution.
- a is an optional lower bound to the interval x.
- b is an optional upper bound to the interval x.

**BINOM.DIST:**

Description: Using the BINOM.DIST function returns the individual term binomial distribution probability. Use BINOM.DIST in problems with a fixed number of tests or trials, when the outcomes of any trial are only success or failure, when trials are independent, and when the probability of success is constant throughout the experiment.

General Syntax: 

=BINOM.DIST(succcess_num; trials; probability; cumulative)

Arguments: 

- success_num is the number of successes in trials.
- trials is the number of independent trials.
- probability is the probability of success on each trial.
- cumulative is a logical value that determines the form of the function. If cumulative is TRUE, then BINOM.DIST returns the cumulative distribution function, which is the probability that there are at most success_num successes; if FALSE, it returns the probability mass function, which is the probability that there are success_num successes.

**BINOM.DIST.RANGE:**

Description: Using the BINOM.DIST.RANGE function returns the probability of a trial result using a binomial distribution.

General Syntax: 

=BINOM.DIST.RANGE(trials, probability, number, number1)

Arguments: 

- trials is the number of independent trials.
- probability is the probability of success on each trial.
- number is the number of successes in trials.
- number1 is optional. If provided, returns the probability that the number of successful trials will fall between number and number1.
**BINOM.INV:**

*Description:* Using the BINOM.INV function returns the smallest value for which the cumulative binomial distribution is greater than or equal to a criterion value.

*General Syntax:*  
=BINOM.INV(trials, probability, alpha)

*Arguments:*  
- **trials** is the number of Bernoulli trials.  
- **probability** is the probability of success on each trial.  
- **alpha** is the criterion value.

**CHISQ.DIST:**

*Description:* Using the CHISQ.DIST function returns the chi-squared distribution. The chi-squared distribution is commonly used to study variation in the percentage of something across samples, such as the fraction of the day people spend watching television.

*General Syntax:*  
=CHISQ.DIST(x, degrees, cumulative)

*Arguments:*  
- **x** is the values at which you want to evaluate the distribution.  
- **degrees** is the number of degrees of freedom to use.  
- **cumulative** is a logical value that determines the form of the function. If TRUE, CHISQ.DIST returns the cumulative distribution function; if FALSE, it returns the probability density function.

**CHISQ.DIST.RT:**

*Description:* Using the CHISQ.DIST.RT function returns the right-tailed probability of the chi-squared distribution. The $\chi^2$ distribution is associated with a $\chi^2$ test. Use the $\chi^2$ test to compare observed and expected values.

*General Syntax:*  
=CHISQ.DIST.RT(x, degrees)

*Arguments:*  
- **x** is the values at which you want to evaluate the distribution.  
- **degrees** is the number of degrees of freedom to use.

**CHISQ.INV:**

*Description:* Using the CHISQ.INV function returns the inverse of the left-tailed probability of the chi-squared distribution.

*General Syntax:*  
=CHISQ.INV(probability, degrees)

*Arguments:*  
- **probability** is a probability associated with the chi-squared distribution.  
- **degrees** is the number of degrees of freedom to use.

**CHISQ.INV.RT:**

*Description:* Using the CHISQ.INV.RT function returns the inverse of the right-tailed probability of the chi-squared distribution.

*General Syntax:*  
=CHISQ.INV.RT(probability, degrees)

*Arguments:*  
- **probability** is a probability associated with the chi-squared distribution.  
- **degrees** is the number of degrees of freedom to use.
CHISQ.TEST:

Description: Using the CHISQ.TEST function returns the test for independence. CHISQ.TEST returns the value from the chi-squared ($\chi^2$) distribution for the statistic and the appropriate degrees of freedom. You can use $\chi^2$ tests to determine whether hypothesized results are verified by an experiment.

General Syntax: 
=CHISQ.TEST(actual_range, expected_range)

Arguments: 
actual_range is the range of data that contains observations to test against expected values.
expected_range is the range of data that contains the ratio of the product of row totals and column totals to the grand total.

CONFIDENCE.NORM:

Description: Using the CONFIDENCE.NORM function returns the confidence interval for a population mean, using a normal distribution. The confidence interval is a range of values. Your sample mean, $\bar{x}$, is at the center of this range and the range is $\bar{x} \pm$ CONFIDENCE.NORM.

General Syntax: 
=CONFIDENCE.NORM(alpha, st_dev, size)

Arguments: 
alpha is the significance level used to compute the confidence level. The confidence level equals 100*(1 - alpha)%, or in other words, an alpha of 0.05 indicates a 95 percent confidence level.
st_dev is the population standard deviation for the data range and is assumed to be known.
size is the sample size.

CONFIDENCE.T:

Description: Using the CONFIDENCE.T function returns the confidence interval for a population mean, using a Student's t distribution.

General Syntax: 
=CONFIDENCE.T(alpha, st_dev, size)

Arguments: 
alpha is the significance level used to compute the confidence level. The confidence level equals 100*(1 - alpha)%, or in other words, an alpha of 0.05 indicates a 95 percent confidence level.
st_dev is the population standard deviation for the data range and is assumed to be known.
size is the sample size.

CORREL:

Description: Using the CORREL function returns the correlation coefficient of the array1 and array2 cell ranges. Use the correlation coefficient to determine the relationship between two properties.

General Syntax: 
=CORREL(array1, array2)

Arguments: 
array1 is the first array or range of values.
array2 is the second array or range of values.

COUNT:

Description: Using the COUNT function counts the number of cells that contain numbers and also numbers within the list of arguments.

General Syntax: 
=COUNT(numbers)

Arguments: 
numbers is a comma-separated list of 1 to 255 arguments.
## Glossary of Functions

### COUNTA:

**Description:**
Using the COUNTA function counts the number of cells that are not empty and the values within the list of arguments. Use COUNTA to count the number of cells that contain data in a range or array.

**General Syntax:**
=COUNTA(numbers)

**Arguments:**
- **numbers** are 1 to 255 arguments representing the values you want to count. In this case, a value is any type of information, including empty text ("") but not including empty cells.

### COUNTBLANK:

**Description:**
Using the COUNTBLANK function counts empty cells in a specified range of cells.

**General Syntax:**
=COUNTBLANK(range)

**Arguments:**
- **range** is the range in which you want to count the blank cells.

### COUNTIF:

**Description:**
Using the COUNTIF function counts the number of cells within a range that meet the given criteria.

**General Syntax:**
=COUNTIF(range,criteria)

**Arguments:**
- **range** is the range in which you want to count the blank cells.
- **criteria** is the criteria that defines the cells to be counted.

### COUNTIFS:

**Description:**
Using the COUNTIFS function counts the number of cells within a range that meet multiple criteria.

**General Syntax:**
=COUNTIFS(criteria_range1, criteria1, criteria_range2, criteria2, …)

**Arguments:**
- **criteria_range1** is the first range in which to evaluate the associated criteria.
- **criteria1** is the criteria in the form of a number, expression, cell reference, or text that define which cells in the **criteria_range1** argument will be counted.
- **criteria_range2, criteria2, …** are the optional, additional ranges and their associated criteria. Up to 127 range/criteria pairs are allowed.

### COVARIANCE.P:

**Description:**
Using the COVARIANCE.P function returns population covariance, the average of the products of deviations for each data point pair in two data sets. Use covariance to determine the relationship between two data sets.

**General Syntax:**
=COVARIANCE.P(array1, array2)

**Arguments:**
- **array1** is the first cell range of integers.
- **array2** is the second cell range of integers.

### COVARIANCE.S:

**Description:**
Using the COVARIANCE.S function returns the sample covariance, the average of the products of deviations for each data point pair in two data sets.

**General Syntax:**
=COVARIANCE.S(array1, array2)

**Arguments:**
- **array1** is the first cell range of integers.
- **array2** is the second cell range of integers.
**DEVSQ:**

*Description:* Using the DEVSQ function returns the sum of squares of deviations of data points from their sample mean.

*General Syntax:* 

\[ =\text{DEVSQ}(\text{numbers}) \]

*Arguments:* 

`numbers` are 1 to 255 comma-separated arguments for which you want to calculate the sum of squared deviations. You can also use a single array instead.

**EXPON.DIST:**

*Description:* Using the EXPON.DIST function returns the exponential distribution. Use EXPON.DIST to model the time between events.

*General Syntax:* 

\[ =\text{EXPON.DIST}(x, \lambda, \text{cumulative}) \]

*Arguments:* 

`x` is the value of the function. 
`\lambda` is the parameter value. 
`cumulative` is a logical value that indicates which form of the exponential function to provide. If cumulative is TRUE, it returns the cumulative distribution function; if FALSE, it returns the probability density function.

**F.DIST:**

*Description:* Using the F.DIST function returns the F probability distribution. You can use this function to determine whether two data sets have different degrees of diversity.

*General Syntax:* 

\[ =\text{F.DIST}(x, f_{\text{degrees}1}, f_{\text{degrees}2}, \text{cumulative}) \]

*Arguments:* 

`x` is the value at which the function is evaluated. 
`f_{\text{degrees}1}` is the numerator’s degrees of freedom. 
`f_{\text{degrees}2}` is the denominator’s degrees of freedom. 
`cumulative` is a logical value that indicates which form of the exponential function to provide. If cumulative is TRUE, it returns the cumulative distribution function; if FALSE, it returns the probability density function.

**F.DIST.RT:**

*Description:* Using the F.DIST.RT function returns the (right-tailed) F probability distribution (degree of diversity) for two data sets.

*General Syntax:* 

\[ =\text{F.DIST.RT}(x, f_{\text{degrees}1}, f_{\text{degrees}2}) \]

*Arguments:* 

`x` is the value at which the function is evaluated. 
`f_{\text{degrees}1}` is the numerator’s degrees of freedom. 
`f_{\text{degrees}2}` is the denominator’s degrees of freedom.

**F.INV:**

*Description:* Using the F.INV function returns the inverse of the F probability distribution. If \( p = \text{F.DIST}(x,...) \), then \( \text{F.INV}(p,...) = x \). The F distribution can be used in an F-test that compares the degree of variability in two data sets.

*General Syntax:* 

\[ =\text{F.INV}(\text{probability}, f_{\text{degrees}1}, f_{\text{degrees}2}) \]

*Arguments:* 

`probability` is a probability associated with the F cumulative distribution. 
`f_{\text{degrees}1}` is the numerator’s degrees of freedom. 
`f_{\text{degrees}2}` is the denominator’s degrees of freedom.
## Glossary of Functions

### F.INV:
**Description:**
Using the F.INV function returns the inverse of the F probability distribution. If \( p = F.DIST(x, \ldots) \), then \( F.INV(p, \ldots) = x \).

The F distribution can be used in an F-test that compares the degree of variability in two data sets.

**General Syntax:**
\[
F.INV(probability, f\_degrees1, f\_degrees2)
\]

**Arguments:**
- **probability** is a probability associated with the F cumulative distribution.
- **f\_degrees1** is the numerator's degrees of freedom.
- **f\_degrees2** is the denominator's degrees of freedom.

### F.TEST:
**Description:**
Using the F.TEST function returns the result of an F-test, the two-tailed probability that the variances in array1 and array2 are not significantly different.

**General Syntax:**
\[
F.TEST(array1, array2)
\]

**Arguments:**
- **array1** is the first array or range of data.
- **array2** is the second array or range of data

### FISHER:
**Description:**
Using the FISHER function returns the Fisher transformation at \( x \). This transformation produces a function that is normally distributed rather than skewed. Use this function to perform hypothesis testing on the correlation coefficient.

**General Syntax:**
\[
FISHER(x)
\]

**Arguments:**
- **x** is a numeric value for which you want the transformation.

### FISHERINV:
**Description:**
Using the FISHERINV function returns the inverse of the Fisher transformation. Use this transformation when analyzing correlations between ranges or arrays of data.

**General Syntax:**
\[
FISHERINV(y)
\]

**Arguments:**
- **y** is the value for which you want to perform the inverse of the transformation.

### FORECAST:
**Description:**
Using the FORECAST function calculates, or predicts, a future value by using existing values. The predicted value is a \( y \)-value for a given \( x \)-value. The known values are existing \( x \)-values and \( y \)-values, and the new value is predicted by using linear regression. You can use this function to predict future sales, inventory requirements, or consumer trends.

**General Syntax:**
\[
FORECAST(x, known\_y, known\_x)
\]

**Arguments:**
- **x** is the data point for which you want to predict a value.
- **known\_y** is the dependent array or range of data.
- **known\_x** is the independent array or range of data.
### FREQUENCY:
**Description:** Using the FREQUENCY function calculates how often values occur within a range of values, and then returns a vertical array of numbers.

**General Syntax:**
\[=\text{FREQUENCY}(\text{data	extunderscore array}, \text{bins	extunderscore array})\]

**Arguments:**
- `data_array` is an array of or reference to a set of values for which you want to count frequencies.
- `bins_array` is an array of or reference to intervals into which you want to group the values in `data_array`.

### GAMMA:
**Description:** Using the GAMMA function returns the gamma function value.

**General Syntax:**
\[=\text{GAMMA}(\text{number})\]

**Arguments:**
- `number` is the number for which you want the gamma function value returned.

### GAMMA.DIST:
**Description:** Using the GAMMA.DIST function returns the gamma distribution. You can use this function to study variables that may have a skewed distribution. The gamma distribution is commonly used in queuing analysis.

**General Syntax:**
\[=\text{GAMMA.DIST}(x, \alpha, \beta, \text{cumulative})\]

**Arguments:**
- `x` is the value at which to evaluate the function.
- `alpha` is a parameter to the distribution.
- `beta` is a parameter to the distribution. If `beta = 1`, it returns the standard gamma distribution.
- `cumulative` is a logical value that determines the form of the function. If `cumulative` is TRUE, it returns the cumulative distribution function; if FALSE, it returns the probability density function.

### GAMMA.INV:
**Description:** Using the GAMMA.INV function returns the inverse of the gamma cumulative distribution. If `p = \text{GAMMA.DIST}(\ldots)`, then `\text{GAMMA.INV}(p, \ldots) = x`. You can use this function to study a variable whose distribution may be skewed.

**General Syntax:**
\[=\text{GAMMA.INV}(\text{probability}, \alpha, \beta)\]

**Arguments:**
- `probability` is the probability associated with the gamma distribution.
- `alpha` is a parameter to the distribution.
- `beta` is a parameter to the distribution. If `beta = 1`, it returns the standard gamma distribution.

### GAMMALN:
**Description:** Using the GAMMALN function returns the natural logarithm of the gamma function, \(\Gamma(x)\).

**General Syntax:**
\[=\text{GAMMALN}(x)\]

**Arguments:**
- `x` is the value for which you want to calculate GAMMALN.

### GAMMALN.PRECISE:
**Description:** Using the GAMMALN.PRECISE function returns the natural logarithm of the gamma function, \(\Gamma(x)\).

**General Syntax:**
\[=\text{GAMMALN.PRECISE}(x)\]

**Arguments:**
- `x` is the value for which you want to calculate GAMMALN.PRECISE.
**GAUSS:**

**Description:** Using the GAUSS function calculates the probability that a member of a standard normal population will fall between the mean and \( x \) standard deviations from the mean.

**General Syntax:**

\[ =\text{GAUSS}(x) \]

**Arguments:**

\( x \) is the number of standard deviations from the mean.

---

**GEOMEAN:**

**Description:** Using the GEOMEAN function returns the geometric mean of an array or range of positive data.

**General Syntax:**

\[ =\text{GEOMEAN}(\text{numbers}) \]

**Arguments:**

\text{numbers} is a comma-separated list of numbers for which you want to calculate the mean. You can also use an array reference, if desired.

---

**GROWTH:**

**Description:** Using the GROWTH function calculates predicted exponential growth by using existing data. GROWTH returns the \( y \)-values for a series of new \( x \)-values that you specify by using existing \( x \)-values and \( y \)-values. You can also use the GROWTH worksheet function to fit an exponential curve to existing \( x \)-values and \( y \)-values.

**General Syntax:**

\[ =\text{GROWTH}(\text{known}_y's, \text{known}_x's, \text{new}_x's, \text{const}) \]

**Arguments:**

\text{known}_y's is the set of \( y \)-values you already know in the relationship \( y = b*m^x \). If the array \text{known}_y's is in a single column, then each column of \text{known}_x's is interpreted as a separate variable. If the array \text{known}_y's is in a single row, then each row of \text{known}_x's is interpreted as a separate variable. If any of the numbers in \text{known}_y's is 0 or negative, GROWTH returns the #NUM! error value.

\text{known}_x's is an optional set of \( x \)-values that you may already know in the relationship \( y = b*m^x \). The array \text{known}_x's can include one or more sets of variables. If only one variable is used, \text{known}_y's and \text{known}_x's can be ranges of any shape, as long as they have equal dimensions. If more than one variable is used, \text{known}_y's must be a vector (that is, a range with a height of one row or a width of one column). If \text{known}_x's is omitted, it is assumed to be the array \{1,2,3,...\} that is the same size as \text{known}_y's.

\text{new}_x's are new \( x \)-values for which you want GROWTH to return corresponding \( y \)-values. \text{new}_x's must include a column (or row) for each independent variable, just as \text{known}_x's does. So, if \text{known}_y's is in a single column, \text{known}_x's and \text{new}_x's must have the same number of columns. If \text{known}_y's is in a single row, \text{known}_x's and \text{new}_x's must have the same number of rows. If \text{new}_x's is omitted, it is assumed to be the same as \text{known}_x's. If both \text{known}_x's and \text{new}_x's are omitted, they are assumed to be the array \{1,2,3,...\} that is the same size as \text{known}_y's.

\text{const} is a logical value specifying whether to force the constant \( b \) to equal 1. If \text{const} is TRUE or omitted, \( b \) is calculated normally. If \text{const} is FALSE, \( b \) is set equal to 1 and the \( m \)-values are adjusted so that \( y = m^x \).

---

**HARMEAN:**

**Description:** Using the HARMEAN function returns the harmonic mean of a data set. The harmonic mean is the reciprocal of the arithmetic mean of reciprocals.

**General Syntax:**

\[ =\text{HARMEAN}(\text{numbers}) \]

**Arguments:**

\text{numbers} is a comma-separated list of numbers for which you want to calculate the mean. You can also use an array reference, if desired.
**Glossary of Functions**

**HYPGEOM.DIST:**

*Description:* Using the HYPGEOM.DIST function returns the hypergeometric distribution. HYPGEOM.DIST returns the probability of a given number of sample successes, given the sample size, population successes, and population size. Use HYPGEOM.DIST for problems with a finite population, where each observation is either a success or a failure, and where each subset of a given size is chosen with equal likelihood.

*General Syntax:* =HYPGEOM.DIST(sample_s, number_sample, population_s, number_population, cumulative)

*Arguments:*
- `sample_s` is the number of successes in the sample.
- `number_sample` is the size of the sample.
- `population_s` is the number of successes in the population.
- `number_population` is the population size.
- `cumulative` is a logical value that determines the form of the function. If TRUE, then HYPGEOM.DIST returns the cumulative distribution function; if FALSE, it returns the probability mass function.

**INTERCEPT:**

*Description:* Using the INTERCEPT function calculates the point at which a line will intersect the y-axis by using existing x-values and y-values. The intercept point is based on a best-fit regression line plotted through the known x-values and known y-values. Use the INTERCEPT function when you want to determine the value of the dependent variable when the independent variable is 0 (zero).

*General Syntax:* =INTERCEPT(known_y's, known_x's)

*Arguments:*
- `known_y's` is the dependent set of observations or data.
- `known_x's` is the independent set of observations or data.

**KURT:**

*Description:* Using the KURT function returns the kurtosis of a data set. Kurtosis characterizes the relative peakedness or flatness of a distribution compared with the normal distribution. Positive kurtosis indicates a relatively peaked distribution. Negative kurtosis indicates a relatively flat distribution.

*General Syntax:* =KURT(numbers)

*Arguments:*
- `numbers` is a comma-separated list of numbers for which you want to calculate the mean. You can also use an array reference, if desired.

**LARGE:**

*Description:* Using the LARGE function Returns the k-th largest value in a data set. You can use this function to select a value based on its relative standing. For example, you can use LARGE to return the highest, runner-up, or third-place score.

*General Syntax:* =LARGE(array,k)

*Arguments:*
- `array` is the array or range of data for which you want to determine the k-th largest value.
- `k` is the position (from the largest) in the array or cell range of data to return.
**Glossary of Functions**

**LINEST:**

*Description:* Using the LINEST function calculates the statistics for a line by using the “least squares” method to calculate a straight line that best fits your data, and returns an array that describes the line. Because this function returns an array of values, it must be entered as an array formula. The equation for the line is: \( y = mx + b \) or \( y = m_1 x^1 + m_2 x^2 + ... + b \) (if there are multiple ranges of x-values) where the dependent y-value is a function of the independent x-values. The m-values are coefficients corresponding to each x-value, and b is a constant value. Note that y, x, and m can be vectors. The array that LINEST returns is \( \{ mn, mn-1,..., m, b \} \). LINEST can also return additional regression statistics.

*General Syntax:* 

\[ =\text{LINEST}(\text{known}_y's, \text{known}_x's, \text{const}, \text{stats}) \]

*Arguments:*

- **known_y's** is the set of y-values you already know in the relationship \( y = mx + b \). If the array is in a single column, then each column of known_x's is interpreted as a separate variable. If the array is in a single row, then each row of known_x's is interpreted as a separate variable.
- known_x's is an optional set of x-values that you may already know in the relationship \( y = mx + b \). The array can include one or more sets of variables. If only one variable is used, known_y's and known_x's can be ranges of any shape, as long as they have equal dimensions. If more than one variable is used, known_y's must be a vector (that is, a range with a height of one row or a width of one column). If known_x's is omitted, it is assumed to be the array \( \{ 1,2,3,... \} \) that is the same size as known_y's.
- **const** is a logical value specifying whether to force the constant b to equal 0. If const is TRUE or omitted, b is calculated normally. If const is FALSE, b is set equal to 0 and the m-values are adjusted to fit \( y = mx \).
- **stats** is a logical value specifying whether to return additional regression statistics. If stats is TRUE, LINEST returns the additional regression statistics, so the returned array is \( \{ mn,mn-1,...,m,1,b ; sen, sen-1,..., se1, sebr, sey ; F, df, ssreg, ssresid \} \). If stats is FALSE or omitted, LINEST returns only the m-coefficients and the constant b. The additional regression statistics are as follows:

*Statistic:*

- **se1, se2, ..., sen**
- **seb**
- **r2**
- **sey**
- **F**
- **df**
- **ssreg**
- **ssresid**

*Description:*

- The standard error values for the coefficients \( m_1, m_2, ..., mn \).
- The standard error value for the constant b (seb = #N/A when const is FALSE).
- The coefficient of determination. Compares estimated and actual y-values, and ranges in value from 0 to 1. If it is 1, there is a perfect correlation in the sample—there is no difference between the estimated y-value and the actual y-value. At the other extreme, if the coefficient of determination is 0, the regression equation is not helpful in predicting a y-value.
- The standard error for the y estimate.
- The F statistic, or the F-observed value. Use the F statistic to determine whether the observed relationship between the dependent and independent variables occurs by chance.
- The degrees of freedom. Use the degrees of freedom to help you find F-critical values in a statistical table. Compare the values you find in the table to the F statistic returned by LINEST to determine a confidence level for the model.
- The regression sum of squares.
- The residual sum of squares.
Glossary of Functions

LOGEST:

Description:
Using the LOGEST function calculates an exponential curve that fits your data and returns an array of values that describes the curve. Because this function returns an array of values, it must be entered as an array formula. The equation for the curve is: \( y = b \cdot m^x \) or \( y = (b \cdot (m^1 \cdot x1) \cdot (m^2 \cdot x2) \cdot \ldots) \) (if there are multiple x-values) where the dependent y-value is a function of the independent x-values. The m-values are bases corresponding to each exponent x-value, and b is a constant value. Note that y, x, and m can be vectors. The array that LOGEST returns is \((mn, mn-1, \ldots, m1, b)\).

General Syntax:
\[ \text{=LOGEST(known\_y's, known\_x's, const, stats)} \]

Arguments:
- **known\_y's** is the set of y-values you already know in the relationship \( y = mx + b \). If the array is in a single column, then each column of **known\_x's** is interpreted as a separate variable. If the array is in a single row, then each row of **known\_x's** is interpreted as a separate variable.
- **known\_x's** is an optional set of x-values that you may already know in the relationship \( y = mx + b \). The array can include one or more sets of variables. If only one variable is used, **known\_y's** and **known\_x's** can be ranges of any shape, as long as they have equal dimensions. If more than one variable is used, **known\_y's** must be a vector (that is, a range with a height of one row or a width of one column). If **known\_x's** is omitted, it is assumed to be the array \((1, 2, 3, \ldots)\) that is the same size as **known\_y's**.
- **const** is a logical value specifying whether to force the constant b to equal 1. If **const** is TRUE or omitted, b is calculated normally. If **const** is FALSE, b is set equal to 1 and the m-values are adjusted to fit \( y = m^x \).
- **stats** is a logical value specifying whether to return additional regression statistics. If **stats** is TRUE, LINEST returns the additional regression statistics, so the returned array is \{(mn, mn-1, \ldots, m1, b); sen, sen-1, \ldots, seb, seb\}; **F; df; ssreg, ssresid\}. If **stats** is FALSE or omitted, LINEST returns only the m-coefficients and the constant b. The additional regression statistics are as follows:

<table>
<thead>
<tr>
<th>Statistic:</th>
<th>Description:</th>
</tr>
</thead>
<tbody>
<tr>
<td>se1, se2, ..., sen</td>
<td>The standard error values for the coefficients ( m1, m2, \ldots, mn ).</td>
</tr>
<tr>
<td>seb</td>
<td>The standard error value for the constant ( b ) (seb = #N/A when <strong>const</strong> is FALSE).</td>
</tr>
<tr>
<td>r2</td>
<td>The coefficient of determination. Compares estimated and actual y-values, and ranges in value from 0 to 1. If it is 1, there is a perfect correlation in the sample—or there is no difference between the estimated y-value and the actual y-value. At the other extreme, if the coefficient of determination is 0, the regression equation is not helpful in predicting a y-value.</td>
</tr>
<tr>
<td>sey</td>
<td>The standard error for the y estimate.</td>
</tr>
<tr>
<td>F</td>
<td>The F statistic, or the F-observed value. Use the F statistic to determine whether the observed relationship between the dependent and independent variables occurs by chance.</td>
</tr>
<tr>
<td>df</td>
<td>The degrees of freedom. Use the degrees of freedom to help you find F-critical values in a statistical table. Compare the values you find in the table to the F statistic returned by LINEST to determine a confidence level for the model.</td>
</tr>
<tr>
<td>ssreg</td>
<td>The regression sum of squares.</td>
</tr>
<tr>
<td>ssresid</td>
<td>The residual sum of squares.</td>
</tr>
</tbody>
</table>

LOGNORM.DIST:

Description:
Using the LOGNORM.DIST function returns the lognormal distribution of x, where \( \ln(x) \) is normally distributed with parameters **mean** and **standard\_dev**.

General Syntax:
\[ \text{=LOGNORM.DIST(x, mean, standard\_dev, cumulative)} \]

Arguments:
- **x** is the value at which you want to evaluate the function.
- **mean** is the mean of \( \ln(x) \).
- **standard\_dev** is the standard deviation of \( \ln(x) \).
- **cumulative** is a logical value that determines the form of the function. If **TRUE**, LOGNORM.DIST returns the cumulative distribution function; if **FALSE**, it returns the probability density function.
LOGNORM.INV:
Description: Using the LOGNORM.INV function returns the inverse of the lognormal cumulative distribution function of x, where ln(x) is normally distributed with parameters mean and standard_dev. If p = LOGNORM.DIST(x,...) then LOGNORM.INV(p,...) = x.
General Syntax: =LOGNORM.INV(probability, mean, standard_dev)
Arguments:
probability is a probability associated with the lognormal distribution.
mean is the mean of ln(x).
standard_dev is the standard deviation of ln(x).

MAX:
Description: Using the MAX function returns the largest value in a set of values.
General Syntax: =MAX(numbers)
Arguments: numbers is a comma-separated list of 1 to 255 numbers for which you want to find the highest value.

MAXA:
Description: Using the MAXA function returns the largest value in a list of arguments. Text and logical values such as TRUE and FALSE are compared as well as numbers.
General Syntax: =MAXA(values)
Arguments: values is a comma-separated list of 1 to 255 values for which you want to find the largest value.

MEDIAN:
Description: Using the MEDIAN function returns the median of the given numbers. The median is the number in the middle of a set of numbers; that is, half the numbers have values that are greater than the median, and half have values that are less.
General Syntax: =MEDIAN(numbers)
Arguments: numbers is a comma-separated list of 1 to 255 numbers for which you want to find the median.

MIN:
Description: Using the MIN function returns the smallest value in a set of values.
General Syntax: =MIN(numbers)
Arguments: numbers is a comma-separated list of 1 to 255 numbers for which you want to find the lowest value.

MINA:
Description: Using the MINA function returns the smallest value in a list of arguments. Text and logical values such as TRUE and FALSE are compared as well as numbers.
General Syntax: =MINA(values)
Arguments: values is a comma-separated list of 1 to 255 values for which you want to find the smallest value.
Glossary of Functions

MODE.MULT:

Description:
Using the MODE.MULT function a vertical array of the most frequently occurring, or repetitive values in an array or range of data. For horizontal arrays, use TRANSPOSE(MODE.MULT(number1, number2,...)). This will return more than one result if there are multiple modes. Because this function returns an array of values, it must be entered as an array formula.

General Syntax:
=MODE.MULT(numbers)

Arguments:
numbers is a comma-separated list of 1 to 255 numbers for which you want to calculate the mode, a single array, or a reference to an array.

MODE.SNGL:

Description:
Using the MODE.SNGL function returns the most frequently occurring, or repetitive, value in an array or range of data.

General Syntax:
=MODE.SNGL(numbers)

Arguments:
numbers is a comma-separated list of 1 to 255 numbers for which you want to calculate the mode, a single array, or a reference to an array.

NEGBINOM.DIST:

Description:
Using the NEGBINOM.DIST function returns the negative binomial distribution, the probability that there will be number_f failures before the number_s success, with probability_s probability of a success. This function is similar to the binomial distribution, except that the number of successes is fixed, and the number of trials is variable. Like the binomial, trials are assumed to be independent.

General Syntax:
=NEGBINOM.DIST(number_f, number_s, probability_s, cumulative)

Arguments:
number_f is the number of failures.
number_s is the threshold number of successes.
probability_s is the probability of a success.
cumulative is a logical value that determines the form of the function. If cumulative is TRUE, NEGBINOM.DIST returns the cumulative distribution function; if FALSE, it returns the probability density function.

NORM.DIST:

Description:
Using the NORM.DIST function returns the normal distribution for the specified mean and standard deviation. This function has a very wide range of applications in statistics, including hypothesis testing.

General Syntax:
=NORM.DIST(x, mean, standard_dev, cumulative)

Arguments:
x is the value for which you want the distribution.
mean is the arithmetic mean of the distribution.
standard_dev is the standard deviation of the distribution.
cumulative is a logical value that determines the form of the function. If cumulative is TRUE, NORMDIST returns the cumulative distribution function; if FALSE, it returns the probability mass function.
Glossary of Functions

NORM.INV:
Description: Using the NORM.INV function returns the inverse of the normal cumulative distribution for the specified mean and standard deviation.

General Syntax: =NORM.INV(probability, mean, standard_dev)

Arguments: probability is a probability corresponding to the normal distribution. mean is the arithmetic mean of the distribution. standard_dev is the standard deviation of the distribution.

NORM.S.DIST:
Description: Using the NORM.S.DIST function returns the standard normal cumulative distribution function. The distribution has a mean of 0 (zero) and a standard deviation of one. Use this function in place of a table of standard normal curve areas.

General Syntax: =NORM.S.DIST(z, cumulative)

Arguments: z is the value for which you want the distribution. cumulative is a logical value that determines the form of the function. If cumulative is TRUE, NORM.S.DIST returns the cumulative distribution function; if FALSE, it returns the probability mass function.

NORM.S.INV:
Description: Using the NORM.S.INV function returns the inverse of the standard normal cumulative distribution. The distribution has a mean of zero and a standard deviation of one.

General Syntax: =NORM.S.INV(probability)

Arguments: probability is a probability corresponding to the normal distribution.

PEARSON:
Description: Using the PEARSON function returns the Pearson product moment correlation coefficient, r, a dimensionless index that ranges from -1.0 to 1.0 inclusive and reflects the extent of a linear relationship between two data sets.

General Syntax: =PEARSON(array1, array2)

Arguments: array1 is a set of independent values. array2 is a set of dependent values.

PERCENTILE.EXC:
Description: Using the PERCENTILE.EXC function returns the k percentile of values in a range, where k is in the range 0..1, exclusive.

General Syntax: =PERCENTILE.EXC(array, k)

Arguments: array is the array or range of data that defines relative standing. k is the percentile value in the range 0..1, exclusive.
Glossary of Functions

PERCENTILE.INC:
Description: Using the PERCENTILE.INC function returns the k percentile of values in a range, where k is in the range 0..1, inclusive.
General Syntax: =PERCENTILE.INC(array, k)
Arguments: array is the array or range of data that defines relative standing. k is the percentile value in the range 0..1, inclusive.

PERCENTRANK.EXC:
Description: Using the PERCENTRANK.EXC function returns the rank of a value in a data set as a percentage (0..1, exclusive) of the data set.
General Syntax: =PERCENTRANK.EXC(array, x, significance)
Arguments: array is the array or range of data with numeric values that defines relative standing. x is the value for which you want to know the rank. significance is an optional value that identifies the number of significant digits for the returned percentage value. If omitted, PERCENTRANK.EXC uses three digits (0.xxx).

PERCENTRANK.INC:
Description: Using the PERCENTRANK.INC function returns the rank of a value in a data set as a percentage (0..1, inclusive) of the data set.
General Syntax: =PERCENTRANK.INC(array, x, significance)
Arguments: array is the array or range of data with numeric values that defines relative standing. x is the value for which you want to know the rank. significance is an optional value that identifies the number of significant digits for the returned percentage value. If omitted, PERCENTRANK.INC uses three digits (0.xxx).

PERMUT:
Description: Using the PERMUT function returns the number of permutations for a given number of objects that can be selected from number objects. A permutation is any set or subset of objects or events where internal order is significant. Permutations are different from combinations, for which the internal order is not significant. Use this function for lottery-style probability calculations.
General Syntax: =PERMUT(number, number_chosen)
Arguments: number is an integer that describes the number of objects. number_chosen is an integer that describes the number of objects in each permutation.

PERMUTATIONA:
Description: Using the PERMUTATIONA function returns the number of permutations for a given number of objects (with repetitions) that can be selected from the total objects.
General Syntax: =PERMUT(number, number_chosen)
Arguments: number is an integer that describes the total number of objects. number_chosen is an integer that describes the number of objects in each permutation.
Glossary of Functions

PHI:

Description: Using the PHI function returns the value of the density function for a standard normal distribution.

General Syntax: 

\[ =\text{PHI}(x) \]

Arguments: 

\(x\) is the number for which you want the density of the standard normal distribution.

POISSON.DIST:

Description: Using the POISSON.DIST function returns the Poisson distribution. A common application of the Poisson distribution is predicting the number of events over a specific time, such as the number of cars driving through an intersection in an hour.

General Syntax: 

\[ =\text{POISSON.DIST}(x, \text{mean}, \text{cumulative}) \]

Arguments: 

\(x\) is the number of events. 

\(\text{mean}\) is the expected numeric value.

\(\text{cumulative}\) is a logical value that determines the form of the probability distribution returned. If cumulative is TRUE, \(\text{POISSON.DIST}\) returns the cumulative Poisson probability that the number of random events occurring will be between zero and \(x\) inclusive; if FALSE, it returns the Poisson probability mass function that the number of events occurring will be exactly \(x\).

PROB:

Description: Using the PROB function returns the probability that values in a range are between two limits. If upper_limit is not supplied, returns the probability that values in \(x\_\text{range}\) are equal to lower_limit.

General Syntax: 

\[ =\text{PROB}(x\_\text{range},\text{prob\_range},\text{lower\_limit};\text{upper\_limit}) \]

Arguments: 

\(x\_\text{range}\) is the range of numeric values of \(x\) with which there are associated probabilities.

\(\text{prob\_range}\) is a set of probabilities associated with values in \(x\_\text{range}\).

\(\text{lower\_limit}\) is the lower bound on the value for which you want a probability.

\(\text{upper\_limit}\) is the optional upper bound on the value for which you want a probability.

QUARTILE.EXC:

Description: Using the QUARTILE.EXC function returns the quartile of the data set, based on percentile values from 0..1, exclusive.

General Syntax: 

\[ =\text{QUARTILE.EXC}(\text{array}, \text{quart}) \]

Arguments: 

\(\text{array}\) is the array or cell range of numeric values for which you want the quartile value.

\(\text{quart}\) indicates which value to return.

If \(\text{quart}\) equals: 

1: \(\text{QUARTILE.EXC}\) returns: 

First quartile (25th percentile)

2: Second quartile (50th percentile) 

3: Third quartile (75th percentile)
Glossary of Functions

**QUARTILE.INC:**

*Description:* Using the QUARTILE.INC function returns the quartile of a data set, based on percentile values from 0..1, inclusive.

*General Syntax:*  

\[ =\text{QUARTILE.INC(array, quart)} \]

*Arguments:*  

array is the array or cell range of numeric values for which you want the quartile value.  

quart indicates which value to return.  

<table>
<thead>
<tr>
<th>If quart equals:</th>
<th>QUARTILE returns:</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>Minimum value</td>
</tr>
<tr>
<td>1</td>
<td>First quartile (25th percentile)</td>
</tr>
<tr>
<td>2</td>
<td>Median value (50th percentile)</td>
</tr>
<tr>
<td>3</td>
<td>Third quartile (75th percentile)</td>
</tr>
<tr>
<td>4</td>
<td>Maximum value</td>
</tr>
</tbody>
</table>

**RANK.AVG:**

*Description:* Using the RANK.AVG function returns the rank of a number in a list of numbers: its size relative to other values in the list; if more than one value has the same rank, the average rank is returned.

*General Syntax:*  

\[ =\text{RANK.AVG(number, ref, order)} \]

*Arguments:*  

number is the number whose rank you want to find.  

ref is an array of, or a reference to, a list of numbers. Nonnumeric values in ref are ignored.  

order is a number specifying how to rank number. If order is 0 (zero) or omitted, Excel ranks number as if ref were a list sorted in descending order. If order is any nonzero value, Excel ranks number as if ref were a list sorted in ascending order.

**RANK.EQ:**

*Description:* Using the RANK.EQ function returns the rank of a number in a list of numbers. Its size is relative to other values in the list; if more than one value has the same rank, the top rank of that set of values is returned. If you were to sort the list, the rank of the number would be its position.

*General Syntax:*  

\[ =\text{RANK.EQ(number, ref, order)} \]

*Arguments:*  

number is the number whose rank you want to find.  

ref is an array of, or a reference to, a list of numbers. Nonnumeric values in ref are ignored.  

order is a number specifying how to rank number. If order is 0 (zero) or omitted, Excel ranks number as if ref were a list sorted in descending order. If order is any nonzero value, Excel ranks number as if ref were a list sorted in ascending order.

**RSQ:**

*Description:* Using the RSQ function returns the square of the Pearson product moment correlation coefficient through data points in known_y’s and known_x’s. The r-squared value can be interpreted as the proportion of the variance in y attributable to the variance in x.

*General Syntax:*  

\[ =\text{RSQ(known_y’s, known_x’s)} \]

*Arguments:*  

known_y’s is an array or range of data points.  

known_x’s is an array or range of data points.
Glossary of Functions

SKEW:
Description: Using the SKEW function returns the skewness of a distribution. Skewness characterizes the degree of asymmetry of a distribution around its mean. Positive skewness indicates a distribution with an asymmetric tail extending toward more positive values. Negative skewness indicates a distribution with an asymmetric tail extending toward more negative values.

General Syntax: \[=SKEW(numbers)\]
Arguments: \(numbers\) is a comma-separated list of 1 to 255 arguments for which you want to calculate skewness.

SKEW.P:
Description: Using the SKEW function returns the skewness of a distribution based on a population: a characterization of the degree of asymmetry of a distribution around its mean.

General Syntax: \[=SKEW.P(numbers)\]
Arguments: \(numbers\) is a comma-separated list of 1 to 255 arguments for which you want to calculate population skewness.

SLOPE:
Description: Using the SLOPE function returns the slope of the linear regression line through data points in \(known\_y's\) and \(known\_x's\). The slope is the vertical distance divided by the horizontal distance between any two points on the line, which is the rate of change along the regression line.

General Syntax: \[=SLOPE(known\_y's,known\_x's)\]
Arguments: \(known\_y's\) is an array or cell range of numeric dependent data points. \(known\_x's\) is the set of independent data points.

SMALL:
Description: Using the SMALL function returns the \(k\)-th smallest value in a data set. Use this function to return values with a particular relative standing in a data set.

General Syntax: \[=SMALL(array,k)\]
Arguments: \(array\) is the array or range of data for which you want to determine the \(k\)-th smallest value. \(k\) is the position (from the smallest) in the array or cell range of data to return.

STANDARDIZE:
Description: Using the STANDARDIZE function returns a normalized value from a distribution characterized by \(mean\) and \(standard\_dev\).

General Syntax: \[=STANDARDIZE(x,mean,standard\_dev)\]
Arguments: \(x\) is the value you want to normalize. \(mean\) is the arithmetic mean of the distribution. \(standard\_dev\) is the standard deviation of the distribution.
# Glossary of Functions

## STDEV.P:

**Description:**
Using the STDEV.P function calculates standard deviation based on the entire population given as arguments (ignores logical values and text).

**General Syntax:**
`=STDEV.P(numbers)`

**Arguments:**
- `numbers` is a comma-separated list of 1 to 255 number arguments corresponding to an entire population. You can also use a single array or an array reference, instead.

## STDEV.S:

**Description:**
Using the STDEV.S function estimates standard deviation based on a sample (ignores logical values and text in the sample).

**General Syntax:**
`=STDEV.S(numbers)`

**Arguments:**
- `numbers` is a comma-separated list of 1 to 255 number arguments corresponding to a sample of a population. You can also use a single array or an array reference, instead.

## STDEVA:

**Description:**
Using the STDEVA function estimates standard deviation based on a sample.

**General Syntax:**
`=STDEVA(values)`

**Arguments:**
- `values` is a comma-separated list of 1 to 255 number arguments corresponding to a sample of a population. You can also use a single array or an array reference, instead.

## STDEVPA:

**Description:**
Using the STDEVPA function calculates standard deviation based on the entire population given as arguments, including text and logical values. The standard deviation is a measure of how widely values are dispersed from the average value (the mean).

**General Syntax:**
`=STDEVPA(values)`

**Arguments:**
- `values` is a comma-separated list of 1 to 255 values corresponding to a population. You can also use a single array or an array reference, instead.

## STEYX:

**Description:**
Using the STEYX function returns the standard error of the predicted y-value for each x in the regression. The standard error is a measure of the amount of error in the prediction of y for an individual x.

**General Syntax:**
`=STEYX(known_y's, known_x's)`

**Arguments:**
- `known_y's` is an array or range of dependent data points.
- `known_x's` is an array or range of independent data points
Glossary of Functions

T.DIST:

Description: Using the T.DIST function returns the Student's left-tailed t-distribution. The t-distribution is used in the hypothesis testing of small sample data sets. Use this function in place of a table of critical values for the t-distribution.

General Syntax: =T.DIST(x, degrees_freedom, cumulative)

Arguments:
- x is the numeric value at which to evaluate the distribution.
- degrees_freedom is an integer indicating the number of degrees of freedom.
- cumulative is a logical value that determines the form of the function. If cumulative is TRUE, T.DIST returns the cumulative distribution function; if FALSE, it returns the probability density function.

T.DIST.2T:

Description: Using the T.DIST.2T function returns the two-tailed Student's t-distribution. The Student's t-distribution is used in the hypothesis testing of small sample data sets. Use this function in place of a table of critical values for the t-distribution.

General Syntax: =T.DIST.2T(x, degrees_freedom)

Arguments:
- x is the numeric value at which to evaluate the distribution.
- degrees_freedom is an integer indicating the number of degrees of freedom.

T.DIST.RT:

Description: Using the T.DIST.RT function returns the right-tailed Student's t-distribution. The t-distribution is used in the hypothesis testing of small sample data sets. Use this function in place of a table of critical values for the t-distribution.

General Syntax: =T.DIST.RT(x, degrees_freedom)

Arguments:
- x is the numeric value at which to evaluate the distribution.
- degrees_freedom is an integer indicating the number of degrees of freedom.

T.INV:

Description: Using the T.INV function returns the left-tailed inverse of the Student's t-distribution.

General Syntax: =T.INV(probability, degrees_freedom)

Arguments:
- probability is the probability associated with the Student's t-distribution.
- degrees_freedom is the number of degrees of freedom with which to characterize the distribution.

T.INV.2T:

Description: Using the T.INV.2T function returns the two-tailed inverse of the Student's t-distribution.

General Syntax: =T.INV.2T(probability, degrees_freedom)

Arguments:
- probability is the probability associated with the Student's t-distribution.
- degrees_freedom is the number of degrees of freedom with which to characterize the distribution.
Glossary of Functions

T.TEST:
Description: Using the T.TEST function returns the probability associated with a Student’s t-Test. Use T.TEST to determine whether two samples are likely to have come from the same two underlying populations that have the same mean.

General Syntax: =T.TEST(array1, array2, tails, type)
Arguments:
array1 is the first data set.
array2 is the second data set.
tails specifies the number of distribution tails. If tails = 1, TTEST uses the one-tailed distribution. If tails = 2, TTEST uses the two-tailed distribution.
type is the kind of t-Test to perform.

<table>
<thead>
<tr>
<th>Type equals</th>
<th>Test performed</th>
<th>Type equals</th>
<th>Test performed</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Paired</td>
<td>2</td>
<td>Two-sample equal variance</td>
</tr>
<tr>
<td>3</td>
<td>Two-sample unequal variance</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

TREND:
Description: Using the TREND function returns values along a linear trend. Fits a straight line (using the method of least squares) to the arrays known_y’s and known_x’s. Returns the y-values along that line for the array of new_x’s that you specify.

General Syntax: =TREND(known_y’s,known_x’s,new_x’s,const)
Arguments:
known_y’s is the set of y-values you already know in the relationship y = mx + b. If the array is in a single column, then each column of known_x’s is interpreted as a separate variable. If the array is in a single row, then each row of known_x’s is interpreted as a separate variable.
known_x’s is an optional set of x-values that you may already know in the relationship y = mx + b. The array can include one or more sets of variables. If only one variable is used, known_y’s and known_x’s can be ranges of any shape, as long as they have equal dimensions. If more than one variable is used, known_y’s must be a vector (that is, a range with a height of one row or a width of one column). If known_x’s is omitted, it is assumed to be the array (1,2,3,...) that is the same size as known_y’s.
new_x’s are new x-values for which you want to return corresponding y-values. It must include a column (or row) for each independent variable, just as known_x’s does. So, if known_y’s is in a single column, known_x’s and new_x’s must have the same number of columns. If known_y’s is in a single row, known_x’s and new_x’s must have the same number of rows. If you omit new_x’s, it is assumed to be the same as known_x’s. If you omit both, they are assumed to be the array (1,2,3,...) that is the same size as known_y’s.
const is a logical value specifying whether to force the constant b to equal 0. If const is TRUE or omitted, b is calculated normally. If const is FALSE, b is set equal to 0 (zero), and the m-values are adjusted so that y = mx.

TRIMMEAN:
Description: Using the TRIMMEAN function returns the mean of the interior of a data set. TRIMMEAN calculates the mean taken by excluding a percentage of data points from the top and bottom tails of a data set. You can use this function when you wish to exclude outlying data from your analysis.

General Syntax: =TRIMMEAN(array,percent)
Arguments:
array is the array or range of values to trim and average.
percent is the fractional number of data points to exclude from the calculation. For example, if percent = 0.2, 4 points are trimmed from a data set of 20 points (20 x 0.2): 2 from the top and 2 from the bottom of the set.
Glossary of Functions

VAR.P:
Description: Using the VAR.P function calculates variance based on the entire population. Ignores logical and text values.
General Syntax: =VAR.P(numbers)
Arguments: numbers is a comma-delimited list of 1 to 255 number arguments corresponding to a population.

VAR.S:
Description: Using the VAR.S function estimates variance based on a sample. Ignores logical and text values.
General Syntax: =VAR.S(numbers)
Arguments: numbers is a comma-delimited list of 1 to 255 number arguments corresponding to a sample of a population.

VARA:
Description: Using the VARA function estimates variance based on a sample. Includes logical and text values in the calculation.
General Syntax: =VARA(values)
Arguments: values is a comma-separated list of 1 to 255 values arguments corresponding to a sample of a population.

VARPA:
Description: Using the VARPA function calculates variance based on the entire population. Includes logical and text values in the calculation.
General Syntax: =VARPA(values)
Arguments: values is a comma-separated list of 1 to 255 values arguments corresponding to an entire population.

WEIBULL.DIST:
Description: Using the WEIBULL.DIST function returns the Weibull distribution. Use this distribution in reliability analysis, such as calculating a device's mean time to failure.
General Syntax: =WEIBULL.DIST(x, alpha, beta, cumulative)
Arguments: x is the value at which to evaluate the function.
alpha is a parameter to the distribution.
beta is a parameter to the distribution.
cumulative determines the form of the function.

Z.TEST:
Description: Using the Z.TEST function Returns the one-tailed P-value of a z-test. For a given hypothesized population mean, μ0, Z.TEST returns the probability that the sample mean would be greater than the average of observations in the data set (array)—that is, the observed sample mean.
General Syntax: =Z.TEST(array, x, sigma)
Arguments: array is the array or range of data against which to test x.
x is the value to test.
sigma is the population (known) standard deviation. If omitted, the sample standard deviation is used.
<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
<th>General Syntax</th>
<th>Arguments</th>
</tr>
</thead>
<tbody>
<tr>
<td>ASC</td>
<td>Using the ASC function changes full-width (double-byte) characters to half-width (single-byte) characters.</td>
<td>=ASC(text)</td>
<td>text is the text or a reference to a cell that contains the text you want to change. If text does not contain any full-width letters, text is not changed.</td>
</tr>
<tr>
<td>BAHTTEXT</td>
<td>Using the BAHTTEXT function converts a number to Thai text and adds a suffix of “Baht.” In Excel for Windows, you can change the Baht format to a different style by using “Regional Settings” or “Regional Options” in the Control Panel.</td>
<td>=BAHTTEXT(number)</td>
<td>number is a number you want to convert to text, or a reference to a cell containing a number, or a formula that evaluates to a number.</td>
</tr>
<tr>
<td>CHAR</td>
<td>Using the CHAR function returns the character specified by a number. Use it to translate code page numbers you might get from files on other types of computers into characters.</td>
<td>=CHAR(number)</td>
<td>number is a number between 1 and 255 specifying which character you want. The character is from the character set used by your computer. Excel Web App supports only CHAR(9), CHAR(10), CHAR(13), and CHAR(32) and above.</td>
</tr>
<tr>
<td>CLEAN</td>
<td>Using the CLEAN function removes all nonprintable characters from text. Use CLEAN on text imported from other applications that contain characters that may not print with your operating system.</td>
<td>=CLEAN(text)</td>
<td>text is any worksheet information from which you want to remove nonprintable characters.</td>
</tr>
<tr>
<td>CODE</td>
<td>Using the CODE function returns a numeric code for the first character in a text string. The returned code corresponds to the character set used by your computer.</td>
<td>=CODE(text)</td>
<td>text is the text for which you want the code of the first character.</td>
</tr>
<tr>
<td>CONCATENATE</td>
<td>Using the CONCATENATE function joins several text strings into one text string. The &quot;&amp;&quot; operator can also be used instead of CONCATENATE to join text items.</td>
<td>=CONCATENATE(text_values)</td>
<td>text_values are 1 to 255 text strings, numbers, or single-cell references to be joined into a single text item.</td>
</tr>
</tbody>
</table>
### DBCS:
**Description:**
Using the DBCS function converts half-width (single-byte) letters within a character string to full-width (double-byte) characters. The name of the function (and the characters that it converts) depends upon your language settings.

**General Syntax:**
=DBCS(text)

**Arguments:**
- `text` is the text or a reference to a cell that contains the text you want to change.

### DOLLAR:
**Description:**
Using the DOLLAR function converts a number to text using currency format, with the decimals rounded to the specified place. The format used is $#,##0.00;($#,###0.00).

**General Syntax:**
=DOLLAR(number, decimals)

**Arguments:**
- `number` is a number, a reference to a cell containing a number, or a formula that evaluates to a number.
- `decimals` is the decimal precision. If it is negative, the number is rounded to the left of the decimal. If omitted, it is 2.

### EXACT:
**Description:**
Using the EXACT function compares two text strings and returns TRUE if they are exactly the same, FALSE otherwise. EXACT is case-sensitive but ignores formatting differences.

**General Syntax:**
=EXACT(text1, text2)

**Arguments:**
- `text1` is the first text string.
- `text2` is the second text string.

### FIND:
**Description:**
Using the FIND function finds one text string within another text string, and returns the number of the starting position of the found text, from the first character of the text it is found within. FIND is case sensitive and doesn't allow wildcard characters.

**General Syntax:**
=FIND(find_text, within_text, start_num)

**Arguments:**
- `find_text` is the text you want to find.
- `within_text` is the text containing the text you want to find.
- `start_num` specifies the character at which to start the search. If omitted, it is 1.

### FIXED:
**Description:**
Using the FIXED function rounds a number to the specified number of decimals, formats the number in decimal format using a period and commas, and returns the result as text.

**General Syntax:**
=FIXED(number, decimals, no_commas)

**Arguments:**
- `number` is the number you want to round and convert to text.
- `decimals` is the number of digits to the right of the decimal point.
- `no_commas` is a logical value that, if TRUE, prevents FIXED from including commas in the returned text.
**Glossary of Functions**

**LEFT:**
*Description:* Using the LEFT function returns the first character or characters in a text string, based on the number of characters you specify.
*General Syntax:* =LEFT(text,num_chars)
*Arguments:*  
- **text** is the text string that contains the characters you want to extract.  
- **num_chars** specifies the number of characters you want LEFT to extract. It must be greater than or equal to zero. If it is greater than the length of text, LEFT returns all of text. If it is omitted, it is assumed to be 1.

**LEN:**
*Description:* Using the LEN function returns the number of characters in a text string.
*General Syntax:* =LEN(text)
*Arguments:*  
- **text** is the text whose length you want to find. Spaces count as characters.

**LOWER:**
*Description:* Using the LOWER function converts all uppercase letters in a text string to lowercase.
*General Syntax:* =LOWER(text)
*Arguments:*  
- **text** is the text you want to convert to lowercase. LOWER does not change characters in text that are not letters.

**MID:**
*Description:* Using the MID function returns a specific number of characters from a text string, starting at the position you specify, based on the number of characters you specify.
*General Syntax:* =MID(text,start_num,num_chars)
*Arguments:*  
- **text** is the text string containing the characters you want to extract.  
- **start_num** is the position of the first character you want to extract in text.  
- **num_chars** specifies the number of characters you want MID to return from text.

**NUMBERVALUE:**
*Description:* Using the NUMBERVALUE function converts text to a number, in a locale-independent way.
*General Syntax:* =NUMBERVALUE(text,decimal_separator,group_separator)
*Arguments:*  
- **text** is the text to convert to a number.  
- **decimal_separator** is the character used to separate the integer and fractional part of the result.  
- **group_separator** is the character used to separate groupings of numbers, such as thousands from hundreds and millions from thousands.

**PHONETIC:**
*Description:* Using the PHONETIC function extracts the phonetic (furigana) characters from a text string.
*General Syntax:* =PHONETIC(text)
*Arguments:*  
- **text** is a text string or a reference to a single cell or a range of cells that contain a furigana text string.
# Glossary of Functions

## PROPER:

**Description:** Using the PROPER function capitalizes the first letter in a text string and any other letters in text that follow any character other than a letter. Converts all other letters to lowercase letters.

**General Syntax:**

```
=PROPER(text)
```

**Arguments:**

- `text` is text enclosed in quotation marks, a formula that returns text, or a reference to a cell containing the text you want to partially capitalize.

## REPLACE:

**Description:** Using the REPLACE function replaces part of a text string, based on the number of characters you specify, with a different text string.

**General Syntax:**

```
=REPLACE(old_text,start_num,num_chars,new_text)
```

**Arguments:**

- `old_text` is text in which you want to replace some characters.
- `start_num` is the position of the character in `old_text` that you want to replace with `new_text`.
- `num_chars` is the number of characters in `old_text` that you want to replace with `new_text`.
- `new_text` is the text that will replace characters in `old_text`.

## REPT:

**Description:** Using the REPT function repeats text a given number of times. Use REPT to fill a cell with a number of instances of a text string.

**General Syntax:**

```
=REPT(text,number_times)
```

**Arguments:**

- `text` is the text you want to repeat.
- `number_times` is a positive number specifying the number of times to repeat text.

## RIGHT:

**Description:** Using the RIGHT function returns the last character or characters in a text string, based on the number of characters you specify.

**General Syntax:**

```
=RIGHT(text,num_chars)
```

**Arguments:**

- `text` is the text string containing the characters you want to extract.
- `num_chars` specifies the number of characters you want RIGHT to extract.

## SEARCH:

**Description:** Using the SEARCH function returns the number of the character at which a specific character or text string is first found, beginning with `start_num`. Use SEARCH to determine the location of a character or text string within another text string so that you can use the MID or REPLACE functions to change the text.

**General Syntax:**

```
=SEARCH(find_text,within_text,start_num)
```

**Arguments:**

- `find_text` is the text you want to find. You can use the wildcard characters of question mark (?) and asterisk (*), in `find_text`. A question mark matches any single character; an asterisk matches any sequence of characters. If you want to find an actual question mark or asterisk, type a tilde (~) before the character.
- `within_text` is the text in which you want to search for `find_text`.
- `start_num` is the character number in `within_text` at which you want to start searching.
**SUBSTITUTE:**

*Description:* Using the SUBSTITUTE function substitutes *new_text* for *old_text* in a text string. Use SUBSTITUTE when you want to replace specific text in a text string; use REPLACE when you want to replace any text that occurs in a specific location in a text string.

*General Syntax:* 

`=SUBSTITUTE(text,old_text,new_text,instance_num)`

*Arguments:*

- *text* is the text or the reference to a cell containing text for which you want to substitute characters.
- *old_text* is the text you want to replace.
- *new_text* is the text you want to replace *old_text* with.
- *instance_num* specifies which occurrence of *old_text* you want to replace with *new_text*. If you specify *instance_num*, only that instance of *old_text* is replaced. Otherwise, every occurrence of *old_text* is changed to *new_text*.

**T:**

*Description:* Using the T function returns the text referred to by value. You do not generally need to use the T function in a formula because Microsoft Excel automatically converts values as necessary. This function is provided for compatibility with other spreadsheet programs.

*General Syntax:* 

`=T(value)`

*Arguments:*

- *value* is the value you want to test.

**TEXT:**

*Description:* Using the TEXT function converts a value to text in a specific number format.

*General Syntax:* 

`=TEXT(value,format_text)`

*Arguments:*

- *value* is a numeric value, a formula that evaluates to a numeric value, or a cell reference containing a numeric value.
- *format_text* is a number format from the “Category” box on the “Number” tab in the “Format Cells” dialog box.

**TRIM:**

*Description:* Using the TRIM function removes all spaces from text except for single spaces between words. Use TRIM on text that you have received from another application that may have irregular spacing.

*General Syntax:* 

`=TRIM(text)`

*Arguments:*

- *text* is the text from which you want spaces removed.

**UNICHAR:**

*Description:* Using the UNICHAR function returns the Unicode character that is referenced by the given numeric value.

*General Syntax:* 

`=UNICHAR(number)`

*Arguments:*

- *number* is the Unicode number that represents the character.

**UNICODE:**

*Description:* Using the UNICODE function returns the number (code point) corresponding to the first character of the text.

*General Syntax:* 

`=UNICODE(text)`

*Arguments:*

- *text* is the character for which you want the Unicode value.
### UPPE:
**Description:** Using the UPPE function converts text to uppercase.
**General Syntax:**  
\[=UPPE(text)\]
**Arguments:**  
* text is the text reference or text string you want converted to uppercase.

### VALUE:
**Description:** Using the VALUE function converts a text string that represents a number to a number.
**General Syntax:**  
\[=VALUE(text)\]
**Arguments:**  
* text is the text enclosed in quotation marks or a reference to a cell containing the text you want to convert.

### ENCODEURL:
**Description:** Using the ENCODEURL function returns a URL-encoded string.
**General Syntax:**  
\[=ENCODEURL(text)\]
**Arguments:**  
* text is a string to be URL encoded.

### FILTERXML:
**Description:** Using the FILTERXML function returns specific data from the XML content by using the specified XPath.
**General Syntax:**  
\[=FILTERXML(xml, xpath)\]
**Arguments:**  
* xml is a string in valid XML format.
* xpath is a string in standard XPath format.

### WEBSERVICE:
**Description:** Using the WEBSERVICE function returns data from a web service on the Internet or Intranet.
**General Syntax:**  
\[=WEBSERVICE(url)\]
**Arguments:**  
* url is the URL of the web service.
EUROCONVERT:

Description:
Using the EUROCONVERT function converts a number to euros, converts a number from euros to a euro member currency, or converts a number from one euro member currency to another by using the euro as an intermediary currency. The currencies available for conversion are those of European Union (EU) members that have adopted the euro. The function uses fixed conversion rates that are established by the EU. If this function is not available, and returns the #NAME? error, install and load the Euro Currency Tools Add-in.

General Syntax:
=EUROCONVERT(number, source, target, full_precision, triangulation_precision)

Arguments:
number is a value or cell reference containing the amount of currency that you want to convert.
source is a three-letter text string (enclosed in double-quotes), corresponding to the ISO code for the source currency. The following are accepted codes:

<table>
<thead>
<tr>
<th>Country/Region</th>
<th>Currency</th>
<th>ISO Code</th>
</tr>
</thead>
<tbody>
<tr>
<td>Belgium</td>
<td>franc</td>
<td>BEF</td>
</tr>
<tr>
<td>Luxembourg</td>
<td>franc</td>
<td>LUF</td>
</tr>
<tr>
<td>Germany</td>
<td>deutsche mark</td>
<td>DEM</td>
</tr>
<tr>
<td>Spain</td>
<td>peseta</td>
<td>ESP</td>
</tr>
<tr>
<td>France</td>
<td>franc</td>
<td>FRF</td>
</tr>
<tr>
<td>Ireland</td>
<td>pound</td>
<td>IEP</td>
</tr>
<tr>
<td>Italy</td>
<td>lira</td>
<td>ITL</td>
</tr>
<tr>
<td>Netherlands</td>
<td>guilder</td>
<td>NLG</td>
</tr>
<tr>
<td>Austria</td>
<td>schilling</td>
<td>ATS</td>
</tr>
<tr>
<td>Portugal</td>
<td>escudo</td>
<td>PTE</td>
</tr>
<tr>
<td>Finland</td>
<td>markka</td>
<td>FIM</td>
</tr>
<tr>
<td>Greece</td>
<td>drachma</td>
<td>GRD</td>
</tr>
<tr>
<td>Slovenia</td>
<td>tolar</td>
<td>SIT</td>
</tr>
<tr>
<td>Euro member states</td>
<td>euro</td>
<td>EUR</td>
</tr>
</tbody>
</table>

target is the required three-letter text string (enclosed in double-quotes), corresponding to the ISO code for the currency to which you want to convert the number.

full_precision is a required logical value (TRUE or FALSE), that specifies how to display the result. If FALSE, or omitted, uses the calculation precision value to calculate the result and the display precision value to display the result. If TRUE, shows all significant digits resulting from the calculation.

<table>
<thead>
<tr>
<th>ISO Code</th>
<th>Calculation Precision</th>
<th>Display Precision</th>
</tr>
</thead>
<tbody>
<tr>
<td>BEF</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>LUF</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>DEM</td>
<td>2</td>
<td>2</td>
</tr>
<tr>
<td>ESP</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>FRF</td>
<td>2</td>
<td>2</td>
</tr>
<tr>
<td>IEP</td>
<td>2</td>
<td>2</td>
</tr>
<tr>
<td>ITL</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>NLG</td>
<td>2</td>
<td>2</td>
</tr>
<tr>
<td>ATS</td>
<td>2</td>
<td>2</td>
</tr>
<tr>
<td>PTE</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>FIM</td>
<td>2</td>
<td>2</td>
</tr>
<tr>
<td>GRD</td>
<td>0</td>
<td>2</td>
</tr>
<tr>
<td>SIT</td>
<td>2</td>
<td>2</td>
</tr>
<tr>
<td>EUR</td>
<td>2</td>
<td>2</td>
</tr>
</tbody>
</table>

triangulation_precision is a required integer that is greater than or equal to 3, which specifies the number of significant digits to use for the intermediate euro value created when converting between two euro member currencies. If omitted, Excel doesn’t round the intermediate euro value.
# Excel Keyboard Shortcuts

## Category: Using Windows

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch to the next window</td>
<td>Alt + Tab</td>
</tr>
<tr>
<td>Switch to previous window</td>
<td>Alt + Shift + Tab</td>
</tr>
<tr>
<td>Close window</td>
<td>Ctrl + W or Ctrl + F4</td>
</tr>
<tr>
<td>Restore window after maximizing it</td>
<td>Alt + F5</td>
</tr>
<tr>
<td>Move clockwise to task pane</td>
<td>F6</td>
</tr>
<tr>
<td>Move counterclockwise to next task pane</td>
<td>Shift + F6</td>
</tr>
<tr>
<td>Switching windows when multiple windows are open</td>
<td>Ctrl + F6</td>
</tr>
<tr>
<td>Switch to previous window</td>
<td>Ctrl + Shift + F6</td>
</tr>
<tr>
<td>Maximize/Restore window</td>
<td>Ctrl + F10</td>
</tr>
<tr>
<td>Copy screen to clipboard</td>
<td>Print Screen</td>
</tr>
<tr>
<td>Copy window to clipboard</td>
<td>Alt + Print Screen</td>
</tr>
</tbody>
</table>

## Category: Using Dialog Boxes

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Switch between screen and dialog box (if possible)</td>
<td>Alt + F6</td>
</tr>
<tr>
<td>Move to next option</td>
<td>Tab</td>
</tr>
<tr>
<td>Move to previous option</td>
<td>Alt + Tab</td>
</tr>
<tr>
<td>Move to next tab</td>
<td>Ctrl + Tab</td>
</tr>
<tr>
<td>Move to previous tab</td>
<td>Ctrl + Shift + Tab</td>
</tr>
<tr>
<td>Move between options in a drop-down menu or option group</td>
<td>Arrow keys</td>
</tr>
<tr>
<td>Perform button action or select/clear a checkbox</td>
<td>Spacebar</td>
</tr>
<tr>
<td>Select an option or select/clear a checkbox in option</td>
<td>Alt + underlined letter in option</td>
</tr>
<tr>
<td>Open a drop-down menu</td>
<td>Alt + Down Arrow</td>
</tr>
<tr>
<td>Select drop-down option</td>
<td>First letter of option</td>
</tr>
<tr>
<td>Close list/ Cancel</td>
<td>Esc</td>
</tr>
<tr>
<td>Run command</td>
<td>Enter</td>
</tr>
</tbody>
</table>

## Category: Text

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move to start of text</td>
<td>Home</td>
</tr>
<tr>
<td>Move to end of text</td>
<td>End</td>
</tr>
<tr>
<td>Move left one character</td>
<td>Left Arrow</td>
</tr>
<tr>
<td>Move right one character</td>
<td>Right Arrow</td>
</tr>
<tr>
<td>Move one word to left</td>
<td>Ctrl + Left Arrow</td>
</tr>
<tr>
<td>Move right one word</td>
<td>Ctrl + Right Arrow</td>
</tr>
<tr>
<td>Select/Deselect to left</td>
<td>Shift + Left Arrow</td>
</tr>
<tr>
<td>Select/Deselect to right</td>
<td>Shift + Right Arrow</td>
</tr>
<tr>
<td>Select/Deselect word left</td>
<td>Ctrl + Shift + Left Arrow</td>
</tr>
<tr>
<td>Select/Deselect word right</td>
<td>Ctrl + Shift + Right Arrow</td>
</tr>
<tr>
<td>Select to beginning</td>
<td>Shift + Home</td>
</tr>
<tr>
<td>Select to end</td>
<td>Shift + End</td>
</tr>
</tbody>
</table>

## Category: Using the “Open” and “Save As” Dialog Boxes

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show “Open” dialog box</td>
<td>Ctrl + O or Ctrl + F12</td>
</tr>
<tr>
<td>Show “Save As” dialog box</td>
<td>F12</td>
</tr>
<tr>
<td>Move to previous folder</td>
<td>Alt + 1</td>
</tr>
<tr>
<td>Move up one level</td>
<td>Alt + 2</td>
</tr>
<tr>
<td>Delete selected folder/file</td>
<td>Del or Delete</td>
</tr>
<tr>
<td>Create new folder</td>
<td>Alt + 4</td>
</tr>
<tr>
<td>Switch folder view</td>
<td>Alt + 5</td>
</tr>
<tr>
<td>Show shortcut menu</td>
<td>Shift + F10</td>
</tr>
<tr>
<td>Move between options</td>
<td>Tab</td>
</tr>
<tr>
<td>Open the “Look in” list</td>
<td>F4 or Alt + 1</td>
</tr>
</tbody>
</table>

## Category: Undoing and Redoing Actions

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cancel action</td>
<td>Esc</td>
</tr>
<tr>
<td>Undo Action</td>
<td>Ctrl + Z</td>
</tr>
<tr>
<td>Redo/Repeat Action</td>
<td>Ctrl + Y</td>
</tr>
</tbody>
</table>
## Excel Keyboard Shortcuts

### Category: Moving and Scrolling in Worksheets/Workbooks

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move one cell up, down, left or right</td>
<td>Arrow Keys</td>
</tr>
<tr>
<td>Move to the edge of the current data region</td>
<td>CTRL + arrow key</td>
</tr>
<tr>
<td>Move to the beginning of the row</td>
<td>HOME</td>
</tr>
<tr>
<td>Move to the beginning of the worksheet</td>
<td>CTRL + HOME</td>
</tr>
<tr>
<td>Move to the last cell on the worksheet</td>
<td>CTRL + END</td>
</tr>
<tr>
<td>Move down one screen</td>
<td>PAGE DOWN</td>
</tr>
<tr>
<td>Move up one screen</td>
<td>PAGE UP</td>
</tr>
<tr>
<td>Move one screen to the right</td>
<td>ALT + PAGE DOWN</td>
</tr>
<tr>
<td>Move one screen to the left</td>
<td>ALT + PAGE UP</td>
</tr>
<tr>
<td>Move to the next sheet in the workbook</td>
<td>CTRL + PAGE DOWN</td>
</tr>
<tr>
<td>Move to the previous sheet in the workbook</td>
<td>CTRL + PAGE UP</td>
</tr>
</tbody>
</table>

### Category: Entering Data

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Complete a cell entry and move down in the selection</td>
<td>ENTER</td>
</tr>
<tr>
<td>Start a new line in the same cell</td>
<td>ALT + ENTER</td>
</tr>
<tr>
<td>Fill the selected cell range with the current entry</td>
<td>CTRL + ENTER</td>
</tr>
<tr>
<td>Complete a cell entry and move up in the selection</td>
<td>SHIFT + ENTER</td>
</tr>
<tr>
<td>Complete a cell entry and move to the right in the selection</td>
<td>TAB</td>
</tr>
<tr>
<td>Complete a cell entry and move to the left in the selection</td>
<td>SHIFT + TAB</td>
</tr>
<tr>
<td>Cancel a cell entry</td>
<td>ESC</td>
</tr>
<tr>
<td>Delete the character to the left of the insertion point, or delete the selection</td>
<td>DELETE</td>
</tr>
<tr>
<td>Delete text to the end of the line</td>
<td>CTRL + DELETE</td>
</tr>
<tr>
<td>Move one character up, down, left or right</td>
<td>Arrow Keys</td>
</tr>
<tr>
<td>Move to the beginning of the line</td>
<td>HOME</td>
</tr>
<tr>
<td>Repeat the last action</td>
<td>F4 or CTRL + Y</td>
</tr>
</tbody>
</table>

### Category: Selecting Cells, Columns, or Rows

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Extend the selection by one cell</td>
<td>SHIFT + arrow key</td>
</tr>
<tr>
<td>Extend the selection to the last nonblank cell in the same column or row as the active cell</td>
<td>CTRL + SHIFT + arrow key</td>
</tr>
<tr>
<td>Extend the selection to the beginning of the row</td>
<td>SHIFT + HOME</td>
</tr>
<tr>
<td>Extend the selection to the beginning of the worksheet</td>
<td>CTRL + SHIFT + HOME</td>
</tr>
<tr>
<td>Extend the selection to the last used cell on the worksheet (lower-right corner)</td>
<td>CTRL + SHIFT + END</td>
</tr>
<tr>
<td>Select the entire column</td>
<td>CTRL + SPACEBAR</td>
</tr>
<tr>
<td>Select the entire row</td>
<td>SHIFT + SPACEBAR</td>
</tr>
<tr>
<td>Select the entire worksheet</td>
<td>CTRL + A</td>
</tr>
<tr>
<td>Select only the active cell when multiple cells are selected</td>
<td>SHIFT + BACKSPACE</td>
</tr>
<tr>
<td>Extend the selection down one screen</td>
<td>SHIFT + PAGE DOWN</td>
</tr>
<tr>
<td>Extend the selection up one screen</td>
<td>SHIFT + PAGE UP</td>
</tr>
<tr>
<td>Select whole data area around active cell</td>
<td>CTRL + SHIFT + *</td>
</tr>
</tbody>
</table>

### Category: Other Functions

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display the “Print” dialog box</td>
<td>CTRL + P</td>
</tr>
<tr>
<td>Insert a new worksheet</td>
<td>SHIFT + F11</td>
</tr>
</tbody>
</table>

### Category: Inserting, deleting and copying a selection

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy the selection</td>
<td>CTRL + C</td>
</tr>
<tr>
<td>Cut the selection</td>
<td>CTRL + X</td>
</tr>
<tr>
<td>Paste the selection</td>
<td>CTRL + V</td>
</tr>
<tr>
<td>Clear the contents of the selection</td>
<td>DELETE</td>
</tr>
<tr>
<td>Delete the selection</td>
<td>CTRL + HYPHEN</td>
</tr>
<tr>
<td>Copy the selection</td>
<td>CTRL + C</td>
</tr>
</tbody>
</table>
### Excel Keyboard Shortcuts

#### Category: Outlining Data

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Group rows or columns</td>
<td>ALT + SHIFT + RIGHT ARROW</td>
</tr>
<tr>
<td>Ungroup rows or columns</td>
<td>ALT + SHIFT + LEFT ARROW</td>
</tr>
<tr>
<td>Display or hide outline symbols</td>
<td>CTRL + 8</td>
</tr>
<tr>
<td>Hide selected rows</td>
<td>CTRL + 9</td>
</tr>
<tr>
<td>Unhide selected rows</td>
<td>CTRL + SHIFT + (</td>
</tr>
<tr>
<td>(opening parenthesis)</td>
<td></td>
</tr>
<tr>
<td>Hide selected columns</td>
<td>CTRL + 0 (zero)</td>
</tr>
<tr>
<td>Unhide selected columns</td>
<td>CTRL + SHIFT + )</td>
</tr>
<tr>
<td>(closing parenthesis)</td>
<td></td>
</tr>
</tbody>
</table>

#### Category: Working in Cells or the Formula Bar

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit the active cell and then clear it, or delete the preceding character in the active cell as you edit cell contents</td>
<td>BACKSPACE</td>
</tr>
<tr>
<td>Complete a cell entry</td>
<td>ENTER</td>
</tr>
<tr>
<td>Enter a formula as an array formula</td>
<td>CTRL + SHIFT + ENTER</td>
</tr>
<tr>
<td>Cancel an entry in the cell or formula bar</td>
<td>ESC</td>
</tr>
<tr>
<td>Display the Formula Palette after you type a function name in a formula</td>
<td>CTRL + A</td>
</tr>
<tr>
<td>Insert the argument names and parentheses for a function after you type a function name in a formula</td>
<td>CTRL + SHIFT + A</td>
</tr>
<tr>
<td>Insert a hyperlink</td>
<td>CTRL + K</td>
</tr>
<tr>
<td>Activate a hyperlink</td>
<td>ENTER (in a cell with a hyperlink)</td>
</tr>
<tr>
<td>Edit the active cell and position the insertion point at the end of the line</td>
<td>F2</td>
</tr>
<tr>
<td>Paste a defined name into a formula</td>
<td>F3</td>
</tr>
<tr>
<td>Paste a function into a formula</td>
<td>SHIFT + F3</td>
</tr>
<tr>
<td>Calculate all sheets in all open workbooks</td>
<td>F9</td>
</tr>
<tr>
<td>Calculate all sheets in the active workbook</td>
<td>CTRL + ALT + F9</td>
</tr>
</tbody>
</table>

#### Category: Working in Cells or the Formula Bar (cont.)

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Calculate the active worksheet</td>
<td>SHIFT + F9</td>
</tr>
<tr>
<td>Start a formula</td>
<td># (equal sign)</td>
</tr>
<tr>
<td>Insert the AutoSum formula</td>
<td>ALT + = (equal sign)</td>
</tr>
<tr>
<td>Enter the date</td>
<td>CTRL + ; (semicolon)</td>
</tr>
<tr>
<td>Enter the time</td>
<td>CTRL + SHIFT + :</td>
</tr>
<tr>
<td>Copy the value from the cell above the active cell into the cell or the formula bar</td>
<td>CTRL + SHIFT + &quot; ( quotation mark)</td>
</tr>
<tr>
<td>Alternate between displaying cell values and displaying cell formulas</td>
<td>CTRL + ' (single left quotation mark)</td>
</tr>
<tr>
<td>Copy a formula from the cell above the active cell into the cell or the formula bar</td>
<td>CTRL + ' (apostrophe)</td>
</tr>
<tr>
<td>Display the AutoComplete list</td>
<td>ALT + DOWN ARROW</td>
</tr>
</tbody>
</table>

#### Category: Formatting Data

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display the “Insert” cells dialog box</td>
<td>CTRL + SHIFT + + (plus sign)</td>
</tr>
<tr>
<td>Display the “Delete” cells dialog box</td>
<td>CTRL + SHIFT + - (minus sign)</td>
</tr>
<tr>
<td>Display the Style dialog box</td>
<td>Alt + ' (apostrophe)</td>
</tr>
<tr>
<td>Display the Format Cells dialog box</td>
<td>CTRL + 1</td>
</tr>
<tr>
<td>Apply the General number format</td>
<td>CTRL + SHIFT + ~</td>
</tr>
<tr>
<td>Apply the Currency format with two decimal places (negative numbers appear in parentheses)</td>
<td>CTRL + SHIFT + $</td>
</tr>
<tr>
<td>Apply the Percentage format with no decimal places</td>
<td>CTRL + SHIFT + %</td>
</tr>
<tr>
<td>Apply the Exponential number format with two decimal places</td>
<td>CTRL + SHIFT + ^</td>
</tr>
<tr>
<td>Apply the Date format with the day, month and year</td>
<td>CTRL + SHIFT + #</td>
</tr>
</tbody>
</table>
## Excel Keyboard Shortcuts

### Category: Formatting Data (cont.)

<table>
<thead>
<tr>
<th>Command</th>
<th>Key</th>
</tr>
</thead>
<tbody>
<tr>
<td>Apply the Time format with the hour and minute, and indicate A.M. or P.M.</td>
<td>CTRL + SHIFT + @</td>
</tr>
<tr>
<td>Apply the Number format with two decimal places, thousands separator, and minus sign (-) for negative values</td>
<td>CTRL + SHIFT + !</td>
</tr>
<tr>
<td>Apply the outline border</td>
<td>CTRL + SHIFT + &amp;</td>
</tr>
<tr>
<td>Remove outline border</td>
<td>CTRL + SHIFT + _</td>
</tr>
<tr>
<td>Apply or remove bold formatting</td>
<td>CTRL + B or CTRL + 2</td>
</tr>
<tr>
<td>Apply or remove italic formatting</td>
<td>CTRL + I or CTRL + 3</td>
</tr>
<tr>
<td>Apply or remove an underline</td>
<td>CTRL + U or CTRL + 4</td>
</tr>
<tr>
<td>Apply or remove strikethrough formatting</td>
<td>CTRL + 5 or CTRL + 5</td>
</tr>
<tr>
<td>Hide rows</td>
<td>CTRL + 9</td>
</tr>
<tr>
<td>Unhide rows</td>
<td>CTRL + SHIFT + (</td>
</tr>
<tr>
<td>(opening parenthesis)</td>
<td></td>
</tr>
<tr>
<td>Toggle between hiding, showing, and showing placeholder for objects</td>
<td>CTRL + 6</td>
</tr>
<tr>
<td>Hide columns</td>
<td>CTRL + 0 (zero)</td>
</tr>
<tr>
<td>Unhide columns</td>
<td>CTRL + SHIFT + )</td>
</tr>
<tr>
<td>(closing parenthesis)</td>
<td></td>
</tr>
</tbody>
</table>